精华内容
下载资源
问答
  • h3c交换机划分vlan

    千次阅读 2018-10-13 16:37:19
    [H3C]vlan 10 [H3C-vlan10]port e1/0/1 to e1/0/8 [H3C-vlan10]q 创建vlan 20,加入9~16 [H3C]vlan 20 [H3C-vlan20]port e1/0/9 to e1/0/16 [H3C-vlan20]q 创建vlan 30,加入17~...
    <H3C>sys
    vlan 10:创建vlan并进入,加入1~8
    [H3C]vlan 10  
    [H3C-vlan10]port e1/0/1 to e1/0/8
    [H3C-vlan10]q
     
    创建vlan 20,加入9~16
    [H3C]vlan 20
    [H3C-vlan20]port e1/0/9 to e1/0/16
    [H3C-vlan20]q
     
    创建vlan 30,加入17~24
    [H3C]vlan 30
    [H3C-vlan30]port e1/0/17 to e1/0/24
    [H3C-vlan30]q
    

    一个交换机当3个用


    业务联系QQ:95565541
    展开全文
  • 在局域网中VLAN是最常见的,通常使用VLAN来划分不同网段,不同的功能区3台电脑代表3个不同网段的VLAN,接在同一台交换机VLAN10:192.168.10.1/24 GW:192.168.10.254VLAN20:192.168.20.1/24 GW:192.168...H3C>sys ...

    在局域网中VLAN是最常见的,通常使用VLAN来划分不同网段,不同的功能区

    ae1f5d1c3d4645ad90864f9c57395a69.png

    3台电脑代表3个不同网段的VLAN,接在同一台交换机上

    VLAN10:192.168.10.1/24 GW:192.168.10.254

    VLAN20:192.168.20.1/24 GW:192.168.20.254

    VLAN30:192.168.30.1/24 GW:192.168.30.254

    <H3C>sys  
    System View: return to User View with Ctrl+Z.
    [H3C]sysn
    [H3C]sysname HC_SW_1                         #设备命名
    [HC_SW_1]vlan 10                             #创建vlan10
    [HC_SW_1-vlan10]name VLAN10                  #vlan命名
    [HC_SW_1-vlan10]vlan 20                      #创建vlan 20
    [HC_SW_1-vlan20]name VLAN20                  #vlan命名 
    [HC_SW_1-vlan20]vlan 30                      #创建vlan30
    [HC_SW_1-vlan30]name VLAN30                  #vlan命名
    [HC_SW_1-vlan30]

    9cc8fa5bdcfadb5fcd9b52b54107262a.png

    查看所有的vlan ,现在VLAN已经创建,但默认交换机的所有端口都在VLAN1,VLAN1是默认vlan,我们需要将对应的端口放在对应的vlan里。

    可以查看哪些端口已经起来了

    5b7d9a67fa6de7b87b43adcddd092524.png

    现在所有端口都是DOWN状态,因为我们还没有将电脑的端口开启。

    8e9402a43204e552788f848e81829853.png

    6ce640089ee0a05af74d83fd421aab81.png

    我们现在没有使用DHCP,需要手动设置地址,我们之前已经划分好VLAN了,现在配置上去

    VLAN10:

    e6a6653629b6800121ff08661857dfc8.png

    VLAN20:

    5d4d6955784664ba7d0ce65cbbc58b03.png

    VLAN30:

    77fdb5bbfbe571169ae494b3f13ac709.png

    现在再看下交换机上面端口是否开启了

    3f6d06e83ec93731f04411cc33686017.png

    端口已经开启

    交换机有两种常见类型 : access trunk口,access一般是接终端, trun口需要封装,一般连接设备如交换机。

    现在我们将对应接口设置为access并划分到对应vlan

    [HC_SW_1]interface GigabitEthernet 1/0/1           #进入1口
    [HC_SW_1-GigabitEthernet1/0/1]port access vlan 10  #端口默认就是access类型,这里直接设置划分到vlan10
    [HC_SW_1]interface GigabitEthernet 1/0/2           #下面同理
    [HC_SW_1-GigabitEthernet1/0/2]port access vlan 20
    [HC_SW_1-GigabitEthernet1/0/2]int g1/0/3
    [HC_SW_1-GigabitEthernet1/0/3]port access vlan 30
    [HC_SW_1-GigabitEthernet1/0/3]
    
    

    现在再查看vlan,已经看到对应vlan已经有对应的端口了

    c88b180f3a23e0433a326e9ca658a735.png

    现在查看ip地址是没有的,因为都没有进入vlan配置过

    24f947f58fcaf494edd6313ae2a8aed8.png

    现在配置ip地址

    [HC_SW_1]interface Vlan-interface 10                             #使用interface来进入接口配置模式
    [HC_SW_1-Vlan-interface10]ip address 192.168.10.254 24           #ip address 配置ip地址 后面 24 是掩码 也可以写255.255.255.0 后面再详细介绍
    [HC_SW_1-Vlan-interface10]int vlan 20                            #同理
    [HC_SW_1-Vlan-interface20]ip address 192.168.20.254 24
    [HC_SW_1-Vlan-interface20]int vlan 30
    [HC_SW_1-Vlan-interface30]ip address 192.168.30.254 24
    [HC_SW_1-Vlan-interface30]
    

    现在可以查看vlan的地址配置了

    8fdb26cc731bc31d678e8b11779d646a.png

    现在端口,地址,网管关都对应上了

    cb1d7f850313444a85cbf1a3ecb29066.png

    在交换机上测试是否连通,使用ping命令加ip地址,已经可以ping通,证明没有问题

    d6a17b84cd1690f818f206306065667d.png

    因为H3C模拟器的交换机是3层交换机,所有只要vlan配置对,不同vlan就可以直接访问,来我们在电脑测试一下

    8b13b8cbdc0e0ccea6c1ec563c99d1d0.png

    在VLAN10访问其他2个VLAN

    先测试了能否ping通网关,然后ping其他vlan电脑,很多时候如果网关都ping不通,就是为了有问题了,所有可以先看下能不能到网关,现在测试都是正常的

    c2d73f203f6027eefc8cdfa65d9f8b59.png

    在vlan20访问也是正常的

    a031849274f88eb4f44ff52f26c83d13.png

    这样vlan就是正常可以通信了

    现在来保存一下吧,我一般都是save f 强制保存的。

    8598fa1a1a51539690a75e058664210c.png

    OK了,最近觉得搞IT的,一段时间不敲命令很容易就忘了,更加需要记一下了。

    展开全文
  • 如果直接使用“undo vlan”是删不干净的,因为配置VLAN时还配置过接口,下面就由小编介绍H3C交换机是如何删除VLAN的吧
  • H3C交换机配置vlan

    万次阅读 2017-05-27 08:42:02
    创建VLAN system-view System View: return to User View ...[H3C_TEST]vlan 99 [H3C_TEST-vlan99]name asd [H3C_TEST-vlan99]quit  把交换机的端端口划分到相应的Vlan中 [H3C_TEST]interface ethernet1/0/2 
    创建VLAN
    
    <H3C_TEST>system-view
    System View: return to User View with Ctrl+Z.
    [H3C_TEST]vlan 99
    [H3C_TEST-vlan99]name asd
    [H3C_TEST-vlan99]quit

     把交换机的端端口划分到相应的Vlan中
    [H3C_TEST]interface ethernet1/0/2       //进入端口模式
    [H3C_TEST-Ethernet1/0/2]port link-type access //设置端口的类型为access
    [H3C_TEST-Ethernet1/0/2]port access vlan 99  //把当前端口划到vlan 99

    [H3C_TEST]vlan 99
    [H3C_TEST-vlan99]port ethernet1/0/1 to ethernet1/0/24  //把以及网端口1/0/1到1/0/24划到vlan99
    [H3C_TEST-vlan99]quit
    [H3C_TEST]interface ethernet1/2/1

    [H3C_TEST-GigabitEthernet1/2/1]port trunk permit vlan  99 100 101    //{ID|All} 设置trunk端口允许通过的VLAN

    [H3C_TEST-GigabitEthernet1/2/1]port trunk permit vlan all(*) //也可以设置trunk端口允许通过的所有VLAN





    展开全文
  • H3C交换机MAC VLAN原理及配置示例

    千次阅读 2012-12-03 08:48:36
    现从笔者编著,目前在全国热销的《Cisco/H3C交换机配置与管理完全手册》(第二版)(与之配套的姊妹篇为《Cisco/H3C交换机高级配置与管理技术手册》)一书中摘选一部分H3C交换机MAC VLAN内容,希望对这些读者有所...

                 对于不是很常用的MAC VLAN,许多读者都感到很陌生,读者QQ群中也经常见到有读者提到这方面的问题,希望我给予解答。现从笔者编著,目前在全国热销的《Cisco/H3C交换机配置与管理完全手册》(第二版)(与之配套的姊妹篇为《Cisco/H3C交换机高级配置与管理技术手册》)一书中摘选一部分H3C交换机MAC VLAN内容,希望对这些读者有所帮助。如要全面了解Cisco和H3C交换机的MAC VLAN相关知识和配置方法,请参见Cisco/H3C交换机配置与管理完全手册》(第二版)。

    19.6  H3C交换机基于MAC地址VLAN配置

           与Cisco IOS中的基于MAC地址VLAN一样,H3C交换机中的基于MAC地址VLAN也是一种动态VLAN划分方式。它并不会把某个端口静态地划分到一个特定的VLAN,而是要根据所连主机的MAC地址来动态选择加入到对应的VLAN中。

            我们在第一篇学习Cisco IOS交换机基于MAC地址划分VLAN时已体会到,总体来说还是比较麻烦的,要配置VMPS服务器,还要配置VPMS客户端,而且VMPS服务器目前来说只能由CatOS系统交换机担当,所以要实现基于MAC地址来划分VLAN网络中必须同时有两种操作系统的Cisco交换机,条件也是比较比较苛刻的。相比之下,本节介绍的H3C交换机基于MAC地址的VLAN划分就简单许多。它是按照报文的源MAC地址来定义VLAN成员,将指定报文加入该VLAN的标记后发送。但在H3C以太网交换机中,支持基于MAC地址的VLAN不多,与前面介绍的基于IP子网VLAN一样,主要有S5500、S5510、S7500E等交换机系列。

       与前面介绍的基于协议VLAN和基于IP子网VLAN一样,基于MAC地址的VLAN功能也只能在Hybrid端口配置,而且也主要用于在用户的接入设备的下行端口上进行配置(基于协议VLAN和基于IP子网VLAN也仅在接入设备的下行端口上配置),因此不和聚合功能同时使用。

    19.6.1  基于MAC地址VLAN的实现机制

    在支持基于MAC地址划分VLAN的H3C交换机中,划分方式又有三种形式:手动配置静态MAC VLAN、动态触发端口加入静态MAC VLAN和动态MAC VLAN。

    1.    手动配置静态MAC VLAN

        在手动配置静态MAC VLAN方式中,管理员需要手动配置MAC VLAN表项,启动基于MAC划分VLAN的功能,然后手动将对应的端口加入MAC VLAN。这种方式显然工作量比较大,常用于MAC VLAN中用户相对较少的网络环境。在该方式下,MAC VLAN的划分原理如下:

    l  当端口收到的报文为不带VLAN标记的报文时,会根据报文的源MAC匹配MAC VLAN表项。首先进行模糊匹配,即查询表中MASK(MAC地址掩码)不是全为F(只比较非F的位)的表项。将源MAC和MASK进行逻辑与运算后再与MAC VLAN表项中的MAC地址匹配,如果完全相同,则匹配成功,给报文添加表项中指定的VLAN ID并转发该报文;如果模糊匹配失败,则进行精确匹配,即查询表中MASK为全F的表项。如果报文中的源MAC与MAC VLAN表项中的MAC地址完全相同,则匹配成功,给报文添加表项中指定的VLAN ID并转发该报文;如果没有找到匹配MAC VLAN表项,则继续按照基于IP子网VLAN、协议VLAN、端口VLAN的先后顺序进行匹配。

    l  当端口收到的报文为带有VLAN标记的报文时,如果VLAN ID在端口中允许通过的VLAN ID列表里时,则接收该报文;否则丢弃该报文。

    2.    动态触发端口加入静态MAC VLAN

        在手动配置静态MAC VLAN划分方式中,管理员需要把端口一一加入相应的MAC VLAN,但这里有一个问题,那就是我们有时往往根本不能确定交换机从哪些端口收到属于MAC VLAN的报文,这时我们就不能通过手动方式把相应端口加入到MAC VLAN。此时,就需要借助另一种更加智能的MAC VLAN配置方式,使用动态触发端口加入静态MAC VLAN中。在这种MAC VLAN配置方式中,配置MAC VLAN表项后,管理员只需在端口上启用基于MAC的VLAN划分功能和MAC VLAN动态触发功能,在端口收到与MAC VLAN表项匹配的报文后,可以通过此报文动态触发端口加入MAC VLAN。其划分原理如下:

    l  当端口收到的报文为不带VLAN标记的报文时,按图19-11所示流程进行处理。

    l  当收到的报文为带VLAN标记的报文时,处理方式和基于端口的VLAN一样:如果端口允许携带该VLAN标记的报文通过,则正常转发;如果不允许,则丢弃该报文。

      【说明】如果用户在同一端口上同时启用了手动配置静态MAC VLAN和动态触发端口加入静态MAC VLAN,此时端口对收到的非精确匹配的报文将做丢弃处理。

    图19-11 在收到不带VLAN标记报文时,动态触发端口加入静态MAC VLAN的处理流程

     3. 动态MAC VLAN

       动态MAC VLAN需要和接入认证(比如基于MAC地址的802.1x认证)配合使用,以实现终端的安全、灵活接入。用户在交换机上配置动态MAC VLAN功能以后,还需要在接入认证服务器上配置MAC地址和VLAN的关联关系,这种MAC VLAN的配置就比较麻烦了,本书不做介绍。

       在动态MAC VLAN中,用户访问网络时,接入认证服务器先对用户进行认证,如果认证通过,服务器下发VLAN信息。交换机会根据用户报文的源MAC地址和下发的VLAN信息生成MAC VLAN表项,并将MAC VLAN添加到端口允许通过的VLAN列表中。用户下线后,交换机自动删除MAC VLAN表项,并将MAC VLAN从端口允许通过的VLAN列表中删除。

    19.6.2 手动配置静态MAC VLAN配置(略)

    19.6.3   动态触发端口加入静态MAC VLAN配置(略)

    19.6.4  手动配置静态MAC VLAN配置示例

       本示例拓扑结构如图19-11所示。SwitchA和SwitchB的GigabitEthernet1/0/1端口分别连接到两个会议室,Laptop1和Laptop2是会议用笔记本电脑,会在两个会议室间移动使用。Laptop1和Laptop2的MAC地址分别为000d-88f8-4e71、0014-222c-aa69。

        使用时,Laptop1和Laptop2要分别用于两个部门的员工,两个部门间使用VLAN100和VLAN200进行隔离。现要求这两台笔记本电脑无论在哪个会议室使用,均只能访问自己部门的服务器,即Server1和Server2。

    图19-11  手动配置静态MAC VLAN示例拓扑结构

     本示例配置所适用的H3C交换机系列和对应的软/硬件版本如表19-18所示。

    表19-18  示例适用的H3C交换机系列及软/硬件版本

    H3C交换机系列

    软件版本

    硬件版本

    S5500-SI系列以太网交换机

    Release 1207软件版本

    全系列硬件版本(除S5500-20TP-SI)

    Release 1301软件版本

    S5500-20TP-SI

    S5500-EI系列以太网交换机

    Release 2102软件版本

    全系列硬件版本

    S7500E系列以太网交换机

    Release 6100,Release 6300软件版本

    全系列硬件版本

    1SwitchA的配置。

    (1)创建VLAN100和VLAN200,并将GigabitEthernet1/0/2配置为Trunk端口,允许VLAN100和VLAN200的报文通过。

    <SwitchA> system-view

    [SwitchA] vlan 100

    [SwitchA-vlan100] quit

    [SwitchA] vlan 200

    [SwitchA-vlan200] quit

    [SwitchA] interface GigabitEthernet1/0/2

    [SwitchA-GigabitEthernet1/0/2] port link-type trunk

    [SwitchA-GigabitEthernet1/0/2] port trunk permit vlan 100 200

    [SwitchA-GigabitEthernet1/0/2] quit

    (2)将GigabitEthernet1/0/1配置为Hybrid端口,并使其在发送VLAN 100和VLAN 200的报文时去掉VLAN Tag。

    [SwitchA] interface GigabitEthernet1/0/1

    [SwitchA-GigabitEthernet1/0/1] port link-type hybrid

    [SwitchA-GigabitEthernet1/0/1] port hybrid vlan 100 200 untagged

    [SwitchA-GigabitEthernet1/0/1] quit

    (3)创建Laptop1的MAC地址与VLAN 100的关联,创建Laptop2的MAC地址与VLAN 200的关联,开启GigabitEthernet1/0/1端口的MAC-VLAN功能。

    [SwitchA] mac-vlan mac-address 000d-88f8-4e71 vlan 100

    [SwitchA] mac-vlan mac-address 0014-222c-aa69 vlan 200

    [SwitchA] interface GigabitEthernet 1/0/1

    [SwitchA-GigabitEthernet1/0/1] mac-vlan enable

    2. SwitchB的配置。

    SwitchB的配置与SwitchA完全一致,这里不再赘述。

    3Core Switch的配置

    (1)创建VLAN100和VLAN200,并将GigabitEthernet1/0/13和GigabitVLANEthernet
    1/0/14端口分别加入这两个VLAN。

    <CoreSwitch> system-view

    [CoreSwitch] vlan 100

    [CoreSwitch-vlan100] port gigabitethernet 1/0/13

    [CoreSwitch-vlan100] quit

    [CoreSwitch] vlan 200

    [CoreSwitch-vlan200] port gigabitethernet 1/0/14

    [CoreSwitch-vlan200] quit

    (2)配置GigabitEthernet1/0/3和GigabitEthernet1/0/4端口为Trunk端口,均允许VLAN100和VLAN200的报文通过。从这里也可以看出,同一个VLAN中可以基于多种VLAN划分方式来添加端口,因为在VLAN 100和VLAN 200中,上一步已通过基于端口VLAN划分方式添加了gigabitethernet 1/0/13和gigabitethernet 1/0/14两个Access端口。而此处添加的了Trunk端口(在SwitchA和SwitchB中还通过基于MAC地址划分方式添加了Hybird端口)。

    [CoreSwitch] interface GigabitEthernet1/0/3

    [CoreSwitch-GigabitEthernet1/0/3] port link-type trunk

    [CoreSwitch-GigabitEthernet1/0/3] port trunk permit vlan 100 200

    [CoreSwitch-GigabitEthernet1/0/3] quit

    [CoreSwitch] interface GigabitEthernet1/0/4

    [CoreSwitch-GigabitEthernet1/0/4] port link-type trunk

    [CoreSwitch-GigabitEthernet1/0/4] port trunk permit vlan 100 200

    [CoreSwitch-GigabitEthernet1/0/4] quit

    展开全文
  • 1、拿到一台H3C交换机后,首先确定交换机支持的vlan功能列表。说明:上表中实心黑色圈表示完全支持该功能;白色圈表示部分支持,即该款设备只能配置一个VLAN接口,且该VLAN必须是管理VLAN;“-”表示不支持该功能。2...
  • H3C交换机VLAN命令行

    2012-09-24 22:02:52
    H3C交换机VLAN命令行手册,有配置说明及配置举例
  • 交换机划分Vlan及DHCP----H3C S5110 Series一、划分VLAN1. 保证交换机不连接到外网,因为连接到外网后,交换机容易自动转变为转发功能。然后进入系统视图。 &lt;H3C&gt;system-view2. VLAN 100---创建VLAN ...
  • H3C交换机VLAN配置实例

    2011-06-23 15:57:57
    介绍H3C交换机VLAN配置方法说明,并有详细的实例说明
  • H3C交换机删除VLAN与其绑定端口配置

    千次阅读 2019-09-23 19:56:32
    在系统视图下,执行 undo int vlan 2 undo vlan 2 可以删除vlan2的配置信息。...[H3C-vlan2]undo port GigabitEthernet 3/1/1 可以解除GE3/1/1和VLAN2的绑定。 在系统视图下,输入: dis int v b 可以查看当前的...
  • H3C交换机VLAN基础配置实例.doc
  • H3C 交换机VLAN配置及DHCP服务配置,用户接口配置
  • 对于不是很常用的MAC VLAN,许多读者都感到很陌生,本文将详细介绍H3C交换机MAC VLAN原理及配置过程,需要了解更多朋友可以参考下
  • 一、基本设置 1.console线连接成功 2.进入系统模式 <H3C>system-view //提示符由<H3C>变为[H3C] 3.更改设备名称 ...[H3C]sysnameTEST ...[H3C]display current-configuration //displ...
  • H3C_S5500_SI交换机_VLAN

    2012-05-08 16:01:21
    设置网络H3C交换机-VLAN,S5500交换机的VLAN划分
  • H3C 三层核心交换机,S3600等型号通用;端口划分port e1/0/23 to e1/0/24 划分vlan 10连接外网公网,公网路由器192.168.1.1port e1/0/21 to e1/0/22 划分vlan 20连接内部网络,网关192.168.2.254 255.255.255.0port ...
  • 华三H3c 交换机 vlan Hybird端口配置

    千次阅读 2020-12-12 17:41:55
    此时swb的配置为缺省配置,在swa上创建vlan30,端口1/0/1设置为Hybird端口(之前已经把端口加入到vlan10里,pvid为vlan10), 并允许vlan10和20数据不打标签;1/0/2端口也是Hybyrd端口(pvid为vlan20),允许vlan20...
  • 核心交接分别划VLAN101 111 。下面两个交换机不配置,现在提示PVID不匹配,但能ping通!如何解决报错?或者有什么更好的配置方法? [img=https://img-bbs.csdn.net/upload/202008/14/1597401642_373109.png][/img]...
  • H3C交换机S5500划分VLAN

    千次阅读 2018-03-06 23:53:17
    H3C交换机S5500划分VLAN 将H3C S5500换机现在需要分三网段,分别是VLAN14,VLAN15,VLAN16,交换机中默认全部口是VLAN1. H3C路由器IP是 192.168.1.1需要划分的网段信息如下: 1)adds 192.168.14.1-254 子掩码:255.255....
  • 本以为挺简单的事情,可到了才发现不是自己想象的那样.vlan间互访没想到h3c搞的那么麻烦,cisco的数据流控制就是做一条访问列表,列表里定义了动作是拒绝还是允许,然后直接把这个列表应用到接口上就可以了,但h3c却没有...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 7,080
精华内容 2,832
关键字:

h3c交换机创建vlan