精华内容
下载资源
问答
  • H3C交换机配置模式有哪几类?很多人都不知道H3C交换机有哪几种配置模式,下面分享四种H3C交换机配置模式一一介绍给大家,需要的朋友可以参考下
  • 用户的网络访问控制方面,最直接、最简单的方法就是配置基于端口的安全模式,不仅Cisco交换机如此,H3C交换机也有类似的功能,而且看起来功能更加强大
  • H3C交换机常用配置命令

    万次阅读 多人点赞 2018-04-21 09:28:25
    H3C>system-view[H3C]super password H3C 设置用户分级密码[H3C]undo super password 删除用户分级密码[H3C]localuser bigheap 123456 1 Web网管用户设置,1(缺省)为管理级用户,缺省admin,admin[H3C]undo...
    一.用户配置:
    
    <H3C>system-view
    [H3C]super password H3C     设置用户分级密码
    [H3C]undo super password     删除用户分级密码
    [H3C]localuser bigheap 123456 1     Web网管用户设置,1(缺省)为管理级用户,缺省admin,admin
    [H3C]undo localuser bigheap     删除Web网管用户
    [H3C]user-interface aux 0     只支持0
    [H3C-Aux]idle-timeout 2 50     设置超时为2分50秒,若为0则表示不超时,默认为5分钟
    [H3C-Aux]undo idle-timeout     恢复默认值
    [H3C]user-interface vty 0     只支持0和1
    [H3C-vty]idle-timeout 2 50     设置超时为2分50秒,若为0则表示不超时,默认为5分钟
    [H3C-vty]undo idle-timeout     恢复默认值
    [H3C-vty]set authentication password 123456     设置telnet密码,必须设置
    [H3C-vty]undo set authentication password     取消密码
    [H3C]display users     显示用户
    [H3C]display user-interface     显示用户界面状态
    二.系统IP配置:
    [H3C]vlan 20
    [H3C]management-vlan 20
    [H3C]interface vlan-interface 20     创建并进入管理VLAN
    [H3C]undo interface vlan-interface 20     删除管理VLAN接口
    [H3C-Vlan-interface20]ip address 192.168.1.2 255.255.255.0     配置管理VLAN接口静态IP地址(缺省为192.168.0.234)
    [H3C-Vlan-interface20]undo ip address     删除IP地址
    [H3C-Vlan-interface20]ip gateway 192.168.1.1     指定缺省网关(默认无网关地址)
    [H3C-Vlan-interface20]undo ip gateway
    [H3C-Vlan-interface20]shutdown     关闭接口
    [H3C-Vlan-interface20]undo shutdown     开启
    [H3C]display ip     显示管理VLAN接口IP的相关信息
    [H3C]display interface vlan-interface 20     查看管理VLAN的接口信息
    <H3C>debugging ip     开启IP调试功能
    <H3C>undo debugging ip
    三.DHCP客户端配置:
    [H3C-Vlan-interface20]ip address dhcp-alloc     管理VLAN接口通过DHCP方式获取IP地址
    [H3C-Vlan-interface20]undo ip address dhcp-alloc     取消
    [H3C]display dhcp     显示DHCP客户信息
    <H3C>debugging dhcp-alloc     开启DHCP调试功能
    <H3C>undo debugging dhcp-alloc
    四.端口配置:
    [H3C]interface Ethernet0/3
    [H3C-Ethernet0/3]shutdown
    [H3C-Ethernet0/3]speed 100     速率,可为10,100,1000和auto(缺省)
    [H3C-Ethernet0/3]duplex full     双工,可为half,full和auto(缺省)  光口和汇聚后不能配置
    [H3C-Ethernet0/3]flow-control     开启流控,默认为关闭
    [H3C-Ethernet0/3]broadcast-suppression 20     设置抑制广播百分比为20%,可取5,10,20,100,缺省为100,同时组播和未知单播也受此影响
    [H3C-Ethernet0/3]loopback internal     内环测试
    [H3C-Ethernet0/3]loopback external     外环测试,需插接自环头,必须为全双工或者自协商模式
    [H3C-Ethernet0/3]port link-type trunk     设置链路的类型为trunk,可为access(缺省),trunk
    [H3C-Ethernet0/3]port trunk pvid vlan 20     设置20为该trunk的缺省VLAN,默认为1
                                               (trunk线路两端的PVID必须一致)
    [H3C-Ethernet0/3]port access vlan 20     将当前access端口加入指定的VLAN
    [H3C-Ethernet0/3]port trunk permit vlan all     允许所有的VLAN通过当前的trunk端口,可多次使用该命令
    [H3C-Ethernet0/3]mdi auto     设置以太端口为自动监测,normal(缺省)为直通线,across为交叉线                            
    [H3C]link-aggregation Ethernet 0/1 to Ethernet 0/4     将1-4口加入汇聚组,1为主端口,两端需要同时配置,设置了端口镜像以及端口隔离的端口无法汇聚
    [H3C]undo link-aggregation Ethernet 0/1     删除该汇聚组
    [H3C]link-aggregation mode egress     配置端口汇聚模式为根据目的MAC地址进行负荷分担,可选为                                      ingress,egress和both,缺省为both
    [H3C]monitor-port Ethernet 0/2     将该端口设置为镜像端口,必须先设置镜像端口,删除时必须先删除被镜像端口,而且它们不能同在一个端口,该端口不能在汇聚组中,设置新镜像端口时,新取代旧,被镜像不变
    [H3C]mirroring-port Ethernet 0/3 to Ethernet 0/4 both     将端口3和4设置为被镜像端口,both为同时监控接收和发送的报文,inbound表示仅监控接收的报文,outbound表示仅监控发送的报文
    [H3C]display mirror
    [H3C]display interface Ethernet 0/3
    <H3C>reset counters     清除所有端口的统计信息
    [H3C]display link-aggregation Ethernet 0/3     显示端口汇聚信息
    [H3C-Ethernet0/3]virtual-cable-test     诊断该端口的电路状况
    五.VLAN配置:
    [H3C]vlan 2
    [H3C]undo vlan all     删除除缺省VLAN外的所有VLAN,缺省VLAN不能被删除
    [H3C-vlan2]port Ethernet 0/4 to Ethernet 0/7     将4到7号端口加入到VLAN2中,此命令只能用来加access端口,不能用来增加trunk或者hybrid端口
    [H3C-vlan2]port-isolate enable     打开VLAN内端口隔离特性,不能二层转发,默认不启用该功能
    [H3C-Ethernet0/4]port-isolate uplink-port vlan 2     设置4为VLAN2的隔离上行端口,用于转发二层数据,只能配置一个上行端口,若为trunk,则建议允许所有VLAN通过,隔离不能与汇聚同时配置
    [H3C]display vlan all     显示所有VLAN的详细信息
      S1550E支持基于端口的VLAN,通过创建不同的user-group来实现,一个端口可以属于多个user-group,不属于同一个user-group的端口不能互相通信,最多支持50个user-group
    [H3C]user-group 20     创建user-group 20,默认只存在user-group 1
    [H3C-UserGroup20]port Ethernet 0/4 to Ethernet 0/7     将4到7号端口加入到VLAN20中,初始时都属于user-group 1中
    [H3C]display user-group 20     显示user-group 20的相关信息
    六.集群配置:
      S2100只能作为成员交换机加入集群中,加入后系统名改为"集群名_成员编号.原系统名"的格式.
      即插即用功能通过两个功能实现: 集群管理协议MAC组播地址协商和管理VLAN协商
    [H3C]cluster enable    启用群集功能,缺省为启用
    [H3C]cluster     进入群集视图
    [H3C-cluster]administrator-address H-H-H name switch     H-H-H为命令交换机的MAC,加入switch集群
    [switch_1.H3C-cluster]undo administrator-address     退出集群
    [H3C]display cluster     显示集群信息
    [H3C]management-vlan 2     集群报文只能在管理VLAN中转发,同一集群需在同一个管理VLAN中,需在建立集群之前指定管理VLAN
    <H3C>debugging cluster
    七.QoS配置:
      QoS配置步骤:设置端口的优先级,设置交换机信任报文的优先级方式,队列调度,端口限速
    [H3C-Ethernet0/3]priority 7     设置端口优先级为7,默认为0
    [H3C]priority-trust cos     设置交换机信任报文的优先级方式为cos(802.1p优先级,缺省值),还可以设为dscp方式(dscp优先级方式)
    [H3C]queue-scheduler hq-wrr 2 4 6 8     设置队列调度算法为HQ-WRR(默认为WRR),权重为2,4,6,8
    [H3C-Ethernet0/3]line-rate inbound 29     将端口进口速率限制为2Mbps,取1-28时,速率为rate*8*1024/125,即64,128,192...1.792M;29-127时,速率为(rate-27)*1024,即2M,3M,4M...100M,千兆时可继续往下取,128-240时,速率为(rate-115)*8*1024,即104M,112M,120M...1000M
    [H3C]display queue-scheduler     显示队列调度模式及参数
    [H3C]display priority-trust     显示优先级信任模式
    八.系统管理:
    [H3C]mac-address blackhole H-H-H vlan 1     在VLAN1中添加黑洞MAC
    [H3C]mac-address static H-H-H interface Ethernet 0/1 vlan 1     在VLAN1中添加端口一的一个mac
    [H3C]mac-address timer aging 500     设置MAC地址表的老化时间为500s
    [H3C]display mac-address
    [H3C]display arp
    [H3C]mac-address port-binding H-H-H interface Ethernet 0/1 vlan 1     配置端口邦定
    [H3C]display mac-address port-binding
    [H3C]display saved-configuration
    [H3C]display current-configuration
    <H3C>save
    [H3C]restore default     恢复交换机出厂默认配置,恢复后需重启才能生效
    [H3C]display version
    <H3C>reboot
    [H3C]display device
    [H3C]sysname bigheap
    [H3C]info-center enable     启用系统日志功能,缺省情况下启用
    [H3C]info-center loghost ip 192.168.0.3     向指定日志主机(只能为UNIX或LINUX,不能为Windows)输出信息,需先开启日志功能,缺省关闭
    [H3C]info-center loghost level 8     设置系统日志级别为8,默认为5.级别说明:1.emergencies 2.alerts 3.critical 4.errors 5.warnings 6.notifications 7.informational 8.debugging
    <H3C>terminal debugging     启用控制台对调试信息的显示,缺省控制台为禁用
    <H3C>terminal logging     启用控制台对日志信息的显示,缺省控制台为启用
    <H3C>terminal trapping     启用控制台对告警信息的显示,缺省控制台为启用
    [H3C]display info-center     显示系统日志的配置和缓冲区记录的信息
    [H3C]display logbuffer     显示日志缓冲区最近记录的指定数目的日志信息
    [H3C]display trapbuffer     显示告警缓冲区最近记录的指定数目的日志信息
    <H3C>reset logbuffer     清除日志缓冲区的信息
    <H3C>reset trapbuffer     清除告警缓冲区的信息
    九.网络协议配置:
      NDP即是邻居发现协议,S1550E只能开启或关闭NDP,无法配置,默认有效保留时间为180s,NDP报文发送的间隔60s
    [H3C]ndp enable     缺省情况下是开启的
    [H3C-Ethernet0/3]ndp enable     缺省情况下开启
    [H3C]display ndp     显示NDP配置信息
    [H3C]display ndp interface Ethernet 0/1     显示指定端口NDP发现的邻居信息
    <H3C>debugging ndp interface Ethernet 0/1
      HABP协议即Huawei Authentication Bypass Protocol,华为鉴权旁路协议,是用来解决当交换机上同时配置了802.1x和HGMPv1/v2时,未经授权和认证的端口上将过滤HGMP报文,从而使管理设备无法管理下挂的交换机的问题。交换机启动HABP后,将忽略802.1x认证。
      HABP包括服务器和客户端,由服务器定期发送请求,客户端进行应答,并向下进行转发,服务器一般启动在管理设备上,客户机在下挂设备上启动,1550E只支持客户端。
    [H3C]habp enable     启动HABP特性,缺省即启动,启动后即缺省为客户机模式
    <H3C>debugging habp     启动HABP调试功能
      NTDP即邻居拓扑发现协议,用来收集网络拓扑信息的协议,与NDP协议一起工作,用于集群管理,S1550E的配置主要包括开启与关闭功能能,开启与关闭调试功能
    [H3C]ntdp enable     缺省情况下为开启的
    [H3C-Ethernet0/3]ntdp enable     缺省情况下为使能
    <H3C>debugging ntdp
    十.SNMP配置:
      S1550E支持SNMPv1,SNMPv2c,主要配置包括:设置团体名,设置系统信息,设置Trap目标主机的地址,允许或禁止发送Trap,禁止SNMP Agent的运行
    [H3C]snmp-agent community read bigheap     设置bigheap团体,且为只读访问
    [H3C]snmp-agent max-size 1600     设置Agent能接受/发送的SNMP消息包最大为1600字节,缺省1500
    [H3C]snmp-agent sys-info contact #27345 location Diqiu version v2c     设置系统信息,版本为v2c,缺省情况下联系信息为"R&D Hangzhou, H3C Technologies co.,Ltd.",位置为"Hangzhou China",v2c版本
    [H3C]undo snmp-agent     禁止SNMP Agent的运行,若配置任何SNMP命令将重新启动SNMP Agent
    [H3C]display snmp-agent community read
    [H3C]display snmp-agent sys-info contact
    [H3C]display snmp-agent sys-info location
    [H3C]display snmp-agent sys-info version
    <H3C>debugging snmp-agent packet|process
    十一.IGMP Snooping配置:
      IGMP Snooping是运行在二层交换机上的组播约束机制,用于管理和控制组播组.主要负责建立和维护二层MAC地址表,同时根据建立的组播地址表来转发路由器下发的组播报文,如果不运行IGMP Snooping,则组播报文将在二层网络中广播
      IGMP Snooping配置包括:启动和关闭IGMP Snooping,配置路由器端口老化时间,配置最大响应查询时间,配置组播组成员端口老化时间,配置端口快速离开,调试功能
    [H3C]igmp-snooping      启用IGMP Snooping功能,默认为关闭
    [H3C]igmp-snooping router-aging-time 500     配置路由器端口老化时间为500s,默认为105s
    [H3C]igmp-snooping max-response-time 15     配置最大响应查询时间为15s,默认为10s
    [H3C]igmp-snooping host-aging-time 300     配置组播组成员端口老化时间为300s,默认为260s
    [H3C-Ethernet0/3]igmp-snooping fast-leave     配置快速离开,若收到离开报文,则立即删除端口,不询问
    [H3C]display igmp-snooping configuration     显示配置信息
    [H3C]display igmp-snooping statistics     显示包统计信息
    [H3C]display igmp-snooping group vlan 2     显示VLAN2中IP组播组和MAC组播组的信息
    <H3C>reset igmp-snooping statistics     清楚统计信息
    <H3C>debugging igmp-snooping
    十二.系统调试:
    <H3C>debugging all     开启所有调试开关,此命令为协议调试开关
    <H3C>terminal debugging     终端调试开关,打开开关,默认为关闭
    <H3C>debugging drv     主要显示报文的实际内容,默认为关闭
    [H3C]display debugging     显示调试开关状态
    十三.802.1x配置:
    [H3C-Ethernet0/3]dot1x     开启802.1x特性,也可在系统视图下使用,使用后全局开启,也可用                 interface参数开启指定端口的802.1x特性,缺省全关闭,要启用802.1x,全局和端口的都需开启
    [H3C-Ethernet0/3]dot1x port-control unauthorized-force     设置工作模式为强制非授权模式,使用        模式与dot1x命令相同,默认为auto,即通过了认证才可以访问,还有authorized-force,为强制授权       模式,允许用户访问
    [H3C-Ethernet0/3]dot1x port-method portbased     设置接入控制方式为基于端口的,使用模式与            dot1x命令相同,默认为macbase,基于MAC地址的
    [H3C-Ethernet0/3]dot1x max-user 10     设置端口接入用户的数量最大为10个,使用模式与dot1x命令         相同,默认为128,取值范围为1-128
    [H3C]dot1x authentication-method eap     设置802.1x的用户认证方法为EAP,即EAP中继,直接用EAP报        文发送到服务器,需服务器支持
    [H3C-Ethernet0/3]dot1x re-authenticate     开启802.1x重认证功能使交换机以一定时间间隔周期性       的进行认证,使用模式同dot1x命令,缺省情况下所有端口该特性都关闭
    [H3C]dot1x timer handshake-period 20 reauth-period 7200 quiet-period 30 tx-period 20 supp-     timeout 20 server-timeout 200     设置802.1x认证的定时器,handshake-period为认证成功后,     系统以此间隔为周期发送握手请求报文(相当于keepalive消息发送间隔),1-1024s,默认15s.
         reauth-period为重认证超时定时器,1-86400s,默认3600s.
         quiet-period为用户认证失败后,Autheticator的静默定时器,静默后再处理认证,10-120s,默认60s.
         tx-period为传送超时定时器,Supplicant未成功发送认证应答报文,则重发认证请求,10-120s,默认   为30s.
         supp-timeout为认证超时定时器,Supplicant未成功响应,则重发认证请求,10-120s,默认30s.
         server-timeout为服务器未成功响应的超时定时器,100-300s,默认100s.
    <H3C>reset dot1x statistics     清除802.1x统计信息
    [H3C]display dot1x statistics     显示802.1x的配置,运行情况和统计信息
    <H3C>debugging dot1x     打开802.1x的相关模块的调试信息
    十四.RADIUS配置:
    [H3C]radius scheme system     进入system方案,其各项值为缺省值,1550E只支持默认方案
    [H3C-radius-system]primary authentication 10.110.1.1 1812     设置RADIUS服务器地址和UDP端口     号,默认情况下,system方案中服务器IP地址为空,UDP端口号为1812
    [H3C-radius-system]key authentication 123     指示RADIUS加密共享密钥为123,默认无共享密钥
    [H3C-radius-system]timer 10     设置RADIUS服务器响应超时定时器,1-10s,默认为5s
    [H3C-radius-system]retry 10     设置RADIUS服务器最大响应重试次数为10,1-20次,默认为5次
    [H3C]display radius     显示radius方案信息
    <H3C>debugging radius packet     打开radius报文调试开关


    对于一般的路由器广大网友们应该都会设置,随着光纤的普及,越来越多的宽带提供商都采用光纤到户,想要使用光纤就必须使用光纤路由器,光纤路由器的设置很多人还不太了解。下面,我以H3C光纤路由器为例,给大家介绍如何进行设置。
    一、连接方式
    光纤-光电转换器—代理服务器—电脑。
    1、ADSL/VDSLPPPoE:电脑上运行第三方拨号软件如Enternet300或WinXP系统自带的拨号程序,填入ISP提供的账号和密码,每次上网前先要拨号。
    2、启用路由功能,填入了ISP提供的账号和密码,拨号的动作交给MODEM去做。
    3、静态IP:ISP提供给您固定的IP地址、子网掩码、默认网关、DNS。
    4、动态IP:电脑的TCP/IP属性设置为“自动获取IP地址”,每次启动电脑即可上网。
    5、802.1X+静态IP:ISP提供固定的IP地址,专用拨号软件,账号和密码。
    6、802.1X+动态IP:ISP提供专用拨号软件,账号和密码。
    7、WEB认证:每次上网之前,打开IE浏览器,会自动跳到ISP指定的主页,填入ISP提供的用户名密码,通过认证以后才可以进行其他得上网操作。
    二、基本设置
    1、物理连接好,这里就不啰嗦了,大同小异,将电脑的ip地址和路由器管理地址设置在同一网段,在IE栏中输入管理IP地址,在用户登陆提示窗口输入宽带路由器说明书中的默认管理账户和密码进入设置界面。
    2、为了让路由器能够自动拨号,我们还需要将ADSL账号填写在路由器中,点击上方的首页标签,然后点击WAN,在PPPoverEthernet处看到设置ADSL账号的地方,输入自己的ADSL账号和密码后保存设置,现在到系统状态-系统信息处察看联网状态,在WAN端可以清晰地看到ADSL拨号获得的网络信息。
    3、设置完ADSL账号后,我们就可以通过宽带路由器上网了,这时我们可以打开DHCP功能,在DHCP服务器可进入的ip范围处设置ip地址范围,保存后光纤路由器设置中就具备自动分配ip地址的功能了。
    光纤路由器设置的内容就为你介绍这里,上面提到的这些连接认证方式只是普及率比较高的一些宽带接入方式,如果你不清楚,可以向ISP商咨询,设置好自己的光纤路由器。
    展开全文
  • H3C交换机SSH配置完全攻略 1.使用SSH+密码认证(基本SSH配置方法)** 注:在用户使用SSH登录交换机时,交换机对所要登录的用户使用密码对其进行身份验证 生成RSA和DSA密钥对 [H3C]public-key local create rsa [H3C]...

    H3C交换机SSH配置完全攻略

    1.使用SSH+密码认证(基本SSH配置方法)**

    注:在用户使用SSH登录交换机时,交换机对所要登录的用户使用密码对其进行身份验证
    生成RSA和DSA密钥对
    [H3C]public-key local create rsa
    [H3C]public-key local create dsa
    设置用户接口上的认证模式为AAA,并让用户接口支持SSH协议
    [H3C]user-interface vty 0 4
    [H3C-ui-vty0-4]authentication-mode scheme
    [H3C-ui-vty0-4]protocol inbound ssh
    创建用户luwenju-juzi,设置认证密码为luwenju-!@# 登录协议为SSH,能访问的命令级别为3
    [H3C]local-user luwenju-juzi
    [H3C-luser-luwenju-juzi]password cipher luwenju-!@#
    [H3C-luser-luwenju-juzi]service-type ssh level 3
    指定用户luwenju-juzi的认证方式为password
    [H3C]ssh user luwenju-juzi authentication-type password
    一个基本的SSH配置就结束了,配置完成后即可使用SSH登录工具进行连接交换机

    2.使用SSH+密钥、密码认证(高级SSH配置方法)

    注:客户端在使用SSH工具登录交换机时,交换机同时使用密钥和密码对所要登录的用户实行身份验证
    生成RSA和DSA密钥对
    [H3C]public-key local create rsa
    [H3C]public-key local create dsa
    设置用户接口上的认证模式为AAA认证,并在接口上开启SSH协议,并设置用户能访问的命令级别为3
    [H3C]user-interface vty 0 4
    [H3C-ui-vty0-4]authentication-mode scheme
    [H3C-ui-vty0-4]protocol inbound ssh
    [H3C-ui-vty0-4]user privilege level 3
    创建用户,并指定认证方式为公钥认证,用户名为luwenju-juzi,密码为luwenju-!@#
    [H3C]local-user luwenju-juzi
    [H3C-luser-luwenju-juzi]password cipher luwenju-!@#
    [H3C-luser-luwenju-juzi]service-type ssh level 3
    [H3C]ssh user luwenju-juzi authentication-type password-publickey
    客户端生成公钥和私钥
    用puttygen.exe生成公私钥对,然后放到某个文件夹下,在此,我们生成的公钥叫luwenjukey私钥为luwenju.ppk,然后我们把公钥文件luwenjukey上传到FTP服务器,然后登录交换机,将luwenjukey下载到交换机
    ftp 202.106.0.20
    [ftp]get luwenjukey
    为用户生成公钥,在交换机上把文件luwenjukey中导入客户端的公钥,公钥名为luwenju-juzikey 注:luwenju-juzikey是为用户生成的公钥
    [H3C]public-key peer luwenju-juzikey import sshkey luwenjukey
    为用户luwenju-juzi指定公钥luwenju-juzikey
    [H3C]ssh user luwenju-juzi assign publickey luwenju-juzikey
    然后打开SSH登录工具,导入私钥luwenju.ppk,然后输入交换机的IP地址登录即可

    3.使用SSH+密码认证(基本SSH配置方法)

    注:在用户使用SSH登录交换机时,交换机对所要登录的用户使用密码对其进行身份验证
    生成RSA和DSA密钥对
    [H3C]public-key local create rsa
    [H3C]public-key local create dsa
    设置用户接口上的认证模式为AAA,并让用户接口支持SSH协议
    [H3C]user-interface vty 0 4
    [H3C-ui-vty0-4]authentication-mode scheme
    [H3C-ui-vty0-4]protocol inbound ssh
    创建用户luwenju-juzi,设置认证密码为luwenju-!@# 登录协议为SSH,能访问的命令级别为3
    [H3C]local-user luwenju-juzi
    [H3C-luser-luwenju-juzi]password cipher luwenju-!@#
    [H3C-luser-luwenju-juzi]service-type ssh level 3
    指定用户luwenju-juzi的认证方式为password
    [H3C]ssh user luwenju-juzi authentication-type password
    一个基本的SSH配置就结束了,配置完成后即可使用SSH登录工具进行连接交换机

    4.使用SSH+密钥、密码认证(高级SSH配置方法)

    注:客户端在使用SSH工具登录交换机时,交换机同时使用密钥和密码对所要登录的用户实行身份验证
    生成RSA和DSA密钥对
    [H3C]public-key local create rsa
    [H3C]public-key local create dsa
    设置用户接口上的认证模式为AAA认证,并在接口上开启SSH协议,并设置用户能访问的命令级别为3
    [H3C]user-interface vty 0 4
    [H3C-ui-vty0-4]authentication-mode scheme
    [H3C-ui-vty0-4]protocol inbound ssh
    [H3C-ui-vty0-4]user privilege level 3
    创建用户,并指定认证方式为公钥认证,用户名为luwenju-juzi,密码为luwenju-!@#
    [H3C]local-user luwenju-juzi
    [H3C-luser-luwenju-juzi]password cipher luwenju-!@#
    [H3C-luser-luwenju-juzi]service-type ssh level 3
    [H3C]ssh user luwenju-juzi authentication-type password-publickey
    客户端生成公钥和私钥
    用puttygen.exe生成公私钥对,然后放到某个文件夹下,在此,我们生成的公钥叫luwenjukey私钥为luwenju.ppk,然后我们把公钥文件luwenjukey上传到FTP服务器,然后登录交换机,将luwenjukey下载到交换机
    ftp 202.106.0.20
    [ftp]get luwenjukey
    为用户生成公钥,在交换机上把文件luwenjukey中导入客户端的公钥,公钥名为luwenju-juzikey 注:luwenju-juzikey是为用户生成的公钥
    [H3C]public-key peer luwenju-juzikey import sshkey luwenjukey
    为用户luwenju-juzi指定公钥luwenju-juzikey
    [H3C]ssh user luwenju-juzi assign publickey luwenju-juzikey
    然后打开SSH登录工具,导入私钥luwenju.ppk,然后输入交换机的IP地址登录即可

    展开全文
  • H3C交换机开启POE的配置方法

    热门讨论 2014-01-10 09:29:56
    H3C交换机开启POE的配置方法,简洁方便的帮助大家配置支持POE的H3C交换机的开启。因为其出厂配置POE默认是关闭的,对于不熟悉操作的用户,开启其POE功能是比较棘手的。
  • H3C交换机配置SSH

    万次阅读 2020-03-27 20:31:49
    一般连接交换机可以使用telnet协议,虽然Telnet较为简单实用也很方便,并不怎么安全。原因在于Telnet是一个明文传送协议,它将用户的所有内容,包括用户名和密码都明文在互联网上传送,具有一定的安全隐患,因此许多...

       一般连接交换机可以使用telnet协议,虽然Telnet较为简单实用也很方便,并不怎么安全。原因在于Telnet是一个明文传送协议,它将用户的所有内容,包括用户名和密码都明文在互联网上传送,具有一定的安全隐患,因此许多服务器都会选择禁用Telnet服务。   SSH (安全外壳协议)为 Secure Shell 的缩写,由 IETF 的网络小组(Network Working Group)所制定;SSH 为建立在应用层基础上的安全协议。SSH 是较可靠,专为远程登录会话和其他网络服务提供安全性的协议。利用 SSH 协议可以有效防止远程管理过程中的信息泄露问题。SSH通过非对称加密完成用户登录。

      下面是具体的配置过程,因为目前h3c交换机有v5版本和v7版本,其配置步骤不一样,故下面会分开进行配置。

    一、V5版本交换机SSH配置

    1、生成RSA和DSA密钥对

    [H3C]public-key local create rsa

    [H3C]public-key local create dsa

    备注: 1)RSA 和 DSA 认证协议的基础是一对专门生成的密钥,都是非对称加密。 2)执行public-key local create命令后,生成的密钥对将保存在设备中,设备重启后不会丢失。 3)生成RSA密钥对时会提示用户输入密钥模数的长度,建议密钥模数的长度大于或等于768比特,以提高安全性保证。 4)生成DSA密钥对时会提示用户输入密钥模数的长度,建议密钥模数的长度大于或等于768比特,以提高安全性保证。 注意:虽然一个客户端只会采用DSA和RSA公共密钥算法中的一种来认证服务器,但是由于不同客户端支持的公共密钥算法不同,为了确保客户端能够成功登录服务器,建议在服务器上生成DSA和RSA两种密钥对。

    2、开启ssh服务

    设置用户接口上的认证模式为AAA,并让用户接口支持SSH协议

    [H3C]ssh server enable

    [H3C]user-interface vty 0 15

    [H3C-ui-vty0-15]authentication-mode scheme

    [H3C-ui-vty0-15] protocol inbound ssh

    注意:如果在该用户界面上配置支持的协议是SSH,为确保登录成功,请务必配置登录用户界面的认证方式为authentication-mode scheme(采用AAA认证)。

    3、创建用户 创建用户admin,设置认证密码admin, 登录协议为SSH,能访问的命令级别为level  3。

    [H3C]local-user admin  

    [H3C-luser-admin]password simple admin    

    备注:若忘记密码,可以通过console端口连接,然后通过该命令来修改密码

    4、定义登录协议

    [H3C-luser-admin]service-type ssh

    5、创建用户级别

    [H3C-luser-admin]authorization-attribute level 3

    [H3C-luser-admin]quit

    [H3C]save                   //保存退出

    二、V7版本交换机SSH配置

    1、生成RSA和DSA密钥对

    [H3C]public-key local create rsa

    [H3C]public-key local create dsa

    说明:可以通过命令显示生成的RSA密钥对的公钥部分(dis public-key local rsa public)

    2、开启ssh服务 并设置用户接口上的认证模式为AAA,并让用户接口支持SSH协议

    [H3C]ssh server enable

    [H3C]user-interface vty 0 63

    [H3C-ui-vty0-15]authentication-mode scheme

    [H3C-ui-vty0-15] protocol inbound ssh

    注意:如果在该用户界面上配置支持的协议是SSH,为确保登录成功,请务必配置登录用户界面的认 证方式为authentication-mode scheme(采用AAA认证)。

    3、创建用户

    创建用户admin,设置认证密码admin,登录协议为SSH,能访问的命令级别为network-admin。

    [H3C]local-user admin  

    [H3C-luser-admin]password simple admin    

    注意:如果忘记密码,可以通过console端口连接,然后通过该命令来修改密码

    4、定义登录协议

    [H3C-luser-admin]service-type ssh

    5、创建用户级别

    [H3C-luser-admin]authorization-attribute user-role network-admin

    [H3C-luser-admin]quit

    [H3C]save                   //保存退出

    展开全文
  • 在局域网中VLAN是最常见的,通常使用VLAN来划分不同网段,不同的功能区3台电脑代表3个不同网段的VLAN,接在同一台交换机上VLAN10:192.168.10.1/24 GW:192.168.10.254VLAN20:192.168.20.1/24 GW:192.168...H3C>sys ...

    在局域网中VLAN是最常见的,通常使用VLAN来划分不同网段,不同的功能区

    ae1f5d1c3d4645ad90864f9c57395a69.png

    3台电脑代表3个不同网段的VLAN,接在同一台交换机上

    VLAN10:192.168.10.1/24 GW:192.168.10.254

    VLAN20:192.168.20.1/24 GW:192.168.20.254

    VLAN30:192.168.30.1/24 GW:192.168.30.254

    <H3C>sys  
    System View: return to User View with Ctrl+Z.
    [H3C]sysn
    [H3C]sysname HC_SW_1                         #设备命名
    [HC_SW_1]vlan 10                             #创建vlan10
    [HC_SW_1-vlan10]name VLAN10                  #vlan命名
    [HC_SW_1-vlan10]vlan 20                      #创建vlan 20
    [HC_SW_1-vlan20]name VLAN20                  #vlan命名 
    [HC_SW_1-vlan20]vlan 30                      #创建vlan30
    [HC_SW_1-vlan30]name VLAN30                  #vlan命名
    [HC_SW_1-vlan30]

    9cc8fa5bdcfadb5fcd9b52b54107262a.png

    查看所有的vlan ,现在VLAN已经创建,但默认交换机的所有端口都在VLAN1,VLAN1是默认vlan,我们需要将对应的端口放在对应的vlan里。

    可以查看哪些端口已经起来了

    5b7d9a67fa6de7b87b43adcddd092524.png

    现在所有端口都是DOWN状态,因为我们还没有将电脑的端口开启。

    8e9402a43204e552788f848e81829853.png

    6ce640089ee0a05af74d83fd421aab81.png

    我们现在没有使用DHCP,需要手动设置地址,我们之前已经划分好VLAN了,现在配置上去

    VLAN10:

    e6a6653629b6800121ff08661857dfc8.png

    VLAN20:

    5d4d6955784664ba7d0ce65cbbc58b03.png

    VLAN30:

    77fdb5bbfbe571169ae494b3f13ac709.png

    现在再看下交换机上面端口是否开启了

    3f6d06e83ec93731f04411cc33686017.png

    端口已经开启

    交换机有两种常见类型 : access trunk口,access一般是接终端, trun口需要封装,一般连接设备如交换机。

    现在我们将对应接口设置为access并划分到对应vlan

    [HC_SW_1]interface GigabitEthernet 1/0/1           #进入1口
    [HC_SW_1-GigabitEthernet1/0/1]port access vlan 10  #端口默认就是access类型,这里直接设置划分到vlan10
    [HC_SW_1]interface GigabitEthernet 1/0/2           #下面同理
    [HC_SW_1-GigabitEthernet1/0/2]port access vlan 20
    [HC_SW_1-GigabitEthernet1/0/2]int g1/0/3
    [HC_SW_1-GigabitEthernet1/0/3]port access vlan 30
    [HC_SW_1-GigabitEthernet1/0/3]
    
    

    现在再查看vlan,已经看到对应vlan已经有对应的端口了

    c88b180f3a23e0433a326e9ca658a735.png

    现在查看ip地址是没有的,因为都没有进入vlan配置过

    24f947f58fcaf494edd6313ae2a8aed8.png

    现在配置ip地址

    [HC_SW_1]interface Vlan-interface 10                             #使用interface来进入接口配置模式
    [HC_SW_1-Vlan-interface10]ip address 192.168.10.254 24           #ip address 配置ip地址 后面 24 是掩码 也可以写255.255.255.0 后面再详细介绍
    [HC_SW_1-Vlan-interface10]int vlan 20                            #同理
    [HC_SW_1-Vlan-interface20]ip address 192.168.20.254 24
    [HC_SW_1-Vlan-interface20]int vlan 30
    [HC_SW_1-Vlan-interface30]ip address 192.168.30.254 24
    [HC_SW_1-Vlan-interface30]
    

    现在可以查看vlan的地址配置了

    8fdb26cc731bc31d678e8b11779d646a.png

    现在端口,地址,网管关都对应上了

    cb1d7f850313444a85cbf1a3ecb29066.png

    在交换机上测试是否连通,使用ping命令加ip地址,已经可以ping通,证明没有问题

    d6a17b84cd1690f818f206306065667d.png

    因为H3C模拟器的交换机是3层交换机,所有只要vlan配置对,不同vlan就可以直接访问,来我们在电脑测试一下

    8b13b8cbdc0e0ccea6c1ec563c99d1d0.png

    在VLAN10访问其他2个VLAN

    先测试了能否ping通网关,然后ping其他vlan电脑,很多时候如果网关都ping不通,就是为了有问题了,所有可以先看下能不能到网关,现在测试都是正常的

    c2d73f203f6027eefc8cdfa65d9f8b59.png

    在vlan20访问也是正常的

    a031849274f88eb4f44ff52f26c83d13.png

    这样vlan就是正常可以通信了

    现在来保存一下吧,我一般都是save f 强制保存的。

    8598fa1a1a51539690a75e058664210c.png

    OK了,最近觉得搞IT的,一段时间不敲命令很容易就忘了,更加需要记一下了。

    展开全文
  • H3C交换机配置

    2021-08-27 11:20:36
    h3c 交换机配置命令 通过 console 连接到交换机 交换机所使用的 console 接口看上去像是一个普通的 RJ45 网卡接口,但是并不能使用普通的网线与 PC 连接 ^_^ 。它要通过 RJ45-RS232 转换线转换为 RS232 接口...
  • cisco与华三华为生成树协议互操作能力,各个模式下是否兼容,不兼容该怎么配置
  • H3C MSR路由器、交换机基本调试步骤(初学级别) 三层交换机配置指令 交换机端口汇聚配置 H3C经典配置 访问控制 认证权限 VLAN等
  • 需要将G1/0/1口的全部流量镜像到G1/0/24口,即G1/0/1为源端口,G0/0/24为目的端口 配置步骤 1、进入配置模式:system-view; 2、创建本地镜像组:mirroring-group 1 local ...[H3C]mirroring-group 1 mi
  • H3C交换机配置常用命令

    千次阅读 2019-02-20 16:56:47
    华为3COM交换机配置命令详解 1、配置文件相关命令 [Quidway]display current-configuration ;显示当前生效的配置 [Quidway]display saved-configuration ;显示flash中配置文件,即下次上电启动时所用的配置文件 &...
  • H3C 交换机配置ssh登陆

    千次阅读 2019-09-30 05:14:51
    1.开启ssh服务,创建密钥。...[D05-S5048-02-luser-manage-iautos]quit //退出用户配置模式 [D05-S5048-02]save //保存配置 4.完成。 转载于:https://www.cnblogs.com/xzlive/p/11507351.html
  • H3C交换机配置命令大全【转载】

    千次阅读 2019-02-26 22:10:11
    H3C不但拥有全线路由器和以太网交换机产品,还在网络安全、IP存储、IP监控、语音视讯、WLAN、SOHO及软件管理系统等领域稳健成长。 在以太网领域,H3C经历多年的耕耘和发展,积累了大量业界领先的知识产权和专利,可...
  • H3C交换机配置链路聚合

    千次阅读 2020-10-10 09:16:45
    system-view //进入配置模式 动态链路聚合: [SW]dis cu //查看所有配置端口信息 [SW]int Bridge-Aggregation 1 //创建链路聚合组端口1 [SW-Bridge-Aggregation1]link-aggregation mode dynamic //链路聚合...
  • H3C交换机配置端口镜像

    万次阅读 2019-05-13 11:56:41
    端口镜像 需要将G0/0/1口的全部流量镜像到G0/0/2口,即G0/0/1为源端口,G0/0/2为目的...1、进入配置模式:system-view; 2、创建本地镜像组:mirroring-group 1 local 3、为镜像组配置源端口:mirroring-grou...
  • H3C交换机配置命令大全 1、system-view 进入系统视图模式 2、sysname 为设备命名 3、display current-configuration 当前配置情况 4、 language-mode Chinese|English 中英文切换 5、interface Ethernet 1/0/1 ...
  • H3C交换机配置命令一览表

    千次阅读 2018-12-02 23:49:38
    H3C&gt;system-view [H3C]super password H3C 设置用户分级密码 [H3C]undo super password 删除用户分级密码 [H3C]localuser bigheap 123456 1 Web网管用户设置,1(缺省)为管理级用户,缺省admin,admin [H3C]...
  • H3C 交换机配置SSH

    2021-02-04 17:16:58
    一般连接交换机可以使用telnet协议,虽然Telnet较为简单实用也很方便,并不怎么安全。原因在于Telnet是一个明文传送协议,它将用户的所有内容,包括用户名和密码都明文在互联网上传送,具有一定的安全隐患,因此许多...
  • H3C 交换机 OpenFlow 配置指南

    千次阅读 2018-12-02 16:34:40
    H3C 交换机 OpenFlow 配置指南 目录 Console 连接交换机 配置 VLAN 创建实例并映射 VLAN 配置控制器1的IP地址并激活实例 验证配置 1. Console 连接交换机 笔记本连接需要一个 USB 转 RS232 串口线。 MacOS 连接后...
  • H3C交换机配置DHCP服务器

    千次阅读 2018-11-19 09:07:00
    dhcp server ip-pool vlan4020 network 10.3.7.0 mask 255.255.255.0 gateway-list 10.3.7.254 dns-list 202.193.160.33 然后在对应接口上开启 dhcp select server ...转载于:https://www.cnblogs.c...
  • H3C交换机配置认证方式

    千次阅读 2019-11-06 20:23:23
    要远程访问设备,首先要配置一个接口IP用来进行远程连接,对于一般的二层接入交换机,不能像路由器一样直接配置接口IP,只能在虚拟VLAN接口上配一个管理IP,用来进行远程登录,在华三交换机配置管理IP的命令可参考...
  • 3、display current-configuration 当前配置情况 4、 language-mode Chinese|English 中英文切换 5、interface Ethernet 1/0/1 进入以太网端口视图 6、 port link-type Access|Trunk|Hybrid 设置端口...
  • H3C交换机配置的备份与恢复(转)

    千次阅读 2019-02-26 22:08:29
     相信有很多网管员备份配置都是采用display current命令查询当前设备运行配置信息,然后采用ctrl+c,ctrl+v的方式将信息保存到txt文档中;或者直接用捕捉屏幕输出的方法保存信息。还原的时候再复制命令到交换机中...
  • h3c交换机配置ssh密码验证登录方式

    万次阅读 2018-11-07 17:45:57
    一、背景: 1、由于PC机串口不支持热插拔,请不要在交换机带电的情况下,将串口插入或者拔出PC机。...H3C&gt;reset saved-configuration 3、重启设备 必须重启才能生效 二、VLAN配置 1...
  • 3、display current-configuration 当前配置情况 4、 language-mode Chinese|English 中英文切换 5、interface Ethernet 1/0/1 进入以太网端口视图 6、 port link-type Access|Trunk|Hybrid 设置端口访问模式 7...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 11,209
精华内容 4,483
热门标签
关键字:

h3c交换机配置模式