精华内容
下载资源
问答
  • 主要介绍了python3.7 使用pymssql往sqlserver插入数据的方法,代码很简单,感兴趣的朋友跟随小编一起看看吧
  • win10+Python3.7使用whl安装dlib(无需编译)-附件资源
  • macOS10.13 python3.7使用pyltp

    千次阅读 2019-03-26 17:36:12
    python3.7 使用pip 安装pyltp时会报错: 首先是不兼容macOS 10.13,最高兼容至10.12;其次是pyltp最高兼容至python3.6,也会报错。需要从源码编译安装来解决上述问题。 >>> git clone ...

    系统环境:

    • macOS 10.13
    • python3.7

    在以上系统环境下使用pip 安装pyltp时会报错:
    首先是不兼容macOS 10.13,最高兼容至10.12;其次是pyltp最高兼容至python3.6,也会报错。需要从源码编译安装来解决上述问题。

    >>> git clone https://github.com/HIT-SCIR/pyltp.git
    >>> cd pyltp
    >>> rm -rf ltp #此处ltp文件夹为空,需手动下载ltp
    >>> cd ltp
    >>> git clone https://github.com/HIT-SCIR/ltp.git
    >>> cd ..
    >>> vim setup.py
    #修改第121行内容
    os.environ['MACOSX_DEPLOYMENT_TARGET'] = '10.13'
    

    再解决python3.7的问题:

    >>> vim patch/libs/python/src/converter/builtin_converters.cpp
    #修改第51行
    return (void *)(PyUnicode_Check(obj) ? _PyUnicode_AsString(obj) : 0)
    

    详细可参考:issue

    最后进行安装:

    sudo python3 setup.py install
    

    模型下载地址:最新为3.4.0

    展开全文
  • 【NLP】Python3.7使用NLTK进行情感分析

    千次阅读 2019-10-28 22:42:28
    【NLP】Python3.7使用NLTK进行情感分析 1.NLTK情感分析 2.使用上的一些坑 3.实战结果

    【NLP】Python3.7使用NLTK进行情感分析

    以前系统的玩过NLP,对于相关的知识较为熟悉,这次需要对一些英文评论性的语料做一些情感分析,本来这段时间好不容易搞定了中文的SnowNlp,发现用已有代码效果不好,本次拿出以前用了很多次的NLTK,好久不用会有一些坑的,那记录一下吧,希望大家可以顺利,不要安装使用上打击了积极性哇!

    1.NLTK情感分析

    自然语言工具包(NLTK)是最受欢迎的自然语言处理(NLP)库。它是用 Python 语言编写的,背后有强大的社区支持。

    NLTK 也很容易入门,实际上,它将是你用到的最简单的自然语言处理(NLP)库。

    2.安装使用上的一些坑

    这次在python 3.7环境下。
    其实一般只需要pip install nltk就可以,在pycharm下直接add也可,这个时候import nltk一般是没问题的。
    但是如果想用Nltk下的自带data,一般使用import nltk后用,

    nltk.download()
    

    这时候会弹出?
    正常下载需要的包就可以了。
    但有可能会像我一样出错,连接不到winerror巴拉巴拉。。。。。
    在这里插入图片描述
    那就看这里吧
    详细步骤,去他的github自己下载
    在github上下载nltk_data,网址为https://github.com/nltk/nltk_data,支持python3。下载packages目录,把目录名改为nltk_data,保存在任意目录下,比如D:/nltk_data这样都可以。
    在这里插入图片描述
    一般这样就会可以用啦!

    3.实战结果

    我从数据库里读出自己的内容,主要nltk情感分析写在这个函数里了!
    不要忘了?
    from nltk.sentiment.vader import SentimentIntensityAnalyzer

    def nltkSentiment(view):
        sid = SentimentIntensityAnalyzer()
        view_sen=[]
        for sen in view:
            print(sen)
            senti = sid.polarity_scores(sen)
            for k in senti:
                print('{0}:{1},'.format(k, senti[k]), end='\n')
    

    输出的结果大概是这样:
    在这里插入图片描述compound是复杂度,基本今天这个结果暂时满意啦~

    3.后续需解决

    一些思考和后续需要解决的问题
    这个解决给了每个句子的pos ,neg, neu三个方向的值,不确定怎么用一个值来衡量,大多都属于中立的范畴,但这样对情感分析不适合,最好是以pos 和neu为主找到一个衡量值,除了pos:0;neg:0;neu:1,就认为他是中立的。

    或许可以?!继续试试,会回来填坑~

    —————EchoZhang——2019/10/28——————————

    展开全文
  • Python3.7 使用 celery

    2020-06-07 17:58:32
    相信大家用Python3.x的情况下 使用 celery 各种报错 我这边有个成功案例 欢迎大家参考 安装 celery pip install celery==4.4.4 在windows10系统 仅仅安装 celery 是不行的 还需要安装一个 eventlet pip install ...

    相信大家用Python3.x的情况下 使用 celery 各种报错 我这边有个成功案例 欢迎大家参考

    安装 celery

    pip install celery==4.4.4
    

    在windows10系统 仅仅安装 celery 是不行的

    还需要安装一个 eventlet

    pip install eventlet
    

    启动命令 如果你客户端需要发起 requests请求的话 请使用 下面的命令启动

    celery worker -A 模块名称 --loglevel=info --pool=solo
    

    如果你只需要多进程操作某个模块的话 请使用

    celery -A 模块名称worker -l info -P eventlet
    
    展开全文
  • ubuntu安装python3.7,并更新python默认指向为python3.7

    万次阅读 多人点赞 2018-12-24 17:57:44
    ubuntu默认带着的python版本不是最新版,因此需要手动安装最新版。 查看python的指向。 ls -l /usr/bin | grep python ...1.直接使用apt-get安装python3.7失败: apt-get install python3.7 2.改为手动安装...

    ubuntu默认带着的python版本不是最新版,因此需要手动安装最新版。

    查看python的指向

    ls -l /usr/bin | grep python

    可以看到,此时python指向的是python3.4。

    第一部分:安装python3.7

    1.直接使用apt-get安装python3.7失败:

    apt-get install python3.7

    2.改为手动安装

    步骤1:在python官网找到python-3.7.1.tgz的地址:https://www.python.org/ftp/python/3.7.1/Python-3.7.1.tgz

    步骤2:下载安装包

    wget https://www.python.org/ftp/python/3.7.1/Python-3.7.1.tgz

    步骤3:解压安装包

    tar -zxvf Python-3.7.1.tgz

    步骤4:切换到解压后的目录下

    cd Python-3.7.1

    步骤5:./configure(也可以./configure --prefix=/usr/local/python3.7.1)

    ./configure
    # 或者
    ./configure --prefix=/usr/local/python3.7.1

    步骤6:编译make(没有安装make的安装一下)

    make
    

    步骤7:测试make test

    make test

    关于make test命令出现ModuleNotFoundError: No module named ‘_ctypes’ 错误,请移步我的另外一篇博文https://blog.csdn.net/u014775723/article/details/85224447

    步骤8:安装sudo make install

    sudo make install

    若步骤5执行的是 ./configure,则安装后可执行文件默认放在/usr /local/bin,库文件默认放在/usr/local/lib,配置文件默认放在/usr/local/include,其它的资源文件放在/usr /local/share。

    若步骤5执行的是./configure --prefix=/usr/local/python3.7.1,则可执行文件放在/usr /local/python3.7.1/bin,库文件放在/usr/local/python3.7.1/lib,配置文件放在/usr/local/python3.7.1/include,其它的资源文件放在/usr /local/python3.7.1/share

    步骤9:若步骤5执行./configure --prefix=/usr/local/python3.7.1,则需要添加环境变量。步骤5是./configure的跳过此步骤

    添加环境变量

    PATH=$PATH:$HOME/bin:/usr/local/python3.7.1/bin

    查看环境变量

    echo $PATH

    步骤10:查看安装目录

    可以看到此时python3.7安装到了/usr/local/lib/(若步骤5执行./configure --prefix=/usr/local/python3.7.1,python3.7安装到了/usr/local/python3.7.1/lib/)

    步骤11:测试,输入python3.7

    第二部分:更新python默认指向为python3.7

    步骤1:查看python命令指向

    ls -l /usr/bin | grep python

    步骤2:若如步骤1的图,若要安装python3.4则,由于python3.4为系统自带的,直接使用以下命令并跳过步骤3:

    删除原有链接

    rm /usr/bin/python 

    建立新链接

    ln -s /usr/bin/python3.4 /usr/bin/python

     

    骤3:由于python3.7是自己安装的,不在/usr/bin下,而在usr/local/bin或者/usr/local/python3.7.1/bin下(取决于前面执行的./configure还是./configure --prefix=/usr/local/python3.7.1。因此需要先加一条软链接并且把之前的python命令改为python.bak,同时pip也需要更改。依次执行以下命令

    若python3.7安装时,执行的是./configure,则:

    mv /usr/bin/python /usr/bin/python.bak
    ln -s /usr/local/bin/python3 /usr/bin/python
    mv /usr/bin/pip /usr/bin/pip.bak
    ln -s /usr/local/bin/pip3 /usr/bin/pip

    若python3.7安装时,执行的是./configure --prefix=/usr/local/python3.7.1,则为:

    mv /usr/bin/python /usr/bin/python.bak
    ln -s /usr/local/python3.7.1/bin/python3.7 /usr/bin/python
    mv /usr/bin/pip /usr/bin/pip.bak
    ln -s /usr/local/python3.7.1/bin/pip3 /usr/bin/pip


     步骤4:此时输入python验证

    参考:

    https://blog.csdn.net/u013214212/article/details/81540840

    https://www.jianshu.com/p/2a5cd519e583

    https://www.cnblogs.com/yhongji/p/9383857.html

    展开全文
  • 在网上能搜到很多关于如何用python selenium启动浏览器的例子,但是实际操作后发现还是以下的方式最靠谱,所以记录一下: 1.安装selenium: 首先要有python,然后进入python的scripts目录(有pip.exe),输入pip install...
  • 添加import lxml 安装一下 就可以食用了 看了其他人的回答(我没试用过不清楚),归纳一下: 方法一: pip install lxml 或是 conda install lxml 方法二: soup = BeautifulSoup(html, 'html.parser') ...
  • 目前py2exe支持的最新Python版本是3.6,3.7使用py2exe时会报错 File "C:\Users\Minhaj\AppData\Local\Programs\Python\Python37-32\lib\site-packa ges\py2exe\mf3.py", line 388, in _scan_...
  • 1.如果安装了PyMySQL还是无法import ...2.如果是是安装python2.X上面了,先在CMD中使用 pip uninstall PyMySQL 卸载已装上的PyMySQL。 3.在cmd中使用 pip3 install PyMySQL 重新安装PyMySQL。 4.在cmd中...
  • python3.7 使用cx_Oracle连接Oracle数据库

    千次阅读 2019-10-02 21:09:26
    import cx_Oracle #导入模块db=cx_Oracle.connect('','',"IP:1521/SID") #连接user/passwd@host:端口/instance 转载于:https://www.cnblogs.com/Kinge/p/9914104.html
  • python3.7 使用socket实现TCP简单实现ssh

    千次阅读 2018-07-31 01:16:48
    客户端 import socket client=socket.socket(socket.AF_INET,socket.SOCK_STREAM) client.connect(("localhost",9090)) while True: cmd=input(">... if cmd is not None and ...
  • pyinstaller 是目前被认为比较好使的python程序打包工具。在初次使用pyinstaller...作用:生成不依赖python环境的,可以直接执行的程序,使用Pyinstaller打包python程序为单文件exe 常用的参数: -h 查看帮助 -F ...
  • (注意python版本) PyCharm安装:files->settings->Project Interpreter 右侧边栏点击+号,搜索安装pyinstaller。 注意: 1.最好不要使用Anaconda3的环境,因为默认的库太多了,后期打包会疯狂报错。 2.用...
  • ![图片说明](https://img-ask.csdn.net/upload/202006/18/1592492292_959621.png) ![图片说明](https://img-ask.csdn.net/upload/202006/18/1592492533_847280.png)
  • 我已经在Windows 10上安装了Anaconda,它附带了Spyder和Python 3.6,但是我希望升级到python3.7使用Python 3.7创建Anaconda环境很容易:conda create --name py37 python=3.7或:conda create --name py370 python=...
  • No Python 3.7 installation was detected,Python 3.7卸载失败

    千次阅读 多人点赞 2019-04-08 07:23:37
    No Python 3.7 installation was detected,解决Python 3.7卸载问题问题解决办法 问题 卸载Python 3.7 时,提示No Python 3.7 installation was detected,无法卸载 解决办法 进入C:\Users\Administrator\...
  • 转自:白月黑羽在线教程:http://www.python3.vip/doc/blog/python/home/选择 Python3.6 还是 Python 3.7Python 3.7 已经发布了,目前Python的用户,主要使用的版本 应该是 Python3.6 和 Python2.7 ,那么是不是该转...
  • ubuntu18.04安装python3.7并将python3指向python3.7写在前面为什么要安装python3.7直接把python3.6升级到3.7行不行? 写在前面 由于一些原因,最近被逼无奈不得不使用ubuntu系统办公,在趟过了一条条巨坑之后,...
  • python3.7入门系列一 Win7下安装python3.7

    千次阅读 2019-04-12 22:32:00
    本文为Python3.7入门系列的第一篇,Win7安装下安装python3.7 一、安装python3.7 访问 https://www.python.org/downloads/windows/,下载python3.7的安装程序 双击下载的python-3.7.3-amd64.exe文件进行安装 ...
  • 1、先brew卸载Python3.72、取消brew同python3的连接3、安装Python 3.6.5版本4、然后再切换连接到新安装的python 3.6.5之前Mac装了最新的Python3.7版本,但有些工具还没有支持到。如何从Python 3.7切换回Python 3.6?...
  • python3.7安装

    2018-08-17 10:24:34
    Python3.7 Python3.7Python3.7Python3.7最新版本PythonPython3.7 Python3.7Python3.7Python3.7最新版本Python
  • python3.7sourcecode python3.7从零开始学各章节原始代码 如果不清楚所需要的环境的配置,可以直接执行配置文件requirements.txt。
  • Anaconda中将python 3.7版本退回python 3.6版本

    万次阅读 多人点赞 2019-01-05 14:49:20
    最近在下载tensorflow的时候出现了如下图...经过一番查找资料,发现,原来在2019年,TensorFlow还不支持python3.7,所以,迫于无奈,我只能乖乖把python的版本退回到3.6版本,具体步骤也很简单。就是打开anaconda p...
  • 在Ubuntu18.04中是自带2.7和3.6的,但是我在项目中是使用python3.7的(试了好多升级3.6的办法,就成了一次,而且成功后终端还打不开了,还是建议安装吧),就在这篇博客中看看如何去操作。 安装 sudo apt install ...
  • python3.7

    2019-04-11 11:27:15
    python3.7

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 82,625
精华内容 33,050
关键字:

python3.7使用

python 订阅