精华内容
下载资源
问答
  • 获取库 在基于 x86_64 Debian 的系统上安装 x86 共享库 2007 年在 Ubuntu 论坛上发布的一个非常有用的脚本的镜像。 现在有点过时了。
  • 用来在64位ubuntu中安装32位软件。使用getlibs <软件名> 可以自动下载软件所需的库文件,从而在64位ubuntu安装32位软件。
  • KiCad-GetLibs 这是一个基本的python脚本,可帮助维护来自GitHub的官方KiCad足迹库的本地副本。 新型KiCad足迹库是名为* .pretty的文件夹,并作为单独的存储库存储在 。 您可以使用GitHub库类型直接从GitHub使用...
  • getlibs

    千次阅读 2009-06-26 09:08:00
    getlibs: Automatically solves dependencies for 32-bit programs on 64-bit On 64-bit systems it downloads and installs libraries needed for 32-bit programs and 64-bit programs.On 32-bit systems it
    getlibs: Automatically solves dependencies for 32-bit programs on 64-bit

    On 64-bit systems it downloads and installs libraries needed for 32-bit programs and 64-bit programs.
    On 32-bit systems it downloads and installs libraries needed for 32-bit programs.

    Newest version: 2.06 released on [March 1st, 2008]

    Thank you to the following bug reporters: marararam ViRMiN Cabal elanthis BogusJoe NullHead mooball
    Thank you to the following Beta Testers: Kilz BogusJoe NullHead
    Special thanks to: RavanH

    To install or upgrade:

    Download getlibs-all from
    http://frozenfox.freehostia.com/cappy/


    getlibs works on:
    • All Ubuntu and Debian systems
    • Debian or Ubuntu based distributions (best to use the package name)


    Tip: To install a 32-bit debian package for a program (not a library!) use
    Code:
    sudo dpkg -i --force-all package_name.deb
    Usage Examples:

    getlibs on a program to download all missing libraries:
    Code:
    getlibs /usr/bin/skype
    -----

    Use getlibs to install a 32-bit library using the library name:
    Code:
    getlibs -l libogg.so.0 libSDL-1.2.so.0
    -----

    Use getlibs to install a 32-bit library using the package name:
    Code:
    getlibs -p libqt4-core libqt4-gui
    -----

    Install a 32-bit library file (.deb):
    Code:
    getlibs -i ~/i386_library_1.deb
    -----

    Download and install a 32-bit library file (.deb):
    Code:
    getlibs -w http://mirrors.kernel.org/ubuntu/pool/main/s/sdl-image1.2/libsdl-image1.2_1.2.5-3_i386.deb
    -----

    Other options:

    --apt-file : Uses apt-file to find the packagenames for libraries. The default uses packages.ubuntu.com. This is especially useful for non-ubuntu users.

    --build : converts a 32-bit package to a 64-bit package and installs it. This will only install libraries from a 32-bit package into the correct place! This will not install any binaries from that package! This is very beta.

    --savebuild : use with --build. Saves new 64-bit package to /home/$USER

    --mirror or -m : Use the specified mirror to download from if one is not specified for package

    --verbose : Extra output

    --ldconfig : Runs ldconfig on directories where new libraries are installed

    -64 : Will let apt-get install 64-bit packages for a 64-bit system

    -32 : Left only for compatibility with getlibs v1. 32-bit library installation is the default for all systems.

    --distro : can set as either Ubuntu or Debian. Ubuntu installs to /usr/lib32 and/or /lib32. Debian installs to /emul/ia32-linux/

    --release : can set as hardy gutsy feisty edgy or dapper. Determines what web interface release is used in search.
    展开全文
  • Angular-getlibs.zip

    2019-09-18 10:20:30
    Angular-getlibs.zip,非常简单的前端开发环境,没有node/webpack/etc.https://unpkg.com/getlibs,Angularjs于2016年发布,是Angularjs的重写版。它专注于良好的移动开发、模块化和改进的依赖注入。angular的设计目的...
  • getlibs-2.06-2.noarch.rpm

    2010-11-13 00:42:39
    getlibs-2.06-2.noarch.rpm
  • 首先安张32位库 sudo apt-get install ia32-libs* sudo apt-get install getlibs #如果没有,到这个地址下http://frozenfox.freehostia.com/cappy/ ...然后用getlibs安装依赖库 ,如 sudo dpkg -i --f

    首先安张32位库
    sudo apt-get install ia32-libs*
    sudo apt-get install getlibs #如果没有,到这个地址下 http://frozenfox.freehostia.com/cappy/
    然后就可以安装32位包
    安装时加--force-architecture
    然后用getlibs安装依赖库
    ,如
    sudo dpkg -i --force-architecture cairo-dock*.deb
    sudo getlibs cairo-dock


    终于又可以用32位的软件了.  :wink: 
    mplayer 安装w64看下贴:
    http://forum.ubuntu.org.cn/viewtopic.php?t=94488


    反安装用 sudo dpkg -P 软件名

    sudo dpkg -P cairo-dock



    转载地址:http://forum.ubuntu.org.cn/viewtopic.php?t=96776

    展开全文
  • 主机:WIN7旗舰版 - 64bit 虚拟机版本: 11.0.0 build-2305329 客户机:ubuntu-16.04.2在安装vm tools 时出现的问题,除了共享文件的功能不能正常安装,其余功能都可实现。出现的错误:make: Entering directory ...

    **主机:WIN7旗舰版 - 64bit
    虚拟机版本: 11.0.0 build-2305329
    客户机:ubuntu-16.04.2**

    在安装vm tools 时出现的问题,除了共享文件的功能不能正常安装,其余功能都可实现。

    出现的错误:

    
    make: Entering directory '/tmp/modconfig-O5xscq/vmhgfs-only'
    Using kernel build system.
    /usr/bin/make -C /lib/modules/3.19.0-15-generic/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. \
      MODULEBUILDDIR= modules
    make[1]: Entering directory '/usr/src/linux-headers-3.19.0-15-generic'
      CC [M]  /tmp/modconfig-O5xscq/vmhgfs-only/backdoorGcc64.o
      CC [M]  /tmp/modconfig-O5xscq/vmhgfs-only/message.o
      CC [M]  /tmp/modconfig-O5xscq/vmhgfs-only/dir.o
      CC [M]  /tmp/modconfig-O5xscq/vmhgfs-only/rpcout.o
      CC [M]  /tmp/modconfig-O5xscq/vmhgfs-only/filesystem.o
      CC [M]  /tmp/modconfig-O5xscq/vmhgfs-only/cpName.o
      CC [M]  /tmp/modconfig-O5xscq/vmhgfs-only/request.o
      CC [M]  /tmp/modconfig-O5xscq/vmhgfs-only/module.o
    /tmp/modconfig-O5xscq/vmhgfs-only/dir.c: In function ‘HgfsPackDirOpenRequest’:
    /tmp/modconfig-O5xscq/vmhgfs-only/dir.c:417:26: error: ‘struct file’ has no member named ‘f_dentry’
                          file->f_dentry) < 0) {
                              ^
    /tmp/modconfig-O5xscq/vmhgfs-only/dir.c: In function ‘HgfsDirLlseek’:
    /tmp/modconfig-O5xscq/vmhgfs-only/dir.c:707:32: error: ‘struct file’ has no member named ‘f_dentry’
        struct dentry *dentry = file->f_dentry;
                                    ^
    In file included from /tmp/modconfig-O5xscq/vmhgfs-only/dir.c:39:0:
    /tmp/modconfig-O5xscq/vmhgfs-only/dir.c: In function ‘HgfsReaddirNextEntry’:
    /tmp/modconfig-O5xscq/vmhgfs-only/dir.c:993:31: error: ‘struct file’ has no member named ‘f_dentry’
        si = HGFS_SB_TO_COMMON(file->f_dentry->d_inode->i_sb);
                                   ^
    /tmp/modconfig-O5xscq/vmhgfs-only/module.h:89:62: note: in definition of macro ‘HGFS_SB_TO_COMMON’
    #define HGFS_SB_TO_COMMON(sb)             ((HgfsSuperInfo *)(sb)->s_fs_info)
                                                                  ^
    /tmp/modconfig-O5xscq/vmhgfs-only/dir.c:1082:26: error: ‘struct file’ has no member named ‘f_dentry’
              *entryIno = file->f_dentry->d_inode->i_ino;
                              ^
    In file included from /tmp/modconfig-O5xscq/vmhgfs-only/dir.c:30:0:
    /tmp/modconfig-O5xscq/vmhgfs-only/dir.c:1088:44: error: ‘struct file’ has no member named ‘f_dentry’
              *entryIno = compat_parent_ino(file->f_dentry);
                                                ^
    /tmp/modconfig-O5xscq/vmhgfs-only/./shared/compat_fs.h:120:46: note: in definition of macro ‘compat_parent_ino’
    #define compat_parent_ino(dentry) parent_ino(dentry)
                                                  ^
    /tmp/modconfig-O5xscq/vmhgfs-only/dir.c:1093:52: error: ‘struct file’ has no member named ‘f_dentry’
          *entryIno = HgfsGetFileInode(&entryAttrs, file->f_dentry->d_inode->i_sb);
                                                        ^
    /tmp/modconfig-O5xscq/vmhgfs-only/dir.c: In function ‘HgfsDoReaddir’:
    /tmp/modconfig-O5xscq/vmhgfs-only/dir.c:1173:13: error: ‘struct file’ has no member named ‘f_dentry’
           !(file->f_dentry) ||
                 ^
    /tmp/modconfig-O5xscq/vmhgfs-only/dir.c:1174:13: error: ‘struct file’ has no member named ‘f_dentry’
           !(file->f_dentry->d_inode)) {
                 ^
    scripts/Makefile.build:257: recipe for target '/tmp/modconfig-O5xscq/vmhgfs-only/dir.o' failed
    make[2]: *** [/tmp/modconfig-O5xscq/vmhgfs-only/dir.o] Error 1
    make[2]: ** Esperando que outros processos terminem.
    Makefile:1394: recipe for target '_module_/tmp/modconfig-O5xscq/vmhgfs-only' failed
    make[1]: *** [_module_/tmp/modconfig-O5xscq/vmhgfs-only] Error 2
    make[1]: Leaving directory '/usr/src/linux-headers-3.19.0-15-generic'
    Makefile:120: recipe for target 'vmhgfs.ko' failed
    make: *** [vmhgfs.ko] Error 2
    make: Leaving directory '/tmp/modconfig-O5xscq/vmhgfs-only'
    
    The filesystem driver (vmhgfs module) is used only for the shared folder
    feature. The rest of the software provided by VMware Tools is designed to work
    independently of this feature.
    
    If you wish to have the shared folders feature, you can install the driver by
    running vmware-config-tools.pl again after making sure that gcc, binutils, make
    and the kernel sources for your running kernel are installed on your machine.
    These packages are available on your distribution's installation CD.
    [ Press Enter key to continue ]
    
    The vmxnet driver is no longer supported on kernels 3.3 and greater. Please
    upgrade to a newer virtual NIC. (e.g., vmxnet3 or e1000e)

    解决方法:

    Please ensure that latest Workstation 11 is installed.
    Make sure open-vm-tools is not installed.

    sudo apt-get remove open-vm-tools

    1.Make sure the updates are done:

    sudo apt-get update

    2.Make sure git is installed

    sudo apt-get install git

    3.Run the command to get the tools from repository.

    sudo git clone https://github.com/rasa/vmware-tools-patches.git

    或者

    sudo git clone https://github.com/rasa/vmware-tools-patches

    4.cd to vmware-tools-folder

    cd vmware-tools-patches

    5.Run the patch

    sudo ./download-tools.sh

    6.Run the following patch

    sudo ./untar-and-patch.sh

    7.Run the complie.sh file

    sudo ./compile.sh

    转载于:
    https://communities.vmware.com/thread/509898?start=0&tstart=0

    pillarpeng
    2016.9.16 11:58

    展开全文
  • To pull this off, we're going to need the last Linux version of Adobe Air, and a nifty little tool called "getlibs-all". Oh yeah, and Ubuntu 12.04 installed on a computer. First, go to  Adobe's ...

    Like the title says. Installing Adobe Air natively on Ubuntu 12.04. With 64-bits. Not 32. :)

    If you like programs like TweetdeckDestroy TwitterWriteOrDie, the Wikipedia Desktop app, etc. you will need the abomination known as Adobe Air. And if you use Ubuntu, especially a newer version, installing Adobe Air is not easy or simple. Adobe quit supplying a Linux version a while back, and there hasn't been anything to replace it... we've been stuck trying to crutch along the older version. Thankfully, most Air apps don't require newer versions of Air.

    To pull this off, we're going to need the last Linux version of Adobe Air, and a nifty little tool called "getlibs-all". Oh yeah, and Ubuntu 12.04 installed on a computer.

    First, go to Adobe's archived Air files and grab Adobe AIR 2.6.0 Linux (15.4 MB). Next, grab the file getlibs-all.deb right here. The guy who wrote it doesn't seem to be hosting it anymore, and it's not a huge program, just extremely useful for finding 32-bit libraries for a 64-bit system. You can right-click "getlibs-all.deb" and open with Gdebi Package Manager, and click Install. So far, so good.

    Next, you need to make sure to install libhal-storage1, lib32nss-mdns, and libgnome-keyring0 if it's not installed. Open a terminal and run:

    sudo apt-get install libhal-storage1 libgnome-keyring0 lib32nss-mdns

    It should ask you to install (Y/n) if they're not already there. Let them install, and rejoice. Now, we need to install all the missing 32-bit libraries that it will need. You can't get these from apt-get unless you know what they all are. Simply use the following commands:

    (Note! Since I wrote this, libgnome-keyring0 has been updated to a newer version!)

    sudo getlibs -l libhal-storage.so.1
    sudo getlibs -l libgnome-keyring.so.0.1.1

    Or possibly, if you've updated libgnome-keyring:

    sudo getlibs -l libgnome-keyring.so.0.2.0

    For each one, it will ask if you want to install (a lot of) libraries. Let them all download and install, and we're almost done! Next, we link a couple of libraries (they're there, but not where Air is looking for them). Run the following:

    sudo ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0

    And then run the actual Air installer. In a terminal, cd to the directory you stored "AdobeAIRInstaller.bin" in and run this:

    chmod +x ./AdobeAIRInstaller.bin
    sudo ./AdobeAIRInstaller.bin

    You should get the standard "Installing" messages, and Air should install with no problem! Enjoy!

    I got most of the information here from Adobe's help site, with a little poking prodding and research to put all the rest of the pieces together.

    展开全文
  • ./getLibs.sh ant ant KpeMainNoTraining (并非如此)快车道 运行脚本getLibs下载构建项目所需的依赖库。 请注意,此脚本假定一个类 UNIX 环境(以及zip命令的可访问性)。 此步骤需要一些时间,具体取决于您的...
  • Windows版Hayaemon 免责声明 该软件是非保修和不负责任的。仅当您同意以下条件时,才可以使用该软件。... *通过执行getlibs.bat,外部库的LIB文件将直接保存在项目文件夹下,而DLL文件将保存在Relea
  • 3、下载安装 getlibs-all.deb包 位于这里:http://frozenfox.freehostia.com/cappy/ 终端安装:sudo dpkg -i getlibs-all.deb 4、用getlibs安装其他必须的32位包 sudo getlibs ./AdobeAIRInstaller.bin sudo ...
  • 试题审核 用到的知识点:layui、复杂公式、template模板。 功能:layui按钮点击选择年级学科等信息、模板列表渲染数据、展开与收起、复杂公式转换、全选、初始化数据、批量初始化数据、删除视频、layui表单选择、...
  • Contents 1.1 Overview The Codec Engine framework is designed to work with any xDAIS- compliant algorithm that is delivered in a custom RTSC (Real-Time System Component) package....
  • 前期准备 本爬虫将从网站爬取排名前几的网站,具体前几名可以具体设置,并分别爬取他们的主页,检查是否引用特定库。 github地址 所用到的node主要模块 express 不用多说 ...cheerio 运行在服务器端的jQuery ...
  • getLibs ( ) ; $ ( '.testlist' ) . html ( '' ) ; toggles ( ) ; } ) $ ( '.diffcultyWrap' ) . on ( 'click' , 'span' , function ( e ) { e . stopPropagation ( ) ; gdata . difficulty = ...
  • Boost 库

    2012-10-21 12:02:46
     libs = getlibs()  libskeys = libs.keys()  includes = { }   ENV = os.environ  ARGV = sys.argv[ 1 :]  files = ARGV  if len(files) == 0:  sys.exit()  for f in files:  if f....
  • = 0: return False return True def _getlibs(arch, scheme, ssl_root): '''Returns an array contains all .lib files' path ''' result = [] owt_path = os.path.join(OUT_PATH, r'%s-%s\obj\talk\owt\owt.lib' % ...
  • ubuntu中的Wine详解

    2019-09-25 18:03:41
    自己谷歌getlibs_2.06-0ubuntu1~ppa2_all.deb下载吧,转载的那个链接已失效 sudo dpkg -i getlibs_2.06-0ubuntu1~ppa2_all.deb 2) 安装32bit库: sudo getlibs -p gnome-keyring:i386 3) 链接 sudo mkdir /usr/lib/...
  • C# 名字五格测试

    千次阅读 2019-03-20 17:27:32
    先申明,看着这个罗莊罗大师罗半仙的文章 ... ... 他这是java版本的 我看了下,把它改成了C#版本 直接上代码吧 比较乱 没有优化命名啥的都没动 只是能跑起来 publ...
  • ubuntu安装后的一些操作

    千次阅读 2015-01-10 09:40:10
    sudo dpkg -i getlibs_2.06-0ubuntu1~ppa2_all.deb 2) Install the 32bit library: sudo getlibs -p gnome-keyring:i386 3) Make the symbolic link: sudo mkdir /usr/lib/i386-linux-gnu/pkcs11 sudo ln ...
  • Android官方技术文档翻译——Ant 任务

    千次阅读 2015-03-19 09:15:02
    <getlibs> 计算项目所依赖的库项目列表。它会计算所有直接和间接的依赖项,并生成一个特定顺序的列表。 属性 描述 是否必须 libraryFolderPathOut 该属性名称用于保存...
  • getlibs -i /home/IE6/gnome-keyring/* sudo mkdir /usr/lib/i386-linux-gnu/pkcs11 sudo ln -s /usr/lib32/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so /usr/lib/i386-linux-gnu/pkcs11/ sudo /home/IE6/ies...
  • 一次http请求优化

    千次阅读 2018-08-17 16:33:17
    今天发现一个http请求特别慢,需要耗时7s中...第一步,打开浏览器开发者模式,切换到netword下,在地址栏访问接口地址,查看返回数据和耗时,返现返回数据大概2000k左右,耗时7000ms左右 ...继续排查,查看服务器输出日...
  • 编译Boost——Linux

    2017-10-09 15:17:00
    libs = getlibs() libskeys = libs.keys() includes = {} ENV = os.environ ARGV = sys.argv[1:] files = ARGV if  len(files) == 0:   sys.exit() for  f  in  files:   if  f.lower()....
  • sudo dpkg -i getlibs_2.06-0ubuntu1~ppa2_all.deb 2) Install the 32bit library: sudo getlibs -p gnome-keyring:i386 3) Make the symbolic link: sudo mkdir /usr/lib/i386-linux-gnu/pkcs11 sudo ln ...

空空如也

空空如也

1 2 3 4 5 ... 10
收藏数 187
精华内容 74
热门标签
关键字:

getlibs