精华内容
下载资源
问答
  • H3_API

    2020-12-25 09:19:26
    DGGS_H3 标签(空格分隔):室内定位 1、Distance h3Distance int h3Distance(H3Index origin, H3Index h3); 返回两个索引对应的网格cell单元的距离 若是查询距离失败,则返回负值 2、Hierarchical grid functions ...

    DGGS_H3

    标签(空格分隔):室内定位

    1、Distance

    h3Distance

    int h3Distance(H3Index origin, H3Index h3);
    

    返回两个索引对应的网格cell单元的距离
    若是查询距离失败,则返回负值

    2、Hierarchical grid functions

    h3ToParent

    H3Index h3ToParent(H3Index h, int parentRes);
    

    Returns the parent (coarser) index containing h.

    h3ToChildren

    void h3ToChildren(H3Index h, int childRes, H3Index *children);
    

    Populates children with the indexes contained by h at resolution childRes. children must be an array of at least size maxH3ToChildrenSize(h, childRes).

    maxH3ToChildrenSize

    int maxH3ToChildrenSize(H3Index h, int childRes);
    

    Returns the size of the array needed by h3ToChildren for these inputs.

    compact

    int compact(const H3Index *h3Set, H3Index *compactedSet, const int numHexes);
    

    Compacts the set h3Set of indexes as best as possible, into the array compactedSet. compactedSet must be at least the size of h3Set in case the set cannot be compacted.

    Returns 0 on success.

    uncompact

    int uncompact(const H3Index *compactedSet, const int numHexes, H3Index *h3Set, const int maxHexes, const int res);
    

    Uncompacts the set compactedSet of indexes to the resolution res. h3Set must be at least of size maxUncompactSize(compactedSet, numHexes, res).

    Returns 0 on success.

    maxUncompactSize

    int maxUncompactSize(const H3Index *compactedSet, const int numHexes, const int res)
    

    Returns the size of the array needed by uncompact.
    #3、 Indexing functions

    filterinputoutputs
    geoToH3lat/lonH3Index
    h3ToGeoH3Indexcell center point in lat/lon
    h3ToGeoBoundaryH3Indexcell boundary in lat/lon
    h3ToComponentsH3Indexcomponents
    kRingH3Indexsurrounding H3Index
    hexRangeH3Indexsurrounding H3Index, in order

    geoToH3

    H3Index geoToH3(const GeoCoord *g, int res);
    

    Indexes the location at the specified resolution.

    Returns 0 on error.

    h3ToGeo

    void h3ToGeo(H3Index h3, GeoCoord *g);
    

    Finds the centroid of the index.

      ##h3ToGeoBoundary
    
    void h3ToGeoBoundary(H3Index h3, GeoBoundary *gp);
    

    Finds the boundary of the index.
    Unix Command Line Examples

    • find the index for coordinates at resolution 5

      echo 40.689167 -74.044444 | geoToH3 5

    • output the cell center point for H3Index 845ad1bffffffff

      echo 845ad1bffffffff | h3ToGeo

    • output the cell boundary for H3Index 845ad1bffffffff

      echo 845ad1bffffffff | h3ToGeoBoundary

    • find the components for the H3Index 845ad1bffffffff

      echo 845ad1bffffffff | h3ToComponents

    • output all indexes within distance 1 of the H3Index 845ad1bffffffff

      echo 845ad1bffffffff | kRing 1

    • output all hexagon indexes within distance 2 of the H3Index 845ad1bffffffff

      echo 845ad1bffffffff | hexRange 2

    Note that the filters h3ToGeo and h3ToGeoBoundary take optional arguments that allow them to generate kml output. See the header comments in the corresponding source code files for details.
    #4、 Index inspection functions

    h3GetResolution

    int h3GetResolution(H3Index h);
    

    Returns the resolution of the index.

    h3GetBaseCell

    int h3GetBaseCell(H3Index h);
    

    Returns the base cell number of the index.

    stringToH3

    H3Index stringToH3(const char *str);
    

    Converts the string representation to H3Index (uint64_t) representation.

    Returns 0 on error.

    h3ToString

    void h3ToString(H3Index h, char *str, size_t sz);
    

    Converts the H3Index representation of the index to the string representation. str must be at least of length 17.

    h3IsValid

    int h3IsValid(H3Index h);
    

    Returns non-zero if this is a valid H3 index.

    h3IsResClassIII

    int h3IsResClassIII(H3Index h);
    

    Returns non-zero if this index has a resolution with Class III orientation.

    h3IsPentagon

    int h3IsPentagon(H3Index h);
    

    Returns non-zero if this index represents a pentagonal cell.
    #5、 Miscellaneous H3 functions

    degsToRads

    double degsToRads(double degrees);
    

    Converts degrees to radians.

    radsToDegs

    double radsToDegs(double radians);
    

    Converts radians to degrees.

    hexAreaKm2

    double hexAreaKm2(int res);
    

    Average hexagon area in square kilometers at the given resolution.

    hexAreaM2

    double hexAreaM2(int res);
    

    Average hexagon area in square meters at the given resolution.

    edgeLengthKm

    double edgeLengthKm(int res);
    

    Average hexagon edge length in kilometers at the given resolution.

    edgeLengthM

    double edgeLengthM(int res);
    

    Average hexagon edge length in meters at the given resolution.

    numHexagons

    int64_t numHexagons(int res);
    

    Number of unique H3 indexes at the given resolution.
    #6、 Neighbor traversal functions

    kRing

    void kRing(H3Index origin, int k, H3Index* out);
    

    k-rings produces indices within k distance of the origin index.

    k-ring 0 is defined as the origin index, k-ring 1 is defined as k-ring 0 and
    all neighboring indices, and so on.

    Output is placed in the provided array in no particular order. Elements of
    the output array may be left zero, as can happen when crossing a pentagon.

    maxKringSize

    int maxKringSize(int k);
    

    Maximum number of indices that result from the kRing algorithm with the given k.

    kRingDistances

    void kRingDistances(H3Index origin, int k, H3Index* out, int* distances);
    

    k-rings produces indices within k distance of the origin index.

    k-ring 0 is defined as the origin index, k-ring 1 is defined as k-ring 0 and
    all neighboring indices, and so on.

    Output is placed in the provided array in no particular order. Elements of
    the output array may be left zero, as can happen when crossing a pentagon.

    hexRange

    int hexRange(H3Index origin, int k, H3Index* out);
    

    hexRange produces indexes within k distance of the origin index.
    Output behavior is undefined when one of the indexes returned by this
    function is a pentagon or is in the pentagon distortion area.

    k-ring 0 is defined as the origin index, k-ring 1 is defined as k-ring 0 and
    all neighboring indexes, and so on.

    Output is placed in the provided array in order of increasing distance from
    the origin.

    Returns 0 if no pentagonal distortion is encountered.

    hexRangeDistances

    int hexRangeDistances(H3Index origin, int k, H3Index* out, int* distances);
    

    hexRange produces indexes within k distance of the origin index.
    Output behavior is undefined when one of the indexes returned by this
    function is a pentagon or is in the pentagon distortion area.

    k-ring 0 is defined as the origin index, k-ring 1 is defined as k-ring 0 and
    all neighboring indexes, and so on.

    Output is placed in the provided array in order of increasing distance from
    the origin. The distances in hexagons is placed in the distances array at
    the same offset.

    Returns 0 if no pentagonal distortion is encountered.

    hexRanges

    int hexRanges(H3Index* h3Set, int length, int k, H3Index* out);
    

    hexRanges takes an array of input hex IDs and a max k-ring and returns an
    array of hexagon IDs sorted first by the original hex IDs and then by the
    k-ring (0 to max), with no guaranteed sorting within each k-ring group.

    Returns 0 if no pentagonal distortion was encountered. Otherwise, output
    is undefined

    hexRing

    int hexRing(H3Index origin, int k, H3Index* out);
    

    Produces the hollow hexagonal ring centered at origin with sides of length k.

    Returns 0 if no pentagonal distortion was encountered.
    #7、 Region functions

    polyfill

    void polyfill(const GeoPolygon* geoPolygon, int res, H3Index* out);
    

    polyfill takes a given GeoJSON-like data structure and preallocated,
    zeroed memory, and fills it with the hexagons that are contained by
    the GeoJSON-like data structure.

    The current implementation is very primitive and slow, but correct,
    performing a point-in-poly operation on every hexagon in a k-ring defined
    around the given geofence.

    maxPolyfillSize

    int maxPolyfillSize(const GeoPolygon* geoPolygon, int res);
    

    maxPolyfillSize returns the number of hexagons to allocate space for when
    performing a polyfill on the given GeoJSON-like data structure.

    h3SetToLinkedGeo

    void h3SetToLinkedGeo(const H3Index* h3Set, const int numHexes, LinkedGeoPolygon* out);
    

    Create a LinkedGeoPolygon describing the outline(s) of a set of hexagons.
    It is the responsibility of the caller to call destroyLinkedPolygon on the
    populated linked geo structure, or the memory for that structure will
    not be freed.

    It is expected that all hexagons in the set will have the same resolution.
    Using different resolution hexagons is not recommended.

    At present, if the set of hexagons is not contiguous, this function
    will return a single polygon with multiple outer loops. The correct GeoJSON
    output should only have one outer loop per polygon. It appears that most
    GeoJSON consumers are fine with the first input format, but it’s less correct
    than the second format. The function may be updated to produce
    multiple polygons in the future.

    destroyLinkedPolygon

    void destroyLinkedPolygon(LinkedGeoPolygon* polygon);
    

    Free all allocated memory for a linked geo structure. The caller is
    responsible for freeing memory allocated to input polygon struct.

    #8、 Unidirectional edge functions

    h3IndexesAreNeighbors

    int h3IndexesAreNeighbors(H3Index origin, H3Index destination);
    

    Returns whether or not the provided H3Indexes are neighbors.

    Returns 1 if the indexes are neighbors, 0 otherwise.

    getH3UnidirectionalEdge

    H3Index getH3UnidirectionalEdge(H3Index origin, H3Index destination);
    

    Returns a unidirectional edge H3 index based on the provided origin and
    destination.

    Returns 0 on error.

    h3UnidirectionalEdgeIsValid

    int h3UnidirectionalEdgeIsValid(H3Index edge);
    

    Determines if the provided H3Index is a valid unidirectional edge index.

    Returns 1 if it is a unidirectional edge H3Index, otherwise 0.

    getOriginH3IndexFromUnidirectionalEdge

    H3Index getOriginH3IndexFromUnidirectionalEdge(H3Index edge);
    

    Returns the origin hexagon from the unidirectional edge H3Index.

    getDestinationH3IndexFromUnidirectionalEdge

    H3Index getDestinationH3IndexFromUnidirectionalEdge(H3Index edge);
    

    Returns the destination hexagon from the unidirectional edge H3Index.

    getH3IndexesFromUnidirectionalEdge

    void getH3IndexesFromUnidirectionalEdge(H3Index edge, H3Index* originDestination);
    

    Returns the origin, destination pair of hexagon IDs for the given edge ID, which are placed at originDestination[0] and
    originDestination[1] respectively.

    getH3UnidirectionalEdgesFromHexagon

    void getH3UnidirectionalEdgesFromHexagon(H3Index origin, H3Index* edges);
    

    Provides all of the unidirectional edges from the current H3Index. edges must be of length 6,
    and the number of undirectional edges placed in the array may be less than 6.

    getH3UnidirectionalEdgeBoundary

    void getH3UnidirectionalEdgeBoundary(H3Index edge, GeoBoundary* gb);
    

    Provides the coordinates defining the unidirectional edge.

    展开全文
  • h3c交换机清空配置命令

    千次阅读 2021-01-16 21:11:08
    h3c交换机清空配置命令H3C CAS云计算管理平台融合了华三通信在网络安全领域的积累,通过对IEEE 802.1Qbg(EVB)标准的支持,为虚拟机在安全、可视、可监管的环境下运行奠定了基础。下面是小编收集的h3c交换机清空配置...

    h3c交换机清空配置命令

    H3C CAS云计算管理平台融合了华三通信在网络安全领域的积累,通过对IEEE 802.1Qbg(EVB)标准的支持,为虚拟机在安全、可视、可监管的环境下运行奠定了基础。下面是小编收集的h3c交换机清空配置命令,希望大家认真阅读!

    一.用户配置:

    system-view

    [H3C]super password H3C 设置用户分级密码

    [H3C]undo super password 删除用户分级密码

    [H3C]localuser bigheap 123456 1 Web网管用户设置,1(缺省)为管理级用户,缺省admin,admin

    [H3C]undo localuser bigheap 删除Web网管用户

    [H3C]user-interface aux 0 只支持0

    [H3C-Aux]idle-timeout 2 50 设置超时为2分50秒,若为0则表示不超时,默认为5分钟

    [H3C-Aux]undo idle-timeout 恢复默认值

    [H3C]user-interface vty 0 只支持0和1

    [H3C-vty]idle-timeout 2 50 设置超时为2分50秒,若为0则表示不超时,默认为5分钟

    [H3C-vty]undo idle-timeout 恢复默认值

    [H3C-vty]set authentication password 123456 设置telnet密码,必须设置

    [H3C-vty]undo set authentication password 取消密码

    [H3C]display users 显示用户

    [H3C]display user-interface 显示用户界面状态

    二.系统IP配置:

    [H3C]vlan 20

    [H3C]management-vlan 20

    [H3C]interface vlan-interface 20 创建并进入管理VLAN

    [H3C]undo interface vlan-interface 20 删除管理VLAN接口

    [H3C-Vlan-interface20]ip address 192.168.1.2 255.255.255.0 配置管理VLAN接口静态IP地址(缺省为192.168.0.234)

    [H3C-Vlan-interface20]undo ip address 删除IP地址

    [H3C-Vlan-interface20]ip gateway 192.168.1.1 指定缺省网关(默认无网关地址)

    [H3C-Vlan-interface20]undo ip gateway

    [H3C-Vlan-interface20]shutdown 关闭接口

    [H3C-Vlan-interface20]undo shutdown 开启

    [H3C]display ip 显示管理VLAN接口IP的相关信息

    [H3C]display interface vlan-interface 20 查看管理VLAN的接口信息

    debugging ip 开启IP调试功能

    undo debugging ip

    三.DHCP客户端配置:

    [H3C-Vlan-interface20]ip address dhcp-alloc 管理VLAN接口通过DHCP方式获取IP地址

    [H3C-Vlan-interface20]undo ip address dhcp-alloc 取消

    [H3C]display dhcp 显示DHCP客户信息

    debugging dhcp-alloc 开启DHCP调试功能

    undo debugging dhcp-alloc

    四.端口配置:

    [H3C]interface Ethernet0/3

    [H3C-Ethernet0/3]shutdown

    [H3C-Ethernet0/3]speed 100 速率,可为10,100,1000和auto(缺省)

    [H3C-Ethernet0/3]duplex full 双工,可为half,full和auto(缺省) 光口和汇聚后不能配置

    [H3C-Ethernet0/3]flow-control 开启流控,默认为关闭

    [H3C-Ethernet0/3]broadcast-suppression 20 设置抑制广播百分比为20%,可取5,10,20,100,缺省为100,同时组播和未知单播也受此影响

    [H3C-Ethernet0/3]loopback internal 内环测试

    [H3C-Ethernet0/3]loopback external 外环测试,需插接自环头,必须为全双工或者自协商模式

    [H3C-Ethernet0/3]port link-type trunk 设置链路的类型为trunk,可为access(缺省),trunk

    [H3C-Ethernet0/3]port trunk pvid vlan 20 设置20为该trunk的缺省VLAN,默认为1

    (trunk线路两端的PVID必须一致)

    [H3C-Ethernet0/3]port access vlan 20 将当前access端口加入指定的VLAN

    [H3C-Ethernet0/3]port trunk permit vlan all 允许所有的VLAN通过当前的trunk端口,可多次使用该命令

    [H3C-Ethernet0/3]mdi auto 设置以太端口为自动监测,normal(缺省)为直通线,across为交叉线

    [H3C]link-aggregation Ethernet 0/1 to Ethernet 0/4 将1-4口加入汇聚组,1为主端口,两端需要同时配置,设置了端口镜像以及端口隔离的端口无法汇聚

    [H3C]undo link-aggregation Ethernet 0/1 删除该汇聚组

    [H3C]link-aggregation mode egress 配置端口汇聚模式为根据目的MAC地址进行负荷分担,可选为 ingress,egress和both,缺省为both

    [H3C]monitor-port Ethernet 0/2 将该端口设置为镜像端口,必须先设置镜像端口,删除时必须先删除被镜像端口,而且它们不能同在一个端口,该端口不能在汇聚组中,设置新镜像端口时,新取代旧,被镜像不变

    [H3C]mirroring-port Ethernet 0/3 to Ethernet 0/4 both 将端口3和4设置为被镜像端口,both为同时监控接收和发送的报文,inbound表示仅监控接收的报文,outbound表示仅监控发送的报文

    [H3C]display mirror

    [H3C]display interface Ethernet 0/3

    reset counters 清除所有端口的统计信息

    [H3C]display link-aggregation Ethernet 0/3 显示端口汇聚信息

    [H3C-Ethernet0/3]virtual-cable-test 诊断该端口的电路状况

    五.VLAN配置:

    [H3C]vlan 2

    [H3C]undo vlan all 删除除缺省VLAN外的所有VLAN,缺省VLAN不能被删除

    [H3C-vlan2]port Ethernet 0/4 to Ethernet 0/7 将4到7号端口加入到VLAN2中,此命令只能用来加access端口,不能用来增加trunk或者hybrid端口

    [H3C-vlan2]port-isolate enable 打开VLAN内端口隔离特性,不能二层转发,默认不启用该功能

    [H3C-Ethernet0/4]port-isolate uplink-port vlan 2 设置4为VLAN2的隔离上行端口,用于转发二层数据,只能配置一个上行端口,若为trunk,则建议允许所有VLAN通过,隔离不能与汇聚同时配置

    [H3C]display vlan all 显示所有VLAN的详细信息

    S1550E支持基于端口的VLAN,通过创建不同的user-group来实现,一个端口可以属于多个user-group,不属于同一个user-group的端口不能互相通信,最多支持50个user-group

    [H3C]user-group 20 创建user-group 20,默认只存在user-group 1

    [H3C-UserGroup20]port Ethernet 0/4 to Ethernet 0/7 将4到7号端口加入到VLAN20中,初始时都属于user-group 1中

    [H3C]display user-group 20 显示user-group 20的相关信息

    六.集群配置:

    S2100只能作为成员交换机加入集群中,加入后系统名改为"集群名_成员编号.原系统名"的格式.

    即插即用功能通过两个功能实现: 集群管理协议MAC组播地址协商和管理VLAN协商

    [H3C]cluster enable 启用群集功能,缺省为启用

    [H3C]cluster 进入群集视图

    [H3C-cluster]administrator-address H-H-H name switch H-H-H为命令交换机的MAC,加入switch集群

    [switch_1.H3C-cluster]undo administrator-address 退出集群

    [H3C]display cluster 显示集群信息

    [H3C]management-vlan 2 集群报文只能在管理VLAN中转发,同一集群需在同一个管理VLAN中,需在建立集群之前指定管理VLAN

    debugging cluster

    七.QoS配置:

    QoS配置步骤:设置端口的优先级,设置交换机信任报文的优先级方式,队列调度,端口限速

    [H3C-Ethernet0/3]priority 7 设置端口优先级为7,默认为0

    [H3C]priority-trust cos 设置交换机信任报文的优先级方式为cos(802.1p优先级,缺省值),还可以设为dscp方式(dscp优先级方式)

    [H3C]queue-scheduler hq-wrr 2 4 6 8 设置队列调度算法为HQ-WRR(默认为WRR),权重为2,4,6,8

    [H3C-Ethernet0/3]line-rate inbound 29 将端口进口速率限制为2Mbps,取1-28时,速率为rate*8*1024/125,即64,128,192...1.792M;29-127时,速率为(rate-27)*1024,即2M,3M,4M...100M,千兆时可继续往下取,128-240时,速率为(rate-115)*8*1024,即104M,112M,120M...1000M

    [H3C]display queue-scheduler 显示队列调度模式及参数

    [H3C]display priority-trust 显示优先级信任模式

    八.系统管理:

    [H3C]mac-address blackhole H-H-H vlan 1 在VLAN1中添加黑洞MAC

    [H3C]mac-address static H-H-H interface Ethernet 0/1 vlan 1 在VLAN1中添加端口一的一个mac

    [H3C]mac-address timer aging 500 设置MAC地址表的老化时间为500s

    [H3C]display mac-address

    [H3C]display arp

    [H3C]mac-address port-binding H-H-H interface Ethernet 0/1 vlan 1 配置端口邦定

    [H3C]display mac-address port-binding

    [H3C]display saved-configuration

    [H3C]display current-configuration

    save

    [H3C]restore default 恢复交换机出厂默认配置,恢复后需重启才能生效

    [H3C]display version

    reboot

    [H3C]display device

    [H3C]sysname bigheap

    [H3C]info-center enable 启用系统日志功能,缺省情况下启用

    [H3C]info-center loghost ip 192.168.0.3 向指定日志主机(只能为UNIX或LINUX,不能为Windows)输出信息,需先开启日志功能,缺省关闭

    [H3C]info-center loghost level 8 设置系统日志级别为8,默认为5.级别说明:1.emergencies 2.alerts 3.critical 4.errors 5.warnings 6.notifications 7.informational 8.debugging

    terminal debugging 启用控制台对调试信息的显示,缺省控制台为禁用

    terminal logging 启用控制台对日志信息的显示,缺省控制台为启用

    terminal trapping 启用控制台对告警信息的显示,缺省控制台为启用

    [H3C]display info-center 显示系统日志的配置和缓冲区记录的信息

    [H3C]display logbuffer 显示日志缓冲区最近记录的指定数目的日志信息

    [H3C]display trapbuffer 显示告警缓冲区最近记录的指定数目的日志信息

    reset logbuffer 清除日志缓冲区的信息

    reset trapbuffer 清除告警缓冲区的信息

    九.网络协议配置:

    NDP即是邻居发现协议,S1550E只能开启或关闭NDP,无法配置,默认有效保留时间为180s,NDP报文发送的间隔60s

    [H3C]ndp enable 缺省情况下是开启的

    [H3C-Ethernet0/3]ndp enable 缺省情况下开启

    [H3C]display ndp 显示NDP配置信息

    [H3C]display ndp interface Ethernet 0/1 显示指定端口NDP发现的'邻居信息

    debugging ndp interface Ethernet 0/1

    HABP协议即Huawei Authentication Bypass Protocol,华为鉴权旁路协议,是用来解决当交换机上同时配置了802.1x和HGMPv1/v2时,未经授权和认证的端口上将过滤HGMP报文,从而使管理设备无法管理下挂的交换机的问题。交换机启动HABP后,将忽略802.1x认证。

    HABP包括服务器和客户端,由服务器定期发送请求,客户端进行应答,并向下进行转发,服务器一般启动在管理设备上,客户机在下挂设备上启动,1550E只支持客户端。

    [H3C]habp enable 启动HABP特性,缺省即启动,启动后即缺省为客户机模式

    debugging habp 启动HABP调试功能

    NTDP即邻居拓扑发现协议,用来收集网络拓扑信息的协议,与NDP协议一起工作,用于集群管理,S1550E的配置主要包括开启与关闭功能能,开启与关闭调试功能

    [H3C]ntdp enable 缺省情况下为开启的

    [H3C-Ethernet0/3]ntdp enable 缺省情况下为使能

    debugging ntdp

    十.SNMP配置:

    S1550E支持SNMPv1,SNMPv2c,主要配置包括:设置团体名,设置系统信息,设置Trap目标主机的地址,允许或禁止发送Trap,禁止SNMP Agent的运行

    [H3C]snmp-agent community read bigheap 设置bigheap团体,且为只读访问

    [H3C]snmp-agent max-size 1600 设置Agent能接受/发送的SNMP消息包最大为1600字节,缺省1500

    [H3C]snmp-agent sys-info contact #27345 location Diqiu version v2c 设置系统信息,版本为v2c,缺省情况下联系信息为"R&D Hangzhou, H3C Technologies co.,Ltd.",位置为"Hangzhou China",v2c版本

    [H3C]undo snmp-agent 禁止SNMP Agent的运行,若配置任何SNMP命令将重新启动SNMP Agent

    [H3C]display snmp-agent community read

    [H3C]display snmp-agent sys-info contact

    [H3C]display snmp-agent sys-info location

    [H3C]display snmp-agent sys-info version

    debugging snmp-agent packet|process

    十一.IGMP Snooping配置:

    IGMP Snooping是运行在二层交换机上的组播约束机制,用于管理和控制组播组.主要负责建立和维护二层MAC地址表,同时根据建立的组播地址表来转发路由器下发的组播报文,如果不运行IGMP Snooping,则组播报文将在二层网络中广播

    IGMP Snooping配置包括:启动和关闭IGMP Snooping,配置路由器端口老化时间,配置最大响应查询时间,配置组播组成员端口老化时间,配置端口快速离开,调试功能

    [H3C]igmp-snooping 启用IGMP Snooping功能,默认为关闭

    [H3C]igmp-snooping router-aging-time 500 配置路由器端口老化时间为500s,默认为105s

    [H3C]igmp-snooping max-response-time 15 配置最大响应查询时间为15s,默认为10s

    [H3C]igmp-snooping host-aging-time 300 配置组播组成员端口老化时间为300s,默认为260s

    [H3C-Ethernet0/3]igmp-snooping fast-leave 配置快速离开,若收到离开报文,则立即删除端口,不询问

    [H3C]display igmp-snooping configuration 显示配置信息

    [H3C]display igmp-snooping statistics 显示包统计信息

    [H3C]display igmp-snooping group vlan 2 显示VLAN2中IP组播组和MAC组播组的信息

    reset igmp-snooping statistics 清楚统计信息

    debugging igmp-snooping

    十二.系统调试:

    debugging all 开启所有调试开关,此命令为协议调试开关

    terminal debugging 终端调试开关,打开开关,默认为关闭

    debugging drv 主要显示报文的实际内容,默认为关闭

    [H3C]display debugging 显示调试开关状态

    十三.802.1x配置:

    [H3C-Ethernet0/3]dot1x 开启802.1x特性,也可在系统视图下使用,使用后全局开启,也可用 interface参数开启指定端口的802.1x特性,缺省全关闭,要启用802.1x,全局和端口的都需开启

    [H3C-Ethernet0/3]dot1x port-control unauthorized-force 设置工作模式为强制非授权模式,使用 模式与dot1x命令相同,默认为auto,即通过了认证才可以访问,还有authorized-force,为强制授权 模式,允许用户访问

    [H3C-Ethernet0/3]dot1x port-method portbased 设置接入控制方式为基于端口的,使用模式与 dot1x命令相同,默认为macbase,基于MAC地址的

    [H3C-Ethernet0/3]dot1x max-user 10 设置端口接入用户的数量最大为10个,使用模式与dot1x命令 相同,默认为128,取值范围为1-128

    [H3C]dot1x authentication-method eap 设置802.1x的用户认证方法为EAP,即EAP中继,直接用EAP报 文发送到服务器,需服务器支持

    [H3C-Ethernet0/3]dot1x re-authenticate 开启802.1x重认证功能使交换机以一定时间间隔周期性 的进行认证,使用模式同dot1x命令,缺省情况下所有端口该特性都关闭

    [H3C]dot1x timer handshake-period 20 reauth-period 7200 quiet-period 30 tx-period 20 supp- timeout 20 server-timeout 200 设置802.1x认证的定时器,handshake-period为认证成功后, 系统以此间隔为周期发送握手请求报文(相当于keepalive消息发送间隔),1-1024s,默认15s.

    reauth-period为重认证超时定时器,1-86400s,默认3600s.

    quiet-period为用户认证失败后,Autheticator的静默定时器,静默后再处理认证,10-120s,默认60s.

    tx-period为传送超时定时器,Supplicant未成功发送认证应答报文,则重发认证请求,10-120s,默认 为30s.

    supp-timeout为认证超时定时器,Supplicant未成功响应,则重发认证请求,10-120s,默认30s.

    server-timeout为服务器未成功响应的超时定时器,100-300s,默认100s.

    reset dot1x statistics 清除802.1x统计信息

    [H3C]display dot1x statistics 显示802.1x的配置,运行情况和统计信息

    debugging dot1x 打开802.1x的相关模块的调试信息

    十四.RADIUS配置:

    [H3C]radius scheme system 进入system方案,其各项值为缺省值,1550E只支持默认方案

    [H3C-radius-system]primary authentication 10.110.1.1 1812 设置RADIUS服务器地址和UDP端口 号,默认情况下,system方案中服务器IP地址为空,UDP端口号为1812

    [H3C-radius-system]key authentication 123 指示RADIUS加密共享密钥为123,默认无共享密钥

    [H3C-radius-system]timer 10 设置RADIUS服务器响应超时定时器,1-10s,默认为5s

    [H3C-radius-system]retry 10 设置RADIUS服务器最大响应重试次数为10,1-20次,默认为5次

    [H3C]display radius 显示radius方案信息

    debugging radius packet 打开radius报文调试开关

    【h3c交换机清空配置命令】相关文章:

    展开全文
  • Uber h3算法

    2021-04-13 19:45:20
    H3地理空间索引系统是一个离散的全局网格系统,该系统由具有层次结构索引的球形多精度六边形拼贴组成。在球形外接二十面体的平面上创建六边形网格系统,然后使用反面为中心的多面体结构投影将网格单元投影到球体的...

    Uber的六角分层空间指数

    概述

    关于H3

    H3是一个针对地球的空间划分和空间索引系统。

    H3地理空间索引系统是一个离散的全局网格系统,该系统由具有层次结构索引的球形多精度六边形拼贴组成。在球形外接二十面体的平面上创建六边形网格系统,然后使用反面为中心的多面体结构投影将网格单元投影到球体的表面。



    名词解释

    Icosahedron(正二十面体)

    正二十面体(Regular twenty aspect) 是由20个等边三角形所组成的正多面体,共有12个顶点,30条棱,20个面。为五个柏拉图多面体之一。

    在几何学上,二十面体是具有20个面的多面体。



    Hexagons(正六边形)

    正六边形就是在平面几何学中,具有六条相等的边和六个相等内角的多边形。各内角相等,六边相等。由多边形外角和等于360度,推出一个内角为180-(360/6)=120度,所以内角为120度。



    侏儒投影



    它从地球中心查看表面数据。

    • 心射地图投影显示所有的大圆为直线。
    • 最小的变形发生在切点处。
    • 不到一半的球体可以投影到有限的地图上。
    • 由于子午线和赤道是大圆,它们始终显示为直线。



    动态投影(Fuller Map)

    用一个正二十面体内切地球,并且是多面体的顶点均映射到海洋区域,然后将地球使用Gnomonic projection 投影到多面体上,将多面体展成一个平面,保证大陆不会被分裂开。



    地球地图,可在一张完整的图片中显示地理信息,而不会破坏任何大陆轮廓,也不会对陆地的相对形状或大小造成任何可见的扭曲。

    可以忽略不计的失真的世界投影,可以一目了然地准确显示全球信息,例如人类迁徙方式和自然资源的分布。

    动态最大值=动态+最大值+张力='事半功倍'




    理论讲解

    投影



    对于地图投影,我们选择使用以二十面体面为中心的侏儒投影。它从地球作为一个球体投射到二十面体的二十面体柏拉图式实体。基于二十面体的地图投影会产生二十个单独的二维平面,而不是单个平面。二十面体可以通过多种方式展开,每次生成二维图。但是,H3不会展开二十面体以构建其网格系统,而是将其网格放置在二十面体的面自身上,从而形成了测地线离散的全局网格系统

    单元格(cell shape)

    使用六边形作为单元格形状对于H3至关重要



    H3用于在单个二十面体的面上创建网格。

    H3网格是通过在地球上布置122个基本单元而构建的,每个面有10个单元。有些单元格包含多个面。由于不可能仅用六边形平铺二十面体,因此我们选择引入十二个五边形,每个二十面体顶点各一个。这些顶点是使用R. Buckminster Fuller的球形二十面体方向进行定位的,它将所有顶点都放置在水中。这有助于避免五边形在我们的工作中浮出水面。


    细分



    H3使用户可以将区域细分为越来越小的六边形

    H3支持十六种分辨率。每个较精细的分辨率所具有的像元的面积为较粗糙分辨率的七分之一。六边形不能完美地细分为七个六边形,因此,较细的单元仅近似包含在父单元中。

    这些子单元格的标识符可以很容易地被截断,以较粗的分辨率找到它们的祖先单元格,从而实现高效索引。

    解析度

    使用孔径7分辨率间距(分辨率是指每个像元的下一个更精细的分辨率网格中的像元数)来创建分辨率高于0的每个后续分辨率。随着分辨率的提高,单位长度将按\(\ sqrt {7} \)进行缩放,并且每个六边形在下一个较粗的分辨率下(以二十面体测量)具有六边形的面积的(1 / 7th \)。除了分辨率为0的基本像元之外,H3还提供了15种更精细的网格分辨率。分辨率最高的分辨率为15,其像元面积小于1 \(m ^ 2 \)。此处提供了一张表格,其中详细列出了每种H3分辨率的平均像元面积。

    H3解析度六角平均面积(平方千米)六角形平均边缘长度(公里)唯一索引数
    04,250,546.84770001,107.712591000122
    1607,220.9782429418.676005500842
    286,745.8540347158.2446558005,882
    312,392.264862159.81085794041,162
    41,770.323551722.606379400288,122
    5252.90336458.5444082762,016,842
    636.12905213.22948277214,117,882
    75.16129321.22062975998,825,162
    80.73732760.461354684691,776,122
    90.10533250.1743756684,842,432,842
    100.01504750.06590780733,897,029,882
    110.00214960.024910561237,279,209,162
    120.00030710.0094155261,660,954,464,122
    130.00004390.00355989311,626,681,248,842
    140.00000630.00134857581,386,768,741,882
    150.00000090.000509713569,707,381,193,162

    五角大楼




    请注意,不可能用六边形完全平铺球体/二十面体。二十面体六边形网格的每个分辨率在每个分辨率下都必须恰好包含12个五边形,其中一个五边形位于每个二十面体顶点的中心。

    旋转的

    每个栅格分辨率相对于下一个较粗分辨率旋转〜19.1°。在每个连续的分辨率下,旋转在逆时针和顺时针之间交替,因此每个分辨率将具有以下两种可能的方向之一:II类或III类(使用R. Buckminster Fuller创造的术语)。组成分辨率为0的基本单元是II类。





    编码

    H3系统为每个单元分配一个唯一的层次结构索引。分辨率r单元的H3索引以适当的分辨率0基本单元号开始。这之后是r个数字0-6的序列,其中第i个数字d i指定以较粗分辨率数字d 1至d i-1指示的像元为中心的7个像元之一。

    基本单元号

    第一个H3分辨率(分辨率0)由122个单元(110个六边形和12个二十面体顶点居中的五边形)组成,称为基本单元。选择它们是为了捕获尽可能多的球形二十面体对称性。这些基本单元根据其中心点的纬度分配了从0到121的数字。基本单元0具有最北端的中心点,而基本单元121具有最南端的中心点。

    分辨率(N> 0)单元格号

    局部六边形坐标系分配给每个分辨率为0的基本单元,并用于定向该基本单元的所有分层索引子单元。在每种分辨率下,数字0-6的分配使用中央位置索引安排。在12个五边形单元格的情况下,将以所有分辨率删除由子数字1生成的索引层次结构。

    子六边形线性地小于其父六边形。

    离散六边形平面网格系统自然具有3个坐标轴,彼此间隔120°。对于三个坐标轴ijk,我们称这种系统为ijk坐标系





    H3Index的位布局

    H3Index是H3索引的整数表示。

    H3Index的布局如下表所示。“保留/边缘”字段的解释因索引的模式而异。


    0x300F0x300E --- 0x300B0x300A --- 0x30080x3007 ---- 0x30040x3003 --- 0x200D0x200C --- 0x0000
    模式保留/边缘解析度基本单元数字1 ----数字15


    模式:模式1是H3单元(六角形)索引,模式2是H3单向边缘(六角形A->六角形B)索引,模式3计划是双向边缘(六角形A->六角形B)。模式0被保留,指示无效的H3索引。

    模式1( 0x300A --- 0x3008 ):保留3位,

    模式2( 0x300A --- 0x3008 :3位表示要遍历的单元格的边1-6,

    缺点

    失真

    由于子单元格仅包含在其中,因此截断过程会产生固定量的形状失真。仅当执行单元标识符的截断时才会出现这种失真。当以特定分辨率索引位置时,单元格边界是精确的。

    失真

    个人感觉,由于H3不是一个完美的数学模型,而是一个地理模型,因此在真正的实现中,使用了大量的固定映射表格,如正二十面体的面的位置,base cell的序号已经他们的邻接关系等;

    实现说明

    H3索引系统是开源的,可以在GitHub上。在H3库本身是用C语言编写,并绑定可用于不同的语言。建议使用绑定来开始使用H3。Uber已经发布了JavaJavaScript的绑定,而社区也为更多的语言提供了绑定。Python和Go的绑定即将推出。

    指数



    邻接



    袖珍的



    边缘



    应用领域


    流量分析

    地理空间分片

    地理可视化

    展开全文
  • H3CNE综合实验

    千次阅读 多人点赞 2021-11-16 16:19:55
    文章目录H3CNE综合实验实验拓扑实验要求实验步骤1.配置IP地址略2.配置链路聚合3.配置vlan地址和接口类型略4.配置边缘端口5.配置MSTP6.配置VRRP7.配置DHCP服务8.配置OSPF9.配置默认路由并引入到OSPF10.配置PPP-MP和...

    H3CNE综合实验

    实验拓扑

    在这里插入图片描述

    实验要求

    1. 按图示配置IP地址
    2. SW1 和 SW2 之间的直连链路配置链路聚合
    3. 公司内部业务网段为Vlan10 和Vlan20;Vlan10是市场部,Vlan20是技术部,要求对Vlan进行命名以便识别;PC1属于Vlan10,PC2属于Vlan20,Vlan30用于SW1和SW2建立OSPF邻居;Vlan111为SW1和R1的互联Vlan,Vlan222为SW2和R2的互联Vlan
    4. 所有交换机相连的端口配置为Trunk,允许相关流量通过
    5. 交换机连接PC的端口配置为边缘端口
    6. 各个交换机上配置mstp,mst域为nidaye,vlan10映射到instance1,vlan20映射到instance2,要求vlan10流量默认走SW1,vlan20的流量默认走SW2
    7. SW1和SW2配置VRRP互为备份,监听上行接口,避免抢占
    8. 在SW1上配置DHCP服务,为Vlan10和Vlan20的PC动态分配IP地址、网关和DNS地址;要求Vlan10的网关是192.168.1.252,Vlan20的网关是192.168.2.253
    9. 配置OSPF实现公司内部网络全网互通,ABR的环回口宣告进骨干区域;业务网段不允许出现协议报文
    10. R1上配置默认路由指向互联网,并引入到OSPF
    11. R1通过双线连接到互联网,配置PPP-MP,并配置双向chap验证
    12. 配置easy ip,只有业务网段192.168.1.0/24和192.168.2.0/24的数据流可以通过R1访问互联网
    13. R1开启TELNET远程管理,使用用户 telnet登录,密码nidaye123456,只允许技术部远程管理R1

    实验步骤

    1.配置IP地址略

    2.配置链路聚合

    SW1
    #创建聚合组
     int Bridge-Aggregation 1
      port link-type trunk
      port trunk permit vlan 10 20 30
    #把端口加入到聚合组
     int g1/0/1
      port link-aggregation group 1
     int g1/0/2
      port link-aggregation group 1
    #
    SW2配置类似
    

    注意,先把链路聚合配好了再去配trunk

    3.配置vlan地址和接口类型略

    4.配置边缘端口

    SW3
    #
    interface GigabitEthernet1/0/3
     stp edged-port
    #
    interface GigabitEthernet1/0/4
     stp edged-port
    #
    

    5.配置MSTP

    SW1、SW2、SW3
    #配置mst域
    stp region-configuration
     region-name nidaye
     instance 1 vlan 10 
     instance 2 vlan 20 
     active region-configuration  这里别忘记激活
    #
    
    SW1
    #
    stp instance 1 root primary
    stp instance 2 root secondary
    #
    
    SW2
    #
    stp instance 1 root secondary
    stp instance 2 root primary
    #
    

    6.配置VRRP

    SW1
    #
    track 1 interface GigabitEthernet1/0/4   监听上行接口
    interface Vlan-interface10
     vrrp vrid 10 virtual-ip 192.168.1.254
     vrrp vrid 10 priority 120
     vrrp vrid 10 track 1 priority reduced 30   降低优先级避免发生抢占
    interface Vlan-interface20
     vrrp vrid 20 virtual-ip 192.168.2.254
    #
    
    SW2
    #
    track 1 interface GigabitEthernet 1/0/4   监听上行接口
    interface Vlan-interface10
     vrrp vrid 10 virtual-ip 192.168.1.254
    interface Vlan-interface20
     vrrp vrid 20 virtual-ip 192.168.2.254
     vrrp vrid 20 priority 120
     vrrp vrid 20 track 1 priority reduced 30   降低优先级避免发生抢占
    #
    

    7.配置DHCP服务

    SW1
    #
    dhcp enable   开启dhcp服务
    dhcp server ip-pool 1  创建dhcp地址池
     gateway-list 192.168.1.252
     network 192.168.1.0 mask 255.255.255.0
     dns-list 8.8.8.8
    #
    dhcp server ip-pool 2
     gateway-list 192.168.2.253
     network 192.168.2.0 mask 255.255.255.0
     dns-list 8.8.8.8
    #
    

    配置完后,在PC1和PC2中开启DHCP就可以获取到IP地址

    在这里插入图片描述

    8.配置OSPF

    SW1
    #
    ospf 1 router-id 10.1.1.11
    业务网段不能出现协议报文,所以要配置静默接口
     silent-interface Vlan-interface10   
     silent-interface Vlan-interface20
     area 0.0.0.1
      network 10.0.0.6 0.0.0.0   将接口宣告进区域可以避免掩码计算出错
      network 10.1.1.11 0.0.0.0
      network 10.1.2.1 0.0.0.0
      network 192.168.1.252 0.0.0.0
      network 192.168.2.252 0.0.0.0
    #
    --------------------------------------------------------------------------------
    SW2
    #
    ospf 1 router-id 10.1.1.12
    业务网段不能出现协议报文,所以要配置静默接口
     silent-interface Vlan-interface10
     silent-interface Vlan-interface20
     area 0.0.0.1
      network 10.0.0.10 0.0.0.0   将接口宣告进区域可以避免掩码计算出错
      network 10.1.1.12 0.0.0.0
      network 10.1.2.2 0.0.0.0
      network 192.168.1.253 0.0.0.0
      network 192.168.2.253 0.0.0.0
    #
    --------------------------------------------------------------------------------
    R1
    #
    ospf 1 router-id 10.1.1.1
     area 0.0.0.0
      network 10.0.0.1 0.0.0.0   将接口宣告进区域可以避免掩码计算出错
      network 10.0.0.14 0.0.0.0
      network 10.1.1.1 0.0.0.0
     area 0.0.0.1
      network 10.0.0.5 0.0.0.0
    #
    注意R1和R2之间的那两个接口宣告进同一个区域,不然邻居起不来
    --------------------------------------------------------------------------------
    R2
    #
    ospf 1 router-id 10.1.1.2
     area 0.0.0.0
      network 10.0.0.2 0.0.0.0   将接口宣告进区域可以避免掩码计算出错
      network 10.0.0.18 0.0.0.0
      network 10.1.1.2 0.0.0.0
     area 0.0.0.1
      network 10.0.0.9 0.0.0.0
    #
    --------------------------------------------------------------------------------
    R3
    #
    ospf 1 router-id 10.1.1.3
    业务网段不能出现协议报文,所以要配置静默接口
     silent-interface GigabitEthernet0/2
     area 0.0.0.0
      network 10.0.0.13 0.0.0.0   将接口宣告进区域可以避免掩码计算出错
      network 10.0.0.17 0.0.0.0
      network 10.1.1.3 0.0.0.0
      network 192.168.3.254 0.0.0.0
    #
    

    可以用display ospf peer查看邻居是否都起来了

    R1有三个邻居
    [R1]dis ospf peer
    
             OSPF Process 1 with Router ID 10.1.1.1
                   Neighbor Brief Information
    
     Area: 0.0.0.0        
     Router ID       Address         Pri Dead-Time  State             Interface
     10.1.1.2        10.0.0.2        1   35         Full/DR           GE0/1
     10.1.1.3        10.0.0.13       1   35         Full/DR           GE0/2
    
     Area: 0.0.0.1        
     Router ID       Address         Pri Dead-Time  State             Interface
     10.1.1.11       10.0.0.6        1   34         Full/DR           GE0/0
    --------------------------------------------------------------------------------
    R2有三个邻居
    [R2]dis ospf peer
    
             OSPF Process 1 with Router ID 10.1.1.2
                   Neighbor Brief Information
    
     Area: 0.0.0.0        
     Router ID       Address         Pri Dead-Time  State             Interface
     10.1.1.3        10.0.0.17       1   33         Full/DR           GE0/1
     10.1.1.1        10.0.0.1        1   34         Full/BDR          GE0/2
    
     Area: 0.0.0.1        
     Router ID       Address         Pri Dead-Time  State             Interface
     10.1.1.12       10.0.0.10       1   30         Full/DR  
    -------------------------------------------------------------------------------- 
    R3有两个邻居
    [R3]dis ospf peer
    
             OSPF Process 1 with Router ID 10.1.1.3
                   Neighbor Brief Information
    
     Area: 0.0.0.0        
     Router ID       Address         Pri Dead-Time  State             Interface
     10.1.1.1        10.0.0.14       1   38         Full/BDR          GE0/0
     10.1.1.2        10.0.0.18       1   30         Full/BDR  
    --------------------------------------------------------------------------------
    SW1有两个邻居
    [SW1]dis ospf peer
    
             OSPF Process 1 with Router ID 10.1.1.11
                   Neighbor Brief Information
    
     Area: 0.0.0.1        
     Router ID       Address         Pri Dead-Time  State             Interface
     10.1.1.12       10.1.2.2        1   40         Full/BDR          Vlan30
     10.1.1.1        10.0.0.5        1   40         Full/BDR 
    -------------------------------------------------------------------------------- 
    SW2有两个邻居
    [SW2]dis ospf peer
    
             OSPF Process 1 with Router ID 10.1.1.12
                   Neighbor Brief Information
    
     Area: 0.0.0.1        
     Router ID       Address         Pri Dead-Time  State             Interface
     10.1.1.11       10.1.2.1        1   34         Full/DR           Vlan30
     10.1.1.2        10.0.0.9        1   36         Full/BDR 
    

    9.配置默认路由并引入到OSPF

    R1
    #
    ip route-static 0.0.0.0 0 202.100.1.1
    #
    ospf 1 router-id 10.1.1.1
     default-route-advertise
    #
    

    配置完后,其他运行OSPF的路由器也能学习到外部默认路由,注意OSPF外部路由的默认优先级为150

    [R2]display ip routing-table 
    
    Destinations : 28       Routes : 29
    
    Destination/Mask   Proto   Pre Cost        NextHop         Interface
    0.0.0.0/0          O_ASE2  150 1           10.0.0.1        GE0/2
    ......
    --------------------------------------------------------------------------------
    [R3]display ip routing-table 
    
    Destinations : 28       Routes : 32
    
    Destination/Mask   Proto   Pre Cost        NextHop         Interface
    0.0.0.0/0          O_ASE2  150 1           10.0.0.14       GE0/0
    ......
    --------------------------------------------------------------------------------
    [SW1]display ip routing-table 
    
    Destinations : 36       Routes : 38
    
    Destination/Mask   Proto   Pre Cost        NextHop         Interface
    0.0.0.0/0          O_ASE2  150 1           10.0.0.5        Vlan111
    ......
    --------------------------------------------------------------------------------
    [SW2]display ip routing-table 
    
    Destinations : 36       Routes : 38
    
    Destination/Mask   Proto   Pre Cost        NextHop         Interface
    0.0.0.0/0          O_ASE2  150 1           10.1.2.1        Vlan30
    ......
    --------------------------------------------------------------------------------
    

    10.配置PPP-MP和双向CHAP验证

    R1
    #创建MP组
    interface MP-group1
     ip address 202.100.1.2 255.255.255.252
    #把接口加入到组
    interface Serial1/0
     ppp mp MP-group1
    interface Serial2/0
     ppp mp MP-group1
    #internet配置类似
    --------------------------------------------------------------------------------
    R1
    #创建对端用于ppp验证的用户
    local-user internet class network
     password simple nidaye123456
     service-type ppp
    #
    interface Serial1/0
     ppp authentication-mode chap   认证模式为chap
     ppp chap password simple nidaye123456
     ppp chap user internet 指定本端用户
    #
    interface Serial2/0
     ppp authentication-mode chap   认证模式为chap
     ppp chap password simple nidaye123456
     ppp chap user internet 指定本端用户
    #
    --------------------------------------------------------------------------------
    internet
    #创建对端用于ppp验证的用户
    local-user r1 class network
     password simple nidaye123456
     service-type ppp
    #
    interface Serial1/0
     ppp authentication-mode chap   认证模式为chap
     ppp chap password simple nidaye123456
     ppp chap user internet 指定本端用户
    #
    interface Serial2/0
     ppp authentication-mode chap   认证模式为chap
     ppp chap password simple nidaye123456
     ppp chap user internet 指定本端用户
    #
    

    11.配置easy ip

    R1
    #创建基本acl,允许两个业务网段访问internet
    acl basic 2000
     rule 0 permit source 192.168.1.0 0.0.0.255
     rule 5 permit source 192.168.2.0 0.0.0.255
    #
    interface MP-group1
     nat outbound 2000   将acl应用到配置了IP地址的接口上
    #
    

    配置完后,只有PC1和PC2能ping通internet,PC3ping不通internet

    <PC1>ping 100.1.1.1
    Ping 100.1.1.1 (100.1.1.1): 56 data bytes, press CTRL_C to break
    56 bytes from 100.1.1.1: icmp_seq=0 ttl=253 time=2.000 ms
    56 bytes from 100.1.1.1: icmp_seq=1 ttl=253 time=5.000 ms
    56 bytes from 100.1.1.1: icmp_seq=2 ttl=253 time=2.000 ms
    56 bytes from 100.1.1.1: icmp_seq=3 ttl=253 time=2.000 ms
    56 bytes from 100.1.1.1: icmp_seq=4 ttl=253 time=4.000 ms
    
    --- Ping statistics for 100.1.1.1 ---
    5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss
    round-trip min/avg/max/std-dev = 2.000/3.000/5.000/1.265 ms
    --------------------------------------------------------------------------------
    <PC2>ping 100.1.1.1
    Ping 100.1.1.1 (100.1.1.1): 56 data bytes, press CTRL_C to break
    56 bytes from 100.1.1.1: icmp_seq=0 ttl=253 time=2.000 ms
    56 bytes from 100.1.1.1: icmp_seq=1 ttl=253 time=6.000 ms
    56 bytes from 100.1.1.1: icmp_seq=2 ttl=253 time=7.000 ms
    56 bytes from 100.1.1.1: icmp_seq=3 ttl=253 time=8.000 ms
    56 bytes from 100.1.1.1: icmp_seq=4 ttl=253 time=5.000 ms
    
    --- Ping statistics for 100.1.1.1 ---
    5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss
    round-trip min/avg/max/std-dev = 2.000/5.600/8.000/2.059 ms
    --------------------------------------------------------------------------------
    <PC3>ping 100.1.1.1
    Ping 100.1.1.1 (100.1.1.1): 56 data bytes, press CTRL_C to break
    Request time out
    Request time out
    Request time out
    Request time out
    Request time out
    
    --- Ping statistics for 100.1.1.1 ---
    5 packet(s) transmitted, 0 packet(s) received, 100.0% packet loss
    
    

    12.配置telnet服务

    R1
    #
    telnet server enable   开启telnet服务
    local-user telnet class manage   创建远程管理用户
     password simple nidaye123456
     service-type telnet
     authorization-attribute user-role level-15
    #
    user-interface vty 0 4
     authentication-mode scheme   认证模式为AAA
     user-role level-15
    #创建基本acl,只允许技术部远程管理R1
    acl basic 2001
     rule 0 permit source 192.168.2.0 0.0.0.255
    #将acl应用到telnet服务上
    telnet server acl 2001
    #
    配置完后PC2可以telnet到R1上,由于模拟器中PC不支持telnet,所以我就不做演示了,大家可以用路由器替换掉PC,在路由器上可以实现telnet登录
    

    这个综合实验基本上运用到了NE阶段的所有内容,学习并不是一蹴而就的,还是要多做实验才能熟练,将理论与实践相结合!

    展开全文
  • + --- a/arch/arm/dts/Makefile +++ b/arch/arm/dts/Makefile @@ -331,7 +331,8 @@ dtb-$(CONFIG_MACH_SUN8I_H3) += \ sun8i-h3-nanopi-m1.dtb \ sun8i-h3-nanopi-m1-plus.dtb \ sun8i-h3-nanopi-neo.dtb \ -sun8i-...
  • h3型云服务器

    2021-08-10 07:03:52
    h3型云服务器 内容精选换一换高性能计算型实例每一个vCPU都对应一个英特尔® 至强® 可扩展处理器核心的超线程,主要适用于高性能计算业务场景,能够提供海量并行计算资源和高性能的基础设施服务,达到高性能计算和...
  • H3C 堆叠

    千次阅读 多人点赞 2021-07-03 15:59:23
    智能堆叠 ,是指将多台支持堆叠特性的交换机设备组合在一起,从逻辑上组合成一台交换设备。
  • 如何初始化配置H3C交换机

    千次阅读 2021-01-14 06:07:57
    近日由于工作需要,新配置了一批H3C 3100交换机。现将配置过程中的方法总结下1、连接配置电缆1.1 将配置电缆的DB-9孔式插头接到要对交换机进行配置的PC的串口上;1.2 将配置电缆的 RJ-45 的一端连到交换机的 Console...
  • H3C IRF MAD检测实战

    千次阅读 2021-05-13 17:21:32
    ​一、 引言 IRF(Intelligent Resilient Framework,智能弹性架构)是H3C自主研发的软件虚拟化技术,也是H3C数据中心解决方案的核心技术,使用这种虚拟化技术可以集合多台设备的硬件资源和软件处理能力,实现多台...
  • 自助式服务门户自助式服务门户是H3Cloud OS云操作系统供租户申请、使用、管理云资源的门户,通过自助服务门户租住能够申请X86虚拟机、云硬盘、云防火墙、云负载均衡、云网络、公网IP等。图 H3Cloud OS云操作系统登录...
  • 3、进入设置选择基本设置,将无线网络功能打开,确保在范围找到无线的SSID。4、设置SSID及工作模式和加密模式,选择为桥接模式,选择不加密。5、加密方式设置为wep加密方式,进行管理。6、设置...
  • 全志H3编译Linux-4.14 BSP

    2021-07-12 21:32:17
    全志H3编译Linux-4.14 BSP 1 安装交叉编译器 访问此处下载地址的toolchain目录,下载交叉编译器arm-cortexa9-linux-gnueabihf-4.9.3.tar.xz,然后解压编译器: $ mkdir -p /opt/FriendlyARM/toolchain $ tar xf arm-...
  • 9.全志H3-修改DDR的速度

    千次阅读 2020-12-21 23:11:33
    22:16:35 +0800) Allwinner Technology CPU: Allwinner H3 (SUN8I 1680) Model: FriendlyElec NanoPi H3 DRAM: 512 MiB CPU Freq: 1008MHz MMC: SUNXI SD/MMC: 0, SUNXI SD/MMC: 1 *** Warning - bad CRC, using ...
  • 组蛋白3(H3)位于细胞核内,与染色质结合。与H2A、H2B和H4一起存在于核小体中。 名称 H3 |组蛋白H3(兔抗体)(核标记) Cat# AS10-710 规格 50ul ...
  • 本文介紹全志H3 recovery制作過程,代碼基於friendly arm的Nano pi M1開發代碼。一,編譯打包運行配置腳本: . ./buildroot/script/mksetup.sh1,芯片類型選擇sun8iw7p1,平台選擇linux,開發板我這里就選擇了...
  • 文章目录前言一、使用Linux-3.4 BSP准备工作安装交叉...NanoPi M1 Plus:Allwinner H3 搭建编译环境、编译Uboot、编译Linux Kernel–失败Kernel跑不起来  经过上一篇的尝试,我放弃了编译主线uboot和Kernel。 前言  
  • H3C 交换机恢复出厂设置以及知识积累

    千次阅读 多人点赞 2021-06-10 21:16:33
    网络设备重新启动、擦除配置文件该如何操作?
  • 提前安装好“Virtual Box” 发现问题 上面的意思是:“详细信息请参见日志文件’D:\HCL\H3C Cloud Lab.exe.log’ ” 那我们去这个文件看看是出现了什么问题? 打开文件我们可以看到一下信息 解决问题 ...
  • H3C路由器telnet进去以后重启的命令是什么啊?在用户模式下输入,reboot建议在重启之前进行设备配置的保存。避免丢失最近的配置操作。保存设备配置命令为:在用户模式下输入,save输入以上两种命令时,均会自动弹出...
  • SDK概述1....2.硬件资源:H3 主控 box 方案板 + 电源适配器;串口线,HDMI/cvbs 线,以太网线,USB 线一条(根据具体的接口需求)等;PC:编译或者烧录开发用(linux 系统),也可以安装虚拟机运行 XP 进行...
  • H3C认证网络工程师(H3CNE) 1.sysname 更改系统名 2.display clock 显示系统时间 3.clock datetime 修改系统时间 4.display cur 显示当前运行的配置 5.save 保存配置 6.reset save-configuration 恢复出厂设置 7.pwd ...
  • 全志h3详细刷机教程

    千次阅读 2020-12-23 13:30:02
    全志h3刷机必备: 1、下载H3的安卓刷机固件 2、USB数据线公对公一根 3、镊子一把(或者牙签)资料下载:全志H3芯片安卓刷机固件网址链接(通用版):全志刷机工具网址链接:全志刷机工具认证文件网址链接:...
  • h3c交换机常用命令

    千次阅读 2020-12-23 17:53:12
    &ltH3C&gt system-view# 进入AUX用户界面视图。[H3C] user-interface aux 0# 设置通过Console口登录交换机的用户进行Password认证。[H3C-ui-aux0] authentication-mode password# 设置用...
  • 一.配置NVMe硬盘的前期准备1. 安装Intel NVMe VROC秘钥模块,该选件全称为H3C-RS3M1NVS-Intel NVMe VROC模块是一个硬件安装到主板上的NVMe SSD VROC模块接口上。Intel NVMe VROC秘钥模块一共有如下三个版本:标准版...
  • H3DNet论文阅读笔记

    2021-11-09 16:41:38
    H3DNet: 3D Object Detection Using Hybrid Geometric Primitives 论文链接:https://arxiv.org/pdf/2006.05682.pdf 代码链接(pytorch):https://github.com/zaiweizhang/H3DNet 1.介绍 属于VoteNet的提优...
  • luser-quidway]service-type telnet level 1 [Quidway]super password level 3 simple h3cpass 以下是测试: Username:quidway Password: %Apr 2 05:41:24 2000 Quidway SHELL/5/LOGIN: ss login from Aux0/0 su ...
  • 文章目录1. 介绍2. 用console口登录交换机并配置3. 创建本地用户4. 本地用户能够通过telnet、SSH登录 1. 介绍 新交换机,通过Console口进入交换机,配置Console登录密码,并创建用户,退出Console登录后,用户通过...
  • 型号:H3C S5552S-EI-D-H3 把设备的电源下电,接着再上电,然后按Ctrl+B(反复同时按) EXTENDED BOOT MENU //扩展启动菜单 1. Download image to flash //下载图像到flash 2. Select image to boot //选择要引导...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 278,907
精华内容 111,562
关键字:

H3

友情链接: DSLT-crude.zip