精华内容
下载资源
问答
  • 华为交换机配置常用命令
    千次阅读
    2021-01-17 02:41:42

    华为交换机配置常用命令

    一、配置软件和硬件

    1、配置(Console)电缆连接

    配置电缆是一根8芯屏蔽电缆,一端是压接的RJ-45连接器,插入交换机的Console口里;另一端则同时带有一个DB-9(孔)和DB-25(孔)连接器

    2、配置软件及设置

    使用系统自带的“超级终端”,运行“hypertrm”程序,设置终端参数,参数要求:波特率为9600,数据位为8,奇偶校验为无,停止位为1,流量控制为无,选择终端仿真为VT100。

    二、常用命令

    1、用户模式:交换机启动后在控制台直接按回车就进入用户模式(远程管理telnet 交换机ip时需要口令)。

    ?--帮助

    quit ――退出当前模式返回上一级

    ping ip-address --测试网络连通性

    telnet ip-address --从交换机登陆其它设备super --从用户模式进入特权模式

    2、特权模式:进入特权模式一般需要口令,可以防止非法登陆交换机

    display current --显示当前运行的配置

    save --保存当前运行的配置

    reboot --重启交换机

    display mac ――显示mac地址表

    display inteface ethernet 0/1 ――查看以太网口状态

    system-view --从特权模式进入全局模式

    3、全局模式:更改配置

    a.进入以太网口配置模式及相关配置

    [switchone]interface ethernet 0/1

    [switchone-Ethernet0/1]shutdown/undo shutdown 关闭/打开接口[switchone-Ethernet0/1]port link-type access/trunk 接口类型设为untagged端口(默认)/tagged端口(用于上行口和级联口)

    access端口发出和接收的帧不带vlan标记,即untagged端口

    trunk端口发出和接收的帧一般要带vlan标记,即tagged端口

    设为tagged口后,还要做以下操作:

    [switchone-Ethernet0/1]port trunk permit vlan 225 to 250

    这条命令是允许有vlan标记225到250的帧上传

    b.进入vlan配置模式(为了便于操作,不用在接口模式下配置access,而在vlan 模式下进行相关操作)

    [switchone]vlan 225

    [switchone-vlan225] port Ethernet 1/1 将ethernet 1/1加入vlan225 c.设置super口令

    [switchone]super password simple 2403h 特权口令为2403h

    三、标准配置:

    更多相关内容
  • 1、开始建立本地配置环境,将主机的串口通过配置电缆与以太网交换机的Console连接。在主机上运行终端仿真程序(如Windows的超级终端等),设置终端通信参数为:波特率为9600bit/s、8位数据位、1位停止位、无校验和无...

    1、开始建立本地配置环境,将主机的串口通过配置电缆与以太网交换机的Console口连接。

    在主机上运行终端仿真程序(如Windows的超级终端等),设置终端通信参数为:波特率为9600bit/s、8位数据位、1位停止位、无校验和无流控,并选择终端类型为VT100。

    以太网交换机上电,终端上显示以太网交换机自检信息,自检结束后提示用户键入回车,之后将出现命令行提示符(如)。

    键入命令,配置以太网交换机或查看以太网交换机运行状态。需要帮助可以随时键入"?"

    2、命令视图

    (1)用户视图(查看交换机的简单运行状态和统计信息):与交换机建立连接即进入

    (2)系统视图(配置系统参数)[Quidway]:在用户视图下键入system-view

    (3)以太网端口视图(配置以太网端口参数)[Quidway-Ethernet0/1]:在系统视图下键入interface ethernet 0/1

    (4)VLAN视图(配置VLAN参数)[Quidway-Vlan1]:在系统视图下键入vlan 1

    (5)VLAN接口视图(配置VLAN和VLAN汇聚对应的IP接口参数)[Quidway-Vlan-interface1]:在系统视图下键入interface vlan-interface 1

    (6)本地用户视图(配置本地用户参数)[Quidway-luser-user1]:在系统视图下键入local-user user1

    (7)用户界面视图(配置用户界面参数)[Quidway-ui0]:在系统视图下键入user-interface

    3、其他命令

    设置系统时间和时区clock time Beijing  add 8

    clock datetime 12:00:00 2005/01/23

    设置交换机的名称[Quidway]sysname TRAIN-3026-1[TRAIN-3026-1]

    配置用户登录[Quidway]user-interface vty 0 4

    [Quidway-ui-vty0]authentication-mode scheme

    创建本地用户[Quidway]local-user huawei

    [Quidway-luser-huawei]password simple huawei

    [Quidway-luser-huawei] service-type telnet level 3

    4、VLAN配置方法

    『配置环境参数』

    SwitchA端口E0/1属于VLAN2,E0/2属于VLAN3

    『组网需求』

    把交换机端口E0/1加入到VLAN2 ,E0/2加入到VLAN3

    数据配置步骤

    『VLAN配置流程』

    (1)缺省情况下所有端口都属于VLAN 1,并且端口是access端口,一个access端口只能属于一个vlan;

    (2)如果端口是access端口,则把端口加入到另外一个vlan的同时,系统自动把该端口从原来的vlan中删除掉;

    (3)除了VLAN1,如果VLAN XX不存在,在系统视图下键入VLAN XX,则创建VLAN XX并进入VLAN视图;如果VLAN XX已经存在,则进入VLAN视图。

    【SwitchA相关配置】

    方法一:

    (1)创建(进入)vlan2

    [SwitchA]vlan 2

    (2)将端口E0/1加入到vlan2

    [SwitchA-vlan2]port ethernet 0/1

    (3)创建(进入)vlan3

    [SwitchA-vlan2]vlan 3

    (4)将端口E0/2加入到vlan3

    [SwitchA-vlan3]port ethernet 0/2

    方法二:

    (1)创建(进入)vlan2

    [SwitchA]vlan 2

    (2)进入端口E0/1视图

    [SwitchA]interface ethernet 0/1

    (3)指定端口E0/1属于vlan2

    [SwitchA-Ethernet1]port access vlan 2

    (4)创建(进入)vlan3

    [SwitchA]vlan 3

    (5)进入端口E0/2视图

    [SwitchA]interface ethernet 0/2

    (6)指定端口E0/2属于vlan3

    [SwitchA-Ethernet2]port access vlan 3

    测试验证

    (1)使用命令disp cur可以看到端口E0/1属于vlan2,E0/2属于vlan3;

    (2)使用display interface Ethernet 0/1可以看到端口为access端口,PVID为2;

    (3)使用display interface Ethernet 0/2可以看到端口为access端口,PVID为3

    5、交换机IP地址配置

    功能需求及组网说明

    『配置环境参数』

    三层交换机SwitchA有两个端口ethetnet 0/1、ethernet 0/2,分别属于vlan 2、vlan 3;

    以vlan 2的三层接口地址分别是1.0.0.1/24作为PC1的网关;

    以vlan 3的三层接口地址分别是2.0.0.1/24作为PC2的网关;

    『组网需求』

    PC1和PC2通过三层接口互通

    【SwitchA相关配置】

    (1)创建(进入)vlan2

    [Quidway]vlan 2

    (2)将端口E0/1加入到vlan2

    [Quidway-vlan2]port ethernet 0/1

    (3)进入vlan2的虚接口

    [Quidway-vlan2]interface vlan 2

    (4)在vlan2的虚接口上配置IP地址

    [Quidway-Vlan-interface2]ip address 1.0.0.1 255.255.255.0

    (5)创建(进入)vlan3

    [Quidway]vlan 3

    (6)将E0/2加入到vlan3

    [Quidway-vlan3]port ethernet 0/2

    (7)进入vlan3的虚接口

    [Quidway-vlan3]interface vlan 3

    (8)在vlan3的虚接口上配置IP地址

    [Quidway-Vlan-interface3]ip address 2.0.0.1 255.255.255.0

    测试验证

    (1)PC1和PC2都可以PING通自己的网关

    (2)PC1和PC2可以相互PING通

    6、端口的trunk配置

    『配置环境参数』

    (1)SwitchA 端口E0/1属于vlan10,E0/2属于vlan20,E0/3与SwitchB端口E0/3互连

    (2)SwitchB 端口E0/1属于vlan10,E0/2属于vlan20,E0/3与SwitchA端口E0/3互连

    『组网需求』

    (1)要求SwitchA的vlan10的PC与SwitchB的vlan10的PC互通

    (2)要求SwitchA的vlan20的PC与SwitchB的vlan20的PC互通

    数据配置步骤

    【SwitchA相关配置】

    (1)创建(进入)vlan10

    [SwitchA] vlan 10

    (2)将E0/1加入到vlan10

    [SwitchA-vlan10]port Ethernet 0/1

    (3)创建(进入)vlan20

    [SwitchA]vlan 20

    (4)将E0/2加入到vlan20

    [SwitchA-vlan20]port Ethernet 0/2

    (5)实际当中一般将上行端口设置成trunk属性,允许vlan透传

    [SwitchA-Ethernet0/3]port link-type trunk

    (6)允许所有的vlan从E0/3端口透传通过,也可以指定具体的vlan值

    [SwitchA-Ethernet0/3]port trunk permit vlan all

    【SwitchB相关配置】

    (1)创建(进入)vlan10

    [SwitchB] vlan 10

    (2)将E0/1加入到vlan10

    [SwitchB-vlan10]port Ethernet 0/1

    (3)创建(进入)vlan20

    [SwitchB]vlan 20

    (4)将E0/2加入到vlan20

    [SwitchB-vlan20]port Ethernet 0/2

    (5)实际当中一般将上行端口设置成trunk属性,允许vlan透传

    [SwitchB-Ethernet0/3]port link-type trunk

    (7)允许所有的vlan从E0/3端口透传通过,也可以指定具体的vlan值

    [SwitchB-Ethernet0/3]port trunk permit vlan all

    【补充说明】

    (1)如果一个端口是trunk端口,则该端口可以属于多个vlan;

    (2)缺省情况下trunk端口的PVID为1,可以在端口模式下通过命令port trunk pvid vlan vlanid 来修改端口的PVID;

    (3)如果从trunk转发出去的数据报文的vlan id和端口的PVID一致,则该报文的VLAN信息会被剥去,这点在配置trunk端口时需要注意。

    (4)一台交换机上如果已经设置了某个端口为hybrid端口,则不可以再把另外的端口设置为trunk端口。

    (5)一般情况下最好指定端口允许通过哪些具体的VLAN,不要设置允许所有的VLAN通过。

    测试验证

    (1)SwitchA vlan10内的PC可以与SwitchB vlan10内的PC互通

    (2)SwitchA vlan20内的PC可以与SwitchB vlan20内的PC互通

    (3)SwitchA vlan10内的PC不能与SwitchB vlan20内的PC互通

    (4)SwitchA vlan20内的PC不能与SwitchB vlan10内的PC互通

    7、端口汇聚配置

    『配置环境参数』

    (1)交换机SwitchA和SwitchB通过以太网口实现互连。

    (2)SwitchA用于互连的端口为e0/1和e0/2,SwitchB用于互连的端口为e0/1和e0/2。

    『组网需求』

    增加SwitchA的SwitchB的互连链路的带宽,并且能够实现链路备份,使用端口汇聚

    数据配置步骤

    【SwitchA交换机配置】

    (1)进入端口E0/1

    [SwitchA]interface Ethernet 0/1

    (2)汇聚端口必须工作在全双工模式

    [SwitchA-Ethernet0/1]duplex full

    (3)汇聚的端口速率要求相同,但不能是自适应

    [SwitchA-Ethernet0/1]speed 100

    (4)进入端口E0/2

    [SwitchA]interface Ethernet 0/2

    (5)汇聚端口必须工作在全双工模式

    [SwitchA-Ethernet0/2]duplex full

    (6)汇聚的端口速率要求相同,但不能是自适应

    [SwitchA-Ethernet0/2]speed 100

    (7)根据源和目的MAC进行端口选择汇聚

    [SwitchA]link-aggregation Ethernet 0/1 to Ethernet 0/2 both

    【SwitchB交换机配置】

    [SwitchB]interface Ethernet 0/1

    [SwitchB-Ethernet0/1]duplex full

    [SwitchB-Ethernet0/1]speed 100

    [SwitchB]interface Ethernet 0/2

    [SwitchB-Ethernet0/2]duplex full

    [SwitchB-Ethernet0/2]speed 100

    [SwitchB]link-aggregation Ethernet 0/1 to Ethernet 0/2 both

    【补充说明】

    (1)同一个汇聚组中成员端口的链路类型与主端口的链路类型保持一致,即如果主端口为Trunk端口,则成员端口也为Trunk端口;如主端口的链路类型改为Access端口,则成员端口的链路类型也变为Access端口。

    (2)不同的产品对端口汇聚时的起始端口号要求各有不同,请对照《操作手册》进行配置。

    8、端口镜像配置

    『环境配置参数』

    (1)PC1接在交换机E0/1端口,IP地址1.1.1.1/24

    (2)PC2接在交换机E0/2端口,IP地址2.2.2.2/24

    (3)E0/24为交换机上行端口

    (4)Server接在交换机E0/8端口,该端口作为镜像端口

    『组网需求』

    (1)通过交换机端口镜像的功能使用server对两台pc的业务报文进行监控。

    根据Quidway交换机不同型号,镜像有不同方式进行配置:

    基于端口的镜像 ——基于端口的镜像是把被镜像端口的进出数据报文完全拷贝一份到镜像端口,这样来进行流量观测或者故障定位。

    基于流的镜像 ——基于流镜像的交换机针对某些流进行镜像,每个连接都有两个方向的数据流,对于交换机来说这两个数据流是要分开镜像的。

    S2008/S2016/S2026/S2403H/S3026等交换机支持的都是基于端口的镜像

    8016交换机支持基于端口的镜像

    3500/3026E/3026F/3050支持基于流的镜像

    5516/6506/6503/6506R支持对入端口流量进行镜像

    数据配置步骤

    以Quidway S3026C为例,通过基于二层流的镜像进行配置:

    (1)定义一个ACL

    [SwitchA]acl num 200

    (2)定义一个规则从E0/1发送至其它所有端口的数据包

    [SwitchA]rule 0 permit ingress interface Ethernet0/1 egress interface Ethernet0/2

    (3)定义一个规则从其它所有端口到E0/1端口的数据包

    [SwitchA]rule 1 permit ingress interface Ethernet0/2 egress interface Ethernet0/1

    (4)将符合上述ACL的数据包镜像到E0/8

    [SwitchA]mirrored-to link-group 200 interface e0/8

    9、生成树STP配置

    『配置环境参数』

    (1)交换机SwitchA、SwitchB和SwitchC都通过GE接口互连

    (2)SwitchB和SwitchC交换机是核心交换机,要求主备。

    『组网需求』

    要求整个网络运行STP协议

    数据配置步骤

    (1)【SwitchA交换机配置】

    启动生成树协议: [SwitchA]stp enable

    (1)【SwitchB交换机配置】

    启动生成树协议:[SwitchB]stp enable

    (3)配置本桥为根桥

    [SwitchB]stp root primary

    (4)【SwitchC交换机配置】

    a 启动生成树协议[SwitchC]stp enable

    b 配置本桥为备份根桥[SwitchC]stp root secondary

    (5)【SwitchD交换机配置】

    a 启动生成树协议[SwitchD]stp enable

    【补充说明】

    (1)缺省情况下交换机的优先级都是32768,如果想人为指定某一台交换机为根交换机,也可以通过修改优先级来实现;

    (2)缺省情况下打开生成树后,所有端口都会开启生成树协议,请把接PC的端口改为边缘端口模式;

    (3)如果要控制某条链路的状态可以通过设置端口的cost值来实现。

    测试验证

    (1)使用display stp查看交换机STP运行状态

    (2)查看端口STP状态display stp interface Ethernet XX是否正确

    10、Quidway交换机维护

    显示系统版本信息:display version

    显示诊断信息:display diagnostic-information

    显示系统当前配置:display current-configuration

    显示系统保存配置: display saved-configuration

    显示接口信息:display interface

    显示路由信息:display ip routing-table

    显示VLAN信息:display vlan

    显示生成树信息:display stp

    显示MAC地址表:display mac-address

    显示ARP表信息:display arp

    显示系统CPU使用率:display cpu

    显示系统内存使用率:display memory

    显示系统日志:display log

    显示系统时钟:display clock

    验证配置正确后,使用保存配置命令:save

    删除某条命令,一般使用命令: undo

    华为交换机的配置方法小编这里整理完毕了,再给大家推荐个华为交换机的购买地址(有内部优惠券可以领!!!)

    展开全文
  • 华为交换机配置基础命令

    万次阅读 2020-12-24 16:55:11
    交换机要求建立vlan 2 192.168.2.1 (端口: g2/0/1 属于该vlan)vlan 3 192.168.3.1 (端口: g2/0/2 属于该vlan)vlan 200 172.16.0.2 (端口: g2/0/3 属于该vlan)g2/0/3 连接华为路由器,路由器该端口IP是: 172.16.0.1...

    交换机要求建立

    vlan 2 192.168.2.1   (端口: g2/0/1 属于该vlan)

    vlan 3 192.168.3.1   (端口: g2/0/2 属于该vlan)

    vlan 200 172.16.0.2 (端口: g2/0/3 属于该vlan)

    g2/0/3 连接华为路由器,路由器该端口IP是: 172.16.0.1

    建立ACL定义vlan 2 与vlan 3 之间不能互访

    配置步骤:

    1.VLAN配置

    sys /进入特权模式

    [Quidway]vlan 2 /建立vlan 2

    [Quidway]ctrl+z /退出vlan2 到普通模式

    sys /进入特权模式

    [Quidway]vlan 3 /建立vlan 3

    [Quidway]ctrl+z /退出vlan3 到普通模式

    sys /进入特权模式

    [Quidway]int vlan 2 /进入到vlan2

    [Quidway-Vlan-interface2]ip address 192.168.2.1 255.255.255.0 /给vlan 2 配置IP

    [Quidway-Vlan-interface2]ctrl+z /退出vlan2 到普通模式

    sys /进入特权模式

    [Quidway]int vlan 3 /进入到vlan3

    [Quidway-Vlan-interface2]ip address 192.168.3.1 255.255.255.0 /给vlan 3 配置IP

    [Quidway-Vlan-interface2]ctrl+z /退出vlan3 到普通模式

    sys /进入特权模式

    [Quidway]int g2/0/1 /进入到g2/0/1端口

    [Quidway-GigabitEthernet2/0/1]port access vlan 2 / 将该端口添加到vlan 2

    [Quidway-GigabitEthernet2/0/1]ctrl+z /退出vlan 2 到普通模式

    sys /进入特权模式

    [Quidway]int g2/0/2 /进入到g2/0/2端口

    [Quidway-GigabitEthernet2/0/1]port access vlan 3 / 将该端口添加到vlan 3

    [Quidway-GigabitEthernet2/0/1]ctrl+z /退出vlan 3 到普通模式

    2.ACL配置

    sys /进入特权模式

    [Quidway]acl number 3015 /建立acl 编号取为3015,该编号可以任意取

    [Quidway-acl-adv-3015]rule deny source 192.168.2.0 0.0.0.255 destination 192.168.3.0

    0.0.0.255 /定义 192.168.2.0 的ip段不能访问 192.168.3.0 网段,反之也一样.

    [Quidway-acl-adv-3015]ctrl+z /退出当前acl 到普通模式

    sys /进入特权模式

    [Quidway]int g2/0/1 /进入到g2/0/1端口

    [Quidway-GigabitEthernet2/0/1]packet-filter inbound ip-group 3015 not-care-for-interface /将

    定义好的acl 3015下发到整台交换机中,让整台交

    3.Trunk配置

    网络环境:

    6506 g2/0/4多模光口 接 3026 g1/1 多模光口

    3026 建立两个 VLAN

    vlan 5 192.168.5.1 255.255.255.0 (原来的用户继续使用,即端口9-24)

    vlan 6 192.168.6.1 255.255.255.0 (用于财务1-8口)

    不允许任何VLAN访问VLAN 6

    步骤:

    6506 上的配置步骤如下:

    sys /进入特权

    vlan 5 /建立两个VLAN,即3026上所要建立的VLAN,必须同名

    vlan 6 /建立两个VLAN,即3026上所要建立的VLAN,必须同名

    int vlan 5 /进入到 vlan 5

    ip add 192.168.5.1 255.255.255.0 /配置 vlan 5 的IP地址

    int vlan 6 /进入到 vlan 6

    ip add 192.168.6.1 255.255.255.0 /配置VLAN 6 的 IP地址

    interface g2/0/4 /进入到端口

    port link-type trunk /配置端口工作在Trunk模式

    port trunk permit vlan 5 /允许vlan 5通过

    port trunk permit vlan 6 /允许vlan 6能过

    speed 1000 /配置速度

    duplex full /工作模式全双工

    acl number 3001 /定义一条ACL,不允许任何VLAN访问VLAN 6

    rule deny ip source any destination 192.168.6.0 0.0.0.255 /定久任何IP不能访问 192.168.6.0网

    int g2/0/4 /进入到端口

    packet-filter inbound ip-group 3001 /将ACL应用到端口

    3026配置步骤如下:

    sys /进入特权

    vlan 5 /建立vlan 5,必须和6506上的相同

    vlan 6 /建立vlan 6,必须和6506上的相同

    int g1/1 /进入到g1/1口

    port link-type trunk /配置端口工作在Trunk模式

    port trunk permit vlan 5 /允许vlan 5通过

    port trunk permit vlan 6 /允许vlan 6能过

    speed 1000 /配置速度

    duplex full /工作模式全双工

    int e0/1 /进入端口

    port access alvn 6 /将端口添加到vlan 6里

    int e0/23 /进入端口

    port access vlan 5 /将端口添加到vlan 5里

    展开全文
  • 因为根据有些群朋友反映,华为交换机使用的比较多,所以本次以华为交换机为例,如果大家以前对vlan了解不深,那么这篇文章却是可以很好入门与深入。一、什么样的网络才能互通通常情况下,两台电脑如何能...

    1651a755e0e693c6a4b13d70ff6bd2a4.png

    我们曾多次提到交换机的配置,有部分朋友反映有点深了,有些内容不懂,今天我们就从基础到深入来了解网络间如何才能互通,如何才能不通,以案例的方式来详细讲解,一文了解清楚vlan的使用与配置,方便后面应用于项目中。

    因为根据有些群朋友反映,华为交换机使用的比较多,所以本次以华为交换机为例,如果大家以前对vlan了解不深,那么这篇文章却是可以很好入门与深入。

    一、什么样的网络才能互通

    通常情况下,两台电脑如何能才互通呢?如何才能不能互相访问呢?

    最简章方法就是利用网段来解决,我们来举例。

    f49a9f1087abfa38f163122f3ec1c85b.png

    1、两台电脑不能互相访问

    假设:

    PC1 ip地址:192.168.1.1/24

    PC2 ip地址:192.168.2.1/24

    要测试PC1和PC2的连通性:最简单的方法就是用PC1去PingPC2,查看Ping的结果。

    37c0e0cb24247d5da07fe5c536ded395.png

    很明显ping不通,PC1和PC2的ip在不同的网段,不能ping通。

    那么什么样的情况能ping通呢?

    2、如何才能互访

    假设:

    PC1的ip地址:192.168.1.1/24

    PC2的IP地址:192.168.1.2/24

    PC3的ip地址: 192.168.1.3/24

    都在同一个网段内,用测试pc1是否能互访pc2与pc3,直接用pc1去ping pc2与pc3就行。

    pc1去ping pc2

    125a8737acf64cdf551a8e88a06cee95.png

    pc1去ping pc3

    fd20413f0a897495ce35ea7022ef2431.png

    很明显,两个都是可以ping通的,因为PC1-PC5在同一个网段内,使用是相同的网关。

    那么问题来了,如何让同一个网段的ip不能互通呢?如何让不同网段ip又能互通

    ?这里面我们就需要引进vlan了。

    二、划分vlan,实现网络的互访与阻绝

    上面我们已经演示了网络最简单的互通与不通的情况,在没有其它设置的情况下,同一个网段的ip地址,能互通,不同的网段的ip地址不能互通。而在实际项目中,并不是这么简单的,我们来看下不同vlan与不同网段之间的互通与阻绝如何实现。

    还是这个拓扑图:

    d611c383fa6cc0fde9c3fe405a464e76.png

    假设:

    PC1的ip地址:192.168.1.1/24 连接LSW1交换机端口Ethernet 0/0/1

    PC2的IP地址:192.168.1.2/24 连接LSW1交换机端口Ethernet 0/0/2

    PC3的ip地址: 192.168.1.3/24 连接LSW1交换机端口Ethernet 0/0/3

    PC4的ip地址: 192.168.1.4/24 连接LSW2交换机端口Ethernet 0/0/1

    现在要让pc1与pc2互访,p1与pc3不能互通,pc1与pc4也不能互访,如何来配置交换机?(今天我们就以华为交换机为例)。

    交换机配置(以华为交换机为例)

    1、配置LSW1

    <Huawei>system-view //进入系统视图

    [Huawei]sysname sw1 //给交换机命名

    [sw1]vlan 10 //创建VLAN10

    [sw1-vlan10]vlan 20 //创建VLAN20

    [sw1-vlan20]display vlan //显示VLAN信息

    [sw1-vlan20]quit //退回上一级视图

    [sw1]interface Ethernet 0/0/1 //进入以太网接口0/0/1

    [sw1-Ethernet0/0/1]port link-type access //配置接口类型为Access

    [sw1-Ethernet0/0/1]port default vlan 10 //分配接口给VLAN10

    [sw1-Ethernet0/0/1]quit //退回上一级视图

    [sw1]interface Ethernet 0/0/2 //进入以太网接口0/0/2

    [sw1-Ethernet0/0/2]port link-type access //配置接口类型为Access

    [sw1-Ethernet0/0/2]port default vlan 10 //分配接口给VLAN10

    [sw1-Ethernet0/0/2]quit //退回上一级视图

    [sw1]interface Ethernet 0/0/3 //进入以太网接口0/0/3

    [sw1-Ethernet0/0/3]port link-type access //配置接口类型为Access

    [sw1-Ethernet0/0/3]port default vlan 20 //分配接口给VLAN20

    [sw1-Ethernet0/0/3]display vlan //显示VLAN信息

    小结:在LSW1中,把pc1与pc2分配在了vlan10,把pc3分配到了vlan20中。

    2、LSW2交换机配置

    命令与上面类似,就不一 一注释了,多看几篇就很容易理解。

    <Huawei>system-view

    [Huawei]sysname sw2

    [sw2]vlan 10 //批量创建VLAN

    [sw2]display vlan

    [sw2]interface Ethernet 0/0/1 //进入pc4的以太网接口0/0/1

    [sw2-Ethernet0/0/1]port link-type access //配置接口类型为Access

    [sw2-Ethernet0/0/1]port default vlan 10 //分配接口给VLAN10

    [sw2-Ethernet0/0/2]display vlan

    在LSW2中,主要是把pc4划分给了vlan10

    3、验证vlan

    a、测试PC1和PC2的连通性。

    130f64f19817eca9525ec677d74de094.png

    因为在同一个vlan且在相同的网段,所以PC1和PC2能够ping通。

    b、测试PC1和PC3的连通性

    66a00b3b41406550b2f072cc5231b616.png

    虽然pc1与pc3的ip地址在同一个网段里面,但PC1和PC3不在同一个vlan中,所以PC1和PC3不能ping通(pc1是属于vlan10,pc3是属于vlan20)。

    c、测试PC1和PC4的连通性

    7028b071d2e7f1d0332ba26b86ccce84.png

    很明显也pc1与pc4不能ping通,这个是为什么呢?

    虽然PC1和PC4在同一个vlan且也在同一个网段中,但是Lsw1和Lsw2交换机没有配置trunk端口,access端口没有tag标记,通不过trunk端口,所以ping不通!

    那么问题来了,如何才能让pc1与pc4互通呢?

    二、如何使交换机间互相通信

    上面我们提到了,pc1是属于LSW1交换机,pc4是属于SLW2交换机,虽然pc1与pc4是划分到了同一个vlan,且ip地址也在同一个网段,但仍然无法互相通信,主要是没有配置trunk接口,我们来配置下。

    fc558908f4746da8728861a5a8b01972.png

    1、LSW1的配置

    [sw1]interface Ethernet 0/0/4 // 进入交换机1与交换机2连接的接口0/0/4

    [sw1-Ethernet0/0/4]port link-type trunk //配置接口类型为trunk

    [sw1-Ethernet0/0/4]port trunk allow-pass vlan 10 20 //trunk口允许通过的VLAN10与vlan20

    2、LSW2的配置

    [sw2]interface Ethernet 0/0/3 // 进入交换机1与交换机2连接的接口0/0/3

    [sw2-Ethernet0/0/3]port link-type trunk //配置接口类型为trunk

    [sw2-Ethernet0/0/3]port trunk allow-pass vlan 10 20

    //trunk口允许通过的VLAN10与vlan20

    3、验证trunk接口配置:

    测试PC1和PC4的连通性,并解释原因。

    3e1c21917d64cf5dee51079088a530d1.png

    PC1和PC4能够ping通,因为交换机之间设置了trunk接口,使得不同vlan之间能够通过其他的交换机!

    最后总结下:

    1、什么情况下,我们才会去划分VLAN。

    让网络进行逻辑隔绝,才会划分vlan!不同的vlan中,即使在相同的网段也不能ping通,

    2、什么情况下,我们才会去配置trunk接口。

    要让交换机和交换机之间连通,需要设置trunk接口。

    展开全文
  • 华为交换机基本配置命令

    千次阅读 2020-12-24 08:23:32
    [Huawei]intg0/0/1[Huawei]portlink-typeaccess(注:接口类型access,hybrid、trunk)[Huawei]portdefaultvlan10批量端口放入VLAN[Huawei]port-group1[Huawei-port-group-1]group-memberethernetG0/0/1...
  • 华为交换机基本配置命令详解

    千次阅读 2020-12-24 08:24:45
    1:配置登录用户,口令等 //用户直行模式提示符,用户视图system-view //进入配置视图[Quidway] //配置视图(配置密码后必须输入密码才可进入配置视图)[Quidway] sysname xxx //设置主机名成为xxx这里使用[Quidway] ...
  • 很多人朋友多次问到华为交换机配置,确实用的比较多,今天我们来了解下华为交换机配置。为了让大家更加清楚,每行代码都有解释。1、创建vlan://用户视图,也就是在Quidway模式下运行命令。system-view //进入...
  • 华为交换机配置过程

    千次阅读 2021-11-26 11:19:41
    Sysname ****** #交换机重命名 # Vlan 10 #配置vlan信息 description to-2609-server #描述TO—位置—目标 interface Vlanif10 ip address 10.10.15.4 255.255.0.0 #根据IP规划配置IP # aaa local-user ...
  • 华为交换机配置dhcp详细配置

    千次阅读 2022-05-06 17:49:34
    Huawei>system-view -- 进去配置模式 [Huawei]dhcp enable 开启dhcp服务 配置防止IP地址重复分配功能 dhcp snooping enable 在全局模式开启dhcp监听功能 (在可以接口配置) [Huawei] dhcp server ping packet 3 ...
  • 华为交换机配置MSTP

    2021-11-04 14:56:55
    交换机S1、S2、S3、S4上配置MSTP防止二层环路,具体要求如下: VLAN10数据流默认经过S3转发,当S3失效时经过S4转发;VLAN20数据流默认经过S4转发,当S4失效时经过S3转发。所配置的参数要求如下: region-name为...
  • 原标题:华为交换机配置及:access、trunk、hybird端口详解很多人朋友多次问到华为交换机配置,确实用的比较多,上次我们有单独提到h3c交换机的配置,今天我们来了解下华为交换机配置,以及以太网的三种链路...
  • 很多人朋友多次问到华为交换机配置,确实用的比较多,上次我们有单独提到h3c交换机的配置,今天我们来了解下华为交换机配置,以及以太网的三种链路方式。为了让大家更加清楚,每行代码都有解释。一、华为交换机...
  • 随着网络规模的不断扩大,接入的主机和设备也越来越多,随之的广播流量也就越大,这样也就加重了交换机的负担,可能会导致交换机死机,因此我们就引入了VLAN技术 1、VLAN的介绍 1.1、VLAN的概念 VLAN...
  • 华为交换机配置trunk接口

    万次阅读 2020-02-11 18:37:12
    配置Trunk接口 trunk端口一般用于交换机之间连接的端口,trunk端口可以属于多个vlan,可以接受发发送多个vlan的报文。 本次的实验如下图: 模拟两天办公区怎么互信通信,切互不影响,PC1与PC3是同网段,PC2与PC4是...
  • 华为交换机配置文件备份与还原

    千次阅读 2020-12-19 20:18:18
    华为交换机配置文件备份与还原2018-09-19(2011-10-31 20:07:01)标签:杂谈方案一:利用安装有FTP服务器软件的笔记本实现配置文件的复制(一)将旧交换机上的配置文件上传至一台FTP服务器图1如图1所示,本次工程实例...
  • 华为交换机配置acl规则

    千次阅读 2021-08-13 10:15:50
    华为交换机配置acl规则 1、实验拓扑 2、设备IP配置 3、基础环境组网配置 进入核心交换机 system-view [Huawei]sysname jigui-sw [jigui-sw]vlan batch 10 20 30 [jigui-sw]interface GigabitEthernet 0/0/1 [jigui...
  • 华为S2300 交换机 配置

    2019-03-07 13:58:28
    华为S2300 交换机 vlan ,trunk,access, 端口 配置
  • 华为交换机配置远程连接

    千次阅读 2021-04-06 11:08:29
    注意:在华为模拟器中选用这个名为:“router”的路由,不然别的路由E不支持配置ip(默认为二层设备端口) 实验思路: 1、路由器配置ip,交换机配置ip实现互通。 2、由于模拟器中交换机是二层设备,所以端口不...
  • 华为交换机配置命令 1、配置文件相关命令 [Quidway]display current-configuration 显示当前生效的配置 [Quidway]display saved-configuration 显示flash中配置文件,即下次上电启动时所用的配置文件 reset saved-...
  • 华为交换机删除命令

    千次阅读 2020-12-24 08:23:31
    给你个绝对可行得办法:[switch]interface g0/0/1 //如果是33系列以下,则是interface ethernet0/0/1[switch-interface g0/0/1]display this //查看当前端口类型,是access,hybrid还是trunk,如果查不到,就说明它...
  • 华为交换机配置

    2021-02-23 17:33:33
    交换机配置 一、H3C 1.连接交换机 ...二、华为交换机基本配置命令: 常用试图名称 进入试图 试图功能 用户试图 用户在终端进入设备,显示 用户可查看运行状态和统计信息功能 系统试图 输入命令
  • 华为交换机配置IP以及telnet服务

    千次阅读 2022-04-13 10:38:20
    由于华为交换机无法直接在接口上配置IP,所以一般使用vlanif配置。 vlanif接口可以理解成对应vlan的特殊接口,可以配置IP进行运行路由协议。 开启交换机与路由以后进入命令行页面进行IP配置配置交换机IP: 赋予...
  • 华为交换机配置dhcp中继

    千次阅读 2021-11-27 20:31:10
    华为交换机配置dhcp中继 两个步骤: 一、配置核心交换机(图中LSW1) (1).接口配置: int gig0/0/1 port link-type access port default vlan 10 int gig0/0/2 port link-type access port default vlan 20...
  • 本文对从一台拆箱的华为交换机来说明如何对华为交换机进行基础的配置,希望能帮到大家。
  • 华为交换机Trunk配置

    千次阅读 2021-03-12 15:11:15
    华为交换机Trunk配置 Trunk 采用Trunk中继链路技术可以实现不同交换机同网段的Vlan间通信。Trunk中继技术可以实现在一条物理线路中可以传递多个Vlan间的信息,如:交换机从属于Vlan2的端口接收到数据,在Trunk中继...
  • 下面是一个简单的华为交换机配置: # sysname SWName01 # vlan 10 description to CWK # vlan 20 description to RLK # interface Vlanif1 ip address 192.168.1.10 255.255.255.0 # interface GigabitEthernet0/0/...
  • 华为交换机如何把access转成trunk?

    千次阅读 2020-12-31 08:10:25
    有两台3层互联的华为9306交换机,因为想迁移其第一台华为9300系列:interfaceVlanif10ipaddress172.16.254.2255.255.255.248#interfaceVlanif11ipaddress192.168.1.2255.255.255.248i...有两台3层互联的华为9306...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 6,551
精华内容 2,620
关键字:

华为交换机配置access口