精华内容
下载资源
问答
  • 让IE6 IE7 IE8 IE9 IE10 IE11支持Bootstrap的解决方法

    万次阅读 多人点赞 2014-11-26 11:53:24
    让IE6 IE7 IE8 IE9 IE10 IE11支持Bootstrap的解决方法,IE6 IE7 IE8 IE9 IE10 IE11,chrome,firefox,safari,opera,360浏览器(极速模式)、搜狗浏览器等浏览器测试通过

    如有雷同,不胜荣幸,若转载,请注明

    让IE6 IE7 IE8 IE9 IE10 IE11支持Bootstrap的解决方法


    最近做一个Web网站,之前一直觉得bootstrap非常好,这次使用了bootstrap3,在chrome,firefox,safari,opera,360浏览器(极速模式)、搜狗浏览器等浏览器下均没有问题,而在IE8及IE11下发现样式无法显示,然后各种百度啊,最后在 雅朋网 的一个网友帖子的帮助下解决了问题,也参考了 千寻学习网 的资料,先将解决方法总结如下:


    首先需要确保你的HTML页面开始部分要有DOCTYPE声明。DOCTYPE告诉浏览器使用什么样的HTML或XHTML规范来解析HTML文档,具体会影响:
    对标记attributes 、properties的约束规则
    对浏览器的渲染模式产生影响,不同的渲染模式会影响到浏览器对于CSS代码甚至JavaScript脚本的解析
    DOCTYPE是非常关键的,目前的最佳实践就是在HTML文档的首行键入:
    <!DOCTYPE html>


    大神的帖子总结的bootstrap的查找原因好几条,首先,Bootstrap3 是移动设备优先的原则开发的,所以原因可能如下:
    1.没有正确调用远程地址
    即只要是IE9以下,就调用两个专门的js
    <!-- HTML5 Shim and Respond.js IE8 support of HTML5 elements and media queries -->
    <!--[if lt IE 9]>
      <script src="http://apps.bdimg.com/libs/html5shiv/3.7/html5shiv.min.js"></script>
      <script src="http://apps.bdimg.com/libs/respond.js/1.4.2/respond.min.js"></script>
    <![endif]-->
    但是我测试发现仅仅使用以上js文件不可行,
    2.调用方法不正确
    不要用file://或@import形式引用respond.min.js或respond.js或css文件


    3.针对浏览器的内容做标识(使用meta标签调节浏览器的渲染方式)
    bootstrap不支持IE兼容模式,为了让IE浏览器运行最新的渲染模式,将添加以下标签在页面中
    <meta http-equiv="X-UA-Compatible" content="IE=edge,Chrome=1" />
    IE=edge表示强制使用IE最新内核,chrome=1表示如果安装了针对IE6/7/8等版本的浏览器插件Google Chrome Frame(可以让用户的浏览器外观依然是IE的菜单和界面,但用户在浏览网页时,实际上使用的是Chrome浏览器内核),那么就用Chrome内核来渲染。关于此meta标签的具体说明,可参见StackOverflow上的精彩回答,<meta>标签高人的英文解释可以参看
    http://stackoverflow.com/questions/6771258/whats-the-difference-if-meta-http-equiv-x-ua-compatible-content-ie-edge-e
    我有加了一句
    <meta http-equiv="X-UA-Compatible" content="IE=9" />
    然后就可以了
    内核控制Meta标签,因为目前国内的主流浏览器都是双内核,故而添加meta标签来告诉浏览器使用什么内核来渲染页面


    4.IE8不支持container的几个属性
    IE8不完全支持box-sizing:border-box与min-width, max-width, min-height或max-height的一起使用.所以,v3.0.1的bootstrap中对container的类,已经不再使用max-width了。


    5.JS与CSS的引入顺序导致的问题
    必须先引用css在引用js
    <link rel="stylesheet" type="text/css" href="bootstrap.min.css" media="screen"/>
    <script type="text/javascript" src="js/respond.min.js"></script>


    6.DOCTYPE前后有空行
    <!DOCTYPE html>
    这里有空格也不行,要去掉空格
    <html>


    7.也可以手动修改bootstrap.css
    如果您使用的是bootstrap2.1.1,修改了navbar-inner{ filter:none}可解决问题,如果使用的是3.0+版的,没有这段代码了,详细介绍请看连接
    http://stackoverflow.com/questions/12460190/bootstrap-navbar-does-not-show-in-ie8


    8.使用quirks mode(兼容模式)
    定义网页时,向后兼容旧的浏览器的模式就是quirks mode,与之对应的是“标准模式”就是 standard mode。具体是将<!DOCTYPE html>写成以前的这种
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
    这个我测试过,不可行


    最后我在IE11下测试通过,但是在IE8下测试,有发现一个问题placeholder不被支持
    下面是解决IE支持placeholder的方法
    本文引用的jquery是1.11.1测试通过,先引用jquery
    <script type="text/javascript" src="http://code.jquery.com/jquery-1.11.1.min.js"></script>
    也可以用其他的jquery版本
    再引入<script type="text/javascript" src="js/jquery.placeholder.js"></script>
    jquery.placeholder.js这个文件的下载地址https://github.com/mathiasbynens/jquery-placeholder
    然后再文件中加入一下代码
    <script type="text/javascript">
        $(function () {
            // Invoke the plugin
            $('input, textarea').placeholder();
        });
    </script>
    如果我这里为涉及到的或者问题依然没有解决的请移步http://hustlzp.com/post/2014/01/ie8-compatibility更加详细


    以上IE6,7,8,9,10,11,chrome,firefox,safari,opera,360浏览器(极速模式)、搜狗浏览器测试通过,只有IE5.5似乎不太可行,总之问题解决到此,万恶的IE6-都叫它打酱油去吧


    如果您不想使用jquery.placeholder.js,再不支持placeholder的浏览器下模拟placeholder实现
    可参考此文讲很详细http://ju.outofmemory.cn/entry/1595

    展开全文
  • ie10离线安装包

    2018-04-25 11:05:25
    ie10 win7 64独立离线安装包说明: 1、整合安装IE10所必需的补丁,可独立离线安装; 2、禁止勾选IE10自动安装新版本; 3、禁止首次运行IE10弹出自定义设置对话框。 版本:10.0.9200.16521 更新版本:RTM(KB2718695...
  • create-react-app 支持IE(IE11/IE10/IE9)

    千次阅读 2019-09-06 10:22:58
    create-react-app创建项目之后无法在IE上正常访问 修改代码支持IE11 (github地址:添加代码...修改代码支持IE10/IE9(github地址:添加代码支持IE10/IE9) 上一步骤之后,IE10/IE9存在下面问题 (1)安装 core...

    create-react-app创建项目之后无法在IE上正常访问

     

     

    修改代码支持IE11 (github地址:添加代码支持IE11)

    修改package.json,index.js,然后删除node_modules,重新安装


    修改代码支持IE10/IE9 (github地址:添加代码支持IE10/IE9)

    上一步骤之后,IE10/IE9存在下面问题

    (1)安装 core-js mutation-observer

    npm install core-js mutation-observer --save

    (2)index.js引入

    (3)webpack.config.js修改,调换位置


    修复遗留问题setprototypeof(github地址:修复兼容IE10/IE9遗留问题
     

    (1)安装setprototypeof

    npm install setprototypeof --save

    (2)手动添加polyfill.js

    import setprototypeof from  'setprototypeof';
    
    Object.setPrototypeOf = setprototypeof; 

    (3)index.js引入polyfill.js文件



    验证完成
     

     

    资源链接:

    https://github.com/facebook/create-react-app/issues/5674
    https://github.com/facebook/create-react-app/issues/5336
    https://github.com/facebook/create-react-app/tree/master/packages/react-app-polyfill
    https://github.com/wesleytodd/setprototypeof

    展开全文
  • bootstrap支持ie8 让IE6 IE7 IE8 IE9 IE10 IE11支持Bootstrap的解决方法

    再分享一下我老师大神的人工智能教程吧。零基础!通俗易懂!风趣幽默!还带黄段子!希望你也加入到我们人工智能的队伍中来!https://blog.csdn.net/jiangjunshow

    展开全文
  • win10将IE11兼容ie10

    千次阅读 2018-01-02 17:32:26
    win10支持的最低IE版本为IE10,现在IE最新版本为IE11,而win10自带的浏览器是microsoft EDGE ,这给 以前的老系统带来很多不便,为了支持以前的老系统,只有降低IE浏览器的版本了,打开IE浏览器,按F12按键打开...


    原文:https://www.cnblogs.com/xxlu/p/5325325.html


    win10支持的最低IE版本为IE10,现在IE最新版本为IE11,而win10自带的浏览器是microsoft  EDGE ,这给 以前的老系统带来很多不便,为了支持以前的老系统,只有降低IE浏览器的版本了,打开IE浏览器,按F12按键打开开发者模式,点击上方“仿真”菜单,将模式中的文档模式改为博友想要的版本,博主这里用8做示例,然后将用户代理字符传改为Internet Explorer 8,最后点击 左上角的保留仿真设置,如果“保留仿真设置”图标变为蓝色,则说明已经保存,然后点击IE浏览器上方的“工具”菜单,或者右上角的齿轮图标,打开“兼容性视图设置”,将需要用仿真模式打开的网页添加到兼容性视图。

    下面用截图来一步步说明。

    第一步:打开IE浏览器,打开需要用低版本兼容的网站。

    第二步:打开开发者模式。

    第三步:点击仿真菜单,将模式中的文档模式和用户代理字符串改为8和Internet Explorer 8

    第四步:点击“保留仿真设置”按钮,对刚才的设置进行保存。

    第五步:打开“兼容性视图设置”菜单,将需要兼容低版本的网添加到兼容性视图。

    第六步:测试。

    展开全文
  • 安装完IETester后发现IE10为灰色,并无法打开使用,这里给大家一个方法,可以让IETester IE10正常工作浏览和测试,下载完后把解压文件夹,解压到IETester的IE10目录中去就可以了。
  • 让IE6 IE7 IE8 IE9 IE10 IE11支持Bootstrap的解决方法 .
  • 解决IE10以上版本doPostBack未定义

    千次下载 热门讨论 2013-12-02 10:24:55
    .Net4.0下ASP.NET在IE10以上版本访问的时候,遇到分页或者控件回发的时候会提示doPostBack未定义,这个补丁是用来在服务器端修正这个问题,安装完需要重启。如不想在服务器修正,可以看...
  • 一行代码解决各种IE兼容问题,IE6,IE7,IE8,IE9,IE10
  • 防止原文章被删,这里也写...本文为大家分享的是一篇让IE6 IE7 IE8 IE9 IE10 IE11支持Bootstrap的方法 ,感兴趣的同学参考下。 bootstrap简介 Bootstrap是Twitter推出的一个开源的用于前端开发的工具包。它由Tw
  • IE9 IE10 IE11兼容性更改

    千次阅读 2013-12-06 18:13:43
    IE9 IE10 IE11兼容性更改
  • ie10兼容ie7

    千次阅读 2013-12-03 19:00:44
    设置ie的兼容模式:ie10兼容ie7.   添加到head标签内.这样样式就不会改变了.
  • 一个能够兼容IE6 IE8 IE9 IE10 IE11 谷歌 火狐 360等常见的10个浏览器的HTML头部信息配置代码
  • 场景说明 ...上面我们发现,如果在IE10 和一下,如果元素是透明的,则相当于没有该元素。 处理方案 为该元素加上一个透明背景 加上透明背景后,IE10 就会识别该元素了。 透明图片素材: 看上面 ...
  • ie10浏览器解析不了es6的语法,需要我们使用babel(Babel是一种工具链,主要用于将ECMAScript 2015+代码转换为当前和旧版浏览器或环境中的向后兼容版本的JavaScript)。但是Babel 默认只转换新的 JavaScript 句法...
  • 一个能够兼容IE6 IE8 IE9 IE10 IE11 谷歌,火狐,360等常见的10个浏览器的HTML头部信息配置代码
  • IE10 安装

    2016-01-14 15:35:19
    IE10 各种语言版本的安装包地址: http://windows.microsoft.com/zh-cn/internet-explorer/downloads/ie-10/worldwide-languages   如果在安装过程中,因下载更新文件失败而导致安装不了的,请参考: ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 28,764
精华内容 11,505
关键字:

ie10