ipv6 订阅
IPv6是英文“Internet Protocol Version 6”(互联网协议第6版)的缩写,是互联网工程任务组(IETF)设计的用于替代IPv4的下一代IP协议,其地址数量号称可以为全世界的每一粒沙子编上一个地址 [1]  。由于IPv4最大的问题在于网络地址资源不足,严重制约了互联网的应用和发展。IPv6的使用,不仅能解决网络地址资源数量的问题,而且也解决了多种接入设备连入互联网的障碍 [1]  。互联网数字分配机构(IANA)在2016年已向国际互联网工程任务组(IETF)提出建议,要求新制定的国际互联网标准只支持IPv6,不再兼容IPv4。 [2] 展开全文
IPv6是英文“Internet Protocol Version 6”(互联网协议第6版)的缩写,是互联网工程任务组(IETF)设计的用于替代IPv4的下一代IP协议,其地址数量号称可以为全世界的每一粒沙子编上一个地址 [1]  。由于IPv4最大的问题在于网络地址资源不足,严重制约了互联网的应用和发展。IPv6的使用,不仅能解决网络地址资源数量的问题,而且也解决了多种接入设备连入互联网的障碍 [1]  。互联网数字分配机构(IANA)在2016年已向国际互联网工程任务组(IETF)提出建议,要求新制定的国际互联网标准只支持IPv6,不再兼容IPv4。 [2]
信息
外文名
IPv6(Internet Protocol Version 6)
类    型
网络协议
地址长度
128位
数    量
2^128(约3.4×10^38)
中文名
互联网协议第6版
IPv6发展历史
至1992年初,一些关于互联网地址系统的建议在IETF(互联网工程任务组)上提出,并于1992年底形成白皮书。在1993年9月,IETF建立了一个临时的ad-hoc下一代IP(IPng)领域来专门解决下一代IP的问题。这个新领域由Allison Mankin和Scott Bradner领导,成员由15名来自不同工作背景的工程师组成。IETF于1994年7月25日采纳了IPng模型,并形成几个IPng工作组。从1996年开始,一系列用于定义IPv6的RFC发表出来,最初的版本为RFC1883。由于IPv4和IPv6地址格式等不相同,因此在未来的很长一段时间里,互联网中出现IPv4和IPv6长期共存的局面。在IPv4和IPv6共存的网络中,对于仅有IPv4地址,或仅有IPv6地址的端系统,两者无法直接通信的,此时可依靠中间网关或者使用其他过渡机制实现通信。2003年1月22日,IETF发布了IPv6测试性网络,即6bone网络。它是IETF用于测试IPv6网络而进行的一项IPng工程项目,该工程目的是测试如何将IPv4网络向IPv6网络迁移。作为IPv6问题测试的平台,6bone网络包括协议的实现、IPv4向IPv6迁移等功能。6bone操作建立在IPv6试验地址分配基础上.并采用3FFE::/16的IPv6前缀,为IPv6产品及网络的测试和试商用部署提供测试环境。截至2009年6月,6bone网络技术已经支持了39个国家的260个组织机构。6bone网络被设计成为一个类似于全球性层次化的IPv6网络,同实际的互联网类似,它包括伪顶级转接提供商、伪次级转接提供商和伪站点级组织机构。由伪顶级提供商负责连接全球范围的组织机构,伪顶级提供商之间通过IPv6的lBGP-4扩展来尽力通信,伪次级提供商也通过BGP-4连接到伪区域性顶级提供商,伪站点级组织机构连接到伪次级提供商。伪站点级组织机构可以通过默认路由或BGP-4连接到其伪提供商。6bone最初开始于虚拟网络,它使用IPv6-over-IPv4隧道过渡技术。因此,它是一个基于IPv4互联网且支持IPv6传输的网络,后来逐渐建立了纯IPv6链接。从2011年开始,主要用在个人计算机和服务器系统上的操作系统基本上都支持高质量IPv6配置产品。例如,Microsoft Windows从Windows 2000起就开始支持IPv6,到Windows XP时已经进入了产品完备阶段。而Windows Vista及以后的版本,如Windows 7、Windows 8等操作系统都已经完全支持IPv6,并对其进行了改进以提高支持度。Mac OS X Panther(10.3)、Linux 2.6、FreeBSD和Solaris同样支持IPv6的成熟产品。一些应用基于IPv6实现.如BitTorrent点到点文件传输协议等,避免了使用NAT的IPv4私有网络无法正常使用的普遍问题。2012年6月6日,国际互联网协会举行了世界IPv6启动纪念日,这一天,全球IPv6网络正式启动。多家知名网站,如Google、Facebook和Yahoo等,于当天全球标准时间0点(北京时间8点整)开始永久性支持IPv6访问。根据飓风电子统计,截至2013年9月,互联网318个顶级域名中的283个支持IPv6接入它们的DNS。约占89.0%,其中276个域名包含IPv6黏附记录,共5,138,365个域名在各自的域内拥有IPv6地址记录 [3]  。2017年11月26日,中共中央办公厅、国务院办公厅印发《推进互联网协议第六版(IPv6)规模部署行动计划》 [4]  。2018年7月,百度云制定了中国的IPv6改造方案 [5]  。11月,国家下一代互联网产业技术创新战略联盟在北京发布了中国首份IPv6业务用户体验监测报告显示,移动宽带IPv6普及率为6.16%,IPv6覆盖用户数为7017万户,IPv6活跃用户数仅有718万户,与国家规划部署的目标还有较大距离。 [6]  2019年4月16日,工业和信息化部发布《关于开展2019年IPv6网络就绪专项行动的通知》。 [7]  2020年3月23日,工业和信息化部发布《关于开展2020年IPv6端到端贯通能力提升专项行动的通知》,要求到2020年末,IPv6活跃连接数达到11.5 亿,较2019年8亿连接数的目标提高了43%。 [8] 
收起全文
精华内容
参与话题
问答
  • IPv6

    2020-08-05 10:55:25
    IPv6 1.为什么有IPv6 2.IPv6数据报格式 3.IPv6和IPv4对比 4.IPv6地址表示形式 5.IPv6基本地址类型 6.IPv6向IPv4过渡的策略 7.总结

    IPv6

    1.为什么有IPv6
    在这里插入图片描述
    2.IPv6数据报格式
    在这里插入图片描述
    在这里插入图片描述
    3.IPv6和IPv4对比
    在这里插入图片描述
    4.IPv6地址表示形式
    在这里插入图片描述
    5.IPv6基本地址类型
    在这里插入图片描述
    6.IPv6向IPv4过渡的策略
    在这里插入图片描述
    7.总结
    在这里插入图片描述

    展开全文
  • IPV6

    千次阅读 2018-11-10 20:29:02
    1.DUAL STACK 双栈 即使用IPV6又使用IPV4 注:同时使用IPV6优于IPV4 2.IPV6没有分片功能,他不需要分片,使用PDM最小MTU路径检测 3.IPV6没有校验字段,在IP报头里面的校验字段IPV6不需要 4.缺省路由 :: 5.IPv6...

    特征-优点:
    1、全球单播地址
    2、可聚合性(IANA组织对全球的地址进行合理分配)
    3、多宿主—一个物理接口可以同时拥有多个不同或相同网段的IPV6地址;但不同接口不能在同一网段
    4、自动配置
    1)DHCP V6
    2)auto-config路由器接口手工配置IPv6地址,然后路由器将自己地址的前缀 (网络号)下放给PC,PC将自动使用EUI-64来补充主机位;
    5、即插即用–热插拔
    6、端到端的连接—不需要NAT
    7、重编址
    8、简易的报头
    1)没有广播机制 只有组播和单播
    2)没有检验和(因为2和4层均存在校验和)
    3)流标签—保留—QOS
    9、安全性和移动性
    10、IPV4和IPV6共存
    在这里插入图片描述

    黄色—一致
    红色—取消 V4中的第二列用于分片 V6可以使用扩展首部实现
    蓝色—替代
    1、服务类型–扩展表
    2、报头长度—有效负载长度
    3、TTL–跳数限制
    4、协议号—下一个头部
    灰色—保留 流标签

    IPV6地址:

    在这里插入图片描述
    1-23位 注册位—IANA分配给各个国家或组织
    24–32位 ISP位—国家分配给各个ISP
    33-48位 站点位—ISP分配给各个企业
    49–64位 子网位----网络管理员进行子网划分
    IPV6地址分类:
    1、单播地址 一对一 只有单播地址能作为源地址,也可作为目标地址
    2、多播地址 一对多 作为目标地址
    3、任意播地址-----一到最近

    单播地址:
    1、AGUA 全球可聚合单播地址 IPV6的公网地址(需申请),全球单播传递
    目前全球已规划地址----2000::/3
    范围–2000::-----3fff:ffff:ffff:ffff:ffff:ffff:ffff:ffff

    *其中 2001::/16 -----当下的IPV6实验室使用地址 目前ipv6 intenet地址

    • 2002::/16-----------6to4 tunnel 专用地址

    2、*本地链路地址—自动私有地址—link-local 169.254.0.0/16
    FE80::/16
    1)路由器接口上配置ipv6 enable命令,该接口将自动生成link-local地址;
    2)若在接口配置一个IPV6单播地址,必然自动生成link-local地址;一个接口只能存在一个link-local地址;

    Link-local地址的网络位固定为FE80::/64,主机位使用本地以太网接口的MAC地址来生成link-local地址主机位;串行链路无MAC地址,将循环借用本设备上以太网接口的MAC;

    主机位生成方法:
    Link-local地址--------------网络位FE80::/64 后64位使用EUI-64补充
    EUI-64简易的用户界面:
    (1)以太网接口MAC地址----ca00.0a60.0000
    在MAC的前24位和后24位之间强行插入FFFE
    ca00.0aFF.FE60.0000
    (2)U位转换
    将合成后的地址,从左往右第7位自反 若该位为0,变为1;为1变为0;
    Ca00=1100 1010 0000 0000 第七位自反
    1100 1000 0000 0000=c800
    (3)link-local地址为
    FE80::c800.aff.fe60.0

    作用:
    (1)在同一广播域内可以通讯使用—由于本地多接口可能使用相同MAC转换,故在
    使用link-local地址访问对端时,需要定义出接口;
    (2)常常作为动态路由协议生成的路由表条目中的下一跳地址;
    因为IPV6存在多宿主概念,该地址最稳定;

    3、site-local 本地站点地址----私有地址 私网地址
    FFC0::/10

    4、未指定地址-----::
    ::
    1)默认(缺省)路由 2)在DHCP时作为无效地址(没有地址)

    5、环回地址—127.0.0.1
    ::1

    6、*IPV4兼容性地址 用于6to4tunnel专用
    假设IPV4地址为192.168.1.1
    192----1100 0000–c0
    168----1010 1000–a8
    1-------0000 0001–01
    1-------0000 0001–01
    192.168.1.1的IPV4兼容性地址为2002:c0a8:0101::/48

    多播地址:
    FF00::/8所有组播地址
    FF02::1—224.0.0.1
    FF02::2—224.0.0.2
    FF02::9—224.0.0.9–RIPNG

    *被请求节点组播地址:—用于NDP协议—获取对端mac地址
    构成FF02::1:FF+24位 (IPV6单播地址的后24位)
    只要存在一个IPV6单播地址,那么便会产生一个被请求节点组播地址;

    Ipv6下的组播MAC地址:
    33.33+32位(后32位为IPV6组播地址后32位)
    FF02::1----33.33.00.00.00.01
    Ipv6下的组播MAC地址:
    33.33+32位(后32位为IPV6组播地址后32位)
    FF02::1----33.33.00.00.00.01

    协议:
    ICMPV6:internet 控制管理协议—存在大量的子协议
    1、PMTU—路径MTU发现协议 通过ICMP error包来获取整段路径上最小MTU值
    2、NDP------邻居发现协议—用于取代IPV4下的ARP协议
    假设PC1和PC2通讯
    1无2的MAC地址
    1)1封装ICMP type 135 NS—相当于ARP的请求
    源IPV6地址(1的接口ip地址) 目标IPV6地址----2的被请求节点组播地址 TTL=1
    源MAC地址(1的接口mac地址) 目标MAC地址----2的被请求节点组播地址对应的MAC

    2)2回应ICMP type 136 NA----相当于ARP的应答
    源IPV6地址(2接口ip) 目标ipv6地址–1的接口IPv6地址
    源MAC地址(2的接口mAC地址)目标mac地址–1的接口mac地址

    ICMPV6中的NDP除取代了AARP外,其他的ARP协议也可被NDP取代,原理一致;

    3、前缀通告------auto-config 仅在以太网环境存在
    路由器周期(200s)向下发送IPV6的地址前缀(网络号)

    路由器 PC
    ICMP type 134—RA ICMP type 133—ACK-RS
    源ip地址—接口ip地址 源ipv6地址— ::
    目标ip地址—FF02::1 TTL=1 目标ip地址----FF02::1 TTL=1
    目标MAC(所有节点MAC) 目标MAC(所有节点MAC)
    r1(config)#ipv6 unicast-routing r2(config-if)#ipv6 address autoconfig
    开启IPV6的单播路由功能,
    该功能开启后,设备上的auto-config
    被激活,同时可以收发IPV6路由协议信息;
    且可以为ipv6的流量进行路由;
    前提路由器接口上已经拥有合法ipv6的单播地址;

    只要在路由器上开启了IPV6的单播路由功能,那么该路由器将向所有存在IPV6地址的以太网接口周期发送其地址的前缀;

    注:在配置动、静态IPV6路由协议时,均需要开启单播路由功能,开启后也导致该路由器会向所有的以太网接口发送前缀,若该接口管理员不要auto-config功能,可以再关闭
    r1(config)#interface fastEthernet 0/0
    r1(config-if)#ipv6 nd suppress-ra

    IPV4和IPV6共存

    【1】普通tunnel
    r1(config)#interface tunnel 0
    r1(config-if)#ipv6 address 10::1/64 该tunnel接口必须工作于V6环境
    r1(config-if)#tunnel source 12.1.1.1
    r1(config-if)#tunnel destination 23.1.1.2
    r1(config-if)#tunnel mode ipv6ip 必须修改模式为ipv6ip

    注:普通的tunnel需要基于所有的ipv6网络配置一条隧道,且均需再配置一条静态路由;

    【2】6to4tunnel—仅需配置一条隧道,一条静态即可访问所有IPV6网络
    将边界路由器的公网IPV4地址换算为IPV4兼容性地址,然后将该地址应用到内网;再配置一条到兼容性地址的静态路由,通过隧道传递;传输数据时,一旦路由到达隧道口,隧道将根据目标IPV6地址计算对应的IPV4地址;

    优点:1、不需要指定tunnel 目标 2、一条静态路由即可

    12.1.1.1 兼容性地址:2002:C01:101::/48
    23.1.1.2 兼容性地址:2002:1701:102::/48

    注:该地址在使用时,一般将其划分为64位;

    配置:
    r1(config)#interface l0
    r1(config-if)#ipv6 address 2002:c01:101::1/64
    r1(config-if)#exit

    r1(config)#interface tunnel 0
    首先需要配置隧道接口的IPV6地址----4种方法
    r1(config-if)#ipv6 address 2002:c01:101:1::1/64 使用一个6TO4地址
    r1(config-if)#ipv6 address 2002:c01:101:2::/64 eui-64 使用6to4地址
    r1(config-if)#ipv6 enable 相当于不配地址
    r1(config-if)#ipv6 unnumbered loopback 0 借内网某个IPv6接口的地址

    r1(config-if)#tunnel source s1/1 定义IPV6源地址所在接口
    r1(config-if)#tunnel mode ipv6ip 6to4 模式标记

    R1(config)#ipv6 route 2002::/16 tunnel 0

    【3】双栈—一台设备同时连接IPV4/IPV6网络,若目标IP为V6地址使用V6的源ip,通过V6的路由表传递;V4同理;

    当进行DNS查询时,优先查询V6网络中的DNS 服务器;

    IPV6路由

    IPV6静态路由协议
    (1)普通静态路由
    r1(config)#ipv6 route 2::/64 serial 1/1
    r1(config)#ipv6 route 2::/64 12::2
    目标网络号 出接口或下一跳
    MA网络建议下一跳,点到点网络建议出接口

    (2)浮动静态路由–修改默认管理距离
    r1(config)#ipv6 route 3::/64 12::2 ?
    <1-254> Administrative distance

    (3)空接口防环
    r2(config)#ipv6 route 2::/63 null 0 ----在更新源路由器上,空接口指向汇总地址;

    (4)缺省路由
    r2(config)#ipv6 route ::/0 12::1

    注:带源ping 时,只能使用接口;或者使用扩展追踪;
    r3#ping 2::2 source loopback 0
    注:由于IPV6存在多宿主,使用接口为源时,默认使用第一地址来访问,建议扩展追踪
    r3#traceroute
    Protocol [ip]: ipv6
    Target IPv6 address: 2::2
    Source address: 3::3

    RIPNG----使用同RIPV2一样的算法;组播更新地址FF02::9 UDP 521
    r1(config)#ipv6 unicast-routing 开启单播路由功能
    r1(config)#ipv6 router rip ? 启动协议时需配置进程号,进程号仅具有本地意义
    WORD User selected string identifying this process

    r1(config)#ipv6 router rip a
    r1(config-rtr)#
    宣告的含义:1、激活接口 2.路由
    r1(config)#interface s1/1
    r1(config-if)#ipv6 rip a enable
    r1(config-if)#exit
    r1(config)#int lo0
    r1(config-if)#ipv6 rip a enable
    注:IPV6下到所有接口上进行配置

    手工汇总:更新源路由器上所有更新发出的接口上进行配置
    r1(config)#int s1/1
    r1(config-if)#ipv6 rip a summary-address 1::/63

    缺省路由:在边界路由器上所有同内网相连的接口上配置,使其向内网所有邻居发出一条缺省信息
    r3(config)#int s1/0
    r3(config-if)#ipv6 rip a default-information ?
    only Advertise only the default route
    originate Originate the default route
    选择only将发出缺省路由,同时其他的路由不会被转发
    选择originate 缺省和明细均发送

    OSPF V3 在原有OSPFV2的基础上,使用新的LSA来专门携带V6的信息;区域规则,SPF算法同IPV4下完全一致。

    r1(config)#ipv6 unicast-routing
    r1(config)#ipv6 router ospf 1 启动时需要配置进程号
    r1(config-rtr)#
    r1(config-rtr)#router-id 1.1.1.1 RID依然使用IPV4地址,规则同OSPF V2一致
    宣告:
    1、激活接口 2、传递路由 3、区域划分
    r1(config)#interface lo0
    r1(config-if)#ipv6 ospf 1 area 0
    r1(config-if)#int s1/1
    r1(config-if)#ipv6 ospf 1 area 0
    r1(config-if)#int lo1
    r1(config-if)#ipv6 ospf 1 area 0

    配置完成后生成邻居表,MA网络存在DR/BDR选举,选举规则同OSPFV2一致;
    另各个邻居间状态也一致;
    r1#show ipv6 ospf neighbor 邻居表

    Neighbor ID Pri State Dead Time Interface ID Interface
    2.2.2.2 1 FULL/ - 00:00:30 3 Serial1/1

    r2#show ipv6 ospf database 数据库表
    r1#show ipv6 route 路由表
    IPv6 Routing Table - 13 entries
    Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
    U - Per-user Static route
    I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
    O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
    ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
    缺省路由配置:在边界路由器上配置
    r3(config)#ipv6 router ospf 1
    r3(config-rtr)#default-information originate ?
    always Always advertise default route 强制发出
    metric OSPF default metric 修改起始度量
    metric-type OSPF metric type for default routes 修改度量类型,默认2
    route-map Route-map reference 关联route-map

    BGPV4+ 在BGPV4的基础上配置IPV6关系;
    r2(config)#router b 2
    r2(config-router)#b router-id 2.2.2.2
    r2(config-router)#neighbor 12::1 remote-as 1
    r2(config-router)#neighbor 3::3 remote-as 3
    r2(config-router)#neighbor 3::3 update-source loopback 0
    r2(config-router)#neighbor 3::3 ebgp-multihop
    此时邻居间仅存在V4下的邻居关系,没有V6关系;不能传递V6路由

    故需要在已经建立的V4邻居关系基础上再来建立V6的邻居关系,传递V6的信息
    注:BGP V4+使用家族模式来配置IPV6的信息,原理为在原有BGPV4的协议中开发出的扩展配置模式;
    r1(config-router)#address-family ipv6 进入IPV6家族模式
    r1(config-router-af)#neighbor 12::2 activate 和该邻居建立IPV6的邻居关系
    注:关于IPV6建邻以后所有配置必须全部在家族模式中进行;

    r1# show bgp ipv6 summary
    查看BGP的邻居关系
    r1#show bgp ipv6
    查看IPV6的BGP表

    总结:
    1.DUAL STACK 双栈 即使用IPV6又使用IPV4
    注:同时使用IPV6优于IPV4
    2.IPV6没有分片功能,他不需要分片,使用PDM最小MTU路径检测
    3.IPV6没有校验字段,在IP报头里面的校验字段IPV6不需要
    4.缺省路由 ::
    5.IPv6
    <1>unicast 全球可聚合地址 ------AGUA
    First ip:2000::
    last ip: 3FFF::
    最长用的地址:2001::/16 ipv6
    6to4 tunnel:2002::/16
    <2>multicast
    <3>anycast
    6.Link-local
    FE80::/10
    相当于MAC地址,只在一个广播域内生效
    每个接口一定有且仅有一个Link-local 地址,可以有多个AGUA地址,作为路由通告的下一跳地址的一定是Link-local 地址
    7.site-local
    FEC0::/10
    相当于ipv4的私有地址
    8.unspecified address
    v6: ::/0 缺省地址 v4: 0.0.0.0/0 缺省地址
    ::/128 非指定地址 v6: 0.0.0.0/32 非指定地址
    9.EUI-64
    EUI-64+Mac/48+FFE0 Mac/48第7为0/1互转
    EUI自动生成接口IP地址
    EUI可以生成link-local(永远自动生成)和AGUA
    网段内通信通link-local,全局通信用AGUA
    10.一个节点通过无状态地址自动获悉了接口的基于EUI-64的AGUA地址的同时,如果该设备是一台基于IPV6的PC,则该设备会同时指定给其分配网段前缀的路由器为其缺省网关。
    11.IPv6不能使用ARP,因为其不支持广播,使用ICMP135作为NS,使用ICMP136作为NA
    12.ICMP type 135/136 (NA/RS)/NS 取代ARP,检测重复地址DAD
    13.ICMP type 133/134 RA(只有以太网接口默认发送RA,关闭RA ipv6 nd ra suppress) 重编址,无状态地址自动获取
    14.ipv6 隐示三条ACE
    <1>permit icmp any any nd-ns
    <2>permit icmp any any nd-na
    <3>deny ipv6 any any
    15.IPV6的单播路由协议-----在使用路由协议前一定需要开启IPV6的单播路由功能,否则不转发IPV6的流量
    IPV6路由
    1.static
    一台路由器没有启用IPV6 Unocast-Routing一样可以配置静态路由,此时,路由只能实现去往邻居路由器直连接口的访问,无法隔跳访问,需要在路由器上启用IPV6 Unicast-Routing实现隔跳访问。
    对于出站接口是MA网段接口,写IPV6静态路由的时候需要伴随下一跳地址,不然无法访问,如果是P2P可以直接携带出站接口。
    2.RIPng
    该协议工作在应用层,UDP封装,端口号521,要配置进程号,具有全局意义。
    3.EIGRP (FF02::10)
    依旧是Cisco私有,是一个4层协议,对应的下一个包头字段值是88.
    进程号具有全局意义,一定要手工建立router-id,支持非等价负载均衡,只能修改内部管理距离,起EIGRP要no shutdown。
    4.OSPF
    进程号具有本地意义,使用OSPFV3,能显示串口的优先级
    5.ISIS
    在做重发布时要进入address-family ipv6模式下进行重发布
    6.BGP
    要进行IPV6单播路由的激活,在进行路由宣告时要在address-family ipv6模式下进行,在进行邻居建立时,要指下一跳也要在address-family ipv6模式下进行
    7.Overlay tunnel
    1:在IPV6边界路由器之间建立一个Tunnel口,建议将Tunnel 的源和目的设置为可达的环回口地址
    2:将Tunnel口的模式改为ipv6IP,实现让tunnel将ipv6报文封装成ipv4数据包
    3:在Tunnel起AGUA地址,保证Tunnel两端的地址在同一个ipv6网段内
    4:在Tunnel口两端将其宣告进某IGP协议,建立邻接关系并且传路由
    5:在两台边界路由器上将通过Tunnel口建立的协议和本地AS的协议单点双向重发布。
    8.6-to-4 tunnel
    1:将ipv6园区网内所有节点的地址迁移到2002(边界路由器Tunnel源)。
    2:在边界路由器启用6-to-4 tunnel,只用指定Tunnel Source.给该接口分配一个已经在本地其他接口使用的2002的IPV6地址ipv6 unnumbered
    3:边界路由器指定一条去往2002::/16的聚合路由直接指定出站接口为Tunnel口
    4:在该边界路由器上将聚合静态路由重发布进IGP,或向IGP域内下放缺省路由。

    关注我的微信公众号:hello521day ,大量网络,渗透、编程资料以及ppt等模板等你来取!

    在这里插入图片描述

    展开全文
  • ipv6

    2018-10-20 21:47:15
    简单记录一下ipv6学习笔记 首先ipv4包头与ipv6包头的对比,ipv6包头更加简单了   在ipv6中没有子网(网段)的概念了,也没有广播的概念了,变成了单播,组播和任播(anycast) 一、ipv6的几种常用的地址类型...

    简单记录一下ipv6学习笔记

    首先ipv4包头与ipv6包头的对比,ipv6包头更加简单了

     

    在ipv6中没有子网(网段)的概念了,也没有广播的概念了,变成了单播,组播和任播(anycast)

    一、ipv6的几种常用的地址类型:

    1、可聚合全球单播地址,AGUA公网地址

    2000:: 至 3FFF:FFFFFF结束

    其中2002::/16 的地址范围被用作ipv6to4自动隧道专用地址

    2、link-local链路本地地址,不会出现子RIB路由表中(所以使用该地址ping的时候要求命令中明确出接口),每个接口根据自己的MAC地址自动生成,这个地址是默认作为动态路由协议的更新源地址的,也就是说配置了动态路由后默认使用这个地址来宣告网络而不是接口配置的其他ipv6地址

    show ipv6 interface tunnel 0 查看链路本地地址:IPv6 is enabled, link-local address is FE80::1701:102

    在接口下使用ipv6 enable命令开启,link-local地址的格式固定为FE80::/10的地址范围,算法为:

    FE80::CE00.1330.0000                   第一步FE80::+接口48bitMAC地址

    FE80::CC00.13 FF.FE 30.0000       第二步MAC地址转化为二进制第7个bit取反(0和1互换,故CE变CC)并在中间插入FFFE

    FE80::CC00:13FF:FE30:0/10          得到link-local地址

    3、site-local站点本地地址,已经收回不关注,原为FEC0::/10格式

    4、未指定地址 ::/128,与ipv4中的0.0.0.0/32地址一样,用于地址dhcp discovery报文的源地址

    5、缺省地址 ::/0 默认路由地址

     

    二、ipv6中的NDP协议

    NDP协议分为以下4个消息报文,并使用组播地址,而不是广播,该组播地址是根据接口的ipv6地址前缀自动生成,一般格式为FF02::1:FFXX:XXXX/8,在这个组播地址内所有运行NDP的设备监听该地址

    NS(Neighbors Solocotation)消息,用于询问,类似arp,查询地址冲突或者请求对端MAC

    NA(Neighbors Advertisement)消息,用于回复,类似arp,回复MAC地址

    RS(Router Solocotation)消息,用于询问网关地址/64前缀,用于接口自动获取ipv6地址前缀(/64的)

    RA(Router Advertisement)消息,用于网关回复,用于接口自动获取ipv6地址前缀(/64)

    RS和RA功能使用命令:ipv6 unicast-routing

                                           interface g0/0

                                           ipv6 address autoconfig                 //自动(从网关)获取ipv6前缀相同的地址

                                           show ipv6 neighbors                      //查看NDP邻居信息

    三、ipv6组播地址

    FF00::/8 开头

    1111 1111 0000 0000::/8 开头,其中第一个0000表示为flag位,第二个0000表示为scope位

    flag位为0000表示永久组播地址,路由协议用固定的,0001表示临时组播地址,只有0000和0001

    scope位为0000-1111,其中0001地址范围表示本设备有效,0002表示本网段范围有效,0101表示本AS内有效,1000-1111表示整个Internet范围有效。比如0002(FF02)表示本网段有效的典型代表地址就是动态路由更新地址:

    FF02::1 本网内所有设备

    FF02::2 本网内所有路由器

    FF02::5-6 OSPFv3使用

    FF02::9 RIPv6使用

    FF02::10 EIGRPv6使用

    FF02::13 PIMv6使用

    ipv6组播MAC地址48bit,33.33开头固定,后32bit从组播ip中取最后32bit组成,如ospf的FF02::5组播地址的MAC地址是33.33.00.00.00.05,后面32bit是00.00.00.05(4*8=32bit)

     

    四、ipv6的路由协议

    1、静态路由和默认路由,必须出接口+下一跳

    ipv6 unicast-routing

    ipv6 route 2001:56::/64 g0/0 2001:12::2

    ipv6 route ::/0 g0/0 2001:12::2

    2、动态路由

    ipv6 unicast-routing

    ipv6 router eigrp 1                     //EIGRPv6

    router-id 1.1.1.1                        //必须有r-id否则邻居起不来

    exit

    internet g0/0

    ipv6 eigrp 1

    no shutdown                             //默认shutdown必须开启邻居才能建立

    exit 

     

    ipv6 unicast-routing

    ipv6 router ospf 1

    router-id 1.1.1.1                       //必须有r-id

    exit

    internet g0/0

    ipv6 ospf 1 area 0

    exit

     

    ipv6 unicast-routing

    router bgp 1

    bgp router-id 1.1.1.1

    no bgp default ipv4-unicast

    address-family ipv6 unicast

    neighbors 2001:12::2 remote-as 1

    neighbor 2001::12::2 update-source loopback 0

    neighbor 2001::12::2 activate

    network 1::1/64

    show ip bgp all 或show ip bgp ipv6 unicast

    show ip bgp ipv6 unicast summary

     

    五、ipv6重分发

    和ipv4一样路由协议里面使用redistribute命令进行充分发,区别是ipv6中默认不重分发直连路由(loopback接口除外)

    需要使用参数include-connected进行重分发直连路由,如:

    redistribute ospf 1 metric 1000000 100 255 255 1500 include-connected                 //eigrp中重分发ospf路由

    redistribute eigrp 1 include-connected                                                                       //ospf中重分发eigrp路由

     

    六、ipv4到ipv6的过度技术

    1、双栈技术,ipv4和ipv6的双向重分发,需要同时启用ipv4和ipv6协议,一般不用

    2、隧道技术,常用,分为三种GRE隧道、ipv6 over ipv4隧道、6to4自动隧

    2.1、GRE隧道技术配置

    ipv6 unicast-routing

    interface f0/0

    ip address 12.1.1.1 255.255.255.0

    exit

    interface tunnel 0

    ipv6 address 2001:13::1/64

    tunnel mode gre                                            //tunnel默认封装发就是GRE协议

    tunnel source 12.1.1.1

    tunnel destiation 23.1.1.3

    exit

    ip route 23.1.1.3 255.255.255.255 12.1.1.2

    ipv6 route 3::3/128 tunel0 2001::13::2

     

    2.2、ipv6 over ipv4隧道技术,把ipv6封装在ipv4中传输,与GRE隧道相同,唯一不同的就是直接将ipv6头部放在ipv4头部后面,中间去掉了GRE头部,节省了4Byte/每包

    ipv6 unicast-routing

    interface f0/0

    ip address 12.1.1.1 255.255.255.0

    exit

    interface tunnel 0

    ipv6 address 2001:13::1/64

    tunnel mode ipv6ip                                 //让tunnel接口使用ipv6ip协议封装报文,而非默认的GRE协议

    tunnel source 12.1.1.1

    tunnel destiation 23.1.1.3

    exit

    ip route 23.1.1.3 255.255.255.255 12.1.1.2

    ipv6 route 3::3/128 tunel0 2001::13::2

     

    2.3、6to4 自动隧道

    6to4专用隧道必须使用专用地址 2002:ipv4::/16 格式的,就是隧道访问的目的地址必须是该格式的地址才能建立隧道,本例中如左边R2的tunnel0接口源使用23.1.1.1/24,那么R1的ipv6地址就必须使用2002:ipv4::X/64格式的地址,那么最终2002:23.1.1.1::/64转换为2002:1701:0101::/64格式的地址,这种地址可以被识别为6to4自动隧道地址(的目的地址)

    转换规则:v4十进制转换二进制(使用8bit方式128 64 32 16 8 4 2 1),二进制在转换为v6十六进制(使用4bit方式8 4 2 1)

    其中需要将ipv4的十进制地址转换成ipv6的十六进制地址,ipv4地址指建立隧道的路由器的tunnel接口的ipv4地址,用这个地址去自动匹配6to4协议

    R2

    ipv6 unicast-routing

    interface f0/0

    ip address 23.1.1.1 255.255.255.0

    exit

    interface tunnel 0

    tunnel mode ipv6ip 6to4                                            //tunnel0使用ipv6ip 6to4自动隧道

    tunnel source 23.1.1.1                                              //只有源地址,目的地地址根据6to4协议自动匹配

    ipv6 enable                                                               //接口启用ipv6可以转发ipv6数据,并生成link-local地址用于隧道ipv6源

    exit

    ipv6 route 2002:1701:0102::/64 tunntl 0                     //没有下一跳

     

    R3

    ipv6 unicast-routing

    interface f0/0

    ip address 23.1.1.2 255.255.255.0

    exit

    interface tunnel 0

    tunnel mode ipv6ip 6to4                                            //tunnel0使用ipv6ip 6to4自动隧道

    tunnel source 23.1.1.2                                              //只有源地址,目的地地址根据6to4协议自动匹配

    ipv6 enable                                                               //接口启用ipv6可以转发ipv6数据,并生成link-local地址用于隧道ipv6源

    exit

    ipv6 route 2002:1701:0101::/64 tunntl 0                     //没有下一跳

     

    R1#ping 2002:1701:0102::1 source 2002:1701:0101::1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 2002:1701:102::1, timeout is 2 seconds:
    Packet sent with a source address of 2002:1701:101::1
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 12/24/32 ms
    R1#

    上面R1和R4需要默认路由 ipv6 route ::/0 GigabitEthernet1/0 2001::12:2,以及ipv6的ospf和eigrp就不在写配置了

    在R2上抓包看到的6to4自动隧道的报文格式:

     

    3、ipv6的NAT-PT地址转换技术(cisco中需要关闭CEF)

    就是让ipv4地址和ipv6地址通过nat转换然后实现互通,拓扑如下,需要R1的g1/0与R3的g1/0口互通,模拟在一个ipv6网络需要访问ipv4网络中的某个服务器的需求

    R1配置,模拟ipv6网络

    ipv6 unicast-routing

    interface GigabitEthernet1/0
     no ip address
     negotiation auto
     ipv6 address 2001:12::1/64

    ipv6 route 2001:2001::/64 GigabitEthernet1/0 2001:12::2

    R2配置,模拟NAT-PT网络设备

    ipv6 unicast-routing

    interface GigabitEthernet1/0
     ipv6 address 2001:12::2/64
     ipv6 nat
    !
    interface GigabitEthernet2/0
     ip address 23.1.1.1 255.255.255.0
     ipv6 nat

    !

    ipv6 nat v4v6 source 23.1.1.2 2001:2001::1
    ipv6 nat v6v4 source 2001:12::1 1.1.1.1
    ipv6 nat prefix 2001::/96

    R3配置,模拟ipv4网络服务器

    interface GigabitEthernet1/0
     ip address 23.1.1.2 255.255.255.0


    ip route 1.1.1.1 255.255.255.255 23.1.1.1

     

    R2#show ipv6 nat translations 
    Prot  IPv4 source              IPv6 source
          IPv4 destination         IPv6 destination
    ---   ---                      ---
          23.1.1.2                 2001:2001::1

    ---   1.1.1.1                  2001:12::1
          23.1.1.2                 2001:2001::1

    ---   1.1.1.1                  2001:12::1
          ---                      ---

    R2#

     

    R1#ping 2001:2001::1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 2001:2001::1, timeout is 2 seconds:
    !!!!!
    Success rate is 0 percent (0/5)
    R1#

     

    R3#ping 1.1.1.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
    !!!!!
    Success rate is 0 percent (0/5)
    R3#

     

    展开全文
  • 这里是有ipv6地址的 解决方案 通过在cmd上输入tracert bt.byr.cn命令。 如果成功了,那就可以直接使用了。 一般这样就会有另外一个问题(就是会发现) 爆出下面 这样的错误 无法解析目标系统...

    条件

    注意一下,这里有条件的!!
    这里是有ipv6地址的

    • 并且你需要改好host,否则也是不行的。可以根据下面的github上的来做修改
    • https://github.com/Sean16SYSU/ipv6-dns
    • Windows下的地址 C:\Windows\System32\drivers\etc>
    • 最新的hosts的更新结果,还有关于其他系统的如何修改,现在都放在了上面的github上了。

    解决方案

    通过在cmd上输入tracert bt.byr.cn命令。
    如果成功了,那就可以直接使用了。

    这里写图片描述

    一般这样就会有另外一个问题(就是会发现)

    爆出下面 这样的错误

    无法解析目标系统名称 bt.byr.cn。
    

    有两种种可能的解决方案。

    第一种:

    就是重启。。。 (没错 运维的神秘操作)

    重启一下路由器。

    第二种:

    第二种有针对性的,其他的用户可以做类似的处理。
    对于使用极路由的用户,需要把教育网ipv6的插件删除之后,重新安装一下。之后,再恢复网络之后。再用上面的命令就好了。

    后记

    成功之后的效果图,就是可以通过ipv6 科学上网呢

    这里写图片描述

    在这里插入图片描述

    展开全文
  • 详解IPv6

    千次阅读 多人点赞 2020-06-10 20:56:16
    IPv6的优势 IPv6的表示方式 IPv6的地址结构 接口标识生成方法 地址转换过程 IPv6地址分类 IPv6报文格式 IPv4报文格式 IPv4报文与IPv6报文区别 IPv6扩展报头
  • IPv6详解IPv6详解IPv6详解IPv6详解IPv6详解IPv6详解IPv6详解IPv6详解
  • 华为 IPv6过渡技术

    万次阅读 多人点赞 2020-06-29 15:29:03
    理解的执行,不理解的在执行中理解。 文章目录 一、IPv6 over IPv4 隧道简介 ...IPv6 over IPv4隧道可实现IPv6网络孤岛之间通过IPv4网络互连。由于IPv4地址的枯竭和IPv6的先进性,IPv4过渡为IPv6势在必行。
  • RHEL 7 & CentOS 7禁用IPV6

    万次阅读 2014-11-24 08:53:34
    RHEL 7 & CentOS 7下禁用IPV6的方法和之前的版本不太一样了,本文整理了一下处理方法:验证IPV6是否关闭首先,过去通过查看内核加载模块的方式看上去不是很有效了,在一个禁用了ipv6的Centos7下,使用# lsmod | grep...
  • IPV4与IPV6的区别(史上最详细)

    万次阅读 多人点赞 2019-01-09 13:25:39
    IPv6 地址 长度为 32 位(4 个字节)。地址由网络和主机部分组成,这取决于地址类。根据地址的前几位,可定义各种地址类:A、B、C、D 或 E。IPv4 地址的总数为 4 294 967 296。 IPv4 地址的文本格式为 ...

空空如也

1 2 3 4 5 ... 20
收藏数 36,227
精华内容 14,490
关键字:

ipv6