精华内容
下载资源
问答
  • IP地址规划入图中所示,现在通过python连接到SW1、SW2、SW3上做配置修改。 版本:python3.9 一、使用telnetlib修改eNSP交换机配置: 在SW1上配置了telnet,现在通过telnetlib模块连接到SW1并创建一个Loopback0接口...

    使用拓扑:

    在这里插入图片描述

    通过云来连接本地主机和eNSP中的设备,保证双方能互相通信。IP地址规划入图中所示,现在通过python连接到SW1、SW2、SW3上做配置修改。

    版本:python3.9

    一、使用telnetlib修改eNSP交换机的配置:

    在SW1上配置了telnet,现在通过telnetlib模块连接到SW1并创建一个Loopback0接口,ip地址为1.1.1.1/32。代码如下:

    #导入telnetlib模块
    import telnetlib
    
    #设置SW1的管理地址,用户名和密码三个变量
    host = "192.168.56.11"    
    
    user = "prin"
    
    password = "Huawei@123"
    
    #调用telnetlib的telnet函数,连接SW1,并将值赋予tn
    tn = telnetlib.Telnet(host)
    
    #调用read_until()函数,告诉python读到Username时输入user变量的值
    tn.read_until(b"Username:")
    tn.write(user.encode('ascii')+b"\n")
    
    #调用read_until()函数,告诉python读到PassWord时输入password变量的值
    tn.read_until(b"Password:")
    tn.write(password.encode('ascii')+b"\n")
    
    #通过write()函数输入配置的命令,完成后退出telnet
    tn.write(b"sys \n")
    
    tn.write(b"int l0 \n")
    
    tn.write(b"ip address 1.1.1.1 32 \n")
    
    tn.write(b"return \n")
    
    tn.write(b"quit\n")
    
    

    最终结果:可以看到在SW1上创建了Loopback0接口,并且有了IP地址。
    在这里插入图片描述

    二、使用netmiko修改eNSP交换机的配置:

    在SW2上配置了SSH,现在通过netmiko模块连接到SW2并创建一个Loopback0接口,ip地址为2.2.2.2/32。

    交换机SSH配置命令:

    # 创建秘钥
    [sw2]dsa local-key-pair create
    
    ## 配置SSH认证类型(密码/其他)
    [sw2]ssh user prin authentication-type password
    [sw2]ssh user prin service-type stelnet
    [sw2]stelnet server enable
    
    ## 配置认证模式
    [sw2]user-interface vty 0 4
    [sw2-ui-vty0-4]authentication-mode aaa  //配置认证模式
    [sw2-ui-vty0-4]protocol inbound ssh     //允许 ssh 连接虚拟终端
    
    ## 配置本地用户信息
    [sw2]aaa
    [sw2-aaa] local-user prin password cipher Huawei@123
    [sw2-aaa]local-user prin privilege level 15
    [sw2-aaa] local-user prin service-type ssh
    

    代码如下:

    #netmiko需要通过pip下载
    from netmiko import ConnectHandler
    
    #设备类型为huawei,除此之外,还支持绝大多数主流厂商的设备,这也是netmiko的优势;其余上参数分别为SW2的IP,SSH的用户名和密码
    SW2 ={
        'device_type': 'huawei',
        'ip': '192.168.56.22',
        'username': 'prin',
        'password': 'Huawei@123',
    }
    
    print("正在连接设备..........")
    #调用ConnectHandler()函数,用上一步创建的字典进行SSH连接,并且将返回值赋予connect变量,注意**不可以省略
    connect = ConnectHandler(**SW2)
    
    print("Successfully connected to "+SW2['ip'])
    
    #设置一个列表,其中为配置的命令,这里可以省略'sys'和'return',因为netmiko会自动加上
    config_commands = ['int l0','ip address 2.2.2.2 255.255.255.255']
    
    #调用connect的send_config_set()函数,发送配置命令,并打印出来
    output = connect.send_config_set(config_commands)
    print(output)
    
    #调用connect的send_command()函数,发送配置命令,并打印
    result = connect.send_command('dis ip int brief')
    
    print(result)
    
    #注意connect.send_command()仅能发送一个命令,而send_config_set()函数则可以一次性发送多个命令
    

    运行程序打印出来的结果:
    在这里插入图片描述

    注意,netmiko常见支持的设备如下:

    
    CLASS_MAPPER_BASE = {
        'a10': A10SSH,
        'accedian': AccedianSSH,
        'alcatel_aos': AlcatelAosSSH,
        'alcatel_sros': AlcatelSrosSSH,
        'apresia_aeos': ApresiaAeosSSH,
        'arista_eos': AristaSSH,
        'aruba_os': ArubaSSH,
        'avaya_ers': AvayaErsSSH,
        'avaya_vsp': AvayaVspSSH,
        'brocade_fastiron': RuckusFastironSSH,
        'brocade_netiron': BrocadeNetironSSH,
        'brocade_nos': BrocadeNosSSH,
        'brocade_vdx': BrocadeNosSSH,
        'brocade_vyos': VyOSSSH,
        'checkpoint_gaia': CheckPointGaiaSSH,
        'calix_b6': CalixB6SSH,
        'ciena_saos': CienaSaosSSH,
        'cisco_asa': CiscoAsaSSH,
        'cisco_ios': CiscoIosSSH,
        'cisco_nxos': CiscoNxosSSH,
        'cisco_s300': CiscoS300SSH,
        'cisco_tp': CiscoTpTcCeSSH,
        'cisco_wlc': CiscoWlcSSH,
        'cisco_xe': CiscoIosSSH,
        'cisco_xr': CiscoXrSSH,
        'coriant': CoriantSSH,
        'dell_force10': DellForce10SSH,
        'dell_os10': DellOS10SSH,
        'dell_powerconnect': DellPowerConnectSSH,
        'dell_isilon': DellIsilonSSH,
        'eltex': EltexSSH,
        'enterasys': EnterasysSSH,
        'extreme': ExtremeSSH,
        'extreme_wing': ExtremeWingSSH,
        'f5_ltm': F5LtmSSH,
        'fortinet': FortinetSSH,
        'generic_termserver': TerminalServerSSH,
        'hp_comware': HPComwareSSH,
        'hp_procurve': HPProcurveSSH,
        'huawei': HuaweiSSH,
        'huawei_vrpv8': HuaweiVrpv8SSH,
        'juniper': JuniperSSH,
        'juniper_junos': JuniperSSH,
        'linux': LinuxSSH,
        'mellanox': MellanoxSSH,
        'mrv_optiswitch': MrvOptiswitchSSH,
        'netapp_cdot': NetAppcDotSSH,
        'netscaler': NetscalerSSH,
        'ovs_linux': OvsLinuxSSH,
        'paloalto_panos': PaloAltoPanosSSH,
        'pluribus': PluribusSSH,
        'quanta_mesh': QuantaMeshSSH,
        'ruckus_fastiron': RuckusFastironSSH,
        'ubiquiti_edge': UbiquitiEdgeSSH,
        'ubiquiti_edgeswitch': UbiquitiEdgeSSH,
        'vyatta_vyos': VyOSSSH,
        'vyos': VyOSSSH,
    }
    

    三、使用paramiko修改eNSP交换机的配置:

    在SW2上配置了SSH,现在通过paramiko模块连接到SW3并创建一个Loopback0接口,ip地址为3.3.3.3/32。

    代码如下:

    #paramiko需要通过pip下载
    import paramiko
    #import time的目的是为了保证不会因为输入命令或者回显内容过快而导致SSH终端速度跟不上,仅能显示部分命令,而netmiko已经自动解决了此问题
    import time
    
    #创建三个变量,表示SW3的IP地址、SSH的用户名和密码
    ip = "192.168.56.33"
    username = "prin"
    password = "Huawei@123"
    
    #调用paramiko的SSHClient()函数,并赋值给ssh_client,表示本端作为SSH的客户端
    ssh_client = paramiko.SSHClient()
    
    #调用set_missing_host_key_policy()函数,用来接受SSH服务器端提供的公钥
    ssh_client.set_missing_host_key_policy(paramiko.AutoAddPolicy())
    
    #调用connect()函数,输入ip地址、ssh用户名和密码三个参数,进行连接
    ssh_client.connect(hostname=ip, username=username, password=password)
    
    print("Successfully connect to ", ip)
    
    #SSH连接成功后,需要使用invoke_shell()方法唤醒shell,并赋值给command
    command = ssh_client.invoke_shell()
    
    #调用command的send()函数,发送配置的信息给SW3
    command.send("sys \n")
    command.send("int l0 \n")
    command.send("ip address 3.3.3.3 32 \n")
    command.send("return \n")
    command.send("quit \n")
    
    #为了保证回显内容能够打印出来,需要先调用time模块的sleep()函数让python休眠2s
    time.sleep(2)
    
    #调用command的recv()函数截取回显的内容,并打印出来,65535表示截取65535个字符,也是一次性最大能够截取的
    output = command.recv(65535)
    print(output.decode("ascii"))
    
    #配置完成后,使用close方法退出SSH
    ssh_client.close()
    

    打印结果:
    在这里插入图片描述

    参考资料:《网络工程师的python之路》

    展开全文
  • eNSP交换机配置VLAN

    万次阅读 多人点赞 2019-05-13 22:42:35
    eNSP交换机配置VLAN 一、VLAN配置过程。 1. 搭建拓扑结构。 运行eNSP>新建拓扑>搭建如下图的拓扑结构>启动设备 2. 测试主机间连通性。 2.1 四台主机基础配置如下: PC1: IP地址:192.168.2.2 子网...

    eNSP交换机配置VLAN

    一、VLAN配置过程。
    1. 搭建拓扑结构。
    运行eNSP>新建拓扑>搭建如下图的拓扑结构>启动设备
    图1
    2. 测试主机间连通性。
    2.1 四台主机基础配置如下:

    PC1:   IP地址:192.168.2.2   子网掩码:255.255.255.0   网关:192.168.2.0
    PC2:   IP地址:192.168.2.3   子网掩码:255.255.255.0   网关:192.168.2.0
    PC3:   IP地址:192.168.2.4   子网掩码:255.255.255.0   网关:192.168.2.0
    PC4:   IP地址:192.168.2.5   子网掩码:255.255.255.0   网关:192.168.2.0
    

    2.2 测试主机间连通性:
    运用ping命令测试各主机间连通性。
    PC1:

    PC>ping 192.168.2.3
    
    Ping 192.168.2.3: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.3: bytes=32 seq=1 ttl=128 time=47 ms
    
    PC>ping 192.168.2.4
    
    Ping 192.168.2.4: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.4: bytes=32 seq=1 ttl=128 time=63 ms
    
    PC>ping 192.168.2.5
    
    Ping 192.168.2.5: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.5: bytes=32 seq=1 ttl=128 time=62 ms
    

    如上,PC1与其他三台主机间都能连通。
    PC2:

    PC>ping 192.168.2.2
    
    Ping 192.168.2.2: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.2: bytes=32 seq=1 ttl=128 time=47 ms
    
    PC>ping 192.168.2.4
    
    Ping 192.168.2.4: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.4: bytes=32 seq=1 ttl=128 time=79 ms
    
    PC>ping 192.168.2.5
    
    Ping 192.168.2.5: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.5: bytes=32 seq=1 ttl=128 time=32 ms
    

    如上,PC2与其他三台主机间都能连通。
    PC3与PC4经测试都能与其他三台主机连通,篇幅原因命令语句在此不进行展示。
    3. 配置交换机。
    3.1 配置交换机LSW1:
    3.1.1 进入管理员系统,构建VLAN2,VLAN3,查看VLAN。

    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]vlan 2
    [Huawei-vlan2]quit
    [Huawei]vlan 3
    [Huawei-vlan3]quit
    [Huawei]display vlan
    The total number of vlans is : 3
    --------------------------------------------------------------------------------
    U: Up;         D: Down;         TG: Tagged;         UT: Untagged;
    MP: Vlan-mapping;               ST: Vlan-stacking;
    #: ProtocolTransparent-vlan;    *: Management-vlan;
    --------------------------------------------------------------------------------
    
    VID  Type    Ports                                                          
    --------------------------------------------------------------------------------
    1    common  UT:Eth0/0/1(U)     Eth0/0/2(U)     Eth0/0/3(U)     Eth0/0/4(D)     
                    Eth0/0/5(D)     Eth0/0/6(D)     Eth0/0/7(D)     Eth0/0/8(D)     
                    Eth0/0/9(D)     Eth0/0/10(D)    Eth0/0/11(D)    Eth0/0/12(D)    
                    Eth0/0/13(D)    Eth0/0/14(D)    Eth0/0/15(D)    Eth0/0/16(D)    
                    Eth0/0/17(D)    Eth0/0/18(D)    Eth0/0/19(D)    Eth0/0/20(D)    
                    Eth0/0/21(D)    Eth0/0/22(D)    GE0/0/1(D)      GE0/0/2(D)      
    
    2    common  
    3    common  
    
    VID  Status  Property      MAC-LRN Statistics Description      
    --------------------------------------------------------------------------------
    
    1    enable  default       enable  disable    VLAN 0001                         
    2    enable  default       enable  disable    VLAN 0002                         
    3    enable  default       enable  disable    VLAN 0003      
    

    3.1.2 将0/0/1和0/0/2端口设置为access类型:

    [Huawei]interface Ethernet 0/0/1    
    [Huawei-Ethernet0/0/1]port link-type access
    [Huawei-Ethernet0/0/1]port default vlan 2  
    [Huawei-Ethernet0/0/1]quit 
    [Huawei]interface Ethernet 0/0/2
    [Huawei-Ethernet0/0/2]port link-type access
    [Huawei-Ethernet0/0/2]port default vlan 3
    [Huawei-Ethernet0/0/2]quit             
    [Huawei]
    

    3.1.3 将0/0/3端口设置为trunk类型:

    [Huawei]interface Ethernet 0/0/3
    [Huawei-Ethernet0/0/3]port link-type trunk
    [Huawei-Ethernet0/0/3]port trunk allow-pass vlan 2
    [Huawei-Ethernet0/0/3]port trunk allow-pass vlan 3
    [Huawei-Ethernet0/0/3]quit
    

    3.1.4 查看VLAN:

    [Huawei]display vlan
    The total number of vlans is : 3
    --------------------------------------------------------------------------------
    U: Up;         D: Down;         TG: Tagged;         UT: Untagged;
    MP: Vlan-mapping;               ST: Vlan-stacking;
    #: ProtocolTransparent-vlan;    *: Management-vlan;
    --------------------------------------------------------------------------------
    
    VID  Type    Ports                                                          
    --------------------------------------------------------------------------------
    1    common  UT:Eth0/0/3(U)     Eth0/0/4(D)     Eth0/0/5(D)     Eth0/0/6(D)     
                    Eth0/0/7(D)     Eth0/0/8(D)     Eth0/0/9(D)     Eth0/0/10(D)    
                    Eth0/0/11(D)    Eth0/0/12(D)    Eth0/0/13(D)    Eth0/0/14(D)    
                    Eth0/0/15(D)    Eth0/0/16(D)    Eth0/0/17(D)    Eth0/0/18(D)    
                    Eth0/0/19(D)    Eth0/0/20(D)    Eth0/0/21(D)    Eth0/0/22(D)    
                    GE0/0/1(D)      GE0/0/2(D)                                      
    
    2    common  UT:Eth0/0/1(U)                                                     
    
                 TG:Eth0/0/3(U)                                                     
    
    3    common  UT:Eth0/0/2(U)                                                     
    
                 TG:Eth0/0/3(U)                                                     
    
    
    VID  Status  Property      MAC-LRN Statistics Description      
    --------------------------------------------------------------------------------
    
    1    enable  default       enable  disable    VLAN 0001                         
    2    enable  default       enable  disable    VLAN 0002                         
    3    enable  default       enable  disable    VLAN 0003                         
    [Huawei]
    

    3.2 配置交换机LSW2:
    步骤同上,配置LSW2,在此不描述详细步骤,只展示交换机命令。

    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]vlan 2
    [Huawei-vlan2]quit 
    [Huawei]vlan 3
    [Huawei-vlan3]quit
    [Huawei]interface Ethernet 0/0/1
    [Huawei-Ethernet0/0/1]port link-type access 
    [Huawei-Ethernet0/0/1]port default vlan 3
    [Huawei-Ethernet0/0/1]quit
    [Huawei]interface Ethernet 0/0/2
    [Huawei-Ethernet0/0/2]port link-type access 
    [Huawei-Ethernet0/0/2]port default vlan 2
    [Huawei-Ethernet0/0/2]quit 
    [Huawei]interface Ethernet 0/0/3
    [Huawei-Ethernet0/0/3]port link-type trunk
    [Huawei-Ethernet0/0/3]port trunk allow-pass vlan 2
    [Huawei-Ethernet0/0/3]port trunk allow-pass vlan 3
    [Huawei-Ethernet0/0/3]quit 
    [Huawei]display vlan 
    The total number of vlans is : 3
    --------------------------------------------------------------------------------
    U: Up;         D: Down;         TG: Tagged;         UT: Untagged;
    MP: Vlan-mapping;               ST: Vlan-stacking;
    #: ProtocolTransparent-vlan;    *: Management-vlan;
    --------------------------------------------------------------------------------
    
    VID  Type    Ports                                                          
    --------------------------------------------------------------------------------
    1    common  UT:Eth0/0/3(U)     Eth0/0/4(D)     Eth0/0/5(D)     Eth0/0/6(D)     
                    Eth0/0/7(D)     Eth0/0/8(D)     Eth0/0/9(D)     Eth0/0/10(D)    
                    Eth0/0/11(D)    Eth0/0/12(D)    Eth0/0/13(D)    Eth0/0/14(D)    
                    Eth0/0/15(D)    Eth0/0/16(D)    Eth0/0/17(D)    Eth0/0/18(D)    
                    Eth0/0/19(D)    Eth0/0/20(D)    Eth0/0/21(D)    Eth0/0/22(D)    
                    GE0/0/1(D)      GE0/0/2(D)                                      
    
    2    common  UT:Eth0/0/2(U)                                                     
    
                 TG:Eth0/0/3(U)                                                     
    
    3    common  UT:Eth0/0/1(U)                                                     
    
                 TG:Eth0/0/3(U)                                                     
    
    
    VID  Status  Property      MAC-LRN Statistics Description      
    --------------------------------------------------------------------------------
    
    1    enable  default       enable  disable    VLAN 0001                         
    2    enable  default       enable  disable    VLAN 0002                         
    3    enable  default       enable  disable    VLAN 0003                         
    [Huawei]	
    

    至此,两台交换机配置完成。
    4.实验验证。
    4.1 测试VLAN中各主机间连通性:
    ping命令测试:
    PC1:

    PC>ping 192.168.2.3
    
    Ping 192.168.2.3: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.2: Destination host unreachable
    From 192.168.2.2: Destination host unreachable
    From 192.168.2.2: Destination host unreachable
    From 192.168.2.2: Destination host unreachable
    From 192.168.2.2: Destination host unreachable
    
    --- 192.168.2.3 ping statistics ---
      5 packet(s) transmitted
      0 packet(s) received
      100.00% packet loss
    
    PC>ping 192.168.2.4
    
    Ping 192.168.2.4: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.2: Destination host unreachable
    From 192.168.2.2: Destination host unreachable
    From 192.168.2.2: Destination host unreachable
    From 192.168.2.2: Destination host unreachable
    From 192.168.2.2: Destination host unreachable
    
    --- 192.168.2.4 ping statistics ---
      5 packet(s) transmitted
      0 packet(s) received
      100.00% packet loss
    
    PC>ping 192.168.2.5
    
    Ping 192.168.2.5: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.5: bytes=32 seq=1 ttl=128 time=62 ms
    From 192.168.2.5: bytes=32 seq=2 ttl=128 time=78 ms
    From 192.168.2.5: bytes=32 seq=3 ttl=128 time=78 ms
    From 192.168.2.5: bytes=32 seq=4 ttl=128 time=47 ms
    From 192.168.2.5: bytes=32 seq=5 ttl=128 time=63 ms
    
    --- 192.168.2.5 ping statistics ---
      5 packet(s) transmitted
      5 packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 47/65/78 ms
    

    PC2:

    PC>ping 192.168.2.2
    
    Ping 192.168.2.2: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.3: Destination host unreachable
    From 192.168.2.3: Destination host unreachable
    From 192.168.2.3: Destination host unreachable
    From 192.168.2.3: Destination host unreachable
    From 192.168.2.3: Destination host unreachable
    
    --- 192.168.2.2 ping statistics ---
      5 packet(s) transmitted
      0 packet(s) received
      100.00% packet loss
    
    PC>ping 192.168.2.4
    
    Ping 192.168.2.4: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.4: bytes=32 seq=1 ttl=128 time=63 ms
    From 192.168.2.4: bytes=32 seq=2 ttl=128 time=62 ms
    From 192.168.2.4: bytes=32 seq=3 ttl=128 time=63 ms
    From 192.168.2.4: bytes=32 seq=4 ttl=128 time=62 ms
    From 192.168.2.4: bytes=32 seq=5 ttl=128 time=63 ms
    
    --- 192.168.2.4 ping statistics ---
      5 packet(s) transmitted
      5 packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 62/62/63 ms
    
    PC>ping 192.168.2.5
    
    Ping 192.168.2.5: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.3: Destination host unreachable
    From 192.168.2.3: Destination host unreachable
    From 192.168.2.3: Destination host unreachable
    From 192.168.2.3: Destination host unreachable
    From 192.168.2.3: Destination host unreachable
    
    --- 192.168.2.5 ping statistics ---
      5 packet(s) transmitted
      0 packet(s) received
      100.00% packet loss
    

    PC3:

    PC>ping 192.168.2.2
    
    Ping 192.168.2.2: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.4: Destination host unreachable
    From 192.168.2.4: Destination host unreachable
    From 192.168.2.4: Destination host unreachable
    From 192.168.2.4: Destination host unreachable
    From 192.168.2.4: Destination host unreachable
    
    --- 192.168.2.2 ping statistics ---
      5 packet(s) transmitted
      0 packet(s) received
      100.00% packet loss
    
    PC>ping 192.168.2.3
    
    Ping 192.168.2.3: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.3: bytes=32 seq=1 ttl=128 time=63 ms
    From 192.168.2.3: bytes=32 seq=2 ttl=128 time=62 ms
    From 192.168.2.3: bytes=32 seq=3 ttl=128 time=63 ms
    From 192.168.2.3: bytes=32 seq=4 ttl=128 time=63 ms
    From 192.168.2.3: bytes=32 seq=5 ttl=128 time=62 ms
    
    --- 192.168.2.3 ping statistics ---
      5 packet(s) transmitted
      5 packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 62/62/63 ms
    
    PC>ping 192.168.2.5
    
    Ping 192.168.2.5: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.4: Destination host unreachable
    From 192.168.2.4: Destination host unreachable
    From 192.168.2.4: Destination host unreachable
    From 192.168.2.4: Destination host unreachable
    From 192.168.2.4: Destination host unreachable
    
    --- 192.168.2.5 ping statistics ---
      5 packet(s) transmitted
      0 packet(s) received
      100.00% packet loss
    

    PC4:

    PC>ping 192.168.2.2
    
    Ping 192.168.2.2: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.2: bytes=32 seq=1 ttl=128 time=94 ms
    From 192.168.2.2: bytes=32 seq=2 ttl=128 time=31 ms
    From 192.168.2.2: bytes=32 seq=3 ttl=128 time=62 ms
    From 192.168.2.2: bytes=32 seq=4 ttl=128 time=63 ms
    From 192.168.2.2: bytes=32 seq=5 ttl=128 time=62 ms
    
    --- 192.168.2.2 ping statistics ---
      5 packet(s) transmitted
      5 packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 31/62/94 ms
    
    PC>ping 192.168.2.3
    
    Ping 192.168.2.3: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.5: Destination host unreachable
    From 192.168.2.5: Destination host unreachable
    From 192.168.2.5: Destination host unreachable
    From 192.168.2.5: Destination host unreachable
    From 192.168.2.5: Destination host unreachable
    
    --- 192.168.2.3 ping statistics ---
      5 packet(s) transmitted
      0 packet(s) received
      100.00% packet loss
    
    PC>ping 192.168.2.4
    
    Ping 192.168.2.4: 32 data bytes, Press Ctrl_C to break
    From 192.168.2.5: Destination host unreachable
    From 192.168.2.5: Destination host unreachable
    From 192.168.2.5: Destination host unreachable
    From 192.168.2.5: Destination host unreachable
    From 192.168.2.5: Destination host unreachable
    
    --- 192.168.2.4 ping statistics ---
      5 packet(s) transmitted
      0 packet(s) received
      100.00% packet loss
    

    4.2 测试结果:
    通过ping命令测试,可得结果为:

    PC1与PC4之间相互连通,与PC2、PC3不通。
    PC2与PC3之间相互连通,与PC1、PC4不通。
    PC3与PC2之间相互连通,与PC1、PC4不通。
    PC4与PC1之间相互连通,与PC2、PC3不通。
    

    4.3 实验结论:

    PC1与PC4属于VLAN2;
    PC2与PC3属于VLAN3.
    VLAN构建成功。
    

    二、相关知识点。

    1.什么是VLAN?
    VLAN(Virtual Local Area Network)的中文名为"虚拟局域网"。

    虚拟局域网(VLAN)是一组逻辑上的设备和用户,这些设备和用户并不受物理位置的限制,可以根据功能、部门及应用等因素将它们组织起来,相互之间的通信就好像它们在同一个网段中一样,由此得名虚拟局域网。

    2.VLAN的作用。
    通过划分不同的VLAN,VLAN内的主机间可以直接通信,而VLAN间不能直接互通,从而将广播报文限制在一个VLAN内。
    作用:限制广播域、增强局域网的安全性(不同VLAN用户不能直接通信)、提高网络的健壮性(限制故障)、灵活构建虚拟工作组(同一VLAN用户不局限于固定的物理范围)。

    3. VLAN的优点。
    3.1 端口的分隔。
    即便在同一个交换机上,处于不同VLAN的端口也是不能通信的。这样一个物理的交换机可以当作多个逻辑的交换机使用。
    3.2 网络的安全。
    不同VLAN不能直接通信,杜绝了广播信息的不安全性。
    3.3 灵活的管理。
    更改用户所属的网络不必换端口和连线,只需更改软件配置。
    VLAN技术的出现,使得管理员根据实际应用需求,把同一物理局域网内的不同用户逻辑地划分成不同的广播域,每一个VLAN都包含一组有着相同需求的计算机工作站,与物理上形成的LAN有着相同的属性。由于它是从逻辑上划分,而不是从物理上划分,所以同一个VLAN内的各个工作站没有限制在同一个物理范围中,即这些工作站可以在不同物理LAN网段 。由VLAN的特点可知,一个VLAN内部的广播和单播流量都不会转发到其他VLAN中,从而有 助于控制流量、减少设备投资、简化网络管理、提高网络的安全性。 VLAN除了能将网络划 分为多个广播域,从而有效地控制广播风暴的发生,以及使网络的拓扑结构变得非常灵活 的优点外,还可以用于控制网络中不同部门、不同站点之间的互相访问。

    4.交换机端口类型。
    4.1 Access
    Access类型的端口只能属于1个VLAN,一般用于连接计算机的端口;
    4.2 Trunk
    Trunk类型的端口可以允许多个VLAN通过,可以接收和发送多个VLAN的报文,一般用于交换机之间连接的端口;
    4.3 Hybrid
    Hybrid类型的端口可以允许多个VLAN通过,可以接收和发送多个VLAN的报文,可以用于交换机之间连接,也可以用于连接用户的计算机。

    Hybrid端口和Trunk端口在接收数据时,处理方法一样,唯一不同之处在于发送数据时:Hybrid端口可以允许多个VLAN的报文发送时不打标签,而Trunk端口只允许缺省VLAN的报文发送时不打标签。

    展开全文
  • cloud连接本机,ip地址为192.168.56.1,五台交换机配置的地址为192.168.1.11~55。现在通过paramiko,ssh进入五台设备,并且在五台设备上分别创建vlan10-vlan20这11个VLAN。 实验步骤: 一、ssh配置: ## 创建秘钥 ...

    实验拓扑:

    在这里插入图片描述
    cloud连接本机,ip地址为192.168.56.1,五台交换机的配置的地址为192.168.1.11~55。现在通过paramiko,ssh进入五台设备,并且在五台设备上分别创建vlan10-vlan20这11个VLAN。

    版本:python3.9

    实验步骤:

    一、ssh配置:

    ## 创建秘钥
    [sw2]dsa local-key-pair create
    
    ## 配置SSH认证类型(密码/其他)
    [sw2]ssh user prin authentication-type password
    [sw2]ssh user prin service-type stelnet
    [sw2]stelnet server enable
    
    ## 配置认证模式
    [sw2]user-interface vty 0 4
    [sw2-ui-vty0-4]authentication-mode aaa  //配置认证模式
    [sw2-ui-vty0-4]protocol inbound ssh     //允许 ssh 连接虚拟终端
    
    ## 配置本地用户信息
    [sw2]aaa
    [sw2-aaa] local-user prin password cipher Huawei@123
    [sw2-aaa]local-user prin privilege level 15
    [sw2-aaa] local-user prin service-type ssh
    

    二、python脚本:

    import paramiko
    import time
    import getpass
    
    #使用input函数,输入SSH的用户名
    username = input('Username: ')
    #通过getpass()函数接收密码,密码是不可见的,但是在windows上有bug,密码可见
    password = getpass.getpass('Password: ')
    
    #创建一个列表,表示五台设备最后8位的地址
    ip_tail_list = [11, 22, 33, 44, 55]
    
    #使用for循环,接受SSH的秘钥,并分别依次连接到五台设备,注意需要将i转化为字符串
    for i in ip_tail_list:
        ip = "192.168.56." + str(i) 
        ssh_client = paramiko.SSHClient()
        ssh_client.set_missing_host_key_policy(paramiko.AutoAddPolicy())
        ssh_client.connect(hostname=ip, username=username, password=password)
    
        print("Successfully connect to ", ip)
    
    #使用invoke_shell()唤醒shell界面
        command = ssh_client.invoke_shell()
    
    #使用command.send()函数创建VLAN,并且设置每个VLAN的描述;未来保证设备能够正常接受配置,每次创建1个VLAN后休息1s
        command.send("system \n")
    
        for n in range(10, 21):
            print("Creating Vlan " + str(n))
            command.send("vlan " + str(n) + "\n")
            command.send("description Python Vlan" + str(n) + "\n")
            time.sleep(1)
    
    #保存配置,并且通过command.recv()函数得到回信的信息,最多接受65535个字符
        command.send("return \n")
        command.send("save \n"+"y \n"+"\n")
        time.sleep(2)
        output = command.recv(65535)
        print(output.decode('ascii'))
    
    #关闭连接
    ssh_client.close()
    
    

    如果管理的设备数目过多,可以直接通过读取txt文件的方式获取IP地址,仅需要将如下代码:

    #创建一个列表,表示五台设备最后8位的地址
    ip_tail_list = [11, 22, 33, 44, 55]
    
    #使用for循环,接受SSH的秘钥,并分别依次连接到五台设备,注意需要将i转化为字符串
    for i in ip_tail_list:
        ip = "192.168.56." + str(i) 
        ssh_client = paramiko.SSHClient()
        ssh_client.set_missing_host_key_policy(paramiko.AutoAddPolicy())
        ssh_client.connect(hostname=ip, username=username, password=password)
    #......省略中间部分
    ssh_client.close()
    

    更换为下述即可:

    #使用open()函数打开ip_list文件,并将读取的结果赋予f
    f = open("ip_list.txt","r")
    
    #调用readlines()函数,返回IP地址的列表,并使用for循环遍历;注意使用readlines()的每一个ip地址后带有\n,需要通过strip()函数去除
    for i in f.readlines():
        ip = i.strip()
        ssh_client = paramiko.SSHClient()
        ssh_client.set_missing_host_key_policy(paramiko.AutoAddPolicy())
        ssh_client.connect(hostname=ip, username=username, password=password)
    #.......省略中间部分,在完成文件操作后,关闭文件
    f.close()
    ssh_client.close()
    

    执行效果:

    在这里插入图片描述

    在设备上检查是否配置成功,以SW1为例:
    在这里插入图片描述
    可以看到创建VLAN和添加VLAN描述成功。

    参考资料:《网络工程师的python之路》

    展开全文
  • ensp交换机实验

    2020-12-24 11:27:10
    ensp交换机实验拓扑图DHCP自动配分IP地址 拓扑图 先进行配置两台PC的IP。 然后在打开LSW2进行配置 这里我给交换机和PC1这条线上赋予了一个access接口,然后把vlan 100分配在这个接口。 PC2和上图步骤一致。略… ...

    拓扑图

    在这里插入图片描述
    先进行配置两台PC的IP。
    在这里插入图片描述
    在这里插入图片描述

    然后在打开LSW2进行配置
    在这里插入图片描述
    这里我给交换机和PC1这条线上赋予了一个access接口,然后把vlan 100分配在这个接口。
    PC2和上图步骤一致。略…

    然后在进入交换机与交换机连接的接口:
    配置为trunk接口,交换机与交换机之间不能使用access接口来执行
    在使用port trunk allow-pass vlan 100 200(这里我使用vlan 100 200 释义是只能100和200可以通过)
    注:接口有4094个,如果vlan all可以全部通过。
    在这里插入图片描述
    LSW2配置完成,在进行LSW1配置
    代码如下:
    port link-type trunk port trunk allow-pass vlan 100 200
    这里第一步也需要配置vlan 100 vlan 200
    在这里插入图片描述
    接下来在给vlan 100 和vlan 200 赋予一个ip,ip为PC1和PC2的网关。
    interface vlan 100

    在这里插入图片描述
    interface vlan 200
    在这里插入图片描述
    然后在进PC1进行ping功能
    ping 192.168.100.254
    在这里插入图片描述

    DHCP自动配分IP地址

    将静态IP改成DHCP
    在这里插入图片描述
    开启dhcp功能
    在这里插入图片描述
    然后进入vlan 100里面输入代码:
    dhcp select interface
    在这里插入图片描述
    分配成功!
    在这里插入图片描述
    个人实验报告(切勿盗取)!小白上手,勿喷!

    展开全文
  • 1.配置两台主机各自的ip地址,掩码和网关地址 2.进入三层交换机进行配置 ①创建vlan35,进入g0/0/6端口设置access模式并把端口加入vlan35 ②设置vlanif 35的ip地址为PC1的网关地址 ③进入g0/0/1...
  • 2.IP地址自行规划设计和VLAN划分 3.对设备进行配置 (1)二层交换机配置 <Huawei>system-view [Huawei]vlan 2 [Huawei-vlan2]quit [Huawei]vlan 3 [Huawei-vlan3]quit [Huawei]int e0/0/2 [Huawei-...
  • 一、实验要求:1、SW为核心交换机,下挂着多个用户VLAN,从Vlan11到Vlan17,共计7个VLAN,每个VLAN对应的IP地址段如图所示。VLAN用户的网关均在核心交换机上;2、SW使用vlan200与R1进行三层对接;3、R2上有多个直连...
  • 今发现的ENSP不支持功能列表如下:1、NAT2、三层接口ACL3、路由器上做VRRP(虚拟网关不通)三层交换上通过interface VLAN可以...拓扑如下:IP规划如下:所有设备Loo0使用设备编号,如R1就用1.1.1.1/32设备间互联地址使...
  • 配置交换机基于接口划分VLAN,实现二层转发。 配置防火墙作为用户的网关,通过子接口或VLANIF接口实现跨网段的三层转发。 配置防火墙作为DHCP服务器,为用户PC分配IP地址。 开启防火墙域间安全策略...
  • 2、掌握IP分配、网关设置原则; 3、了解路由协议的作用,掌握网络互联设备的作用和配置。 1、实验环境 环境:eNSP模拟器 版本信息:1.3.00.100 V100R003C00 SPC100 设备:路由器三台(AR3260)、交换机三台(S5700)、...
  • 1、单台交换机上使用VLAN来隔离连接在其上的终端之间的...3、配置交换机管理IP地址测试PC与交换机间的逻辑联通 在实验2的基础上进行实验,拓扑图相同,交换机配置大体相同 lsw1相较于实验2增加的配置命令 验证 ...
  • 如图所示,配置pc1~pc4(从左至右的顺序)的IP地址和子网掩码2.交换机SW1下的接口为0/0/1和0/0/2,交换机SW2下的接口为0/0/3和0/0/4,交换机之间的接口为0/0/243. 进入交换机SW1进行配置[SW1]vlan 5 //创建一个端口为...
  • PC1的IP地址192.168.10.1,vlan 10 网关192.168.10.254 PC2的IP地址192.168.10.2,vlan 10 网关192.168.10.254 PC3的IP地址192.168.20.1,vlan 20 网关192.168.20.254 PC4的IP地址192.168.30.1,vlan 30 网关192.168...
  • eNSP模拟帧中继交换机 (1)实验拓扑(路由器配置里添加2SA接口,帧中继交换机设置里添加映射) (2)编写帧中继转发表 ... fr map ip 192.168.1.2 102 //配置到R2的静态地址映射; fr map ip 192.16...
  • VRRP是一种网关备份和负载均衡技术,以实现用户网络的多网关备份和负载均衡,主要用于WAN接入线路的备份和负载均衡接口和双机...在交换机上部署VRRP功能时需注意:1、不同备份组之间的虚拟IP地址不能重复,并且必...
  • 使用ensp模拟器中的三层交换机配置vrrp 关于vrrp的介绍、相关术语、状态及使用路由器配置vrrp请...如图配置好相应的ip地址、子网掩码和网关。 LSW1: [lsw1]vlan batch 10 20 [lsw1]interface Ethernet0/0/1 [lsw1-...
  • eNSP软件模拟DHCP协议分配IP地址

    千次阅读 2020-06-24 17:24:01
    实验内容:根据eNSP拓扑图来配置交换机跟路由器。 实验目标:各台PC主机设置为DHCP模式,并且可以获得IP地址,且互相可以通信。 实验结果:通过在主机上,用ipconfig命令查看或的IP地址,再用抓包工具看DHCP规则模 ...
  • 两台交换机S5720通过堆叠线进行堆叠,并设置虚拟管理IP地址为172.30.5.1;与防火墙USG6305E进行互联,,防火墙IP地址...防火墙配置如下:设置 vlanif 5 的接口类型及IP地址: 端口GE0/0/0 以及 GE0/0/1 加入到vlanif...
  • 实验: 1.配置IP 为什么无法配置IP? 配置vlanif,完成和路由器的直连通信,然后远程管理 [SW1]interface g0/0/10 ...[SW1-GigabitEthernet0/0/10]ip address 10.1.1.254 24 //交换接口无法执行配置IP地址的命令...
  • 华为S5700交换机配置 不同vlan 间通信—eNSP ...2、通过vlanif 口为 不同的交换机 配直 IP地址(作为网关地址,实际只是配置一个IP,具体的通过在终端制定网关为上述地址) 具体代码 交换机S1 undo ter mon system-
  • eNSP华为模拟器 基于三层交换机的单臂路由配置 一、实验概述 二、二层交换机配置 三、三层交换机配置 四、实验结果 一、实验概述 实验要求:完成单臂路由的设计与配置 实验内容: 一、按照以下的拓扑连接,自行...
  • 一、实验要求:1、网络拓扑如上图所示。...其中双方的GE0/0/23接口通过一条低带宽链路互联,采用VLAN11对接(IP地址段为192.168.11.0/24);另外双方的GE0/0/24接口通过另一条线路互联,该条线路中存在一台非可网管...
  • 华为eNSP配置备份网关

    千次阅读 2019-12-21 18:18:30
    直接在面相PC或交换机的端口配置命令 vrrp vrid 1 virtual-ip 192.168.1.1 将端口虚拟成此地址 Vrrp vrid 1 priority 120 更改vvrp的优先级 vrrp vrid 1 track interface GigabitEthernet 0/0/0 reduced 30 惩罚值...
  • 五台交换机IP地址如图上所示。 在五台交换机的上配置SSH,后续在PC上通过paramiko进行连接,SSH和paramiko连接代码具体配置参考如下文章: https://blog.csdn.net/tushanpeipei/article/details/113730861 需要在...
  • 华为模拟器eNSP将防火墙配置成三层核心交换机

    千次阅读 多人点赞 2020-06-09 01:37:12
    首先配置PC1、PC2、PC3、PC4、R1、R2、R3的接口,IP地址,掩码,网关 PC1: PC2: PC3: R1: sys un in en sysname R1 int e0/0/0 ip address 192.168.70.7 24 dis this quit R2: sys un in en sysname R2 int ...
  • eNspVlan配置

    2020-08-28 09:40:49
    二层交换机1-2口划分到VLAN 100;...PC1的IP地址为100.100.学号.1,PC2的IP地址为100.100.学号.2, PC3的IP地址为200.200.学号.1,PC4的IP地址为200.200.学号.2。 配置后实现PC1、PC2、PC3、PC4之间能够互通。
  • eNSP为什么直连交换机防火墙却ping不通交换机

    千次阅读 多人点赞 2021-04-03 14:57:09
    按道理来说防火墙他的默认有配IP地址为什么ping不通 防火墙默认的IP地址192.168.0.1 那好我们在g0/0/1的接口给它配置IP为10.10.10.1如图 接下来我们要为路由器改名和弄IP我们在去ping一下防火墙看看能不能...
  • 小型园区网典型组网拓扑图组网需求:1.接入交换机与核心交换机通过Eth-Trunk组网保证可靠...4.接入交换机配置DHCP Snooping功能,防止内网用户私接小路由器分配IP地址。5.同时配置IPSG功能,防止内网用户私自更改I...
  • 实验拓扑图: 实验目的: 不同的vlan下不能通信 相同的vlan下可以通信 补充什么是二层设备?什么是三层设备 简单理解 二层设备是基于MAC地址表进行...交换机记录IP地址对应的端口号和MAC地址。 由于直到数据链路层,所

空空如也

空空如也

1 2 3 4 5 ... 10
收藏数 189
精华内容 75
关键字:

ensp配置交换机ip地址