精华内容
下载资源
问答
  • ospf路由聚合
    2020-04-07 17:51:42


    1、 全区域启动OSPF协议,a2为NSSA区域,R4写静态到R5,R5写缺省到R4
    2、 区域1的交换机配置四个虚拟接口分别为vlanif1,2,3,4,vlanif1配置ip连接R1,其他三个虚拟接口分别对应三台PC
    3、 在区域2的R3上进行路由聚合,不能再r2上,route-id大的优先

    聚合前查看ospf数据库
    		 AS External Database
     Type      LinkState ID    AdvRouter          Age  Len   Sequence   Metric
     External  20.0.5.1        10.0.3.3            58  36    80000002       1
     External  20.0.5.0        10.0.3.3            63  36    80000005       1
     External  20.0.5.3        10.0.3.3            61  36    80000007       1
         External  20.0.5.2        10.0.3.3            61  36    80000002       1
    在R3上聚合后
    		 AS External Database
     Type      LinkState ID    AdvRouter          Age  Len   Sequence   Metric
         External  20.0.5.0        10.0.3.3           132  36    80000005       1
    

    4、 在R1上对区域1的路由进行聚合聚合前,查看数据库,多余的在文档删掉

    <r1>dis ospf lsdb
    	 OSPF Process 1 with Router ID 10.0.1.1
    		 Link State Database 
    		         Area: 0.0.0.0
     Type      LinkState ID    AdvRouter          Age  Len   Sequence   Metric
     Sum-Net   20.0.3.0        10.0.1.1           592  28    80000001       2
     Sum-Net   20.0.2.0        10.0.1.1           592  28    80000001       2
    Sum-Net   20.0.1.0        10.0.1.1           592  28    80000001       2
    聚合后
    <r2>dis ospf lsdb
    
    	 OSPF Process 1 with Router ID 10.0.2.2
    		 Link State Database 
    
    		         Area: 0.0.0.0
     Type      LinkState ID    AdvRouter          Age  Len   Sequence   Metric
     Sum-Net   20.0.0.0        10.0.1.1             8  28    80000001       2
    
    更多相关内容
  • OSPF路由聚合(学习笔记+实验验证)

    千次阅读 多人点赞 2020-04-30 18:50:44
    路由聚合原理概述注:路由聚合算法实验目的实验内容实验拓扑编址表实验步骤1,基本配置1)各个接口IP配置2)S1的vlan和IP的配置3)配置access接口4)开启OSPF5)配置area2为NSSA区域2,路由引入1)在R4上配置去往外部...

    原理概述

    1,与Rip不同,OSPF不支持自动路由聚合,仅支持手动路由聚合。
    2,OSPF聚合路由分为区域间路由聚合和外部路由聚合
    1)区域间路由聚合必须配置在ABR路由器上,指的是ABR在把与自己直接相连区域中的Type-1和Type-2LSA转换成Type-3LSA时,对生成的Type-3LSA进行聚合。
    2)外部路由聚合必须配置在ASBR路由器上,值得时ASBR对Type-5LSA进行聚合
    3,区域间路由聚合是ABR对自己直接相连区域内的路由进行聚合,从而减少传播至与自己直接相连的其他区域的Type-3LSA的数量。
    强调:区域间路由只能聚合由Type-1LSA或Type-2LSA产生的路由;如果路由是由外部或其他区域传到本区域的,则这样的ABR路由不进行聚合。
    4,外部路由聚合是指在ASBR路由器上针对引入OSPF网络的外部路由进行聚合,目的是减少在OSPF网络中的Type-5LSA的数量。外部路由聚合必须在外部路由进入OSPF网络的ASBR上进行;外部路由进入OSPF网络后,在ABR上是无法对相应的Type-5LSA进行聚合的。
    5,对于NSSA区域,当该区域的ABR将Type-7LSA转换为Type-5LSA时,该ABR也可以充当ASBR的角色,并对Type-5LSA进行聚合。
    注意:当NSSA区域存在多台ABR时,必须由Router-ID最大的ABR进行Type-7LSA到Type-5LSA转换的操作。NSSA区域的外部路由聚合有两种方式,一种是在NSSA区域的ASBR上直接对外部路由进行聚合,另一种是在NSSA区域中Router-ID最大的,负责将Type-7LSA转成Type-5LSA的ABR进行聚合。

    注:

    外部路由聚合,如本区域有多个ABR,必须在router-id最大的ABR上完成
    需先添加vlan和配置每个路由器的接口IP,以及路由协议,没给代码,要自己完成
    交换机端口还要配access模式,不要忘记
    OSPF路由区域间路由聚合(可在本区域ABR上完成)
    外部路由聚合(可在ASBR上完成,也可在本区域ABR上完成)

    路由聚合算法

    (老师教的)
    在这里插入图片描述
    在这里插入图片描述

    实验目的

    理解OSPF区域间路由聚合和外部路由聚合的概念和过程
    掌握配置OSPF区域间路由聚合和外部路由聚合的方法

    实验内容

    在这里插入图片描述

    实验拓扑

    在这里插入图片描述

    编址表

    在这里插入图片描述

    实验步骤

    1,基本配置

    可能有做的不对的地方,评论一下,谢谢,没看书自己配置的【主要是书上省略了】

    1)各个接口IP配置

    R1,R2,R3,R4,R5的loopback和接口IP,根据编址配置(还有S1的loopback)
    如:
    #int + 接口
    #ip add+地址+掩码

    2)S1的vlan和IP的配置

    [S1]vlan batch 2 3 4 5
    [S1]int Vlanif 2
    [S1-Vlanif2]ip add 20.0.1.100 24
    [S1-Vlanif2]int vlanif 3
    [S1-Vlanif3]ip add 20.0.2.100 24
    [S1-Vlanif3]int vlanif 4
    [S1-Vlanif4]ip add 20.0.3.100 24
    [S1-Vlanif4]int vlanif 5
    [S1-Vlanif5]ip add 10.0.16.6 24
    

    3)配置access接口

    [S1]int e0/0/1
    [S1-Ethernet0/0/1]port link-type access 
    [S1-Ethernet0/0/1]port default vlan 2
    [S1-Ethernet0/0/1]int e0/0/2
    [S1-Ethernet0/0/2]port link-type access 
    [S1-Ethernet0/0/2]port default vlan 3
    [S1-Ethernet0/0/2]int e0/0/3
    [S1-Ethernet0/0/3]port link-type access 
    [S1-Ethernet0/0/3]port default vlan 4
    [S1-Ethernet0/0/3]int e0/0/4
    [S1-Ethernet0/0/4]port link-type access 
    [S1-Ethernet0/0/4]port default vlan 5
    

    在这里插入图片描述

    4)开启OSPF

    [S1]ospf router-id 10.0.6.6
    [S1-ospf-1]area 1
    [S1-ospf-1-area-0.0.0.1]network 10.0.16.0 0.0.0.255
    [S1-ospf-1-area-0.0.0.1]network 20.0.1.0 0.0.0.255
    [S1-ospf-1-area-0.0.0.1]network 20.0.2.0 0.0.0.255
    [S1-ospf-1-area-0.0.0.1]network 20.0.3.0 0.0.0.255
    [S1-ospf-1-area-0.0.0.1]network 10.0.6.6 0.0.0.0
    
    [R1]ospf router-id 10.0.1.1
    [R1-ospf-1]area 0
    [R1-ospf-1-area-0.0.0.0]network 10.0.12.0 0.0.0.255
    [R1-ospf-1-area-0.0.0.0]network 10.0.13.0 0.0.0.255
    [R1-ospf-1-area-0.0.0.0]network 10.0.1.1 0.0.0.0
    [R1-ospf-1]area 1
    [R1-ospf-1-area-0.0.0.1]network 10.0.16.0 0.0.0.255
    
    [R2]ospf router-id 10.0.2.2
    [R2-ospf-1]area 0
    [R2-ospf-1-area-0.0.0.0]network 10.0.12.0 0.0.0.255
    [R2-ospf-1-area-0.0.0.0]area 2
    [R2-ospf-1-area-0.0.0.2]network 10.0.24.0 0.0.0.255
    [R2-ospf-1-area-0.0.0.2]network 10.0.2.2 0.0.0.0
    
    [R3]ospf router-id 10.0.3.3
    [R3-ospf-1]area 0
    [R3-ospf-1-area-0.0.0.0]network 10.0.13.0 0.0.0.255
    [R3-ospf-1-area-0.0.0.0]area 2
    [R3-ospf-1-area-0.0.0.2]network 10.0.3.3 0.0.0.0
    [R3-ospf-1-area-0.0.0.2]network 10.0.34.0 0.0.0.255
    
    [R4]ospf router-id 10.0.4.4
    [R4-ospf-1]area 2
    [R4-ospf-1-area-0.0.0.2]network 10.0.4.4 0.0.0.0
    [R4-ospf-1-area-0.0.0.2]network 10.0.24.0 0.0.0.255
    [R4-ospf-1-area-0.0.0.2]network 10.0.34.0 0.0.0.255
    [R4-ospf-1-area-0.0.0.2]network 10.0.45.0 0.0.0.255
    

    5)配置area2为NSSA区域

    [R2-ospf-1]area 2
    [R2-ospf-1-area-0.0.0.2]nssa
    [R3-ospf-1]area 2
    [R3-ospf-1-area-0.0.0.2]nssa 
    [R4-ospf-1]area 2
    [R4-ospf-1-area-0.0.0.2]nssa 
    

    2,路由引入

    1)在R4上配置去往外部网络的静态路由,并进行引入。

    [R4]ip route-static 20.0.5.1 32 10.0.45.5
    [R4]ip route-static 20.0.5.2 32 10.0.45.5
    [R4]ip route-static 20.0.5.3 32 10.0.45.5
    [R4]ospf 
    [R4-ospf-1]import-route static 
    

    使用# dis ospf peer查看邻居关系是否都为Full
    在这里插入图片描述

    查看R1的路由表
    在这里插入图片描述
    可以看到R1已经获取到了非直连路由的,表示全网实现了互通。

    3,配置区域间路由聚合

    1)在R2上查看LSDB

    在这里插入图片描述
    可以看到R2为PC所属的网络都单独维护了Type-3LSA(Sum-Net)

    2)查看R2的路由表

    在这里插入图片描述
    可以看到R2路由表中拥有一台PC所属的路由,所以为了减少LSDBType-3LSA的数目,使用聚合路由

    3)在S1上使用abr-summary配置区域间路由聚合

    [S1-ospf-1-area-0.0.0.1]abr-summary 20.0.0.0 255.255.252.0
    

    (网络截图)
    在这里插入图片描述

    在R1上查看LSDB和路由表,会看到没有发生变化,原因是只有在ABR上才能经行区域间路由聚合,而S1并非ABR(区域边界路由)。
    删除S1的配置

    [S1-ospf-1-area-0.0.0.1]undo abr-summary 20.0.0.0 255.255.252.0
    

    在ABR路由R2的区域0中配置区域间路由聚合

    [R2-ospf-1-area-0.0.0.0]abr-summary 20.0.0.0 255.255.252.0
    

    再查看R4的LSDB及路由表
    在这里插入图片描述
    在这里插入图片描述
    还是这样,因为ABR只能对与自己直接相连的区域进行区域间路由聚合。
    接着删除R2的配置

    [R2-ospf-1-area-0.0.0.0]undo abr-summary 20.0.0.0 255.255.252.0
    

    4)在ABR路由器R1上配置路由聚合

    [R1]ospf
    [R1-ospf-1]area 1
    [R1-ospf-1-area-0.0.0.1]abr-summary 20.0.0.0 255.255.252.0
    

    查看R2的路由表和LSDB
    在这里插入图片描述
    在这里插入图片描述
    可以看到,现在R2的LSDB里面没有每一台PC的网络,而是一个聚合后的Type-3LSA;R2路由去往PC的网络明细路由也被聚合后的路由取代了。

    4,配置外部路由聚合

    现已将区域间路由聚合,但是以Type-7LSA的OSPF网络外部路由任然没有聚合,LSDB任然会为每一条外部路由单独维护一条LSA,路由表中也会为每一条这样的LSA产生明细路由。

    1)在R4上使用命令asbr-summary配置外部路由聚合

    [R4-ospf-1]asbr-summary 20.0.5.0 255.255.255.252
    

    (只截了部分图)
    在这里插入图片描述
    在这里插入图片描述
    可以看到,R1的LSDB中没有明细Type-5 LSA,只有聚合Type-5LSA。路由表中也没有外部网络的明细路由,只有聚合后的路由。

    2)查看R2的LSDB路由表

    在这里插入图片描述
    在这里插入图片描述
    可以看到,R2的LSDB中没有明细Type-5LSA和Type-7LSA,只有聚合后的Type-5LSA和Type-7LSA,R2的路由表中没有外部网络的明细路由,只有聚合后的路由。

    5,在NSSA区域的ABR上配置外部路由聚合

    由于区域2 是NSSA区域,该区域的ABR路由器会将Type-7LSA转换为Type-5LSA,并泛洪到区域0。

    1)先删除R4上的路由聚合配置,然后再区域2的ABR路由器R2上配置外部路由聚合。

    [R4-ospf-1]undo asbr-summary 20.0.5.0 255.255.255.252
    [R2-ospf-1]asbr-summary 20.0.5.0 255.255.255.252
    

    再R1上查看LSDB
    在这里插入图片描述
    可以看到,R1的LSDB每一条外部明细路由都有一条相应的Type-5LSA,说明聚合没有生效。原来是将Type-7LSA转换为Type-5 LSA的Router-ID较大的ABR路由器R3,所以,在R2上的外部聚合路由不能生效。
    查看R1 的路由表
    在这里插入图片描述
    看到R1的外部路由网络全部是明细路由

    2)保留在R2上的外部聚合路由配置,并在R3上配置外部路由聚合

    [R3-ospf-1]asbr-summary 20.0.5.0 255.255.255.252
    

    配置好后,在R1上查看LSDB和路由表
    在这里插入图片描述
    在这里插入图片描述
    可以看到,R1的LSDB没有明细Type-5 LSA,只有聚合后的;路由表也是没有明细路由,只有聚合后的,下一跳为R3(10.0.3.3),说明已经生效。

    3)关闭R3的g0/0/1口,模拟R3故障

    [R3-GigabitEthernet0/0/1]shutdown 
    

    在R1上查看LSDB
    在这里插入图片描述
    可以看到R1上聚合后的Type-5 LSA的AdvRouter变成了R2(10.0.2.2)
    查看R1的路由表
    在这里插入图片描述
    可以看到,R1去往外部网络的聚合路由的下一跳变为了R2(10.0.12.2).上面的实验说明,ABR路由器R2上的外部路由聚合配置,是对ABR路由器R3上的外部路由聚合的一个冗余备份。

    展开全文
  • 华三 h3c ospf路由聚合

    千次阅读 2020-12-21 17:59:03
    先完成基本的ospf配置(创建环回口和配置ip就不做阐述) R1 [R1-ospf-1-area-0.0.0.1]network 1.1.1.1 0.0.0.0 [R1-ospf-1-area-0.0.0.1]net 10.0.0.0 0.0.0.255 [R1-ospf-1-area-0.0.0.1]...

    先完成基本的ospf配置(创建环回口和配置ip就不做阐述)

    R1

    [R1-ospf-1-area-0.0.0.1]network 1.1.1.1 0.0.0.0

    [R1-ospf-1-area-0.0.0.1]net 10.0.0.0 0.0.0.255

    [R1-ospf-1-area-0.0.0.1]net 192.168.1.0 0.0.0.255

    [R1-ospf-1-area-0.0.0.1]net 192.168.2.0 0.0.0.255

    [R1-ospf-1-area-0.0.0.1]net 192.168.3.0 0.0.0.255

    R2

    [R2-ospf-1-area-0.0.0.1]net 10.0.0.0 0.0.0.255

    [R2-ospf-1-area-0.0.0.0]network 2.2.2.2 0.0.0.0

    [R2-ospf-1-area-0.0.0.0]net 20.0.0.0 0.0.0.255

    R3

    [R3-ospf-1-area-0.0.0.0]net 3.3.3.3 0.0.0.0

    [R3-ospf-1-area-0.0.0.0]net 20.0.0.0 0.0.0.255

    完成以上配置之后,会在R3上面看到R1的3条明细业务网段路由和其他路由

    在R2上面配置路由聚合(ABR上做路由聚合,是对某一个区域的路由信息进行聚合,聚合后,ABR像其他区域只发送一条聚合后的路由 参数not-advertise是不向外发布这条聚合路由。默认是发布的,不然就没意义了。。。)

    [R2-ospf-1]area 1

    [R2-ospf-1-area-0.0.0.1]abr-summary 192.168.0.0 22

    此时在看R3的路由表,会发现业务网段只能学习到一条聚合后的路由:

    192.168.0.0/22     O_INTER 10  2           20.0.0.1        GE0/1

     

    在R2上配置聚合路由,并且不发布聚合后的路由

    [R2-ospf-1]area 1

    [R2-ospf-1-area-0.0.0.1]abr-summary 192.168.0.0 22 not-advertise

    此时R3上没有学习到任何关于业务网段的路由信息。

     

    上面做的是在ABR(R2)上配置路由聚合。在ospf协议里还有一种常见的路由器类型就是ASBR:跟其他AS连接的路由器(这里用R1做模拟)

    在R1上首先把宣告的ospf业务网段路由删掉,通过引入直连路由的方式发布业务网段,此时的业务网段是外部路由,可以当作是通过别的自治系统学习到的路由,那么此时的R1就是ASBR路由器了。

    具体操作如下

    [R1-ospf-1]area 1

    [R1-ospf-1-area-0.0.0.1]undo net 192.168.1.0 0.0.0.255-----不在宣告业务网段为区域内路由

    [R1-ospf-1-area-0.0.0.1]undo net 192.168.2.0 0.0.0.255

    [R1-ospf-1-area-0.0.0.1]undo net 192.168.3.0 0.0.0.255

    [R1-ospf-1]import-route direct-----通过引入直连发布业务网段路由

    此时在R3上会学习到类型为第二类外部路由的业务网段信息

    Destination/Mask   Proto   Pre Cost        NextHop         Interface

    192.168.1.0/24     O_ASE2  150 1           20.0.0.1        GE0/1

    192.168.2.0/24     O_ASE2  150 1           20.0.0.1        GE0/1

    192.168.3.0/24     O_ASE2  150 1           20.0.0.1        GE0/1

     

    在R1上配置路由聚合

    [R1-ospf-1]asbr-summary 192.168.0.0 22---注意了,在ASBR上配置聚合路由时是在ospf进程视图下面配置,并非像在ABR配置是在区域视图下面,切记----------

    在R3上只会看到1条聚合后的路由

    Destination/Mask   Proto   Pre Cost        NextHop         Interface

    192.168.0.0/22     O_ASE2  150 1           20.0.0.1        GE0/1

    在聚合路由的后面在加上not-advertise参数,R3一条业务网段的路由信息都看不到。

     

     

    展开全文
  • NP、OSPF路由聚合

    2020-12-09 21:33:18
    OSPF路由聚合有两种机制:区域间路由聚合和外部路由聚合。区域间路由聚合必须配置在ABR路由器上,指的是ABR在把与自己直接相连区域(Area)中的Type-1和Type-2 LSA转换成Type-3 LSA时,对生成的Type-3 LSA进行聚合。...

    与RIP不同,OSPF不支持自动路由聚合,仅支持手动路由聚合。OSPF路由聚合有两种机制:区域间路由聚合和外部路由聚合。区域间路由聚合必须配置在ABR路由器上,指的是ABR在把与自己直接相连区域(Area)中的Type-1和Type-2 LSA转换成Type-3 LSA时,对生成的Type-3 LSA进行聚合。外部路由聚合必须配置在ASBR路由器上,指的是ASBR对Type-5 LSA进行聚合。

    区域间路由聚合是ABR对自己直接相连区域内的路由进行聚合,从而减少传播至与自己直接相连的其它区域的Type-3 LSA 的数量。需要注意:区域间路由只能聚合由Type-1 LSA 或 Type-2 LSA产生的路由;如果路由器由外部或其它区域传到本区的(或者说路由是由Type-5 LSA或Type-3 LSA 生成的),则对于这样的路由ABR是不能够进行聚合的。

    外部路由聚合是指在ASBR路由器上针对引入OSPF网络的外部路由进行的聚合,目的是减少在OSPF网络中的Type-5 LSA 的数量。外部路由聚合必须在外部路由进入OSPF网络的ASBR上进行;外部路由进入OSPF网络后,在ABR上是无法对相应的Type-5 LSA进行聚合的。

    对于NSSA区域,当该区域的ABR将Type-7 LSA 转换为 Type-5 LSA 时,该ABR也可以充当ASBR的角色,并对Type-5 LSA 进行聚合。需要注意:当NSSA区域存在多台ABR时,必须由Router-ID 最大的ABR进行Type-7 LSA 到 Type-5 LSA的转换操作。NSSA区域的外部路由聚合有两种方式,一种是在NSSA区域的ASBR上直接对外部路由进行聚合,另一种是在NSSA区域中 Router-ID 最大的、负责将Type-7 LSA 转换成Type-5 LSA 的ABR上进行聚合。

    R1、R2、R3为公司总部网络路由器,R4为分支机构路由器,R5为外部非OSPF网络的路由器,SW1为总部内部交换机,R1、R2、R3、R4、SW1运行OSPF协议。PC1、PC2、PC3、分别属于vlan2 vlan 3 vlan 4。SW1与R1之间的链路属于vlan5,且属于区域1。R1与R2 R1与R3之间链路属于区域0。R4与R2 R4与R3属于区域2。区域2 是一个NSSA区域,R4使用静态路由去往R5的Loopback接口所模拟的外部网络。网络管理员需要在实现全网互通的前提下,尽可能地精简LSDB和优化路由表。
    在这里插入图片描述

    接口IP配置不赘述,接下来部署OSPF。
    SW1配置
    在这里插入图片描述
    在这里插入图片描述
    R1配置
    在这里插入图片描述
    R2配置
    在这里插入图片描述
    R3配置
    在这里插入图片描述
    R4配置OSPF 并配置去往外部网络的静态路由,并进行引入。
    在这里插入图片描述

    //查看R1的邻居状态(状态都为Full)
    在这里插入图片描述

    //查看R1的路由表
    在这里插入图片描述

    在这里插入图片描述
    //可以看到R1上已经接收到了所有的非直连路由,全网已经实现了互通。

    //查看R2的LSDB
    在这里插入图片描述

    在这里插入图片描述
    //可以看到目前R2为每一台PC所属的网络都单独维护了Type-3 LSA (Sum-Net LSA)

    //查看R2的路由表
    在这里插入图片描述
    //可以看到目前R2的路由表中拥有每一台PC所属网络的路由。为了减少LSDB中Type-3 LSA 的数量以及路由表中路由条目的数量,下面进行区域间路由聚合。

    //在SW1上使用命令 abr-summary 配置区域间路由聚合
    在这里插入图片描述

    //查看R1的LSDB及路由表
    在这里插入图片描述
    在这里插入图片描述
    //可以看到,R1的LSDB中为每一台PC所属的网络都单独维护了 Type-3 LSA,在路由表中为每一台PC所属的网络都单独维护了路由,说明配置区域间路由聚合并没有产生作用,原因是只有在ABR上才能进行区域间的路由聚合。删除SW1上的路由聚合配置
    [SW1-ospf-10-area-0.0.0.1]undo abr-summary 20.0.0.0 255.255.252.0

    //在ABR路由器R2的区域0中配置域间路由聚合
    在这里插入图片描述
    //查看R4的LSDB及路由表
    在这里插入图片描述
    在这里插入图片描述
    //可以看到R4在LSDB中为每一台PC所属的网络单独维护了 Type-3 LSA ,在路由表中为每一台PC所属的网络都单独维护了路由,ABR路由器R2上配置的区域路由聚合也没有产生作用,原因是ABR只能对自己直连的区域进行区域间路由聚合。删除R2上的路由聚合配置
    [R2-ospf-10-area-0.0.0.0]undo abr-summary 20.0.0.0 255.255.252.0

    //在ABR路由器R1区域1中配置路由聚合
    在这里插入图片描述
    //查看R2的LSDB及路由表
    在这里插入图片描述
    在这里插入图片描述
    可以看到,R2的LSDB中没有为每一台所属的网络单独维护 Type-3 LSA,维护的是聚合后的 Type-3 LSA;R2的路由表中去往每一台PC所属的网络明细路由也被聚合后的路由取代了。

    //配置外部路由聚合
    以 Type-7 LSA 的形式进入OSPF网络的外部路由仍然未被聚合,LSDB仍然会为每一条外部路由单独维护一条LSA,路由表中也会为每一条这样的LSA产生明细路由。
    R4上使用 asbr-summary 配置外部路由聚合
    在这里插入图片描述
    //查看R4的LSDB及路由表
    在这里插入图片描述

    在这里插入图片描述
    //可以看到R1的LSDB中没有明细 Type-5 LSA,只有聚合了的 Type-5 LSA,R1的路由表中也没有外部网络的明细路由,只有聚合后的路由。

    //查看R2的LSDB及路由表
    在这里插入图片描述
    在这里插入图片描述
    //可以看到,R2的LSDB中没有明细 Type-5 LSA和Type-7 LSA,只有聚合后的Type-5 LSA 和 Type-7 LSA,R2的路由表中没有外部网络的明细路由,只有聚合后的路由。

    //在NSSA区域的ABR上配置外部路由聚合
    由于区域2是NSSA区域,该区域的ABR路由器会将 Type-7 LSA 转换为 Type-5 LSA,并泛洪到区域0。
    先删除R4上的路由聚合配置,然后在区域2的ABR路由器R2上配置外部路由聚合
    [R4-ospf-10]undo asbr-summary 20.0.5.0 255.255.255.252

    [R2-ospf-10]asbr-summary 20.0.5.0 255.255.255.252

    //查看R1的LSDB
    在这里插入图片描述
    //可以观察到,R1的LSDB中针对每一条外部明细路由都有一条相应的Type-5 LSA ,说明在ABR路由器R2上进行的外部路由聚合配置并未生效。原来,将 Type-7 LSA 转换为Type-5 LSA 的是Router-ID 较大的ABR路由器R3,所以,在R2上进行的外部路由聚合配置不能生效。

    //查看R1上的路由表
    在这里插入图片描述
    //可以看到R1上的路由全部是明细路由

    现在保留R2上的外部路由聚合配置,并在R3上配置外部路由聚合。
    [R3-ospf-10]asbr-summary 20.0.5.0 255.255.255.252

    配置完成后,查看R1的LSDB及路由表
    在这里插入图片描述
    在这里插入图片描述
    //

    可以看到R1的LSDB中没有明细的 Type-5 LSA,只有 Advrouter为R3(10.0.3.3)的聚合后的 Type-5 LSA,路由表中没有外部网络的明细路由,只有外部网络的聚合路由下一跳为R3(10.0.13.3),这说明R3上外部路由聚合配置已经生效。

    关闭R3的G0/0/1接口,模拟故障。
    [R3]int g 0/0/1
    [R3-GigabitEthernet0/0/1]shutdown

    //查看R1的LSDB
    在这里插入图片描述
    //可以看到R1上聚合后的Type-5 LSA 的Abvrouter变成了R2(10.0.2.2)。

    查看R1的路由表
    在这里插入图片描述
    //可以看到R1去往外部网络的聚合路由的下一跳变成了R2(10.0.12.2)。说明,ABR路由器R2上的外部路由聚合配置是,对ABR路由器R3上的外部路由聚合配置的一个冗余备份。

    展开全文
  • 素材来源:华为路由器配置指南 ...当大规模部署OSPF网络时,可能会出现由于OSPF路由表规模过大而降低路由查找速度的现象,为了解决这个问题,可以配置路由聚合,减小路由表的规模,降低管理的复杂度。此外,如果
  • 一、路由聚合图解: 二、做路由聚合的优势: 三、OSPF里面对路由汇聚,只能在两个地方做 (1)ABR:仅针对本区域域内路由(以O开头的路由)做汇总,本区域的OIA的域间路由没有办法汇总  ——配置: (2)ASBR:...
  • OSPF路由聚合 教师参考OSPF路由聚合 教师参考
  • 配置OSPF发布聚合路由

    千次阅读 2019-06-02 12:41:05
    1.13.3 配置OSPF发布聚合路由 组网需求• • Switch A 和 Switch B 位于 AS 200 内,AS 200 内使用 OSPF 作为 IGP 协议。• • Switch C、Switch D 和 Switch E 位于 AS 100 内,AS 100 内使用 OSPF 作为 IGP 协议...
  • 实验3ospf路由聚合

    2019-10-07 10:09:33
    实验任务一:ABR上的路由聚合 1.建立物理连接 2.配置ospf协议 [RTA-ospf-1-area-0.0.0.1]network 1.1.1.1 0.0.0.0 [RTA-ospf-1-area-0.0.0.1]network 192.168.0.0 0.0.0.255 [RTA-ospf-1-area-0.0.0.1]network 192....
  • ospf路由汇总(聚合)实例

    千次阅读 2021-03-04 11:02:23
    非骨干区域路由汇总(聚合) 这里我们在AR4上创建两个环回口 Lo8 Lo9,IP地址分别设置为:Lo8-192.168.8.1/24,Lo9-192.168.9.1/24 然后设置环回口的OSPF的网络类型为广播,这里如果不设置为广播
  • OSPF路由聚合的理解

    2013-03-26 14:06:08
    实验拓扑: R3s0/6/1-------s0/6/1--R1--s0/6/0 ----------------s0/6/0---R2 R3与R1互联的接口在area 1 R1与R2...在R3 上引入直连网段的几个loopback接口,将R3视为ASBR路由器,作ASBR路由聚合 在R3上发布...
  • HCL实验:OSPF路由汇聚

    千次阅读 2022-04-02 15:09:22
    OSPF协议提供了路由汇聚功能,能够减少路由表中的路由条目。 路由汇聚在区域边界路由器(ABR)和 自治系统边界路由器(ASBR) 上进行配置,其命令分别为: [OSPF视图]abr-summary 网段 汇聚后的掩码 [OSPF视图]asbr-...
  • HCL配置OSPF路由聚合(上)实验

    千次阅读 多人点赞 2020-04-01 11:57:18
    OSPF路由协议解决了很多RIP路由协议无法解决的问题,因而得到了广泛应用 RIP的缺陷 以跳数评估路由并非最优路径 最大跳数16导致网络尺度小 收敛速度慢 更新发送全部路由表浪费网络资源 什么是OSPF OSPF((Open ...
  • HCL配置OSPF路由聚合(下)实验

    千次阅读 2020-04-01 12:40:44
    OSPF路由聚合(上)实验的基础上可以继续用该工程文件,也可以重新创建一个工程 若用OSPF路由聚合(上)工程文件接下来进行的一步就是删除原来的ospf配置的命令 首先在三台路由器上执行 undo ospf 就可以把原来的...
  • OSPF路由汇总实验

    2022-03-01 11:30:37
    定义区域间路由汇总和外部路由汇总: R1: router rip redistribute ospf 1 metric 10 router ospf 1 redistribute rip subnets R3: area 2 range 172.16.0.0 255.255.224.0 测试: R0:sh ip route Ping 172.16....
  • Cisco OSPF路由手工汇总

    2021-06-23 10:41:08
    router ospf 1 router-id 1.1.1.1 auto-cost reference-bandwidth 1000 network 172.16.0.0 0.0.3.255 area 1 #环回接口汇总网络,反子网掩码 network 172.16.12.1 0.0.0.0 area 1 R2: router ospf 1 router-id 2.2...
  • OSPF路由聚合实验(详细)

    千次阅读 2013-01-16 21:15:29
    利用abr-summary 过滤区域内的路由,对区域类型没有要求。 利用asbr-summary过滤区域内的外部路由,需要在区域内部的ASBR上配置,当ASBR很多时,配置比较复杂。 利用asbr-summary过滤区域内的外部路由,只...
  • 路由聚合是指将多条具有相同IPv6前缀的路由聚合成一条路由。当大规模部署OSPFv3网络时,可能会出现由于OSPFv3路由表规模过大而降低路由查找速度的现象,为了解决这个问题,可以配置路由聚合,减小路由表的规模,降低...
  • ospf-路由聚合

    2018-08-30 15:25:00
    转载于:https://www.cnblogs.com/activecode/p/9560438.html
  • 【分享】OSPF 路由汇总

    千次阅读 2022-05-10 16:46:45
    在这篇文章中,将介绍 OSPF 路由汇总。 什么是路由汇总? 路由汇总是指设备将学习到的部分路由网段按照一定的规则聚合成单个路由的操作,一般来说,路由汇总可以大大减少设备路由表项和转发表项。一方面可以减轻...
  • 作为减少OSPF LSDB和OSPF路由表的有效手段,OSPF路由汇总与BGP等其他路由协议有很大不同。 在这篇文章中,我将介绍 OSPF 路由汇总。 什么是路由汇总? 路由汇总是指设备将学习到的部分路由网段按照一定的规则聚合成...
  • 1.配置OSPF多区域和虚连接以及路由聚合 二.OSPF路由聚合 1.在ABR,或ASBR上配置路由聚合后,ABR或ASBR上本地的OSPF路由表是保 持不变的,仍为各个网段的明细路由 2.当聚合路由向其他OSPF区域,通告时,会把那些...
  • OSPF配置命令总结

    千次阅读 2020-10-26 15:29:58
    abr-summary(OSPF区域) //用来在区域边界路由器(ABR)上配置路由聚合。 area(OSPF) //用来创建OSPF区域,并进入OSPF区域视图。 asbr-summary //用来设置自治系统边界路由器(ASBR)对OSPF引入的路由...
  • (1)针对明细路由做汇总可以有效地减少OSPF路由器的数据库条目也就是路由表条目,合理的节省了设备性能 (2)可以隐藏明细路由不稳定所造成的...(3)在双出口做路由聚合时,有一个做,有一个没做会影响到路由选路
  • 【课程思政案例】广域网互联技术:OSPF路由协议的配置--树立正确的三观.pdf
  • OSPF路由协议实验配置命令

    千次阅读 2022-04-18 17:37:44
    拓扑介绍 上述拓扑中配置OSPF,分为三...1 按照拓扑中区域规划运行OSPF路由协议,完成设备间的个网段互通 2 用户不能直接发布到OSPF中,需要作为外部路由注入OSPF,且在注入后需将连续网段聚合 3 将area2配置..

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 6,024
精华内容 2,409
关键字:

ospf路由聚合