精华内容
下载资源
问答
  • 路由与交换

    2021-03-17 13:14:26
    路由与交换

    路由协议:


    路由器转发原理与arp协议

    路由表:记录网段转发的一种数据库,包括IP前缀、下一跳、出接口等参数。

    路由表IP前缀的来源:链路层自学习(直连路由)、静态路由、动态路由

    根据算法分为以下几类:

    • 距离矢量型----- RIP EIGRP
    • 链路状态型----- OSPF ISIS
    • 路径矢量型----- BGP

    根据范围(AS)分为两大类:

    • IGP—(内部网关协议)
    • BGP—(边界网关协议)

    路由表的构成

    • IP前缀
    • 掩码
    • 下一跳
    • 出接口
    • 来源 (L、C、O、B、S)
    • 路由优先级----( 0-255 小优 当路由前缀与掩码一致而来源不一致的时候通过该参数决定那
      种来源的路由会放置在路由表中。)
    • 开销 ----(不同协议有不同的开销,所以不同的协议不同比较开销。 开销相同会负载均衡)
    • flag

    路由的查找规则

    • 精确匹配 /最长匹配
    • 递归查找 (以太网中路由的下一跳,会在路由表中再次查找,找出能arp的下一跳与出接口。)
    • 黑洞l路由(下一跳是null接口的路由 作用:防环、安全)

    路由器封装与解封装

    • 接口接收目的MAC是自己的数据帧,还有广播帧以及它需要接收的组播帧。目的不是自己MAC的单播帧会被丢弃。
    • 如果是自己,则拆掉二层封装查看查看目标IP,并对比本地路由表中是否有记录,如果有记录则无条件按照路由表转发,并且重新封装二层,源MAC为本地出接口的MAC,目标MAC为下一跳的接口MAC,若路由表中无记录则丢弃该数据;

    交换机转发原理

    MAC转发表

    1. 表的形成( 自学习)
      当以太网帧到达交换机时,交换机会自动学习该数据帧的源MAC地址与进入的接口形成绑定关系,注意该表会有老化时间,一般是5min?,这个数值可以修改,当该表项被执行转发时会刷新老化时间。
    2. 表的查询与转发
      查询执行的精确查询,一种完全命中的查询,一次命中。
      存储转发---- 帧所有内容都接受才转发
      直通转发 ----只接受到目的MAC就转发
      片段转发 ----接受到32字节就转发,及一个最小帧的长度
    3. 转发
      已知单播帧---- 精确转发
      未知单播帧 ----洪范转发
      广播与组播帧---- 洪范转发

    VLAN
    通过vlanb划分接口把mac表分割为以vlan为单位的独立mac表-----隔离广播域的技术
    标记技术来解决不同交换机vlan互通的问题------802.1q

    路由协议

    静态路由协议 —人工书写的路由

    • 书写规则---- 前缀+ 掩码 + 下一跳/出接口 在多路网络中只能使用下一跳才能精确到路由的方
      向,只有一种情况必要写出接口就是下一跳不固定的场景(拨号线路)
    • 浮动路由 ----当一个目标有多条线路可达时,我们会使用浮动静态来增加路由的可靠性
    • 默认路由---- 一般在边界路由器上或者末端路由器上我可以使用默认路由来表示多个目标的路
      由。

    RIP
    学习路由的原则

    • 没有的一定学习
    • 有的分为俩种情况
      1、同源 ----无条件更新,会覆盖原来的路由和开销无关
      2、不同源 ----会比较选择开销小的

    防环原则:

    • 水平分割 ----从此接口进的路由不能在从此接口出去;
    • 毒性逆转—路由器从某个接口上接收到某个网段的路由信息之后,并不是不往回发信息了,而是发送,只不过是将这个网段标识为不可达,在发送出去,收到此种的路由信息后,接受方路由器会立刻抛弃该路由,而不是等待其老化时间达到,这样可以加快路由的收敛;
    • 抑制计时器
    • 触发更新
    • 最大跳数

    OSPF
    open shortest path first
    SPF算法,围绕该算法计算路由信息的协议,迪特格拉斯算法。
    open 是指IETF发明的一种针对IP的路由协议。

    • 信息---- 拓扑信息
    • 传递---- 传递过程不会更改原始信息
    • 计算 ----每个路由器都是独立计算路由

    路由器转发过程的描述:

    PC1向PC2发送数据包,那么在PC1形成数据包的目的IP为PC2,源IP为PC1的IP
    源MAC为PC1自己,目标MAC为路由器(B1)的MAC,如果为第一次通信,则目标MAC地址为FFFF:FFFF:FFFF:FFFF,开启ARP广播应答,建立ARP表,由于PC1与PC2不在同意个网段,路由器不转发广播帧,所有路由器(B1)给PC1回复一个应答数据包,告诉本地MAC地址就是PC2的MAC地址,而路由器(B1)在出接口时重新封装数据包的二层报头格式为:源MACPC1,源IP为PC1,目标IP地址为PC2,目标MAC为FFFF:FFFF:FFFF:FFFF(以此类推)最终PC2将自己的IP地址与数据包进行匹配,若符合则接受,不符合则丢弃

    交换机的转发过程的描述:

    交换机属于二层设备,基于MAC进行转发,当流量进入交换机后,根据数据帧中的源MAC,建立该地址与交换机端口的映射,并写入MAC地址表中。再查看数据帧中的目的MAC,根据MAC地址表中的信息进行转发,如果MAC地址表中没有相关信息,则进行洪泛处理(目标MAC为全F);若划分了VLAN,则向对应的VLAN进行洪泛,如果收到的为广播帧或组播帧,则直接进行洪泛;

    展开全文
  • 路由与交换技术路由与交换技术路由与交换技术路由与交换技术路由与交换技术
  • 路由与交换技术

    2017-03-28 14:27:00
    很深刻的路由与交换技术描述
  • 构建高级路由与交换网络==构建高级路由与交换网络==构建高级路由与交换网络
  • 思科路由与交换

    2015-11-06 23:28:13
    思科公司的网络设备,路由与交换设备,CCIE认证
  • 路由与交换入门试验手册,包含思科与华为,H3C设备。路由与交换入门试验手册,包含思科与华为,H3C设备
  • 路由与交换课程设计.docx
  • 趣学CCNA 路由与交换

    2018-02-21 20:47:57
    趣学CCNA 路由与交换
  • 路由与交换大纲

    2012-05-19 09:57:50
    路由与交换大纲
  • HCIA 路由与交换 v2.5

    2020-11-09 09:56:33
    华为官网的公开资料,只进行了收集和整理发在这里。HCIA 路由与交换v2.5版,当前最新的版本了。如果侵权,马上删除。
  • 路由与交换实验自测题。
  • CCIE路由与交换认证指南
  • CCNA2路由与交换课件PPT
  • 路由与交换学习总结

    千次阅读 2019-01-04 16:02:45
    路由与交换学习总结 因期末考试。。。本篇仅做个人复习所需,可忽略。。。。。。。。。。。  《路由与交换》以如何组建一个园区网作为一个完整的工程项目,在整体任务之内,各子项目设计为积木式的主题学习单元,...

                                                 路由与交换学习总结

    因期末考试。。。本篇仅做个人复习所需,可忽略。。。。。。。。。。。

        《路由与交换》以如何组建一个园区网作为一个完整的工程项目,在整体任务之内,各子项目设计为积木式的主题学习单元,各单独的模块也可成为一个相对独立的工作过程。通过任务引领型的项目活动,旨在使学生掌握设计和组建园区网的基本知识和技能,包括网络拓扑设计、IP地址规划、路由及路由器、交换及交换机、ACL及其他网络安全技术、初步的网络故障排除和优化等相关知识以及园区网络工程实施中的网络设备配置和联调能力。

     

    交换机配置:

    int f0/1  //接口

    speed auto //速度选择

    duplex auto //模式选择

    no shut  //激活

    exit //在全局模式下配置网关

    ip default-gateway 218.11.1.254

    exit//退回全局模式

    int vlan1 //进入vlan1

    ip addr 218.11.1.1 255.255.255.0 //设置交换机ip

    no shut //激活

     

    交换机设置远程登录

    line vty 0 4

    password <远程登录口令>

    login

    //pc端进入终端 telnet 218.11.1.1 // IP地址  

     

    创建vlan

    特权模式下

    vlan database

    vlan 10 name lzw //创建vlan口  并命名

     

    vlan模式设置(经过多交换机,每个交换机都要创建相应的vlan)

    相同vlan可以互通 不同vlan不能互通

    int range f0/1-2 //进入接口

    switchport mode trunk //配置为trunk模式  (跨交换机)

    switchport trunk allowed vlan all //应用到全面vlan上

     

    switchport mode access//配置为access模式  (单交换机)

    switchport access vlan 10//应用到指定vlan口上

     

    vtp配置

    VTP(VLAN Trunking Protocol):是VLAN中继协议,也被称为虚拟局域网干道协议。它是思科私有协议。作用是十几台交换机企业网中,配置VLAN工作量大,可以使用VTP协议,把一台交换机配置成VTP Server, 其余交换机配置成VTP Client,这样他们可以自动学习到server 上的VLAN 信息。

    1. 设置服务器以及创建vlan(三层交换机)

    Vlan database

    Vtp domain <域名>

    Vtp server

    Vlan <vlan序号>  //添加vlan 口

         2、设置客户端(二层交换机)

    Vlan database

    Vtp domain <域名>  #与三层交换机域名一样

    Vtp client

    3、交换机端口设置vlan (参考上面)

    4、交换机主干配置(三层交换机)

    Interface <端口>

    Switchport trunk encapsulation dot1q   #三层交换机必须加上这一句

    Switchport mode trunk

    Switchport trunk allowed vlan all

    5、交换机配置ip和网关

    Interface  vlan1

    Ip address IP地址 子网掩码

    Ip default-gateway <网关>   #三层交换机不用配置网关  (在全局模式下)

    6、配置各个vlan的路由,在三层交换机上执行

    Int vlan <vlan序号>

    Ip address <下一层网关> 子网掩码

    Ip routing //激活路由协议

     

    端口聚合与STP协议配置(生成树协议)

    端口聚合也叫做以太通道(ethernet channel),主要用于交换机之间连接。但是,失去了路径冗余的优点,因为STP的链路切换会很慢,在50s左右。使用以太通道的话,交换机会把一组物理端口联合起来,做为一个逻辑的通道,也就是channel-group,这样交换机会认为这个逻辑通道为一个端口。

    STP协议(生成树协议)逻辑上断开环路,防止二层网络的广播风暴的产生。

    端口聚合:(全局模式下)

    Channel-protocol lacp

    Channel-group 1 mode active  //对端可以用active或者passive

    STP协议:(全局模式下)

    spanning-tree mode pvst

    spanning-tree vlan 1 priority 4096 //(优先级为n*4096)

    spanning-tree vlan 10 priority 8192 //设置其他vlan口优先级(优先级为n*4096)

    spanning-tree vlan 1 root primary /设置主根桥

    进入汇聚好的端口进行交换机配置

    int port-channel1

    sw trunk encapsulation dot1q  //3层交换机必须要有这一句

    sw mode trunk
    sw tr allowed vlan all
    int f0/1
    sw mo ac
    sw ac vlan 20

     

    单臂路由配置

    单臂路由(router-on-a-stick)是指在路由器的一个接口上通过配置子接口(或“逻辑接口”,并不存在真正物理接口)的方式,实现原来相互隔离的不同VLAN(虚拟局域网)之间的互联互通。

     

    ACL配置

    访问控制列表(Access Control List,ACL) 是路由器交换机接口的指令列表,用来控制端口进出的数据包。ACL适用于所有的被路由协议,如IP、IPX、AppleTalk等。

    1、ACL(访问控制列表)的分类:

    <1>基本ACL:对访问对象进行分类管理

    格式:access-list <标号> permit(允许)/deny(禁止)<网络地址> <子网掩码反码>  

    <2>扩展ACL:对访问对象进行过滤管理

    access-list 110 deny tcp 218.11.10.0 0.0.0.255 host 218.11.20.1 eq 80

    格式:access-list <标号> permit/deny <协议> <源网络号> <子网掩码> <目标网络号> <子网掩码的反码>  eq(等于)/lt(小于)/gt(大于) <端口号>

     

    DNS、DHCP 

    DNS(Domain Name System,域名系统),万维网上作为域名和IP地址相互映射的一个分布式数据库,能够使用户更方便的访问互联网,而不用去记住能够被机器直接读取的IP数串。通过域名,最终得到该域名对应的IP地址的过程叫做域名解析(或主机名解析)。DNS协议运行在UDP协议之上,使用端口号53。在RFC文档中RFC 2181对DNS有规范说明,RFC 2136对DNS的动态更新进行说明,RFC 2308对DNS查询的反向缓存进行说明。

     

    动态主机设置协议(英语:Dynamic Host Configuration Protocol,DHCP)是一个局域网网络协议,使用UDP协议工作,主要有两个用途:用于内部网或网络服务供应商自动分配IP地址;给用户用于内部网管理员作为对所有计算机作中央管理的手段。

     

     

    展开全文
  • 英文CCNP路由与交换7.1(1/1) Cisco认证网络专业人员(CCNP)路由和交换认证可验证本地和广域企业网络的规划、实施、验证和故障排除能力,以及与高级安全、语音、无线和视频解决方案专家协作。 适合那些至少有一年...
  • 路由与交换技术应用课后习题答案 华为3认证 路由与交换技术
  • 华为HCIE认证培训-路由与交换,适合要参加HCIE认证考试的人。
  • 网络路由与交换实验

    2012-12-19 22:04:54
    网络路由与交换的实验内容及实验的步骤和方法。
  • 复习题-路由与交换技术 复习题-路由与交换技术

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 3,882
精华内容 1,552
关键字:

路由与交换