精华内容
下载资源
问答
  • 配置路由器IP地址 然后用命令ip address x.x.x.x x.x.x.x配置IP地址。具体命令如下:Router2800>enable (进入特权模式)Router2800#configure termial (进入全局配置模式)Router2800(config)#int f0/1 (进入接口...

    配置路由器IP地址

    然后用命令ip address x.x.x.x x.x.x.x配置IP地址。具体命令如下:
    Router2800>enable (进入特权模式)
    Router2800#configure termial (进入全局配置模式)
    Router2800(config)#int f0/1 (进入接口配置模式)
    Router2800(config-if)#ip address 192.168.0.1 255.255.255.0 (为接口分配IP地址和掩码)
    Router2800(config-if)#no shutdown (启用接口)
    Router2800(config-if)#ex (退出接口模式)

    远程登录配置

    首先路由器要设置远程登录密码(在被远程的路由器上设置)
    line vty 0 4 (允许5台设备登录)
    passwork +密码
    login
    其次全局模式下也要键入配置密码
    enable password +密码 (这个密码不安全)

    最后才能实现远程登录
    telnet + 远程登录的地址

    如果要设置一个安全的密码,如下

    R2# en
    R2#conf t
    R2(config)#enable secret 密码

    转载于:https://blog.51cto.com/13242922/2062304

    展开全文
  • 配置路由器IP地址3.查看路由表4.激活端口5.查看路由表6.验证主机连通 基础知识 ip地址是网络层中使用的地址,网络层依靠IP地址和路由协议将数据报送到目的IP主机。 路由器是互联网的核心设备,它在IP网络间转发数据...

    基础知识

    ip地址是网络层中使用的地址,网络层依靠IP地址和路由协议将数据报送到目的IP主机。

    路由器是互联网的核心设备,它在IP网络间转发数据报,这使得路由器的每个接口都连接一个或多个网络,而两个接口却不可以代表一个网络,路由器的一个配置了IP地址的接口所在的网络就是路由器的直连网络,路由器不需要额外的配置路由,当接口被激活后,路由器就会自动将直连网络加入到路由表中。

    常用命令

    命令格式 含义
    ip address IP地址 子网掩码 在接口模式下配置当前接口的IP地址
    show ip route 特权模式下查看路由器的路由表
    do show ip route 非特权模式下查看路由表
    no shutdown 接口模式下激活该接口

    实验流程

    开始
    设计拓扑
    配置ip
    未激活情况下查看路由表
    激活情况下查看路由表
    验证主机连通
    结束

    1.设计拓扑

    在这里插入图片描述

    2.配置路由器IP地址

    Router>enable
    Router#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    Router(config)#interface g0/0
    Router(config-if)#ip address 192.168.1.1 255.255.255.0
    Router(config-if)#exit
    Router(config)#interface g0/1
    Router(config-if)#ip address 192.168.2.1 255.255.255.0
    Router(config-if)#end
    Router#
    %SYS-5-CONFIG_I: Configured from console by console
    
    Router#
    

    3.查看路由表

    Router#show ip route
    Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is not set
    
    

    4.激活端口

    Router#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    Router(config)#interface g0/0
    Router(config-if)#no shutdown
    
    Router(config-if)#
    %LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
    
    %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
    
    Router(config-if)#exit
    Router(config)#interface g0/1
    Router(config-if)#no shutdown
    
    Router(config-if)#
    %LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up
    
    %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
    
    Router(config-if)#
    

    5.查看路由表

    Router#show ip route
    Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is not set
    
         192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
    C       192.168.1.0/24 is directly connected, GigabitEthernet0/0
    L       192.168.1.1/32 is directly connected, GigabitEthernet0/0
         192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
    C       192.168.2.0/24 is directly connected, GigabitEthernet0/1
    L       192.168.2.1/32 is directly connected, GigabitEthernet0/1
    

    6.验证主机连通

    这里验证p0和p2的连通性,打开主机p0终端

    C:\>ping 192.168.2.11
    
    Pinging 192.168.2.11 with 32 bytes of data:
    
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    
    Ping statistics for 192.168.2.11:
        Packets: Sent = 4, Received = 0, Lost = 4 (100% loss)
    C:\>
    

    等等,忘记配置每个主机的IP,子网掩码,网关了
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    再来

    C:\>ping 192.168.2.11
    
    Pinging 192.168.2.11 with 32 bytes of data:
    
    Request timed out.
    Reply from 192.168.2.11: bytes=32 time<1ms TTL=127
    Reply from 192.168.2.11: bytes=32 time<1ms TTL=127
    Reply from 192.168.2.11: bytes=32 time=1ms TTL=127
    
    Ping statistics for 192.168.2.11:
        Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 0ms, Maximum = 1ms, Average = 0ms
    
    C:\>
    

    已经可以证明两者可以互相通信了,其它的同样也可以就不做验证了。

    此时再看一下拓扑图
    在这里插入图片描述
    之前的红点已经变成了绿色。

    绿色:代表连通
    红色:代表未连接
    黄色:代表阻塞

    注意:路由器端口所连接的不能是同一个网络,否者会出现端口重叠的现象。

    展开全文
  • 路由器IP地址配置

    2021-01-07 15:12:08
    (1)底层 所有节点配置合法ip地址 (2)路由 全网可达 (3)策略 规则,优化和安全 (4)测试 (5)排错 3.维护 4.升级(基于拓扑结构设计) 对于上面的实验我们用这个思路 对于可能用到的理论 1、负载均衡 – 当...

    关于下图的实验
    在这里插入图片描述
    网络部署的思路
    1.拓扑设计
    ip地址的规划
    2.实施
    (1)底层 所有节点配置合法ip地址
    (2)路由 全网可达
    (3)策略 规则,优化和安全
    (4)测试
    (5)排错
    3.维护
    4.升级(基于拓扑结构设计)
    对于上面的实验我们用这个思路
    对于可能用到的理论
    1、负载均衡 – 当路由器访问同一目标,具有多条开销相似路径时;可以让设备将流量拆分后延多条路径同时传输;–可以起到带宽叠加的效果;

    2、环回接口
    在路由器上,创建环回接口;配置ip地址后,可以和PC的环回网卡一样,测试该设备是否可以正常支持tcp/ip协议栈道;
    同时该接口还可用于在实验环境中,模仿连接PC终端的物理接口;

    3、 手工汇总—当访问多个连续子网(可以进行汇总计算),且通过相同的路径时;可以将这些网段进行汇总计算后,仅在路由器上编辑到达汇总网段的路由条目即可;减少了路由器路由表的条目数量;

    4、 路由黑洞 — 在汇总计算时,汇总的地址中包含网络内实际不存在的地址时,将出现有去无回的现象;浪费链路和硬件资源;
    良好的地址规划,和精确的地址汇总可以降低黑洞的出现;

    5、 缺省路由 –一条不限定目标的路由条目;路由器查表时,在查看完本地所有的直连、静态、动态路由后若依然没有可达路径;才使用该条目;
    [r1]ip route-static 0.0.0.0 0.0.0.0 192.168.3.2

    6、 空接口路由 –当路由黑洞与缺省路由相遇,将必然出现环路;
    在黑洞路由器上配置到达汇总网段的空接口路由来防止环路径的出现
    [r1]ip route-static 4.4.0.0 22 NULL 0

    7、 浮动静态路由
    所有的路由条目在路由表中,均存在优先级0-255,小优;
    若学习到多条去往相同目标的路由,但优先级不同,仅加载优先级小的路由进入路由表;
    未被加载路由,将存储在缓存中,不使用;
    通过修改路由的优先级,可以起到路径备份的作用—浮动静态路由
    [r7]ip route-static 8.8.8.0 24 13.1.1.2 preference ?
    INTEGER<1-255> Preference value range
    [r7]ip route-static 8.8.8.0 24 13.1.1.2 preference 61
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    实验过程可能用到的命令

    sys
    system-view
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysn
    [Huawei]sysname r2
    [r2]
    [r2]int g 0/0/0
    [r2-GigabitEthernet0/0/0]ip add 192.168.1.2 24
    Jan 7 2021 12:46:28-08:00 r2 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP
    on the interface GigabitEthernet0/0/0 has entered the UP state.
    [r2-GigabitEthernet0/0/0]int g 0/0/1
    [r2-GigabitEthernet0/0/1]ip add 192.168.3.1 24
    Jan 7 2021 12:46:46-08:00 r2 %%01IFNET/4/LINK_STATE(l)[1]:The line protocol IP
    on the interface GigabitEthernet0/0/1 has entered the UP state.
    [r2-GigabitEthernet0/0/1]
    sys
    system-view
    Enter system view, return user view with Ctrl+Z.
    [r2]ip rou
    [r2]ip route-
    [r2]ip route-static 192.168.2.0 24 192.168.1.1
    [r2]ip rou
    [r2]ip route-
    [r2]ip route-static 192.168.4.0 24 192.168.3.2

    [r4]ip route-
    [r4]ip route-static 5.5.5.0 24 192.168.6.2prer
    [r4]ip route-static 5.5.5.0 24 192.168.6.2 pre
    [r4]ip route-static 5.5.5.0 24 192.168.6.2 preference 61
    [r4]disp
    [r4]display ip rou
    [r4]display ip routing-table
    Route Flags: R - relay, D - download to fib

    [r4]
    [r4]ip rou
    [r4]ip route-
    [r4]ip route-static 5.5.5.0 24 192.168.5.2
    Error: The route already exists.
    [r4]ip route-static 5.5.5.0 24 192.168.6.2
    Info: Succeeded in modifying route.
    [r3]
    [r3]ip rou
    [r3]ip route-
    [r3]ip route-static 192.168.1.0 24 192.168.2.1
    [r3]ip rou
    [r3]ip route-
    [r3]ip route-static 192.168.3.0 24 192.168.4.2
    [r3]ip rou
    [r3]ip route-
    [r3]ip route-static 5.5.5.0 24 192.168.4.2
    [r3]
    [r1]ip rou
    [r1]ip route-
    [r1]ip route-static 192.168.3.0 24 192.168.1.2
    [r1]ip rou-
    [r1]ip rou
    [r1]ip route-
    [r1]ip route-static 192.168.4,0 24 192.168.2.2
    ^
    Error: Wrong parameter found at ‘^’ position.
    [r1]ip route-static 192.168.4.0 24 192.168.2.2
    [r1]ip rou
    [r1]ip route-
    [r1]ip route-static 192.168.6.0 24 192.168.1.2
    [r1]ip route-static 192.168.6.0 24 192.168.2.2

    展开全文
  • (1)底层 所有节点配置合法ip地址 (2)路由 全网可达 (3)策略 规则,优化和安全 (4)测试 (5)排错 3.维护 4.升级(基于拓扑结构设计) 对于上面的实验我们用这个思路 对于可能用到的理论 1、负载均衡 – 当...

    关于下图的实验
    在这里插入图片描述网络部署的思路
    1.拓扑设计
    ip地址的规划
    2.实施
    (1)底层 所有节点配置合法ip地址
    (2)路由 全网可达
    (3)策略 规则,优化和安全
    (4)测试
    (5)排错
    3.维护
    4.升级(基于拓扑结构设计)
    对于上面的实验我们用这个思路
    对于可能用到的理论
    1、负载均衡 – 当路由器访问同一目标,具有多条开销相似路径时;可以让设备将流量拆分后延多条路径同时传输;–可以起到带宽叠加的效果;

    2、环回接口
    在路由器上,创建环回接口;配置ip地址后,可以和PC的环回网卡一样,测试该设备是否可以正常支持tcp/ip协议栈道;
    同时该接口还可用于在实验环境中,模仿连接PC终端的物理接口;

    3、 手工汇总—当访问多个连续子网(可以进行汇总计算),且通过相同的路径时;可以将这些网段进行汇总计算后,仅在路由器上编辑到达汇总网段的路由条目即可;减少了路由器路由表的条目数量;

    4、 路由黑洞 — 在汇总计算时,汇总的地址中包含网络内实际不存在的地址时,将出现有去无回的现象;浪费链路和硬件资源;
    良好的地址规划,和精确的地址汇总可以降低黑洞的出现;

    5、 缺省路由 –一条不限定目标的路由条目;路由器查表时,在查看完本地所有的直连、静态、动态路由后若依然没有可达路径;才使用该条目;
    [r1]ip route-static 0.0.0.0 0.0.0.0 192.168.3.2

    6、 空接口路由 –当路由黑洞与缺省路由相遇,将必然出现环路;
    在黑洞路由器上配置到达汇总网段的空接口路由来防止环路径的出现
    [r1]ip route-static 4.4.0.0 22 NULL 0

    7、 浮动静态路由
    所有的路由条目在路由表中,均存在优先级0-255,小优;
    若学习到多条去往相同目标的路由,但优先级不同,仅加载优先级小的路由进入路由表;
    未被加载路由,将存储在缓存中,不使用;
    通过修改路由的优先级,可以起到路径备份的作用—浮动静态路由
    [r7]ip route-static 8.8.8.0 24 13.1.1.2 preference ?
    INTEGER<1-255> Preference value range
    [r7]ip route-static 8.8.8.0 24 13.1.1.2 preference 61
    在这里插入图片描述在这里插入图片描述
    在这里插入图片描述在这里插入图片描述在这里插入图片描述实验过程可能用到的命令

    sys
    system-view
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysn
    [Huawei]sysname r2
    [r2]
    [r2]int g 0/0/0
    [r2-GigabitEthernet0/0/0]ip add 192.168.1.2 24
    Jan 7 2021 12:46:28-08:00 r2 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP
    on the interface GigabitEthernet0/0/0 has entered the UP state.
    [r2-GigabitEthernet0/0/0]int g 0/0/1
    [r2-GigabitEthernet0/0/1]ip add 192.168.3.1 24
    Jan 7 2021 12:46:46-08:00 r2 %%01IFNET/4/LINK_STATE(l)[1]:The line protocol IP
    on the interface GigabitEthernet0/0/1 has entered the UP state.
    [r2-GigabitEthernet0/0/1]
    sys
    system-view
    Enter system view, return user view with Ctrl+Z.
    [r2]ip rou
    [r2]ip route-
    [r2]ip route-static 192.168.2.0 24 192.168.1.1
    [r2]ip rou
    [r2]ip route-
    [r2]ip route-static 192.168.4.0 24 192.168.3.2

    [r4]ip route-
    [r4]ip route-static 5.5.5.0 24 192.168.6.2prer
    [r4]ip route-static 5.5.5.0 24 192.168.6.2 pre
    [r4]ip route-static 5.5.5.0 24 192.168.6.2 preference 61
    [r4]disp
    [r4]display ip rou
    [r4]display ip routing-table
    Route Flags: R - relay, D - download to fib

    [r4]
    [r4]ip rou
    [r4]ip route-
    [r4]ip route-static 5.5.5.0 24 192.168.5.2
    Error: The route already exists.
    [r4]ip route-static 5.5.5.0 24 192.168.6.2
    Info: Succeeded in modifying route.
    [r3]
    [r3]ip rou
    [r3]ip route-
    [r3]ip route-static 192.168.1.0 24 192.168.2.1
    [r3]ip rou
    [r3]ip route-
    [r3]ip route-static 192.168.3.0 24 192.168.4.2
    [r3]ip rou
    [r3]ip route-
    [r3]ip route-static 5.5.5.0 24 192.168.4.2
    [r3]
    [r1]ip rou
    [r1]ip route-
    [r1]ip route-static 192.168.3.0 24 192.168.1.2
    [r1]ip rou-
    [r1]ip rou
    [r1]ip route-
    [r1]ip route-static 192.168.4,0 24 192.168.2.2
    ^
    Error: Wrong parameter found at ‘^’ position.
    [r1]ip route-static 192.168.4.0 24 192.168.2.2
    [r1]ip rou
    [r1]ip route-
    [r1]ip route-static 192.168.6.0 24 192.168.1.2
    [r1]ip route-static 192.168.6.0 24 192.168.2.2

    展开全文
  • 路由器配置IP地址

    2020-06-17 12:33:17
    用静态路由配置实现IP路由 ...按照图1,连接路由器、配置路由器和PC机端口IP地址。 2.16.1.2 掩码:255.255.255.0 网关172.16.1.1 PC1:172.16.3.2 掩码:255.255.255.0 网关172.16.3.1 PC2:192.168.5.2 掩
  • 多途径多方法配置路由器接口(物理接口和逻辑接口)IP地址
  • 有好几种方法可用来配置Cisco路由器配置可以由TFTP服务器通过网络来完成;可以通过启动时提供的菜单界面来完成;并且可以由运行setup命令所提供的菜单界面来完成;还可以由保存到内存中的配置来完成。本教程不会...
  • 一、实验软件 GNS3二、实验拓扑以及地址规划,如下图所示 三、实验步骤 1、配置IP地址 在R1上配置接口IP地址 在R2上配置IP地址 2、在R1上配置静态路由 在R2上配置静态路由表 3、查看配置文件。命令show running-con....
  • Cisco IOS 设备的操作与使用(以Cisco Packet Tracer Student为例)路由器IP地址配置 配置交换机IP地址 交换机开机进入控制台特权模式: 对终端做配置 进入F0接口 对IP地址进行配置 命令端口不要...
  • 就能彻底解决路由器IP地址冲突问题,在一些无线网络中,由于客户机数目较多,为方便对这些机器进行管理,很多管理员会使用无线路由器提供的DHCP服务,为客户机提供TCP/IP参数配置,如路由器IP地址、网关地址和DNS...
  • 配置路由器端口地址

    千次阅读 2019-05-20 21:04:35
    实验工具:2台PC机,1台路由器(Routers 1841) 2根Copper Cross-Over(交叉线) 第一步:用交叉线把PC和路由器连接起来 第二步:如图用标签写下PC机对应的IP、掩码、默认网关 第三步:点击PC机,选择Desktop,点击IP,...
  • 路由器配置接口IP地址和网关的配置

    千次阅读 2017-11-14 15:18:00
    实验总结:实验的重点就是路由器配置,通过路由器配置两个异构网络的网关,然后就是保存路由器配置,最后一定要配个各个主机的网关,否则无法ping通 本文转自 无心低语 51CTO博客,原文链接:...
  • 网段的最终表现形式是IP地址,也就是说路由器的IP地址,那么我们如何配置路由器IP地址呢?还是拿上一个拓扑图来举例子:路由器AR1配置如下[AR1]interface GigabitEthernet 0/0/0[AR1-GigabitEthernet0/0/0]ip ...
  • 华为路由器ip地址和mac地址绑定命令

    千次阅读 2020-09-23 18:04:08
    首先进入路由器命令行 使用display current-configuration命令...输入命令dhcp server static-bind ip-address x.x.x.x mac-address H-H-H (x.x.x.x是你要绑定的IP地址,H-H-H是Mac地址) 如果提示:Error: The IP a.
  • 去掉全0的网络地址,和全1的广播地址,一共就是14个IP可以用。 范围是: 203.116.75.17~203.116.75.30 现在的问题是,他只给了一个网线,如何去把这些外网的Ip分配到每一台机器上? 还有,他的网关地址怎么...
  • 实验二 配置路由器的接口IP地址及接口描述 实验目的:熟练路由器的常用接口配置命令,会用路由器的状态命令查看路由器的状态。 实验内容和步骤: 1、利用控制台登陆到路由器上,用password设置密码为cisco,用...
  • IP地址分为网络地址和主机地址二个部分,A类地址前8位为网络地址,后24位为主机地址,B类地址16位为网络地址,后16位为主机地址,C类地址前24位为网络地址,后8位为主机地址,网络地址范围如下表所示: 种类  ...
  • 如果您需要对网络进行任何更改,则通常将登录路由器配置页面,方法是在网络浏览器中键入路由器IP地址来访问该页面。但是,如何找到路由器IP地址?在本文中,您将学习如何在所有主要平台(包括智能手机或平板...
  • 当我们的网络出现问题的时候,一般会首先排除线路,其次最重要的就是检查路由器是否正常工作,此时就需要...最简单粗暴的方法 如果你知道如何配置路由器,那么最简单的方法是把路由器恢复出厂默认设置,此时就会用默...
  • CISCO路由器配置IP地址映射

    千次阅读 2008-12-30 16:06:00
    "telnet_ip" /连接设备,出现提示后输入用户和密码/提示符为#时输入中"conf_ter" /进入特权配置模式/提示符为#输入"ip_nat_inside_source_static_tcp_内网IP_端口_公网IP_端口" /设置地址映射/输入"exit" 
  • 华为路由器配置ip

    2021-04-06 09:59:16
    配置路由接口ip地址 使用display ip interface brief查看接口与ip等摘要信息 退出当前接口配置 配置路由第二个接口ip地址 使用display ip interface brief查看接口与ip等摘要信息 查看路由表 测试路由到PC1的...
  • IP地址的分类 IP地址由32位二进制组成,通常由四位十进制表示 主要看ABC三类,分为网络部分(NETWORK)和主机部分(HOST) A类:一个网络部分,三个主机部分 1.0.0.0/8到126.0.0.0/8 子网掩码为:255.0.0.0 B类:两个...
  • 如何配置路由器实现L2TP拨号用户始终使用指定的IP地址 需求:AR46-80(LAC)下面接50个L2TP拨号用户,要求每个用户都使用指定的IP地址,而不是LNS随机分配的IP地址。 组网:PC--------AR46-80---------AR28-11 AR...
  • 路由器固定IP配置

    2018-12-15 18:46:00
    前言 路由器插入好电源,插入好...2、上网方式选择固定IP地址,输入IP地址,子网掩码,默认网关,DNS服务 3、输入wifi名称,密码,然后wifi路由器配置成功 转载于:https://www.cnblogs.com/qy1234/p/10124274.html...
  • Netcore磊科无线路由器配置简单,不过对于没有网络基础的用户来说,完成路由器的安装和配置IP地址过滤,仍然有一定的困难,下面是小编给大家整理的一些有关磊科无线路由器IP地址过滤的设置方法,,需要的朋友可以参考...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 7,163
精华内容 2,865
关键字:

配置路由器ip地址