精华内容
下载资源
问答
  • bgp路由聚合
    2021-07-06 23:27:07
    对于自然聚合的 使用summary automatic对import的路由进行汇总 即只能在始发地进行汇总 而使用手动汇总aggragate x.x.x.x mask可以对本地bgp路由表中的路由进行聚合 无论是否是不是本地始发 
    使用汇总后 属性会
    1 发生变化
    origin imcomplete>egp>igp 向下兼容
    nexthop为aggretor的rid(聚合者)
    med 恢复默认
    local-pref恢复默认
    as-path会清空 除非配置as-set会携带无序的as进行防环 但只有手动聚合可以配置 
    community 继承所有明细的团体属性
    ext-community 继承所有明细的拓展团体属性
    2 新增
    aggregator
    聚合者rid
    automatic-aggregate
    automitic-aggregate 使用手动聚合 aggragate xx..x.x.x detail-suppressed 后不传递明细路由 因此会携带该属性进行说明 
    15.1 场景&实验 
    <r7>dis bgp  routing-table
    BGP Local router ID  is 37.1.1.7
    Status codes: * -  valid, > - best, d -  damped,
                   h -  history,  i -  internal, s -  suppressed, S -  Stale
                   Origin  : i - IGP, e - EGP,  ? - incomplete
    Total Number of  Routes: 18
          Network             NextHop        MED         LocPrf    PrefVal  Path/Ogn
    *>   1.1.1.1/32          37.1.1.3                               0      200 100?
    *>   1.1.1.2/32          37.1.1.3                               0      200 100?
    *>   1.1.1.3/32          37.1.1.3                               0      200 100?
    *>   1.1.1.4/32          37.1.1.3                               0      200 100?
    *>   1.1.1.5/32          37.1.1.3                               0      200 100?
    *>   2.2.2.2/32          37.1.1.3                               0      200 100?
    *>   4.4.4.4/32          37.1.1.3                               0      200 100?
    *>   4.4.4.5/32          37.1.1.3                               0      200 100?
    *>   4.4.4.6/32          37.1.1.3                               0      200 100?
    *>   4.4.4.7/32          37.1.1.3                               0      200 100?
    *>   4.4.4.8/32          37.1.1.3                               0      200 100?
    *>   5.5.5.5/32          37.1.1.3                               0      200 100?
    *>   5.5.5.6/32          37.1.1.3                               0      200 100?
    *>   5.5.5.7/32          37.1.1.3                               0      200 100?
    *>   5.5.5.8/32          37.1.1.3                               0      200 100?
    *>   12.1.1.0/24         37.1.1.3                               0      200 100?
    *>   24.1.1.0/24         37.1.1.3                               0      200 100?
    *>   25.1.1.0/24         37.1.1.3                               0      200 100?
    1 如果在r3上进行手动汇总并设置了detail-suppress明细过滤后
    <r7>dis bgp  routing-table
    BGP Local router ID  is 37.1.1.7
    Status codes: * -  valid, > - best, d -  damped,
                   h -  history,  i -  internal, s -  suppressed, S -  Stale
                   Origin  : i - IGP, e - EGP,  ? - incomplete
    Total Number of  Routes: 7
          Network             NextHop        MED         LocPrf    PrefVal  Path/Ogn
    *>   1.1.1.0/24          37.1.1.3                               0      200?
    *>   2.2.2.2/32          37.1.1.3                               0      200 100?
    *>   4.4.4.0/24          37.1.1.3                               0      200?
    *>   5.5.5.0/24          37.1.1.3                               0      200?
    *>   12.1.1.0/24         37.1.1.3                               0      200 100?
    *>   24.1.1.0/24         37.1.1.3                               0      200 100?
    *>   25.1.1.0/24         37.1.1.3                               0      200 100?
    可见丢失了as-path 100的属性
    2 如果在r3上进行手动汇总并设置了detail-suppress明细过滤,并对1.1.1.0的汇总路由设置as-set后
    <r7>dis bgp  routing-table
    BGP Local router ID  is 37.1.1.7
    Status codes: * -  valid, > - best, d -  damped,
                   h -  history,  i -  internal, s -  suppressed, S -  Stale
                   Origin  : i - IGP, e - EGP,  ? - incomplete
    Total Number of  Routes: 3
          Network             NextHop        MED         LocPrf    PrefVal  Path/Ogn
    *>   1.1.1.0/24          37.1.1.3                               0      200 100i
    可见其携带了as-path 100的属性
    3 如果在r2上不import ospf 1 而是network了除5.5.5.7外的所有的明细路由 但是对5.5.5.7这条路由还是进行了import ospf 1 的方式进行引入 那么它的origin是?其他的都是i 在r3上进行了路由汇总 就会在r2上出现被r3汇总的路由 下一跳指向r3
    [r2-bgp]dis bgp  routing-table
    BGP Local router ID  is 2.2.2.2
    Status codes: * -  valid, > - best, d -  damped,
                   h -  history,  i -  internal, s -  suppressed, S -  Stale
                   Origin  : i - IGP, e - EGP,  ? - incomplete
    Total Number of  Routes: 13
          Network             NextHop        MED         LocPrf    PrefVal  Path/Ogn
    *>   1.1.1.0/24          23.1.1.3                               0      200i
    *>   1.1.1.1/32          0.0.0.0         1                      0      i
    *>   1.1.1.2/32          0.0.0.0         1                      0      i
    *>   1.1.1.3/32          0.0.0.0         1                      0      i
    *>   1.1.1.4/32          0.0.0.0         1                      0      i
    *>   4.4.4.0/24          23.1.1.3                               0      200i
    *>   4.4.4.4/32          0.0.0.0         1                      0      i
    *>   4.4.4.5/32          0.0.0.0         1                      0      i
    *>   4.4.4.6/32          0.0.0.0         1                      0      i
    *>   5.5.5.0/24          23.1.1.3                               0      200i
    *>   5.5.5.5/32          0.0.0.0         1                      0      i
    *>   5.5.5.6/32          0.0.0.0         1                      0      i
    *>   5.5.5.7/32          0.0.0.0         1                      0      ?
    在r3上进行手动汇总并设置了detail-suppress明细过滤后
    <r7>dis bgp  routing-table
    BGP Local router ID  is 37.1.1.7
    Status codes: * -  valid, > - best, d -  damped,
                   h -  history,  i -  internal, s -  suppressed, S -  Stale
                   Origin  : i - IGP, e - EGP,  ? - incomplete
    Total Number of  Routes: 3
          Network             NextHop        MED         LocPrf    PrefVal  Path/Ogn
    *>   1.1.1.0/24          37.1.1.3                               0      200i
    *>   4.4.4.0/24          37.1.1.3                               0      200i
    *>   5.5.5.0/24          37.1.1.3                               0      200?

    可见被汇总的路由继承了最差的origin属性
    4 在r1上给1.1.1.2 赋予300的local-pref 给1.1.1.3 赋予10的local-pref 然后在r1上进行手动汇总 设置as-set和detail-suppress
    [r1-bgp]dis bgp  routing-table
    BGP Local router ID  is 12.1.1.1
    Status codes: * -  valid, > - best, d -  damped,
                   h -  history,  i -  internal, s -  suppressed, S -  Stale
                   Origin  : i - IGP, e - EGP,  ? - incomplete
    Total Number of  Routes: 10
          Network             NextHop        MED         LocPrf    PrefVal  Path/Ogn
    *>   1.1.1.0/24          127.0.0.1                              0      i
    s>   1.1.1.2/32          0.0.0.0         0           300        0      i
    s>   1.1.1.3/32          0.0.0.0         0           10         0      i

    在r2上进行查看
    [r2-bgp]dis bgp  routing-table
    BGP Local router ID  is 2.2.2.2
    Status codes: * -  valid, > - best, d -  damped,
                   h -  history,  i -  internal, s -  suppressed, S -  Stale
                   Origin  : i - IGP, e - EGP,  ? - incomplete
    Total Number of  Routes: 8
          Network             NextHop        MED         LocPrf    PrefVal  Path/Ogn
    *>i  1.1.1.0/24          1.1.1.1                     100        0      i

    发现local-pref恢复了默认值100
    5 在r2上给1.1.1.2 赋予300的med 给1.1.1.3 赋予200的med 在r2上进行手动汇总 设置as-set
    在r3上进行查看
    <r3>dis bgp  routing-table
    BGP Local router ID  is 23.1.1.3
    Status codes: * -  valid, > - best, d -  damped,
                   h -  history,  i -  internal, s -  suppressed, S -  Stale
                   Origin  : i - IGP, e - EGP,  ? - incomplete
    Total Number of  Routes: 12
          Network             NextHop        MED         LocPrf    PrefVal  Path/Ogn
    *>   1.1.1.0/24          23.1.1.2                               0      100i
    *>   1.1.1.1/32          23.1.1.2        200                    0      100i
    *>   1.1.1.2/32          23.1.1.2        300                    0      100i
    发现med恢复了默认值0
    6 在r2上给1.1.1.2 赋予200的community属性 给1.1.1.1 赋予300的community属性 在r3上进行手动汇总 设置as-set
    <r7>dis bgp  routing-table  1.1.1.0
    BGP local router ID  : 37.1.1.7
    Local AS number :  300
    Paths:   1  available, 1 best, 1  select
    BGP routing table  entry information of  1.1.1.0/24:
    From: 37.1.1.3  (23.1.1.3)
    Route Duration:  00h00m09s  
    Direct  Out-interface:  GigabitEthernet0/0/0
    Original nexthop:  37.1.1.3
    Qos information :  0x0
    Community:<0:100>,  <0:200>
    AS-path 200, origin  igp, pref-val 0,  valid, external,  best, select,  active, pre
    255
    Aggregator: AS 200,  Aggregator ID  23.1.1.3
    Not advertised to  any peer yet

    发现汇总后的路由继承了所有的团体属性值
    更多相关内容
  • 华为 BGP路由聚合

    万次阅读 多人点赞 2020-07-01 11:03:17
    文章目录BGP路由聚合的作用和聚合的方式拓扑基础配置策略与观察TS排错 BGP的聚合相对其他协议的聚合差异较大,且重要性较高,关于手动聚合的属性及策略运用要熟练掌握。 BGP路由聚合的作用和聚合的方式 1、减少...

    业精于勤,荒于嬉;行成于思,毁于随。

    BGP的聚合相对其他协议的聚合差异较大,且重要性较高,关于手动聚合的属性及策略运用要熟练掌握。

    一、BGP聚合

    在中型或大型BGP网络中,BGP路由表会变得十分庞大,存储路由表占用大量的交换机内存资源,传输和处理路由信息需要占用大量的网络资源。使用路由聚合(Routes Aggregation)可以大大减小路由表的规模;另外通过对路由进行聚合,隐藏一些具体的路由,可以减少路由震荡对网络带来的影响。

    BGP路由聚合结合灵活的路由策略,使BGP更有效的传递和控制路由。

    1、减少路由表项网络设备的硬件资源的占用
    2、提高网络的稳定性

    BGP支持两种聚合方式:自动聚合和手动聚合。自动聚合的路由优先级低于手动聚合的路由优先级(宣告聚合路由–配合静态来实现)。

    1.1 BGP路由聚合的作用

    (1)减少路由表的明细路由(减少空间占用和维护每条明细路由带来压力)
    (2)减少因为某些明细路由的频繁更新导致网络波动

    1.2 BGP路由聚合的方式

    (1)summary automatic 自动聚合
    (2)Aggregation 手动聚合
    (3)静态宣告 宣告时宣告手动汇总后的路由(需要再ip路由表静态部署一条指向null 0的手动聚合后的路由)

    二、拓扑

    在这里插入图片描述

    三、基础配置

    1、AS-200运行OSPF协议属于区域0

    2、如图构建BGP邻居,全部建立EBGP邻居(AR-4不运行BGP),开启团体属性通告功能

    3、在AR-4将静态路由及Loopback 1直连路由引入进OSPF,引入后的路由开销为150,类型值为2

    [AR-4]acl 2000                                           //创建基本acl 2000 来匹配192.168.1.4/32的主机路由
    [AR-4-acl-basic-2000]rule permit source 192.168.1.4 0 
    [AR-4-acl-basic-2000]quit 
    [AR-4]route-policy ospf_cost permit node 10              //创建名称为ospf_cost的路由策略节点10	
    [AR-4-route-policy]if-match acl 2000                     //此节点匹配acl 2000抓取的路由
    [AR-4-route-policy]apply cost 150                        //此节点匹配到路由修改开销为150
    [AR-4-route-policy]quit 
    
    [AR-4]ospf 1                                             //进入OSPF进程
    [AR-4-ospf-1]import-route direct route-policy ospf_cost  //引入直连路由时挂接名称为ospf_cost的路由策略进行路由过滤与开销修改
    [AR-4-ospf-1]import-route static cost 150                //引入此设备的静态路由并修改开销为150
    [AR-4-ospf-1]quit 
    

    3.1 自动聚合

    (1)只对引入的BGP路由会自动聚合,network宣告进BGP的路由无法执行自动聚合。
    (2)只对始发与本地的BGP路由聚合会生效,对于通过其他BGP设备传递而来的外部路由聚合不会生效。
    (3)只将聚合后的路由发布出去
    (4)聚合后自动在本地生成一条指向聚合的Null路由来防止可能出现的环路
    (5)默认情况BGP设备的自动聚合是关闭的

    1、在AR-3将Loopback 1接口地址引入进BGP协议并开启自动聚合

    [AR-3]bgp 300	
    [AR-3-bgp]net 192.168.1.3 32 
    [AR-3-bgp]ipv4-family unicast 
    [AR-3-bgp-af-ipv4]summary automatic  //开启本BGP设备的自动汇总,自动汇总只对引入(重分发)进本BGP的路由有效,会将路由汇总为主类路由
    

    四、策略与观察

    1、查看AR-2 BGP路由表中192.168.1.0/24路由的MED值,AS-patch值判断AR-2对于此路由的最优来源选择

    dis bgp routing-table
    在这里插入图片描述
    MED值为0;AS-patch值为300;
    主要是该路由到达目的地的路由是唯一的,所以直接优选。

    2、在AR-2将OSPF路由引入进BGP协议,查看AR-2 BGP路由表中192.168.1.0/24路由的MED值,AS-path值判断AR-2对于此路由的最优来源选择

    [AR-2]bgp 200
    [AR-2-bgp]import-route ospf 
    

    dis bgp routing-table
    在这里插入图片描述
    MED值为150,AS-path值为空(本地产生);为本地始发
    Origin i>e>?
    主要是该路由到达目的地的路由是唯一的,所以直接优选,对到达同一目的地的路由不存在多条。

    3、在AR-2开启自动聚合,查看AR-2 BGP路由表中192.168.1.0/24路由的MED值,AS-path值判断AR-2对于此路由的最优来源选择

    [AR-2]bgp 200
    [AR-2-bgp]summary automatic 
    

    dis bgp routing-table
    在这里插入图片描述
    4、在AR-2通过手动聚合产生192.168.1.0/24的BGP路由,查看AR-2 BGP路由表针对192.168.1.0/24路由的MED值,AS-patch值判断AR-2对于此路由的最优来源选择
    (通告查看192.168.1.0的bgp详细路由信息来区分路由是自动聚合或是手动聚合产生)

    起源属性为“?”是自动聚合产生;
    起源属性为“i”可能是自动聚合产生,也可能是动聚合产生。

    [AR-2-bgp]aggregate 192.168.1.0 24
    

    dis bgp routing-table
    在这里插入图片描述

    [AR-2-bgp]undo summary automatic 
    

    dis bgp routing-table
    在这里插入图片描述
    5、当完成上述内容后,在AR-2的BGP路由表存在几条192.168.1.0/24的路由,同时存在这些路由时优选哪个起源属性的路由,并得出BGP本地起源属性的规则

    BGP本地起源属性:

    BGP的第四条选路原则只有当BGP设备针对同一条路由有多个获取源时,使用第四条选路原则
    手动聚合>自动聚合>IGP>BGP的规则来原则最佳路由

    五、TS排错

    1、现要求AS-100的路由器可以正常接收聚合路由192.168.2.0/24

    [AR-2-bgp]aggregate 192.168.2.0 255.255.255.0 detail-suppressed
    

    dis bgp routing-table
    在这里插入图片描述
    2、此路由需要最好的放环属性

    [AR-2-acl-basic-2000]acl 2020
    [AR-2-acl-basic-2020]rule 20 permit source 192.168.2.0 0.0.0.255
    [AR-2-acl-basic-2020]quit
    [AR-2]route-policy no-ad permit node 10
    [AR-2-route-policy]if-match acl 2020
    [AR-2-route-policy]apply community no-advertise
    [AR-2-route-policy]quit
    [AR-2]route-policy no-ad  permit node 20
    [AR-2-route-policy]quit
    [AR-2]bgp 200
    [AR-2-bgp]peer 12.1.1.1 route-policy no-ad  export 
    

    3、同时只接收192.168.2.0/24内的明细路由192.168.2.3/32

    请在AR-2进行故障排查,修改缺失或者错误配置及策略,满足以上题目需求
    (注意:可做修改与增加配置,不要删除任何配置)

    我这里用的是“反向操作”!!但是最好所有的问题和需求都在聚合策略下完成

    [AR-2]acl 2030
    [AR-2-acl-basic-2030]rule 30 permit source 192.168.2.2 0
    [AR-2-acl-basic-2030]rule 40 permit source 192.168.2.4 0
    [AR-2-acl-basic-2030]quit
    [AR-2]route-policy aa permit node 10
    [AR-2-route-policy]if-match acl 2030
    [AR-2-bgp]undo  peer 12.1.1.1 route-policy no-ad export
    [AR-2-bgp]aggregate 192.168.2.0 255.255.255.0 as-set suppress-policy aa 
    

    dis bgp routing-table
    在这里插入图片描述

    5.1 手动聚合

    1、聚合后明细和聚合路由都发布出去

    (1)对宣告;引入;始发;以及通过BGP学到的路由都会生效
    (2)汇总后将明细和汇总路由都传递出去
    (3)汇总后的路由不再携带明细路由的AS号,只携带汇总设备的AS号,此路由以汇总设备作为始发。
    (4)聚合后自动在本地生成一条指向聚合的Null路由来防止可能出现的环路

      [AR-2-bgp]aggregate 192.168.2.0 24 ?
              as-set              //发出聚合路由时携带明细路由的AS号
              attribute-policy    //为聚合路由添加属性值
              detail-suppressed   //抑制所有的明细路由,只发出聚合路由
              origin-policy       //只有命中指定路由后才会产生此聚合路由(被route-policy命中的的明细)
              suppress-policy     //选择性抑制明细路由(被suppress-policy命中的路由会被抑制)
    

    2、聚合后的路由携带明细AS发布出去

    (1)默认情况下聚合后的路由不再携带原明细路由的AS号,只有本聚合设备的AS然后开始传递,这样聚合路由回传存在环路的风险
    (2)对聚合路由赋予as-set属性,此聚合路由将保留原明细路由的AS属性

    [AR-2-bgp]aggregate 192.168.0.0 22 as-set                  //手动聚合的这条路由将携带明细路由的AS-Path属性发布出去。
    
    [AR-2-bgp]aggregate 40.1.0.0 22 detail-suppressed as-set   //只将聚合后的路由发送给邻居,并携带明细路由的AS-Path属性。
    

    3、只将聚合后的路由发布出去

    (1)对宣告;引入;始发;以及通过BGP学到的路由都会生效
    (2)汇总后只将汇总路由传递出去 ,参与汇总的明细路由将在本地BGP路由表打上“S”被抑制
    (3)汇总后的路由不再携带明细路由的AS号,只携带汇总设备的AS号,此路由以汇总设备作为始发。

     [AR-2-bgp]aggregate 192.168.2.0 24 detail-suppressed        //手动聚合后只将聚合路由传递下去
    
     [AR-2-bgp]aggregate 192.168.2.0 24 suppress-policy aa      //手动聚合后的路由和经过路由策略AAA过滤完的明细路由传递下去
    

    六、策略

    suppress-policy 抑制策略

    作用:抑制BGP对的路由(被抑制的路由不会被邻居通告)
    匹配:Route-policy

    attribute-policy 聚合路由路径属性策略

    作用:修改聚合路由属性
    匹配:Route- policy

    origin- policy 起源策略

    作用:限制聚合路由的条件(只有被origin- policy命中的路由才可以产生聚合路由)
    匹配:route policy

    route policy 路由策略

    作用:过滤路由修改路由属性,匹配路由(抓取路由–基于cost路由匹配)
    匹配:ACL,匹配所以路由

    在这里插入图片描述

    本人所有文章都受版权保护,著作权归艺博东所有!未经授权,转载必究或附上其原创链接。

    展开全文
  • BGP 路由聚合(Huawei设备)

    千次阅读 2020-10-31 19:20:16
    文章目录BGP 路由的聚合所产生的问题参考阅读说明一、实验搭建1.1 配置EBGP1.2 宣告路由1.3 路由聚合1.3.1 network方式1.3.2 aggregate方式1.4 团体属性1.5 AS-Path属性二、附加思考 BGP 路由的聚合所产生的问题 ...

    BGP 路由的聚合所产生的问题

    参考阅读

    BGP聚合路由小实验

    说明

    此篇Blog阐述了BGP路由汇总时的问题

    • 抑制明细会有什么影响,如何避免这种影响
    • 如何即抑制明细又传递团体属性
    • 跨AS域做汇总会有什么影响

    一、实验搭建

    场景

    你是公司的网络管理员。公司的网络采用了BGP协议作为路由协议。公司的网络由多个自制系统组成,不同的分支机构使用了不同的AS号。随着公司规模的扩大,路由器中已经有越来越多的路由表,进行BGP的路由汇总迫在眉睫。

    实验拓扑如下

    在这里插入图片描述

    地址规划

    • 各个路由器之间的直连网段使用10.0.xy.xy/24 ,如R1连接R5的链路IP地址为10.0.15.1/24 与10.0.15.5/24,其他同理;
    • 环回的地址如上图所示,注意模拟真实主机,即使用32位

    1.1 配置EBGP

    [R1]router id 10.1.1.1
    [R1]bgp 64513
    [R1-bgp]peer 10.0.12.2 as-number 64514
    [R1-bgp]peer 10.0.14.4 as-number 64512
    [R1-bgp]peer 10.0.15.5 as-number 64516 
    
    [R2]router id 10.1.2.2
    [R2]bgp 64514
    [R2-bgp]peer 10.0.12.1 as-number 64513
    [R2-bgp]peer 10.0.23.3 as-number 64515 
    
    [R3]router id 10.1.3.3
    [R3]bgp 64515
    [R3-bgp]peer 10.0.23.2 as-number 64514 
    
    [R4]router id 10.0.4.4
    [R4]bgp 64512
    [R4-bgp]peer 10.0.14.1 as-number 64513 
    
    [R5]router id 10.1.5.5
    [R5]bgp 64516
    [R5-bgp]peer 10.0.15.1 as-number 64513 
    

    检查各个路由器的BGP的对等体关系

    [R1]dis bgp peer 
    
     BGP local router ID : 10.1.1.1
     Local AS number : 64513
     Total number of peers : 3                Peers in established state : 3
    
      Peer            V          AS  MsgRcvd  MsgSent  OutQ  Up/Down       State PrefRcv
    
      10.0.12.2       4       64514       16       15     0 00:10:23 Established       1
      10.0.14.4       4       64512       13       14     0 00:10:23 Established       1
      10.0.15.5       4       64516       13       15     0 00:10:23 Established       1
      
    [R3]dis bgp peer 
    
     BGP local router ID : 10.1.3.3
     Local AS number : 64515
     Total number of peers : 1                Peers in established state : 1
    
      Peer            V          AS  MsgRcvd  MsgSent  OutQ  Up/Down       State PrefRcv
    
      10.0.23.2       4       64514       17       13     0 00:11:15 Established       2
    

    1.2 宣告路由

    在各个路由器的BGP进程中宣告自身的回环

    [R1]bgp 64513
    [R1-bgp]network 10.1.1.1 255.255.255.255
    
    [R2]bgp 64514
    [R2-bgp]network 10.1.2.2 255.255.255.255
    
    [R3]bgp 64515
    [R3-bgp]network 10.1.3.3 255.255.255.255
    
    [R4]bgp 64512
    [R4-bgp]network 10.0.4.4 255.255.255.255
    
    [R5]bgp 64516
    [R5-bgp]network 10.1.5.5 255.255.255.255
    

    在R4上查看BGP的路由表,可见其他AS域宣告的路由,观察其AS-Path属性为这条路由进入本AS域所经过的AS号

    在这里插入图片描述

    1.3 路由聚合

    路由汇总的目的在于减少路由条目,提高查表转发的效率与速度;对于IGP来说叫做路由汇总,而对于BGP而言存在成千上万条路由条目,其就叫做路由聚合,本质上是一个道理

    1.3.1 network方式

    使用network的方式汇总路由,首先在R1上配置一条静态,即空接口防环路由,为了防止在未来当明细路由丢失的情况下产生的路由黑洞无法处理的情况;然后将其宣告在BGP进程中

    [R1]ip route-static 10.1.0.0 16 NULL 0
    [R1]bgp 64513
    [R1-bgp]network 10.1.0.0 255.255.0.0
    

    其次,在R1与R4建立BGP对等体时过滤掉汇总路由中的明细,抓路由,调用即可

    [R1]ip ip-prefix det permit 10.1.0.0 8 less-equal 24
    [R1]bgp 64513
    [R1-bgp]peer 10.0.14.4 ip-prefix det export 
    

    在R4上查看BGP的路由表,产生了一条由AS64513的汇总路由

    在这里插入图片描述

    1.3.2 aggregate方式

    首先,删除上一方式的配置,然后使用aggregate来聚合10.1.0.0的路由

    [R1]bgp 64513
    [R1-bgp]aggregate 10.1.0.0 255.255.0.0 
    

    R4上查看BGP路由表,可见一条由AS64513而来的聚合路由;但是还存在一些明细路由
    在这里插入图片描述

    聚合时抑制明细

    [R1-bgp]aggregate 10.1.0.0 16 detail-suppressed
    

    在这里插入图片描述

    由于明细路由的消失,必然要空接口防环,所以抑制明细后,R1上会自动产生一条空接口防环的路由;R1上的明细路由被打上s标志,即suppressed,被抑制的意思

    在这里插入图片描述

    在这里插入图片描述

    1.4 团体属性

    验证聚合后的路由是否会清洗明细的属性

    思路:R5将自己的回环发布给R1时携带团体属性(前提是打开传递团体属性的开关),在R4上查看是否还存在(R1上做了聚合)

    步骤一:打开传递团体属性的开关

    [R5]bgp 64516
    [R5-bgp]peer 10.0.15.1 advertise-community
    
    [R1]bgp 64513
    [R1-bgp]peer 10.0.14.4 advertise-community
    

    步骤二:制作策略

    [R5-acl-basic-2000]di th
    [V200R003C00]
    #
    acl number 2000  
     rule 5 permit source 10.1.5.5 0 
    #
    return
    
    [R5-route-policy]di th
    [V200R003C00]
    #
    route-policy com permit node 10 
     if-match acl 2000 
     apply community 100 
    #
    return
    

    步骤三:对对等体调用

    [R5-bgp]peer 10.0.15.1 route-policy com export
    

    验证:

    R1上查看是否携带团体属性,可见,这条被抑制的明细路由是携带团体属性的;而R4上没有是因为R1在做汇总后清洗掉了明细路由的属性

    在这里插入图片描述

    [R4]dis bgp routing-table  community
    
     Total Number of Routes: 0
    

    聚合后如何使其不丢失明细的团体属性?

    答:使用attribute-policy

    步骤1:R1上抓取聚合的路由,制作策略,即为这个聚合的路由进行团体值的设定

    [R1-acl-basic-2000]di th
    [V200R003C00]
    #
    acl number 2000  
     rule 5 permit source 10.1.0.0 0.0.255.255 
    #
    return
    
    [R1-route-policy]di th
    [V200R003C00]
    #
    route-policy comm permit node 10 
     if-match acl 2000 
     apply community 100:2 
    #
    return
    

    步骤2:对等体间调用

    [R1-bgp]aggregate 10.1.0.0 16 attribute-policy comm 
    

    R4上验证查看,可见即保留了聚合路由的团体属性,又继承了明细路由的团体属性

    在这里插入图片描述

    如何,即抑制明细,又继承团体属性?

    [R1-bgp]aggregate 10.1.0.0 16 attribute-policy comm detail-suppressed
    

    1.5 AS-Path属性

    聚合的路由还会丢失明细路由的AS-Path属性,这个属性的丢失极会导致环路的产生

    那么,如何使聚合路由不丢失这个属性呢?

    答:as-set

    [R1-bgp]aggregate 10.1.0.0 16 detail-suppressed as-set
    

    R4上验证,可见保留了明细路由的AS-Path属性,明细的属性在{}中,聚合的始发在最前面

    在这里插入图片描述

    至此,实验完成,验证完成!


    二、附加思考

    • 完成as-set以后,R5是否能访问到R3的Loopback地址?

      不能,因为R1上执行aggregate时带上了as-set,即保留明细上的AS-Path属性,即携带了来自明细路由的AS-Path属性,那么这条汇总路径将不能在进入其他产生明细路由的AS域,这种汇总的方式其实是不应该的,一般汇总的都是本AS域内的汇总,这样的汇总是跨AS域的汇总

    • AggregateSummary automatic有什么区别?
      Aggregate**是清洗了路由的属性后的一种聚合方式

    展开全文
  • bgp路由聚合

    2017-10-05 14:49:17
    bgp路由知识!
  • 路由聚合是将多条路由合并的机制,它通过只向对等体发送聚合后的路由而不发送所有的具体路由的方法,减小路由表的规模。并且被聚合的路由如果发生路由振荡,也不再对网络造成影响,从而提高了网络的稳定性。 路由...

    概述:

    在这里插入图片描述
    在大规模的网络中,BGP路由表十分庞大,给设备造成了很大的负担,同时使发生路由振荡的几率也大大增加,影响网络的稳定性。

    路由聚合是将多条路由合并的机制,它通过只向对等体发送聚合后的路由而不发送所有的具体路由的方法,减小路由表的规模。并且被聚合的路由如果发生路由振荡,也不再对网络造成影响,从而提高了网络的稳定性。

    路由聚合是会使用Aggregator属性和AutoAggregator属性 :

    Atomic-Aggregate属性:属于公认任意属性,主要用于路由聚合时,如果聚合路由将所有明细路由抑制了,就会为聚合路由生成该属性。使用该属性也有一种警告作用,用于告知对等体,原始的明细路由AS_ PATH 出现了丢失。

    Aggregator属性:属于可选过渡属性,该属性作为Atomic-Aggregate 的补充,指明路由信息是在何处出现了丢失,该属性包含发起聚合路由的AS号及生成聚合路由的BGP通告者的RouterID ( 又称为Aggregator ID)。

    自动聚合:

    在这里插入图片描述
    自动聚合注意事项:

    1. 该命令对BGP引入的路由进行聚合,引入的路由可以是直连路由、静态路由、RIP路由、OSPF路由、IS-IS路由。配置聚合后,BGP将按照自然网段聚合路由,明细路由在BGP路由更新中被抑制。该命令对network命令引入的路由无效。
    2. BGP只向对等体发送聚合后的路由。
    3. 缺省情况下BGP不启用自动聚合。

    配置:

    1. 执行命令bgp as-number,进入BGP视图。
    2. 执行命令ipv4-family unicast,进入IPv4单播地址族视图。
    3. 执行命令summary automatic,配置对本地引入的路由自动聚合。
      该命令对BGP引入的路由进行聚合,引入的路由可以是直连路由、静态路由、RIP路由、OSPF路由、IS-IS路由。配置该命令后,BGP将按照自然网段聚合路由。该命令对network命令引入的路由无效。

    手动聚合:

    一、利用静态路由进行聚合
    这种方式是先在路由表中为聚合地址创建静态表项,之后再利用network命令宣告该聚合地址,如下面这个例子:
    在这里插入图片描述
    如图,AS100中有192.168.1.0/24、192.168.2.0/24、192.168.3.0/24和192.168.4.0/24四个内部网络,现在要将4个内部网络的路由聚合成一条192.168.0.0/16这条路由。R1的关键配置:

    bgp 100
    peer 11.1.1.2 as-number 200

    ipv4-family unicast
    undo synchronization
    network 192.168.0.0 255.255.0.0 //将聚合路由发布到BGP中
    peer 11.1.1.2 enable

    ip route-static 192.168.0.0 255.255.0.0 NULL0 //配置一条指向NULL0的静态聚合路由

    由于聚合路由本身并不是合法的终端目的地址,因而静态路由指向Null接口,该路由在R1的路由表中仅代表一条精确路由。如果数据包的目的地址属于AS100的C类地址,那么AS100的外部路由器将撇配该聚合路由并转发给R1,到了路由器R1之后,数据包将被匹到更精确的地址,并被转发到正确的内部下一跳路由器。如果因某种导致更精确的C类地址不在R1路由表中的话,将把该数据包转发到Null接口并予以丢弃。我们查看R2的BGP路由表:
    在这里插入图片描述
    R2的路由表中只有一条聚合路由,其他明细路由均未进入R2的路由表。

    二、通过aggregate命令手动聚合路由,并抑制明细路由
    在上面这种简单的场景下,通过静态路由进行聚合的方式已经足够了,但是对于拓扑结构或者路由策略稍微复杂一些的情况,通过静态路由进行聚合的方式不建议被使用,我们可以使用aggregate命令进行手动聚合。下面具体说明下aggregate命令极其参数的作用。先在上面那个简单的例子中使用aggregate命令。

    R1的关键配置:

    bgp 100
    peer 11.1.1.2 as-number 200

    ipv4-family unicast
    undo synchronization
    aggregate 192.168.0.0 255.255.0.0 detail-suppressed
    network 192.168.1.0
    network 192.168.2.0
    network 192.168.3.0
    network 192.168.4.0
    peer 11.1.1.2 enable

    想要宣告由aggregate命令指定的聚合路由,必须通过重分布或者network命令使至少一个更精确的地址进入BGP路由表。这里我们查看R1和R2的BGP路由表:
    在这里插入图片描述
    可以看到,R1的BGP路由表中包含了所有精确路由,而R2的路由表中只有一条聚合路由,这是因为在aggregate命令中配置了detail-suppressed参数,使R1只会将聚合路由发送给R2。而R1的BGP路由表中,明细路由前面都有“s”的标志,代表这些路由已经被聚合路由抑制。

    三、 同时发送聚合路由和明细路由
    对于像上面这种简单拓扑来说,确实不需要同时宣告聚合路由和明细路由。再看一下下面这个例子:
    在这里插入图片描述
    如图,AS100多归属到AS200,AS200需要从AS100接受全部路由以设置路由策略,但AS200仅能向AS300发送聚合路由。这个场景下,AS100就需要将全部路由发送给AS200。这里一种简单的解决方式是利用团体属性。让AS100发送给AS200的明细路由携带NO_EXPORT团队属性。配置以R1为例:

    bgp 100
    peer 11.1.1.2 as-number 200

    ipv4-family unicast
    undo synchronization
    aggregate 192.168.0.0 255.255.0.0 /路由聚合为192.168.0.0/16,并且不抑制明细路由
    network 192.168.1.0
    network 192.168.2.0
    network 192.168.3.0
    network 192.168.4.0
    peer 11.1.1.2 enable
    peer 11.1.1.2 route-policy COMMUNITY export /对R2出方向使用路由策略COMMUNITY
    peer 11.1.1.2 advertise-community /对R2发送携带团队属性的路由

    route-policy COMMUNITY permit node 5 /配置路由策略COMMUNITY,对匹配前缀列表AGGREGATE的路由不设置团队属性
    if-match ip-prefix AGGREGATE
    apply community none

    route-policy COMMUNITY permit node 10 /未匹配上一个节点的路由,为其打上团队属性NO_EXPORT,这样就实现了仅对明细路由打上NO_EXPORT属性
    apply community no-export

    ip ip-prefix AGGREGATE index 10 permit 192.168.0.0 16 /配置前缀列表
    AGGREGATE仅匹配192.168.0.0/16

    我们通过命令display bgp routing-table 192.168.0.0查看R2上聚合路由的详细信息:
    在这里插入图片描述
    可以看到,该路由已被并标明是一条聚合路由,并且在AS100进行聚合,始发路由器的ROUTER ID是11.1.1.1。该路由并未携带任何团队属性。再查看R5的BGP路由表:
    在这里插入图片描述
    R5上只存在聚合路由,明细路由由于携带NO_EXPORT团队属性,并未发送给R5。

    四、仅发送聚合路由和选定的明细路由
    在这里插入图片描述

    在上述场景下,通过仅发送聚合路由和选定的明细路由,我们还可以实现链路的备份和负载分担,方法如下:

    1. 让R1-R2的链路只宣告192.168.1.0/24和192.168.2.0/24这两条路由。
    2. 让R3-R4的链路只宣告192.168.3.0/24和192.168.4.0/24这两条路由
    3. 通过上述两条链路宣告聚合路由作为备份,再任一条链路出现故障的情况下,所有该链路上访问AS100的流量都会迅速被切换到另外一条链路上。

    这里,我们需要R1和R3分别发送聚合路由和一部分明细路由,这时,会用到aggregate命令的另外一个参数“suppress-policy”。下面给出R1和R3的关键配置:

    R1的关键配置:

    bgp 100
    peer 11.1.1.2 as-number 200

    ipv4-family unicast
    undo synchronization
    aggregate 192.168.0.0 255.255.0.0 suppress-policy SUPPRESS /聚合路由时使用抑制列表SUPPRESS,对于匹配路由策略SUPPRESS的明细路由进行抑制,没有匹配到的就放行,不抑制。
    network 192.168.1.0
    network 192.168.2.0
    network 192.168.3.0
    network 192.168.4.0
    peer 11.1.1.2 enable

    route-policy SUPPRESS permit node 5 /配置路由策略,注意这里只能配置if-match子句,用来匹配被抑制的路由。虽然上面使用的是抑制策略,但是这里仍然配置路由策略即可,但是名称需要和调用的抑制。并且不要再添加一个新的节点,只需要匹配抑制的条目即可。
    if-match ip-prefix SUPPRESS

    ip ip-prefix SUPPRESS index 10 permit 192.168.3.0 24 /配置前缀列表,匹配抑制的条目
    ip ip-prefix SUPPRESS index 20 permit 192.168.4.0 24

    R3的关键配置:

    bgp 100
    peer 12.1.1.2 as-number 200

    ipv4-family unicast
    undo synchronization
    aggregate 192.168.0.0 255.255.0.0 suppress-policy SUPPRESS
    network 192.168.1.0
    network 192.168.2.0
    network 192.168.3.0
    network 192.168.4.0
    peer 12.1.1.2 enable

    route-policy SUPPRESS permit node 5
    if-match ip-prefix SUPPRESS

    ip ip-prefix SUPPRESS index 10 permit 192.168.1.0 24
    ip ip-prefix SUPPRESS index 20 permit 192.168.2.0 24

    我们通过抑制特定的明细路由,实现了R1和R3只宣告聚合路由和特定的明细路由,在R5上查看BGP路由表:
    在这里插入图片描述
    可以看到,R5上聚合路由有两个下一跳,而192.168.1.0/24和192.168.2.0/24这两条路由的下一跳为R2,而192.168.3.0/24和192.168.4.0/24这两条路由的下一跳为R4。这就实现了访问AS100不同网段的流量的负载分担,而一旦有一条链路出现故障,由于聚合路由的存在,可以将流量快速切换到另外一条链路上。

    五、仅聚合特定的明细路由
    依然是这个场景下,假定我们要求R1只将192.168.1.0/24和192.168.2.0/24这两条路由进行聚合,而聚合其余的明细路由。如图:
    在这里插入图片描述
    这里,我们可以用到aggregate命令的“origin-policy”参数。下面给出R1的具体配置:

    R1的关键配置:

    bgp 100
    peer 11.1.1.2 as-number 200

    ipv4-family unicast
    undo synchronization
    aggregate 192.168.0.0 255.255.0.0 detail-suppressed origin-policy ORIGIN /这里只有匹配路由策略ORIGIN的路由被聚合,其他明细路由未被聚合。并只宣告聚合路由
    network 192.168.1.0
    network 192.168.2.0
    network 192.168.3.0
    network 192.168.4.0
    peer 11.1.1.2 enable

    route-policy ORIGIN permit node 5 /配置路由策略ORIGIN(仍然是配置路由策略),注意这里只能配置if-match子句,匹配前缀列表ORIGIN的路由
    if-match ip-prefix ORIGIN

    ip ip-prefix ORIGIN index 10 permit 192.168.1.0 24 /配置前缀列表
    ip ip-prefix ORIGIN index 20 permit 192.168.2.0 24

    这样,就实现了只聚合特定的明细路由,而其余明细路由未被聚合,我们查看一下R2的BGP路由表:

    在这里插入图片描述

    可以看到,R2的BGP路由表中,只有一条聚合路由,和两条明细路由。由于192.168.1.0/24和192.168.2.0/24这两条路由已被聚合,而R1上又配置了detail-suppressed参数,所以这两条明细路由并未发送给R2,而其余明细路由由于未被聚合,所以被发送给了R2,这里还需要说明的是,只有被聚合的明细路由(192.168.1.0/24和192.168.2.0/24)均失效的情况下,聚合路由才会实效,而其余明细路由失效与否是不会影响聚合路由的。

    六、修改聚合路由的属性

    还是这个场景,在R5上,聚合路由的下一跳有两个,分别是R2和R4,而我们很可能要求手动实现R5选择R4作为优选下一跳,而选择R2作为备份下一跳。如果用MED属性,我们需要在R2和R4上部署路由策略,这里我们采用另外一种方式:在发送聚合路由的时候,可以修改聚合路由的属性。
    在这里插入图片描述
    由于明细路由均为我们手动Network进R1的,所以路由的Origin属性均为IGP,而当两条BGP路由的Origin分别为IGP和Incomplete时,BGP会优选Origin属性为IGP的路由。所以我们可以将R1发送给R2的聚合路由属性修改为Incomplete。

    这时,我们会用到了aggregate命令的另一个参数“attribute-policy”。下面给出具体配置:

    R1的关键配置:

    bgp 100
    peer 11.1.1.2 as-number 200

    ipv4-family unicast
    undo synchronization
    aggregate 192.168.0.0 255.255.0.0 detail-suppressed attribute-policy ATTRIBUTE /按照路由策略ATTRIBUTE修改聚合路由属性
    network 192.168.1.0
    network 192.168.2.0
    network 192.168.3.0
    network 192.168.4.0
    peer 11.1.1.2 enable

    route-policy ATTRIBUTE permit node 5 /配置路由策略ATTRIBUTE修改属性为incomplete
    apply origin incomplete

    查看R5的BGP路由表:
    在这里插入图片描述
    可以看到,BGP优选了R4作为优选下一跳,由于R4对应的路由Ogn值为“i”代表该路由的Origin属性为IGP,而R2对应的路由的Ogn值为“?”代表该路由的Origin属性为Incomplete。

    配置汇总:

    1. 执行命令bgp as-number,进入BGP视图。
    2. 执行命令ipv4-family unicast,进入IPv4单播地址族视图。
    3. 根据实际组网选择执行如下命令,配置路由的手动聚合。
      • 发布全部的聚合路由和明细路由:执行命令aggregate ipv4-address { mask | mask-length }
      • 只发布聚合路由:执行命令aggregate ipv4-address { mask | mask-length } detail-suppressed
      • 有选择的发布明细路由:执行命令aggregate ipv4-address { mask | mask-length } suppress-policy route-policy-name
      可以通过peer route-policy命令应用策略来达到相同的效果。
      • 生成检测环路的聚合路由:执行命令aggregate ipv4-address { mask | mask-length } as-set
      • 设置聚合路由的属性:执行命令aggregate ipv4-address { mask | mask-length } attribute-policy route-policy-name
      通过执行peer route-policy命令也可以达到相同效果。
      执行aggregate命令时,如果使用了关键字as-set,而在策略中也执行命令apply as-path配置了AS_Path属性,那么策略中的AS_Path不会生效。
      • 只根据部分明细路由来生成聚合路由:执行命令aggregate ipv4-address { mask | mask-length } origin-policy route-policy-name

    手动聚合对BGP本地路由表中已经存在的路由表项有效,例如BGP路由表中不存在10.1.1.1/24等掩码长度大16的路由,即使配置了命令aggregate 10.1.1.1 16对其进行聚合,BGP也不会将这条聚合路由发布出去。

    检测配置结果:使用display bgp routing-table [ network [ mask | mask-length ] ]命令查看BGP聚合路由信息。

    另外,如果一个聚合路由条目的起源有?也有i,最后聚合出来的路由条目的起源为?。如果都为i才为i。

    整理资料来源:《交换机在江湖》、华为培训文档

    展开全文
  • BGP路由聚合分为两种,一种为自动聚合,一种为手工聚合。 IPV4支持自动聚合、手工聚合,IPV6只支持手工聚合,以下主要研究IPV4路由聚合。 如图所示拓扑,R5上存在三条外部路由,分别为1.1.1.0/24、1.1.2.0/24、...
  • BGP路由聚合

    千次阅读 2018-03-15 10:17:18
    聚合之后传递的路由信息量变少,设备路由表数量也变小聚合后会丢弃原有的所以路由的属性静态路由是因为路由表没有这条路由,就无法network宣告,所以必须写一条静态路由欺骗BGP。而使用null0是因为最长匹配原则,而...
  • BGP自动路由聚合

    千次阅读 2021-05-04 22:13:15
    BGP路由聚合有两种方式,一种是自动路由聚合,一种是手动路由聚合。     自动路由聚合是在自然网络边界路由器上自动执行的,在默认情况下,BGP的自动路由汇聚功能是关闭的,并且BGP不会自动聚合B
  • r2(config)#access-list 1 per 192.168.1.0 0.0.0.255 ...r2(config)#router bgp 100 r2(config-router)#nei 1.1.1.1 route-map aaa in 只从1.1.1.1接受192.168.1.0的路由 ip prefix-list aaa seq 1..
  • bgp路由聚合

    万次阅读 2018-03-16 17:05:54
    bgp路由聚合分为自动聚合和手动聚合。自动聚合:对BGP引入的IGP子网路由进行自然掩码也就是主类路由聚合,配置自动聚合后,生成聚合后的自然网络路由,而原先引入的子网路由被抑制,不会被优先和发布给BGP邻居。自动...
  • bgp路由聚合aggregate-address A.B.C.D/M

    千次阅读 2018-06-04 14:11:40
    在aggregate-address聚合路由时。若不写as-set命令,聚合路由的as-path是基于生成聚合路由的as-path,而不是明细路由的as-path。...如果不使用as-set,那么聚合后的BGP路由,会带有atomic-aggregate(...
  • OSPF的基本配置和路由聚合的简单介绍
  • 1、并不是真正意义上BGP路由汇总,只是通过BGP发布路由的特点来实现了路由汇总的效果。通过配置静态路由进行路由聚合(配置汇总后的黑洞路由),然后再宣告这个汇总后的路由。默认情况下不抑制明细路由,不携带明细...
  • 由于IBGP邻居处于同一个AS中,一般情况下,一个AS中存在大量的备份路径,若使用物理接口建立邻居关系,将浪费这些备份或者负载均衡资源,故...3、当路由器执行路由反射时,他只将自己使用的最优的BGP路由进行反射。...
  • BGP手动路由聚合原理概述实验目的实验内容实验拓扑实验步骤1,基本配置2,配置BGP路由协议3,配置BGP路由聚合4,属于No-Advertise关键字控制路由聚合5,使用Detail-Suppressed关键字控制路由聚合6,使用Suppress-Policy...
  • BGP 自动路由聚合

    千次阅读 2021-01-25 10:09:11
    BGP 是一种无类路由协议,支持CIDR、VLSM(无类别域间路由,可变长子网掩码)和路由聚合路由聚合技术的使用,可以在一定程度上缩减路由条目的数量,同时还可以减轻路由震荡导致的网络不稳定的问题。BGP路由聚合...
  • BGP的属性、路由聚合

    2021-10-16 21:10:08
    Origin属性定义路径信息的来源,标记一条路由是怎么成为BGP路由的。 AS_Path 如图所示: AS 1内的RTA能够从RTB与RTC收到100.0.0.0/24的路由,RTA如何进行自动优选? RTA->RTB->RTC之间在拓扑上存在环路,...
  • BGP路由的引入与聚合

    2022-08-27 23:51:19
    BGP协议本身不发现路由,因此需要将其他路由发布到BGP路由中。BGP引入路由时支持Import和Network两种方式 路由聚合是将多条路由合并的机制,它通过只向对等体发送聚合后的路由而不发送所有的具体路由的方法,减小...
  • HCL配置 BGP 路由聚合与反射实验

    千次阅读 多人点赞 2020-06-17 19:10:41
    实验任务一:配置 BGP 路由反射器 IP地址表 设备名称 接口 IP地址 RTA G0/0 10.10.10.1/30 Loopback0 1.1.1.1/32 RTB G0/0 10.10.10.2/30 G0/1 10.10.10.6/30 Loopback0 2.2.2.2/32 RTC G0/0 ...
  • BGP的基本配置,BGP路由聚合,路由反射器
  • BGP 路由聚合实验

    2020-04-10 16:19:49
    BGP 路由聚合实验
  • 022B-BGP路由聚合

    2020-08-17 09:42:33
    BGP路由聚合的方法 AS_PATH属性的变化 BGP路由聚合配置 BGP路由聚合策略 路由聚合概述 BGP协议可以使用命令,将具体路由聚合成一条聚合路由。 BGP路由聚合种类—自动聚合 对BGP引入的子网路由进行自然掩码聚合。...
  • 7,BGP路由聚合 --- BGP的路由汇总 自动聚合 --- 1,自动聚合功能只能针对重发布的路由条目生效 2,自动聚合只能将明细路由直接汇总到主类。 这样将会产生巨大的路由黑洞。所 以,华为设备默认关闭自动...
  • 一、bgp建立 [r1]bgp 1 [r1-bgp]router-id 1.1.1.1 [r1-bgp]peer 2.2.2.2 as 1 [r1-bgp]pe 2.2.2.2 con lo0 [r2]bgp 1 [r2-bgp]router-id 2.2.2.2 [r2-bgp]pe 1.1.1.1 as 1 [r2-bgp]pe 1.1.1.1 con l...
  • BGP选路与聚合

    2020-11-27 17:09:01
    Value属性聚合方式对选路的影响EBGP的邻居路由优先于IBGP的邻居路由AS内部IGP MetricRouter-ID与IP地址对BGP选路的影响BGP路由策略控制实例BGP路由聚合BGP路由聚合的必要性BGP路由聚合-静态BGP路由聚合-自动聚合BGP...
  • bgp路由汇聚

    千次阅读 2021-11-26 23:47:31
    IBGP环回建邻 bgp 100 router-id 1.1.1.1 peer 4.4.4.4 as-number 100 peer 4.4.4.4 connect-interface LoopBack0 EBGP直连建邻 ...bgp 100 ...逐条宣告所有的明细路由,再进行标准的BGP聚...
  • 实验任务一:配置BGP路由反射器 建立物理连接 RTA和RTB建立EBGP对等体,RTC分别和RTB,RTD建立IBGP对等体, [RTD]ip route-static 2.2.2.2 32 10.0.0.9 [RTD]ip route-static 3.3.3.3 32 10.0.0.9 [RTC]ip route-...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 5,135
精华内容 2,054
关键字:

bgp路由聚合

友情链接: CF2_with_DenseNet.rar