精华内容
下载资源
问答
  • Ubuntu 使用telnet

    万次阅读 2018-07-29 16:49:23
    Ubuntu 使用telnet 想要远程登录Ubuntu(linux)系统的电脑,可以使用ssh,也可以使用telnet。 ubuntu开启telnet服务 sudo apt-get install openbsd-inetd sudo apt-get intstall telnetd sudo /etc/...

    Ubuntu 使用telnet

    • 想要远程登录Ubuntu(linux)系统的电脑,可以使用ssh,也可以使用telnet。
    • ubuntu开启telnet服务
    sudo apt-get install openbsd-inetd
    sudo apt-get install telnetd
    sudo /etc/init.d/openbsd-inetd restart
    # 查看 telnet服务是否开启
    sudo netstat -a | grep telnet
    
    • telnet登陆
    # telnet address
    telnet 192.168.x.x
    

    Linux系列

    展开全文
  • Ubuntu使用dpkg安装软件依赖问题解决这里以在ubuntu 16.04安装Ubuntu Tweak为例进行说明,通常安装包依赖问题都可以用这种方法解决:sudo apt-get install -f也要善用update等。ubuntu-tweak for ubuntu 16.04 64 ...

    Ubuntu使用dpkg安装软件依赖问题解决

    这里以在ubuntu 16.04安装Ubuntu Tweak为例进行说明,通常安装包依赖问题都可以用这种方法解决:

    sudo apt-get install -f

    也要善用update等。

    ubuntu-tweak for ubuntu 16.04 64 LTS下载地址:

    http://download.csdn.net/download/zhangrelay/9705031





    具体过程如下:

    relaybotbox@relaybotbox-desktop:~$ sudo dpkg -i ubuntu-tweak_0.8.7-1~getdeb2~xenial_all.deb 
    [sudo] relaybotbox 的密码: 
    正在选中未选择的软件包 ubuntu-tweak。
    (正在读取数据库 ... 系统当前共安装有 334292 个文件和目录。)
    正准备解包 ubuntu-tweak_0.8.7-1~getdeb2~xenial_all.deb  ...
    正在解包 ubuntu-tweak (0.8.7-1~getdeb2~xenial) ...
    dpkg: 依赖关系问题使得 ubuntu-tweak 的配置工作不能继续:
     ubuntu-tweak 依赖于 python-apt;然而:
      未安装软件包 python-apt。
     ubuntu-tweak 依赖于 python-aptdaemon;然而:
      未安装软件包 python-aptdaemon。
     ubuntu-tweak 依赖于 python-aptdaemon.gtk3widgets;然而:
      未安装软件包 python-aptdaemon.gtk3widgets。
     ubuntu-tweak 依赖于 python-defer;然而:
      未安装软件包 python-defer。
     ubuntu-tweak 依赖于 python-compizconfig;然而:
      未安装软件包 python-compizconfig。
     ubuntu-tweak 依赖于 gir1.2-gconf-2.0;然而:
      未安装软件包 gir1.2-gconf-2.0。
     ubuntu-tweak 依赖于 gir1.2-webkit-3.0;然而:
      未安装软件包 gir1.2-webkit-3.0。
    
    dpkg: 处理软件包 ubuntu-tweak (--install)时出错:
     依赖关系问题 - 仍未被配置
    正在处理用于 hicolor-icon-theme (0.15-0ubuntu1) 的触发器 ...
    正在处理用于 dbus (1.10.6-1ubuntu3.1) 的触发器 ...
    正在处理用于 bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) 的触发器 ...
    Rebuilding /usr/share/applications/bamf-2.index...
    正在处理用于 gnome-menus (3.13.3-6ubuntu3.1) 的触发器 ...
    正在处理用于 desktop-file-utils (0.22-1ubuntu5) 的触发器 ...
    正在处理用于 mime-support (3.59ubuntu1) 的触发器 ...
    正在处理用于 gconf2 (3.2.6-3ubuntu6) 的触发器 ...
    正在处理用于 libglib2.0-0:i386 (2.48.1-1~ubuntu16.04.1) 的触发器 ...
    覆盖文件 /usr/share/glib-2.0/schemas/50_sogoupinyin.gschema.override 中指定的方案 org.gnome.settings-daemon.plugins.xsettings 中没有键 Gtk/IMModule;忽略对此键的覆盖。
    正在处理用于 libglib2.0-0:amd64 (2.48.1-1~ubuntu16.04.1) 的触发器 ...
    覆盖文件 /usr/share/glib-2.0/schemas/50_sogoupinyin.gschema.override 中指定的方案 org.gnome.settings-daemon.plugins.xsettings 中没有键 Gtk/IMModule;忽略对此键的覆盖。
    在处理时有错误发生:
     ubuntu-tweak
    relaybotbox@relaybotbox-desktop:~$ sudo apt-get install -f
    正在读取软件包列表... 完成
    正在分析软件包的依赖关系树       
    正在读取状态信息... 完成       
    正在修复依赖关系... 完成
    将会同时安装下列软件:
      gir1.2-gconf-2.0 gir1.2-javascriptcoregtk-3.0 gir1.2-webkit-3.0
      libjavascriptcoregtk-3.0-0 libwebkitgtk-3.0-0 libwebkitgtk-3.0-common
      python-apt python-aptdaemon python-aptdaemon.gtk3widgets python-compizconfig
      python-debian python-defer
    建议安装:
      python-apt-dbg python-apt-doc
    下列【新】软件包将被安装:
      gir1.2-gconf-2.0 gir1.2-javascriptcoregtk-3.0 gir1.2-webkit-3.0
      libjavascriptcoregtk-3.0-0 libwebkitgtk-3.0-0 libwebkitgtk-3.0-common
      python-apt python-aptdaemon python-aptdaemon.gtk3widgets python-compizconfig
      python-debian python-defer
    升级了 0 个软件包,新安装了 12 个软件包,要卸载 0 个软件包,有 3 个软件包未被升级。
    有 1 个软件包没有被完全安装或卸载。
    需要下载 10.2 MB 的归档。
    解压缩后会消耗 45.1 MB 的额外空间。
    您希望继续执行吗? [Y/n] y
    获取:1 http://mirrors.aliyun.com/ubuntu xenial/main amd64 python-apt amd64 1.1.0~beta1build1 [139 kB]
    获取:2 http://mirrors.aliyun.com/ubuntu xenial/universe amd64 python-debian all 0.1.27ubuntu2 [64.2 kB]
    获取:3 http://mirrors.aliyun.com/ubuntu xenial/universe amd64 python-defer all 1.0.6-2build1 [10.7 kB]
    获取:4 http://mirrors.aliyun.com/ubuntu xenial/universe amd64 python-aptdaemon all 1.1.1+bzr982-0ubuntu14 [76.4 kB]
    获取:5 http://mirrors.aliyun.com/ubuntu xenial/universe amd64 python-aptdaemon.gtk3widgets all 1.1.1+bzr982-0ubuntu14 [13.8 kB]
    获取:6 http://mirrors.aliyun.com/ubuntu xenial-updates/universe amd64 python-compizconfig amd64 1:0.9.12.2+16.04.20160823-0ubuntu1 [38.2 kB]
    获取:7 http://mirrors.aliyun.com/ubuntu xenial/main amd64 gir1.2-gconf-2.0 amd64 3.2.6-3ubuntu6 [6,208 B]
    获取:8 http://mirrors.aliyun.com/ubuntu xenial-updates/universe amd64 gir1.2-javascriptcoregtk-3.0 amd64 2.4.11-0ubuntu0.1 [12.7 kB]
    获取:9 http://mirrors.aliyun.com/ubuntu xenial-updates/universe amd64 libjavascriptcoregtk-3.0-0 amd64 2.4.11-0ubuntu0.1 [1,852 kB]
    获取:10 http://mirrors.aliyun.com/ubuntu xenial-updates/universe amd64 libwebkitgtk-3.0-common all 2.4.11-0ubuntu0.1 [367 kB]
    获取:11 http://mirrors.aliyun.com/ubuntu xenial-updates/universe amd64 libwebkitgtk-3.0-0 amd64 2.4.11-0ubuntu0.1 [7,593 kB]
    获取:12 http://mirrors.aliyun.com/ubuntu xenial-updates/universe amd64 gir1.2-webkit-3.0 amd64 2.4.11-0ubuntu0.1 [60.7 kB]
    已下载 10.2 MB,耗时 10秒 (975 kB/s)                                           
    正在选中未选择的软件包 python-apt。
    (正在读取数据库 ... 系统当前共安装有 334565 个文件和目录。)
    正准备解包 .../python-apt_1.1.0~beta1build1_amd64.deb  ...
    正在解包 python-apt (1.1.0~beta1build1) ...
    正在选中未选择的软件包 python-debian。
    正准备解包 .../python-debian_0.1.27ubuntu2_all.deb  ...
    正在解包 python-debian (0.1.27ubuntu2) ...
    正在选中未选择的软件包 python-defer。
    正准备解包 .../python-defer_1.0.6-2build1_all.deb  ...
    正在解包 python-defer (1.0.6-2build1) ...
    正在选中未选择的软件包 python-aptdaemon。
    正准备解包 .../python-aptdaemon_1.1.1+bzr982-0ubuntu14_all.deb  ...
    正在解包 python-aptdaemon (1.1.1+bzr982-0ubuntu14) ...
    正在选中未选择的软件包 python-aptdaemon.gtk3widgets。
    正准备解包 .../python-aptdaemon.gtk3widgets_1.1.1+bzr982-0ubuntu14_all.deb  ...
    正在解包 python-aptdaemon.gtk3widgets (1.1.1+bzr982-0ubuntu14) ...
    正在选中未选择的软件包 python-compizconfig:amd64。
    正准备解包 .../python-compizconfig_1%3a0.9.12.2+16.04.20160823-0ubuntu1_amd64.deb  ...
    正在解包 python-compizconfig:amd64 (1:0.9.12.2+16.04.20160823-0ubuntu1) ...
    正在选中未选择的软件包 gir1.2-gconf-2.0。
    正准备解包 .../gir1.2-gconf-2.0_3.2.6-3ubuntu6_amd64.deb  ...
    正在解包 gir1.2-gconf-2.0 (3.2.6-3ubuntu6) ...
    正在选中未选择的软件包 gir1.2-javascriptcoregtk-3.0:amd64。
    正准备解包 .../gir1.2-javascriptcoregtk-3.0_2.4.11-0ubuntu0.1_amd64.deb  ...
    正在解包 gir1.2-javascriptcoregtk-3.0:amd64 (2.4.11-0ubuntu0.1) ...
    正在选中未选择的软件包 libjavascriptcoregtk-3.0-0:amd64。
    正准备解包 .../libjavascriptcoregtk-3.0-0_2.4.11-0ubuntu0.1_amd64.deb  ...
    正在解包 libjavascriptcoregtk-3.0-0:amd64 (2.4.11-0ubuntu0.1) ...
    正在选中未选择的软件包 libwebkitgtk-3.0-common。
    正准备解包 .../libwebkitgtk-3.0-common_2.4.11-0ubuntu0.1_all.deb  ...
    正在解包 libwebkitgtk-3.0-common (2.4.11-0ubuntu0.1) ...
    正在选中未选择的软件包 libwebkitgtk-3.0-0:amd64。
    正准备解包 .../libwebkitgtk-3.0-0_2.4.11-0ubuntu0.1_amd64.deb  ...
    正在解包 libwebkitgtk-3.0-0:amd64 (2.4.11-0ubuntu0.1) ...
    正在选中未选择的软件包 gir1.2-webkit-3.0:amd64。
    正准备解包 .../gir1.2-webkit-3.0_2.4.11-0ubuntu0.1_amd64.deb  ...
    正在解包 gir1.2-webkit-3.0:amd64 (2.4.11-0ubuntu0.1) ...
    正在处理用于 libc-bin (2.23-0ubuntu4) 的触发器 ...
    正在设置 python-apt (1.1.0~beta1build1) ...
    正在设置 python-debian (0.1.27ubuntu2) ...
    正在设置 python-defer (1.0.6-2build1) ...
    正在设置 python-aptdaemon (1.1.1+bzr982-0ubuntu14) ...
    正在设置 python-aptdaemon.gtk3widgets (1.1.1+bzr982-0ubuntu14) ...
    正在设置 python-compizconfig:amd64 (1:0.9.12.2+16.04.20160823-0ubuntu1) ...
    正在设置 gir1.2-gconf-2.0 (3.2.6-3ubuntu6) ...
    正在设置 gir1.2-javascriptcoregtk-3.0:amd64 (2.4.11-0ubuntu0.1) ...
    正在设置 libjavascriptcoregtk-3.0-0:amd64 (2.4.11-0ubuntu0.1) ...
    正在设置 libwebkitgtk-3.0-common (2.4.11-0ubuntu0.1) ...
    正在设置 libwebkitgtk-3.0-0:amd64 (2.4.11-0ubuntu0.1) ...
    正在设置 gir1.2-webkit-3.0:amd64 (2.4.11-0ubuntu0.1) ...
    正在设置 ubuntu-tweak (0.8.7-1~getdeb2~xenial) ...
    正在处理用于 libc-bin (2.23-0ubuntu4) 的触发器 ...
    正在处理用于 dbus (1.10.6-1ubuntu3.1) 的触发器 ...
    relaybotbox@relaybotbox-desktop:~$ sudo dpkg -i ubuntu-tweak_0.8.7-1~getdeb2~xenial_all.deb 
    (正在读取数据库 ... 系统当前共安装有 334781 个文件和目录。)
    正准备解包 ubuntu-tweak_0.8.7-1~getdeb2~xenial_all.deb  ...
    正在将 ubuntu-tweak (0.8.7-1~getdeb2~xenial) 解包到 (0.8.7-1~getdeb2~xenial) 上 ...
    正在设置 ubuntu-tweak (0.8.7-1~getdeb2~xenial) ...
    正在处理用于 hicolor-icon-theme (0.15-0ubuntu1) 的触发器 ...
    正在处理用于 dbus (1.10.6-1ubuntu3.1) 的触发器 ...
    正在处理用于 bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) 的触发器 ...
    Rebuilding /usr/share/applications/bamf-2.index...
    正在处理用于 gnome-menus (3.13.3-6ubuntu3.1) 的触发器 ...
    正在处理用于 desktop-file-utils (0.22-1ubuntu5) 的触发器 ...
    正在处理用于 mime-support (3.59ubuntu1) 的触发器 ...
    正在处理用于 gconf2 (3.2.6-3ubuntu6) 的触发器 ...
    正在处理用于 libglib2.0-0:i386 (2.48.1-1~ubuntu16.04.1) 的触发器 ...
    覆盖文件 /usr/share/glib-2.0/schemas/50_sogoupinyin.gschema.override 中指定的方案 org.gnome.settings-daemon.plugins.xsettings 中没有键 Gtk/IMModule;忽略对此键的覆盖。
    正在处理用于 libglib2.0-0:amd64 (2.48.1-1~ubuntu16.04.1) 的触发器 ...
    覆盖文件 /usr/share/glib-2.0/schemas/50_sogoupinyin.gschema.override 中指定的方案 org.gnome.settings-daemon.plugins.xsettings 中没有键 Gtk/IMModule;忽略对此键的覆盖。
    relaybotbox@relaybotbox-desktop:~$ 
    


    relaybotbox@relaybotbox-desktop:~$ sudo dpkg -i ubuntu-tweak_0.8.7-1~getdeb2~xenial_all.deb
    [sudo] relaybotbox 的密码:
    正在选中未选择的软件包 ubuntu-tweak。
    (正在读取数据库 ... 系统当前共安装有 334292 个文件和目录。)
    正准备解包 ubuntu-tweak_0.8.7-1~getdeb2~xenial_all.deb  ...
    正在解包 ubuntu-tweak (0.8.7-1~getdeb2~xenial) ...
    dpkg: 依赖关系问题使得 ubuntu-tweak 的配置工作不能继续:
     ubuntu-tweak 依赖于 python-apt;然而:
      未安装软件包 python-apt。
     ubuntu-tweak 依赖于 python-aptdaemon;然而:
      未安装软件包 python-aptdaemon。
     ubuntu-tweak 依赖于 python-aptdaemon.gtk3widgets;然而:
      未安装软件包 python-aptdaemon.gtk3widgets。
     ubuntu-tweak 依赖于 python-defer;然而:
      未安装软件包 python-defer。
     ubuntu-tweak 依赖于 python-compizconfig;然而:
      未安装软件包 python-compizconfig。
     ubuntu-tweak 依赖于 gir1.2-gconf-2.0;然而:
      未安装软件包 gir1.2-gconf-2.0。
     ubuntu-tweak 依赖于 gir1.2-webkit-3.0;然而:
      未安装软件包 gir1.2-webkit-3.0。

    dpkg: 处理软件包 ubuntu-tweak (--install)时出错:
     依赖关系问题 - 仍未被配置
    正在处理用于 hicolor-icon-theme (0.15-0ubuntu1) 的触发器 ...
    正在处理用于 dbus (1.10.6-1ubuntu3.1) 的触发器 ...
    正在处理用于 bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) 的触发器 ...
    Rebuilding /usr/share/applications/bamf-2.index...
    正在处理用于 gnome-menus (3.13.3-6ubuntu3.1) 的触发器 ...
    正在处理用于 desktop-file-utils (0.22-1ubuntu5) 的触发器 ...
    正在处理用于 mime-support (3.59ubuntu1) 的触发器 ...
    正在处理用于 gconf2 (3.2.6-3ubuntu6) 的触发器 ...
    正在处理用于 libglib2.0-0:i386 (2.48.1-1~ubuntu16.04.1) 的触发器 ...
    覆盖文件 /usr/share/glib-2.0/schemas/50_sogoupinyin.gschema.override 中指定的方案 org.gnome.settings-daemon.plugins.xsettings 中没有键 Gtk/IMModule;忽略对此键的覆盖。
    正在处理用于 libglib2.0-0:amd64 (2.48.1-1~ubuntu16.04.1) 的触发器 ...
    覆盖文件 /usr/share/glib-2.0/schemas/50_sogoupinyin.gschema.override 中指定的方案 org.gnome.settings-daemon.plugins.xsettings 中没有键 Gtk/IMModule;忽略对此键的覆盖。
    在处理时有错误发生:
     ubuntu-tweak
    relaybotbox@relaybotbox-desktop:~$ sudo apt-get install -f
    正在读取软件包列表... 完成
    正在分析软件包的依赖关系树       
    正在读取状态信息... 完成       
    正在修复依赖关系... 完成
    将会同时安装下列软件:
      gir1.2-gconf-2.0 gir1.2-javascriptcoregtk-3.0 gir1.2-webkit-3.0
      libjavascriptcoregtk-3.0-0 libwebkitgtk-3.0-0 libwebkitgtk-3.0-common
      python-apt python-aptdaemon python-aptdaemon.gtk3widgets python-compizconfig
      python-debian python-defer
    建议安装:
      python-apt-dbg python-apt-doc
    下列【新】软件包将被安装:
      gir1.2-gconf-2.0 gir1.2-javascriptcoregtk-3.0 gir1.2-webkit-3.0
      libjavascriptcoregtk-3.0-0 libwebkitgtk-3.0-0 libwebkitgtk-3.0-common
      python-apt python-aptdaemon python-aptdaemon.gtk3widgets python-compizconfig
      python-debian python-defer
    升级了 0 个软件包,新安装了 12 个软件包,要卸载 0 个软件包,有 3 个软件包未被升级。
    有 1 个软件包没有被完全安装或卸载。
    需要下载 10.2 MB 的归档。
    解压缩后会消耗 45.1 MB 的额外空间。
    您希望继续执行吗? [Y/n] y
    获取:1 http://mirrors.aliyun.com/ubuntu xenial/main amd64 python-apt amd64 1.1.0~beta1build1 [139 kB]
    获取:2 http://mirrors.aliyun.com/ubuntu xenial/universe amd64 python-debian all 0.1.27ubuntu2 [64.2 kB]
    获取:3 http://mirrors.aliyun.com/ubuntu xenial/universe amd64 python-defer all 1.0.6-2build1 [10.7 kB]
    获取:4 http://mirrors.aliyun.com/ubuntu xenial/universe amd64 python-aptdaemon all 1.1.1+bzr982-0ubuntu14 [76.4 kB]
    获取:5 http://mirrors.aliyun.com/ubuntu xenial/universe amd64 python-aptdaemon.gtk3widgets all 1.1.1+bzr982-0ubuntu14 [13.8 kB]
    获取:6 http://mirrors.aliyun.com/ubuntu xenial-updates/universe amd64 python-compizconfig amd64 1:0.9.12.2+16.04.20160823-0ubuntu1 [38.2 kB]
    获取:7 http://mirrors.aliyun.com/ubuntu xenial/main amd64 gir1.2-gconf-2.0 amd64 3.2.6-3ubuntu6 [6,208 B]
    获取:8 http://mirrors.aliyun.com/ubuntu xenial-updates/universe amd64 gir1.2-javascriptcoregtk-3.0 amd64 2.4.11-0ubuntu0.1 [12.7 kB]
    获取:9 http://mirrors.aliyun.com/ubuntu xenial-updates/universe amd64 libjavascriptcoregtk-3.0-0 amd64 2.4.11-0ubuntu0.1 [1,852 kB]
    获取:10 http://mirrors.aliyun.com/ubuntu xenial-updates/universe amd64 libwebkitgtk-3.0-common all 2.4.11-0ubuntu0.1 [367 kB]
    获取:11 http://mirrors.aliyun.com/ubuntu xenial-updates/universe amd64 libwebkitgtk-3.0-0 amd64 2.4.11-0ubuntu0.1 [7,593 kB]
    获取:12 http://mirrors.aliyun.com/ubuntu xenial-updates/universe amd64 gir1.2-webkit-3.0 amd64 2.4.11-0ubuntu0.1 [60.7 kB]
    已下载 10.2 MB,耗时 10秒 (975 kB/s)                                           
    正在选中未选择的软件包 python-apt。
    (正在读取数据库 ... 系统当前共安装有 334565 个文件和目录。)
    正准备解包 .../python-apt_1.1.0~beta1build1_amd64.deb  ...
    正在解包 python-apt (1.1.0~beta1build1) ...
    正在选中未选择的软件包 python-debian。
    正准备解包 .../python-debian_0.1.27ubuntu2_all.deb  ...
    正在解包 python-debian (0.1.27ubuntu2) ...
    正在选中未选择的软件包 python-defer。
    正准备解包 .../python-defer_1.0.6-2build1_all.deb  ...
    正在解包 python-defer (1.0.6-2build1) ...
    正在选中未选择的软件包 python-aptdaemon。
    正准备解包 .../python-aptdaemon_1.1.1+bzr982-0ubuntu14_all.deb  ...
    正在解包 python-aptdaemon (1.1.1+bzr982-0ubuntu14) ...
    正在选中未选择的软件包 python-aptdaemon.gtk3widgets。
    正准备解包 .../python-aptdaemon.gtk3widgets_1.1.1+bzr982-0ubuntu14_all.deb  ...
    正在解包 python-aptdaemon.gtk3widgets (1.1.1+bzr982-0ubuntu14) ...
    正在选中未选择的软件包 python-compizconfig:amd64。
    正准备解包 .../python-compizconfig_1%3a0.9.12.2+16.04.20160823-0ubuntu1_amd64.deb  ...
    正在解包 python-compizconfig:amd64 (1:0.9.12.2+16.04.20160823-0ubuntu1) ...
    正在选中未选择的软件包 gir1.2-gconf-2.0。
    正准备解包 .../gir1.2-gconf-2.0_3.2.6-3ubuntu6_amd64.deb  ...
    正在解包 gir1.2-gconf-2.0 (3.2.6-3ubuntu6) ...
    正在选中未选择的软件包 gir1.2-javascriptcoregtk-3.0:amd64。
    正准备解包 .../gir1.2-javascriptcoregtk-3.0_2.4.11-0ubuntu0.1_amd64.deb  ...
    正在解包 gir1.2-javascriptcoregtk-3.0:amd64 (2.4.11-0ubuntu0.1) ...
    正在选中未选择的软件包 libjavascriptcoregtk-3.0-0:amd64。
    正准备解包 .../libjavascriptcoregtk-3.0-0_2.4.11-0ubuntu0.1_amd64.deb  ...
    正在解包 libjavascriptcoregtk-3.0-0:amd64 (2.4.11-0ubuntu0.1) ...
    正在选中未选择的软件包 libwebkitgtk-3.0-common。
    正准备解包 .../libwebkitgtk-3.0-common_2.4.11-0ubuntu0.1_all.deb  ...
    正在解包 libwebkitgtk-3.0-common (2.4.11-0ubuntu0.1) ...
    正在选中未选择的软件包 libwebkitgtk-3.0-0:amd64。
    正准备解包 .../libwebkitgtk-3.0-0_2.4.11-0ubuntu0.1_amd64.deb  ...
    正在解包 libwebkitgtk-3.0-0:amd64 (2.4.11-0ubuntu0.1) ...
    正在选中未选择的软件包 gir1.2-webkit-3.0:amd64。
    正准备解包 .../gir1.2-webkit-3.0_2.4.11-0ubuntu0.1_amd64.deb  ...
    正在解包 gir1.2-webkit-3.0:amd64 (2.4.11-0ubuntu0.1) ...
    正在处理用于 libc-bin (2.23-0ubuntu4) 的触发器 ...
    正在设置 python-apt (1.1.0~beta1build1) ...
    正在设置 python-debian (0.1.27ubuntu2) ...
    正在设置 python-defer (1.0.6-2build1) ...
    正在设置 python-aptdaemon (1.1.1+bzr982-0ubuntu14) ...
    正在设置 python-aptdaemon.gtk3widgets (1.1.1+bzr982-0ubuntu14) ...
    正在设置 python-compizconfig:amd64 (1:0.9.12.2+16.04.20160823-0ubuntu1) ...
    正在设置 gir1.2-gconf-2.0 (3.2.6-3ubuntu6) ...
    正在设置 gir1.2-javascriptcoregtk-3.0:amd64 (2.4.11-0ubuntu0.1) ...
    正在设置 libjavascriptcoregtk-3.0-0:amd64 (2.4.11-0ubuntu0.1) ...
    正在设置 libwebkitgtk-3.0-common (2.4.11-0ubuntu0.1) ...
    正在设置 libwebkitgtk-3.0-0:amd64 (2.4.11-0ubuntu0.1) ...
    正在设置 gir1.2-webkit-3.0:amd64 (2.4.11-0ubuntu0.1) ...
    正在设置 ubuntu-tweak (0.8.7-1~getdeb2~xenial) ...
    正在处理用于 libc-bin (2.23-0ubuntu4) 的触发器 ...
    正在处理用于 dbus (1.10.6-1ubuntu3.1) 的触发器 ...
    relaybotbox@relaybotbox-desktop:~$ sudo dpkg -i ubuntu-tweak_0.8.7-1~getdeb2~xenial_all.deb
    (正在读取数据库 ... 系统当前共安装有 334781 个文件和目录。)
    正准备解包 ubuntu-tweak_0.8.7-1~getdeb2~xenial_all.deb  ...
    正在将 ubuntu-tweak (0.8.7-1~getdeb2~xenial) 解包到 (0.8.7-1~getdeb2~xenial) 上 ...
    正在设置 ubuntu-tweak (0.8.7-1~getdeb2~xenial) ...
    正在处理用于 hicolor-icon-theme (0.15-0ubuntu1) 的触发器 ...
    正在处理用于 dbus (1.10.6-1ubuntu3.1) 的触发器 ...
    正在处理用于 bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) 的触发器 ...
    Rebuilding /usr/share/applications/bamf-2.index...
    正在处理用于 gnome-menus (3.13.3-6ubuntu3.1) 的触发器 ...
    正在处理用于 desktop-file-utils (0.22-1ubuntu5) 的触发器 ...
    正在处理用于 mime-support (3.59ubuntu1) 的触发器 ...
    正在处理用于 gconf2 (3.2.6-3ubuntu6) 的触发器 ...
    正在处理用于 libglib2.0-0:i386 (2.48.1-1~ubuntu16.04.1) 的触发器 ...
    覆盖文件 /usr/share/glib-2.0/schemas/50_sogoupinyin.gschema.override 中指定的方案 org.gnome.settings-daemon.plugins.xsettings 中没有键 Gtk/IMModule;忽略对此键的覆盖。
    正在处理用于 libglib2.0-0:amd64 (2.48.1-1~ubuntu16.04.1) 的触发器 ...
    覆盖文件 /usr/share/glib-2.0/schemas/50_sogoupinyin.gschema.override 中指定的方案 org.gnome.settings-daemon.plugins.xsettings 中没有键 Gtk/IMModule;忽略对此键的覆盖。
    relaybotbox@relaybotbox-desktop:~$



    展开全文
  • ubuntu使用启动盘创建器安装系统的一些心得1. 安装过程中,无法进入安装操作界面;2.安装过程不要连网,安装速度好快;更新软件源;3.更新软件源和软件4.还没有完,重启你会发现电脑卡死,解决方法,安装NVIDIA; 1....

    1. 安装过程中,无法进入安装操作界面;

    • 使用u盘安装时,在进入尝试使用系统、安装系统、…;这个界面时,选择Install ubunut, 按e,在quiet splash —后面,把—改为acpi=off ,然后就可以安装了
    quiet splash --- 改为 quiet splash acpi=off 
    

    特别注意上面的修改只是应用于安装Ubuntu16,别的版本容易会出现各种问题;

    重启卡住,无法进入系统(适用于ubuntu16、20)

    1、重启,跳出grub界面后选择ubuntu,然后按e
    在这里插入图片描述

    2、在splash后面加nouveau.modeset = 0
    ubuntu16.04安装完成后重启,登陆之后卡死,进不去系统_第1张图片
    3、按F10,输入登陆密码进入系统
    4、打开终端,输入如下命令:

    sudo update-grub
    sudo gedit /etc/default/grub
    

    5、找到GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"将其改为GRUB_CMDLINE_LINUX_DEFAULT=“quiet nouveau.modeset = 0”,保存并退出
    6、更新

    sudo update-grub
    

    7、重启电脑

    reboot
    

    2.安装过程不要连网,安装速度好快;更新软件源;

    sudo cp /etc/apt/sources.list /etc/apt/sources.list.bak
    sudo gedit /etc/apt/sources/list
    
    • 添加如下软件源,这里特别强调一点,不同的系统版本可能有不同的软件源,其次,不同的软件来源安装软件的速度也不同,也有可能会在更新时卡死,但是下面的清华软件源相当不错;可以放心更新:
    # deb cdrom:[Ubuntu 16.04 LTS _Xenial Xerus_ - Release amd64 (20160420.1)]/ xenial main restricted
    deb http://mirrors.tuna.tsinghua.edu.cn/ubuntu/ xenial main restricted
    deb http://mirrors.tuna.tsinghua.edu.cn/ubuntu/ xenial-updates main restricted
    deb http://mirrors.tuna.tsinghua.edu.cn/ubuntu/ xenial universe
    deb http://mirrors.tuna.tsinghua.edu.cn/ubuntu/ xenial-updates universe
    deb http://mirrors.tuna.tsinghua.edu.cn/ubuntu/ xenial multiverse
    deb http://mirrors.tuna.tsinghua.edu.cn/ubuntu/ xenial-updates multiverse
    deb http://mirrors.tuna.tsinghua.edu.cn/ubuntu/ xenial-backports main restricted universe multiverse
    deb http://mirrors.tuna.tsinghua.edu.cn/ubuntu/ xenial-security main restricted
    deb http://mirrors.tuna.tsinghua.edu.cn/ubuntu/ xenial-security universe
    deb http://mirrors.tuna.tsinghua.edu.cn/ubuntu/ xenial-security multiverse
    
    

    3.更新软件源和软件

    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get dist-upgrade
    
    • 执行上面命令时,会出现什么文件lock,直接删除就可;

    4.还没有完,重启你会发现电脑卡死,解决方法,安装NVIDIA;

    • 安装NVIDIA, 不同的软件源可能安装的NVIDIA,版本过高,从而导致重启后,无法进入图形界面;
    • 但是上面的软件源是适合Ubuntu16的;其他的系统类似:
    • 安装NVIDIA
    ubuntu-drivers devices
    sudo ubuntu-drivers autoinstall  #主要不要版本过高,要不会不适应的
    

    到此安装的基本工作就完成了,后续就是安心使用了;

    5.可选,系统升级

    • 注意系统升级时,千万不要打断,建立在上面正确的软件源才可以,为了流利进行;
    sudo  do-release-upgrade
    

    6.安装双系统

    如果识别u盘启动盘,但是无法从u盘启动盘启动;

    • 重启按F2进入bios界面, 在启动中找到CSM,然后开启CSM, 将其设置为Enable;

    双系统安装参考

    心得:先安装window再安装ubuntu,因为参考较多,反过来太容易出现问题了;
    1.ubuntu安装好后,可能会出现找不到ubuntu启动项,进入bios界面将boot中ubuntu启动设置为第一个就好了,第二个为window的启动;
    2.可能ubuntu下不能挂载D盘,进入window10下开放D盘权限;

    7.双系统删除Ubuntu

    删除 Windows 上的 Ubuntu 的步骤就是
    开机进入到 BIOS 中,将 Boot Option1 改成 Windows
    回到 Windows,进入到 磁盘管理,删除掉 Ubuntu 所在的硬盘分区
    将删除的分区合并回原来的分区

    展开全文
  • Ubuntu:成功解决ubuntu使用su切换root出现Authentication failure用户时认证失败 导读 最讨厌网上回答的啰嗦和不清晰!本人最讨厌啰嗦,直接上来,图文表达,简单明了,快速解决问题!最讨厌网上答案一大片的废话...

    Ubuntu:成功解决ubuntu使用su切换root出现Authentication failure用户时认证失败

    导读
    最讨厌网上回答的啰嗦和不清晰!本人最讨厌啰嗦,直接上来,图文表达,简单明了,快速解决问题!最讨厌网上答案一大片的废话和没有用的、弄不清楚解释,我,直接就是上解决的答案!是本博主的一贯风格!

     

     

    目录

    解决问题

    解决方法


     

     

     

     

    解决问题

    ubuntu使用su切换root出现Authentication failure用户时认证失败

     

     

    解决方法

    因为Ubuntu系统默认没有激活root用户,因此需手动激活,操作,然后再使用su命令才可以

     

     

    展开全文
  • ubuntu使用apt-get安装指定版本

    千次阅读 2018-08-22 10:09:41
    ubuntu使用apt-get安装指定版本 使用 sudo apt-get install wine 安装wine的时候出现了以下提示 虚拟软件包 wine 由下面的软件包提供: wine-stable 3.0-1ubuntu1 wine-development 3.6-1 请您明确地选择安装...
  • ubuntu使用xftp

    千次阅读 2014-02-26 23:10:52
    2.在 Ubuntu使用 apt-get install 命令来升级、安装应用程序,要求 Ubuntu 可以连接到 internet 上。所以,在安装 vsftpd 之前,请确认 Ubuntu 可以访问 internet。 在 Ubuntu 中新建终端,输入下面的命令...
  • ubuntu 使用anydesk

    千次阅读 2019-06-13 17:58:14
    进入anydesk官网下载最新版linux版本,链接https://anydesk.com/zhs 下载完成后使用 tar -zxvf 对压缩包解压缩。 进入压缩得到的文件夹,运行 sudo ./anydesk 即可运行anydesk。 ...
  • Ubuntu使用国内源出现Hash Sum mismatch错误
  • Ubuntu使用VSCode无法输入中文

    千次阅读 多人点赞 2020-04-15 08:34:16
    Ubuntu19.1的VSCode无法输入中文。 原因是, Ubuntu19.1向导安装的VSCode是snap的削减版本,不支持中文。 解决方式是: 卸载后重新安装官方版本。 具体方式 卸载snap版本: sudo snap remove code 安装官方版本...
  • Ubuntu使用MD5

    千次阅读 2019-03-21 14:51:54
    md5sum 文件名 示例:
  • ubuntu使用snap下载速度慢

    万次阅读 2019-06-13 16:44:15
    前往https://uappexplorer.com/snaps 搜索并下载snap包 下载后执行此命令安装 sudo snap install xxxxx.snap --dangerous 参考:https://kuricat.com/gist/snap-install-too-slow-zmbjy
  • ubuntu 使用 fdisk 磁盘分区

    万次阅读 2017-07-06 16:28:15
    主要是使用 fdisk 对空白磁盘进行分区划分,并使用 scp 命令上传数据。
  • 虚拟机中ubuntu使用共享文件夹

    千次阅读 2019-02-05 07:50:36
    1.在vmware中添加共享文件夹 2.在虚拟机中使用命令,sudo vmware-config-tools.pl -d,需要输入ubuntu管理员账号 3.在mnt/hgfs 路径下可以看到共享文件夹
  • ubuntu使用df指令查看磁盘使用情况

    千次阅读 2018-01-15 16:37:55
    系统版本:ubuntu 16.04 root@reacher:~/gethFile# df -h  Filesystem Size Used Avail Use% Mounted on udev 2.0G 0 2.0G 0% /dev tmpfs 396M 2.8M 393M 1% /run /dev/v
  • ubuntu使用KVM创建虚拟机

    千次阅读 2017-03-23 13:40:07
    ubuntu环境基于KVM创建和管理虚拟机 kvm, qemu, libvirt
  • Ubuntu 使用命令向QQ邮箱发送邮件

    万次阅读 2020-10-21 15:48:02
    1、安装heirloom-mailx sudo apt-get install heirloom-mailx 2. 修改/etc/s-nail.rc中来添加外部SMTP服务器如下: 这是个只读文件,先改权限: ...sudo chmod 777 /etc/s-nail.rc ...在文件最后加上:【把××××...
  • ubuntu使用手机的usb共享网络

    千次阅读 2020-05-08 20:19:55
    sudo dhclient usb0
  • 使用命令行安装谷歌浏览器稳定版 sudo wget http://www.linuxidc.com/files/repo/google-chrome.list -P /etc/apt/sources.list.d/ wget -q -O - https://dl.google.com/linux/linux_signing_key.pub | sudo apt-...
  • ubuntu使用命令行下载文件

    千次阅读 2016-11-23 13:24:05
    首先安装axel这个命令   sudo apt-get install axel 然后使用这个命令下载文件   例如:   axel http://soft.vpser.net/lnmp/lnmp0.8-full.tar.gz  就会自动下载文件了
  • Ubuntu使用apt-get下载速度慢的解决方法

    万次阅读 多人点赞 2018-08-21 23:08:03
    查看所用的源: $ sudo vim /etc/apt/sources.list   由于安装的Ubuntu Server 16.04.1 LTS是英文版的,软件源就默认都是 us....# deb cdrom:[Ubuntu-Server 16.04.1 LTS _Xenial Xerus_ - Release amd64 (...
  • Ubuntu 使用命令行清空回收站

    万次阅读 2018-01-07 21:38:02
    在清空回收站时经常无响应 , 所以使用命令行删除sudo rm -rf ~/.local/share/Trash/*
  • 1、安装Ubuntu之后第一个感觉就是默认的窗口太小了,需要变大点儿,呵呵~~。 设置如下: 桌面版右键打开terminal,使用命令 xrandr 查看可以使用的分辨率: 然后使用 xrandr -s 2560x1600 设置自己想选的分辨率...
  • ubuntu使用chkconfig命令来管理服务

    千次阅读 2017-03-02 14:36:45
    安装命令: sudo apt-get install chkconfig ...在ubuntu使用应该会出现这样的错误: /sbin/insserv: No such file or directory 解决办法:sudo ln -s /usr/lib/insserv/insserv /sbin/insserv
  • 使用vmware创建虚拟机ubuntu时,使用桥接模式后可以直接在在右上角设置网络,设置自己的IP地址与主机同一网段的IP即可,并且设置子网掩码,网关河DNS。但是当我们复制或是移动虚拟机到另外一台机器时会导致无法连接...
  • 楼主的是Ubuntu14.04版本,其它版本应该也适用,在使用apt-get update时出现以下错误: Err http://mirrors.aliyun.com trusty InRelease Err http://mirrors.aliyun.com trusty-updates InRelease Err ...
  • Ubuntu 使用 ./ 没有文件或目录

    千次阅读 2018-09-04 16:27:06
    ubuntu 64位下运行 ./xxx 会跳出来说没有这个文件或者目录,但是ls看又有这个文件,很是奇怪。其实原因很简单,是因为他没有32位的运行库 ia32-libs ,直接安装即可。 apt-get install ia32-libs 可能会出现...
  • ubuntu 使用filezilla 管理FTP

    千次阅读 2014-01-05 10:01:36
    FileZilla是一个免费而且开源的FTP客户端软件,共有两种版本:客户端版本、服务器版本。...本文介绍的是Ubuntu下FileZilla的安装。 FileZilla Client 非常好用,以下是安装步骤。 安装filezilla :su
  • 使用df命令就可以查到相应的目录或文件系统等挂载信息。df命令还可以展示其磁盘空间的使用情况。 查看所有的挂载信息及空间使用情况 ~$ df 显示某个文件目录(如根目录)的挂信息 ~$ df / 显示某个文件系统...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 614,114
精华内容 245,645
关键字:

ubuntu的使用