精华内容
下载资源
问答
  • 动态路由协议

    2018-10-15 17:22:41
    网络中常见的一种动态协议,对搭建华为试验环境的配置和理解,做的一些总结
  • 在CISCO仿真软件Packet tracer下进行基于动态协议RIP/OSPF的路由配置,增强学生对网络概念的理解。通过实验使大家掌握常见CISCO设备的操作方法,具备独立组建简单网络的能力。
  • 实验序号:06 实验项目名称:实验6 RIPv2动态路由协议 学 号 姓 名 班 级 实验地点 信息学院网络实验室 指导教师 一、实验目的 通过实验理解并掌握在路由器上配置RIP V2; 二、实验要求 通过实验理解并掌握在...
  •  根据是否在一个自治域内部使用,动态路由协议分为内部网关协议(IGP)和外部网关协议(EGP)。这里的自治域指一个具有统一管理机构、统一路由策略的网络。自治域内部采用的路由选择协议称为内部网关协议,常用的有...
  • 实验5 动态路由协议RIP与OSPF的配置 实验学时2 一实验目的 1熟悉CISCO IOS和CLI命令模式的使用 2了解和掌握路由器基本配置命令的使用 3掌握动态路由协议的配置 4掌握VLAN中路由器的设置 3.掌握RIP与OSPF路由协议及其...
  • 主要为大家介绍了动态路由协议的概念、分类、组成部分和优缺点,路由协议的主要好处,只要网络拓扑结构发生了变化,路由器就会相互交换路由信息,不仅能够自动获知新增加的网络,还可以在当前网络连接失败时找出备用...
  • 动态路由协议是一些动态生成(或学习到)路由信息的协议。在计算机网络互 联技术领域,我们可以把路由定义如下,路由是指导IP报文发送的一些路径信息。动态路由协议是网络设备如路由器(Router)学习网络中路由信息的...
  • 常用动态路由协议的算法分析与性能比较,王彦坤,宋茂强,动态路由能够随着网络运行情况和拓扑结构的变化而变化,路由器根据路由协议提供的功能自动计算数据传输的最佳路径,并由此动态
  •  根据是否在一个自治域内部使用,动态路由协议分为内部网关协议(IGP)和外部网关协议(EGP)。这里的自治域指一个具有统一管理机构、统一路由策略的网络。自治域内部采用的路由选择协议称为内部网关协议,常用的有...
  • 动态路由协议简单理解

    千次阅读 2020-06-19 17:41:04
    一、什么是路由?       在一个网络中,路由是一个非常基本的概念,当路由器(或者其他三层设备)收到一个IP数据包,路由器会...二、路由协议的分类      &nb

    一、什么是路由?

          在一个网络中,路由是一个非常基本的概念,当路由器(或者其他三层设备)收到一个IP数据包,路由器会找出报文中的IP头里的目的IP地址,然后拿着目的IP地址到自己的路由表中进行查找,找到“最匹配”的路由条目后,将数据包根据路由条目所指示的出接口或下一跳IP转发出去。随着网络路由的发展,路由的种类有很多,如静态路由、动态路由、缺省路由等。

    二、路由协议的分类

          动态路由是指路由器能够根据路由器之间的交换的特定路由信息自动地建立自己的路由表,并且能够根据链路和节点的变化适时地进行自动调整。而路由协议是用于路由器之间交换路由信息的协议,路由协议的分类大致如下图所示:
    在这里插入图片描述

    图1 路由协议的分类

    (1) 按用途分类
          动态路由协议按用途分类可以分为内部网关协议(Interior Gateway Protocol,简称IGP)和外部网关协议(Exterior Gateway Protocol,简称EGP)。一个Internet网可以被分成多个域或多个自治系统,各自治系统通过一个核心路由器连到主干网上,每个自治系统都有自己的路由技术,对不同的自治系统路由技术是不相同的。所谓内部网关协议,就是指用于自治系统内部的路由协议,而外部网关协议,就是指用于自治系统间接口上的单独的协议。

    (2) 按操作分类
          动态路由协议按操作分类可以分为距离矢量路由协议、链路状态路由协议或路径矢量路由协议。其中距离矢量路由协议和链路状态路由协议属于内部网关协议,而路径矢量路由协议则属于外部网关协议。

    (3) 按行为分类
          动态路由协议按行为分类可以分为有类路由协议和无类路由协议,他们二者本质区别就是在发送路由更新时是否发送子网掩码,有类路由协议不会在路由更新中发送子网掩码信息,而无类路由协议在路由更新中包含子网掩码信息。目前,仅RIPv1和IGRP是有类路由协议,所有其他IPv4和IPv6路由协议都是无类路由协议。

    三、路由协议的使用

          在学习的过程中,面对众多的动态路由协议,我开始思考,这么多的路由协议在不同的网络中应该如何选择呢?为了解决这个疑问,就需要对这些动态路由协议的特性和优缺点进行比较,并根据实际情况选择出一个最佳方案。

    (1) IGP和EGP
          首先,是内部网关协议和外部网关协议,对于这两个协议,根据它们各自的用途,很容易做出判断:在公司、组织、服务提供商各自的内部网络中使用IGP,而在服务提供商、公司和大型企业之间则使用EGP实现互联。目前,边界网关协议(BGP)是目前唯一可行的EGP,而对于IGP就有很多的选择如RIP、EIGRP、OSPF和IS-IS等。

    (2) 距离矢量路由协议和链路状态路由协议
          根据路由算法,动态路由协议可分为距离向量路由协议和链路状态路由协议。距离矢量路由协议基于Bellman-Ford算法,主要有RIP、IGRP;链路状态路由协议基于Dijkstra算法,即最短优先路径算法,如OSPF。在距离向量路由协议中,路由器将部分或全部的路由表传递给与其相邻的路由器;而在链路状态路由协议中,路由器将链路状态信息传递给在同一区域内的所有路由器。
    距离矢量路由协议通过向其邻居发送自己的路由表的方式来维护自己本身的路由信息,有跳数限制,适合运用于小型网络中。链路状态路由协议从网络或者网络的限定区域内的所有其他路由器处收集信息然后在不依赖其他路由器的情况下计算到达各个网络的路由,收敛速度快,适合在大型网络中运行。

    (3) RIPv2和EIGRP
          RIPv2和EIGRP均为距离矢量路由协议。RIP是路由器生产商之间使用的第一个开放标准,是最广泛的路由协议,在所有IP路由平台上都可以得到。RIP有两个版本:RIPv1和RIPv2,它们均基于经典的距离向量路由算法,最大跳数为15跳。RIP具有算法简单、可以与不同厂商的路由器互联的特点,但在路径较多时收敛速度慢,广播路由信息时占用的带宽资源较多,它适用于网络拓扑结构相对简单的小型网络中。
    IGRP为第一代思科专有协议,是一种动态的、长跨度的路由协议,最大跳数为255跳,与RIP相比,IGRP的收敛时间更长,但传输路由信息所需的带宽减少,适合较为复杂的网络。EIGRP为IGRP的增强版,它使用与IGRP相同的路由算法,但它集成了链路状态路由协议和距离向量路由协议的长处,同时加入扩散更新算法(DUAL)具有快速收敛、减少了带宽的消耗、减少路由器CPU的利用等特点。

    (4) OSPF和IS-IS
          OSPF和IS-IS是链路状态路由协议的两个最典型的代表,都采用STP算法来计算路由;开放式最短路径优先(OSPF)协议是一种为IP网络开发的内部网关路由选择协议,它能够在自己的链路状态数据库内表示整个网络,这极大地减少了收敛时间,并且支持大型异构网络的互联,具有快速收敛、区域划分、无跳数限制、安全性好等优点。中间系统到中间系统(IS-IS)是由国际标准化组织制定最初是为OSI协议簇设计的,后来添加了对IP网络的支持。ISIS和OSPF从基本功能与操作上都非常相似,但也存在着差异,如封装位置、划分边界、支持路由等。

    四、总结

          以上对各类路由协议的描述,对于在不同的网络中选择何种路由协议这个问题可以得出初步的结论:在公司、组织各自的内部网络中使用IGP,而在服务提供商、公司和大型企业之间使用EGP实现互联。在IGP的配置中,如果网络规模较小,路由器的数量小于或等于15个,则可以考虑使用RIP或IGRP。对于小规模的网络,可以使用RIPv2协议;而对于中型的网络,使用EIGRP协议则更为合适;如果是大型网络,则需要考虑使用OSPF协议。

    展开全文
  • 动态路由协议的归纳总结

    千次阅读 2021-07-20 08:57:10
    文章目录引言一、动态路由协议的分类二、动态路由协议的优缺点三、RIP路由协议1.工作原理2.RIP的防环机制3.RIPv1和RIPv2的区别4.RIP的配置四、OSPF路由协议ospf的概念ospf工作过程Router IDospf包类型ospf路由器类型...


    引言

    在工作中,面对众多的动态路由协议,我开始思考,这么多的路由协议在不同的网络中应该如何选择呢?为了解决这个疑问,就需要对这些动态路由协议的特性和优缺点进行比较,并根据实际情况选择出一个最佳方案。

    一、动态路由协议的分类

    动态路由是指路由器能够根据路由器之间的交换的特定路由信息自动地建立自己的路由表,并且能够根据链路和节点的变化适时地进行自动调整。而路由协议是用于路由器之间交换路由信息的协议,路由协议的分类大致如下图所示:
    在这里插入图片描述
    1.按工作区域分类
    动态路由协议按用途分类可以分为内部网关协议(IGP)和外部网关协议(EGP)。一个Internet网可以被分成多个域或多个自治系统,各自治系统通过一个核心路由器连到主干网上,每个自治系统都有自己的路由技术,对不同的自治系统路由技术是不相同的。所谓内部网关协议,就是指用于自治系统内部的路由协议,而外部网关协议,就是指用于自治系统间接口上的单独的协议。
    2.按寻径算法分类
    动态路由协议按操作可以分为距离矢量路由协议、链路状态路由协议或路径矢量路由协议。其中距离矢量路由协议和链路状态路由协议属于内部网关协议,而路径矢量路由协议则属于外部网关协议。
    3.按行为分类
    动态路由协议按行为分类可以分为有类路由协议和无类路由协议。他们二者本质区别就是在发送路由更新时是否发送子网掩码,有类路由协议不会在路由更新中发送子网掩码信息,而无类路由协议在路由更新中包含子网掩码信息。

    二、动态路由协议的优缺点

    • 可以自动适应网络状态的变化
    • 自动维护路由信息而不需要网络管理员的参与
    • 由于需要相互交换路由信息,因而占用网络带宽与系统资源
    • 安全性不如静态路由

    三、RIP路由协议

    1.工作原理

    在路由器上开启RIP协议,并将路由器的直连网段宣告进RIP后,RIP会将这些直连网段信息封装成RIP协议报文,路由器每30秒会向邻居发送自己的路由表。路由器用邻居发来的路由表根据距离向量算法修改自己的路由表。这样邻居路由器间就可以相互学习对方的网段信息,实现网络互通。

    2.RIP的防环机制

    • RIP的度量值为跳数,最大跳数为15跳,如果一条RIP路由的跳数到达16,路由器则认为该路由不可达。
    • 因为RIP基于UDP(端口号520)发送协议报文,而UDP没有确认机制,所以路由将路由发送出去以后无法确认另据是否收到RIP路由,为了保障路由的可靠更新,所以需要周期发送RIP路由(30s)。
    • 水平分割技术:从一个接口学来的路由不会从该接口发回去,减少路由更行信息占用链路带宽资源。

    3.RIPv1和RIPv2的区别

    RIPv1RIPv2
    有类路由协议无类路由协议
    自动路由汇总,不可关闭自动汇总可关闭,可手动汇总
    广播更新(255.255.255.255)组播更新(224.0.0.9)
    不支持不连续子网支持不连续子网
    不支持VLSM(可变长子网掩码)支持VLSM

    4.RIP的配置

    拓扑图
    在这里插入图片描述

    AR1配置:

    <Huawei>undo terminal monitor 
    <Huawei>system-view 
    [Huawei]user-interface console 0
    [Huawei-ui-console0]idle-timeout 0 0
    [Huawei-ui-console0]sysname R1
    [R1]int g0/0/0
    [R1-GigabitEthernet0/0/0]undo shutdown
    [R1-GigabitEthernet0/0/0]ip address 10.1.1.1 24
    [R1-GigabitEthernet0/0/0]q
    [R1]int loop 0
    [R1-LoopBack0]ip add 10.2.1.8 32
    [R1-LoopBack0]q
    [R1]rip
    [R1-rip-1]version 1
    [R1-rip-1]network 10.0.0.0
    

    AR2配置

    <Huawei>undo terminal monitor 
    <Huawei>system-view 
    [Huawei]user-interface console 0
    [Huawei-ui-console0]idle-timeout 0 0
    [Huawei-ui-console0]sysname R2
    [R2]int g0/0/0
    [R2-GigabitEthernet0/0/0]undo shutdown 
    [R2-GigabitEthernet0/0/0]ip address 10.1.1.2 24
    [R2-GigabitEthernet0/0/0]int g0/0/1
    [R2-GigabitEthernet0/0/1]undo shutdown 
    [R2-GigabitEthernet0/0/1]ip address 172.16.1.2 24
    [R2-GigabitEthernet0/0/1]q
    [R2]rip
    [R2-rip-1]network 10.0.0.0
    [R2-rip-1]network 172.16.0.0
    

    AR3配置

    <Huawei>undo terminal monitor 
    <Huawei>system-view 
    [Huawei]user-interface console 0
    [Huawei-ui-console0]idle-timeout 0 0
    [Huawei-ui-console0]sysname R3
    [R3]int g0/0/0
    [R3-GigabitEthernet0/0/0]undo shutdown 
    [R3-GigabitEthernet0/0/0]ip address 172.16.1.3 24
    [R3-GigabitEthernet0/0/0]q
    [R3]int loop 0
    [R3-LoopBack0]ip address 10.2.3.10 32
    [R3-LoopBack0]q
    [R3]rip
    [R3-rip-1]network 172.16.0.0
    [R3-rip-1]network 10.0.0.0
    

    测试:
    测试直连网段的联通性,如下:
    在这里插入图片描述
    查看路由表,如下:
    在这里插入图片描述

    在这里插入图片描述
    综上可得配置成功


    四、OSPF路由协议

    ospf的概念

    • OSPF路由协议是用于网际协议(IP)网络的链路状态路由协议。该协议使用链路状态路由算法的内部网关协议(IGP),直接运行于IP协议之上,协议号为89。
    • DRother组播地址是224.0.0.5,DR/BDR的组播地址是224.0.0.6

    ospf工作过程

    1、初始化形成端口初始信息:在路由器初始化或网络结构发生变化(如链路发生变化,路由器新增或损坏)时,相关路由器会产生链路状态广播数据包LSA,该数据包里包含路由器上所有相连链路,也即为所有端口的状态信息。
    2、路由器间通过泛洪机制交换链路状态信息:各路由器一方面将其LSA数据包传送给所有与其相邻的OSPF路由器,另一方面接收其相邻的OSPF路由器传来的LSA数据包,根据其更新自己的数据库。
    3、形成稳定的区域拓扑结构数据库:OSPF路由协议通过泛洪法逐渐收敛,形成该区域拓扑结构的数据库,这时所有的路由器均保留了该数据库的一个副本。
    4、形成路由表:所有的路由器根据其区域拓扑结构数据库副本采用最短路径法计算形成各自的路由表。

    Router ID

    router-id是ospf区域内唯一标识路由器的IP地址
    选取规则
    a.手工进程下配置了router-id的最优
    b.全局下配置了router-id
    c.如果有多个环回口,选取地址最大的一个;如果只有一个,选举唯一的环回口的地址为router-id
    d.如果没有配置环回口,选举活动物理地址最大的一个

    ospf包类型

    OSPF协议依靠五种不同类型的包来建立邻接关系和交换路由信息

    • Hello包:
      用于发现和维持邻居关系。
    • 数据库描述包(DBD)
      用于向邻居发送摘要信息以同步链路状态数据库,选举DB和BDR。
    • 链路状态请求包(LSR)
      在路由器收到包含新信息的DBD后发送,用于请求更详细的信息。
    • 链路状态更新包(LSU)
      收到LSR后发送链路状态通告(LSA),一个Lsu数据包可能包含几个LSA。
    • 链路状态确认包(LSAck)
      确认已经支到Lsu,每个LSA需要被分别确认。

    ospf路由器类型

    ospf路由器类型:
    IR:内部路由器 所有连接得网段都在一个区域的路由器,属于同一个区域的IR维护相同的LSDB(链路状态数据库)
    ABR:区域边界路由器 连接到多个区域得路由器,ABR为每一个所连接的区域维护一个LSDB
    BR:骨干路由器 指至少有一个端口连接到骨干区域的路由器,包括所有的ABR和所有端口都在骨干区域的路由器
    ASBR:AS边界路由器 和其他AS中的路由器交换路由信息的路由器,这种路由器向整个AS通告AS外部路由信息。AS边界路由器可以是内部路由器IR,或者ABR,可以属于骨干区域也可以不属于骨干区域。

    ospf网络类型

    • 点到点网络
    • 广播多路访问网络
    • 非广播多路访问广播
    • 点到多点网络

    ospf区域类型

    • 生成多区域的原因:改善网络的可扩展性,收敛速度快

    • 同一个网段必须划分进一个区域,如果ospf只能存在一个区域,并且要保持网络的通信,那么这个区域必须为区域0

    • 骨干区域 Area 0

    • 非骨干区域
      -标准区域
      -末梢区域
      -完全末梢区域
      -非纯末梢区域

    • 末梢-------------阻止4.5类LSA传递进stub区域,会由ABR生成一条默认路由3类给stub区域

    • 完全末梢-------阻止3.4.5类LSA传递进stub区域,会由ABR生成一条默认路由3类给stub区域

    • 次末节----------阻止4.5类LSA传递进ospf,将5类LSA转变为7类LSA,由ABR将7类LSA再转变为5类LSA

    • 完全次末节----阻止3.4.5LSA传递进OSPF,会由ABR下发一条默认路由指向nssa区域

    ospf的基本特点

    1. 支持无类域间路由
    2. 支持区域划分
    3. 无路由自环
    4. 支持可变长子网掩码VLSM
    5. 路由变化收敛速度快
    6. 使用IP组播收发协议数据
    7. 支持多条等值路由
    8. 支持协议报文的认证

    ospf建立邻居关系的条件

    1. ROUTER-ID不能相同
    2. HELLO时间和DEAD时间必须一致
    3. 区域ID必须相同
    4. 认证类型和密钥必须相同
    5. STUB标志位必须相同
    6. 三层MTU不一致,无法建立邻接关系
    7. 当OSPF网络类型是MA时,要求掩码一定一致

    邻居状态机

    1.Down:邻居状态机的初始状态,是指在过去的Dead-Intenal时间内没有收到对方的Hello报文或OSPP没启动时
    2.Init: 本状态表示已经收到了邻居的Hello报文,但是该报文中列出的邻居中没有包含我的Router ID(对方并没有收到我发的Hello报文)
    3. 2-way: 本状态表示双方互相收到了对端发送的Helo报文,建立了邻居关系。在广播和BNA类型的网络中,两个接状态是DRother的
    路由器之间将停留在此状态。其他情况状态机将继续转入高级状态
    4.Exstart: 在此状态下,路由器和它的邻居之间通过互相交换DD报文来决定发送时的主/从关系,建立主/从关系主要是为了保证在后续的DD报文
    交换中能够有序的发送。
    5.exchange: 路由器将本地的LSDB用DD报文来描述,关发给邻居
    6.Loading:路由器发送LSR报文向邻居请求对方的DD报文。
    7.Full: 在此状态下,邻居路由器的LSDB中所有的LSA本路由器全都有了,即,本路由器和邻居建立了邻接状态。

    OSPF与RIP区别

    OSPFRIPv1RIPv2
    协议类型链路状态距离矢量距离矢量
    CIDR支持支持不支持
    VLSM支持支持不支持
    自动聚合不支持支持支持
    手动聚合支持支持不支持
    路由泛洪组播更新周期组播更新周期广播
    路径开销带宽跳数跳数
    路由收敛
    跳数限制1515
    邻居认证支持支持不支持
    分级网络支持(区域)不支持不支持
    更新事件触发更新路由表更新路由表更新
    路由计算DijkstraBellman-FordBellman-Ford

    五、OSPF的配置

    单区域

    拓扑图如下:
    在这里插入图片描述
    AR1配置:

    [R1]int g0/0/0
    [R1-GigabitEthernet0/0/0]ip add 10.1.1.1 24	
    [R1-GigabitEthernet0/0/0]undo shutdown 
    [R1]int LoopBack 0
    [R1-LoopBack0]ip address 192.168.1.1 32
    [R1-LoopBack0]q
    [R1]ospf 1 router-id 1.1.1.1 
    [R1-ospf-1]area 0
    [R1-ospf-1-area-0.0.0.0]network 192.168.1.1 0.0.0.0
    [R1-ospf-1-area-0.0.0.0]network 10.1.1.0 0.0.0.255
    

    AR2配置:

    [R2]int g0/0/0	
    [R2-GigabitEthernet0/0/0]ip address 10.1.1.2 24
    [R2-GigabitEthernet0/0/0]undo shutdown 
    [R2-GigabitEthernet0/0/0]int g0/0/1
    [R2-GigabitEthernet0/0/1]ip address 10.1.2.2 24
    [R2-GigabitEthernet0/0/1]undo shutdown 
    [R2-GigabitEthernet0/0/1]q
    [R2]q
    <R2>system-view 
    [R2]router id 2.2.2.2
    [R2]ospf 1
    [R2-ospf-1]area 0
    [R2-ospf-1-area-0.0.0.0]network 10.1.1.0 0.0.0.255
    [R2-ospf-1-area-0.0.0.0]network 10.1.2.0 0.0.0.255
    [R2-ospf-1-area-0.0.0.0]q
    [R2-ospf-1]display ospf peer
    

    AR3配置:

    [R3]int g0/0/0	
    [R3-GigabitEthernet0/0/0]ip address 10.1.2.3 24
    [R3-GigabitEthernet0/0/0]undo shutdown 
    [R3-GigabitEthernet0/0/0]q	
    [R3]int LoopBack 0	
    [R3-LoopBack0]ip address 172.16.1.1 32
    [R3-LoopBack0]ospf 1	
    [R3-ospf-1]area 0
    [R3-ospf-1-area-0.0.0.0]network 10.1.2.0 0.0.0.255
    [R3-ospf-1-area-0.0.0.0]network 170.16.1.1 0.0.0.0
    [R3-ospf-1-area-0.0.0.0]q	
    

    测试:
    在这里插入图片描述

    在这里插入图片描述

    在这里插入图片描述
    网络联通性测试成功,邻居建立成功。

    多区域

    要求:全网互通
    拓扑图

    在这里插入图片描述
    R1配置

    [R1]int LoopBack 0
    [R1-LoopBack0]ip address 1.1.1.1 32
    [R1-LoopBack0]int g0/0/0
    [R1-GigabitEthernet0/0/0]ip address 10.1.1.1 24
    [R1-GigabitEthernet0/0/0]undo shutdown 
    [R1-GigabitEthernet0/0/0]q	
    [R1]ospf 1 router-id 1.1.1.1	
    [R1-ospf-1]area 1
    [R1-ospf-1-area-0.0.0.1]network 10.1.1.0 0.0.0.255
    [R1-ospf-1-area-0.0.0.1]network 1.1.1.1 0.0.0.0
    

    R2配置

    [R2]int g0/0/0
    [R2-GigabitEthernet0/0/0]undo shutdown 
    [R2-GigabitEthernet0/0/0]int g0/0/1	
    [R2-GigabitEthernet0/0/1]ip address 10.1.2.2 24
    [R2-GigabitEthernet0/0/1]undo shutdown 
    [R2-GigabitEthernet0/0/1]int loop 0
    [R2-LoopBack0]ip address 2.2.2.2 32
    [R2-LoopBack0]q
    [R2]ospf 1 router-id 2.2.2.2
    [R2-ospf-1]area 1
    [R2-ospf-1-area-0.0.0.1]network 2.2.2.2 0.0.0.0
    [R2-ospf-1-area-0.0.0.1]network 10.1.1.0 0.0.0.255
    [R2-ospf-1-area-0.0.0.1]q
    [R2-ospf-1]area 0
    [R2-ospf-1-area-0.0.0.0]network 10.1.2.0 0.0.0.255
    [R2-ospf-1-area-0.0.0.0]q
    

    R3配置

    [R3]int g0/0/0	
    [R3-GigabitEthernet0/0/0]ip address 10.1.2.3 24	
    [R3-GigabitEthernet0/0/0]undo shutdown 
    [R3-GigabitEthernet0/0/0]int g0/0/1	
    [R3-GigabitEthernet0/0/1]ip address 10.1.3.3 24
    [R3-GigabitEthernet0/0/1]undo shutdown 
    [R3-GigabitEthernet0/0/1]int loop 0	
    [R3-LoopBack0]ip address 3.3.3.3 32
    [R3-LoopBack0]q
    [R3]router id 3.3.3.3
    [R3]ospf 1
    [R3-ospf-1]area 0
    [R3-ospf-1-area-0.0.0.0]network 10.1.2.0 0.0.0.255
    [R3-ospf-1-area-0.0.0.0]area 2
    [R3-ospf-1-area-0.0.0.2]network 3.3.3.3 0.0.0.0
    [R3-ospf-1-area-0.0.0.2]network 10.1.3.0 0.0.0.255
    [R3-ospf-1-area-0.0.0.2]q
    

    R4配置

    [R4]int g0/0/0	
    [R4-GigabitEthernet0/0/0]ip address 10.1.3.4 24
    [R4-GigabitEthernet0/0/0]undo shutdown 	
    [R4-GigabitEthernet0/0/0]int loop 0	
    [R4-LoopBack0]ip address 4.4.4.4 32
    [R4-LoopBack0]q
    [R4]router id 4.4.4.4
    [R4]ospf 1
    [R4-ospf-1]area 2
    [R4-ospf-1-area-0.0.0.2]network 10.1.3.0 0.0.0.255
    [R4-ospf-1-area-0.0.0.2]network 4.4.4.4 0.0.0.0
    [R4-ospf-1-area-0.0.0.2]q
    [R4-ospf-1]display ospf peer 
    

    最后测试网络联通性,全网互通。

    六、OSPF虚链路

    1.概念

    指一条通过一个非骨干区域连接到骨干区域的链路,它属于区域0

    2.使用场合

    一个非骨干区域跨越一个非骨干区域区域时用

    3.作用

    帮助这个非骨干区域获得完整的LSDB

    4.配置

    注意:虚链路必须配置在两台ABR路由器之间

    拓扑图如下:
    在这里插入图片描述
    要求:全网互通

    AR1配置:

    [R1]int loop 0
    [R1-LoopBack0]ip add 1.1.1.1 32
    [R1-LoopBack0]int g0/0/0
    [R1-GigabitEthernet0/0/0]ip add 12.1.1.1 24
    [R1-GigabitEthernet0/0/0]undo sh
    [R1-GigabitEthernet0/0/0]q
    [R1]ospf 1 router-id 1.1.1.1
    [R1-ospf-1]area 1
    [R1-ospf-1-area-0.0.0.1]network 1.1.1.1 0.0.0.0
    [R1-ospf-1-area-0.0.0.1]network 12.1.1.0 0.0.0.255
    

    AR2配置:

    [R2]int g0/0/0
    [R2-GigabitEthernet0/0/0]ip add 12.1.1.2 24
    [R2-GigabitEthernet0/0/0]undo sh
    [R2-GigabitEthernet0/0/0]int g0/0/1
    [R2-GigabitEthernet0/0/1]ip add 23.1.1.2 24
    [R2-GigabitEthernet0/0/1]undo sh
    [R2-GigabitEthernet0/0/1]int loop 0
    [R2-LoopBack0]ip add 2.2.2.2 32
    [R2-LoopBack0]q
    [R2]ospf 1 router-id 2.2.2.2
    [R2-ospf-1]area 1
    [R2-ospf-1-area-0.0.0.1]network 12.1.1.0 0.0.0.255
    [R2-ospf-1-area-0.0.0.1]area 0
    [R2-ospf-1-area-0.0.0.0]network 2.2.2.2 0.0.0.0
    [R2-ospf-1-area-0.0.0.0]network 23.1.1.0 0.0.0.255
    

    AR3配置:

    [R3]int g0/0/0
    [R3-GigabitEthernet0/0/0]ip add 23.1.1.3 24
    [R3-GigabitEthernet0/0/0]undo sh
    [R3-GigabitEthernet0/0/0]int g0/0/1
    [R3-GigabitEthernet0/0/1]ip add 34.1.1.3 24
    [R3-GigabitEthernet0/0/1]undo sh
    [R3-GigabitEthernet0/0/1]int loop 0
    [R3-LoopBack0]ip add 3.3.3.3 32
    [R3-LoopBack0]q
    [R3]ospf 1 router-id 3.3.3.3
    [R3-ospf-1]area 0
    [R3-ospf-1-area-0.0.0.0]network 3.3.3.3 0.0.0.0
    [R3-ospf-1-area-0.0.0.0]network 23.1.1.0 0.0.0.255
    [R3-ospf-1-area-0.0.0.0]q
    [R3-ospf-1]area 2
    [R3-ospf-1-area-0.0.0.2]network 34.1.1.0 0.0.0.255
    [R3-ospf-1-area-0.0.0.2]q
    [R3-ospf-1]q
    [R3]ospf 1
    [R3-ospf-1]area 2
    [R3-ospf-1-area-0.0.0.2]vlink-peer 4.4.4.4
    

    AR4配置:

    [R4]int g0/0/0
    [R4-GigabitEthernet0/0/0]ip add 34.1.1.4 24
    [R4-GigabitEthernet0/0/0]undo sh
    [R4-GigabitEthernet0/0/0]int g0/0/1
    [R4-GigabitEthernet0/0/1]ip add 45.1.1.4 24
    [R4-GigabitEthernet0/0/1]undo sh
    [R4-GigabitEthernet0/0/1]int loop 0
    [R4-LoopBack0]ip add 4.4.4.4 32
    [R4-LoopBack0]q
    [R4]ospf 1 router-id 4.4.4.4
    [R4-ospf-1]area 2
    [R4-ospf-1-area-0.0.0.2]network 4.4.4.4 0.0.0.0
    [R4-ospf-1-area-0.0.0.2]network 34.1.1.0 0.0.0.255
    [R4-ospf-1-area-0.0.0.2]q
    [R4-ospf-1]area 3
    [R4-ospf-1-area-0.0.0.3]network 45.1.1.0 0.0.0.255
    [R4-ospf-1-area-0.0.0.3]q
    [R4-ospf-1]q
    [R4]ospf 1
    [R4-ospf-1]area 2
    [R4-ospf-1-area-0.0.0.2]vlink-peer 3.3.3.3
    

    AR5配置:

    [R5]int g0/0/0
    [R5-GigabitEthernet0/0/0]ip add 45.1.1.5 24
    [R5-GigabitEthernet0/0/0]undo sh
    [R5-GigabitEthernet0/0/0]int loop 0
    [R5-LoopBack0]ip add 5.5.5.5 32
    [R5-LoopBack0]q
    [R5]ospf 1 router-id 5.5.5.5
    [R5-ospf-1]area 3
    [R5-ospf-1-area-0.0.0.3]network 45.1.1.0 0.0.0.255
    [R5-ospf-1-area-0.0.0.3]network 5.5.5.5 0.0.0.0
    

    配置完毕查看路由表及网络的联通性,如下:
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    在这里插入图片描述
    成功实现全网互通


    七、RIP和OSPF重分发

    1.含义

    在大型的企业中,可能在同一网内使用到多种路由协议,为了实现多种路由协议的协同工作,路由器可以使用路由重分发将其学习到的一种路由协议的路由通过另一种路由协议广播出去,这样网络的所有部分都可以连通了。 为了实现重分发,路由器必须同时运行多种路由协议,这样,每种路由协议才可以取路由表中的所有或部分其他协议的路由来进行广播。

    2.配置

    要求:实现全网互通

    拓扑图
    在这里插入图片描述

    AR1配置

    [R1]int g0/0/0	
    [R1-GigabitEthernet0/0/0]ip address 12.1.1.1 24
    [R1-GigabitEthernet0/0/0]undo shutdown 
    [R1-GigabitEthernet0/0/0]int loop 0
    [R1-LoopBack0]ip add	
    [R1-LoopBack0]ip address 1.1.1.1 32
    [R1-LoopBack0]q	
    [R1]ospf 1 router-id 1.1.1.1
    [R1-ospf-1]area 1
    [R1-ospf-1-area-0.0.0.1]network 1.1.1.1 0.0.0.0
    [R1-ospf-1-area-0.0.0.1]network 12.1.1.0 0.0.0.255
    [R1-ospf-1-area-0.0.0.1]q
    [R1-ospf-1]q
    [R1]ospf 1
    [R1-ospf-1]area 1
    [R1-ospf-1-area-0.0.0.1]stub 
    [R1-ospf-1-area-0.0.0.1]q
    [R1-ospf-1]q
    [R1]ping -a 1.1.1.1 6.6.6.6
      PING 6.6.6.6: 56  data bytes, press CTRL_C to break
        Reply from 6.6.6.6: bytes=56 Sequence=1 ttl=251 time=30 ms
        Reply from 6.6.6.6: bytes=56 Sequence=2 ttl=251 time=50 ms
        Reply from 6.6.6.6: bytes=56 Sequence=3 ttl=251 time=30 ms
        Reply from 6.6.6.6: bytes=56 Sequence=4 ttl=251 time=30 ms
        Reply from 6.6.6.6: bytes=56 Sequence=5 ttl=251 time=30 ms
    

    AR2配置

    [R2]int g0/0/0
    [R2-GigabitEthernet0/0/0]ip address 12.1.1.2 24
    [R2-GigabitEthernet0/0/0]undo sh
    Info: Interface GigabitEthernet0/0/0 is not shutdown.
    [R2-GigabitEthernet0/0/0]int g0/0/1
    [R2-GigabitEthernet0/0/1]ip address 23.1.1.2 24
    [R2-GigabitEthernet0/0/1]undo sh
    Info: Interface GigabitEthernet0/0/1 is not shutdown.
    [R2-GigabitEthernet0/0/1]int loop 0
    [R2-LoopBack0]ip address 2.2.2.2 32
    [R2-LoopBack0]ping 12.1.1.1
      PING 12.1.1.1: 56  data bytes, press CTRL_C to break
        Reply from 12.1.1.1: bytes=56 Sequence=1 ttl=255 time=60 ms
        Reply from 12.1.1.1: bytes=56 Sequence=2 ttl=255 time=30 ms
        Reply from 12.1.1.1: bytes=56 Sequence=3 ttl=255 time=10 ms
        Reply from 12.1.1.1: bytes=56 Sequence=4 ttl=255 time=20 ms
        Reply from 12.1.1.1: bytes=56 Sequence=5 ttl=255 time=10 ms
    
     position.
    [R2-LoopBack0]ping 23.1.1.3
      PING 23.1.1.3: 56  data bytes, press CTRL_C to break
        Reply from 23.1.1.3: bytes=56 Sequence=1 ttl=255 time=50 ms
        Reply from 23.1.1.3: bytes=56 Sequence=2 ttl=255 time=20 ms
        Reply from 23.1.1.3: bytes=56 Sequence=3 ttl=255 time=20 ms
        Reply from 23.1.1.3: bytes=56 Sequence=4 ttl=255 time=10 ms
        Reply from 23.1.1.3: bytes=56 Sequence=5 ttl=255 time=30 ms
    

    AR3配置

    [R3]int g0/0/0
    [R3-GigabitEthernet0/0/0]ip add 23.1.1.3 24
    [R3-GigabitEthernet0/0/0]undo sh
    [R3-GigabitEthernet0/0/0]int g0/0/1
    [R3-GigabitEthernet0/0/1]ip add 34.1.1.3 24
    [R3-GigabitEthernet0/0/1]undo sh
    [R3-GigabitEthernet0/0/1]int loop 0
    [R3-LoopBack0]ip add 3.3.3.3 32	
    [R3]ospf router-id 3.3.3.3
    
    [R3-ospf-1]area 0
    [R3-ospf-1-area-0.0.0.0]network 23.1.1.0 0.0.0.255
    [R3-ospf-1-area-0.0.0.0]network 3.3.3.3 0.0.0.0
    [R3-ospf-1-area-0.0.0.0]q
    [R3-ospf-1]area 2
    [R3-ospf-1-area-0.0.0.2]network 34.1.1.0 0.0.0.255
    [R3-ospf-1-area-0.0.0.2]q
    [R3-ospf-1]area 2
    [R3-ospf-1-area-0.0.0.2]vlink-peer 4.4.4.4
    

    AR4配置

    [R4]int g0/0/0
    [R4-GigabitEthernet0/0/0]ip add 34.1.1.4 24
    [R4-GigabitEthernet0/0/0]undo sh
    [R4-GigabitEthernet0/0/0]int g0/0/1
    [R4-GigabitEthernet0/0/1]ip add 45.1.1.4 24
    [R4-GigabitEthernet0/0/1]undo sh
    [R4-GigabitEthernet0/0/1]int loop 0
    [R4-LoopBack0]ip add 4.4.4.4 32
    [R4-LoopBack0]q	
    [R4]ospf 1 router-id 4.4.4.4
    [R4-ospf-1]area 2
    [R4-ospf-1-area-0.0.0.2]network 34.1.1.0 0.0.0.255
    [R4-ospf-1-area-0.0.0.2]network 4.4.4.4 0.0.0.0
    [R4-ospf-1-area-0.0.0.2]q
    [R4-ospf-1]area 3
    [R4-ospf-1-area-0.0.0.3]network 45.1.1.0 0.0.0.255
    [R4-ospf-1-area-0.0.0.3]q
    [R4-ospf-1]area 2
    [R4-ospf-1-area-0.0.0.2]vlink-peer 3.3.3.3
    [R4-ospf-1-area-0.0.0.2]q
    [R4-ospf-1]q
    [R4]ospf 1
    [R4-ospf-1]area 3
    [R4-ospf-1-area-0.0.0.3]nssa
    [R4-ospf-1-area-0.0.0.3]q
    [R4-ospf-1]area 3
    [R4-ospf-1-area-0.0.0.3]nssa no-summary 
    

    AR5配置

    [R5]int g0/0/0
    [R5-GigabitEthernet0/0/0]ip add 45.1.1.5 24
    [R5-GigabitEthernet0/0/0]undo sh
    [R5-GigabitEthernet0/0/0]int g0/0/1
    [R5-GigabitEthernet0/0/1]ip add 56.1.1.5 24
    [R5-GigabitEthernet0/0/1]undo sh
    [R5-GigabitEthernet0/0/1]int loop 0
    [R5-LoopBack0]ip add 5.5.5.5 32
    [R5-LoopBack0]q
    [R5]ospf 1 router-id 5.5.5.5
    [R5-ospf-1]area 3
    [R5-ospf-1-area-0.0.0.3]network 45.1.1.0 0.0.0.255
    [R5-ospf-1-area-0.0.0.3]network 5.5.5.5 0.0.0.0
    [R5-ospf-1-area-0.0.0.3]q
    [R5-ospf-1]q
    [R5]ping -a 5.5.5.5 1.1.1.1
      PING 1.1.1.1: 56  data bytes, press CTRL_C to break
        Reply from 1.1.1.1: bytes=56 Sequence=1 ttl=252 time=50 ms
        Reply from 1.1.1.1: bytes=56 Sequence=2 ttl=252 time=30 ms
        Reply from 1.1.1.1: bytes=56 Sequence=3 ttl=252 time=40 ms
        Reply from 1.1.1.1: bytes=56 Sequence=4 ttl=252 time=30 ms
        Reply from 1.1.1.1: bytes=56 Sequence=5 ttl=252 time=30 ms
    
    [R5]rip
    [R5-rip-1]ver 2 
    [R5-rip-1]undo summary 
    [R5-rip-1]network 56.0.0.0
    [R5-rip-1]q
    [R5]ospf 1
    [R5-ospf-1]import-route rip 1 cost 100
    [R5-ospf-1]q
    [R5]rip
    [R5-rip-1]import-route ospf 1 cost 0
    [R5-rip-1]q
    [R5]ospf 1
    [R5-ospf-1]area 3
    [R5-ospf-1-area-0.0.0.3]nssa
    [R5-ospf-1-area-0.0.0.3]q
    [R5-ospf-1]q
    [R5]rip		
    [R5-rip-1]default-route originate cost 0
    

    AR6配置

    [R6]int g0/0/0
    [R6-GigabitEthernet0/0/0]ip add 56.1.1.6 24
    [R6-GigabitEthernet0/0/0]undo sh
    [R6-GigabitEthernet0/0/0]int loop 0
    [R6-LoopBack0]ip add 6.6.6.6 32
    
    [R6-LoopBack0]q
    [R6]rip
    [R6-rip-1]ver 2	
    [R6-rip-1]undo summary 
    [R6-rip-1]network 56.0.0.0	
    [R6-rip-1]network 6.0.0.0
    

    测试网络联通性成功,实现全网互通。

    总结

    对于在不同的网络中该如何选择路由协议得出以下结论:

    • 在公司、组织各自的内部网络中使用IGP,而在服务提供商、公司和大型企业之间使用EGP实现互联。
    • 如果网络规模较小,路由器的数量小于或等于15个,则可以考虑使用RIP或IGRP。
    • 对于小规模的网络,可以使用RIPv2协议。而对于中型的网络,使用EIGRP协议则更为合适。如果是大型网络,则需要考虑使用OSPF协议。
    展开全文
  • 动态路由协议及分类

    千次阅读 2020-07-29 08:48:02
    .3动态路由协议及分类 前面已经为大家介绍了路由器对于直连路由的发现过程,以及静态路由的概念和部 署要点。对于一个小型网络,静态路由或许已经能够满足需求,但是在大中型网络中, 由于网段数量特别多、网络拓扑...

    技术背景

    • 对于一个小型网络,静态路由或许已经能够满足需求,但是在大中型网络中,由于网段数量特别多、网络拓扑复杂等原因,仅仅使用静态路由来实现数据互通显然是不太现实的,原因是配置及维护工作量都太大,再者存在静态路由无法动态地响应网络拓扑变更等因素。
    • 动态路由协议(Dynamic Routing Protocol)可以很好地解决上述需求问题。
    • 在路由器上激活了动态路由协议后,就相当于激活了路由器的某种能力,路由器之间就能够交互路由信息或者用于路由计算的数据,而当网络拓扑发生变更时,动态路由协议能够感知这些变化并且自动地作出响应,从而使得网络中的路由信息适应新的拓扑,这种动作完全由协议自动完成,无需人为干预。
    • 因此在一个规模较大的网络中,我们往往会使用动态路由协议,或者静态路由与动态路由协议相结合的方式来建设该网络。

    动态路由协议分类

    • 动态路由协议有很多,而分类的方法也存在多种。
    • 基于协议算法不同,可以将动态路由协议分成两类:
    1. 距离矢量路由协议(Distance Vector Routing Protocol);
    2. 链路状态路由协议(Link State Routing Protocol) 。
    • 根据工作范围的不同,动态路由协议可分为两类:
    1. IGP ( Interior Gateway Protocol,内部网关协议),比如RIP, OSPF, IS-IS等;
    2. EGP ( Exterior Gateway Protocol,外部网关协议),比如BGP ( Border Gateway Protocol )等。
    • IGP被用于在AS(Autonomous System,自治系统)内部实现路由信息的交互,而EGP则被用于在AS之间实现路由信息的交互。AS的传统定义是,由一个单一的机构或组织所管理的一系列IP网络及其设备所构成的集合,可以简单地将AS理解为一个独立的机构或者企业所管理的网络,比如一家跨省公司的网络等。

    距离矢量路由协议

    • 距离矢量路由协议指的是基于距离矢量的路由协议,RIP是最具代表性的距离矢量路由协议。
    • “距离矢量”这个概念包含两个关键的信息:“距离”和“方向”,其中“距离”指的是到达目标网络的度量值,而方向指的是到达该目标网络的下一跳设备。
    • 每一台运行距离矢量路由协议的路由器都会周期性地将自己的路由表通告出去,其直连的路由器会收到这些路由信息,学习前者通告的路由并更新自己的路由表后,它也会向自己直连的路由器通告其路由表,最终网络中的每台路由器都能获知到达各个网段的路由,这个过程被称为路由的泛洪(Flooding)过程。

    示例

    如下图所示的网络拓扑中,

    在这里插入图片描述

    • R1及R2两台路由器直连。
    • 初始情况下R1及R2都只知道自己“家门口的情况”,也就是说,R1及R2都自动发现了自己直连接口的路由。R1在其路由表中写入192.168.12.0/24及1.0.0.0/8两条直连路由,而R2则在其路由表中写入192.168.12.0/24这一条直连路由。
    • 对于R2而言,此刻是无法访问1.0.0.0/8的,因为在它的路由表中并没有任何能够到达这个网段的路由信息。
    • 现在R1和R2上激活距离矢量路由协议。
    • R1路由通告:
      (1)R1将已经发现的路由(1.0.0.0/8及192.168.12.0/24)通过路由协议报文通告给R2,这两条路由各附带着一个度量值。
      (2)以距离矢量路由协议的典型代表RIP为例,它使用跳数(Hop Count)作为路由的度量值,所谓跳数就是到达目的网段所需经过的路由器的个数,直连网段的度量值被视为0跳。
      (3)R1将两条直连路由通告给R2时,为路由设置的跳数为1,“我家门口的这些网段对于我自己而言可以直接到达(只需0跳),现在别人要经过我来访问该网段,就需要加上我这一跳”。
    • R2处理R1的路由通告:
      (1)由于192.168.12.0/24是R2自己的直连网段,因此R2会忽略R1通告过来的、到达该网段的路由更新,而1.0.0.0/8路由对于R2而言是未知的,因此R2将这条路由加载进路由表,同时为该条路由关联度量值:1跳,并且把路由的通告者R1视为该条路由的下一跳。
      (2)当R2要转发到达1.0.0.0/8的数据包时,就会将数据包发给下一跳路由器R1。可以形象的理解就是:“R2认为1.0.0.0/8可以通过R1到达,自己与该网段距离1跳路由器”,这也就是“距离矢量”名称的由来。
    • 需要注意的是,运行距离矢量路由协议的路由器并不了解网络的拓扑结构,该路由器只知道:
      (1)自己与目的网络之间的距离;
      (2)从哪个方向可到达目的网络。

    链路状态路由协议

    • 链路状态路由协议与距离矢量路由协议不同,运行链路状态路由协议的路由器会使用一些特殊的信息描述网络的拓扑结构及IP网段,这些信息被称为链路状态(Link State )信息,所有的路由器都会产生描述自己直连接口状况的链路状态信息。
    • 路由器将网络中所泛洪的链路状态信息都搜集起来并且存入一个数据库中,这个数据库就是LSDB( Link-State Database,链路状态数据库),
    • LSDB可以视为对整个网络的拓扑结构及IP网段的描绘,所有路由器拥有对该网络的统一认知,接下来所有的路由器都基于LSDB使用特定的算法进行计算,计算的结果是得到一棵以自己为根的、无环的最短路径树,并将基于这棵树得到的路由加载到路由表中。
    • 典型的链路状态路由协议有OSPF及IS-IS。
    展开全文
  • 动态路由是与静态路由相对的一个概念,指路由器能够根据路由器之间的交换的特定路由信息自动地建立自己的路由表,并且能够根据链路和节点的变化适时地进行自动调整。当网络中节点或节点间的链路发生故障,或存在其它...

    前言

    动态路由是与静态路由相对的一个概念,指路由器能够根据路由器之间的交换的特定路由信息自动地建立自己的路由表,并且能够根据链路和节点的变化适时地进行自动调整。当网络中节点或节点间的链路发生故障,或存在其它可用路由时,动态路由可以自行选择最佳的可用路由并继续转发报文。

    一:动态路由

    动态路由是指路由器能够自动地建立自己的路由表,并且能够根据实际情况的变化适时地进行调整。

    1.1:动态路由协议基础

    1.1.1:动态路由:

    基于某种路由协议实现

    1.1.2:动态路由特点:

    (1)优点:减少了管理任务

    (2)缺点:占用了网络带宽

    1.2:动态路由协议

    1.2.1:.动态路由协议概述

    路由器之间用来交换信息的语言

    1.2.2:度量值

    度量值是用来衡量路径优劣的参数

    跳数:一个路由器就是一条,跳数越小越好。

    带宽:用来标识信号传输的数据传输能力、标识单位时间内通过链路的数据量、标识显示器的显示能力。

    负载:承载的传输数据量。

    时延:指一个报文或分组从一个网络的一端传送到另一个端所需要的时间

    可靠性:数据传输的稳定性和效率。

    成本:带宽越高,路径成本越低。

    1.2.3:收敛概念

    使所有路由表都达到一致状态的过程。

    1.2.4:静态路由和动态路由的比较

    网络中静态路由和动态路由互相补充。静态路由的优先级高于动态路由。

    mark

    1.3:动态路由协议分类

    按照路由执行的算法分类。

    1.3.1:距离矢量路由协议:RIP , IGRP

    依据从源网络到目标网络所经过的路由器的个数选择路由。

    1.3.2:链路状态路由协议:OSPF , IS-IS

    综合考虑从源网络到目标网络的各条路径的情况选择路由。

    二:RIP路由协议工作原理

    2.1:RIP路由协议工作原理

    2.1.1:RIP是距离-矢量路由选择协议
    2.1.2:RIP的基本概念:

    1.定期更新:每过一段时间就会探测里面网段的变化

    2.邻居:邻居发现机制。传输都是通过邻居传输的。

    3.广播更新:RIP v1版本使用广播更新。

    4.全路由表更新:看路由表,差哪些就把哪些更新上去。

    2.1.3:路由表的形成原理

    结合每一步图片对应查看。

    第一步:路由器学习到直连路由的网段。

    直连网段会直接被路由检测到,并添加到路由表中。

    第二步:更新周期30s到时,路由器会向邻居发送路由表。

    更新周期30s到时间后,路由器会向邻居路由发送自己已经拥有的网段,邻居路由接收到数据后,和自己的路由表比较,将没有的网段添加到自己的路由表中。

    向邻居发送路由表的过程:

    1:R1将第一步就建立好的路由表:10.0.0.0 和 20.0.0.0发送给邻居R2,R2接收到后,将自己没有的10.0.0.0 网段添加到自己的路由表中。

    2:R2将第一步就建立好的路由表:20.0.0.0 和 30.0.0.0发送给邻居R1 和 R3。

    R1 和 R3接收到后:R1 将自己没有的 30.0.0.0 网段添加到自己的路由表中。R3 将自己没有的 20.0.0.0网段添加到自己的路由表中。

    3:R3将第一步就建立好的路由表:30.0.0.0 和 40.0.0.0发送给邻居R2,R2接收到后,将自己没有的40.0.0.0 网段添加到自己的路由表中。

    第三步:再过30s,第二个更新周期到了,再次发送路由表。

    第二个更新周期30s到时间后,路由器会向邻居路由发送自己已经拥有的网段,邻居路由接收到数据后,和自己的路由表比较,将没有的网段添加到自己的路由表中。

    向邻居发送路由表的过程:

    1:R1将第二步建立好的路由表:10.0.0.0 , 20.0.0.0 ,和30.0.0.0 发送给邻居R2,R2接收到后,发现数据自己都有了,便不进行更新。

    2:R2将第二步建立好的路由表:20.0.0.0 , 30.0.0.0 ,10.0.0.0 和 40.0.0.0 发送给邻居R1 和 R3。

    R1 和 R3接收到后:R1 将自己没有的 40.0.0.0 网段添加到自己的路由表中。R3 将自己没有的 10.0.0.0网段添加到自己的路由表中。

    3:R3将第二步建立好的路由表:30.0.0.0 , 40.0.0.0 和 20.0.0.0 发送给邻居R2,R2接收到后,发现数据自己都有了,便不进行更新。

    mark

    mark

    mark

    2.1.4:RIP的度量值与更新时间

    1.RIP度量值为跳数:最大跳数15跳,16跳为不可达。

    2.RIP更新时间:每隔30s发送路由更新消息,UDP520端口

    3.RIP路由更新消息:发送整个路由表信息

    2.1.5:水平分割

    1.路由环路的产生(看图)

    原本三个路由器的路由表都记录了所有网段,此时突然R3的40网段坏了,R3将40网段的跳数设为16。即标记为不可达。
    mark
    mark
    mark

    2.执行水平分割可以阻止路由环路的发生

    从一个接口学习到路由信息,不再从这个接口发送出去。

    同时也能减少路由更新信息占用的链路带宽资源。

    2.2:RIP路由协议的配置和验证

    模式命令目的
    全局模式:Router(config)#router rip启动RIP进程
    全局模式:Router(config-router)#nnetwork network-number宣告主网络号
    特权模式:Router#sshow ip route查看路由表
    特权模式:Router#show ip protocols查看路由协议的配置
    RIP的配置和验证
    Router(config)#router rip   启动RIP进程
    Router(config-router)#network network-number  宣告主网络号
    Router#show ip router  查看路由表
    Router#show ip protocols  查看路由协议的配置
    

    管理距离:路由协议的可信任度,数值越小,信任度越高。

    2.3:RIP路由协议V1 与 V2

    mark

    2.4:RIP V2的配置

    Router(config)#router rip
    Router(config-router)#version 2  启动版本v2
    Router(config-router)#no auto-summary   关闭RIP v2的路由自动汇总
    
    

    三:动态路由实验

    3.1:实验环境与配置

    GNS3软件

    三台初始化状态路由器,路由器需要添加磁盘空间。

    两台主机

    自定义各个接口IP地址

    3.2:实验目的

    通过动态路由RIP协议实现不同网段的两台主机实现互联互通。

    3.3:实验过程

    mark

    mark

    mark

    mark

    mark

    mark

    3.4:总结

    1.使用路由器时,路由器的磁盘空间需要设置,否则路由器没有空间记录路由表。

    2.接口IP设置完成后,需要no shutdown(开启端口)。

    3.使用RIP版本2(缩写 ve 2)进行实验,需要关闭自动路由汇总功能(缩写no au)。

    展开全文
  • Re:计算机网络 静态路由和动态路由协议  ====================== # IP路由-网络层实现的功能:       网络畅通的条件       静态路由       路由汇总   &...
  • 路由协议一般工作在OSI参考模型的传输层或者应用层,常见的路由协议有RIP、OSPF、BGP(Border Gateway Protocol,边界网关协议)等。 可路由协议:又称为被路由协议,指可以被路由器在不同逻辑网段间路由的协议。可...
  • 动态路由协议 RIP(路由信息协议)

    千次阅读 2019-12-02 20:08:04
    动态路由协议 RIP(路由信息协议) 什么是路由? 当一个路由器(或者其他三层设备)获得一个数据包,会查看数据包中的报头的IP地址,并在自己的路由表中进行查看,匹配最佳路径,最优路由,并将数据包扔给该路由的下一...
  • RIPV2动态路由协议—网络基础

    千次阅读 多人点赞 2021-03-25 12:37:05
    RIPV2动态路由协议一、实验题目1、IP地址规划2、拓扑搭建3、配置IP地址与环回接口4、RIPV2的配置5、RIP的扩展配置:6、成果展示二、动态路由1、动态路由协议:2、动态路由协议的缺点:3、静态路由协议的缺省:4、...
  • 动态路由协议动态路由和rip)

    千次阅读 2020-06-01 20:13:18
    动态路由协议动态路由和rip) 动态路由协议通过路由信息的交换生成并维护转发引擎所需的路由表。...文章目录动态路由协议动态路由和rip)动态路由动态路由概述动态路由协议基础动态路由协议分类rip路由协议rip路由
  • 常见动态路由协议

    万次阅读 2018-06-08 20:06:52
    动态路由协议有自己的路由算法,能够自动适应网络拓扑的变化,适用于具有一定数量三层设备的网络。缺点是配置对用户要求比较高,对系统的要求高于静态路由,并将占用一定的网络资源。 常见的动态路...
  • 学习笔记:动态路由协议,距离矢量路由协议RIP(原理及配置) 1.动态路由 基于某种路由协议实现 特点: 减少了管理任务 占用了网络带宽 1.1基础 动态路由协议概述 路由器之间用来交换信息的语言 度量值 跳数...
  • 实验一:RIP动态路由协议实验

    千次阅读 2019-09-22 16:14:31
    实验报告一:RIP动态路由协议实验 实验拓扑: Requirment: 某网络整体结构如果所示,在Router1上有3个回环口,IP地址如图,Router3连接两台主机,现要求通过使用路由协议实现全网互联。 在各路由器上配置静态路由...
  • 静态路由与动态路由的比较 网络中静态路由和动态路由相互补充 6、动态路由协议分类 距离矢量路由协议:依据从源网络到目标网络所经过的路由器的个数选择路由 - - RIP、IGIP(思科私有协议) 链路状态路由协议:综合...
  • 文章目录3 实验四:动态路由协议3.1 实验目的和内容3.1.1实验目的3.1.2 实验内容3.2 实验过程3.2.1 基于RIP动态路由协议的网络互联3.2.2 基于OSPF动态路由协议的ipv43.2.3 基于OSPF动态路由协议的ipv63.3 实验分析...
  • 计算机网络管理实训教程: RIP、OSPF动态路由协议的陪着
  • 文章目录一、动态路由及RIP协议工作原理1.1 动态路由概述1.1.2 动态路由协议1.1.3 动态路由协议分类1.2 RIP路由协议工作原理1.2.1 RIP的基本概念1.2.2 路由表的形成1.2.3 RIP的度量值与更新时间1.2.4 水平分割1.2.5 ...
  • 动态路由协议RIP OSPF

    2019-06-19 13:19:06
    动态路由协议的分类 (1)基于运行特征来分类 距离矢量协议:RIP、EIGRP、BGP 链路状态协议:OSPF、ISIS 距离矢量:距离(远近)矢量(方向),路由器之间传递的是路由表,通过与邻居路由交换信息来工作 链路状态:...
  • 1、动态路由是与静态路由相对的一个概念,指路由器能够根据路由器之间的交换的特定路由信息自动地建立自己的路由表,并且能够根据链路和节点的变化适时地进行自动调整2、当网络中节点或节点间的链路发生故障,或存在...
  • 动态路由协议-RIP原理与配置实验

    千次阅读 2020-06-01 17:33:40
    最简单的拓扑图解释RIP配置,RIP协议特点,华为模拟器中详细的配置命令
  • H3C动态路由协议配置

    2011-05-17 18:13:40
    描述了H3C路由器的RIP路由协议,包括详细介绍和基本的配置

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 312,182
精华内容 124,872
关键字:

动态路由协议