精华内容
下载资源
问答
  • 思科RIP路由协议配置

    千次阅读 2020-05-23 23:09:55
    思科路由器RIP协议的配置 (供自己参考学习) RIP简介 RIP(Routing Information protocol) 路由信息协议. 是一种内部网关协议(IGP),是一种动态路由选择协议,用于自治系统(AS)内的路由信息的传递。RIP协议...

    思科路由器RIP协议的配置
    (供自己参考学习)

    RIP简介

    RIP(Routing Information protocol) 路由信息协议.
    是一种内部网关协议(IGP),是一种动态路由选择协议,用于自治系统(AS)内的路由信息的传递。RIP协议基于距离矢量算法(DistanceVectorAlgorithms),使用“跳数”(即metric)来衡量到达目标地址的路由距离。RIP通过UDP报文进行路由信息交换,使用的端口号为520.

    RIP包括RIP-v1和RIP-v2两个版本

    RIPV1和RIPV2比较

    RIPV1RIPV2
    有类路由协议无类路由协议
    不支持VLSM支持VLSM
    广播更新255.255.255.255组播更新224.0.0.9

    实验
    在这里插入图片描述

    1. 首先配置PC2  PC3的IP地址
      PC1 192.168.10.2 MAC 255.255.255.0
      PC2 192.168.20.2 MAC 255.255.255.0
    2. R1的IP 10.0.0.1 255.255.255.252
    3. R2的IP 10.0.0.2 255.255.255.252
    4. 配置路由R1
      在这里插入图片描述
      Router>enable
      Router#conf t
      Router(config)#int g0/0(进入G0/0端口)
      Router(config-if)#no shutdown
      Router(config-if)#ip add 192.168.10.1 255.255.255.0 (配置G0/0端口的的IP地址)
      Router(config-if)#int g0/1
      Router(config-if)#no shutdown (开启端口)
      Router(config-if)#ip add 10.0.0.1 255.255.255.252
      Router(config)#route rip
      Router(config-router)#version 2
      Router(config-router)#network 192.168.10.0
      Router(config-router)#network 10.0.0.0
      Router(config-router)#no auto-summary
      Router(config-router)#ex
      在这里插入图片描述
      Router(config)#route rip (开启RIP协议)
      Router(config-router)#version 2 (启用RIPv2 )
      Router(config-router)#network 192.168.10.0 (宣告网段)
      Router(config-router)#network 10.0.0.0 (宣告网段)
      Router(config-router)#no auto-summary (关闭自动汇总)
      5.show ip route 查看路由信息
      6.配置R2
      在这里插入图片描述
      (全部同上)
      Router>en
      Router#conf t
      Router(config)#int g0/0
      Router(config-if)#no shutdown
      Router(config-if)#int g0/0
      Router(config-if)#ip add 192.168.20.1 255.255.255.0
      Router(config-if)#int g0/1
      Router(config-if)#no shutdown
      Router(config-if)#ip add 10.0.0.2 255.255.255.252
      Router(config-if)#ex
      Router(config)#route rip
      Router(config-router)#version 2
      Router(config-router)#ne
      Router(config-router)#network 192.168.20.0
      Router(config-router)#net
      Router(config-router)#network 10.0.0.2
      Router(config-router)#no au
      Router(config-router)#no auto-summary
      Router(config-router)#ex
      7.验证:PC
      在这里插入图片描述
    展开全文
  • 计算机网络实验六rip路由协议配置.doc 太原理工大学现代科技学院计算机通信网络课程实验报告专业班级学号姓名指导教师太原理工大学现代科技学院实验报告实验名称同组人专业班级学号姓名成绩一、实验目的计算机通信...

    41528d3028836879cd698677c3999917.gif计算机网络实验六rip路由协议配置.doc

    太原理工大学现代科技学院计算机通信网络课程实验报告专业班级学号姓名指导教师太原理工大学现代科技学院实验报告实验名称同组人专业班级学号姓名成绩一、实验目的计算机通信网络实验指导书掌握RIP动态路由协议的配置、诊断方法。二、实验任务1、配置RIP动态路由协议,使得3台CISCO路由器模拟远程网络互联。2、对运行中的RIP动态路由协议进行诊断。三、实验设备CISCO路由器3台,带有网卡的工作站PC2台,控制台电缆一条,交叉线、V35线若干。四、实验环境五、实验步骤1、运行CISCOPACKETTRACER软件,在逻辑工作区放入3台路由器、两台工作站PC,分别点击各路由器,打开其配置窗口,关闭电源,分别加入一个2口同异步串口网络模块(WIC2T),重新打开电源。然后,用交叉线(COPPERCROSSOVER)按图61(其中静态路由区域)所示分别连接路由器和各工作站PC,用DTE或DCE串口线缆连接各路由器(ROUTER0ROUTER1),注意按图中所示接口连接(S0/0为DCE,S0/1为DTE)。2、分别点击工作站PC1、PC3,进入其配置窗口,选择桌面(DESKTOP)项,选择运行IP设置(IPCONFIGURATION),设置IP地址、子网掩码和网关分别为PC11921681100/24GW19216811PC31921683100/24GW19216833装订线太原理工大学现代科技学院实验报告3、点击路由器R1,进入其配置窗口,点击命令行窗口(CLI)项,输入命令对路由器配置如下点击路由器R2,进入其配置窗口,点击命令行窗口(CLI)项,输入命令对路由器配置如下同理对R3进行相应的配置4、测试工作站PC间的连通性。太原理工大学现代科技学院实验报告从PC1到PC3PCPING1921683100(不通)5、设置RIP动态路由接前述实验,继续对路由器R1配置如下同理,在路由器R2、R3上做相应的配置6、在路由器R1上输入SHOWIPROUTE命令观察路由信息,可以看到增加的RIP路由信息。太原理工大学现代科技学院实验报告同理,在路由器R2、R3上输入SHOWIPROUTE命令观察路由信息。从PC1到PC3PCPING1921683100(通),太原理工大学现代科技学院实验报告六、实验体会在实验中,我们掌握RIP动态路由协议的配置、诊断方法。对运行中的RIP动态路由协议进行诊断,在对设备路由器的连接时,先将路由器的电源开关关闭,加入2个WIC2T,再关上电源,路由器之间进行连接应注意端口的。从实验中,对RIP配置的了解有一定的认识与理解,使自己在计算机领域的知识又有了一定的提高。太原理工大学现代科技学院实验报告

    展开全文
  • RIP路由协议

    2019-03-27 07:31:57
    RIP路由协议 动态路由协议:RIP(Routing Information Protocols路由信息协议) Routing protocols(路由协议)是用来在路由器之间确定到达目的地的可能路径并防止最佳的路径到路由表中以及一旦网络结构发生变化能...
    1. RIP路由协议

    动态路由协议:RIP(Routing Information Protocols路由信息协议)

    Routing protocols(路由协议)是用来在路由器之间确定到达目的地的可能路径并防止最佳的路径到路由表中以及一旦网络结构发生变化能动态无需人为参与地适应这种变化,并正确地把这种变化反映到网络表中。

    一旦路由被确定,路由器就能路由可路由协议如:IP、IPX、APPLET、ALK等

    • 动态路由协议在协议栈中的位置

    BGP  RIP   OSPF EIGRP(应用层)

    TCP  UDP                 //RIP是封装在UDP中,OSPF EIGRP是封装到IP中的

        IP

        链路层

    物理层

    RIP使用的端口号:UIDP 520 ,目的端口和源端口都是520

    • 路由协议的分类(根据运行位置AS的不同)

    自制系统(Autonomous System 内部网络的集合体)是在同一管理模式下的一个内部往来的集合体

    IGP(内部网络协议)在AS内部进行工作

    EGP(外部网关协议)是在AS之间运行的协议

    1. AS的说明

    IANA(internet地址授权委员会)分配,也分公有AS和私有AS

    • 路由协议分类(从是否携带掩码的角度)
    1. 有类路由选择协议

     在进行路由信息通告的时候,不携带子网掩码

    如果整个网络运行相同的主类网络,但子网不同;要求所有相同子网的子网掩码必须相同,否则会产生路由不可达问题。

    1. 无类路由选择协议

    无类路由选择协议在进行路由信息通告的时候传递子网掩码

    无类路由选择协议支持变长子网掩码(VLSM)

    无类路由选择协议可以手工实施汇总;而有类路由选择协议只能自定汇总,没有手工汇总这种强大的控制网络传播的能力。

    • 路由协议分类(从路由计算方法的角度)
    1. 距离矢量型Distance Vector EIGRP
    2. 平衡混合型Hybrid Routing EIGRP
    3. 链路状态型Link State

    路由协议分类汇总

     

    内部网关协议  IGP 

    1)距离矢量型 a:有类的RIPv1,IGRP   b:无类的RIPV2,EIGRP

    2)链路状态型(无类的)a:OSPF   b:IS-IS 中间系统到中间系统

    外部网关协议  EGP BGP

    • 管理距离

    距离越小,优先级越高

    • 距离矢量路由选择协议
    1. 距离矢量

    How Far Vecctor Which Dierction

    1. 路由信息的获取

    广播或者组播的方式,距离矢量组合

    1. 使用度量值(Metric)来选择最佳路由

    RIP使用HOP(跳数)作为度量值

    IGRP-思科私有协议,度量值(Bandwidth/Deplay/Load/Reliability/MTU-带宽、延迟、负载、可靠性、最大传输单元)

    1. 维护路由信息

    当拓扑环境发生变化,

    两种方式更新路由表:1)定期更新、2)触发(增量)更新。有的用广播来发送分组、有的用多播

    1. 不一致的路由条目

    路由环路

    解决方法:

    1. 设置无穷大值:如 RIP约定16条就是无穷大,这条路由标记为possible down状态,但是不会马上从路由表中清除
    2. 水平分割:路由器从某个接口接受到的信息,不能反向再发回去。对毒性反转无效
    3. 路由中毒:明确告诉邻居这条路由已经坏了(Down),不需要计数到无穷,加快了收敛的时间
    4. 毒性反转:Infinity不可达,Possibly Down
    5. 触发更新(Triggered Updates):RIP每30秒更新一次,
    6. 抑制计时(Holedown Timers):思科路由器独有的。

    原理:一个路由条目失效后,一段时间内这条路由处于抑制状态,即在一个特定时间段内不再接收关于这条路由的任何路由更新,然而在下列情况下,抑制时间解除:

     A:抑制计时器超时

     B:收到一个好度量值的路由更新(小于原来的度量值)

     C:刷新时间到时

    1. 距离矢量路由协议的路由更新流程
    • RIP

    RIP距离矢量路由协议,有两个版本:v1/v2

    RIP支持等价的负载均衡,到达同一个目标网络有多条路径,如果跳数一样,进行负载分担,默认4条,最多可配置支持6条,

    RIP每30秒定期发送路由更新。不是一个确定的30秒

    RIP通过UPD 520端口

    RIP定义了两种信息类型:请求和应答两个方式

    RIP的metric是基于跳数(hop count)的,metric为16代表不可达

    1. RIP发送更新的规则,针对RIPv1
    2. RIP接收更新的规则,针对RIPv1
    • 配置RIP的步骤

    #router rip  进入路由配置模式

    #network network-number   选择参与RIP的路由器接口,写主类网络号network 12.0.0.0

    #version 2  启用RIPv2 

    #no au 关掉自动汇总

    #s 1/1

    #ip summary-address rip ?

    #ip summary-address rip 13.1.0.0 255.255.0.0 汇总

    #passive-interface type/number  被动接口

    #ip summary-address rip RIPv2汇总网络号

    #debug ip rip   矢量累计是在发送方更新的

    RIPv1使用广播地址224.0.0.9发送路由更新

    • RIP计时器

    更新时间30 seconds

    失效时间Possibily down 180 seconds

    Hold down timer 180s

    Flushed after 刷新计时器240 删除该条目

    180+180(240秒)

     

     

    复习:

    RIP  路由信息协议

    Rfc:1058

    距离矢量协议   距离 方向 累加 开销  传递的内容是路由表中的信息

    度量值:跳数。跳数超过15不可达(不适用于大型网络)

    跳数:网络中路由器的个数。

    度量值是每一个动态路由协议为了计算开销用的,

    不同协议之间参考值不一样,有可能是带宽,跳数越少,越快,开销小有限

    每30秒收敛一次,整张路由表更新一次,30秒给下一跳一次

    针对IPv4的RIP有V1和V2两个版本

    V1使用广播,

    V2使用组播,组播地址:224.0.0.9 专门提供给RIP的

    组播传的内容更精准

    管理地址(AD值):120   管理距离越小,优先级越高,

    S 192.168.2.1 [1/0]

    R 192.168.2.1[120]

    路由表会保存最优的协议 最优的路由

    IP地址三种通信方式。以数据包的目的地址区分的

    单播:IP数据包   E+IP(S,D)+IGMP,当目的地址是主机地址的情况下是单播 一对一

    广播:目的地址是广播  交换机所以接口都向外发送 即:泛红  一对所有

    组播:类似RIP 224.0.0.9  一对多  。

     

    RIPV1有类路由协议,不支持变长子网掩码VLSM,更新方式为广播,不支持认证,每个更新包最大支持25条路由条目,路由表查询方式主类网段不支持不连续子网

     

    Ripv2无类路由协议,支持VLSM,组播更新,支持认证思科私有,路由表查询机制是由小类-》大类(按位查询,最长匹配,精确匹配,先检查32位掩码的),支持不连续的子网

     

    有类路由不传子网掩码,精确匹配子网困难,易出现负载均衡

    无类路由传递子网掩码,

    12.0.0.0/24  主类

    C 12.1.1.0/24 直连子类

    C 12.1.2.0/24 直连子类

    Rip协议使用UDP协议  端口520  协议号:17  Rip是一个应用层协议

       E(Type)+IP(协议号) + UDP(端口号) +Rip

    Rip协议形式:请求消息,响应消息

    Rip 默认支持等价负载均衡:4,最大支持6   

    平衡等价下一跳4条,人为最大修改为6

    Rip计时器

    Update:30s  更新计时器  更新给所有旁边直连的启用Rip的设备

    Invalid:180s 无效计时器  没有刷新 等待时间 将该路由条目的度量值设置为:16

    Flush:240 刷新计时器,删除所有传递的路由

    Hold-down:180抑制计时器,相对于180s无效计时器设置16,超出15路由不可达

    Rip环路发生-防环机制 距离矢量的一个机制

    水平分割:

    路由毒华和毒性逆转水平分割

    触发更新

    虚拟接口环回loopback

    #interface loopback 0

    #

    R1(config)#router rip

    R1(config-route)#version 2

    #no auto-summary  关闭自动汇总,把无类汇总成有类,有类不传掩码

    #network 1.1.11    宣告C直连(自己配IP的网段)的网段,

    把路由所在的接口宣告给rip的组播(224.0.0.9)分组中发出去

    从这个接口向外发送组播请求信息以及更新消息

    对方发送的请求有资格查询

    #do show ip route

    R 3.3.3.3[120/2]  120管理距离,2开销,2跳

    展开全文
  • RIP路由协议原理

    2020-06-13 14:18:13
    路由协议基础1.1 自治系统(AS)1.2 路由协议分类2. RIP协议基本原理3. RIP路由表形成4. RIP消息格式5. RIP-1与RIP-25 .1RIP-1的报文格式5.2 RIP-2的报文格式5.3 运行RIP-1和RIP-2版本的不同5.3.1 运行RIP-1的时候...

    RIP


    思维导图

    1. 路由协议基础

    1.1 自治系统(AS)

    自治系统(Autonomous System,AS):在网络中一个自治系统指的是若干个二层网络及若干路由器组成的集合,集合中的这些网络和这些路由器属于同一个管理机构。规模大小不同,一个 internet 可以包含一个或多个AS

    1.2 路由协议分类

    • 路由协议分为两大类,一类是IGP(Interior Gateway Protocol,内部网关协议),一类是EGP(Exterior Gateway Protocol ,外部网关协议 )
    • IGP成员有RIP(Routing Information Protocol)OSPF(Open Shortest Path First)IS-IS(Intermediate System to Intermediate System)等;
    • EGP成员虽然也有若干个协议,但是目前使用的就只有一个BGP(Border Gateway Protocol)

    2. RIP协议基本原理

    • RIP是一种基于距离矢量(Distance Vector,简称DV)算法的IGP协议,其协议的优先级为100(华为),120(思科);

    • 以“跳数”作为开销,所谓“跳数”就是到达目的地需要经过的路由器个数,跳数>=16时视为不可达路由,使得RIP只能应用于小规模的网络;

    • 周期性更新路由表,即使在稳定状态下,路由交换过程仍然会继续进行;

    3. RIP路由表形成

    一台路由器在创建RIP路由表初期,RIP路由表中只包含直连路由。随后路由器会不断接收从邻居发来的路由信息,并根据这些路由信息来完善自己的路由表。同时路由器会每隔30s向邻居路由器发起更新请求。

    4. RIP消息格式

    • RIP的消息格式有两种:一种是RIP请求消息(Request),另一种是RIP响应消息(Response)

    • RIP路由器发送请求消息给邻居路由器,邻居路由器收到后就会立即发送响应消息给邻居路由器;

    • RIP路由器可以随时向邻居发出请求消息;

    • RIP路由器总是会每隔30s周期性向邻居路由器发送响应消息

      RIP请求消息有两种

      1. 请求消息用来请求关于某一些指定的路由信息;
      2. 请求关于整个RIP网络的路由信息,RIP刚刚启动的时候应该是采用第二种RIP请求消息

    5. RIP-1与RIP-2

    ​ RIP协议有两个版本,RIP-1和RIP-2,基于UDP协议,使用的端口号为520

    5 .1RIP-1的报文格式

    RIP-1报文由头部(Header)和多个路由表项(Route Entries)部分组成。在一个RIP报文中,最多可以有25个路由表项。RIP是一个基于UDP协议的,并且RIP-1的数据包不能超过512字节

    字段名长度含义
    Command(命令)8比特标识报文的类型: 1:Request报文,向邻居请求全部或部分路由信息; 2:Reponse报文,发送自己全部或部分路由信息,一个Response报文中最多包含25个路由表项。
    Version(版本)8比特RIP的版本号: 1:RIP-1 2:RIP-2
    Must be zero16 比特必须为零字段。
    AFI(Address Family Identifier)协 议簇16比特地址族标识,其值为2时表示IP协议。对于Request报文,此字段值为0。
    Route Tag16比特外部路由标记。
    IP Address32比特该路由的目的IP地址,可以是自然网段的地址,也可以是子网地址或主机地址。
    Metric32比特路由的开销值。对于Request报文,此字段为16。

    5.2 RIP-2的报文格式

    字段名长度含义
    Command(命令)8比特标识报文的类型: 1:Request报文,向邻居请求全部或部分路由信息; 2:Reponse报文,发送自己全部或部分路由信息,一个Response报文中最多包含25个路由表项。
    Version(版本)8比特RIP的版本号: 1:RIP-1 2:RIP-2
    Must be zero16比特必须为零字段。
    AFI(Address Family Identifier)协议簇16比特地址族标识,其值为2时表示IP协议。对于Request报文,此字段值为0。
    Route Tag16比特外部路由标记。
    IP Address32比特该路由的目的IP地址,可以是自然网段的地址,也可以是子网地址或主机地址。
    Subnet Mask32比特目的地址的掩码。
    Next Hop32比特提供一个更好的下一跳地址。如果为0.0.0.0,则表示发布此路由的路由器地址就是最优下一跳地址。
    Metric32比特路由的开销值。对于Request报文,此字段为16。

    5.3 运行RIP-1和RIP-2版本的不同

    5.3.1 运行RIP-1的时候

    1. 对于请求消息或周期性的响应消息(情况1),IP报文的目的地址为广播地址255.255.255.255,源地址为发送该请求消息或响应消息的接口的IP地址,协议字段的值为0x11

    2. 为了回应请求消息而发送的响应消息(情况2),IP报文的目的地址为发送请求消息接口的IP地址,源地址为发送响应消息的接口的IP地址,协议字段0x11

      • 接下来,IP报文又是封装在以太网帧中(假设路由器的接口都是以太网接口)
    • 对于情况1,以太网帧的目的MAC地址是ff-ff-ff-ff-ff-ff,源地址是发送请求消息或响应消息的接口的MAC地址,类型字段为0x0800。

    • 对于情况2,以太网帧的目的MAC地址是发送请求消息的接口的MAC地址,源地址为发送该响应消息的接口的MAC地址,类型字段为0x0800。

    5.3.2 运行RIP-2的时候

    1. 对于请求消息或周期性的相应消息(情况1),IP报文的目的地址为组播地址224.0.0.9,也可以为广播地址255.255.255.255,源地址为发送该请求消息或响应消息的接口的IP地址,协议字段的值为0x11。

    2. 为了回应请求消息而发送的响应消息(情况2),IP报文的目的地址为发送请求消息接口的IP地址,源地址为发送响应消息的接口的IP地址,协议字段0x11。

      • 接下来,IP报文又是封装在以太网帧中(假设路由器的接口都是以太网接口)

        • 对于情况1,以太网帧的目的MAC地址是ff-ff-ff-ff-ff-ff,源地址是发送请求消息或响应消息的接口的MAC地址,类型字段为0x0800。

        • 对于情况2,以太网帧的目的MAC地址是发送请求消息的接口的MAC地址,源地址为发送该响应消息的接口的MAC地址,类型字段为0x0800。

    5.3.3 RIP-1与RIP-2的不同

    1. RIP-1只支持有类路由;RIP-2支持无类路由,支持VLSM,CIDP等特性;
    2. RIP-1不支持认证功能;RIP-2可以支持认证功能,因此安全性得到提高;
    3. RIP-1不能采用组播方式发布消息;RIP-2可以采用组播方式发布消息,因此RIP-2比RIP-1占用更少的设备处理资源;

    6. RIP定时器

    RIP协议有三种定时器:分别是更新定时器(Update Timer)无效定时器(Invalid Timer)垃圾收集定时器(Carbage Collection Timer)

    6.1 更新定时器

    更新定时器也可以称为周期定时器(Periodic Timer),每台RIP路由器都有一个属于自己的RIP更新定时器。缺省情况下,周期值为30s。每当更新定时器倒计时值为0时,路由器就会向所有邻居发送RIP响应消息,当路由器收到RIP请求消息时候,会立即发送RIP响应消息,但是不影响基于更新定时器的周期性RIP响应消息的发送

    6.2 无效定时器

    每个路由器都建立并维护一个无效定时器。缺省情况下,无效定时器值为180s(更新定时器周期的6倍)。当一个路由项的无效定时器的值倒计时为0时,就说明该路由表项已经有180s的时间没有别更新,此时路由表会认为该路由项已经变为一个无效的路由项,也就是认为该路由项所指的所指的目的地已经变为不可达,于是路由器会将该路由的cost值设置为16.

    6.3 垃圾收集定时器

    • 当无效定时器值倒计时为0时,该路由项是一个无效路由项,其cost值就会被设置为16。此时路由器不会立即将这个无效的路由项删除掉,而是会为该路由项启用一个被称为垃圾收集定时器的倒数计时器。垃圾收集定时器的缺省值为120s。

    • 在垃圾收集定时器倒计时为0之前,该路由器仍然会周期性在RIP响应消息中携带这条无效的路由信息,其目的是为了告诉他的所有邻居这条路由项对于自己来说已经无效,以便路由器能够及时对各自的RIP路由表中的相应的路由项进行更新。

    • 一旦垃圾收集定时器的值倒计时为0时,路由器就会将这条无效路由项删除。(注意:在垃圾收集定时器为0前的某一时刻,该无效路由被更新,即Cost的值更新为小于16,则该路由项的的无效定时器会被复位成初始值,然后重新计时,相应的垃圾收集定时器则会被删除掉

    7. RIP环路问题

    假设路由器C发生故障(E0接口down掉),RC监测到该故障后会立即向RB发送故障信息(跳数设置为16)表示10.4.0.0为无效路由。然而,在RC准备将这条无效路由周期性响应消息发给RB的时候,收到RB周期性的相应消息,其中包含10.4.0.0 网段的路由信息,那么这个时候RC就会认为通过RB可以到达10.4.0.0网段,所以RC就在10.4.0.0路由项的跳数上+1,RB又会从RC学习到这条路由并且会通告给自己的邻居,那么不断往复,就产生了环路。

    8. 环路解决

    华为的环路解决方案提供了触发更新水平分割毒性逆转三种

    8.1 触发更新

    • 所谓触发更新,就是指RIP路由表中的某些路由项的内容发生改变时,路由器应立即向它的所有邻居发布响应消息,而不用等待更新定时器所规定的下一个响应消息的发送时刻。(立即更新)

    • 另外,触发更新响应消息中只需要包含路由信息发生了改变的路由项,减少带宽及路由器处理资源的消耗

    注意如果对方未收到触发更新的消息,本端就收到一个周期性响应消息,这种情况下仍然会产生路由。但是触发更新在一定程度上降低了环路产生的概率。

    8.2 水平分割

    水平分割的原理是:如果一台路由器的RIP路由表中目的地/掩码为z/y的路由信息是通过该路由器的Interface-x接口学习来的,那么该路由器在通过Interface-x接口向外发送响应消息时,响应消息一定不要包含关于z/y这个路由项的信息。(从哪里学到就不发回哪里

    8.3 毒性逆转

    毒性逆转的原理是:如果一台路由器的RIP路由表中目的地/掩码为z/y的路由信息是通过该路由器的Interface-x接口学习来的,那么该路由通过Interface-x接口向外发送消息时,响应消息中仍然需要包含z/y这个路由项,但是这个路由项的Cost值总是16。

    里`)

    8.3 毒性逆转

    毒性逆转的原理是:如果一台路由器的RIP路由表中目的地/掩码为z/y的路由信息是通过该路由器的Interface-x接口学习来的,那么该路由通过Interface-x接口向外发送消息时,响应消息中仍然需要包含z/y这个路由项,但是这个路由项的Cost值总是16。

    展开全文
  • 一:按rip默认的version 1配置: 1:拓扑结构图 2:配置代码 R1: enable config terminal host r1 no ip domain-lookup int f0/0 ip address 10.0.1.2 255.255.255.0 no shut exit int f0/1 ip address 192....
  • 假设在校园网在地理上分为2个区域,每个区域内分别有一台路由器连接了2个子网,需要将两台...为了在未来每个校园区域扩充子网数量的时候,管理员不需要同时更改路由器的配置,计划使用RIP路由协议实现子网之间的互通。
  • RIP路由协议配置

    2020-05-07 21:45:03
    1、配置RIP动态路由协议,使得3台Cisco路由器模拟远程网络互联。 2、对运行中的RIP动态路由协议进行诊断。 二、实验原理:(写,该实验对应哪些协议?应用哪些技术?等等) RIP路由信息协议:是应用较早、使用较普遍...
  • 动态路由协议 路由往邻居上发包,然后互相学习。 不同的路由协议有不同的值,有的路由协议会定期发送给邻居,有些路由协议是触发性发送,就是当自己的网段发生改变或者增加时,会发送给相邻的路由,让他们学习。 ...
  • ®南昌大学实验报告学生姓名 ________学号 _专业班级______________________________实验类型 口验证■综合□设计□创新实验日期 2017/12/14__________实验成绩__________实验六动态路由协议RIP配置实训...
  • 路由信息协议RIP) 简介 (RIP/RIP2/RIPng:Routing Information Protocol) 作为一种内部网关协议或 IGP(内部网关协议),路由选择协议应用于 AS 系统。连接 AS 系统有专门的协议,其中最早的这样的协议是“EGP...
  • 借助Cisco Packet Tracer理解RIP路由协议实验 1.搭建网络 1.1 网络拓扑图如下: 将PC端和路由器的IP地址都写出来方便后面进行参数配置。 1.2 路由器基本配置并激活路由器接口 路由器R1配置后接口的IP信息如下 ...
  • 动态路由协议RIP工作原理一级目录二级目录三级目录 一级目录 二级目录 三级目录 配置实例 1、配置R1 <Huawei>sys Enter system view, return user view with Ctrl+Z. [Huawei]un in en Info: Information ...
  • RIP 路由协议

    2017-11-27 09:21:00
    RIP动态路由选择协议 routing information protocol IGP 小范围 路由器限制为15台 超过可能无法收敛 收敛概念 在一个域内 各个路由器知道各个网段的链路信息 接口 彼此学习 同步过程 称为收敛 好的路由选择协议...
  • RIP路由协议(距离矢量路由选择协议) 运行距离矢量的路由器就关心两样事情: 1、将路由通过广播或组播的形式发送给所有配置了该协议的接口。 2、从接口接收邻居路由器发来的路由信息,并根据距离和矢量的组合放入到...
  • 掌握在路由器上如何配置 RIP 路由协议。两台路由器通过快速以太网端口连接在一起,每个路由器上设置 2 个 Loopback 端口模拟子网,在所有端口运行 RIP 路由协议,实现所有子网间的互通。
  • RIP(Routing Information Protocol,路由信息协议) 可能会使用到的命令cisco版 #特权模式 查看路由表 show ip route write #全局模式 route rip #RIP进程中 version "1 or 2" no auto-summary network "宣告的网段...
  • 了解RIP路由协议的工作原理及基本配置 二、实验内容 连线连不上是因为中间的那个路由器端口不够,请开启WIC-2T模块 如何开启自行百度,不在详写 三:具体命令 这里Serial端口根据自己连线的图改成自己的就行! ...
  • rip路由协议

    2016-06-27 10:44:28
    ·RIP协议的特点:  1)RIP属于IGP,是Distance-Vector协议。  2)RIP是基于UDP的,端口号520  3)周期性以广(组)播向邻居发送更新。  4)做完整更新,将整个路由表的信息传递给邻居。  5)Metric(度量...
  • 实验 9 RIP 路由协议配置

    千次阅读 2017-04-28 22:17:03
    1.配置 RIP 动态路由协议,使得两台 Cisco2611 路由器模拟远程网络互联。 2.对运行中的 RIP 动态路由协议进行诊断。 三.实验设备: 路由器 Cisco 2621 两台,带有网卡的工作站 PC 两台,控制台电缆一条,交叉...
  • 思科动态路由协议RIP

    2019-09-01 16:36:53
    思科动态路由协议 规划网段(路由是隔离网段的) 配置每个节点IP地址。 R0 Router(config)#interface f0/0 Router(config-if)#no shutdown Router(config-if)#ip address 192.168.10.1 255.255.255.0 ...
  • 下面内容摘自笔者编著的网管员必读网络基础第2版一书111 RIP路由协议及工作原理 RIP工作原理路由器的收敛机制RIP报文格式 下面内容摘自笔者编著的《网管员必读——网络基础》(第2版)一书。 9.11.1 ...
  • RIP路由协议实验

    2021-06-25 20:47:14
    【实验题目】静态路由实验 【实验目的】掌握静态路由的配置和使用方法,熟悉交换机端口镜像的方法以及如何用于监视端口。 【实验内容】 实验结果和分析直接记录在下面每一个步骤后面(小组共用) 【实验记录】...
  • 04 RIP路由协议

    2015-11-18 17:14:18
    Enabling RIP:1、IGP2、DV3、RIP V1 V24、7层协议UDP520一个更新报文最多传输25条路由条目,如果大于25条路由条目则发生多个更新报文RIP的两种报文1、Request 2、Update最大6条负载均衡默认4条30S发送一次更新报文...
  • 内部网关协议——RIP简介“距离”三个要点~~距离向量算法~~优缺点dddd:坏消息传得慢RIP路由协议的版本4.动态路由5.相关代码开始实验1. 预备知识 1.内部网关协议[IGP] IGP,Interior Gateway Protocol 在一个自治...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 10,380
精华内容 4,152
关键字:

思科rip路由协议