精华内容
下载资源
问答
  • 思科动态路由协议配置,如RIP OSPF
  • 思科RIP路由协议配置

    千次阅读 2020-05-23 23:09:55
    是一种内部网关协议(IGP),是一种动态路由选择协议,用于自治系统(AS)内的路由信息的传递。RIP协议基于距离矢量算法(DistanceVectorAlgorithms),使用“跳数”(即metric)来衡量到达目标地址的路由距离。RIP...

    思科路由器RIP协议的配置
    (供自己参考学习)

    RIP简介

    RIP(Routing Information protocol) 路由信息协议.
    是一种内部网关协议(IGP),是一种动态路由选择协议,用于自治系统(AS)内的路由信息的传递。RIP协议基于距离矢量算法(DistanceVectorAlgorithms),使用“跳数”(即metric)来衡量到达目标地址的路由距离。RIP通过UDP报文进行路由信息交换,使用的端口号为520.

    RIP包括RIP-v1和RIP-v2两个版本

    RIPV1和RIPV2比较

    RIPV1 RIPV2
    有类路由协议 无类路由协议
    不支持VLSM 支持VLSM
    广播更新255.255.255.255 组播更新224.0.0.9

    实验
    在这里插入图片描述

    1. 首先配置PC2  PC3的IP地址
      PC1 192.168.10.2 MAC 255.255.255.0
      PC2 192.168.20.2 MAC 255.255.255.0
    2. R1的IP 10.0.0.1 255.255.255.252
    3. R2的IP 10.0.0.2 255.255.255.252
    4. 配置路由R1
      在这里插入图片描述
      Router>enable
      Router#conf t
      Router(config)#int g0/0(进入G0/0端口)
      Router(config-if)#no shutdown
      Router(config-if)#ip add 192.168.10.1 255.255.255.0 (配置G0/0端口的的IP地址)
      Router(config-if)#int g0/1
      Router(config-if)#no shutdown (开启端口)
      Router(config-if)#ip add 10.0.0.1 255.255.255.252
      Router(config)#route rip
      Router(config-router)#version 2
      Router(config-router)#network 192.168.10.0
      Router(config-router)#network 10.0.0.0
      Router(config-router)#no auto-summary
      Router(config-router)#ex
      在这里插入图片描述
      Router(config)#route rip (开启RIP协议)
      Router(config-router)#version 2 (启用RIPv2 )
      Router(config-router)#network 192.168.10.0 (宣告网段)
      Router(config-router)#network 10.0.0.0 (宣告网段)
      Router(config-router)#no auto-summary (关闭自动汇总)
      5.show ip route 查看路由信息
      6.配置R2
      在这里插入图片描述
      (全部同上)
      Router>en
      Router#conf t
      Router(config)#int g0/0
      Router(config-if)#no shutdown
      Router(config-if)#int g0/0
      Router(config-if)#ip add 192.168.20.1 255.255.255.0
      Router(config-if)#int g0/1
      Router(config-if)#no shutdown
      Router(config-if)#ip add 10.0.0.2 255.255.255.252
      Router(config-if)#ex
      Router(config)#route rip
      Router(config-router)#version 2
      Router(config-router)#ne
      Router(config-router)#network 192.168.20.0
      Router(config-router)#net
      Router(config-router)#network 10.0.0.2
      Router(config-router)#no au
      Router(config-router)#no auto-summary
      Router(config-router)#ex
      7.验证:PC
      在这里插入图片描述
    展开全文
  • 思科动态路由协议RIP

    2019-09-01 16:36:53
    思科动态路由协议 规划网段(路由是隔离网段的) 配置每个节点IP地址。 R0 Router(config)#interface f0/0 Router(config-if)#no shutdown Router(config-if)#ip address 192.168.10.1 255.255.255.0 ...

    思科动态路由协议

    1. 规划网段(路由是隔离网段的)
      

    在这里插入图片描述

    1. 配置每个节点IP地址。
      

    R0
    Router(config)#interface f0/0
    Router(config-if)#no shutdown
    Router(config-if)#ip address 192.168.10.1 255.255.255.0
    Router(config-if)#exit
    Router(config)#interface f0/1
    Router(config-if)#ip address 192.168.20.1 255.255.255.0
    Router(config-if)#no shutdown
    R1
    Router(config)#interface f0/0
    Router(config-if)#no shutdown
    Router(config-if)#ip address 192.168.20.2 255.255.255.0
    Router(config-if)#exit
    Router(config)#interface f0/1
    Router(config-if)#no shutdown
    Router(config-if)#ip address 192.168.30.1 255.255.255.0
    Router(config-if)#exit
    R2
    Router(config)#interface f0/0
    Router(config-if)#no shut
    Router(config-if)#ip address 192.168.30.2 255.255.255.0
    Router(config-if)#exit
    Router(config)#interface f0/1
    Router(config-if)#no shutdown
    Router(config-if)#ip address 192.168.40.1 255.255.255.0

    动态路由协议(RIP):
    配置起来相当简单。
    查看自已的路由表,然后把自已带C的网段添加rip就可以了。
    R0
    Router#show ip route
    C 192.168.10.0/24 is directly connected, FastEthernet0/0
    C 192.168.20.0/24 is directly connected, FastEthernet0/1
    Router#conf t
    Router(config)#
    Router(config)#router rip
    Router(config-router)#network 192.168.10.0
    Router(config-router)#network 192.168.20.0
    R1
    Router#show ip route
    C 192.168.20.0/24 is directly connected, FastEthernet0/0
    C 192.168.30.0/24 is directly connected, FastEthernet0/1
    Router#conf t
    Router(config)#router rip
    Router(config-router)#network 192.168.20.0
    Router(config-router)#network 192.168.30.0
    R2
    Router#show ip route
    C 192.168.30.0/24 is directly connected, FastEthernet0/0
    C 192.168.40.0/24 is directly connected, FastEthernet0/1
    Router#conf t
    Router(config)#router rip
    Router(config-router)#network 192.168.30.0
    Router(config-router)#network 192.168.40.0
    不管是静路由协议还是动态路由协议最终的目的都是为了让每台三层设备都有所有的网段。

    展开全文
  • rip动态路由协议配置 网络拓朴图 在R1上的全部配置 Router>enable Router#conf Router(config)#intf0/0 Router(config-if)#ipaddress192.168.0.1255.255.255.0 Router(con...

                         rip动态路由协议配置

    网络拓朴图

    R1上的全部配置

    Router>enable

    Router#conf

    Router(config)#int f0/0

    Router(config-if)#ip address 192.168.0.1 255.255.255.0

    Router(config-if)#no shutdown

    Router(config-if)#int s2/0

    Router(config-if)#ip address 192.168.1.1 255.255.255.0

    Router(config-if)#no shutdown

    Router(config-if)#exit

    Router(config)#router rip

    Router(config-router)#network 192.168.0.0

    Router(config-router)#network 192.168.1.0

    R2全部配置

    Router>enable

    Router#conf

    Router(config)#int s2/0

    Router(config-if)#ip address 192.168.1.2 255.255.255.0

    Router(config-if)#clock rate 128000

    Router(config-if)#no shutdown

    Router(config-if)#int s3/0

    Router(config-if)#ip address 192.168.2.1 255.255.255.0

    Router(config-if)#no shutdown

    Router(config-if)#exit

    Router(config)#router rip

    Router(config-router)#network 192.168.1.0

    Router(config-router)#network 192.168.2.0

    R3全部配置

    Router>enable

    Router#conf

    Router(config)#int s3/0

    Router(config-if)#ip address 192.168.2.2 255.255.255.0

    Router(config-if)#clock rate 128000

    Router(config-if)#no shutdown

    Router(config-if)#int f0/0

    Router(config-if)#ip address 192.168.3.1 255.255.255.0

    Router(config-if)#no shutdown

    Router(config-if)#exit

    Router(config)#router rip

    Router(config-router)#network 192.168.2.0

    Router(config-router)#network 192.168.3.0

    Router(config-router)#exit

    这时可以在三个路由器的特权模式下:show ip route

    Router#show ip route

    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

           * - candidate default, U - per-user static route, o - ODR

           P - periodic downloaded static route

    Gateway of last resort is not set

    R    192.168.0.0/24 [120/2] via 192.168.2.1, 00:00:21, Serial3/0

    R    192.168.1.0/24 [120/1] via 192.168.2.1, 00:00:21, Serial3/0

    C    192.168.2.0/24 is directly connected, Serial3/0

    C    192.168.3.0/24 is directly connected, FastEthernet0/0

    pc4  ip配置

    pc5  ip配置

    测试连通性

    使用pc5 ping pc4测试










    本文转自 guodong810 51CTO博客,原文链接:http://blog.51cto.com/guodong810/1033267,如需转载请自行联系原作者
    展开全文
  • 思科cisco路由器动态路由协议配置方法 配置IGRP动态路由协议 IGRP是...

    思科cisco路由器动态路由协议配置方法

    •  配置IGRP动态路由协议

          IGRP是EIGRP协议的前身,虽然现在基本被EIGRP协议所取代,但在一些特殊场合我们仍然会用到该动态路由协议。他的使用配置和EIGRP协议很相似。我们简单介绍一下。

        配置环境:

        ROUTER-A连接10.1.1.1/24和20.1.1.1/30两个网段,ROUTER-B连接20.1.1.1/30与30.1.1.1/24两个网段。如果不配置任何动态路由协议的话router-b将不知道到达10.1.1.1/24这个网段的路线,相应的A也不知道到达30.1.1.1/24这个网络。不配置IGRP协议的话PC2是不能成功PING通PC1的。下面我们在两台路由器上配置IGRP动态协议。

        配置命令:

        ROUTER-A:

        router igrp 65500    启动IGRP动态协议,并设置自治系统号为65500。

        小提示:自治系统号为1到65535的数,而且只有64512到65535可以让我们私用,其他自治系统号都用于公网中。


        network 10.0.0.0    宣告IGRP通告的网段,这里值得注意的是通告的网段要写主类形式即10.0.0.0,而不是类似OSPF一样写10.1.1.0的形式。(如图3)

        小提示:IGRP会自动在边界上归纳路由信息为主类IP地址而且自动归纳无法取消。

        ROUTER-B:

        router igrp 65500    启动IGRP动态协议,并设置自治系统号为65500,自治系统号要和A设置的一样才能正常通讯。

        network 30.0.0.0    宣告IGRP通告的网段,仍然要采用主类的方式。

        总结:配置完毕后在PC2上ping PC1计算机的IP地址是可以连通的,同理pc1也可以成功ping通PC2。这些都是因为IGRP动态协议对10.0.0.0与30.0.0.0网段宣告的结果。

    • 配置EIGRP动态路由协议

          EIGRP是结合了链路状态型和距离矢量型路由选择协议优点的CISCO专用协议。该混合协议具有快速收敛,减少带宽占用,支持多种网络层协议的特点。不过由于他是CISCO专用协议,所以其他厂商的路由器不支持该协议,他只应用于整个网络都是CISCO公司的路由器的情况。总的来说他是一种高级的距离矢量型路由选择协议,是从IGRP协议发展而来的。

        配置环境:

        ROUTER-A连接10.1.1.1/24和20.1.1.1/30两个网段,ROUTER-B连接20.1.1.1/30与30.1.1.1/24两个网段。如果不配置任何动态路由协议的话router-b将不知道到达10.1.1.1/24这个网段的路线,相应的A也不知道到达30.1.1.1/24这个网络。不配置EIGRP协议的话PC2是不能成功PING通PC1的。下面我们在两台路由器上配置EIGRP动态协议。


        配置命令:

        ROUTER-A

        router eigrp 65500    启动EIGRP动态协议,并设置自治系统号为65500。

        小提示:自治系统号为1到65535的数,而且只有64512到65535可以让我们私用,其他自治系统号都用于公网中。

        network 10.0.0.0    宣告EIGRP通告的网段,这里值得注意的是通告的网段要写主类形式即10.0.0.0,而不是类似OSPF一样写10.1.1.0的形式。

        小提示:EIGRP会自动在边界上归纳路由信息为主类IP地址,如果要想取消自动归纳则需要使用no auto-summary命令。

        ROUTER-B

        router eigrp 65500    启动EIGRP动态协议,并设置自治系统号为65500,自治系统号要和A设置的一样才能正常通讯。

        network 30.0.0.0    宣告EIGRP通告的网段,仍然要采用主类的方式。

        总结:配置完毕后在PC2上ping PC1计算机的IP地址是可以连通的,同理pc1也可以成功ping通PC2。这些都是因为EIGRP动态协议对10.0.0.0与30.0.0.0网段宣告的结果。

    • 配置OSPF动态路由协议

          OSPF协议也叫开放最短路径优先协议,他是一项链路状态型技术,与路由选择信息协议(RIP)这样的距离矢量型技术相对,OSPF协议完成各路由选择协议算法的两大主要功能是路径选择和路径交换。目前最新版本是OSPF版本2。OSPF是一种内部网关协议(IGP),也就是说他在属于同一自治系统的路由器间发布路由选择信息。

        目前OSPF是应用最广泛的动态路由协议,他不是CISCO专有的路由协议,可以互连CISCO,华为和实达等多个公司的路由器,兼容性非常不错。因此适合于中小企业路由的互连。

        配置环境:

        ROUTER-A连接10.1.1.1/24和20.1.1.1/30两个网段,ROUTER-B连接20.1.1.1/30与30.1.1.1/24两个网段。如果不配置任何动态路由协议的话router-b将不知道到达10.1.1.1/24这个网段的路线,相应的A也不知道到达30.1.1.1/24这个网络。不配置OSPF协议的话PC2是不能成功PING通PC1的。下面我们在两台路由器上配置OSPF动态协议。


        配置方法

        ROUTER-A

        router ospf 1    启动OSPF进程,进程号为1,值得注意的是进程号本地路由器有效。

        network 10.1.1.0 0.255.255.255 area 0    设置OSPF通告的网络范围,将对10.1.1.0/24这个网段通告。后头的0.255.255.255指的是反向掩码,他代表通告的网段的子网掩码是255.255.255.0。

        小提示:第二句也可以使用network 10.1.1.1 0.0.0.0 area 0代替,这样OSPF将宣告接口10.1.1.1连接的网络。


        ROUTER-B

        router ospf 1    启动OSPF进程,进程号为1。

        network 30.1.1.1 0.255.255.255 area 0    宣告30.1.1.0/24这个网段。

        小提示:第二句也可以使用network 30.1.1.1 0.0.0.0 area 0这个命令来宣告ROUTER-B上30.1.1.1这个接口连接的网段。

     

    转载于:https://www.cnblogs.com/wude/archive/2007/04/01/1941648.html

    展开全文
  • 一、网络拓扑搭建 二、命令配置 命令配置都是大同小异,这里我们简单看一下和pc4连接的路由器是怎么配置的 ...R2(config)#router rip(进入rip协议配置) R2(config-router)#version 2 (启...
  • RIP是一种动态路由协议,通常用于小到中型TCP/IP网络中,是一个使用距离矢量计算路由的可靠协议。动态路由与静态路由最大不同就是,动态路由无须手动配置一跳跳的路由,且可在网络通信流量或网络拓扑发生变化时能...
  • 路由协议一般工作在OSI参考模型的传输层或者应用层,常见的路由协议有RIP、OSPF、BGP(Border Gateway Protocol,边界网关协议)等。 可路由协议:又称为被路由协议,指可以被路由器在不同逻辑网段间路由的协议。可...
  • 1.RIP协议━━━━━━━━━┳━━━━━━━━━━━━━━━命令 ┃ 功能━━━━━━━━━╋━━━━━━━━━━━━━━━router ┃ 指定使用RIP协议━━━━━━━━━╋━━━━━━━━━━━━━━━...
  • 一、首先来看一下静态路由协议个动态路由协议的区别:静态路由:这种路由由网络管理员手动输入路由器命令管理。缺点:需要手工指定,网络过大无法使用。动态路由:这种路由由网络路由协议根据拓扑或流量改变而自动...
  • 思科 动态路由OSPF

    2020-01-23 11:37:22
    1.利用ospf动态路由协议完成各个子网网络之间的互联通信 2.利用ospf动态路由协议完成不同自治区域之间的互联通信 实验步骤 1.利用ospf动态路由协议完成各个子网网络之间的互联通信 拓扑图见上边 路由器和PC的配置 ...
  • OSPF(链路状态路由协议路由协议概述 按照AS分类 As是指由同一个技术管理机构管理、使用统一选路策略的一些路由器的集合。 【1】按自治系统分为 IGP:内部网关路由协议,运行在As内部的路由协议,主要解决As内部的...
  • 思科高级配置(RIP动态路由配置)

    千次阅读 2019-05-15 21:21:22
    问题 在相对较小而且结构不变的网络中,静态路由是很好的解决方案,它配置简单而且不过多消耗设备资源(动态路由协议在运行时要消耗路由器内部资源,在与其他...动态路由协议配置灵活,路由器会发送自身的路由信息...
  • 首先了解路由协议以及动态路由协议,路由协议(Routing protocol)是一种指定数据包转送方式的网络协议。Internet网络的主要节点设备是路由器,路由器通过路由表来转发接收到的数据包。转发策略可以是人工指定的,通过...
  • 思科仿真实验–RIP动态路由 实验设备 PC 2 台;Switch_3560 1 台;Router-PT 2 台;直连线;交叉线;DCE 串口线 设备配置情况 PC1 IP: 192.168.1.2 Submask: 255.255.255.0 Gateway: 192.168.1.1 PC2 IP: 192.168....

空空如也

空空如也

1 2 3 4 5 ... 7
收藏数 128
精华内容 51
关键字:

思科动态路由协议配置