精华内容
下载资源
问答
  • ospf动态路由协议配置
    千次阅读
    2021-12-30 10:41:50

    1. 配置PSPF

    在这里插入图片描述
    配置路由器 R1
    R1(config)#router ospf 1
    R1(config-router)#router-id 1.1.1.1
    R1(config-router)#network 1.1.1.0 255.255.255.0 area 0
    R1(config-router)#network 192.168.12.0 255.255.255.0 area 0

    2. 配置24位环回路由接口

    R2(config)#interface loopback 0
    R2(config-if)#ip ospf network point-to-point
    //环回接口 OSPF 路由条目的掩码长度都是 32 位,这是环回接口的特性,尽管通告了24 位,解决的办法是在环回接口下修改网络类型为“Point-to-Point”

    3. 显示 OSPF 进程及区域的细节

    R2#show ip ospf 1

    R2#show ip ospf interface s0/0/0

    R2#show ip ospf neighbor

    R2#show ip ospf database

    4. 设置接口的 cost值

    R2(config-if)#ip ospf cost
    //cost 的计算公式为 10^8/带宽(bps),然后取整,而且是所有链路入口的 cost 之和,环回接口的 cost 为 1

    5. 修改Hello 间隔(秒)

    ip ospf hello-interval

    6. 修改Dead 间隔(秒)

    ip ospf dead-interval

    7. 修改带宽

    R3(config)#router ospf 1
    R3(config-router)#bandwidth 1000

    8. 修改参考带宽

    R3(config)#router ospf 1
    R3(config-router)#auto-cost reference-bandwidth

    9. 修改接口优先级

    R1(config-router)#int f0/0
    R1(config-if)#ip ospf priority 1
    //优先级(范围为 0-255),优先级最高的被选举成 DR,默认情况下,多路访问网络的接口优先级为 1,点到点网络接口优先级为 0

    10. 重新选举 DR

    1.重新启动路由器
    2.clear ip ospf process

    11. OSPF 区域内注入一条默认路由

    R1(config-router)#default-information originate

    12. 查看达到网络 10.10.10.0/24 的 OSPF 开销

    R1#show ip route
    <省略部分输出>
    10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C 10.1.1.1/32 is directly connected, Loopback0
    O 10.10.10.0/24 [110/65] via 192.168.10.2, 00:16:56, Serial0/0/0
    172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
    C 172.16.1.16/28 is directly connected, FastEthernet0/0
    O 172.16.1.32/29 [110/65] via 192.168.10.6, 00:17:06, Serial0/0/1
    192.168.10.0/30 is subnetted, 3 subnets
    C 192.168.10.0 is directly connected, Serial0/0/0
    C 192.168.10.4 is directly connected, Serial0/0/1
    O 192.168.10.8 [110/128] via 192.168.10.6, 00:17:06, Serial0/0/1
    [110/128] via 192.168.10.2, 00:16:56, Serial0/0/0

    13. 查看 Serial 0/0/0 接口的带宽

    R1#show interfaces serial0/0/0

    Serial0/0/0 is up, line protocol is up (connected)
    Hardware is HD64570
    Internet address is 192.168.10.1/30
    MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load
    1/255
    Encapsulation HDLC, loopback not set, keepalive set (10 sec)
    Last input never, output never, output hang never
    Last clearing of “show interface” counters never
    Input queue: 0/75/0 (size/max/drops); Total output drops: 0
    <省略部分输出>

    14. 验证串行链路的开销

    R1#show ip ospf interface

    <省略部分输出>
    Serial0/0/0 is up, line protocol is up
    Internet address is 192.168.10.1/30, Area 0
    Process ID 1, Router ID 10.1.1.1, Network Type POINT-TO-POINT, Cost:
    1562

    Transmit Delay is 1 sec, State POINT-TO-POINT,
    Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:05
    Index 2/2, flood queue length 0
    Next 0x0(0)/0x0(0)
    Last flood scan length is 1, maximum is 1
    Last flood scan time is 0 msec, maximum is 0 msec
    Neighbor Count is 1 , Adjacent neighbor count is 1
    Adjacent with neighbor 10.2.2.2
    Suppress hello for 0 neighbor(s)
    Serial0/0/1 is up, line protocol is up
    Internet address is 192.168.10.5/30, Area 0
    Process ID 1, Router ID 10.1.1.1, Network Type POINT-TO-POINT, Cost:
    1562

    Transmit Delay is 1 sec, State POINT-TO-POINT,
    <省略部分输出>

    15. 配置 OSPF 开销

    R3(config)#interface serial0/0/0
    R3(config-if)#ip ospf cost 1562

    16. 验证是否已修改 Hello 计时器和Dead 计时器

    R2#show ip ospf interface serial0/0/0

    Serial0/0/0 is up, line protocol is up
    Internet address is 192.168.10.2/30, Area 0
    Process ID 1, Router ID 10.2.2.2, Network Type POINT-TO-POINT, Cost:
    1562
    Transmit Delay is 1 sec, State POINT-TO-POINT,
    Timer intervals configured, Hello 5, Dead 20, Wait 20, Retransmit 5
    Hello due in 00:00:00
    Index 3/3, flood queue length 0
    Next 0x0(0)/0x0(0)
    Last flood scan length is 1, maximum is 1
    Last flood scan time is 0 msec, maximum is 0 msec
    Neighbor Count is 1 , Adjacent neighbor count is 1
    Adjacent with neighbor 10.1.1.1
    Suppress hello for 0 neighbor(s)

    17. 验证与 R2 的相邻关系是否已恢复

    R1#show ip ospf neighbor

    Neighbor ID Pri State Dead Time Address
    Interface
    10.2.2.2 0 FULL/- 00:00:19 192.168.10.2
    Serial0/0/0
    10.3.3.3 0 FULL/- 00:00:34 192.168.10.6
    Serial0/0/1

    18. 查看是否为DB,BDR

    R2#show ip ospf interface

    FastEthernet0/0 is up, line protocol is up
    Internet address is 192.168.1.2/24, Area 0
    Process ID 1, Router ID 192.168.31.22, Network Type BROADCAST, Cost: 1
    Transmit Delay is 1 sec, State BDR, Priority 1
    Designated Router (ID) 192.168.31.33, Interface address 192.168.1.3
    Backup Designated Router (ID) 192.168.31.22, Interface address
    192.168.1.2
    Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:03
    Index 1/1, flood queue length 0
    Next 0x0(0)/0x0(0)
    Last flood scan length is 1, maximum is 1
    Last flood scan time is 0 msec, maximum is 0 msec
    Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 192.168.1.3 (Designated Router)
    Suppress hello for 0 neighbor(s)

    更多相关内容
  • 拓扑图: 配置代码: R1 enable config terminal ...OSPF路由协议的进程号为100,一个路由器上可启用多个OSPF进程,以进程号作为区别标志 network 192.168.1.0 0.0.0.255 area 1 router-id 192.168.1.1 !这个路
  • OSPF的基础配置/原理及认证

    OSPF配置方法,及认证

    ospf:开放式最短路径优先协议 ,IGP中的链路状态路由协议(应用层协议)
    开放式最短路径优先协议:如有多条线路可以到达目的,找一条开销最小的线路去转发
    ospf工作原理:是动态获取路由信息添加到路由表,然后根据路由表去转发。

    这次实验我用ensp软件来展示
    1.拿出三台路由器(AR2220为例)像我这样把拓扑搭建好。
    在这里插入图片描述
    2.将设备改名并配置好IP地址。
    路由器R1:

    <Huawei>system-view 	//进入系统视图
    [Huawei]sysname R1	    //修改名称为R1
    [R1]interface GigabitEthernet 0/0/0    //进入接口
    [R1-GigabitEthernet0/0/0]ip add 12.1.1.1 24   //配置IP地址,掩码24位
    [R1-GigabitEthernet0/0/0]quit        //返回上一级视图
    [R1]interface loop 0        //进入回环接口,做测试用	   
    [R1-LoopBack0]ip address 1.1.1.1 32   //配置IP地址
    

    路由器R2:

    <Huawei>system-view 	
    [Huawei]sysname R2
    [R2]interface g0/0/0
    [R2-GigabitEthernet0/0/0]ip address 12.1.1.2 24. 
    [R2-GigabitEthernet0/0/0]inter g0/0/1 
    [R2-GigabitEthernet0/0/1]ip add 23.1.1.2 24
    

    路由器R3:

    <Huawei>sys
    [Huawei]sys R3
    [R3]inter g0/0/1
    [R3-GigabitEthernet0/0/1]ip add 23.1.1.3 24
    [R3]interface loop 0
    [R3-LoopBack0]ip address 3.3.3.3 32
    

    在R2路由器ping R1和R3测试直连路由连通性

    [R2]ping 12.1.1.1    //ping,R1路由器接口IP地址测试能不能通
    [R2]ping 23.1.1.3
    

    3.配OSPF协议:
    路由器R1:

    [R1]ospf 1            //进入OSPF进程1 
    [R1-ospf-1]area 0     //进入区域0
    [R1-ospf-1-area-0.0.0.0]network 12.1.1.1 0.0.0.0  //把IP地址宣告进区域0里IP地址后面+"通配符"
    [R1-ospf-1-area-0.0.0.0]network 1.1.1.1 0.0.0.0     
    

    路由器R2:

    [R2]ospf 1
    [R2-ospf-1]area 0
    [R2-ospf-1-area-0.0.0.0]network 12.1.1.2 0.0.0.0
    [R2-ospf-1-area-0.0.0.0]network 23.1.1.2 0.0.0.0
    

    路由器R3:

    [R3]ospf 1
    [R3-ospf-1]area 0
    [R3-ospf-1-area-0.0.0.0]network 23.1.1.3 0.0.0.0
    [R3-ospf-1-area-0.0.0.0]network 3.3.3.3 0.0.0.0
    

    测试路由器R1能否ping通R3的回环地址:

    <R1>ping 3.3.3.3
    

    在这里插入图片描述
    配置OSPF时,进程号可以不同不会影响网络联通性,但内区域必须要一致,不同区域内是不能互通的(除一些特殊情况),在宣告地址时,想让别的已经运行OSPF的设备学到那些路由条目,你就宣告那些你有的路由。

    4.配置OSPF认证:
    认证可以在接口去配置,也可以在OSPF区域去配置,要记住接口认证的优先级要大于区域认证的优先级
    例如:你在区域启认证,但是你在接口配置空认证,那就遵循接口的配置,你就相当于没有认证。
    你在区域配置认证后:你这个设备的所有接口就都配置了认证。
    在这里插入图片描述
    路由器R1配置:

    [R1]ospf 1	
    [R1-ospf-1]area 0
    [R1-ospf-1-area-0.0.0.0]
    [R1-ospf-1-area-0.0.0.0]authentication-mode simple plain huawei   //在区域里配置明文的认证
    

    路由器R2的配置:

    [R2]ospf 1
    [R2-ospf-1]area 0
    [R2-ospf-1-area-0.0.0.0]authentication-mode simple plain huawei   
    [R2-ospf-1-area-0.0.0.0]interface GigabitEthernet 0/0/1
    [R2-GigabitEthernet0/0/1]ospf authentication-mode null    //在接口配置空认证
    

    我们这次的实验就完成啦,有不懂得积极在下方评论哦,我会第一时间回复哒

    展开全文
  • OSPF动态路由协议

    2022-01-18 22:33:58
    动态路由协议之中,OSPF(Open Shortest Path First,开放式最短路径优先)协议是使用场景非常广泛的动态路由协议之一。 OSPF在RFC2328中定义,是一种基于链路状态算法的路由协议。 本章节将初步介绍OSPF基本概念...

    目录:

    • OSPF协议概述
    • OSPF协议工作原理

    背景:

    由于静态路由由网络管理员手工配置,因此当网络发生变化时,静态路由需要手动调整,这制约了静态路由在现网大规模的应用。 动态路由协议因其灵活性高、可靠性好、易于扩展等特点被广泛应用于现网。

    在动态路由协议之中,OSPF(Open Shortest Path First,开放式最短路径优先)协议是使用场景非常广泛的动态路由协议之一。 OSPF在RFC2328中定义,是一种基于链路状态算法的路由协议。

    本章节将初步介绍OSPF基本概念、工作原理。

    对比:

    静态

    无法适应大规模网络

    无法动态响应网络变化

    动态

    灵活性高、可靠性好、易于扩展等特点

    动态路由协议及分类

    RIP——路由信息协议

    RIP(Routing Information Protocol,路由信息协议)是使用最久的协议之一。RIP是一种分布式的基于距离向量的路由选择协议,RIP协议是施乐公司20世纪80年代推出的,主要适用于小规模的网络环境。RIP协议主要用于一个AS(自治系统)内的路由信息的传递,每30s发送一次路由信息更新。 

    RIP应用于OSI网络七层模型的应用层。各厂家定义的管理距离(AD,即优先级)如下:华为定义的优先级是100,思科定义的优先级是120。

                                                                                            来自 <RIP协议_百度百科>

    OSPF——开放式最短路径优先

    OSPF(Open Shortest Path First开放式最短路径优先)是一个内部网关协议(Interior Gateway Protocol,简称IGP),用于在单一自治系统(autonomous system,AS)内决策路由。是对链路状态路由协议的一种实现,隶属内部网关协议(IGP),故运作于自治系统内部。著名的迪克斯彻(Dijkstra)算法被用来计算最短路径树。OSPF支持负载均衡和基于服务类型的选路,也支持多种路由形式,如特定主机路由和子网路由等。

                                                                                                    来自 <组播扩展OSPF_百度百科>

    IS-IS——中间系统到中间系统

    IS-IS(Intermediate System-to-Intermediate System,中间系统到中间系统)路由协议最初是ISO(the International Organization for Standardization,国际标准化组织)为CLNP(Connection Less Network Protocol,无连接网络协议)设计的一种动态路由协议。

                                                                                                                    来自 <is-is_百度百科>

    BGP——边界网关协议

    边界网关协议(BGP)是运行于TCP 上的一种自治系统路由协议。 BGP 是唯一一个用来处理像因特网大小的网络的协议,也是唯一能够妥善处理好不相关路由域间的多路连接的协议。 BGP 构建在 EGP 的经验之上。 BGP 系统的主要功能是和其他的 BGP 系统交换网络可达信息。网络可达信息包括列出的自治系统(AS)的信息。这些信息有效地构造了 AS 互联的拓扑图并由此清除了路由环路,同时在 AS 级别上可实施策略决策。

                                                                                                    来自 <边界网关协议_百度百科>

    距离矢量型路由协议

            周期性泛洪路由表

    问题——选择的路径不一定最优,也有可能产生环路(全是邻居告诉的——对端路由器)

    链路状态路由协议

            第一步建立邻居关系(运行同种协议的路由器)

            第二步建立LSDB

                    LSA泛洪

                    LSA信息——描述了路由器接口的状态信息,例如接口的开销、连接的对象等

                            结果:每个路由器形成一个LSDB链路状态的数据库

                    LSDB数据库

                            汇总了网络中路由器对于自己接口的描述

                            包含了全网拓扑的描述

            第三步进行SPF计算

                    SPF计算

                            每台路由器以自己为‘根’计算出到其他网段(除了自己的直连路由以外)的最优路径(无环的路径)

                            以开销做计算,开销与带宽成反比

            目的:完善路由表

            第四步生成路由表项

                    RIB路由信息表

    补:RIB——路由表,FIB——转发表

    RIB表和FIB表共享数据但是不是同一个表

    FIB是为了更快速的进行路由查表,而生成的一张简化路由表,查RIB表是由CPU完成,但是FIB是由硬件芯片完成,目的:简化了查表-递归的过程

    OSPF协议概述

    OSPF简介

    OSPF基本术语:

            Area(区域)——标识一个OSPF的区域

                    逻辑上将设备划分为不同组,每个组用区域号(Area ID)来标识

            Router-ID(路由标识符)——唯一的表示一台路由器

            度量值:默认情况下100M和1G的开销值都为1(因为1G为0.1但是cost最小为1)

    OSPF协议报文的五种类型

    OSPF三大表项

    邻居表

    LSDB表

    OSPF路由表

    注:OSPF路由表与IP路由表不是同一个表项,OSPF路由表到IP路由表要经过最优路径选择

    OSPF工作原理:

            建立邻居关系、邻接关系

    注:建立了邻居关系后林局表中的状态切换到2-Way(最初或是第一次知道时状态为Init)

    邻接关系的建立

    DD报文(协调主从关系——Router ID大的为主)

    注:路由器状态

    Exchange Start(Ex-start)——>Loading(表明正在做数据库同步)——>Full(同步完成之后)

    OSPF路由表建立

    OSPF网络类型(四种)

            Broadcast——广播类型

            NBMA——非广播的多点接入类型

            P2MP——点到多点类型

            P2P——点到点类型

    MA网络(多路访问网络):

            (1)BMA(支持广播的多路访问网络)----LAN

            (2)NBMA(不支持广播的多路访问网络)----帧中继

    MA网络中路由器接口的角色:

            DR——Designated Router(指定路由器)

            BDR——Backup Designated Router(备用指定路由器)

            DRother路由器——即不是DR又不是BDR的所有其他路由器接口

                    选举DR目的:减少邻接关系数量

    OSPF域与单区域、多区域

    注意点:

            1、OPSF域是指使用OPSF协议的路由器所在的同一个区域

            2、在OPSF多区域中区域边界的路由器可能会属于多个域

            3、多区域划分可以大致看作是同一个国家的不同城市划分

            目的:提高网络扩展性,减少了LSA泛洪范围,可以在边界路由汇总以达到优化网络

    OPSF路由器类型

            区域内路由器 IR

            区域边界路由器 ABR

            骨干路由器 BR ——(骨干区:Area 0)

            自治系统边界路由器 ASBR —— 连接了不同协议的路由器,需要做路由引入

     OSPF单区域、多区域的典型组网

    展开全文
  • ospf动态路由配置

    2018-03-10 19:57:24
    利用三层交换机和ospf协议来实现实现动态路由。有完整的拓扑图和命令
  • 实验十二 动态路由协议RIP配置 1 实验目的 (1)掌握动态路由协议的原理。 (2)掌握经典动态路由协议RIP的原理及过程。 (3)掌握动态路由协议RIP的配置过程。 2 实验内容 (1)依据相应的网络拓扑要求,在路由器上...

    实验十二 动态路由协议RIP配置
    1 实验目的
    (1)掌握动态路由协议的原理。
    (2)掌握经典动态路由协议RIP的原理及过程。
    (3)掌握动态路由协议RIP的配置过程。
    2 实验内容
    (1)依据相应的网络拓扑要求,在路由器上配置动态路由协议RIP,实现全网连通。
    3 实验原理
    动态路由是指网络中的路由器之间相互通信,并传递路由信息,再利用收到的路由信息更新路由表的过程。它能实时地适应网络结构的变化。如果路由更新信息表明发生了网络变化,路由选择协议就会重新计算路由,并发出新的路由更新信息。这些信息通过各个网络,引起各路由器重新启动其路由算法,并更新各自的路由表来动态地反映网络拓扑变化。动态路由适用于网络规模大,网络拓扑复杂的网络。
    RIP(路由信息协议)使用跳数作为唯一的度量值。在RIP中,规定跳数的最大值为15跳,16跳就视为不可达。RIP进程使用UDP(用户数据报协议)的520号端口发送和接收RIP分组,RIP分组每隔30s就从每个启动的RIP的接口发送路由更新信息。
    路由器接收到相邻路由器发送来的路由信息时,会与自己的路由表中的条目进行比较,如果路由表中已经存在这条路由信息,路由器就会比较新接收到的路由信息是否优子现在的条目,当优于现在的条目时,路由器会用新的路由信息替换原有的路由条目。反之,路由器会比较这条路由信息与原有的条目是否来自同一个源,如果来自同一个源,则更新,否则就忽略这条路由信息。
    4 实验步骤
    实验拓扑结构图如图1所示。
    在这里插入图片描述

    图 1 实验拓扑结构图
    1)基本配置
    (1)配置路由器dongrui_router1接口IP地址命令如下:
    在这里插入图片描述

    图 2 路由器dongrui_router1接口配置
    (2)配置路由器dongrui_router2接口IP地址命令如下:
    在这里插入图片描述

    图 3 路由器dongrui_router2接口配置
    (3)配置两台路由器的RIP命令如下:
    路由器dongrui_router1配置RIP:
    在这里插入图片描述

    图 4 路由器dongrui_router1配置RIP
    路由器dongrui_router2配置RIP:
    在这里插入图片描述

    图 5 路由器dongrui_router2配置RIP

    2)查看路由配置和网络连通性
    在这里插入图片描述

    图 6 路由配置和网络连通性
    实验十三 动态路由协议OSPF配置
    1 实验目的
    (1)掌握动态路由协议的原理。
    (2)掌握经典动态路由协议OSPF的原理及过程。
    (3)掌握动态路由协议OSPF的配置过程。
    2 实验内容
    (1)构建网络拓扑图。
    (2)配置PC机端口IP地址和路由器IP配置,配置动态路由协议OSPF,使PC之间能相互通信。
    (3)查看相关路由器配置信息。
    3 实验原理
    OSPF(Open Shortest Path First,开放式最短路径优先)协议是目前网络中应用最广泛的路由协议之一,其属于内部网关路由协议,能够适应各种规模的网络环境,是典型的链路状态(link-state)协议。
    动态路由协议OSPF通过向全网扩散设备的链路状态信息,使网络中的每台设备最终同步一个具有全网链路状态的数据库(LSDB)。路由器采用最短路径优先(SPF)算法,以自己为根,计算到达其他网络的最短路径,最终形成全网路由信息。OSPF属于无类路由协议,支持VLSM(变长子网掩码)。OSPF以组播的形式进行链路状态通告。
    4 实验步骤
    实验拓扑结构图如图7所示。
    在这里插入图片描述

    图 7 网络拓扑图
    2)基本配置
    (1)配置路由器1接口IP地址命令如下:
    R1
    en
    conf t
    int f0/0
    ip address 192.168.1.254 255.255.255.0
    no shut
    exit
    int s2/0
    ip address 192.168.3.1 255.255.255.0
    clock rate 64000
    no shut
    exit
    (2)配置路由器2接口IP地址命令如下:
    R2
    en
    conf t
    int f0/0
    ip address 192.168.2.254 255.255.255.0
    no shut
    exit
    int s2/0
    ip address 192.168.3.2 255.255.255.0
    no shut
    exit
    (3)配置两台路由器的RIP命令如下:
    路由器1配置RIP:
    router ospf 1
    network 192.168.1.0 0.0.0.255 area 1
    network 192.168.3.0 0.0.0.255 area 1
    end路由器2配置RIP:
    router ospf 1
    network 192.168.2.0 0.0.0.255 area 1
    network 192.168.3.0 0.0.0.255 area 1
    end
    3)路由器配置如下
    (1)路由器配置,如图8所示;
    在这里插入图片描述

    图 8 路由器配置
    (2)路由表查看,如图9所示;
    在这里插入图片描述

    图 9 路由表信息

    (2)通过在PC0、PC1、PC2、PC3上使用Ping命令来测试网络连通性,如图10和图11所示。

    在这里插入图片描述

    图 10 查看网络连通性
    在这里插入图片描述

    图 11 查看网络连通性

    展开全文
  • 动态路由协议OSPF配置

    千次阅读 2021-06-08 16:50:47
    (2)规划PC及路由器相关接口的IP地址,配置动态路由协议OSPF,使PC之间能相互通信; (3)使用命令查看每台路由器上的相关信息。三、实验仪器及环境 (1)路由器2台; (2)交换机2台; (3)PC4台; (4)双绞线、控制线、背靠背...
  • 详细写出每台路由器接口IP地址配置以及OSPF路由协议配置;利用路由显示命令,如show ip route,查看路由,并利用动态路由选择协议的冗余性测试链路发生故障后重新计算路由的过程;基于PacketTracer实现网络功能。 ...
  • RIP、OSPF动态路由协议

    千次阅读 2022-04-03 15:51:34
    RIP 1.应用层,基于UDP520端口 2.距离矢量协议 3.内部网关协议(IGP) 4.RIPV1无类,V2有类 5.管理距离=120,度量值为hop(跳数) OSPF (1)传输层协议 基于IP协议,...动态路由协议的分类 (1)基于运行特征来分类 距
  • 《实验报告OSPF动态路由配置》由会员分享,可在线阅读,更多相关《实验报告OSPF动态路由配置(5页珍藏版)》请在人人文库网上搜索。1、淮海工学院计算机工程学院实验报告书课程名:网络管理技术 题 目: 动态路由...
  • OSPF路由协议配置动态路由学习

    千次阅读 2021-03-23 13:38:44
     前一篇博客使用了 距离矢量路由协议的 RIP协议来动态配置路由。本篇博客学习使用OSPF协议实现动态路由。 一、OSPF的基本概念  OSPF(,开放的最短路径优先协议) 自治系统(AS):一个使用相同路由策略的区域; ...
  • 实验二:OSPF动态路由协议

    千次阅读 2019-09-22 16:19:42
    实验报告二:OSPF动态路由协议 实验拓扑图 Requirment: 网络拓扑如图所示,R1和R2作为某公司的人事部和销售部网关,连接到公司的总网关R3上,其中R1R2与R3用交换机相连,R4是公司的信息部门,信息部门有一台...
  • 动态路由OSPF路由协议

    2020-11-09 14:13:56
    动态路由——OSPF协议一、相关概念1.1自治系统(AS)1.2外部网关...动态路由协议可以理解为一种路由器之间用来交流的语言,而动态路由协议按照路由执行的算法可以分为: 1.距离矢量路由协议 依据从源网络到目标网络所经
  • 为了安全的原因,我们可以在相同OSPF区域的路由器上启用身份验证的功能,只有经过身份验证的同一区域的路由器才能互相通告路由信息。在默认情况下OSPF不使用区域验证。通过两种方法可启用身份验证功能,纯文本身份 ...
  • 动态路由OSPF协议实验

    2021-12-22 19:52:08
    利用ospf协议使主机之间能够互相访问 拓扑图ENSP 根据拓扑图配置主机地址 PC1:IP:192.168.1.1 子网掩码:255.255.255.252 网关:192.168.1.2 PC2:IP:192.168.7.2 子网掩码:255.255.252 网关:192.168....
  • OSPF动态路由协议--寻找最短路径

    千次阅读 2021-12-26 21:35:15
    OSPF动态路由协议--寻找最短路径一、简介二、CLI命令创建OSPF进程三、具体实现1. SWRoot2. RT0 一、简介 OSPF(Open Shortest Path First)为 IETF OSPF 工作组开发的一种基于链路状态的内部网关路由协议OSPF 是专...
  • 配置动态路由OSPF协议

    千次阅读 2020-03-22 14:50:18
    一、网络结构 (1) 交换机与PC机、交换机与路由器的连接由以太网接口用直连线连接即可(每个设备会自动生成无数个以太网接口f0/0、f0/1……) (2) 路由器之间是广域网之间连接,必须用...配置路由器Router...
  • OSPF动态路由协议原理与配置PPT教案.pptx
  • 实验5 动态路由协议RIP与OSPF的配置 实验学时2 一实验目的 1熟悉CISCO IOS和CLI命令...掌握RIP与OSPF路由协议及其配置 二实验设备与环境 Windows 2000 Server/Advance Server主机局域网CISCO Catalyst 2950交换机和260
  • 静态路由与动态路由协议OSPF、RIP笔记
  • 实训十RIPOSPF动态路由协议配置PPT学习教案.pptx
  • 之后我们开始配置动态路由 以R1 为例 ospf route-id 1.1.1.1 area 0 network 192.168.1.2 0.0.0.0 (地址为端口地址,后面为反子网掩码) 之后三台路由全部按照以上例子配置,之后我们进行验证用PC1 ping PC2...
  • OSPF路由协议通过向全网扩散本设备的链路状态信息,使网络中每台设备最终同步一个具有全网链路状态的数据库,然后路由器采用SPF算法,以自己为根,计算到达其他网络的最短路径,最终形成全网路由信息。 2.实验设备...
  • OSPF动态路由协议 拓扑图 配置pc的IP,子网掩码和网关 Pc1 IP 192.168.1.1 子网掩码 255.255.255.252 网关 192.168.1.2 Pc2 IP 192.168.5.2 子网掩码 255.255.255.252 网关 192.168.5.1 Pc3 IP 192...
  • 文章目录分析一、地址分配二、路由配置1.设置环回2.骨干分配3.测试三、启动OSPF1.宣告2.修改DR(干涉选举)四、拓展配置1.全网可达——边界路由设置2.保障安全——手工认证3.减少条目——汇总4.避免环
  • 文章目录拓扑图R1R2R3PING一下附 拓扑图 R1 配置接口IP地址 配置回环网口 ...reset ospf process ###重置OSPF进程 [Huawei]display ip routing-table ##查看路由表(可以查看再检查一下) ...
  • OSPF是链路状态路由协议OSPF(最短路径优先选择协议)工作过程最短路径:路径成本低,带宽越高。一直在学习链路状态信息 OSPF区域OSPF区域(Area 0为骨干区域,有且只有一个,其它区域都是非骨干区域)为了适应大型...
  • 动态路由协议——RIP、OSPF

    千次阅读 2022-02-19 20:56:05
    RIPV1:是一种有类别的距离矢量型路由协议(不传递网络掩码) RIPV2:是一种无类别的距离矢量型路由协议(传递网络掩码) 通过发送数据包进行路由信息的交互,request(请求) response (响应); 数据包封装...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 40,011
精华内容 16,004
关键字:

ospf动态路由协议配置

友情链接: abc.rar