精华内容
下载资源
问答
  • 华为三层交换机做DHCP Server

    千次阅读 2015-03-06 13:23:46
     vlan11:11.1.1.0 vlan12:12.1.1.0 ...dhcp enable ... dhcp select global  quit interface Vlanif 12  dhcp select global  quit
    




    vlan11:11.1.1.0

    vlan12:12.1.1.0



    L2(两台)
    system-view

    interface e0/0/1
     port link-type access
     undo shutdown

    interface e0/0/2
     port link-type access
     undo shutdown
     quit

    vlan 11
     port e0/0/1
    vlan 12
     port e0/0/2
     quit

    interface g0/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
     undo shutdown
     quit

    L3
    system-view

    port-group group-member g0/0/1 to g0/0/2
     port link-type trunk
     port trunk allow-pass vlan all
     undo shutdown
     quit

    vlan 11
    vlan 12
     quit

    interface Vlanif 11
     ip add 11.1.1.1 255.255.255.0
     quit

    interface Vlanif 12
     ip add 12.1.1.1 255.255.255.0
     quit



    dhcp enable

    ip pool vlan11
     network 11.1.1.0 mask 255.255.255.0
     gateway-list 11.1.1.1
     dns-list 11.1.1.1
     lease day 1

    ip pool vlan12
     network 12.1.1.0 mask 255.255.255.0
     gateway-list 12.1.1.1
     dns-list 12.1.1.1
     lease day 1

    interface Vlanif 11
     dhcp select global
     quit

    interface Vlanif 12
     dhcp select global
     quit

    展开全文
  • 当然这只是实验中这么来,现实中考虑到通信速率的...LSW1三层交换机 undo t m sys vlan 10 vlan 20 int g0/0/1 port link-type ac port default vlan 10 int g0/0/2 port link-type ac port default vlan 20 q dhcp

    当然这只是实验中这么来做,现实中考虑到通信速率的问题DHCP服务会交给专门的DHCP服务器来做,所以更多的时候会布置DHCP中继来指向DHCP服务器,关于中继的问题可以看我的下一篇博客。
    在这里插入图片描述
    配置脚本:

    DHCP服务配置
    LSW1三层交换机
    undo t m
    sys
    vlan 10
    vlan 20
    int g0/0/1
    port link-type ac
    port default vlan 10
    int g0/0/2
    port link-type ac
    port default vlan 20
    q
    dhcp enable
    int vlan 10
    ip add 192.168.10.254 24
    dhcp select global
    ip pool vlan10
    network 192.168.10.0 mask 255.255.255.0
    gateway-list 192.168.10.254
    dns-list 192.168.100.1
    excluded-ip-address 192.168.10.66
    q
    int vlan 20
    ip add 192.168.20.254 24
    dhcp select global
    ip pool vlan20
    network 192.168.20.0 mask 255.255.255.0
    gateway-list 192.168.20.254
    dns-list 192.168.100.1
    excluded-ip-address 192.168.20.66
    q
    

    下面我来说一下几个配置中的参数:
    dhcp enable 开启DHCP服务
    int vlan 10 进入vlan10
    ip add 192.168.10.254 24 配置vlan10网关
    dhcp select global 配置DHCP全局模式,中继的话使用relay
    ip pool vlan10 为vlan10创建一个地址池
    network 192.168.10.0 mask 255.255.255.0 给地址池创建用于分配的地址范围和子网掩码
    gateway-list 192.168.10.254 设置分配地址的网关也就是vlan的网关
    dns-list 192.168.100.1 配置dns服务器地址
    excluded-ip-address 192.168.10.66 配置不参与分配的IP地址
    static-bind ip-address 【192.168.10.xx】 mac-address 【mac地址】锁定分配给某台主机的IP地址
    主机启用DHCP服务:
    在这里插入图片描述
    这里要注意一个小细节,修改设置后一定要点右下角的应用,不然配置无法生效
    查看地址获取情况:
    在这里插入图片描述

    展开全文
  • 华为ensp三层交换机DHCP中继代理配置

    千次阅读 2020-09-07 11:31:21
    使用三层交换机做DHCP的中继代理 拓扑图如图所示 R1的配置如下 sysname R1 # dhcp enable # ip pool dhcp1 gateway-list 192.168.2.1 network 192.168.2.0 mask 255.255.255.0 lease day 7 hour 0 minute 0 ...

    三层交换机DHCP中继代理配置

    使用三层交换机做DHCP的中继代理
    拓扑图如图所示

    在这里插入图片描述
    R1的配置如下

     sysname R1
    #
    dhcp enable
    #
    ip pool dhcp1
     gateway-list 192.168.2.1 
     network 192.168.2.0 mask 255.255.255.0 
     lease day 7 hour 0 minute 0 
     dns-list 114.114.114.114 8.8.8.8 
    #
    ip pool dhcp2
     gateway-list 192.168.3.1 
     network 192.168.3.0 mask 255.255.255.0 
     lease day 7 hour 0 minute 0 
     dns-list 114.114.114.114 8.8.8.8 
    #
    ip pool dhcp3
     gateway-list 192.168.1.1 
     network 192.168.1.0 mask 255.255.255.0 
     lease day 7 hour 0 minute 0 
     dns-list 114.114.114.114 8.8.8.8 
    #
    
    interface GigabitEthernet0/0/0
     ip address 192.168.100.100 255.255.255.0 
     dhcp select global
    #
    
    ip route-static 192.168.1.0 255.255.255.0 192.168.100.1
    ip route-static 192.168.2.0 255.255.255.0 192.168.100.1
    ip route-static 192.168.3.0 255.255.255.0 192.168.100.1
    

    3层交换机的配置如下3

    
    #
    sysname L3
    #
    vlan batch 2 to 3 100
    #
    dhcp enable
    #
    interface Vlanif1
     ip address 192.168.1.1 255.255.255.0
    #
    interface Vlanif2
     ip address 192.168.2.1 255.255.255.0
     dhcp select relay
     dhcp relay server-ip 192.168.100.100
    #
    interface Vlanif3
     ip address 192.168.3.1 255.255.255.0
     dhcp select relay
     dhcp relay server-ip 192.168.100.100
    #
    interface Vlanif100
     ip address 192.168.100.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 3 100
    

    2层交换机的配置如下

    sysname L2
    #
    vlan batch 2 to 3 100
    #
    interface Vlanif100
     ip address 192.168.100.101 255.255.255.0
    #
    interface Ethernet0/0/1
     port link-type access
     port default vlan 2
    #
    interface Ethernet0/0/2
     port link-type access
     port default vlan 3
    #
    interface GigabitEthernet0/0/1
     port link-type access
     port default vlan 100
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 to 3 100
    

    2台PC机只需要设置DHCP
    在这里插入图片描述
    实验结果如下图所示

    测试与DHCP服务器的连通性
    在这里插入图片描述
    测试客户机与客户机的连通性
    在这里插入图片描述

    展开全文
  • 关于华为交换机配置教程搜集整理了一下,从基础组网,对接防火墙、多种方式的设备登录开始,一直到安全认证、故障处理,...2、作为三层交换机使用,部署用户的网关,实现跨网段数据访问。三种典型组网1.一个用户pc...

    关于华为交换机配置教程搜集整理了一下,从基础组网,对接防火墙、多种方式的设备登录开始,一直到安全认证、故障处理,内容比较全面细致。近期更新一下,更新完了之后做一个汇总。有需要的可以关注一下。


    交换机在局域网中的应用

    交换机在局域网中的应用分为两种:

    1、作为二层交换机使用,为多个用户划分VLAN,实现同网段数据访问。

    2、作为三层交换机使用,部署用户的网关,实现跨网段数据访问。

    三种典型组网

    1.一个用户pc链接一台交换机,通过路由器接入外部网络。

    4bca7eda12508d4ba3f960f5d7230b46.png

    2.两个用户pc同时接入一台交换机,然后通过路由器接入外部网络。

    54ce6362d482505bfa4d62dfb7a2d31b.png

    3.多个用户pc分别接入多台交换机,然后通过路由器接入外部网络

    329884192630d97c4be70cbfca5452ec.png

    PC属于同一局域网同一网段时,交换机不需要任何配置,可以直接使用。

    45f5a5e6b236d555ab6fa4da406c6f17.png

    二层交换机在局域网中的应用

    如果用户pc属于不同局域网,二层交换机需要如何配置才可以接入外部网络呢?

    如图所示:

    54ce6362d482505bfa4d62dfb7a2d31b.png
    • 用户PC1和PC2的属于不同的VLAN域。PC1属于VLAN2,PC2属于VLAN 3。
    • PC1的IP地址是10.2.1.2/24,网关是10.2.1.1/24;PC2的IP地址是10.3.1.3/24 ,网关是10.3.1.1/24 。
    • 用户PC1和PC2的IP地址属于同一网段,且网关都部署在路由器上。

    配置思路和配置步骤

    路由器需要做的配置是,连接交换机的接口,配置两个子接口。

    子接口1:

    IP地址是10.2.1.1/24, 终结VLAN2。

    子接口2:

    IP地址是10.3.1.1/24,终结VLAN3。

    第一步:批量创建VLAN 2和VLAN 3

     system-view[Switch] vlan batch 2 to 3

    第二步:配置连接PC的接口GE0/0/1和GE0/0/2,以access方式加入对应VLAN。

    [Switch] interface  GigabitEthernet 0/0/1[Switch-GigabitEthernet0/0/1] port link-type access[Switch-GigabitEthernet0/0/1] port default vlan 2[Switch-GigabitEthernet0/0/1] quit[Switch] interface  GigabitEthernet 0/0/2[Switch-GigabitEthernet0/0/2] port link-type access[Switch-GigabitEthernet0/0/2] port default vlan 3[Switch-GigabitEthernet0/0/2] quit

    第三步:配置连接路由器的接口GE0/0/3,以trunk方式加入VLAN 2和VLAN 3。

    [Switch] interface  GigabitEthernet 0/0/3[Switch-GigabitEthernet0/0/3] port link-type trunk[Switch-GigabitEthernet0/0/3] port trunk allow-pass vlan 2 to 3[Switch-GigabitEthernet0/0/3] quit

    这样交换机的配置就完成了。

    三层交换机在局域网中的应用

    如图所示:

    e04100ebe51fa87865c0065643165faf.png
    • 用户PC1和PC2的属于不同的VLAN域。PC1属于VLAN20,PC2属于VLAN 30。
    • PC1的IP地址是20.2.1.2/24,网关是20.2.1.1/24;PC2的IP地址是30.3.1.3/24 ,网关是30.3.1.1/24 。
    • 用户PC1和PC2的IP地址不是同一网段,且网关部署在交换机上。

    要求:用户PC1和PC2可以通过交换机和路由器访问外部网络。

    配置思路

    路由器的配置:

    • 子接口配置IP地址和终结VLAN

    IP地址是10.2.1.1/24, 终结VLAN2

    • 路由器已经存在访问用户的静态路由:

    ip route-static 20.2.1.0 255.255.255.0 10.2.1.2

    ip route-static 30.3.1.0 255.255.255.0 10.2.1.2

    交换机配置:

    第一步:批量创建VLAN 2、VLAN 20和VLAN30

    第二步:配置VLANIF接口

    第三步:配置连接PC的接口GE0/0/1和GE0/0/2

    第四步:配置连接路由器的接口GE0/0/3

    第五步:配置缺省路由

    配置步骤:

    第一步:批量创建VLAN 2、VLAN 20和VLAN30

     system-view[Switch] vlan batch 2 20 30

    第二步:配置VLANIF接口

    [Switch] interface Vlanif  2[Switch-Vlanif2] ip address 10.2.1.2 24[Switch-Vlanif2] quit[Switch] interface Vlanif  20[Switch-Vlanif20] ip address 20.2.1.1 24[Switch-Vlanif20] quit[Switch] interface Vlanif  30[Switch-Vlanif30] ip address 30.3.1.1 24[Switch-Vlanif30] quit

    第三步:配置连接PC的接口GE0/0/1和GE0/0/2

    [Switch] interface  GigabitEthernet 0/0/1[Switch-GigabitEthernet0/0/1] port link-type access[Switch-GigabitEthernet0/0/1] port default vlan 20[Switch-GigabitEthernet0/0/1] quit[Switch-GigabitEthernet0/0/2] port link-type access[Switch-GigabitEthernet0/0/2] port default vlan 30[Switch-GigabitEthernet0/0/2] quit

    第四步:配置连接路由器的接口GE0/0/3

    [Switch-GigabitEthernet0/0/3] port link-type trunk[Switch-GigabitEthernet0/0/3] port trunk allow-pass vlan 2[Switch-GigabitEthernet0/0/3] quit

    第五步:配置缺省路由

    [Switch] ip route-static 0.0.0.0 0.0.0.0 10.2.1.1

    这样交换机的配置就完成了。


    下一篇为大家介绍一下二、三层交换机与防火墙的对接,欢迎持续关注。

    更新完了之后会做一个汇总放在主页栏目里面。

    展开全文
  • 实验拓扑实验需求1、C1与C3属于VLAN10,C2与C4属于VLAN20,在SW1上创建VLAN100上行VLAN2、在SW1上终结所有VLAN3、在所有VLAN成员使用DHCP获取IP4、全网互通IP规划VLAN10 :192.168.10.0/24VLAN20 :192.168.20.0/...
  • 之前有人提出华为交换机关于DHCP中继配置方面的问题,我了一个简单的测试,将测试结果分享给大家。 测试拓扑结构: sys#进入系统视图 sysname dhcptest #设备重命名 dhcp enable#启用DHCP功能 Vlan 2....
  • f99b4cbdf76d478393de658f5c53f6ca-300x220.jpg (8.78 KB, 下载次数: 22)华为S7706交换机DHCP Server 配置不成功问题2016-6-10 14:22 上传问题描述如...在S5700设备上做DHCP中继,S7706和S5700之间用vlan 40三层互联...
  • DHCP服务---三层交换机

    2020-10-27 18:56:21
    使用华为三层交换机做DHCP服务,实现为客户机提供DHCP服务
  • 华为 三层交换机VLAN间路由配置详解

    千次阅读 2015-07-11 16:55:54
    实验拓扑实验需求1、C1与C3属于VLAN10,C2与C4属于VLAN20,在SW1上创建VLAN100上行VLAN2、在SW1上终结所有VLAN3、在所有VLAN成员使用DHCP获取IP4、全网互通IP规划VLAN10 :192.168.10.0/24VLAN20 :192.168.20.0/...
  • 假设IP地址10.1.1.2,MAC地址0000-0000-0001[b]1、IP+MAC+端口绑定流程[/b]华为三层交换机中目前只有S3526系列支持使用AM命令来进行IP地址和端口的绑定。并且如果S3526系列交换机要采用AM命令来实现绑定功能,则...
  • 实验拓扑 LSW2上中继服务,R1上部署DHCP服务 二层交换机配置 三层交换机配置如下(作中继)
  • 华为防火墙跨三层mac识别配置

    千次阅读 2020-09-08 17:04:48
    但是局域网一般都是三层,尤其是开启了DHCP的局域网,大家都知道二层是mac地址,三层是IP,显然三层交换机发给上层设备防火墙的是IP,并非mac;但是三层交换下接二层交换机,二层交换机将mac地址告诉了.
  • DHCP中继实验(华为ENSP模拟)

    千次阅读 2020-09-10 22:08:11
    实验要求:在三层交换机做DHCP中继转发,PC1~4利用DHCP获得IP地址 实验拓扑图如下 三层交换机L3-SW1配置如下 二层交换机L2-SW1配置如下 R1交换机配置如下 设置PC机为DHCP获取地址,结果如下 PC1...
  • 十三、交换路由综合实验一组网需求:1、利用三层交换机实现不同VLAN间通信2、实现三层交换机和路由器互联互通3、设置三层交换机DHCP功能4、路由器上NAT实现主机上网5、发布服务器映射,实现外网访问服务器6、可以...
  • eNSP 华为模拟器 配置DHCP服务器实验 一、实验概述 二、路由器的配置 三、三层交换机的配置 四、实验结果 一、实验概述 实验二 实验内容:主要了解Ensp工具的使用。了解协议在路由器中是如何存放的及存放的位置。...
  • 配置中继的原因我在上篇中已经说过了,因为三层交换机等主要维持数据层面的交换功能,所以DHCP服务由专门的DHCP服务器来完成,而这时想让主机找到DHCP服务器就需要在三层设备上中继将DHCP服务指向服务器地址。...
  • 说明 之前介绍过华为的交换机,华为...拓扑说明:有3个VLAN用户,一个VLAN2,另外一个VLAN3,连接二层交换机,二层交换机连接三层交换机,然后连接出口路由器 NAT,让下面的用户能够访问Internet。这里DHCP的应用...
  • 文章目录实验题·DHCP中继实验环境需求分析实验步骤设置二层交换机sw2设置三层交换机sw1设置CentOS 7.6 DHCP中继服务去华为模拟器里面在PC1、PC2去获取IP地址 实验环境 需求分析 Cloud1 使用虚拟机CentOS 7.6 来...
  • 要求三层楼每层2个ap,确保无线可以实现全面的覆盖,dhcp获取地址。 核心交换机上,为ap单独划分vlan16,并配置vlan16 的IP地址:172.16.16.254/24 ,DHCP服务器在服务器上,核心交换机做一条中继即可!这里注意...
  • 小型企业园区组网实验

    千次阅读 2020-04-23 22:46:43
    小型企业园区组网实验 ...每个部门划分到不同的VLAN ,部门间在核心交换机之间通过VLANIF 三层互通 核心层作为DHCP SERVER为用户分配IP地址; 内网服务NAT 服务器映射到公网; 核心交换机和出口路由器...

空空如也

空空如也

1 2
收藏数 25
精华内容 10
关键字:

华为三层交换机做dhcp