精华内容
下载资源
问答
  • 基于协议划分VLAN

    千次阅读 2019-01-09 21:39:02
    基于协议划分VLAN是根据不同网络层协议(包括IPv4、IPX、AppleTalk等协议)进行的VLAN划分,不是根据具体类型的网络层地址进行VLAN划分。 配置实例  (1)创建所需要的协议VLAN10和VLAN20。 (2)配置网络层...

    基于协议划分VLAN是根据不同网络层协议(包括IPv4、IPX、AppleTalk等协议)进行的VLAN划分,不是根据具体类型的网络层地址进行VLAN划分。

    配置实例

     (1)创建所需要的协议VLAN10和VLAN20。

    (2)配置网络层协议与以上协议VLAN产关联。

    [SwitchA]vlan 10
    [SwitchA-vlan10]protocol-vlan ipv4
    [SwitchA-vlan10]q
    [SwitchA]vlan 20
    [SwitchA-vlan20]protocol-vlan ipv6
    [SwitchA-vlan20]

    (3) 配置端口类型及允许通过的协议VLAN。注意,与LSW2连接的G0/0/24端口要允许所有的协议VLAN通过,并且必须是Hybird类型。

    interface GigabitEthernet0/0/24
     port hybrid tagged vlan 1 to 4094

        

    interface GigabitEthernet0/0/1
     port hybrid untagged vlan 10
     protocol-vlan vlan 10 0 priority 0
    #
    

     

    display protocol-vlan interface all

    [SwitchA]display protocol-vlan interface all 
    -------------------------------------------------------------------------------
     Interface                VLAN    Index        Protocol Type           Priority
    -------------------------------------------------------------------------------
     GigabitEthernet0/0/1     10      0            IPv4                    0
     GigabitEthernet0/0/2     10      0            IPv4                    0
     GigabitEthernet0/0/3     20      0            IPv6                    0
     GigabitEthernet0/0/4     20      0            IPv6                    0
    

     

    展开全文
  • 基于协议划分VLAN 某企业拥有多种业务,如IPTV、VoIP、Internet等,每种业务使用的协议不同,为了便于管理,现在需要将同一种类型业务划分到同一个VLAN中,不同类型的业务划分到不同的VLAN中; 创建VLAN: [sw1]...

    基于协议划分VLAN

    某企业拥有多种业务,如IPTV、VoIP、Internet等,每种业务使用的协议不同,为了便于管理,现在需要将同一种类型业务划分到同一个VLAN中,不同类型的业务划分到不同的VLAN中;
    在这里插入图片描述

    创建VLAN:
    [sw1]vlan batch 10 20
    [sw2]vlan batch 10 20

    配置协议关联VLAN:
    [sw2]vlan 10
    [sw2-vlan10]protocol-vlan ?
    INTEGER<0-15> Protocol index
    at AT(AppleTalk Protocol) configuration information
    ipv4 IPv4 configuration information
    ipv6 IPv6 configuration information
    ipx IPX(Internetwork Packet eXchange) configuration information
    mode Other protocol mode configuration information
    [sw2-vlan10]protocol-vlan ipv4
    [sw2-vlan10]quit

    [sw2]vlan 20
    [sw2-vlan20]protocol-vlan ipv6
    [sw2-vlan20]quit

    配置接口关联协议VLAN:
    [sw2]int g0/0/1
    [sw2-GigabitEthernet0/0/1]protocol-vlan vlan 10 ?
    INTEGER<0-15> Protocol index
    all All the protocols of the VLAN

    [sw2-GigabitEthernet0/0/1]protocol-vlan vlan 10 all priority ?
    INTEGER<0-7> The priority ID

    [sw2-GigabitEthernet0/0/1]protocol-vlan vlan 10 all priority 5
    [sw2-GigabitEthernet0/0/1]quit

    配置接口划入对应VLAN、配置Trunk:
    [sw2]int g0/0/3
    [sw2-GigabitEthernet0/0/3]port link-type trunk
    [sw2-GigabitEthernet0/0/3]port trunk allow-pass vlan 10 20
    [sw2-GigabitEthernet0/0/3]quit

    [sw2]int g0/0/1
    [sw2-GigabitEthernet0/0/1]port link-type access
    [sw2-GigabitEthernet0/0/1]port default vlan 10
    [sw2-GigabitEthernet0/0/1]quit

    [sw2]int g0/0/2
    [sw2-GigabitEthernet0/0/2]port link-type access
    [sw2-GigabitEthernet0/0/2]port default vlan 20
    [sw2-GigabitEthernet0/0/2]quit

    [sw1]int g0/0/3
    [sw1-GigabitEthernet0/0/3]port link-type trunk
    [sw1-GigabitEthernet0/0/3]port trunk allow-pass vlan 10 20
    [sw1-GigabitEthernet0/0/3]quit

    [sw1]int g0/0/1
    [sw1-GigabitEthernet0/0/1]port link-type trunk
    [sw1-GigabitEthernet0/0/1]port trunk allow-pass vlan 10
    [sw1-GigabitEthernet0/0/1]quit

    [sw1]int g0/0/2
    [sw1-GigabitEthernet0/0/2]port link-type trunk
    [sw1-GigabitEthernet0/0/2]port trunk allow-pass vlan 20
    [sw1-GigabitEthernet0/0/2]quit

    查看配置结果:
    [sw2]display protocol-vlan interface all
    /-------------------------------------------------------------------------------
    Interface VLAN Index Protocol Type Priority
    /-------------------------------------------------------------------------------
    GigabitEthernet0/0/1 10 0 IPv4 5
    GigabitEthernet0/0/2 20 0 IPv6 6

    展开全文
  • ##配置基于协议划分 VLAN

    千次阅读 2018-10-25 19:03:18
    协议划分VLAN特点是减少了人工配置 VLAN的工作量, 同时保证了用户自由地增加、 移动和修改. 组网需求 某企业拥有多种业务,如 IPTV、 VoIP、Internet 等,每种业务所采用的协议各不相同。为了便于管理,减少人工...

    按协议划分VLAN特点是减少了人工配置 VLAN的工作量, 同时保证了用户自由地增加、 移动和修改.
    组网需求
    某企业拥有多种业务,如 IPTV、 VoIP、Internet 等,每种业务所采用的协议各不相同。为了便于管理,减少人工配置 VLAN的工作量,现需要将同一种类型业务划分到同一 VLAN中,不同类型的业务划分到不同 VLAN中。
    Switch 收到的用户报文有多种业务,所采用的协议各不相同。 VLAN10中的
    用户采用 IPv4 协议与远端用户通信, 而 VLAN20中的用户采用 IPv6 协议与远端服务器通信。
    现需要将不同类型的业务划分到不同的 VLAN中,通过不同的 VLAN ID 分流到不同的远端服
    务器上以实现业务互通。
    在这里插入图片描述
    配置思路
    采用如下的思路配置基于协议划分 VLAN:
    创建 VLAN,确定每种业务所属的 VLAN。
    关联协议和 VLAN。
    Switch 根据端口接收到的报文所属的协议 (族) 类型给报文分配不同的 VLAN ID。无论用户物理位置是否移动、用户主机网卡是否更换、用户是否在同一网段、只要用户设备所采用的协议没有变换, VLAN都不用再重新划分。关联接口和协议 VLAN。当有关联的协议进入关联的接口时,系统自动为该协议分配已经划分好的 VLAN ID。
    允许基于协议的 VLAN通过当前端口。
    数据准备
    为完成此配置例,需准备如下的数据。
    在 Switch 上配置接口 GE0/0/1 以 untagged 方式加入 VLAN10、VLAN20。
    在 Switch 上配置接口 GE0/0/2 、GE0/0/3 以 tagged 方式分别加入 VLAN10、VLAN20。
    各个 VLAN对应的协议:
    VLAN10:IPv4
    VLAN20:IPv6
    操作步骤
    创建 VLAN
    配置 Switch 。
    system-view
    [Quidway] sysname Switch
    [Switch] vlan batch 10 20
    配置基于协议划分 VLAN
    在 Switch 上配置 VLAN10与协议 IPv4 关联。
    [Switch] vlan 10
    [Switch-vlan10] protocol-vlan ipv4
    [Switch-vlan10] quit
    在 Switch 上配置 VLAN20与协议 IPv6 关联。
    [Switch] vlan 20
    [Switch-vlan20] protocol-vlan ipv6
    [Switch-vlan20] quit
    配置接口关联协议 VLAN
    在 Switch 上配置接口与 VLAN10关联,优先级是 5。
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] protocol-vlan vlan 10 all priority 5
    在 Switch 上配置接口与 VLAN20关联,优先级是 6。
    [Switch-GigabitEthernet0/0/1] protocol-vlan vlan 20 all priority 6
    [Switch-GigabitEthernet0/0/1] quit
    配置接口
    在 Switch 上配置接口 GE0/0/1 允许 VLAN10和 VLAN20通过。
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type hybrid
    [Switch-GigabitEthernet0/0/1] port hybrid untagged vlan 10 20
    [Switch-GigabitEthernet0/0/1] quit
    在 Switch 上配置接口 GE0/0/2 允许 VLAN10通过。
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type trunk
    [Switch-GigabitEthernet0/0/2] port trunk allow-pass vlan 10
    [Switch-GigabitEthernet0/0/2] quit
    在 Switch 上配置接口 GE0/0/3 允许 VLAN20通过。
    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] port link-type trunk
    [Switch-GigabitEthernet0/0/3] port trunk allow-pass vlan 20
    [Switch-GigabitEthernet0/0/3] quit
    验证配置结果
    上述配置完成后,执行命令 display protocol-vlan interface all ,可以查看
    接口关联基于协议划分 VLAN的配置信息。

    展开全文
  • 这个也比较简单

    在这里插入图片描述这个也比较简单

    展开全文
  • 基于IP划分VLAN

    千次阅读 2015-09-09 22:47:50
    划分vlan的方法:1、基于vlan2、基于端口3、基于网络协议,例如IP4、基于策略常见的是如上四种,当然还有其他方法,但并不多见。其实在企业中,我也是基本依据端口来划分VLAN划分VLAN的好处就不多赘述了,最重要的...
  • VLAN(Virtual Local Area Network,虚拟局域网)是一种将局域网设备从逻辑上划分成一个 个网段,从而...VLAN的实现方法,可以大致划分为六类:基于端口划分的VLAN基于MAC地址划分VLAN基于网络层协议划分VLAN根据IP组播...
  • 基于协议vlan示例

    2018-12-27 15:58:45
    华为hcie实验,基于协议的lan划分。 示例文件用ensp打开即可。
  • ​组网图形图1 配置接入层设备作为网关组网图 图1 配置接入层设备作为网关组网图 简介划分VLAN的方式有:基于接口、基于MAC地址、基于IP子网、基于协议、基于策略(MAC地址、IP地址、接口)。其中基于接口划分VLAN,...
  • 忆龙2009:基于协议VLAN简介

    千次阅读 2009-12-07 19:37:00
    基于协议的VLAN是根据端口接收到的报文所属的协议(族)类型及封装格式来给报文分配不同的VLAN ID。可用来划分VLAN的协议有IP、IPX、AppleTalk(AT),封装格式有Ethernet II、802.3 raw、802.2 LLC、802.2 SNAP等。...
  • 其实VLAN是为解决以太网的广播问题和安全性而提出的一种协议,它在以太网帧的基础上增加了VLAN头,用VLAN ID把用户划分为更小的工作组,限制不同工作组间的用户互访,每个工作组就是一个虚拟局域网。虚...
  • 划分VLAN

    2020-02-06 08:13:00
    基于协议 根据IP组播划分 基于策略 按用户定义 VLAN中继协议 1)封装 ISL(思科私有):是在数据帧前加26字节,尾加4字节 802.1Q(工业标准):是在数据帧中插入4字节,打标签 802.1Q Native Vlan:默认vlan1不...
  • VLAN,业界还存在基于MAC地址划分VLAN、基于IP地址划分VLAN基于协议划 分VLAN以及基于策略划分VLAN等方式(具体的交换机型号是否支持这些工作方式 视该产品特性而定,并非所有的交换机都支持上述工作方式)。 在图8-...
  • vlan划分

    2020-12-19 22:18:29
    1.基于端口的划分VLAN 2.基于MAC地址划分VLAN 3.基于网络层协议划分VLAN 4.根据IP组播划分VLAN 5.按策略协议划分VLAN 6.按用户定义、非用户授权划分VLAN
  • VLAN划分与互联.ppt

    2019-09-08 19:20:07
    VLAN划分方法 基于端口划分的VLAN 基于MAC地址划分VLAN 基于网络层协议划分VLAN 根据IP组播划分VLAN
  • VLAN划分

    千次阅读 2018-12-17 15:30:28
    可以基于接口、MAC地址、子网、网络层协议、匹配策略方式来划分VLAN。不同方式的VLAN划分比 较。 VLAN划分方式差异 1.VLAN划分方式 基于端口原理:根据交换设备的端口编号来划分VLAN。为交换机的每个端口配置不同...
  • vlan划分

    2019-09-18 06:16:38
    这种划分VLAN的方法是根据以太网交换机的交换端口来划分的,它是将VLAN交换机上的物理端口和VLAN交换机内部的PVC(永久虚电路)端口分成若干个组,每个组构成一个虚拟网,相当于一个独立的VLAN交换机。对于不同部门...
  • 划分VLAN的方式有:基于接口、基于MAC地址、基于IP子网、基于协议、基于策略(MAC地址、IP地址、接口)。其中基于接口划分VLAN,是最简单,最常见的划分方式。 基于接口划分VLAN指的是根据交换机的接口来划分VLAN。...
  • VLAN应用篇 1.华为 H3C交换机多种划分VLAN方式配置【基于接口、MAC、子网、协议、策略5种方式划分,可实现IP与MAC绑定】
  • 对于思科VLAN划分,只支持基于接口的形式,当然也有种动态VLAN划分,叫做VMPS,也是基于源MAC来进行动态的划分,但是这种需要思科特定的服务器,而且不是所有设备交换机都支持,另外一种需要通过mac认证或者dot1x的...
  • VLAN的划分VLAN(virtual local areanetwork):虚拟局域网划分方法->相关协议->基本配置->VLAN间路由为了提高网络的性能和更安全的管理网络,可以将一个物理网络逻辑的划分成多个vlan,每个vlan都属于不同的...
  • 四、基于协议划分VLAN 基于协议划分VLAN是指基于数据帧中的上层(网络层)协议类型进行的VLAN划分。也只处理Untagged数据帧,且也只能在Hybrid端口上进行配置 划分思想是把用户计算机上运行的网络层协议与某个VLAN...
  • 》Huawei-R&S-网络工程师实验笔记20190608-VLAN划分基础(基于...一、基于端口划分VLAN: [SWA]vlan 10 //创建VLAN10,这一步是前提(设备默认只有VLAN 1) [SWA-vlan10] Jun 9 2019 02:11:50-08:00 SWA...
  • 基于协议划分vlan(v4v6):5.基于策略划分vlan:3.Vlan 聚合:4.MUX Vlan 复杂Vlan:5.QinQ:透传,内网通过广域网互通(外网ISP)6.Vlan Mapping Vlan映射(内网常见): 1. MAC 和 arp : MAC地址: 00-06-1b-e3-93-6c 8...
  • 基于协议划分VLAN 基于协议划分VLAN是指基于数据帧中的上层(网络层)协议类型进行的VLAN划分。也只处理Untagged数据帧,且也只能在Hybrid端口上进行配置,对于Tagged数据帧的处理方式和基于端口的VLAN一样。 划分...
  • NPS+MAC认证+MAC-VLAN,实现基于MAC地址的动态VLAN划分 windows 2012 nps配置 1.安装windows nps角色,安装网络策略服务器及主机凭据授权协议。 2、在RADIUS客户端中添加RADIUS客户端 3、配置连接策略,连接策略...
  • 动态划分VLAN的方法中不包括(23)。 (23)A.网络层协议 B.网络层地址 C.交换机端口 D.MAC地址 【答案】C 【解析】 在交换机上实现VLAN,可以采用静态的或动态的方法: ①静态分配VLAN:为交换机的各个端口指定...
  • VLAN可以有很多种方式划分,基于IP,基于端口甚至基于协议,而子网只能通过掩码划分VLAN能够将广播进行隔离,较子网具有更高的安全性。 vlan是可以隔离广播的。子网划分不能隔离广播 子网划分就是通过借主机位来...
  • VLAN(虚拟局域网)划分

    2016-10-11 14:48:00
    VLAN根据不同的需求,可以有多种划分方式: 一:静态划分 基于端口 按VLAN交换机上的...这种划分VLAN的方法是根据每个用户主机的MAC地址来划分的 基于网络协议 VLAN按网络层协议来划分为IP、IPX等VLAN网络 ...

空空如也

空空如也

1 2 3 4 5 ... 9
收藏数 173
精华内容 69
关键字:

基于协议划分vlan