精华内容
下载资源
问答
  • 基于IP地址划分VLAN

    2021-04-12 21:02:25
    基于IP地址划分VLAN 一.实验拓扑图 二.实验要求 如图所示,查看 S1、S2 和 S3 的配置。 1.测试同一网段的PC和服务器能否通信?(仅30的网段可以,WHY?) 2.思考 S1 交换机发送给 S3 交换机时的上行流量是否均有...

    基于IP地址划分VLAN

    一.实验拓扑图
    在这里插入图片描述

    二.实验要求
    如图所示,查看 S1、S2 和 S3 的配置。

    1.测试同一网段的PC和服务器能否通信?(仅30的网段可以,WHY?)
    2.思考 S1 交换机发送给 S3 交换机时的上行流量是否均有TAG标签?
    3.假设 S1 交换机由于某种原因,无法配置,请在 S3 的 E4 端口进行相应配置,根据相应IP进行VLAN的划分。
    4.测试同一网段的PC和服务器能否通信?(YES)。

    首先,先在用户视图下使用命令display current-configuration查看交换机当前配置;使用命令display port vlan 查看端口vlan。(可使用Tab补全
    S1:划分了一个vlan30,设E3端口类型access,并允许vlan30通过,PVID=30,设E4端口类型Trunk,并允许所有vlan通过 ;

    在这里插入图片描述
    在这里插入图片描述
    S2:划分了vlan10 20 30三个vlan,设E1 E2 E3端口类型为access,分别允许vlan30 20 10通过,PVID分别为30 20 10,设E4端口类型为Trunk,并允许所有vlan通过;
    在这里插入图片描述
    在这里插入图片描述
    S3:划分了vlan10 20 30三个vlan,设E1 E4端口类型为Trunk,并允许所有vlan通过;
    在这里插入图片描述
    在这里插入图片描述

    1.测试:
    (1)测试网段192.168.10.x/24的PC6与Server1,如图无法通信;(原因 :当PC6向Server1发送数据帧时,以一个无标记数据帧到达S2的E3接口,被打上一个10的标签,被S2接收,在E4时,接口类型为Trunk,PVID=1,与数据帧PVID不一致,故保留PVID发送出去,带着标记的数据帧到达S3的E1 Trunk接口,允许通过,到达S3内部,经过E4时,PVID缺省1,Trunk类型,将继续保留标记10发送出去,此时到达S1的E4 Trunk类型,PVID=1,允许进入S1,但在E1接口,hybrid类型(在缺省情况下只允许缺省vlan的数据帧通过),PVID为1,则此时数据帧无法到达,丢弃,通过对端口抓包可明显看出:PC6的数据帧最远到达S1的E1接口)
    PC5与Server2同理

    在这里插入图片描述
    对S2的E4进行抓包:
    在这里插入图片描述
    对S2的E3进行抓包:
    在这里插入图片描述
    对S3的E1进行抓包:
    在这里插入图片描述
    对S3的E4进行抓包:
    在这里插入图片描述
    对S1的E4进行抓包:
    在这里插入图片描述
    对S1的E1进行抓包:没有接收到从PC6发送过来的数据帧
    在这里插入图片描述
    (2)测试网段192.168.20.x/24的PC5与Server2,同样无法通信;
    在这里插入图片描述
    (3)测试网段192.168.30.x/24的PC4与Server3,此时可以正常通信;(原因 :当PC4向Server3发送数据帧时,以一个无标记数据帧到达S2的E1接口,被打上一个30的标签,被S2接收,E4为Trunk,PVID=1,与数据帧标记不一致,故剥离标记从E4发出,以无标记帧的形式到达S3的E1,打上标记1,进入S3,E4为Trunk缺省vlan为1,标记一致故剥离标记从E4发出,以无标记帧形式到达S1的E4,打上标记1,进入S1,E1为hybrid缺省vlan1,数据帧与缺省vlan相同,故能通过到达Server1。)
    在这里插入图片描述
    2.思考 S1 交换机发送给 S3 交换机时的上行流量是否均有TAG标签?
    否,只有Server3发送数据帧时有Tag标签,因为Server3发送无标记数据帧到达S1的E3,被打上Tag30标记进入S1,与E4标记不一致所以带着Tag30标签到达S3的E4,进入S3;而Server1 2在S1的E4接口时剥离Tag1再发送出去,故没有Tag标签。

    3.假设 S1 交换机由于某种原因,无法配置,请在 S3 的 E4 端口进行相应配置,根据相应IP进行VLAN的划分。

    首先,先进入S3的E4接口,使用命令display this 查看接口配置;再使用undo命令将接口类型及允许通过的vlan删掉,再进行配置,(port hybrid tagged vlan 30允许vlan30通过30Tag保留直接转发到相应的接口两层意思,port hybrid untagged vlan 10 20允许10 20通过并去掉Tag10 20 再进行转发) 记得记得记得最后要save 保存命令欧!!!

    在这里插入图片描述
    在这里插入图片描述

    根据相应IP进行VLAN的划分
    在这里插入图片描述
    测试 经过对S3的配置,同个网段的PC和服务器已经实现互相通信。
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    展开全文
  • 3.假设S1交换机由于某种原因,无法配置,请在S3的E4端口进行相应配置,根据相应IP进行VLAN划分。 4.测试同一网段的PC和服务器能否通信?(YES)。 三、配置命令与原因分析: 1.测试同一网段的PC和服务器能否...

    一、实验拓扑图:

                      

    二、实验要求:

    如图所示,查看 S1、S2 和 S3 的配置。
    1.测试同一网段的PC和服务器能否通信?(仅30的网段可以,WHY?)
    2.思考 S1 交换机发送给 S3 交换机时的上行流量是否均有TAG标签?
    3.假设 S1 交换机由于某种原因,无法配置,请在 S3 的 E4 端口进行相应配置,根据相应IP进行VLAN的划分。
    4.测试同一网段的PC和服务器能否通信?(YES)。

    三、配置命令与原因分析:

    1.测试同一网段的PC和服务器能否通信?(仅30的网段可以,WHY?)答:因为交换机之间的接口都配置为Trunk类型,S2与PC连接的3个接口都配置为access类型并加入相应的VLAN,S1与服务器3互连的接口配置为access类型并加入VLAN30,而S1与服务器1和2互连的接口没有配置也就是默认为hybrid类型。此时PC1的数据帧被交换机S2发出时携带VLAN10的标记,经过S3到达S1后也携带着VLAN10的标记,因为S1的E0/0/1接口pvid1与该数据帧的VLAN10标记不一致,因此S1将该数据帧丢弃。所以只有VLAN30网段能够通信。

    2.思考 S1 交换机发送给 S3 交换机时的上行流量是否均有TAG标签?答:S1交换机从E0/0/3接口接收的VLAN30的数据帧才携带tag,其余两个数据帧没有携带tag。因为其余两个接口没有配置成access接口和加入相应的VLAN,所以从这两个接口发出的数据帧进入S1交换机后打上VLAN1标记,从交换机S1发出时与PVID值一至,所以剥除数据帧后发给S3,所以S3收到的是无tag的。

    3.假设 S1 交换机由于某种原因,无法配置,请在 S3 的 E4 端口进行相应配置,根据相应IP进行VLAN的划分。

    配置命令:

    4.测试同一网段的PC和服务器能否通信?(YES)。

    PC4 ping Server3截图:

    PC5 ping Server2截图:

    PC6 ping Server1截图:

    展开全文
  • 8.2.7案例4:基于IP地址划分VLAN 通常在一个典型的局域网中,我们多采用基于接口划分VLAN的方式,也就是通过 命令将交换机的接口加入某个或者某些特定的VLAN。当然,除了可基于接口划分 VLAN,业界还存在基于MAC地址...

    技术背景

    • 通常在一个典型的局域网中,我们多采用基于接口划分VLAN的方式,也就是将交换机的接口加入某个或者某些特定的VLAN。
    • 除了可基于接口划分VLAN,还存在基于MAC地址划分VLAN、基于IP地址划分VLAN、基于协议划分VLAN以及基于策略划分VLAN等方式。

    示例

    如下图所示的网络拓扑中:

    1. SW2下挂着三台服务器,其中SW2连接Server1及Server2的接口是Access类型,而且加入了VLAN1;
    2. SW2连接Server3的接口也是Access类型,但是加入VLAN30。
    3. SW2的上联接口(连接SW1的接口)则是Trunk类型,该接口在其允许通过的VLAN-ID列表中添加了VLAN1及VLAN30,并且将VLAN1指定为缺省VLAN。
    4. 基于上述配置,SW1将会在其GE6/0/15接口上收到三种类型的上行流量,分别是源地址为10.10.10.0/24网段的无标记帧、源地址为10.10.20.0/24网段的无标记帧,以及源地址为10.10.30.0/24网段的VLAN30标记帧。

    引入问题

    基于上述配置,用户的网络需求是,将来自这三个网段的数据帧在SW1上根据规划(根据下图所示的表格)对应到相应的VLAN,并且SW1转发这些帧给CoreSwitch时都携带Tag。由于某种原因,SW2的配置无法变更,因此要求只能在SW1上完成配置。
    在这里插入图片描述

    问题分析

    • 实际上,基于IP地址划分VLAN可以很好的解决上述问题需求。
    • 在SW1上部署基于IP地址的VLAN划分时:
      (1)当在GE6/0/15接口上收到源地址为10.10.10.0/24网段的数据时,将其识别为VLAN10的数据;
      (2)当在GE6/0/15接口上收到源地址为10.10.20.0/24网段的数据时,将其识别为VLAN20的数据;
      (3)源地址为10.10.30.0/24网段的数据本身携带tag(VLAN 30),SW1只要以标记帧的形式处理VLAN30的数据即可。
      (4)为了让SW2顺利地接收相关数据帧,SW1的GE6/0/15接口在发送VLAN 10及VLAN20的数据帧时不能打标记,而在发送VLAN30的数据帧时则需要打标记。

    配置

    SW1的配置如下:

    [SWl]vlan batch 10 20 30
    
    [SWl]vlan 10
    [SW1-v1aa10]ip-subnet-vlan ip 10.10.10.0 24					#配置10.10.10.0网段与VLAN 10的对应关系
    [SW1-v1an10]quit
    [SW1]vlan 20
    [SW1-v1an20]ip-subnet-vlan ip 10.10.20.0 24					#配置10.10.20.0网段与VLAN 20的对应关系
    [SW1-v1an20]quit
    
    
    [SW1]interface GigabitEthernet 6/0/15
    [SW1-GigabitEthernet6/0/15]port link-type hybrid
    [SW1-GigabitEthernet6/0/15]port hybrid untagged vlan 10 20
    [SW1-GigabitEthernet6/0/15]port hybrid tagged vlan 30
    [SW1-GigabitEthernet6/0/15]ip-subnet-vlan enable			#配置基于IP地址划分ULAN
    [SW1-GigabitEthernet6/0/15]quit
    
    
    
    [SW1]interface GigabitEthernet 6/0/22
    [SW1-GigabitEthernet6/0/22]port link-type trunk
    [SW1-GigabitEthernet6/0/22]port trunk allow-pass vlan 10 20 30
    
    • 在上述配置中,在VLAN10的配置视图下执行的ip-subnet-vlan ip 10.10.10.0 24命令,用于将10.10.10.0/24这个IP网段与VLAN 10进行关联,使得该网段发出的报文能够在VLAN10内传输。
    • 在SW1的GE6/0/15接口配置了ip-subnet-vlan enable命令,该命令用于在该接口下激活基于IP子网划分VLAN的功能,并且该命令只能在Hybrid类型的接口上应用(HW)。
    • SW1的GE6/0/22接口被指定为Trunk类型,并且放通了VLAN10, 20及30的流量,这三个VLAN的数据帧将以标记帧的形式通过该接口。因此,对于CoreSwitch而言,它需将自己的GE6/0/22接口配置为Trunk类型,并且将VLAN10, 20及30添加到该接口允许通行的VLAN-ID列表中。
    展开全文
  • 2.使能基于IP子网划分VLAN功能,并关联IP子网和VLAN,实现根据报文中的源IP地址或指定网段确定VLAN。配置介绍:Switch的配置文件#sysname Switch //交换机命名#vlan batch 100 200 300 //创建VLAN 100、VLAN 200和...

    1.创建VLAN并将接口加入VLAN,实现基于IP子网的VLAN可以透传当前接口。

    2.使能基于IP子网划分VLAN功能,并关联IP子网和VLAN,实现根据报文中的源IP地址或指定网段确定VLAN。

    d79d6fabe747d77f9e6ebee4770cd1e3.png

    配置介绍:

    • Switch的配置文件
    #sysname Switch   //交换机命名#vlan batch 100 200 300    //创建VLAN 100、VLAN 200和VLAN 300#vlan 100 ip-subnet-vlan 1 ip 192.168.1.2 255.255.255.0 priority 2vlan 200 ip-subnet-vlan 1 ip 192.168.2.2 255.255.255.0 priority 3vlan 300 ip-subnet-vlan 1 ip 192.168.3.2 255.255.255.0 priority 4#interface GigabitEthernet1/0/1 port link-type hybrid port hybrid untagged vlan 100 200 300 ip-subnet-vlan enable     扩展插槽#interface GigabitEthernet1/0/2 port link-type trunk port trunk allow-pass vlan 100 200 300#return
    展开全文
  • 2.使能基于IP子网划分VLAN功能,并关联IP子网和VLAN,实现根据报文中的源IP地址或指定网段确定VLAN。配置介绍:Switch的配置文件#sysname Switch //交换机命名#vlan batch 100 200 300 //创建VLAN 100、VLAN 200和...
  • 基于IP子网划分VLAN 某企业拥有多种业务,如IPTV、VoIP、Internet等,每种业务使用的IP地址网段各不相同,为了便于管理,现在需要将同一种类型业务划分到同一个VLAN中; 创建VLAN: [sw1]vlan batch 10 20 30 接口...
  • ##配置基于 IP 子网划分 VLAN

    千次阅读 2018-10-25 17:37:47
    通过配置基于 IP 子网划分 VLAN,将指定网段或 IP 地址发出的报文在指定的 VLAN中传输,减轻了网络管理者的初始配置任务量,且有利于管理。 企业拥有多种业务,如 IPTV、VoIP、Internet 等,每种业务使用的 IP 地址...
  • 基于IP地址划分VALN

    2020-06-14 16:38:13
    1.配置基于IP地址划分VLAN 二、注意事项 1.交换机的各个端口都要放行,相关VLAN 三、基于IP地址划分VLAN 1、只适用于接收untagged帧,并且只能再hybrid端口上进行 四、基本配置 LSW1 sysname LSW1 # vlan batch 2 to...
  • 基于mac地址划分VLAN与VLAN学习mac地址,全局DHCP配置 配置步骤(全部在S5700交换机配置) 一、配置DHCP交换机 1、进入用户试图 system-view 2、开启dhcp功能 dhcp enlabe 3、创建地址池名字10 ip pool 10 4、设置...
  • Vlan划分是基于mac地址,不是端口划分vlan,这样到好处是当pc切换端口后不会因为端口改变而改变vlan 虚拟网卡IP地址 192.168.56.1 Vlan2 IP地址 192.168.56.2(虚拟网卡192.168.56.1的网关) vlan3 IP地址 192....
  • 基于子网划分VLAN基于数据帧中上层(网络层) IP地址或所属IP网段进行的VLAN划分, 也属于动态VLAN划分方式,既可减少手工配置VLAN的工作量,又可保证用户自由地增加、移动和修改。基于子网划分VLAN适用于对安全性需求...
  • 基于子网划分VLAN基于数据帧中上层(网络层) IP地址或所属IP网段进行的VLAN划分, 也属于动态VLAN划分方式,既可减少手工配置VLAN的工作量,又可保证用户自由地增加、移动和修改。基于子网划分VLAN适用于对安全性需求...
  • 基于子网划分VLAN基于数据帧中上层(网络层)IP地址或所属IP网段进行的VLAN划分,属于动态VLAN划分方式,即可以减少手工配置VLAN的工作量,以可保证用户自由增增加、移动和修改。基于子网划分VLAN适用于对安全性...
  • 基于IP子网划分的VLAN——ielab实验室,基于子网划分VLAN是基于数据帧中上层(网络层) IP地址或所属IP网段进行的VLAN划分,也属于动态VLAN划分方式,既可减少手工配置VLAN的工作量,又可保证用户自由地增加、移动和修改...
  • 学网络,就在IE-LAB国内最著名的高端网络工程师培养基地基于子网划分VLAN基于数据帧中上层(网络层)IP地址或所属IP网段进行的VLAN划分, 也属于动态VLAN划分方式,既可减少手工配置VLAN的工作量,又可保证用户自由地...
  • 基于端口的静态VLAN  直接指示哪些端口是一个VLAN组,比如一个交换机上有8个端口,我们指示1,3,5,7为VLAN1分组,2,4,6,8为VLAN2分组, 不同的交换机之间也可以进行VLAN组别划分。... 基于IP地址VLAN,则...
  • 我们前面曾说到,关于vlan的划分方法有很多,项目应用中较多的方法就是基于端口划分vlan、基于mac地址划分vlan、基于ip地址划分vlan,要真正对vlan了解,必须熟悉这三次划分方法,以便于根据实际项目进行应用。...
  • 关于vlan的划分方法有很多,项目应用中较多的方法就是基于端口划分vlan、基于mac地址划分vlan、基于ip地址划分vlan,要真正对vlan了解,必须熟悉这三次划分方法,以便于根据实际项目进行应用。一...
  • 基于策略划分VLAn也可称为Policy VLAN,是根据一定的策略进行VLAN划分的,可实现用户终端的即插即用功能,同时可为终端用户提供安全的数据隔离。这里的策略主要包括“基于MAC地址+IP地址”组合和“基于MAC地址+IP...
  • 忆龙2009:基于IP子网的VLAN简介

    千次阅读 2009-12-07 19:39:00
    基于IP子网的VLAN是根据报文源IP地址及子网掩码来进行划分的。设备从端口接收到untagged报文后,会根据报文的源地址来确定报文所属的VLAN,然后将报文自动划分到指定VLAN中传输。 此特性主要用于将指定网段或IP地址...
  • 关于vlan的划分方法有很多,项目应用中较多的方法就是基于端口划分vlan、基于mac地址划分vlan、基于ip地址划分vlan,要真正对vlan了解,必须熟悉这三次划分方法,以便于根据实际项目进行应用。一...
  • 思科基于端口划分VLAN

    2020-06-15 10:01:50
    然后对每一台主机进行IP地址、子网掩码、网关的配置 然后进行相关VLAN的配置: Switch>en Switch>en Switch#config t Enter configuration commands, one per line. End with CNTL/Z. Switch(config)#vlan...
  • ​组网图形图1 配置接入层设备作为网关组网图 图1 配置接入层设备作为网关组网图 简介划分VLAN的方式有:基于接口、基于MAC地址、基于IP子网、基于协议、基于策略(MAC地址、IP地址、接口)。其中基于接口划分VLAN,...
  • # 在Switch上创建VLAN100、VLAN200和VLAN300。...# 在Switch上配置VLAN100与IP地址192.168.1.0/24关联。 [Switch] vlan 100 [Switch-vlan100] ip-subnet-vlan ip 192.168.1.024 [Switch-vlan100] quit...
  • 关于vlan的划分方法有很多,项目应用中较多的方法就是基于端口划分vlan、基于mac地址划分vlan、基于ip地址划分vlan,要真正对vlan了解,必须熟悉这三次划分方法,以便于根据实际项目进行应用。今天我们以华为交换机...
  • 很多朋友在留言中也多次提到了华为交换机,华为也是在项目中用的比较多...我们前面曾说到,关于vlan的划分方法有很多,项目应用中较多的方法就是基于端口划分vlan、基于mac地址划分vlan、基于ip地址划分vlan,要真...
  • 配置过程:启用所有设备,配置好主机的IP地址,CLIENT1: 10.0.0.1/24 CLIENT2: 10.0.1.1/24 CLIENT3: 10.0.0.2/24 CLIENT4: 10.0.1.2/24VLAN 10 : CLIENT1CLIENT3VLAN 20: CLIENT2 CLIENT4实现VLAN10 内的主机可以...
  • 很多朋友在留言中也多次提到了华为交换机,华为也是在项目中用的比较多...我们前面曾说到,关于vlan的划分方法有很多,项目应用中较多的方法就是基于端口划分vlan、基于mac地址划分vlan、基于ip地址划分vlan,要真...

空空如也

空空如也

1 2 3 4 5 ... 8
收藏数 143
精华内容 57
关键字:

基于ip地址划分vlan