精华内容
下载资源
问答
  • 本次介绍一下在CISCO路由器上配置NTP服务器,以解决企业中路由器、交换机及windows服务器、Linux服务器等设备的时间同步问题。尤其是做网络管理的同志们可要注意啦!您肯定不希望接收到设备时间不统一Trap事件。 NTP...

    不管您是做网络管理,还是路由交换或是服务器搭建。设备的时间同步问题都非常的重要。本次介绍一下在CISCO路由器上配置NTP服务器,以解决企业中路由器、交换机及windows服务器、Linux服务器等设备的时间同步问题。尤其是做网络管理的同志们可要注意啦!您肯定不希望接收到设备时间不统一Trap事件。

    NTP(Network Time Protocol,网络时间协议)是基于RFC1305的协议,是一个跨越广域网或局域网的复杂的同步时间协议。一般情况下建议配置在路由器上,当然配置在其它设备上都是可以的。接下来我们根据下面的拓扑图来看一下在路由器上配置NTP服务器的方法以及在不同网段获取NTP信息。

    拓扑如下:

     

    【实验要求】

    R5充当NTPServer

    R1与R6自动从NTPServer上获取地址


     

    【实验配置】


    1、配置路由器基本信息。
     

    R1:
    inter fa 0/0
    ip address 155.1.146.1 255.255.255.0
    no shut
    R4:
    inter ethernet 0/0
    ip address 155.1.146.4 255.255.255.0
    no shut
    !
    interface Serial 0/0
    encaps frame-relay
    no frame-relay inverse
    ip address 155.1.0.4 255.255.255.0
    frame map ip 155.1.0.5 405 broad
    no shutdown
    R5:
    interface Serial 0/0
    encaps frame-relay
    no frame-relay inverse
    ip address 155.1.0.5 255.255.255.0
    frame map ip 155.1.0.4 504 broad
    no shut
    R6:
    inter gig 0/0
    ip address 155.1.146.6 255.255.255.0
    no shut

     

    2、配置路由器的所在的时区。

    R5(config)#clock timezone peking +8
    R5(config)#
    Mar 1 00:24:49.275: %SYS-6-CLOCKUPDATE: System clock has been updated from 08:24:49 peking Fri Mar 1 2002 to 08:24:49 peking Fri Mar 1 2002, configured from console by console.
    说明:上面的配置中Peking用来指明所在时区的名字,+8是指相对于国际时间的偏移量,这个值的取值范围从-23 – 23.

     
    3、配置路由器的时间
    R5#clock set 08:36:00 12 April 2012

    4、指定路由器为NTP服务器,及指定发送广播接口
    R5:
    ntp master 1
    interface Serial 0/0
    ntp broadcast
    说明:指定路由器为NTP服务器时用的命令是master,而不是server,注意现在又回到了全局模式

    5、在R4上启用NTP客户端接收由NTP Server发出的时钟信号
    R4:
    interface Serial 0/0
    ntp broadcast client

    6、在R1与R6上设置NTP同步
    R1(config)#ntp server 155.1.146.4
    R1(config)#clock timezone peking +8
    R6(config)#ntp server 155.1.146.4
    R6(config)#ntp peer 155.1.146.1
    R6(config)#clock timezone peking +8
    如果不能获得请注意以下原因,比如网络不通,防火墙阻碍了123端口(NTP服务的端口),客户端上显示的时间与NTP服务器上的时间悬殊过大。

    说明:现在使用ntp server命令来指定NTP服务器的地址,注意不要望了时区的设置,否则获得的时间将会是UTC时间。



    本文转自zcm8483 51CTO博客,原文链接:http://blog.51cto.com/haolun/993078

    展开全文
  • Ntp时间服务Core_R0(config)#clock timezone peking +8 相对国际时间+8Core_R0#clock set 14:17:00 24 March 设置时间Core_R0(config)#ntp master 1 指定路由器为n...

    Ntp时间服务

    Core_R0(config)#clock timezone peking +8          相对国际时间+8

    Core_R0#clock set 14:17:00 24 March                   设置时间

    Core_R0(config)#ntp master 1                               指定路由器为ntp服务器

    Core_R0(config)#int loopback 0

    Core_R0(config-if)#ntp broadcast                          指定发送广播的接口

    客户端

    R2(config)#clock timezone peking +8

    R2(config)#ntp server 10.10.10.10                         指定ntp服务器的地址


    转载于:https://blog.51cto.com/11227668/2093175

    展开全文
  • NTP时间同步服务器配置实例(CISCO7200路由) 出于网管的目的,我们架设了netflow,来监控流量,同时也可以获取内网用户访问Internet的详细访问记录,这种记录可以精确到秒,但前提是被监控的路由器或交换机等网络设备的...

                         NTP 时间同步服务器配置实例(CISCO 7200路由)

    出于网管的目的,我们架设了netflow,来监控流量,同时也可以获取内网用户访问Internet的详细访问记录,这种记录可以精确到秒,但前提是被监控的路由器或交换机等网络设备的时间,必须与监控日志所在服务器(可以是win,也可以是solaris系统)的时间保持绝对同步.
     
    win系统的时间同步,我们可以通过单击右下角的时间,选择Internet时间,设置时间同步服务器来实现,win2000与2003的同步方法稍微复杂一些,下面会有详细过程的描述.
     
    cisco路由器或交换机的同步,也非常简单,只需对NTP稍作了解即可:
     
    NTP : Network Time Protocol 网络时间协议
     
    由于部分思科设备不带有时钟,一旦重启后时钟会被重置为初始时间,这正是我们使用NTP的原因.通过使用NTP可以与互联网上的一级、二级时钟源同步。我们可以查询
    http://www.eecis.udel.edu/~mills/ntp/clock1a.html来查找与自已位置最近的时钟源。
     
    配置方法:
    // router 7206
    conf t
    ntp source FastEthernet0/1     //指定更新源地址,覆盖ntp server中的配置
    ntp update-calendar            //设备如带有硬件时钟,同时更新硬件时钟
    ntp server 202.155.248.218 source FastEthernet0/1   //指定更新目的地址,香港,并指定更新源接口为f0/1.
     
    int f0/1
      ntp enable
     
    这时你应该已经获得了时间,但是注意,时区是否正确,默认为格林威治时间,如想改为北京时间,下面这步是必不可少的。
     
    clock timezone BeiJing 8   //最后这个数字8,代表+8时区。
     
    验证方法:
    show ntp status
    show ntp associate
     
    一旦成功建立关联,我们还可以将win日志监控服务器的时钟与CISCO路由器同步,这样就保证了时钟的绝对同步,保证我们的网络访问日志可以精确到以秒为单位的程度.
     
    win2000与2003同步方法不像XP这样简单
    DOS状态下执行:
    net time /setsntp:202.155.248.218     //香港
    w32tm -once 可立即进行NTP同步
     
    另外这里再解释一下NTP中的两种用法:
    ntp server     本设备通过远端时钟源,来更新自身的时间,单向.
    ntp peer       本设备既可以接受时钟同步,也可以给远端设备提供时钟,双向.
     
     
    参考网站:
     

     

    转载于:https://blog.51cto.com/kwsnh/440259

    展开全文
  • 出于网管的目的,我们架设了netflow,来监控流量,同时也可以获取内网用户访问Internet的详细访问记录,这种记录可以精确到秒,但前提是被监控的...win系统的时间同步,我们可以通过单击右下角的时间,选择Internet时间,...

    出于网管的目的,我们架设了netflow,来监控流量,同时也可以获取内网用户访问Internet的详细访问记录,这种记录可以精确到秒,但前提是被监控的路由器或交换机等网络设备的时间,必须与监控日志所在服务器(可以是win,也可以是solaris系统)的时间保持绝对同步.

     
    win系统的时间同步,我们可以通过单击右下角的时间,选择Internet时间,设置时间同步服务器来实现,win2000与2003的同步方法稍微复杂一些,下面会有详细过程的描述.
     
    cisco路由器或交换机的同步,也非常简单,只需对NTP稍作了解即可:
     
    NTP : Network Time Protocol 网络时间协议
     
    由于部分思科设备不带有时钟,一旦重启后时钟会被重置为初始时间,这正是我们使用NTP的原因.通过使用NTP可以与互联网上的一级、二级时钟源同步。我们可以查询
    [url]http://www.eecis.udel.edu/~mills/ntp/clock1a.html[/url]来查找与自已位置最近的时钟源。
    配置方法:
    // router 7206
    conf t
    ntp source FastEthernet0/1     //指定更新源地址,覆盖ntp server中的配置
    ntp update-calendar            //设备如带有硬件时钟,同时更新硬件时钟
    ntp server 202.155.248.218 source FastEthernet0/1   //指定更新目的地址,香港,并指定更新源接口为f0/1.
     
    int f0/1
      ntp enable
     
    这时你应该已经获得了时间,但是注意,时区是否正确,默认为格林威治时间,如想改为北京时间,下面这步是必不可少的。
     
    clock timezone BeiJing 8   //最后这个数字8,代表+8时区。
     
    验证方法:
    show ntp status
    show ntp associate
     
    written by cracker
    一旦成功建立关联,我们还可以将win日志监控服务器的时钟与CISCO路由器同步,这样就保证了时钟的绝对同步,保证我们的网络访问日志可以精确到以秒为单位的程度.
     
    win2000与2003同步方法不像XP这样简单
    DOS状态下执行:
    net time /setsntp:202.155.248.218     //香港
    w32tm -once 可立即进行NTP同步
     
    另外这里再解释一下NTP中的两种用法:
    ntp server     本设备通过远端时钟源,来更新自身的时间,单向.
    ntp peer       本设备既可以接受时钟同步,也可以给远端设备提供时钟,双向.
     
     
    参考网站:









    本文转自 ciscodocu51CTO博客,原文链接:http://blog.51cto.com/ciscodocu/52760,如需转载请自行联系原作者
    展开全文
  • 出于网管的目的,我们架设了netflow,来监控流量,同时也可以获取内网用户访问Internet的详细访问记录,这种记录可以精确到... win系统的时间同步,我们可以通过单击右下角的时间,选择Internet时间,设置时间同步服务器来...
  • 路由器NTP配置

    2009-10-11 15:12:16
    Network Time Protocol(NTP)是用来使计算机时间同步化的一种协议,它可以使计算机对其服务器或时钟源(如石英钟,GPS等等)做同步化,它可以提供高精准度的时间校正(LAN上与标准间差小于1毫秒,WAN上几十毫秒)...
  • 本次介绍一下在CISCO路由器上配置NTP服务器,以解决企业中路由器、交换机及windows服务器、Linux服务器等设备的时间同步问题。尤其是做网络管理的同志们可要注意啦!您肯定不希望接收到设备时间不统一Trap事件。 ...
  • CISCO路由器上配置NTP服务器----实验

    千次阅读 2012-04-13 07:48:05
    本次介绍一下在CISCO路由器上配置NTP服务器,以解决企业中路由器、交换机及windows服务器、Linux服务器等设备的时间同步问题。尤其是做网络管理的同志们可要注意啦!您肯定不希望接收到设备时间不统一Trap事件。 ...
  • NTP

    2020-06-01 09:49:17
    时间和日历服务(NTP) 在真正深入了解网络管理之前,可以帮助...通常,可以使用以下两种方法之一来设置路由器或交换机上的日期和时间设置:您可以手动配置日期和时间(如示例中所示),或配置网络时间协议(NTP)。 R1#
  • 一:NTP的工作原理(UDP端口 123)NTP工作原理:上图是NTP的基本工作原理,路由器A和路由器B通过网络连接,它们都有自己独立...—以路由器B为NTP时间服务器,即路由器A将使自己的时钟与路由器B的时钟同步。—数据包在路...
  • NTP协议

    2016-07-06 12:04:58
    一:NTP的工作原理(UDP端口 123)NTP工作原理:上图是NTP的基本工作原理,路由器A和路由器B通过网络连接,它们都有自己独立的系统时钟,要实现各自的...—以路由器B为NTP时间服务器,即路由器A将使自己的时钟与路由器...
  • Cisco交换机时间服务(NTP)的设置

    千次阅读 2010-07-21 17:41:05
    show ntp status 另外这里再解释一下NTP中的两种用法: ... ntp peer 本设备既可以接受时钟同步,也可以给远端设备提供时钟,双向 --- 华为路由器配置NTP ntp-service source-interface LoopBack0 nt...
  • Cisco NTP学习总结

    千次阅读 2017-11-12 19:33:00
    1、NTP属于时间同步的协议 2、基本NTP配置 如上图所示,在R5上配置NTP服务器,R1与R6通过R5矫正时间 【NTP 主时钟配置】 R5: ntp master 1//配置路由器NTP主时钟。 interface s0/0 ntp broadcast//指定接口,...
  • NTP算法

    2015-04-02 08:30:00
    网络时间协议 由特拉华大学的David L. Mills热心提供。... 由Reinhard v....rvh@informatik.uni-kiel.de (一)引言 ...(1)网络时间协议(NTP)使得在互联网上主机和路由器的时钟同步。 (2)有超过十万...
  • Openwrt常用软件模块之NTP NTP简介 NTP(Net Time Protocol)是用于互联网上计算机时间同步的协议。其中有NTP服务器来提供网络时间服务,客户端从服务器获取时间 ...该选项用来设置NTP时间服务器
  • 因为本人已经成功使普通家用型路由器通过此服务器授时,而处于同一子网的windows主机同步时却出现以下提示:“Windows在与X进行同步时出错。时间例子被拒绝,因为:对等机器的层次(stratum)比主机层次少。” 其他: ...
  • 1、NTP属于时间同步的协议2、基本NTP配置如上图所示,在R5上配置NTP服务器,R1与R6通过R5矫正时间【NTP 主时钟配置】R5:ntp master 1 //配置路由器NTP主时钟。interface s0/0ntp broadcast //指定接口,发送NTP...
  • 在多机ROS中的时间同步问题

    千次阅读 2019-04-25 23:25:50
    局域网内两台设备时间同步 由于项目需要,需要笔记本和无人车上的tx2在无人车上的路由内组建局域网。但本项目系统是以ROS为框架的,...下面介绍如何通过ntp来对局域网内的两台电脑进行时间同步。 (1) 服务器端配置 ...
  • 笔记本上安装Uuntu16.04,turtlebot3_burger的树莓派上安装了Ubuntu16 MATE,通过路由器组建局域网,没有与外网连接。由于burger没有挂外网,二者的时间不同步,在...如何通过ntp对外网进行时间同步 1.主从分别安装...
  • Linux NTP协议

    千次阅读 2010-06-27 18:34:00
     上图所示的是ntp 基本工作原理,路由器gwa 和gwb 通过网络相连,它们都有自己独立的系统时钟,  要实现各自系统时钟的自动同步,作如下假设:1 在gwa 和gwb 的系统时钟同步之前, gwa 的时钟设定为10:00:00am,...
  • CISCO NTP服务的配置

    千次阅读 2012-09-07 10:30:11
    本次介绍一下在CISCO路由器上配置NTP服务器,以解决企业中路由器、交换机及windows服务器、Linux服务器等设备的时间同步问题。尤其是做网络管理的同志们可要注意啦!您肯定不希望接收到设备时间不统一Trap事件。 NTP...

空空如也

空空如也

1 2 3
收藏数 55
精华内容 22
关键字:

路由器ntp时间同步