精华内容
下载资源
问答
  • <p>xml文件中使用到android.support.v7....但是导入cardview-v7库出现以下问题: <p>cannot resolve class android.support.v7.widget.CardView 在buide.gradle中以添加下列代码: <code>compile '...
  • appcompat_v7库导入出错的解决办法

    千次阅读 2015-10-10 01:56:52
    导入V7包时候我们经常会出现各种各样的错误,下面介绍两种常见错误。 第一种:V7包直接报错。这种错误一般是res中的value文件报错,比如value21 value19这样的文件夹。导致该种错误的原因是V7包所选择的android SDK...

    appcompat_v7一般是在我们创建兼容4.0以下的项目才需要使用到的一个兼容库,很多时候导入这个库都会出错,出错的原因在于更新了SDK中的Android-Support-Library。这个Android-Support-Library就是我们导入的appcompat_v7库所在,简单来说更新了Android-Support-Library,那么appcompat_v7也会被更新。

    那么这个时候,如果你的实际工程的targetSDK低于更新后的最新的appcompat_v7所需的SDK,那么就会出错。比如现在最新的appcompat_v7是需要android6.0来支持的,那么我们实际项目的targetSDK也就需要设置为22,编译SDK也需要选择android6.0。

    如果你的项目不用兼容4.0以下的设备,那么创建项目时候,选择miniSDK大于等于14就不用依赖appcompat_v7包了。

    如果你又要兼容4.0以下,但是又没有appcompat_v7所需的最新SDK,那么你就只能自己把报错的地方删掉了,手动修改项目。

    本方法适用于eclipse和android studio

    展开全文
  • eclipse 导入 v7

    2015-08-01 15:38:00
    从github上面导入了工程后发现需要v7包的支持,这个包在SDK路径下面就有,如:G:\work soft\android-sdk-windows\extras\android\support\v7,  里面有一个appcompat需要导入,直接File->Import->copy into ...

      从github上面导入了工程后发现需要v7包的支持,这个包在SDK路径下面就有,如:G:\work soft\android-sdk-windows\extras\android\support\v7,

      里面有一个appcompat需要导入,直接File->Import->copy into workspace,在需要的项目里面添加这个库即可

     

      另外碰到一个问题就是找不到  Theme.AppCompat.Light.NoActionBar

      这个可以自定义一个

       

    <resources>
    
        <!-- Base application theme. -->
        <style name="AppTheme" parent="Theme.AppCompat.Light.NoActionBar">
        </style>
          <style name="Theme.AppCompat.Light.NoActionBar" parent="@style/Theme.AppCompat.Light">  
                <item name="android:windowNoTitle">true</item>  
          </style>  
    </resources>

     

      

    转载于:https://www.cnblogs.com/maydow/p/4694184.html

    展开全文
  • eclipse如何导入v7

    万次阅读 2016-04-08 22:33:14
    此文纪念小白的我走过的艰难的导包岁月v4,v7包都是安卓的一...那么,开始安装v7包的麻烦之旅吧首先,要确定eclipse安装了一个叫Support Library(支持)的东西。 如何安装这个呢?请戳 http://www.cnblogs.com/kis

    此文纪念小白的我走过的艰难的导包岁月

    v4,v7包都是安卓的一个兼容包,用来兼容4.0以下的版本。
    包括toolbar,actionbar等等这些代码里出现的奇奇怪怪小白以前没见过的的类都在这个包里面。
    那么,开始安装v7包的麻烦之旅吧

    首先,要确定eclipse安装了一个叫Support Library(支持库)的东西。
    如何安装这个呢?请戳 http://www.cnblogs.com/kissazi2/p/3644848.html
    只看安装Support Library的部分就可以了。
    其实也可以在这个网站http://www.androiddevtools.cn/#adt-bundle手动下载Support Library。在左上角菜单栏Android sdk tools里的Android SDK Extras选项,下载该咋办网站有说明,按说明来就行

    然后也是在这个网站下载v7包,在Support Library里,对就是在Android SDK Extras的下面。

    好了准备工作已经完成,接下来就是导包了。
    详细步骤看下面链接
    http://www.cnblogs.com/pandapan/p/3999261.html
    关于上面文章里的一些说明
    1.导入v7包工程:点击file->import->选中Android文件夹下的existing Android code into workspace,点击next->点brose,找到v7包的位置sdk/extras/android/support/v7/appcompat,点确定,就ok了(不要在意大小写,我随便打的,也不要告诉我你找不到你的sdk文件夹在哪)
    2.properties选项右键工程名就可以看见了。

    展开全文
  • ![如图](https://img-ask.csdn.net/upload/201508/31/1440989751_189536.png) 导入 appcompat-v7-23.0.0 出这个错,sdk是23的。 求 原因及解决办法。
  • 1.将support-v7的编译版本提高的5.0获取6.02.当有其他项目引用到这个包时,需在同一个目录下,不然导入v7库会不成功

    1.将support-v7的编译版本提高的5.0获取6.0

    2.当有其他项目引用到这个包时,需在同一个目录下,不然导入v7库会不成功

    展开全文
  • 为什么你配置不好support.v7库 其实搜索android.support.v7的配置,百度上会出来很多回答。但是按照教程上面走了,其实也配置不好support.v7库。这是为什么呢?其实不一定是教程错,也不一定是你跟错,而是教程太老...
  • 用android studio new 一个demo时用到RecyclerView,先在xml中引入support v7包的RecyclerView,发现没有找到...android studio新建工程的时候会导入V7包,如下在build.gradle中加入recyclerview-v7包和support-v4包...
  • 今天用到了CardView布局,但是按照网上的一些教程在导入时出错(implementation 'com.android.support:cardview-v7:25.3.1'),这是因为CardView是不断更新的,最新版本的Android无法兼容旧版本,网上的教程多为...
  • 如何导入support_v7

    千次阅读 2016-08-12 14:22:07
    support_v7包中只有类文件,没有资源文件,所以要以工程的形式导入:1.下载v7-appcompat后,正常导入工程(import)。2.然后,在v7工程上右键,Properties,选Android,“is library”打上勾。3.然后,在你的工程上...
  • 目的:AndroidStudio 导入三方使用环境:系统:Windows 环境:AndroidStudio步骤:1. New一个新的project。 2. 2. 将三方文件copy到project的app/libs/文件夹下,依次为app/libs/armeabi/,app/libs/armeabi-v7...
  • 我遇到的:导入到dependencies里:依赖就画红线,找不到 1.解决方案:尝试了换个高版本,就ok了,(版本兼容问题) implementation ‘com.android.support:recyclerview-v7:28.0.0’ Ok 2.重构的时候编译出现available...
  • 当我们开发android应用需要用到android-support-v7-appcompat.jar这个时(比方说要在2.2版本上使用actionbar和fragment),在项目中导入v4和v7这两个之后,新手往往会遇到一些问题。在这里,总结一下可能遇到的...
  • Android Studio 导入SO

    2016-01-15 10:23:44
    1.在libs 目录下创建文件夹armeabi-v7a,把相应的SO拷贝进来这个目录。 2.在build.gradle文件里添加如下代码即可:(这是AS添加SO的代码,其中JAVA代码添加SO有所区别,请注意区分!) ...
  • Android 开发中,不可避免的要使用一些 sdk 自带的或者优秀开发者的一些依赖,但是,导入依赖时也会发生一些问题Failed to resolve:com.android.support:appcompat-v7:xx.xx.xx support 依赖是 Android 开发...
  • PreferenceFragmentCompat组件默认是不在appcompat-v7里的,所以要使用它必须先导入导入代码:compile 'com.android.support:preference-v7:26.+'后面的26.+根据你的配置进行更改。 继承 public class ...
  • ECLIPSE使用appcompat_v7库无法找到android:Widget.Material.ActionButton的问题 使用ECLIPSE导入appcompat_v7后发现报错 error: Error retrieving parent for item: No resource found that matches the ...
  • base commit: ec501a89d8f77fe4b9aaa9049eb27948d8348758 在文章准备工作--ffmpeg编译已经编译出了ffmpeg的。我的生成的目录在ffmpeg-4.1.3/dist/ffmpeg-4.0/,工程导入的是动态,只导入armeabi-v7a...
  • 添加第三方文件将第三方文件添加到对应的架构目录中如果有多个目录的,可能会报错:More than one file was found with OS independent path 'lib/armeabi-v7a/libmyJNI.so'第三方so一般放在jniLibs目录下对应...
  • 当我们导入 v7包 cardview 做卡片式的效果的时候 会报下面的错误 : <!-- On API v23+ we can use the platform provided floating background color -->在 23 或者更高版本的 api 我们才能用 系统提供的这个 ...
  • 这个是android-support-v7的依赖包,希望对你有用
  • 最近用cmake替代ndk-build编译so,编译出来的so打出很多,ndk-build编译的400k左右,cmake编译出的达到4.5M。Gradle插件的版本是:gradle:3.0.0,gradle版本是:gradle-4.1-all.zip。build.gradle cmake 配置...
  • 简单来说就是新的eclipse默认模版主题UI需要使用比较高版本api,如果需要支持低版本,需要导入appCompact来支持,网上一般给出的解法: File->Import (android-sdk\extras\android\support\v7). Choose "appcompat...
  • Android Studio 导入v4 和v7包冲突问题

    千次阅读 2018-08-03 00:16:41
    由于第三方包中的v4 jar一般比较旧,将v4包从libs目录下删除,重新添加在线的依赖v4包,在build.gradle中添加依赖: compile 'com.android.support:support-v4:24.2.0' 注意此时的v4包的版本号要和你主工程...
  • 1、 将jni中生成的文件目录armeabi和armeabi-v7a两个目录拷贝到你app模块的libs目录下; 2、 在app目录下的build.gradle文件中的android节点下添加代码: sourceSets{ main{ jniLibs.srcDirs = [‘libs’] } } ...
  • eclipse如何导入android-support-v7

    千次阅读 2019-04-12 23:16:28
    v4,v7包都是安卓的一个兼容包,用来兼容4.0以下的版本。...首先,要确定eclipse安装了一个叫Support Library(支持)的东西。 在这个网站http://www.androiddevtools.cn/#adt-bundle手动下载Suppor...
  • butterknife:10.0.0 已经不支持 support 老版,如果需要使用,只能使用9.0.0这版。...implementation 'com.android.support:recyclerview-v7:24.1.1' 已经无效 要使用 implementation 'androidx.rec...
  • 安卓旧与新

    2019-08-26 20:05:38
    最近在搞Toolbar,在gradle中导入v7库的时候没有报错,在Activity中却无法使用库中的类,网上查了好多也没解决问题,后来在stack overflow中找到了答案。 原来是导入时androidx和android冲突。我新建项目是自动使用...

空空如也

空空如也

1 2 3 4 5 ... 13
收藏数 248
精华内容 99
关键字:

导入v7库