精华内容
下载资源
问答
  • eNSP下园区网综合实验分步配置(1)Eth-Trunk、Vlan、Trunk
    2022-04-05 20:26:15

    链路聚合(Eth-Trunk):

    接入交换机SW6与汇聚交换机SW3

    SW6(接入):
    <Huawei>system-view
    [Huawei]sysname JieRu-SW6
    [JieRu-SW6]undo info-center enable //关闭日志
    [JieRu-SW6]interface Eth-Trunk 1
    [JieRu-SW6-Eth-Trunk1]mode lacp-static 
    [JieRu-SW6-Eth-Trunk1]trunkport GigabitEthernet 0/0/1
    [JieRu-SW6-Eth-Trunk1]trunkport GigabitEthernet 0/0/2
    
    SW3(汇聚):
    <Huawei>system-view
    [Huawei]sysname HuiJu-SW3
    [HuiJu-SW3]undo info-center enable
    [HuiJu-SW3]int Eth-Trunk 1
    [HuiJu-SW3-Eth-Trunk1]mode lacp-static 
    [HuiJu-SW3-Eth-Trunk1]trunkport GigabitEthernet 0/0/2
    [HuiJu-SW3-Eth-Trunk1]trunkport GigabitEthernet 0/0/3
    
    

    核心交换机SW1、SW2

    SW1(核心):
    <Huawei>sys
    [Huawei]sysname HeXin-SW1
    [HeXin-SW1]undo info-center enable
    [HeXin-SW1]interface Eth-Trunk 2
    [HeXin-SW1-Eth-Trunk2]mode lacp-static 
    [HeXin-SW1-Eth-Trunk2]trunkport GigabitEthernet 0/0/2
    [HeXin-SW1-Eth-Trunk2]trunkport GigabitEthernet 0/0/3
    
    SW2(核心):
    <Huawei>system-view
    [Huawei]sysname HeXin-SW2
    [HeXin-SW2]undo info-center enable
    [HeXin-SW2]interface Eth-Trunk 2
    [HeXin-SW2-Eth-Trunk2]mode lacp-static 
    [HeXin-SW2-Eth-Trunk2]trunkport GigabitEthernet 0/0/1
    [HeXin-SW2-Eth-Trunk2]trunkport GigabitEthernet 0/0/2
    

    可以用如下命令查看聚合端口:

    [HeXin-SW1]display eth-trunk 2
    //正常情况下可以看到两个端口被选择
    

    Vlan及Trunk配置:

    SW5(接入):
    <Huawei>system-view	
    [Huawei]sysname JieRu-SW5
    [JieRu-SW5]undo info-center enable
    [JieRu-SW5]vlan batch 2 to 5 1000
    //尽管没有vlan 4 5的流量,但为了后边配置mst,所以全部配置
    //vlan 1000做管理vlan使用,后边Telnet用到
    [JieRu-SW5]interface Ethernet0/0/2
    [JieRu-SW5-Ethernet0/0/2]port link-type access 
    [JieRu-SW5-Ethernet0/0/2]port default vlan 2
    [JieRu-SW5-Ethernet0/0/2]quit
    [JieRu-SW5]interface GigabitEthernet 0/0/1
    [JieRu-SW5-GigabitEthernet0/0/1]port link-type trunk 
    [JieRu-SW5-GigabitEthernet0/0/1]port trunk allow-pass vlan 2 1000
    [JieRu-SW5-GigabitEthernet0/0/1]quit
    
    SW6(接入):
    [JieRu-SW6]vlan batch 2 to 5 1000
    [JieRu-SW6]int Ethernet 0/0/3
    [JieRu-SW6-Ethernet0/0/3]port link-type ac
    [JieRu-SW6-Ethernet0/0/3]po de vlan 3
    [JieRu-SW6-Ethernet0/0/3]qu
    [JieRu-SW6]int Eth-Trunk 1
    [JieRu-SW6-Eth-Trunk1]port link-type trunk 
    [JieRu-SW6-Eth-Trunk1]port trunk allow-pass vlan 3 1000
    [JieRu-SW6-Eth-Trunk1]qu
    
    SW3(汇聚):
    [HuiJu-SW3]vlan batch 2 to 5 1000
    [HuiJu-SW3]int GigabitEthernet 0/0/1
    [HuiJu-SW3-GigabitEthernet0/0/1]port link-type tr
    [HuiJu-SW3-GigabitEthernet0/0/1]port trunk allow-pass vlan all
    [HuiJu-SW3-GigabitEthernet0/0/1]qu
    [HuiJu-SW3]int Eth-Trunk 1
    [HuiJu-SW3-Eth-Trunk1]port link-type tr
    [HuiJu-SW3-Eth-Trunk1]qu
    [HuiJu-SW3]int Eth-Trunk 1
    [HuiJu-SW3-Eth-Trunk1]port trunk allow-pass vlan all
    [HuiJu-SW3-Eth-Trunk1]qu
    [HuiJu-SW3]port-group group-member GigabitEthernet 0/0/4 GigabitEthernet 0/0/5
    [HuiJu-SW3-port-group]port link-type trunk 
    [HuiJu-SW3-GigabitEthernet0/0/4]port link-type trunk 
    [HuiJu-SW3-GigabitEthernet0/0/5]port link-type trunk 
    [HuiJu-SW3-port-group]port trunk allow-pass vlan all
    [HuiJu-SW3-GigabitEthernet0/0/4]port trunk allow-pass vlan all
    [HuiJu-SW3-GigabitEthernet0/0/5]port trunk allow-pass vlan all
    [HuiJu-SW3-port-group]qu
    
    ----------------
    SW7(接入):
    <Huawei>sys
    [Huawei]sysname JieRu-SW7
    [JieRu-SW7]un in en
    [JieRu-SW7]vlan batch 2 to 5 1000
    [JieRu-SW7]int GigabitEthernet 0/0/2
    [JieRu-SW7-GigabitEthernet0/0/2]port link-type ac
    [JieRu-SW7-GigabitEthernet0/0/2]port de vlan 4
    [JieRu-SW7-GigabitEthernet0/0/2]qu
    [JieRu-SW7]int gi 0/0/3
    [JieRu-SW7-GigabitEthernet0/0/3]port link-type ac
    [JieRu-SW7-GigabitEthernet0/0/3]po de vlan 5
    [JieRu-SW7-GigabitEthernet0/0/3]qu
    [JieRu-SW7]int GigabitEthernet 0/0/1
    [JieRu-SW7-GigabitEthernet0/0/1]port trunk allow-pass vlan 4 5 1000
    [JieRu-SW7-GigabitEthernet0/0/1]qu
    
    
    SW4(汇聚):
    <Huawei>sys
    [Huawei]sysname HuiJu-SW4
    [HuiJu-SW4]un in en
    [HuiJu-SW4]vlan batch 2 to 5 1000
    [HuiJu-SW4]port-group group-member GigabitEthernet 0/0/1 GigabitEthernet 0/0/2 G
    igabitEthernet 0/0/3
    [HuiJu-SW4-port-group]port link-type trunk
    [HuiJu-SW4-GigabitEthernet0/0/1]port link-type trunk
    [HuiJu-SW4-GigabitEthernet0/0/2]port link-type trunk
    [HuiJu-SW4-GigabitEthernet0/0/3]port link-type trunk
    [HuiJu-SW4-port-group]port tr	
    [HuiJu-SW4-port-group]port trunk al	
    [HuiJu-SW4-port-group]port trunk allow-pass vlan all
    [HuiJu-SW4-GigabitEthernet0/0/1]port trunk allow-pass vlan all
    [HuiJu-SW4-GigabitEthernet0/0/2]port trunk allow-pass vlan all
    [HuiJu-SW4-GigabitEthernet0/0/3]port trunk allow-pass vlan all
    [HuiJu-SW4-port-group]qu
    
    ----------------
    SW8(供服务器使用):
    <Huawei>sys
    [Huawei]sysname SW8
    [SW8]un in en
    [SW8]vlan batch 2 to 5 200 1000
    [SW8]PORT-G group-member Ethernet 0/0/3 Ethernet 0/0/4
    [SW8-Ethernet0/0/4]port link-type ac
    [SW8-port-group]po de vlan 200
    [SW8-Ethernet0/0/3]po de vlan 200
    [SW8-Ethernet0/0/4]po de vlan 200
    [SW8-port-group]qu
    [SW8]port-g group-member Ethernet 0/0/1 Ethernet 0/0/2
    [SW8-port-group]port link-type trunk 
    [SW8-Ethernet0/0/1]port link-type trunk 
    [SW8-Ethernet0/0/2]port link-type trunk 
    [SW8-port-group]port trunk allow-pass vlan 200 1000
    [SW8-Ethernet0/0/1]port trunk allow-pass vlan 200 1000
    [SW8-Ethernet0/0/2]port trunk allow-pass vlan 200 1000
    [SW8-port-group]qu
    
    ----------------
    
    SW1(核心):
    <HeXin-SW1>sys
    [HeXin-SW1]vlan batch 2 to 5 200 1000
    [HeXin-SW1]int GigabitEthernet 0/0/5
    [HeXin-SW1-GigabitEthernet0/0/5]port link-type tr
    [HeXin-SW1-GigabitEthernet0/0/5]port tr allow-pass vlan 200 1000
    [HeXin-SW1-GigabitEthernet0/0/5]qu
    [HeXin-SW1]int GigabitEthernet 0/0/1
    [HeXin-SW1-GigabitEthernet0/0/1]port link-type tr
    [HeXin-SW1-GigabitEthernet0/0/1]port trunk allow-pass vlan 2 3 1000
    [HeXin-SW1-GigabitEthernet0/0/1]qu
    [HeXin-SW1]int GigabitEthernet 0/0/4
    [HeXin-SW1-GigabitEthernet0/0/4]port link-ty tr
    [HeXin-SW1-GigabitEthernet0/0/4]port trunk allow-pass vlan 4 5 1000
    [HeXin-SW1-GigabitEthernet0/0/4]qu
    [HeXin-SW1]int Eth-Trunk 2
    [HeXin-SW1-Eth-Trunk2]port link-type tr
    [HeXin-SW1-Eth-Trunk2]port trunk allow-pass vlan all
    [HeXin-SW1-Eth-Trunk2]qu
    [HeXin-SW1]vlan 800 //用于创建三层SVI接口
    [HeXin-SW1-vlan800]qu
    [HeXin-SW1]int GigabitEthernet 0/0/6
    [HeXin-SW1-GigabitEthernet0/0/6]port link-type ac
    [HeXin-SW1-GigabitEthernet0/0/6]port default vlan 800
    
    SW2(核心):
    [HeXin-SW2]vlan batch 2 to 5 200 801 1000
    [HeXin-SW2]int GigabitEthernet 0/0/3
    [HeXin-SW2-GigabitEthernet0/0/3]port link-ty tr
    [HeXin-SW2-GigabitEthernet0/0/3]port trunk allow-pass vlan 4 5 1000
    [HeXin-SW2-GigabitEthernet0/0/3]qu
    [HeXin-SW2]int GigabitEthernet 0/0/4
    [HeXin-SW2-GigabitEthernet0/0/4]port link-type tr
    [HeXin-SW2-GigabitEthernet0/0/4]port trunk allow-pass vlan 2 3 1000
    [HeXin-SW2-GigabitEthernet0/0/4]qu
    [HeXin-SW2]int Eth-Trunk 2
    [HeXin-SW2-Eth-Trunk2]port link-type trunk 
    [HeXin-SW2-Eth-Trunk2]port tr allow-pass vlan all
    [HeXin-SW2-Eth-Trunk2]qu
    [HeXin-SW2]int GigabitEthernet 0/0/5
    [HeXin-SW2-GigabitEthernet0/0/5]port link-type tr
    [HeXin-SW2-GigabitEthernet0/0/5]port tr all vlan 200 1000
    [HeXin-SW2-GigabitEthernet0/0/5]qu
    [HeXin-SW2]int gi0/0/6
    [HeXin-SW2-GigabitEthernet0/0/6]port link-type ac
    [HeXin-SW2-GigabitEthernet0/0/6]port de vlan 801

    当需要将某个交换机端口由trunk改为access,可以:

    undo port default vlan xx
    或
    undo port  trunk allow-pass vlan all
    
    而后
    undo port link-type

    裁剪vlan的目的在于减小广播域范围。

    更多相关内容
  • 华为配置eth-trunk接口下的LACP模式的链路聚合示例(交换机之间直连
  • Eth-Trunk接口能够实现负载分担、增加带宽和提高可靠性。
  • Eth-trunk

    万次阅读 2021-10-29 09:40:52
    一、Eth-trunk的概念 1、Eth-trunk的作用 2、Eth-trunk的前提条件 二、Eth-trunk的案例 1、二层案例 2、三层案例 总结 前言 Eth-trunk(端口绑定技术)是将一组物理接口捆绑在一起,来增加带宽,又称为多...

    目录

    前言

    一、Eth-trunk的概念

    1、Eth-trunk的作用

    2、Eth-trunk的前提条件

    二、Eth-trunk的案例

    1、二层案例

    2、三层案例

    总结


    前言

    Eth-trunk(端口绑定技术)是将一组物理接口捆绑在一起,来增加带宽,又称为多接口负载均衡组或链路聚合组。

    一、Eth-trunk的概念

    1、Eth-trunk的作用

    把两台设备之间建立链路聚合组,可以提供更高的通讯带宽和更高的可靠性,链路的聚合不仅为设备通信提供了冗余保护,而且不需要对硬件进行升级。

    2、Eth-trunk的前提条件

    1、每个Eth-trunk接口下最多包含8个接口

    2、成员接口不能配置任何业务和静态MAC地址

    3、成员加入Eth-trunk时,必须为缺省的bried类型接口

    4、Eth-trunk接口不能嵌套,即成员接口不能是Eth-trunk

    5、一个以太网接口只能加入一个Eth-trunk接口,如果需要加入其他组的Eth-trunk,必须要退出的原先的Eth-trunk

    6、一个Eth-trunk接口中的成员接口必须是同一类型的,例如如百兆和千兆不能加入同一个Eth-trunk接口。

    7、可以将不同接口板上的以太网接口加入到同一个Eth-trunk

    8、如果本地设备使用Eth-trunk,与成员接口直连的对端也要捆绑Eth-trunk两端才能通信

    9、成员接口速率不一致时,实际使用速率小的接口可能会出现拥塞导致丢包。

    10、当成员接口加入Eth-trunk组后,学习MAC地址时是按照Eth-trunk,而不是按照成员接口来学习的

    二、Eth-trunk的案例

    1、二层案例

    pc1和pc2分别属于vlan10,LSW1和LSW2的g0/0/1和g0/02端口加入 Eth-trunk组增加带宽。最后pc验证连通性。

    LSW1配置
    <Huawei>undo terminal monitor                               关闭弹窗
    <Huawei>sys                                                               进入用户视图
    [Huawei]sysname LSW1                                               更改名字为LSW1
    [LSW1]user-interface console 0
    [LSW1-ui-console0]id 0 0                                             永不超时
    [LSW1-ui-console0]q                                                    退回上一级
    [LSW1]vlan batch 10                                                   创建vlan 10

    [LSW1]int eth-trunk 1                                                 进入eth-trunk
    [LSW1-Eth-Trunk1]q                                                      退回上一级
    [LSW1]int g0/0/1                                                         进入g0/0/1

    [LSW1-GigabitEthernet0/0/1]eth-trunk 1                    加入eth-trunk

    [LSW1-GigabitEthernet0/0/1]int g0/0/2                    进入g0/0/2      
    [LSW1-GigabitEthernet0/0/2]eth-trunk 1                 加入eth-trunk

    [LSW1-GigabitEthernet0/0/2]q                                      退回上一级

    [LSW1]int e0/0/1                                                            进入e0/0/1

    [LSW1-Ethernet0/0/1]port hybrid pvid vlan 10          定义标签vlan 10

    [LSW1-Ethernet0/0/1]port hybrid untagged vlan 10  脱掉vlan10 标签

    [LSW1]int eth-trunk 1                                                进入 eth-trunk
    [LSW1-Eth-Trunk1]port hybrid tagged vlan 10         允许vlan10直接通过

    LSW2配置

    <Huawei>undo terminal monitor                               关闭弹窗
    <Huawei>sys                                                               进入用户视图
    [Huawei]sysname LSW1                                               更改名字为LSW2
    [LSW2]user-interface console 0
    [LSW2-ui-console0]id 0 0                                             永不超时
    [LSW2-ui-console0]q                                                    退回上一级
    [LSW2]vlan batch 10                                                   创建vlan 10

    [LSW2]int eth-trunk 1                                                 进入eth-trunk
    [LSW2-Eth-Trunk1]q                                                      退回上一级
    [LSW2]int g0/0/1                                                         进入g0/0/1

    [LSW2-GigabitEthernet0/0/1]eth-trunk 1                    加入eth-trunk

    [LSW2-GigabitEthernet0/0/1]int g0/0/2                    进入g0/0/2      
    [LSW2-GigabitEthernet0/0/2]eth-trunk 1                 加入eth-trunk

    [LSW2-GigabitEthernet0/0/2]q                                      退回上一级

    [LSW2]int e0/0/1                                                            进入e0/0/1

    [LSW2-Ethernet0/0/1]port hybrid pvid vlan 10          定义标签vlan 10

    [LSW2-Ethernet0/0/1]port hybrid untagged vlan 10  脱掉vlan10 标签

    [LSW2]int eth-trunk 1                                                进入 eth-trunk
    [LSW2-Eth-Trunk1]port hybrid tagged vlan 10         允许vlan10直接通过

    pc验证

    经验证能够正常通常。

    2、三层案例

     pc1和pc2分别属于10.0网段和20.0网段,LSW1和LSW2的g0/0/1和g0/02端口加入 Eth-trunk组增加带宽。最后pc验证连通性。

    LSW1配置

    <HUAWEI>undo terminal monitor                                         关闭弹窗
    <HUAWEI>sys                                                                         用户试图
    [*HUAWEI]user-interface console 0                                        延长1440s
    [*HUAWEI-ui-console0]id 1440
    [*HUAWEI-ui-console0]commit                                              载入
    [~LSW1-ui-console0]q                                                           退回上一级
    [*LSW1]int eth-trunk 1                                                          进入eth-trunk
    [*LSW1-Eth-Trunk1]q                                                               退回上一级
    [*LSW1]int g1/0/2                                                                 进入g1/0/2端口
    [*LSW1-GE1/0/2]eth-trunk 1                                                 加入eth-trunk组                            
    [*LSW1-GE1/0/2]commit                                                       载入
    [~LSW1-GE1/0/2]int g1/0/2                                                 进入g1/0/2
    [~LSW1-GE1/0/2]un sh                                                         激活端口
    [*LSW1-GE1/0/2]int g1/0/1                                                 进入1/0/1
    [*LSW1-GE1/0/1]un sh                                                          激活端口
    [*LSW1-GE1/0/1]eth-trunk 1                                              加入eth-trunk1
    [~LSW1]int g1/0/0                                                             进入g1/0/0
    [~LSW1-GE1/0/0]port link-type hybrid                             选择hybrid模式
    [*LSW1-GE1/0/0]port hybrid pvid vlan 1                           定义标签vlan1
    [*LSW1-GE1/0/0]port hybrid untagged vlan 1                   脱掉标签vlan1
    [*LSW1-GE1/0/0]commit                                                      载入
    [~LSW1-GE1/0/0]un sh                                                        激活端口
    [~LSW1-GE1/0/0]int eth-trunk 1                                        进入 eth-trunk
    [~LSW1-Eth-Trunk1]undo portswitch                                关闭交换机接口
    [*LSW1-Eth-Trunk1]ip add 10.1.1.1 24                               配置ip地址 10.1.1.1/24
    [*LSW1-Eth-Trunk1]un sh                                                   激活端口
    [*LSW1-Eth-Trunk1]commit                                                载入
    [~LSW1-Eth-Trunk1]q                                                        退回上一级
    [~LSW1]int vlanif 1                                                            进入vlan1
    [*LSW1-Vlanif1]ip add 192.168.10.1 24                             配置ip地址 192.168.10.1/24
    [*LSW1-Vlanif1]un sh                                                         激活端口
    [*LSW1-Vlanif1]q                                                                退回到上一级
    [*LSW1]int vlanif 1                                                              进入 vlan1
    [*LSW1-Vlanif1]commit                                                      载入
    [~LSW1-Vlanif1]q                                                                退回到上一级                                                            
    [~LSW1]ip route-static 192.168.20.0  24 10.1.1.2              获取192.168.20.0 网络号,下一条地址 10.1.1.2
    [*LSW1]commit                                                                   载入

    LSW2配置

    <HUAWEI>undo terminal monitor                               关闭弹窗
    <HUAWEI>sys                                                               用户试图
    [*HUAWEI]user-interface console 0                               延长1440s
    [*HUAWEI-ui-console0]id 1440
    [*HUAWEI-ui-console0]commit                                     载入 
    [~LSW2-ui-console0]q                                                退回上一级
    [*LSW1]int g1/0/2                                                      进入g1/0/2端口
    [*LSW2-GE1/0/2]eth-trunk 1                                     加入eth-trunk组 
    [*LSW2-GE1/0/2]commit                                             载入                                     
    [~LSW2-GE1/0/2]int g1/0/2                                       进入g1/0/2                                      
    [~LSW2-GE1/0/2]un sh                                               激活端口                                               
    [*LSW2-GE1/0/2]int g1/0/1                                        进入g1/0/1端口 
    [*LSW2-GE1/0/1]un sh                                               激活端口
    [*LSW2-GE1/0/1]eth-trunk 1                                     加入 eth-trunk组
    [~LSW2]int g1/0/0                                                    进入 g1/0/0
    [~LSW2-GE1/0/0]port link-type hybrid                   选择hybrid模式       
    [*LSW2-GE1/0/0]port hybrid pvid vlan 1                定义标签vlan 1      
    [*LSW2-GE1/0/0]port hybrid untagged vlan 1          允许脱掉标签流量   
    [*LSW2-GE1/0/0]commit                                             载入
    [~LSW2-GE1/0/0]un sh                                             激活端口
    [~LSW2-GE1/0/0]int eth-trunk 1                              进入 eth-trunk1
    [~LSW2-Eth-Trunk1]undo portswitch                        关闭交换机接口
    [*LSW2-Eth-Trunk1]ip add 10.1.1.1 24                      配置ip地址 10.1.1.1/24
    [*LSW2-Eth-Trunk1]un sh                                         激活端口
    [*LSW2-Eth-Trunk1]commit                                      载入
    [~LSW2-Eth-Trunk1]q                                              退回到上一级
    [~LSW2]int vlanif 1                                                    进入vlan 1
    [*LSW2-Vlanif1]ip add 192.168.20.1 24                    配置ip地址192.168.20/24
    [*LSW2-Vlanif1]un sh                                               激活端口
    [*LSW2-Vlanif1]q                                                      退回到上一级
    [*LSW2]int vlanif 1                                                   进入 vlan1
    [*LSW2-Vlanif1]commit                                           载入
    [~LSW2-Vlanif1]q                                                     退回到上一级
    [~LSW2]ip route-static 192.168.10.0  24 10.1.1.1    获取192.168.20.0 网络号,下一条地址 10.1.1.2
    [*LSW2]commit                                                        载入

    最后双方验证连通性

     

      验证成功,双方pc都能互相通信。 

    总结

    本次主要介绍了,Eth-trunk的两种类型。Eth-trunk的合理利用可以增加链路带宽。

     

     


     


     

    展开全文
  • 华为s交换机Eth-Trunk

    2015-11-12 22:25:09
    端口聚合技术 手动分担 LACP 华为s交换机Eth-Trunk
  • Eth-Trunk接口做心跳口别忘记配这条命令
  • E-trunk+Eth-trunk模拟实验(ENSP)

    万次阅读 2021-11-26 12:45:02
    E-trunk是跨设备的链路聚合,基于LACP进行了扩展,链路可靠性从单板级提高到了设备级,常用与CE双归接入PE1和PE2。 E-trunk配置示例: 1、SW2和SW3配置三层接口,能互相通信 sw2: interface Vlanif100 ...

    E-trunk是跨设备的链路聚合,基于LACP进行了扩展,链路可靠性从单板级提高到了设备级,常用与CE双归接入PE1和PE2。

    E-trunk配置示例:

     

     

     1、SW2和SW3配置三层接口,能互相通信

    sw2:
    
    interface Vlanif100
    ip address 10.1.1.1 255.255.255.0
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 100
    
    sw3:
    
    interface Vlanif100
    ip address 10.1.1.2 255.255.255.0
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 100

    2、sw1、sw2、sw3、sw4配置eth-trunk,并将相应的接口绑定到eth-trunk

    [sw1]interface Eth-Trunk 10
    mode lacp-static                   //要配置模式为静态,而且要先设置模式再绑定端口
    trunkport GigabitEthernet 0/0/1 to 0/0/4
    
    
    [sw2]interface Eth-Trunk 20
    mode lacp-static
    trunkport GigabitEthernet 0/0/1
    trunkport GigabitEthernet 0/0/2
    [sw2]interface Eth-Trunk 24        //sw2与sw4之间创建eth-trunk24
    mode lacp-static                   
    trunkport GigabitEthernet 0/0/4 
    trunkport GigabitEthernet 0/0/5
    
    [sw3]interface Eth-Trunk 30
    mode lacp-static
    trunkport GigabitEthernet 0/0/1
    trunkport GigabitEthernet 0/0/2
    [sw2]interface Eth-Trunk 34        //sw3与sw4之间创建eth-trunk34
    mode lacp-static                   
    trunkport GigabitEthernet 0/0/4 
    trunkport GigabitEthernet 0/0/5
    
    [sw4]int Eth-Trunk 40
    mode lacp-static                   
    trunkport GigabitEthernet 0/0/1 to 0/0/4

    在各交换机上查看eth-trunk是否正常,示例sw1

    [sw1]dis eth-trunk 10
    Eth-Trunk10's state information is:
    Local:
    LAG ID: 10                  WorkingMode: STATIC                               
    Preempt Delay: Disabled     Hash arithmetic: According to SIP-XOR-DIP         
    System Priority: 32768      System ID: 4c1f-cc03-4f4e                         
    Least Active-linknumber: 1  Max Active-linknumber: 8                          
    Operate status: up          Number Of Up Port In Trunk: 2                     
    --------------------------------------------------------------------------------
    ActorPortName          Status   PortType PortPri PortNo PortKey PortState Weight
    GigabitEthernet0/0/1   Selected 1GE      32768   2      2609    10111100  1     
    GigabitEthernet0/0/2   Unselect 1GE      32768   3      2609    10110000  1     
    GigabitEthernet0/0/3   Selected 1GE      32768   4      2609    10111100  1     
    GigabitEthernet0/0/4   Unselect 1GE      32768   5      2609    10110000  1     
    
    Partner:
    --------------------------------------------------------------------------------
    ActorPortName          SysPri   SystemID        PortPri PortNo PortKey PortState
    GigabitEthernet0/0/1   32768    0000-0000-0001  32768   2      33073   10111100
    GigabitEthernet0/0/2   32768    0000-0000-0001  32768   32770  33073   10100000
    GigabitEthernet0/0/3   32768    0000-0000-0001  32768   3      33073   10111100
    GigabitEthernet0/0/4   32768    0000-0000-0001  32768   32771  33073   10100000

    3、在sw2和sw3上配置e-trunk

    SW2为主设备

    [sw2]e-trunk 1
    [sw2-e-trunk-1]priority 99 //配置优先级,越小越优默认是100,用于竞争主备,备用设备要down接口
    [sw2-e-trunk-1]peer-address 10.1.1.2 source-address 10.1.1.1 //指定对端ip和本ip

    SW3为备用设备

    [sw3]e-trunk 1
    [sw3-e-trunk-1]peer-address 10.1.1.1 source-address 10.1.1.2

    在sw2和sw3上绑定e-trunk

    [sw2]lacp e-trunk system-id 0000-0102-0304 //配置MAC地址
    [sw2]lacp e-trunk priority 32768 //配置优先级,默认就是32768
    [sw2]int Eth-Trunk 20
    [sw2-Eth-Trunk20]e-trunk 1 remote-eth-trunk 30 //关联E-trunk 1,remote-eth-trunk 30是对端Eth-trunk30
    [sw2]int Eth-Trunk 24
    [sw2-Eth-Trunk24]e-trunk 1 remote-eth-trunk 30 //关联E-trunk 1,remote-eth-trunk 30是对端Eth-trunk30
    
    [sw3]lacp e-trunk system-id 0000-0102-0304
    [sw3]lacp e-trunk priority 32768
    [sw3]int Eth-Trunk 30
    [sw3-Eth-Trunk30]e-trunk 1 remote-eth-trunk 20
    [sw3]int Eth-Trunk 34
    [sw3-Eth-Trunk34]e-trunk 1 remote-eth-trunk 20
    注:配置两台mac地址和优先级要保持一致
    

    4、查看sw2和sw3的e-trunk状态

    [sw2]display e-trunk 1
                                The E-Trunk information
    E-TRUNK-ID : 1                          Revert-Delay-Time (s) : 120
    Priority : 99                           System-ID : 4c1f-cc5b-1cf4
    Peer-IP : 10.1.1.2                      Source-IP : 10.1.1.1
    State : Master                          Causation : PRI
    Send-Period (100ms) : 10                Fail-Time (100ms) : 200
    Receive : 12622                         Send : 12634
    RecDrop : 0                             SndDrop : 9
    Peer-Priority : 100                     Peer-System-ID : 4c1f-cce7-14de
    Peer-Fail-Time (100ms) : 200            BFD-Session : -
    Description : -
    --------------------------------------------------------------------------------
                                The Member information
    Type      ID  LocalPhyState  Work-Mode     State   Causation        Remote-ID
    Eth-Trunk 20  Up             auto          Master  ETRUNK_MASTER    30        
    Eth-Trunk 24  Up             auto          Master  ETRUNK_MASTER    30   
    [sw3]display e-trunk 1
                                The E-Trunk information
    E-TRUNK-ID : 1                          Revert-Delay-Time (s) : 120
    Priority : 100                          System-ID : 4c1f-cce7-14de
    Peer-IP : 10.1.1.1                      Source-IP : 10.1.1.2
    State : Backup                          Causation : PRI
    Send-Period (100ms) : 10                Fail-Time (100ms) : 200
    Receive : 16809                         Send : 17200
    RecDrop : 9                             SndDrop : 399
    Peer-Priority : 99                      Peer-System-ID : 4c1f-cc5b-1cf4
    Peer-Fail-Time (100ms) : 200            BFD-Session : -
    Description : -
    --------------------------------------------------------------------------------
                                The Member information
    Type      ID  LocalPhyState  Work-Mode     State   Causation        Remote-ID
    Eth-Trunk 30  Down           auto          Backup  PEER_MEMBER_UP   20        
    Eth-Trunk 34  Down           auto          Backup  ETRUNK_BACKUP    20 

    5、模拟故障,当sw2出现故障(关机),查看sw3的e-trunk状态是否成为master

    [sw3]display e-trunk 1
                                The E-Trunk information
    E-TRUNK-ID : 1                          Revert-Delay-Time (s) : 120
    Priority : 100                          System-ID : 4c1f-cce7-14de
    Peer-IP : 10.1.1.1                      Source-IP : 10.1.1.2
    State : Master                          Causation : TIMEOUT
    Send-Period (100ms) : 10                Fail-Time (100ms) : 200
    Receive : 17289                         Send : 17712
    RecDrop : 9                             SndDrop : 429
    Peer-Priority : -                       Peer-System-ID : -
    Peer-Fail-Time (100ms) : -              BFD-Session : -
    Description : -
    --------------------------------------------------------------------------------
                                The Member information
    Type      ID  LocalPhyState  Work-Mode     State   Causation        Remote-ID
    Eth-Trunk 30  Up             auto          Master  ETRUNK_MASTER    20        
    Eth-Trunk 34  Up             auto          Master  ETRUNK_MASTER    20 

    在SW1上查看eth-trunk 10的状态,看链路是否自动切换

    [sw1]display eth-trunk 10
    Eth-Trunk10's state information is:
    Local:
    LAG ID: 10                  WorkingMode: STATIC                               
    Preempt Delay: Disabled     Hash arithmetic: According to SIP-XOR-DIP         
    System Priority: 32768      System ID: 4c1f-cc03-4f4e                         
    Least Active-linknumber: 1  Max Active-linknumber: 8                          
    Operate status: up          Number Of Up Port In Trunk: 2                     
    --------------------------------------------------------------------------------
    ActorPortName          Status   PortType PortPri PortNo PortKey PortState Weight
    GigabitEthernet0/0/1   Unselect 1GE      32768   2      2609    10100010  1     
    GigabitEthernet0/0/2   Selected 1GE      32768   3      2609    10111100  1     
    GigabitEthernet0/0/3   Unselect 1GE      32768   4      2609    10100010  1     
    GigabitEthernet0/0/4   Selected 1GE      32768   5      2609    10111100  1     
    
    Partner:
    --------------------------------------------------------------------------------
    ActorPortName          SysPri   SystemID        PortPri PortNo PortKey PortState
    GigabitEthernet0/0/1   0        0000-0000-0000  0       0      0       10100011
    GigabitEthernet0/0/2   32768    0000-0000-0001  32768   32770  33073   10111100
    GigabitEthernet0/0/3   0        0000-0000-0000  0       0      0       10100011
    GigabitEthernet0/0/4   32768    0000-0000-0001  32768   32771  33073   10111100

    展开全文
  • 《华为基础实验》十八 配置和实施Eth-Trunk.docx
  • Eth-Trunk

    2021-04-10 19:35:52
    Eth-Trunk Eth-Trunk 技术背景 随着网络中部署的业务量不断增长,对于全双工点对点链路,单条物理链路的带宽已不能满足正常的业务流量需求。如果将当前接口板替换为具备更高带宽的接口板,则会浪费现有的设备资源,...

    Eth-Trunk

    Eth-Trunk 技术背景

    随着网络中部署的业务量不断增长,对于全双工点对点链路,单条物理链路的带宽已不能满足正常的业务流量需求。如果将当前接口板替换为具备更高带宽的接口板,则会浪费现有的设备资源,而且升级代价较大。如果增加设备间的链路数量,则在作为三层口使用时需要在每个接口上配置IP地址,从而导致浪费IP地址资源。

    Eth-Trunk 技术如何实现以及解决的问题

    Eth-Trunk( 链路聚合技术 )作为一种捆绑技术,可以把多个独立的物理接口绑定在一起作为一个大带宽的逻辑接口使用从而实现 增加链路带宽 的目的这样既不用替换接口板也不会浪费IP地址资源。

    Eth-Trunk 技术通信原理

    数据流控制-负载分担

    ●Ether—Trunk支持在同一个以太信道组的链路中执行负载均衡
    ●负载均衡动作可以基于MAC、端口、IP (源IP、目的IP或两者)
    ●默认的行为:源目IP地址对( src-dst-ip )

    数据流控制-负载分担

    对于负载分担,可以分为 逐包 的负载分担和 逐流 的负载分担。
    逐包的负载分担在使用Eth-Trunk转发数据时,由于聚合组两端设备之间有多条物理链路,就会产生同一数据流的第一个数据帧在一条物理链路上传输,而第二个数据帧在另外一条物理链路上传输的情况。这样一来同一数据流的第二个数据帧就有可能比第一个数据帧先到达对端设备,从而产生 接收数据包乱序 的情况。

    逐流的负载分担这种机制把数据帧中的地址通过 HASH算法生成HASH-KEY值,然后根据这个数值在Eth-Trunk转发表中寻找对应的出接口,不同的MAC或IP地址HASH得出的HASH-KEY值不同,从而出接口也就不同,这样既保证了同一数据流的帧在同一条物理链路转发,又实现了流量在聚合组内各物理链路上的负载分担。逐流负载分担能保证包的顺序,但不能保证带宽利用率。

    注:一个数据包最大传输单元为1500字节(MTU:最大传输单元)

    负载分担方式

    为了 避免 数据包 乱序 情况的发生,Eth-Trunk采用 逐流负载分担 的机制,其中如何转发数据则由于选择不同的负载分担方式而有所差别。
    负载分担的方式主要包括以下几种,用户可以根据具体应用选择不同的负载分担方式。

    • 根据报文的源MAC地址进行负载分担
    • 根据报文的目的MAC地址进行负载分担
    • 根据报文的源IP地址进行负载分担
    • 根据报文的目的IP地址进行负载分担
    • 根据报文的源MAC地址和目的MAC地址进行负载分担
    • 根据报文的源IP地址和目的IP地址进行负载分担

    Eth-Trunk 技术实现原理

    以太信道组的建立

    (1)手动模式 (2)LACP (802.3AD)

    (1)手动模式

    手工模式下,Eth-Trunk的建立、成员接口的加入由手工配置,没有链路聚合控制协议LACP的参与。当需要在两个直连设备之间提供一个较大的链路带宽而设备又不支持LACP协议时,可以使用手工模式。

    手工模式可以实现增加 带宽、提高可靠性和负载分担的目的。
    在这里插入图片描述

    (2)LACP模式 (802.3AD)

    在这里插入图片描述

    Eth-Trunk 技术的配置

    二层链路聚合配置

    在这里插入图片描述

    静态方式配置:
    [SWA]interface Eth-Trunk 1
    [SW1-Eth-Trunk1]mode manual load-balance //指定手工配置的静态模式
    [SWA-Eth-Trunk1]interface GigabitEthernet0/0/1
    [SWA-GigabitEthernet0/0/1]eth-trunk 1
    [SWA-GigabitEthernet0/0/1]interface GigabitEthernet0/0/2
    [SWA-GigabitEthernet0/0/2]eth-trunk 1

    [SW2-Eth-Trunk1] trunkport GigabitEthernet 0/0/1 0/0/2 等价于上面的四行命令

    动态LACP模式
    interface Eth-Trunk2
    port link-type trunk
    port trunk allow-pass vlan 2 to 4094
    mode lacp-static //指定动态LACP模式
    trunkport GigabitEthernet 0/0/1 0/0/2 //将物理接口加入逻辑接口

    查看配置信息

    在这里插入图片描述

    三层链路聚合配置——路由器

    在这里插入图片描述
    静态方式配置:
    [SWA]interface Eth-Trunk 1
    [SWA]undo portswith
    [SWA]ip address 192.168.1.1 24
    [SW1-Eth-Trunk1]mode manual load-balance //指定手工配置的静态模式
    [SWA-Eth-Trunk1]interface GigabitEthernet0/0/1
    [SWA-GigabitEthernet0/0/1]eth-trunk 1
    [SWA-GigabitEthernet0/0/1]interface GigabitEthernet0/0/2
    [SWA-GigabitEthernet0/0/2]eth-trunk 1

    [SW2-Eth-Trunk1] trunkport GigabitEthernet 0/0/1 0/0/2 等价于上面的四行命令

    动态LACP模式
    interface Eth-Trunk2
    undo portswitch
    ip address 192.168.1.1 24
    port link-type trunk
    port trunk allow-pass vlan 2 to 4094
    mode lacp-static //指定动态LACP模式
    trunkport GigabitEthernet 0/0/1 0/0/2 //将物理接口加入逻辑接口

    查看配置信息

    两个成员接口已经被绑定到Eth-trunk 1。
    在这里插入图片描述

    Eth-Trunk 技术实施要点在这里插入图片描述

    Eth-Trunk 技术的优势

    增加带宽

    链路聚合接口的最大带宽可以达到各成员接口带宽之和。

    提高可靠性

    当某条活动链路出现故障时,流量可以切换到其他可用的成员链路上,从而提高链路聚合接口的可靠性。互为备份。

    负载分担

    在一个链路聚合组内,可以实现在各成员活动链路上的负载分担。

    展开全文
  • 链路聚合Eth-Trunk

    2021-08-12 08:43:16
    目录 一,链路聚合定义 二,链路聚合实现的条件 三,链路聚合划分 四,二层链路捆绑步骤 ...端口捆绑技术:链路聚合是将一组物理接口捆绑一起作为一个逻辑接口来增加带宽的一...1,每个eth-trunk接口下最多可包含8个.
  • MSTP和Eth-trunk

    千次阅读 2022-02-11 16:09:09
    eth-trunk 0 [SW2]int Eth-Trunk 0 [SW2-Eth-Trunk0]mode lacp-static [SW2-Eth-Trunk0]load-balance src-dst-mac [SW2-Eth-Trunk0]int g0/0/2 [SW2-GigabitEthernet0/0/2]eth-trunk 0 [SW2-GigabitEthernet0/0/2]...
  • 华为S系列交换机Eth-Trunk特性入门。这是V1.0_D版文档
  • Eth-Trunk链路聚合

    2021-07-15 08:49:36
    Eth-Trunk1]lacp preempt enable # 开启LACP抢占 [Huawei-Eth-Trunk1]lacp preempt delay 10 # 设置LACP抢占延时 [Huawei-Eth-Trunk1]port link-type trunk [Huawei-Eth-Trunk1]port trunk allow-pass vlan 10 20 ...
  • 一、Eth-Trunk简介 1.Eth-Trunk是将多条以太网链路聚合形成一条更高带宽的逻辑链路 2.配置Eth-Trunk后还会生成一个LAG(链路聚合组),也被称为“以太网聚合链路”还会生成一个逻辑接口,称之为“Eth-Trunk接口”...
  • ETH-trunk(链路聚合协议)&lacp

    千次阅读 2022-05-05 19:44:52
    以太网链路聚合Eth-Trunk简称链路聚合,它通过将多条以太网物理链路捆绑在一起成为一条逻辑链路,从而实现增加链路带宽的目的。同时,这些捆绑在一起的链路通过相互间的动态备份,可以有效地提高链路的可靠性。可以...
  • 链路聚合 Eth-Trunk

    2021-07-31 20:50:45
    Eth-Trunk中加入成员接口: 在Eth-Trunk接口视图下: 执行interface eth-trunk trunk-id命令,进入Eth-Trunk接口视图。 执行以下任一个步骤,添加Eth-Trunk成员接口。 配置LACP 创建LACP模式Eth-Trunk: 执行system...
  • 华为 Eth-Trunk链路聚合

    千次阅读 多人点赞 2020-09-09 20:11:32
    SW-2配置类似 [SW-2]display int Eth-Trunk SW-3 SW-4配置类似 [SW-4]int Eth-Trunk 11 [SW-4-Eth-Trunk11]mode lacp-static //设置本聚合组模式为lacp模式 [SW-4-Eth-Trunk11]load-balance src-dst-ip [SW-4-Eth-...
  • Eth-Trunk(链路聚合)

    千次阅读 多人点赞 2021-01-24 12:50:38
    Eth-Trunk(链路聚合) 以太网链路聚合Eth-Trunk简称链路聚合,它通过将多条以太网物理链路捆绑在一起成为一条逻辑链路,从而实现增加链路带宽的目的。同时,这些捆绑在一起的链路通过相互间的动态备份,可以有效地提高...
  • 理解Eth-Trunk

    2020-12-22 04:04:06
    1、Eth-Trunk背景随着网络中部署的业务量不断增长,对于全双工点对点链路,单条物理链路的带宽已不能满足正常的业务流量需求。如果将当前接口板替换为具备更高带宽的接口板,则会浪费现有的设备资源,而且升级代价较...
  • Eth-Trunk技术原理与配置

    千次阅读 2020-11-22 18:57:28
    文章目录前言Eth-Trunk基本原理Eth-Trunk概念手工负载分担模式LACP模式Eth-Trunk接口负载分担Eth-Trunk配置Eth-Trunk注意项 前言   随着网络中部署的业务量不断增长,对于全双工点对点链路,单条物理链路的带宽已...
  • Eth-Trunk是一种捆绑技术,它将多个物理接口捆绑成一个逻辑接口,这个逻辑接口就称为Eth-Trunk接口,捆绑在一起的每个物理接口称为成员接口。Eth-Trunk只能由以太网链路构成,其优势在于: 负载分担:在某一个Eth-...
  • 链路聚合Eth-Trunk配置实验 配置要求--------所有主机能互通 【XX可行换】 配置思路: SW1做主三层,汇聚层,用于连接边界设备 SW1配置eth-trunk 1,eth-trunk 2,绑定21,22,23,24端口 SW1的vlanif ip做PC的...
  • 问题:交换机S5700与防火墙USG5500无法对接Eth-trunk LACP-static模式,两端正常配置后,端口状态显示错误,Eth-trunk端口无法up 。问题描述:交换机侧 GE0/0/5和GE 0/0/6 组成Eth-trunk3 通过LACP-static与防火墙...
  • 链路聚合:Eth-Trunk

    2020-09-10 10:41:33
    1.Eth-Trunk原理 以太网链路聚合Eth-Trunk简称链路聚合,它通过将多条以太网物理链路捆绑在一起成为一条逻辑链路,从而实现增加链路带宽的目的。同时,这些捆绑在一起的链路通过相互间的动态备份,可以有效地提高...
  • ETH-TRUNK以太通道技术

    2022-03-14 11:17:41
    可以创建8个Eth-Trunk接口,每个Trunk接口下最多可以包含4条成员物理链路 4 一个物理端口只能加入到一个Trunk接口 5 成员口缺省权重为1,总权重不大于16,根据权重实施负载分担 6 支持逐流负载分担,对于三层...
  • 链路聚合 eth-trunk

    2022-02-21 18:00:29
    转发原理:eth-trunk位于mac于llc子层,属于数据链路层。 eth-trunk模块内部维护一张转发表,表由两项组成。 hash-key:hash-key是根据数据包的mac地址或ip地址等,仅hash算法得出。 接口号:不同的hash-key值对应...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 6,679
精华内容 2,671
关键字:

eth-trunk