精华内容
下载资源
问答
  • 静态路由综合实验

    2021-01-13 23:41:01
    静态路由综合实验实验要求实验分析:IP地址规划: 实验要求 1、R6为ISP, 接口IP地址均为公有地址;该设备只能配置IP地址,之后不能再对其进行任何配置; 2、 R1-R5为 局域网,私有IP地址192. 168.1.0/24,请合理分配;...

    实验要求

    1、R6为ISP, 接口IP地址均为公有地址;该设备只能配置IP地址,之后不能再对其进行任何配置;
    2、 R1-R5为 局域网,私有IP地址192. 168.1.0/24,请合理分配;
    3、所有路由器上环回,均代表连接用户的接口;
    4、R3下的两台PC通过DHCP自动获取IP地址;
    5、选路最佳,路由表尽量小,避免环路;
    6、R1-R5均可访问R6的环回;
    7、R6telnetR5的公有IP地址时,实际登陆到R1上;
    8、R4与R5正常通过1000M链路,故障时通过100M链路;

    实验拓扑

    实验分析:

    在该实验中:
    1.R6为ISP路由器,只能配置IP地址,因此内网需要访问互联网时需要在边界路由器上添加静态路由和出接口上做SNAT,即可达到R1-R5均可访问R6的环回的目的。
    2.IP地址的合理规划可以有效的减少路由条目。
    3.若要在R6TelnetR5的公有IP地址,实际登陆到R1,需要在出接口上做DNAT即可达到该目的。

    IP地址规划:

    划分思路:
    IP地址根据题目要求使用192.168.1.0/24进行划分,划分时,我们可将IP地址分成以下几类:骨干网P地址和各个路由器上的环回接口地址;骨干中每个网段需要两个IP地址,因此可以使用30位的掩码。在该实验中需要5(用户网段)+1(骨干网段)个网段,在骨干网段中,直接使用30位网络位的IP地址,将其他剩余地址作为预留地址,以备hi后的网络扩容使用。

    192.168.1.0/24
      192.168.1.0/27 --骨干
         192.168.1.0/30
         192.168.1.4/30
         192.168.1.8/30
         192.168.1.12/30
         192.168.1.16/30
         192.168.1.20/30
         192.168.1.24/30--预留
         192.168.1.28/30--预留
      192.168.1.32/27 --R1
         192.168.1.32/28
         192.168.1.48/28
      192.168.1.64/27 --R2
         192.168.1.64/28
         192.168.1.80/28
      192.168.1.96/27 --R3
         192.168.1.96/28
         192.168.1.112/28
      192.168.1.128/27 --R4
         192.168.1.128/28
         192.168.1.144/28
      192.168.1.160/27 --R5
         192.168.1.160/28
         192.168.1.176/28
      192.168.1.192/27 --预留
      192.168.1.224/27 --预留
    

    最终IP地址分配如图
    在这里插入图片描述

    实验配置

    1. 首先按照地址划分配置IP地址,并在配置时验证IP地址的准确性
    2. 手动配置静态路由,在配置结束后需要保证每个路由器的路由表有以下网段:
      192.168.1.0/30
      192.168.1.4/30
      192.168.1.8/30
      192.168.1.12/30
      192.168.1.16/30
      192.168.1.20/30
      192.168.1.64/27
      192.168.1.96/27
      192.168.1.128/27
      192.168.1.160/27
    3. 验证内网区域是否全网可达;
    4. 内网全网可达后配置静态默认路由,指向出接口方向,此时内网与外网可进行通信,但是外网发送给内网的数据无法到达内网,此时使用SNAT技术可打通外网与内网的路由;
      配置如下:

    acl number 2000
    rule 5 permit source 192.168.1.0 0.0.0.255 //使用ACL抓取感兴趣流量
    interface GigabitEthernet0/0/2
    ip address 1.1.1.1 255.255.255.0
    nat outbound 2000 //在接口使用easynat并调用ACL

    1. 若需要若要在R6TelnetR5的公有IP地址,实际登陆到R1;首先需要在R1上开启telnet;然后再在R5上做DNAT,进行端口映射。

    R1上开启telnet

    local-user huawei password cipher 123456
    local-user huawei privilege level 15
    local-user huawei service-type telnet //在R1上创建用户名为huawei,密码为123456的本地账户,指定其优先级并其服务类型为telnet
    user-interface vty 0 4 //配置Telnet,同时配置5个用户
    authentication-mode aaa //认证模式是AAA

    R5上做DNAT

    interface GigabitEthernet0/0/2
    ip address 1.1.1.1 255.255.255.0
    nat server protocol tcp global current-interface telnet inside 192.168.1.1 telnet //由于华为设备不支持使用接口IP地址作为全局地址,因此直接使用接口即可

    1. 验证结果
    2. R4与R5正常通过1000M链路,故障时通过100M链路;该要求可以使用浮动静态路由解决,将100M链路的优先级调整为61即可。

    各设备配置如下

    R1的静态路由配置

    ip route-static 0.0.0.0 0.0.0.0 192.168.1.2
    ip route-static 192.168.1.8 255.255.255.252 192.168.1.2
    ip route-static 192.168.1.12 255.255.255.252 192.168.1.6
    ip route-static 192.168.1.16 255.255.255.252 192.168.1.2
    ip route-static 192.168.1.16 255.255.255.252 192.168.1.6
    ip route-static 192.168.1.20 255.255.255.252 192.168.1.2
    ip route-static 192.168.1.20 255.255.255.252 192.168.1.6
    ip route-static 192.168.1.32 255.255.255.224 NULL0
    ip route-static 192.168.1.64 255.255.255.224 192.168.1.2
    ip route-static 192.168.1.96 255.255.255.224 192.168.1.6
    ip route-static 192.168.1.128 255.255.255.224 192.168.1.6
    ip route-static 192.168.1.128 255.255.255.224 192.168.1.2
    ip route-static 192.168.1.160 255.255.255.224 192.168.1.6
    ip route-static 192.168.1.160 255.255.255.224 192.168.1.2

    R2的静态路由配置

    ip route-static 0.0.0.0 0.0.0.0 192.168.1.10
    ip route-static 192.168.1.4 255.255.255.252 192.168.1.1
    ip route-static 192.168.1.16 255.255.255.252 192.168.1.10
    ip route-static 192.168.1.20 255.255.255.252 192.168.1.10
    ip route-static 192.168.1.32 255.255.255.224 192.168.1.1
    ip route-static 192.168.1.64 255.255.255.224 NULL0
    ip route-static 192.168.1.96 255.255.255.224 192.168.1.1
    ip route-static 192.168.1.96 255.255.255.224 192.168.1.10
    ip route-static 192.168.1.128 255.255.255.224 192.168.1.10
    ip route-static 192.168.1.160 255.255.255.224 192.168.1.10
    ip route-static 192.198.1.12 255.255.255.252 192.168.1.10

    R3的静态路由配置

    ip route-static 0.0.0.0 0.0.0.0 192.168.1.14
    ip route-static 192.168.1.0 255.255.255.252 192.168.1.5
    ip route-static 192.168.1.8 255.255.255.252 192.168.1.14
    ip route-static 192.168.1.16 255.255.255.252 192.168.1.14
    ip route-static 192.168.1.20 255.255.255.252 192.168.1.14
    ip route-static 192.168.1.32 255.255.255.224 192.168.1.5
    ip route-static 192.168.1.64 255.255.255.224 192.168.1.5
    ip route-static 192.168.1.64 255.255.255.224 192.168.1.14
    ip route-static 192.168.1.96 255.255.255.224 NULL0
    ip route-static 192.168.1.128 255.255.255.224 192.168.1.14
    ip route-static 192.168.1.160 255.255.255.224 192.168.1.14

    R4的静态路由配置

    ip route-static 0.0.0.0 0.0.0.0 192.168.1.18
    ip route-static 192.168.1.0 255.255.255.252 192.168.1.9
    ip route-static 192.168.1.4 255.255.255.252 192.168.1.13
    ip route-static 192.168.1.32 255.255.255.224 192.168.1.9
    ip route-static 192.168.1.32 255.255.255.224 192.168.1.13
    ip route-static 192.168.1.64 255.255.255.224 192.168.1.9
    ip route-static 192.168.1.96 255.255.255.224 192.168.1.13
    ip route-static 192.168.1.128 255.255.255.224 NULL0
    ip route-static 192.168.1.160 255.255.255.224 192.168.1.18
    ip route-static 192.168.1.160 255.255.255.224 192.168.1.21 preference 61

    R5的静态路由配置

    ip route-static 0.0.0.0 0.0.0.0 1.1.1.2
    ip route-static 192.168.1.0 255.255.255.252 192.168.1.17
    ip route-static 192.168.1.0 255.255.255.252 192.168.1.21 preference 61
    ip route-static 192.168.1.4 255.255.255.252 192.168.1.17
    ip route-static 192.168.1.4 255.255.255.252 192.168.1.21 preference 61
    ip route-static 192.168.1.8 255.255.255.252 192.168.1.17
    ip route-static 192.168.1.8 255.255.255.252 192.168.1.21 preference 61
    ip route-static 192.168.1.12 255.255.255.252 192.168.1.17
    ip route-static 192.168.1.12 255.255.255.252 192.168.1.21 preference 61
    ip route-static 192.168.1.32 255.255.255.224 192.168.1.17
    ip route-static 192.168.1.32 255.255.255.224 192.168.1.21 preference 61
    ip route-static 192.168.1.64 255.255.255.224 192.168.1.17
    ip route-static 192.168.1.64 255.255.255.224 192.168.1.21 preference 61
    ip route-static 192.168.1.96 255.255.255.224 192.168.1.17
    ip route-static 192.168.1.96 255.255.255.224 192.168.1.21 preference 61
    ip route-static 192.168.1.128 255.255.255.224 192.168.1.17
    ip route-static 192.168.1.128 255.255.255.224 192.168.1.21 preference 61
    ip route-static 192.168.1.160 255.255.255.224 NULL0

    实验现象

    在ISP上远程登陆R1:
    在这里插入图片描述
    R1可ping通公网IP

    实验总结

    1. 在此次实验中,内网全网可达、做完easynat内网与外网不通,检查后,是因为未在每个路由器上添加指向内网出口的静态默认路由,添加静态默认路由后全网可达。
    2. 每个路由器上的环回都做过子网汇总,因此需要添加空接口路由来避免路由黑洞。
    展开全文
  • HCIP之静态路由综合实验静态路由综合实验实验要求实验拓扑分析图 静态路由综合实验 实验要求 1.全网可达 2.拓扑中所需地址全部基于192.168.0.0/24划分所得 3.静态路由(不允许使用任何动态路由) 4.R1环回需要汇总 ...

    静态路由综合实验

    在这里插入图片描述

    实验要求

    1.全网可达
    2.拓扑中所需地址全部基于192.168.0.0/24划分所得
    3.静态路由(不允许使用任何动态路由)
    4.R1环回需要汇总

    实验拓扑分析图

    在这里插入图片描述

    实验过程

    在这里插入图片描述

    IP地址规划

    纵观全局,我们可以看出,一共需要9个网段:
    我们可以将192.168.0.0/24子网划分为三个网段,给环回一个,给骨干链路一个,给两个VLAN一个,分别为:
    借2位
    192.168.00000000.00000000/24
    128 64 32 16 8 4 2 1
    00—0,01—64,10—128,11–192
    192.168.0.0/26
    192.168.0.64/26
    192.168.0.128/26
    192.168.0.192/26

    取出前三个网段来用
    192.168.0.0/26用来给骨干链路,再将其划分为/30的
    相当于是借了4位
    128 64 32 16 8 4 2 1
    0000—0,192.168.0.0/30
    0001—4,192.168.0,4/30
    0010—8,192.168.0.8/30
    0011—12,192.168.0.12/30
    0100—16,192.168.0.16/30
    0101—20,192.168.0.20/30
    0110—24,192.168.0.24/30
    0111—28,192.168.0.28/30
    1000—32,192.168.0.32/30
    1001—36,192.168.0.36/30
    1010—40,192.168.0.40/30
    1011—44,192.168.0.44/30
    1100—48,192.168.0.48/30
    1101—52,192.168.0.52/30
    1110—56,192.168.0.56/30
    1111—60,192.168.0.60/30
    我们随便取其中6个网段拿出来用即可!

    192.168.0.64/26用来给R1上的三个环回地址,借2位,将其划分为/28的
    128 64 32 16 8 4 2 1
    00—64,192.168.0.64/28
    01—80,192.168.0.80/28
    10—96,192.168.0.96/28
    11—112,192.168.0.112/28
    当然我们只需要取其中3个网段拿出来用即可!

    192.168.0.128/26用来给两个VLAN,因为一个VLAN只有两台主机,所以将其划分为/27的即可;
    192.168.0.128/27
    192.168.0.160/27
    192.168.0.192/27
    当然我们只需要取其中两个网段出来用即可!

    实现内网可达

    划分VLAN
    创建VLAN
    在这里插入图片描述
    定义接口类型
    在这里插入图片描述
    允许所有VLAN通过
    在这里插入图片描述
    定义接口类型
    在这里插入图片描述
    划分到VLAN2中去
    在这里插入图片描述
    同理
    在这里插入图片描述在这里插入图片描述
    然后再到0/0/4接口
    在这里插入图片描述
    在这里插入图片描述
    然后再到SW2中去
    同理
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    然后再给R3配置虚接口
    创建虚拟接口
    在这里插入图片描述
    给接口配置IP地址
    在这里插入图片描述
    在这里插入图片描述
    开启ARP广播功能,因为虚拟接口的默认ARP广播功能是关闭的,所以为可以一直ping通,需手动开启。
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    然后再给PC分配IP地址,利用地址池,DHCP进行分配
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    开启DHCP
    在这里插入图片描述
    虚接口调用
    在这里插入图片描述

    同理,给VLAN3也创建一个地址池,在虚拟接口上调用即可
    在这里插入图片描述
    在这里插入图片描述在这里插入图片描述在这里插入图片描述
    在这里插入图片描述
    检验一下:
    在这里插入图片描述
    在这里插入图片描述
    同理,其他PC也是同样的方法
    我们在R4上检测一下上下左右是否都能ping通?
    通过检测确实可以ping通!

    给每台设备都写静态路由!

    查看路由表
    在这里插入图片描述
    空间口防环
    R1上:
    在这里插入图片描述
    R4上:
    在这里插入图片描述

    测试内网是否可以全网可达:
    在这里插入图片描述
    在这里插入图片描述
    通过测试内网已经全网可达;

    实现内网和外网可达

    在R6上配置给接口配地址
    在这里插入图片描述
    在这里插入图片描述
    互相ping一下,发现没问题。

    现在我们再写缺省,单方向写
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    内网全网可达
    在这里插入图片描述
    配置NAT,做easy IP:
    在这里插入图片描述
    在这里插入图片描述
    Ping ISP
    在这里插入图片描述
    成功!
    实验结束!

    总结

    总体来讲,实验其实并不难,需要重点掌握的是IP地址规划以及内网和外网的可达!

    展开全文
  • 通过静态路由综合实验,熟悉网络搭建的过程。

    拓扑图如图所示:
    在这里插入图片描述
    题目需求如下:
    在这里插入图片描述
    每一个网络部署思路应如下:

    1.拓扑设计--已经设计好了, 需要规划ip地址。
    2.拓扑搭建
    3.配置
    (1)底层--所有结点拥有合法ip
    (2)路由--全网可达
    (3)策略--规则,优化,安全
    (4)测试
    (5)排错
    4.维护
    5.升级---割接,一定要留有ip地址。
    

    **

    1.ip地址规划。

    **
    地址规划的目的:

    1.方便汇总
    2.便于管理
    3.避免地址浪费。
    

    根据目的反过来进行ip地址的规划,根据题目要求,需要内网分配192.168.1.0/24网段,可以进行划分如下:
    在这里插入图片描述
    将路由器上的环回分为5个网段,骨干路线总为1个网段,一共6个网段,就需要分8段

    192.168.1.0/27
    192.168.1.32/27
    192.168.1.64/27
    192.168.1.96/27
    192.168.1.128/27
    192.168.1.160/27留下两端作为后续网络添加
    

    再往下细分,一个环回需要2个网段,我们可以将192.168.1.0/27分给骨干,其余分给R1-5上的环回(注:图中RA7应为R5).

    骨干:192.168.1.0/27
    192.168.1.0/30
    192.168.1.4/30
    192.168.1.8/30
    192.168.1.12/30
    192.168.1.16/30
    192.168.1.20/32一共六个骨干网段,还余下一些以后可以使用。
    R1:192.168.1.32/27
    192.168.1.32/28
    192.168.1.48/28
    R2:192.168.1.64/27
    192.168.1.64/28
    192.168.1.80/28
    R3:192.168.1.96/27---只有一个网段不用分
    R4:192.168.1.128/27
    192.168.1.128/28
    192.168.1.144/28
    192.168.1.160/27---只有一个环回不用分
    
    同时还有R6没有ip,自己给其分配一个,自定R6左边网段ip地址为12.1.1.0/24网段
    R6环回ip地址为12.1.2.0/24网段。
    

    **

    2.每个结点拥有合法ip

    **
    ip地址规划后如下:注:R2环回应为192.168.1.64/27
    在这里插入图片描述
    Ip地址配好后:
    R1:
    在这里插入图片描述
    R2:
    在这里插入图片描述
    R3:
    在这里插入图片描述
    R4:
    在这里插入图片描述
    R5:
    在这里插入图片描述
    R6:
    在这里插入图片描述
    R3进行dhcp池塘配置:

    [r3]dhcp enable 
    [r3]ip pool xuhaobo
    [r3-ip-pool-xuhaobo]network 192.168.1.96 mask 27
    [r3-ip-pool-xuhaobo]gateway-list 192.168.1.97
    [r3-ip-pool-xuhaobo]dns-list 114.114.114.114
    [r3-ip-pool-xuhaobo]q
    [r3]interface g0/0/2	
    [r3-GigabitEthernet0/0/2]dhcp select global 
    

    Pc1和pc2都获取到了合法ip地址:
    在这里插入图片描述
    在这里插入图片描述
    配置第一步完成,所有结点拥有合法ip地址。
    **

    3.配置第二步:实现全网可达

    **
    因为R4和R5之间需要做备份我们先关掉R4下面的接口,其他路由配好了再回来看
    关掉100M接口,再进行分析。
    在这里插入图片描述

    为了使路由条目尽可能的少,我们先配缺省路由,再根据缺省路由看哪些路由条目还需要添加。
    

    缺省路由方向如下:
    在这里插入图片描述
    配置缺省路由:
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    [r5]ip route-static 0.0.0.0 0 12.1.1.2
    

    缺省路由配置完毕后,查看路由器去往其他网段是否为最佳网段。
    对R1而言:
    在这里插入图片描述
    需要做四条静态路由:
    在这里插入图片描述
    R2:
    在这里插入图片描述
    需要做5条:
    在这里插入图片描述
    R3:
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    R4:
    在这里插入图片描述
    在这里插入图片描述
    最后是R5:
    在这里插入图片描述
    可以看到,如果做静态路由需要做8条
    可以考虑做一条汇总路由:
    在这里插入图片描述
    并且在R4上做黑洞路由:
    在这里插入图片描述
    做到这里,就实现了局域网内可达,要实现访问外部网络,需要在边界路由器做nat转换:
    在这里插入图片描述
    在这里插入图片描述
    做好以后,便实现全网可达:R1可以pingR6
    在这里插入图片描述
    4.路由备份
    开启R4的备份接口,再配置一条缺省路由优先级比1000M线低。
    在这里插入图片描述
    再在R5上做100M口的回来路由。
    就完成了路由备份。
    5。远程登录

    R5上开启访问23端口转R1
    

    在R5上作为端口转换。
    在这里插入图片描述
    在R1上开启远程登录。
    在这里插入图片描述
    当外界当问R5公有ip时,转到R1去。
    用于局域网内服务器让外部网络进行访问。
    在这里插入图片描述
    本次实验通过一个完整的静态路由实验,对整个网络的搭建进行一个综合。

    展开全文
  • hcia静态路由综合实验

    2021-01-22 23:51:16
    ##实验要求: ①R6为ISP,接口IP地址为公有地址;该设备只能配IP地址,之后不能在对其进行任何配置; ②R1-R5为局域网,私有IP地址192.168.1.0/24请合理分配; ③所有的路由器上均有换回,代表用户接口; ④R3下的...

    (一)实验要求
    (二)实验拓扑
    (三)子网划分
    (四)实验配置
    (五)实验结果测试

    (一)实验要求:

    在这里插入图片描述
    ①R6为ISP,接口IP地址为公有地址;该设备只能配IP地址,之后不能在对其进行任何配置;
    ②R1-R5为局域网,私有IP地址192.168.1.0/24请合理分配;
    ③所有的路由器上均有换回,代表用户接口;
    ④R3下的两台PC通过DHCP自动获取IP地址;
    ⑤选路最佳,路由表尽量小,避免环路;
    ⑥R1-R5均可访问R6的环回;
    ⑦R6 telnet R5的公有IP地址时,实际登录到R1上;
    ⑧R4与R5正常通过千兆链路,故障时,通过百兆链路。

    (二)实验拓扑:

    在这里插入图片描述

    (三)子网划分:

    由实验要求图可知R1、R2、R4均需两个网段代表换回,R5需要一个网段代表换回,一共7个网段,同时为了路由表尽量少,我们把连线表示出来的网段放在一个网段的下面,因此只需将192.168.1.0/24分为8个网段,子网掩码向后借三个单位:
    192.168.1.0/27(主网段)
    192.168.1.32/27(R1环回)
    192.168.1.64/27(R1环回)
    192.168.1.96/27(R2环回)
    192.168.1.128/27(R2环回)
    192.168.1.160/27(R4环回)
    192.168.1.192/27(R4环回)
    192.168.1…224/27(用于R3dhcp使用)
    其中192.168.1.0/27作为连线网段的主网段,而子网段需要7个网段,对其进行子网划分:
    192.168.1.0/30
    192.168.1.4/30
    192.168.1.8/30
    192.168.1.12/30
    192.168.1.16/30
    192.168.1.20/30
    192.168.1.24/30(保留)
    192.168.1.28/30(保留)

    (四)实验配置:

    第一步先配置所有IP地址:
    【R1】:
    [R1]int g 0/0/0
    [R1-GigabitEthernet0/0/0]ip address 192.168.1.1 30
    [R1-GigabitEthernet0/0/0]int g0/0/1
    [R1-GigabitEthernet0/0/1]ip address 192.168.1.5 30
    [R1]int LoopBack 0
    [R1-LoopBack0]ip address 192.168.1.33 27
    [R1]int LoopBack 1
    [R1-LoopBack1]ip address 192.168.1.65 27
    【R2】:
    [R2]int g0/0/0
    [R2-GigabitEthernet0/0/0]ip address 192.168.1.9 30
    [R2-GigabitEthernet0/0/0]int g0/0/01
    [R2-GigabitEthernet0/0/1]ip address 192.168.1.2 30
    [R2]int LoopBack 0
    [R2-LoopBack0]ip address 192.168.1.97 27
    [R2]int LoopBack 1
    [R2-LoopBack1]ip address 192.168.1.129 27
    【R3】:
    [R3]int g0/0/0
    [R3-GigabitEthernet0/0/0]ip address 192.168.1.6 30
    [R3-GigabitEthernet0/0/0]int g0/0/1
    [R3-GigabitEthernet0/0/1]ip address 192.168.1.13 30
    [R3]int g0/0/2
    [R3-GigabitEthernet0/0/2]ip address 192.168.1.225 27
    R3的dhcp配置:
    [R3]ip pool 1
    [R3-ip-pool-1]network 192.168.1.224 mask 27
    [R3-ip-pool-1]gateway-list 192.168.1.225
    [R3-ip-pool-1]dns-list 8.8.8.8 8.8.4.4
    [R3-ip-pool-1]int g0/0/2
    [R3-GigabitEthernet0/0/2]dhcp select global
    PC1和PC2:
    在这里插入图片描述在这里插入图片描述
    【R4】:
    [R4]int g0/0/1
    [R4-GigabitEthernet0/0/1]ip address 192.168.1.10 30
    [R4-GigabitEthernet0/0/1]int g0/0/2
    [R4-GigabitEthernet0/0/2]ip address 192.168.1.14 30
    [R4-GigabitEthernet0/0/2]int g0/0/0
    [R4-GigabitEthernet0/0/0]ip address 192.168.1.21 30
    [R4]int e4/0/0
    [R4-Ethernet4/0/0]ip address 192.168.1.17 30
    [R4]int LoopBack 0
    [R4-LoopBack0]ip address 192.168.1.161 27
    [R4-LoopBack0]int lo 1
    [R4-LoopBack1]ip address 192.168.1.193 27
    【R5】:
    [R5]int g0/0/0
    [R5-GigabitEthernet0/0/0]ip address 192.168.1.22 30
    [R5-GigabitEthernet0/0/0]int g0/0/1
    [R5-GigabitEthernet0/0/1]ip address 56.1.1.1 24
    [R5]int e4/0/0
    [R5-Ethernet4/0/0]ip address 192.168.1.18 30
    [R5]int LoopBack 0
    [R5-LoopBack0]ip address 5.5.5.5 24
    【R6】:
    [R6]int g0/0/0
    [R6-GigabitEthernet0/0/0]ip address 56.1.1.2 24
    [R6-GigabitEthernet0/0/0]int lo 0
    [R6-LoopBack0]ip address 6.6.6.6 24
    第二步配置静态路由和缺省:
    【R1】:
    [R1]ip route-static 0.0.0.0 0.0.0.0 192.168.1.2//缺省走上
    [R1]ip route-static 0.0.0.0 0.0.0.0 192.168.1.6//缺省走下
    [R1]ip route-static 192.168.1.96 27 192.168.1.2//R2环回走上
    [R1]ip route-static 192.168.1.128 27 192.168.1.2// R2环回走上
    [R1]ip route-static 192.168.1.160 27 192.168.1.2//R4环回走上,负载分担
    [R1]ip route-static 192.168.1.8 30 192.168.1.2//R2-R4网段走上
    [R1]ip route-static 192.168.1.12 30 192.168.1.6//R3-R4网段走下
    [R1]ip route-static 192.168.1.192 27 192.168.1.6//R4环回走下,负载分担
    [R1]ip route-static 192.168.1.224 27 192.168.1.6//R3下面的网段走下
    [R1]ip route-static 192.168.1.32 27 NULL 0//R1的环回空接口闭环
    [R1]ip route-static 192.168.1.64 27 NULL 0//R1的环回空接口闭环
    【R2】:
    [R2]ip route-static 0.0.0.0 0.0.0.0 192.168.1.10//缺省走右
    [R2]ip route-static 192.168.1.32 27 192.168.1.1// R1环回走左
    [R2]ip route-static 192.168.1.64 27 192.168.1.1// R1环回走左
    [R2]ip route-static 192.168.1.4 30 192.168.1.1//R1-R3网段走左
    [R2]ip route-static 192.168.1.224 27 192.168.1.1//到R3下面的网段负载均衡
    [R2]ip route-static 192.168.1.224 27 192.168.1.10//到R3下面的网段负载均衡
    [R2]ip route-static 192.168.1.96 27 NULL 0//R1的环回空接口闭环
    [R2]ip route-static 192.168.1.128 27 NULL 0//R1的环回空接口闭环
    【R3】:
    [R3]ip route-static 0.0.0.0 0.0.0.0 192.168.1.14//缺省走右
    [R3]ip route-static 192.168.1.32 27 192.168.1.5//R1环回走左
    [R3]ip route-static 192.168.1.64 27 192.168.1.5// R1环回走左
    [R3]ip route-static 192.168.1.0 30 192.168.1.5//R1-R2网段走左
    [R3]ip route-static 192.168.1.96 27 192.168.1.5//R2的环回走左,负载分担
    [R3]ip route-static 192.168.1.128 27 192.168.1.14//R2的环回走右,负载分担
    【R4】:
    [R4]ip route-static 0.0.0.0 0.0.0.0 192.168.1.22//缺省走千兆线右
    [R4]ip route-static 0.0.0.0 0.0.0.0 192.168.1.18 preference 61//备份缺省走百兆线右
    [R4]ip route-static 192.168.1.96 27 192.168.1.9//R2的环回走上
    [R4]ip route-static 192.168.1.128 27 192.168.1.9//R2的环回走上
    [R4]ip route-static 192.168.1.0 30 192.168.1.9//R1-R2网段走上
    [R4]ip route-static 192.168.1.32 27 192.168.1.9//R1的环回走上,负载分担
    [R4]ip route-static 192.168.1.64 27 192.168.1.13//R1的环回走下,负载分担
    [R4]ip route-static 192.168.1.4 30 192.168.1.13//R1-R3网段走下
    [R4]ip route-static 192.168.1.224 27 192.168.1.13//R3下面的网段走下
    [R4]ip route-static 192.168.1.160 27 NULL 0//R4环回空接口闭环
    [R4]ip route-static 192.168.1.192 27 NULL 0// R4环回空接口闭环
    [R4]ip route-static 192.168.1.24 30 NULL 0//保留地址空接口闭环
    [R4]ip route-static 192.168.1.28 30 NULL 0//保留地址空接口闭环
    【R5】:
    [R5]ip route-static 0.0.0.0 0.0.0.0 56.1.1.2//缺省走右
    [R5]ip route-static 192.168.1.0 24 192.168.1.21//到局域网走左千兆线
    [R5]ip route-static 192.168.1.0 24 192.168.1.17 preference 61//备份到局域网走左百兆线
    R1开启telnet:
    [R1]aaa
    [R1-aaa]local-user root privilege level 15 password cipher root
    Info: Add a new user.
    [R1-aaa]local-user root service-type telnet
    [R1-aaa]q
    [R1]user-interface vty 0 4
    [R1-ui-vty0-4]authentication-mode aaa
    第三步R5配置NAT以及端口映射:
    配置NAT:
    [R5]acl 2000
    [R5-acl-basic-2000]rule permit source 192.168.1.0 0.0.0.255
    [R5-acl-basic-2000]int g0/0/1
    [R5-GigabitEthernet0/0/1]nat outbound 2000
    端口映射:
    [R5]int g0/0/1
    [R5-GigabitEthernet0/0/1]nat server protocol tcp global current-interface 23(协议号) ins
    ide 192.168.1.33 23(端口号)
    Warning:The port 23 is well-known port. If you continue it may cause function fa
    ilure.
    Are you sure to continue?[Y/N]:y

    (五)实验结果测试:

    在这里插入图片描述在这里插入图片描述在这里插入图片描述
    在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述

    展开全文
  • 实验要求: 合理分配IP地址: 骨干链路 192.168.1.0/27 192.168.1.0/30 192.168.1.4/30 192.168.1.8/30 192.168.1.12/30 192.168.1.16/30 192.168.1.20/30 192.168.1.24/30 环回地址 R1 192.168.1.32/27 192.168....
  • ![在这里插入图片描述](https://img-blog.csdnimg.cn/20210324215158445.png?x-oss-process=image/watermark,type_... 实验目的: 实验装置:五个路由器 实验步骤: 一·右键ar5 打开设置给ar5增加一个 1GEC 接口
  • 1.实验拓扑如下: 2.实验要求 1)R4为ISP,只能配置IP地址,不能...5)R2与R3间浮动静态路由进行备份 6) R4TelnetR3实际登录到R1 7)减少路由条目数量,避免环路 8)R2和R3分别有两个环回地址 3.实验分析 1)先...
  • 实验要求 r6为isp,接口ip地址均为公有地址;该设备只能配置ip地址,之后不能在对其进行任何配置 r1-r5为局域网,私有ip地址192.168.1.0/24,请合理分配 所有路由器上换回,均代表连接用户的接口 r3下的两台pc通过...

空空如也

空空如也

1 2 3 4 5 ... 12
收藏数 237
精华内容 94
关键字:

静态路由综合实验