精华内容
下载资源
问答
  • cisco2960交换机配置命令
  • Cisco2960交换机配置手册 pdf 文档 配置交换机的文档
  • 思科2960交换机telnet连接配置

    千次阅读 2020-07-24 19:17:02
    本次实验是基于思科2960交换机进行配置,实验设备:笔记本、思科2960交换机、console线一条、网线一条。 本次实验的连接软件为XSHELL。 一、交换机重置 如果交换机已经经过配置,可以通过如下方式进行重置: ...

    本次实验是基于思科2960交换机进行配置,实验设备:笔记本、思科2960交换机、console线一条、网线一条。

    本次实验的连接软件为XSHELL。

    一、交换机重置

    如果交换机已经经过配置,可以通过如下方式进行重置:

    长按CISCO 2960交换机MODE键10秒,直到STAT DUPLX SPEED 三个LED灯常亮,然后三个灯同时闪烁再到常亮,放开MODE键,此时,交换机已重置完成。

    二、交换机配置

    1.xshell登录

    我们将console线一端接交换机 console口(注意:不是网口),一端USB接笔记本。console线连接好后,我们进入设备管理器,可以看到端口已经有USB接入,对应端口是COM4口。

    此时,我们就可以启动xshell,协议选择“SERIAL”,接下来选择左边串口,端口选择COM4,波特率选择9600,确认后,即可连接。连接后,界面如下:

     

    此时,已经用xshell完成console口登录,可以进行配置了。

    2.交换机配置

    进入交换机后,思科交换机有以下几种模式,需要注意:

    登录后,默认是用户模式。

    通过命令”enable”可以进入特权模式:

    通过命令”configure terminal”可以进入全局模式:

    各个模式的命令及权限有所区别,输入命令时,需要注意所处在的模式。

    此时,我们就可以开始配置了:

    2.1配置ip地址

    先进入全局模式:

    输入下图命令:

    进入vlan 1中;接着输入如图命令,添加IP地址和子网掩码:

    通过no shutdown命令,开启端口:

    2.2设置特权模式密码

    通过以下命令,设置进入特权模式的密码,如果不设置特权模式密码,telnet命令连接后,无法进行操作。

    2.3设置登录人数

    通过以下命令设置允许登录的人数,0-5为编号,此时设置可供6人登录。

    2.4设置登录模式

    一共有三种登录模式:

    login:账号密码登录

    login local:本地登录

    no login local:无密码登录

    此时,我们设置为本地登录:

    2.5登录用户及密码设置

    设置好登录模式和登录人数后,我们退出到全局模式进行登录用户、权限及密码配置,如下图:

     

    配置完成后,我们就可以通过网线,运用telnet命令进行登录了。

    三、telnet连接

    1.打开telnet服务

    win10的telnet命令默认是被禁止了的,需要手动进行打开,打开“控制面板“,点击”卸载程序”,找到左边的”启用或关闭windows功能”,找到”Telnet Client”,勾选即可。

    2.配置ip

    telnet服务需要将设备和交换机放在同一网段下,需重新配置ip地址,配置如下:

    3.telnet连接

    进入cmd界面,我们可以先”ping”一下,查看连接情况:

    证明连接正常,此时,我们可以进行talnet登录了:

    输入用户名和密码,进入交换机,可以通过对交换机进行配置和管理了。

    如果要进入特权模式,还需要输入相应密码。

    展开全文
  • 基于思科2960交换机的二层设备配置范例及基本概念介绍
  • 交换机的主机名、进入enable模式的密码、远程登陆的用户名和...这些和之前的2950交换机都是一样的, 2960交换机和2950相比增加了限速等功能,由于今后客户新上架除了签署了流量合同的其他都要在交换机的端口上做限速。
  • Cisco 2960交换机密码恢复 一、准备工具 串口线,串口-USB线 USB一端接电脑USB口,另一端接交换机console口; 确保电脑有串口端口(没有的需要安装usb-232驱动); 二、交换机两种密码恢复 2.1 知道交换机密码...

    Cisco 2960交换机密码恢复

    在这里插入图片描述
    一、准备工具
    串口线,串口-USB线
    在这里插入图片描述
    USB一端接电脑USB口,另一端接交换机console口;
    确保电脑有串口端口(没有的需要安装usb-232驱动);
    在这里插入图片描述
    二、交换机两种密码恢复
    2.1 知道交换机密码恢复出厂设置
    在这里插入图片描述
    SZswitch>enable
    Password:
    SZswitch#erase startup-config
    Erasing the nvram filesystem will remove all configuration files! Continue? [confirm] 按回车
    [OK]
    Erase of nvram: complete
    SZswitch#
    *Mar 1 00:48:40.342: %SYS-7-NV_BLOCK_INIT: Initialized the geometry of nvram
    SZswitch#reload
    System configuration has been modified. Save? [yes/no]: no
    Proceed with reload? [confirm] 回车
    Would you like to enter the initial configuration dialog? [yes/no]: no
    Switch>en
    Switch#show run
    Building configuration…
    2.2 不知道交换机密码恢复出厂设置
    Cisco交换机与路由器的密码恢复是不一样的,交换机没有电源开关(也就是说接上电源就启动了),如何恢复,但又使配置文件不变呢?
    使用secureCRT连接
    在这里插入图片描述
    实操:首先拔掉交换机电源,在把电源插进交换机,快速按交换机 MODE键然后松开就进入了SWITCH模式了。
    Switch:(这个就是SWITCH模式,安全模式)
    在这里插入图片描述
    switch: flash_init
    Initializing Flash…
    flashfs[0]: 538 files, 19 directories
    flashfs[0]: 0 orphaned files, 0 orphaned directories
    flashfs[0]: Total bytes: 32514048
    flashfs[0]: Bytes used: 10887680
    flashfs[0]: Bytes available: 21626368
    flashfs[0]: flashfs fsck took 11 seconds.
    …done Initializing Flash.
    在这里插入图片描述
    看看flash 里面的文件: dir flash:
    在这里插入图片描述
    交换所有的配置以及密码都保存在config.text文档里,那么居然密码都保存在这个文档里,启动时不加载这个文档就跳过了密码,所有更改该文件名即可,这样就可以直接进入交换机。
    switch: rename flash:config.text flash:old-config.text
    在这里插入图片描述
    在执行reset 然后重启交换机
    在这里插入图片描述
    Would you like to enter the initial configuration dialog? [yes/no]: no
    在这里插入图片描述
    然后再加载以前的配置copy flash:old-config.text running-config
    在这里插入图片描述

    配置加载完成在配置密码口令,就可以覆盖以前的口令了。
    SZswitch(config)#enable secret cisco
    SZswitch(config)#line vty 0 4
    SZswitch(config-line)#password cisco
    SZswitch(config-line)#login
    SZswitch(config-line)#end
    SZswitch#write
    保存重启进入就是使用刚设置的cisco密码进入交换机,

    在这里插入图片描述

    展开全文
  • Cisco 2960交换机排错

    2017-11-18 19:34:00
    Cisco 2960交换机排错 运维部一卡座的网络端口,接了一台TP-LINK 16口交换机,突然有天,发现接在这个交换机上的所有PC都不通了,简单检查了一下,发现此交换机进线口不亮灯(卡座口与TP-LINK交换机连接线),用测...

    Cisco 2960交换机排错

       

        运维部一卡座的网络端口,接了一台TP-LINK 16口交换机,突然有天,发现接在这个交换机上的所有PC都不通了,简单检查了一下,发现此交换机进线口不亮灯(卡座口与TP-LINK交换机连接线),用测线仪测了下,发现8个灯亮,初步判断是弱电井的2960相应的端口被shutdown了,于是登录交换机查看端口,发现并没有administrator down,百思不得其解。

        测线仪测出,8根线都是亮的,说明网线是没有问题的,端口又没被shutdown,说明没有被管理员关闭。
        再登录交换机,show一下该端口情况,仔细一看,发现第一行后面的括号里有err-disabled信息,百度一下关键字“err-disabled”,得出解决办法。

        线路不通,物理指示灯灭,而测试仪显示8根线通,可show int status查下,通过该命令发现46口有err-disabled,理由是loopback。

        在缺省配置下,思科交换机端口被置为err-disabled,IOS将不会试图万利接口,必须手工将它恢复,于是再输入命令errdisable recovery cause lookup,配置完这个命令后,查看端口情况,还是err-disabled,这是因为恢复时间需要300秒,输入sh errdisable recovery查看下,还需要多少时间才能恢复,从图上看,需要257秒。耐心等257秒后,该端口正常,TP-LINK交换机上的PC也正常。

     

    问题反思。
        这肯定是监控干的,在TP-LINK交换机上乱拉线,最后拉成环路了,思科交换机监控到环路,就把该端口置为错误端口,从而避免整个网络出现异常。当然思科交换机并不会自动去把有问题的端口置为环路,需要在每个端口下输入命令,控制广播风暴。





         本文转自itwork 51CTO博客,原文链接:http://blog.51cto.com/369369/790835,如需转载请自行联系原作者



    展开全文
  • 2960交换机配置

    2018-09-26 16:34:57
    交换机配置文档。
  • 思科2960交换机四大安全特性,生成树协议、风暴控制、端口安全、DHCP snooping,当然2960最新版已经支持DAI了。
  • 2960交换机简要配置手册(中文)针对思科基础二层设备进行配置讲解
  • Cisco 2960交换机配置

    2017-03-27 09:16:00
    Cisco 2960交换机配置 1、 Cisco工作模式分类及作用 #用户模式仅答应基本的监测命令,在这种模式下不能改变路由器的配置。 Switch> #用户模式 #允许用户执行所有的测试、查看、保存等命令,这种...

    Cisco 2960交换机配置

     

     

     

    1、 Cisco工作模式分类及作用

     

    #用户模式仅答应基本的监测命令,在这种模式下不能改变路由器的配置。

    Switch>                                         #用户模式

     

    #允许用户执行所有的测试、查看、保存等命令,这种模式下不能进行路由器配置的修改,一般此模式建议设置密码保护。

    Switch>enable                                  #进入特权模式

    Switch#

     

    #允许用户配置路由器。

    Switch#configure terminal                    #进入全局模式

    Switch(config)#

     

    #允许用户配置fastEthernet 0/1接口。

    Switch(config)#interface fastEthernet 0/1       #进入配置fa 0/1接口模式

    Switch(config-if)#

     

     

     

     

    2、 基本操作

     

    #全局模式下修改交换机名称

    Switch(config)#hostname test01(交换机名称)

     

    #全局模式下设置登陆特权加密密码

    Switch(config)#enable secret  123456

     

    #全局模式下设置登陆特权非加密密码

    Switch(config)#enable password 123456

     

    #特权模式下查看Vlan信息

    Switch#show vlan

     

    #特权模式下查看端口信息

    Switch#show interfaces fa0/1

     

    #特权模式下查看交换机系统版本、型号、开机时间等等

    Switch#show version

     

     

     

     

    3、 设置交换机时间

     

    标注:普通思科交换机一般不带电池保存时间,交换机重启后时钟都会恢复到初始化时间,建议配置NTP服务。

    #特权模式下显示交换机时间

    Switch#show clock

    #特权模式下修改交换机时间

    Switch#clock set 17:42:00 22 Mar 2017

     

     

     

     

    4、 配置Vlan

     

    #特权模式下进入Vlan子模式

    Switch#vlan database

     

    #创建vlan并命名为test01

    Switch(vlan)#vlan 10 name test01

     

    #退出Vlan配置模式

    Switch(vlan)#exit

     

    #返回到特权模式下查看Vlan创建情况

    Switch#show vlan

     

     

     

     

    4、删除Vlan

     

    #特权模式下进入Vlan子模式

    Switch#vlan database

     

    #删除已创建好的Vlan

    Switch(vlan)#no vlan 10

     

    #返回到特权模式下查看指定的Vlan创建情况

    Switch#show vlan id 10

     

     

     

     

    5、 将端口划入指定的Vlan

     

    #全局模式下进入fa/01端口模式

    Switch(config)#interface fastEthernet 0/1

     

    #将fa0/1端口划分到Vlan 10

    Switch(config-if)#switchport access vlan 10 

     

    #fa0/1设置成静态Vlan访问模式

    Switch(config-if)#switchport mode access

     

    #激活fa0/1接口

    Switch(config-if)#no shutdown

     

    #全局模式下进入fa/02端口到fa0/10端口模式

    Switch(config)#interface range fastEthernet 0/2-10

     

    #将入fa/02端口到fa0/10端口划分到Vlan10

    Switch(config-if-range)#switchport access vlan 10

     

    # fa/02端口到fa0/10端口设置成静态Vlan访问模式

    Switch(config-if-range)#switchport mode access

     

    # 激活fa/02端口到fa0/10端口

    Switch(config-if-range)#no shutdown

     

    #返回到特权模式下查看指定的Vlan创建情况

    Switch#show vlan id 10

     

    #特权模式下保存配置

    Switch#write

     

     

     

     

    6将端口划出指定的Vlan

     

    #全局模式下进入fa/01端口模式

    Switch(config)#interface fastEthernet 0/1

     

     

    #将fa0/1端口从Vlan 10划出(把fa0/1端口从Vlan10删除)

    Switch(config-if)#no switchport access vlan 10

     

    #全局模式下进入fa/02端口到fa0/10端口模式

    Switch(config)#interface range fastEthernet 0/2-10

     

    #把fa0/2端口和fa/10从Vlan 10划出(把fa0/1端口从Vlan10删除)

    Switch(config-if-range)#no switchport access vlan 10

     

    #特权模式下保存配置

    Switch#write

     

     

     

     

    7、 设置交换机端口工作模式

     

    标注:思科交换机端口三种工作模式

    access     一个access端口只能属于一个Vlan,也只能转发这个Vlan数据,主要用于接入终端设备、如PC、服务器、打印服务器等

    trunk     一个trunk端口属于多个Vlan,能转发多个Vlan数据,主要用于连接其它交换机、以便在线路上承载多个Vlan

    dynamic   动态可取模式,主动对端协商,也就是通常的Trunk模式优先。在可以和对端协商成trunk模式时使用trunk模式,不行则改为access模式。

     

    #全局模式下进入fa/01模式

    Switch(config)#interface fastEthernet 0/1

     

    #查看交换机支持哪些端口工作模式

    Switch(config-if)#switchport mode ?

    access Set trunking mode to ACCESS unconditionally 

    dynamic Set trunking mode to dynamically negotiate access or trunk mode 

    trunk Set trunking mode to TRUNK unconditionally

     

    #将fa0/1端口设置成Access模式

    Switch(config-if)#switchport mode access

     

    #将fa0/1端口设置成Trunk模式

    Switch(config-if)#switchport mode dynamic

     

    #将fa0/1端口设置成Trunk模式

    Switch(config-if)#switchport mode trunk

     

    #特权模式下查看端口工作模式

    Switch#show interfaces fastEthernet 0/1 switchport

    Name: Fa0/1

    Switchport: Enabled

    Administrative Mode: trunk

    Operational Mode: down

     

    #特权模式下保存配置

    Switch#write

     

     

     

     

    8、 双工模式设置

     

    #全局模式下进入fa0/1端口

    Switch(config)#interface fastEthernet 0/1

     

    #自行选择,full全双工模式、half半双工模式、auto自动选择模式

    Switch(config-if)#duplex full

     

    #查看fa0/1端口双工模式

    Switch#show interfaces fastEthernet 0/1

    Encapsulation ARPA, loopback not set

    Keepalive set (10 sec)

    Full-duplex, 100Mb/s

     

    #保存配置

    Switch#write

     

     

     

     

    9、配置Vlan的IP地址及网关

     

    #全局模式下进入指定vlan 10

    Switch(config)#interface vlan 10

     

    #配置vlan 10的IP地址及子网掩码

    Switch(config-if)#ip address 192.168.10.1 255.255.255.0

     

    #全局模式下设置交换机所连域的域名test.com

    Switch(config)#ip domain-name test.com

     

    #激活端口

    Switch(config-if)#no shutdown

     

    #全局模式下设置网关地址

    Switch(config)#ip default-gateway 192.168.10.254

     

    #特权模式下查看vlan及接口状态

    Switch#show ip interface brief

     

    #特权模式下查看交换机网关地址

    Switch#show running-config

     

    #特权模式下保存配置

    Switch#write

     

     

     

     

    10、配置telnet远程登录

     

    #全局模式下设置登陆特权加密密码,telnet远程登录需要先设置特权登录密码

    Switch(config)#enable secret  123456

     

    #全局模式下进入虚拟线程配置模式, 0到4意思是最多同时允许0,1,2,3,4的5个用户远程telnet登录

    Switch(config)#line vty 0 4

     

    #设置登录口令(远程telnet登录交换机密码)

    Switch(config-line)#password 654321

     

    #设置远程telnet需要口令验证

    Switch(config-line)#login

     

    #特权模式下查看telnet配置情况

    Switch#show running-config

    line vty 0 4

    password 654321

    login

     

    #特权模式下保存配置

    Switch#write

     

     

     

     

    11、恢复交换机出厂设置

     

    #特权模式下执行出厂恢复设置,弹出提示按回车键确认

    Switch#write erase

     

    #特权模式下重启交换机,弹出提示按回车键确认

    Switch#reload

     

     

     

    12、使用IPSG绑定IP地址(Port/IP/MAC三者绑定)

     

    #在特权模式下查看Port/IP/MAC绑定情况

    Switch# show ip source binding

     

    #在特权模式下查看192.168.10.10 的Port/IP/MAC绑定情况

    Switch# show ip source binding | include 192.168.10.10

     

    #特殊模式下查看192.168.10.10 的IP地址对应的物理地址与所属于VLAN

    Switch# show arp | include 192.168.10.10 

     

    #特殊模式下查看448a.5b00.12a1 的MAC地址对应的端口

    Switch#show mac address-table | include 448a.5b00.12a1

     

    #全局模式下绑定IP地址(Port/IP/MAC三者绑定)

    Switch(config)# ip source binding 448a.5b00.12a1 vlan 192.168.10.10 interface GI0/12

     

     

     

    13、交换机配置trunk端口 (trunk允许多个Vlan通过,access只允许一个Vlan通过)

     

    标注:三层交换机与二层交换机设置级连,三层交换端口默认dyna auto,dyna auto端口能同步下级交换机端口工作模式trunk,

    三层交换机会自动适应成trunk,所以,只要配置二层交换机端口为trunk即可。

    #全局模式下进入fa0/24端口进行配置

    Switch(config)#interface fastEthernet 0/24

     

    #设置trunk口,允许多个 Vlan通过,一般接到三层交换机上的trunk口

    Switch(config-if)#switchport mode trunk

    #激活端口

    Switch(config-if)#no shutdown

     

    #特权模式下保存配置

    Switch#write

     

    #查看fa0/24接口否配置成trunk

    Switch#show interfaces fastEthernet 0/24 switchport

    Name: Fa0/24

    Switchport: Enabled

    Administrative Mode: trunk

     

    转载于:https://www.cnblogs.com/zoulongbin/p/6625153.html

    展开全文
  • 思科2918与2960交换机性能参数及功能对比
  • cisco2960交换机 清除配置的命令1、计算机通过COM端口连接到交机,如果电脑不带COM,需要使用USB转串口线连接交换机,通过超级终端调试。2、当开关通电时,按住开关前面的“模式”按钮,用手按住交换机“Mode” 按钮...
  • 交换机手册,用于CISCO公司,Catalyst 2960, 100M交换机,网络搬砖
  • Cisco 2960 交换机 配置

    2018-08-03 10:36:09
    Cisco 交换机配置命令
  • 思科C2960交换机的默认网关

    千次阅读 2017-05-17 09:25:43
    思科C2960交换机的默认网关。直接命令补充,看不到default-gateway。但实际输入会出现。
  • Cisco catelyst 2960交换机:::: 1.24 或 48 个具有线速转发性能的千兆以太网端口 2.千兆位小型封装热插拔 (SFP) 或 10G SFP+ 上行链路 最简单的三层架构: Cisco catelyst 4506 作...
  • 思科2960交换机 - 配置命令大全

    千次阅读 2018-11-13 15:36:47
    今天给大家分享下思科2960交换机的配置命令: 一、使能口令和使能密码 1、使能口令(enable password),口令以明文显示。 2、使能密码(enbale secret), 口令以密文显示。 Switch.> /*用户直行模式...
  • Cisco_2960交换机中如何绑定IP与MAC地址
  • 思科2960交换机配置命令

    千次阅读 2013-11-11 10:47:56
    思科2960交换机配置命令  交换机基本状态:  switch: ;ROM状态, 路由器是rommon>  hostname> ;用户模式  hostname# ;特权模式  hostname(config)# ;全局配置模式  hostname...
  • cisco2960交换机安装配置基础新设备配置内容:1.interfacevlan1的ip,gatewayconftintvlan1ipaddressxx.xx.xx.xx255.255.255.0ipdefault-gatewayip-addressnoshutdownexit2.en的密码3.linevty0-4telnet的密码4....
  • 今天向同事借了一台Cisco2960交换机做实验,结果连接上发现有密码,于是自己第一时间想到的是自己破解一把,以下是破解过程:1、通过SecureCRT连接交换机 ,出现连接界面2、拔掉交换机电源 ,按下交换机前面板上的...
  • 2960交换机售前文档

    2013-01-15 23:49:09
    2960售前文档参考 ,主要版本之间的差异
  • 2960交换机限速

    2017-11-26 22:21:00
    3560交换机限速:  在3560 EMI上做速率限制是采用QOS的速率管制功能(policying),依次需要做如下配置。 1、在所有端口上关闭流量控制 3560(config)#interface range gigabitEthernet 0/1 - 12 3560(config...
  • Cisco 2960交换机中如何绑定IP与MAC地址 请问:在2960交换机中如何进行端口MAC地址绑定,并同时绑定IP与MAC地 址? 网友1: conf t arp 192.168.1.1 0000.1001.2200 arpa fa0/1 网友2: IP地址与MAC...
  • 本文讲的是思科Catalyst 2960交换机中的CVE-2017-3881漏洞分析, 2017年3月17日,思科官方网站发布公告称Cisco IOS&IOS XE Software 集群管理协议(Cluster Management Protocol)存在远程执行代码漏洞(CVE-2017...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 529
精华内容 211
关键字:

2960交换机