精华内容
下载资源
问答
  • 通过三层交换机不同vlan之间通信

    千次阅读 2018-12-25 17:34:00
    通过三层交换机不同vlan之间通信 通过三层交换机,不同vlan之间通信 先在三层交换机上创建vlan en //进入特权模式 conf t //进入全局模式 vlan 2 //创建vlan vlan 3 //创建vlan ex //退出 然后绑定vlan的ip...

    通过三层交换机不同vlan之间通信

    通过三层交换机,不同vlan之间通信
    o_%e6%8b%93%e6%89%91.png
    先在三层交换机上创建vlan
    en //进入特权模式
    conf t //进入全局模式
    vlan 2 //创建vlan
    vlan 3 //创建vlan
    ex //退出
    o_TIM%e6%88%aa%e5%9b%be20181225172138.png
    然后绑定vlan的ip
    int vl 2 //进入vlan 2
    ip add 192.168.1.254 255.255.255.0 //绑定IP
    ex //退出
    int vl 3 //进入vlan 3
    ip add 192.168.2.254 255.255.255.0 //绑定IP
    ex //退出
    o_TIM%e6%88%aa%e5%9b%be20181225172248.png
    然后将端口划入vlan
    int f0/2 //进入端口2
    sw ac vl 2 //将端口划入vlan 2
    no sh //启动端口
    ex //退出
    int f0/3 //进入端口3
    sw ac vl 3 //将端口划入vlan 3
    no sh //启动端口
    ex //退出
    o_TIM%e6%88%aa%e5%9b%be20181225172319.png
    最后开启三层交换机的路由功能
    ip routing
    o_TIM%e6%88%aa%e5%9b%be20181225172357.png
    最后检查一下能不能通
    o_TIM%e6%88%aa%e5%9b%be20181225171833.png

    posted on 2018-12-25 17:34 坤sir 阅读(...) 评论(...) 编辑 收藏

    展开全文
  • 不同VLAN之间通信的原理

    千次阅读 2019-04-03 17:05:09
    在划分VLAN后,不同VLAN之间不能直接进行二层通信。如果要实现VLAN间通信,可以采取以下方案。 1.三层VLANIF接口方案 这是一种通过计算机网络体系结构中第三层(网络层)来实现VLAN间通信的解决方案。每个VLAN都...

    在划分VLAN后,不同VLAN之间不能直接进行二层通信。如果要实现VLAN间通信,可以采取以下方案。

    1.三层VLANIF接口方案

    这是一种通过计算机网络体系结构中第三层(网络层)来实现VLAN间通信的解决方案。每个VLAN都可以配置一个三层VLANIF逻辑接口,而这些VLANIF接口就作为对应VLAN内部用户主机的缺省网关,通过三层交换机内部的IP路由功能可以实现同一交换机上不同VLAN的三层互通,不同交换机上不同VLAN间的三层互通需要配置各VLANIF接口所在网段间的路由。

    该方案除S1700系列外,其他所有华为S系列交换机均支持。

    在图6-20所示的网络中,Device交换机上划分了两个VLAN:VLAN2和VLAN3。可通过如下配置实现VLAN间互通。

    (1)在Device上创建两个VLANIF接口并配置VLANIF接口的IP地址,但这两个VLANIF接口对应的IP地址不能在同一网段。

    (2)将各VLAN中的用户设备缺省网关设置为所属VLAN对应VLANIF接口的IP地址。

    现在仅以位于VLAN 2中的主机A向位于VLAN 3中的主机C发起通信为例,介绍通过VLANIF接口进行VLAN间三层互通的基本原理。具体通信流程如下。

    (1)在主机A向主机C发送的数据包到了网络层后,主机A先将包中的目的IP地址-主机C的IP地址和自己所在网段进行比较。

    (2)发现主机C和自己不在同一个子网,于是主机A以广播方式在本子网内发送一个ARP请求帧,其目的是查寻自己的网关-VLANIF2接口的MAC地址。

    (3)VLANIF2接口经过与ARP请求帧中的目的IP地址进行比较,发现自己的IP地址与其一致,接收该ARP请求帧,然后以单播方式向主机A返回一个ARP应答帧,帧中的源MAC地址即为VLANIF2的MAC地址。

    (4)在主机A接收由VLANIF2接口返回的ARP应答帧后从中学习到了VLANIF2接口的MAC地址。

    (5)主机A利用所获得的网关VLANIF2接口的MAC地址,重新进行数据帧封装,把帧中的目的MAC改为VLANIF2接口MAC地址,目的IP仍为主机C的IP地址,然后发送给网关-VLANIF2接口。

    (6)Device交换机在收到该数据帧后进行三层转发,发现帧中的目的IP地址–主机C的IP地址为直连路由,数据帧直接通过该主机的网关-VLANIF3接口进行转发。

    (7)VLANIF3接口作为VLAN 3内主机的网关,在收到数据帧后如果已有主机C的IP地址与MAC地址映射表,则直接发送给主机C,否则VLANIF3接口先在VLAN 3内以广播方式发送一个ARP请求帧,查寻主机C的MAC地址。

    (8)主机C在收到ARP广播帧后向VLANIF3接口返回一个ARP应答帧。

    (9)VLANIF3接口在收到主机C发来的ARP应答帧后再次进行数据帧封装,把帧中的目的MAC地址改为主机C的真实MAC地址(其他不变),然后把主机A发来的数据帧发送给主机C。这样主机A之后要发给C的数据帧都先发送给网关,由网关-VLANIF3接口做三层转发。

    主机C与主机A之间的通信原理一样,最终实现VLAN间的三层互通。

    2.三层以太网子接口方案

    三层以太网子接口是一种同时具备三层以太网物理接口和二层以太网物理接口双重特性的逻辑接口。即它具有三层以太网物理接口的三层路由功能,同时又具有二层以太网物理接口封装VLAN标签的特性。通过三层以太网子接口就可以实现不同VLAN间的三层互通,也就是我们通常所说的"单臂路由",在三层交换机和路由器中均可实现。

    该方案仅5700HI和5710EI子系列、S7700、S9300和S9700系列华为交换机支持。

    如图6-21所示,DeviceA为支持配置子接口的三层设备,DeviceB为二层交换设备。LAN通过DeviceB的二层以太网接口与DeviceA的三层以太网接口相连。连接在DeviceB上的用户主机被划分到两个VLAN:VLAN2和VLAN3。这时可通过如下配置实现VLAN间互通。
    在这里插入图片描述(1)在DeviceA与DeviceB相连的三层以太网接口上创建两个子接口Port1.1和Port1.2,并配置802.1Q封装与VLAN2和VLAN3分别对应。

    (2)为以上这两个子接口配置与各自所属VLAN对应网段的IP地址。

    (3)将DeviceB与DeviceA相连的二层以太网接口类型配置为Trunk或Hybrid类型,并同时允许VLAN2和VLAN3的帧通过。

    (4)将VLAN 2和VLAN 3中的用户设备的缺省网关设置为所属VLAN对应三层以太网子接口的IP地址。

    现在同样以主机A向主机C发起通信为例介绍三层以太网子接口的VLAN间通信方案的基本原理(其实基本过程与前面介绍的VLANIF接口VLAN间通信方案是一样的,只不过这里的网关是各VLAN所对应的子接口)。具体流程如下。

    (1)在主机A向主机C发送的数据包到了网络层后,主机A先将包中的目的IP地址-主机C的IP地址和自己所在网段进行比较。

    (2)发现主机C和自己不在同一个子网,于是主机A以广播方式在本子网内发送一个ARP请求帧,其目的是查寻自己的网关VLAN 2对应的Port1.1子接口的MAC地址。

    (3)Port1.1子接口经过与ARP请求帧中的目的IP地址进行比较,发现自己的IP地址与其一致,接收该ARP请求帧,然后以单播方式向主机A返回一个ARP应答帧,帧中的源MAC地址即为Port1.1子接口的MAC地址。

    (4)主机A接收由Port1.1子接口返回的ARP应答帧后从中学习到该子接口的MAC地址。

    (5)主机A利用所获得的网关Port1.1子接口的MAC地址,重新封装数据帧,把目的MAC地址改为Port1.1子接口MAC,目的IP仍为主机C的IP地址,然后发送给网关Port1.1子接口。

    (6)DeviceA交换机在收到该数据帧后进行三层转发,发现其目的IP地址-主机C的IP地址为直连路由,数据帧直接通过该主机的网关-VLAN 3对应Port1.2子接口进行转发。

    (7)Port1.2子接口作为VLAN 3内主机的网关,在收到数据帧后如果已有主机C的IP地址与MAC地址映射表,则直接发送给主机C,否则Port1.2子接口先在VLAN 3内以广播方式发送一个ARP请求帧,查寻主机C的MAC地址。

    (8)主机C在收到ARP广播帧后向Port1.2子接口返回一个ARP应答帧。

    (9)Port1.2子接口在收到主机C的ARP应答帧后,再次进行数据帧封装,把帧中的目的MAC地址改为主机C的真实MAC地址(其他不变),然后就把主机A发来的数据帧发送给主机C。这样主机A之后要发给C的数据帧都先发送给网关,由网关-Port1.2子接口做三层转发。

    主机C与主机A之间的通信原理一样,最终实现VLAN间的三层互通。

    转载自:http://book.51cto.com/art/201312/423175.htm

    展开全文
  • 静态路由:连接两个路由器之间,实现四个不同VLAN之间通信(静态路由只能手动配置) 静态路由的配置原理:IP route-static 目标网段+ 下一跳出口 2,实验拓扑如下图: 3,实验配置步骤 首先配置IP地址以及网关 ...

    一,两个单臂路由连接实现四个不同VLAN间通信

    1,涉及到的原理:

    • 单臂路由:来实现两个连接在同一台交换机与路由器上面的通信,下设两个vlan
    • 静态路由:连接两个路由器之间,实现四个不同VLAN之间通信(静态路由只能手动配置)
      静态路由的配置原理:IP route-static 目标网段+ 下一跳出口

    2,实验拓扑如下图:

    在这里插入图片描述

    3,实验配置步骤

    • 首先配置IP地址以及网关

         PC1:192.168.10.10 /192.168.10.1
         PC2:192.168.20.10 /192.168.20.1
         PC3 :192.168.30.10 /192.168.30.1
         PC4:192.168.40.10 /192.168.40.1
      
    • R1:

             interface GigabitEthernet0/0/1 (进接口设置网关,使得两个连接路由器的接口处在同一网段)
             ip address 10.1.1.1 255.255.255.0 
             interface GigabitEthernet0/0/0.1 (设置子接口所承接的VLAN,以及相应的网关)
              vlan-type dot1q 10 default 
              ip address 192.168.10.1 255.255.255.0 
              int  GigabitEthernet0/0/0.2 
              vlan-type dot1q 20 default 
              ip address 192.168.20.1 255.255.255.0
      

    添加静态路由:(R1的目标网段+下一跳出口)

            ip route-static 192.168.30.0 255.255.255.0 10.1.1.2
            ip route-static 192.168.40.0 255.255.255.0 10.1.1.2
    

    R2: (同R1一个原理,在此不做注解)

             interface GigabitEthernet0/0/1  
             ip address 10.1.1.2 255.255.255.0
             interface GigabitEthernet0/0/0.1 
             vlan-type dot1q 30 default   
             ip address 192.168.30.1 255.255.255.0 
             interface GigabitEthernet0/0/0.2 
             vlan-type dot1q 40 default 
             ip address 192.168.40.1 255.255.255.0
    

    配置静态路由:

           ip route-static 192.168.10.0 255.255.255.0 10.1.1.1  
           ip route-static 192.168.20.0 255.255.255.0 10.1.1.1
    

    交换机配置:

     将连接路由器与交换机的接口设置为trunk接口,
     其他接口都设置位hybrid接口,因为我们的目的是要实现全网互通,
     所以务必将 VLAN 10 20 30 40 都放行。
         
         SW1: 
                vlan bat 10 20 30 40 
                interface Ethernet0/0/1  
                port hybrid pvid vlan 10 
                port hybrid untagged vlan 10 20 30 40
                interface Ethernet0/0/2 
                port hybrid pvid vlan 20 
                port hybrid untagged vlan 10 20 30 40
                interface GigabitEthernet0/0/1
                port link-type trunk  
                port trunk allow-pass vlan 10 20 30 40
      SW2:
              vlan  bat  10 20 30 40 
              interface Ethernet0/0/1 
              port hybrid pvid vlan 10 
              port hybrid untagged vlan 10 20 30 40
              interface Ethernet0/0/2 
              port hybrid pvid vlan 20 
              port hybrid untagged vlan 10 20 30 40  
              interface GigabitEthernet0/0/1 
              port link-type trunk 
              port trunk allow-pass vlan 10 20 30 40
    

    4.最后我们来测试一下连通性

    在 PC1 上进行测试:

    在这里插入图片描述

    实验到这里,我们已经实现了全网互通。

    展开全文
  • 单臂路由主要解决不同VLAN之间通信问题,将一个物理接口对应不同的vlan划分若干个子接口。 这种技术现在仍然在使用。 一.背景 园区网划分vlan之后,导致debuff,导致广播域被隔离,vlan之间不能通信 VALN划分时 ...

    单臂路由主要解决不同VLAN之间的通信问题,将一个物理接口对应不同的vlan划分若干个子接口。
    这种技术现在仍然在使用。
    一.背景
    园区网划分vlan之后,导致debuff,导致广播域被隔离,vlan之间不能通信
    VALN划分时 地理 部门 属性 部门与部门之间隔离
    方案一:在同一台交换机上,用一根线把不同的VLAN连接–不可行(划分vlan将没有意义)
    方案二:用路由器的接口来实现不同VLAN所对应网段之间的通信----不可行(路由器接口有限)
    只有运行商级别的路由器接口多/企业级的路由器接口少
    二.单臂路由的实现
    物理接口虚拟成多个子接口,每个子接口具备处理802.1Q tag标记的能力来实现同一接口处理不同vlan网段数据的能力

    1.子接口————虚拟接口,逻辑上存在的接口,范围是0-65535
    	DOT1Q实际上就是802.1Q  有tag字段的封装,配合vlan,trunk
    2.单臂路由的配置
    	现网设备配置,除了排错,基本都是刷脚本
    	int g0/0/1.1 —— 创建物理接口的子接口
    	dot1q termination vid 2 —— 用来配置子接口dot1q封装的单层vlan id,将接口划分到VALN10下
    	arp broadcast enable —— 激活ARP广播功能
    

    三,单臂路由实验演示
    1,路由器,交换机,两台pc机,建立简单的拓扑图
    pc机分别属于vlan 10 和vlan 20在这里插入图片描述
    2,配置pc的ip地址及其网关
    pc1Ip地址PC1IP地址
    3,交换机配置命令
    system-view
    vlan batch 10 20
    int g0/0/1
    port link-type access
    port default vlan 10
    int g0/0/2
    port link-type access
    port default vlan 20
    int g0/0/10
    port link-type trunk
    port trunk allow-pass vlan 10 20 (可以直接作为脚本把配置刷进去)
    在这里插入图片描述4,路由器配置命令
    interface GigabitEthernet0/0/0.10
    dot1q termination vid 10
    ip address 192.168.10.254 255.255.255.0
    arp broadcast enable

    interface GigabitEthernet0/0/0.20
    dot1q termination vid 20
    ip address 192.168.20.254 255.255.255.0
    arp broadcast enable
    在这里插入图片描述

    5,实验验证是否成功
    在这里插入图片描述
    实现了不同vlan网络下的pc可以通信。

    展开全文
  • 1、交换机上的配置命令:(创建vlan并配置接口类型和对应的vlan) 1、交换机上的配置命令:(创建vlan并配置接口类型和对应的vlanvlan batch 10 20 # interface Ethernet0/0/1 port link-type access port ...
  • 不同VLan之间进行通信需要通过Router进行VLan的Label的交换,而每个Router的interface进行抽象出多个子接口,对子接口进行encapsulation dot1q vlan_id的配置,同时每个子接口都各自的网段.基本配置命令:interface ...
  • 通过三层交换机实现不同vlan间的主机可以相互访问 拓扑图 配置如下 主机 PCa PCb PCc PCd VLAN vlan 2 vlan 3 vlan 4 vlan 5 IP地址 192.168.1.1/24 192.168....
  • 一、前置条件1.1目的:利用三层交换机,实现二次交换机的所有功能,同时具有路由功能,节省路由器费用,完成多个vlan之间通信1.2基本设备及配置:三层交换机s5700,1.2.1交换机的ge0/0/1连接pc1,ge0/0/2连接pc2,...
  • 首先,向一直关注本BLOG的博友们表示歉意,最近由于工作繁忙很少来博客,也没有及时给大家带来好的文章分享,今天借这个时间在这里跟大家一起来研究一下关于不同VLAN之间通信问题。 没错,正如标题所说,今天我...
  • 步骤我们要用 R1 来实现分别处于 VLAN1 和 VLAN2 的 PC1 和 PC2 间的通信。(1) 步骤 1:在 S1 上划分 VLANS1(config)# vlan 2S1(config-vlan)# exitS1(config)# int f0/5S1(config-if)# swi...
  • 9 / 9一、网络规划1、设备一台路由器一台二层交换机两台PC2、地址规划路由器(AR1):ge 0/0/0 IP:192.168.10.1/24 vlan1ge 0/0/1 IP:192.168.20.1/24 vlan2交换机(L2SW):eth 0/0/1 eth 0/0/3 属于vlan10 eth 0/0/2...
  • 不同vlan之间相互通信

    2019-09-28 05:47:23
    不同VLAN之间相互通信的两种方式 (单臂路由、三层交换) 试验目的: 1、通过单臂路由实现不同VLAN之间通信 2、通过三层交换路由功能实现不同VLAN之间通信 网络拓扑图: 1、单臂路由实现不同VLAN互通...
  • 不同vlan之间通信原理 交换机只能向端口转发相同标记的数据帧,如果要实现不同的vlan之间相互通信,就需要靠路由器的路由表转发,通过查找ip的方式实现路由转发 ,实现不同vlan之间通信。 单臂路由实现不同vlan...
  • 不同VLAN之间相互通信

    2012-06-07 09:31:34
    不同VLAN之间相互通信。单臂路由实验实例;三层交换实现实例。
  • 学习笔记|不同VLAN之间相互通信

    万次阅读 2018-11-02 16:51:04
    不同VLAN之间无法通信。 今天整理一下不同VLAN之间相互通信的方法。 在划分VLAN后,不同VLAN之间不能直接进行二层通信。如果要实现VLAN间通信。下面通过三种方法实现不同VLAN之间相互通信。 1、单臂路由 ...
  • 不同VLAN之间相互通信的两种方式通过单臂路由实现不同VLAN之间通信 通过三层交换路由功能实现不同VLAN之间通信
  • 实验的拓扑图: 按照拓扑图配置相应的IP地址和网关,即可实现不同主机的通信(因为路由转发实现了...switch0的配置:(要实现不同VLAN之间通信要将交换机的f0/3端口配置成trunk口,trunk口的作用百度一下) Switch>..
  • 不同vlan之间通信

    2021-01-16 15:08:35
    想实现不同vlan通信时,都有什么方法呢? 一、单臂路由 单臂路由是由二层交换机和路由器构成,原理是路由器重新封装MAC地址,转换Vlan标签。交换机与PC机用access,与路由器用trunk。 如图要使PC1与PC2不在相同...
  • 不同VLAN之间通信

    千次阅读 2017-12-10 17:34:33
    实验目的:(1)理解三层交换实现VLAN之间通信的原理  (2)掌握三层交换中SVI的配置、干道的配置 实验环境:计算机一台(PT) 实验拓扑图: 实验内容:(1)搭建网络拓扑图,给图中的设备和端口配置正确的...
  • 不同VLAN之间互相通信

    万次阅读 多人点赞 2016-01-26 18:47:03
    前话我们经常到机房上课,想必对机房后面那层叠的跟DVD一样的机器有...说简单点,就是为主机之间创建通信道路的机器,如下图,各主机连接同个交换机,且IP在同一网段,在同一VLAN,他们是可以互相通信的,他们就简单
  • VLAN是一种将局域网设备从逻辑上划分成一个个网段,从而实现虚拟工作组的新兴数据交换技术。那么如何实现同一路由器不同vlan之间通信?下面就详情来看看vlan配置方式了解下
  • 步骤我们要用 S1 来实现分别处于 VLAN1 和 VLAN2 的 PC1 和 PC2 间的通信。(1) 步骤 1:在 S1 上划分 VLANS1(config)# vlan 2S1(config-vlan)# exitS1(config)# int f0/5S1(config-if)# switchport mode a...
  • 步骤我们要用 S1 来实现分别处于 VLAN1 和 VLAN2 的 PC1 和 PC2 间的通信。(1) 步骤 1:在 S1 上划分 VLANS1(config)# vlan 2S1(config-vlan)# exitS1(config)# int f0/5S1(config-if)# switchport mode a...
  • 阐述了虚拟局域网(VLAN)技术的工作原理及特点,针对不同VLAN之间通信问题,设计出了通过单臂路由、路由接口和三层交换路由功能实现不同VLAN之间通信的三种实验方案,让学生能够从理论上和实践上更好地掌握VLAN技术...
  • 运用三层交换机实现不同VLAN之间通信. 实验的拓扑图: 实验条件:两台主机,一个二层交换机,一个三层交换机 配置概要: 二层交换机的f0/3接口设置为trunk口,f0/1和f0/2口设置为access口 三层交换机的f0/1...
  • 实验目的:实现不同网段之间通信。 1)链路类型 (1)交换机连接主机的端口为access链路 (2)交换机连接路由器的端口为Trunk链路 2)子接口 (1)路由器的物理接口可以被划分成多个逻辑接口 (2)每个子接口对应...
  • SVI实现不同vlan通信

    千次阅读 2013-06-29 16:27:13
    SVI实现不同vlan之间通信   vlan有隔离广播的好处,但是不同vlan之间的通信需要用到三层设备。   通过三层网络设备实现vlan间通信有三种方法:  1. 利用SVI的方式实现,使用三层交换机,具有速度高,无冲突...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 1,097
精华内容 438
关键字:

不同vlan之间通信