精华内容
下载资源
问答
  • 创建地址池 租约: 50% 发的是单播 默认3天,剩余1.5,发一个更新租约 的request报文,续约后变为1.5+3=4.5 87.5% 发的广播,发给网络中的所有DHCP服务器一个光 的request报文 SW1 u t m system-view sys SW1 dhcp ...

    在这里插入图片描述
    单臂路由 有缺陷 三层交换机

    1.创建vlan 原则:所有交换机创建一模一样的vlan
    2.把接口类型做好 原则:只在交换机的接口配置,交换机之间一定是trunk,交换机与 其他设备一定是aceess(单臂路由和无线设备除外)
    3.做MSTP 原则:所有MSTP配置必须一模一样(优先级的命令除外)
    4.网关
    5.路由
    6.DHCP 全局:网关和DHCP服务器是同一台设备
    网关处开全局模式,创建地址池
    接口:几乎不用
    中继:网关和DHCP服务器不是同一台设备且不是同一个网段
    中继:网关在哪里,哪里做中继命令(2条命令)
    服务器:服务器IP地指处开全局,创建地址池
    租约: 50% 发的是单播 默认3天,剩余1.5,发一个更新租约 的request报文,续约后变为1.5+3=4.5
    87.5% 发的广播,发给网络中的所有DHCP服务器一个光 的request报文

    SW1
    u t m
    system-view
    sys SW1
    dhcp enable
    vlan batch 6 10 20 30 40
    port-group group-member g0/0/1 to g0/0/5
    port link-type trunk
    port trunk allow-pass vlan all
    quit
    stp region-configuration
    region-name 1
    instance 1 vlan 10 20
    instance 2 vlan 30 40
    active region-configuration
    quit
    stp instance 1 priority 0
    stp instance 2 priority 4096
    interface vlanif 10
    ip add 192.168.10.254 24
    dhcp select relay
    dhcp relay server-ip 192.168.6.2
    interface vlanif 20
    ip add 192.168.20.254 24
    dhcp select relay
    dhcp relay server-ip 192.168.6.2
    return

    SW2
    u t m
    system-view
    dhcp enable
    sys SW2
    vlan batch 6 10 20 30 40
    port-group group-member g0/0/1 to g0/0/5
    port link-type trunk
    port trunk allow-pass vlan all
    quit
    int g0/0/6
    port link-type access
    port default vlan 6
    quit
    stp region-configuration
    region-name 1
    instance 1 vlan 10 20
    instance 2 vlan 30 40
    active region-configuration
    quit
    stp instance 1 priority 4096
    stp instance 2 priority 0
    interface vlanif 30
    ip add 192.168.30.254 24
    dhcp select relay
    dhcp relay server-ip 192.168.6.2
    interface vlanif 40
    ip add 192.168.40.254 24
    dhcp select relay
    dhcp relay server-ip 192.168.6.2
    interface vlanif 6
    ip add 192.168.6.1 24
    return

    SW3
    u t m
    system-view
    sys SW3
    vlan batch 6 10 20 30 40
    port-group group-member e0/0/1 e0/0/2
    port link-type trunk
    port trunk allow-pass vlan all
    quit
    int e0/0/3
    port link-type access
    port default vlan 10
    int e0/0/4
    port link-type access
    port default vlan 20
    quit
    stp region-configuration
    region-name 1
    instance 1 vlan 10 20
    instance 2 vlan 30 40
    active region-configuration

    SW4
    u t m
    system-view
    sys SW4
    vlan batch 6 10 20 30 40
    port-group group-member e0/0/1 e0/0/2
    port link-type trunk
    port trunk allow-pass vlan all
    quit
    int e0/0/3
    port link-type access
    port default vlan 10
    int e0/0/4
    port link-type access
    port default vlan 30
    quit
    stp region-configuration
    region-name 1
    instance 1 vlan 10 20
    instance 2 vlan 30 40
    active region-configuration
    SW5
    u t m
    system-view
    sys SW5
    vlan batch 6 10 20 30 40
    port-group group-member e0/0/1 e0/0/2
    port link-type trunk
    port trunk allow-pass vlan all
    quit
    int e0/0/3
    port link-type access
    port default vlan 20
    int e0/0/4
    port link-type access
    port default vlan 40
    quit
    stp region-configuration
    region-name 1
    instance 1 vlan 10 20
    instance 2 vlan 30 40
    active region-configuration
    SW6
    u t m
    system-view
    sys SW6
    vlan batch 6 10 20 30 40
    port-group group-member e0/0/1 e0/0/2
    port link-type trunk
    port trunk allow-pass vlan all
    quit
    int e0/0/3
    port link-type access
    port default vlan 40
    int e0/0/4
    port link-type access
    port default vlan 30
    quit
    stp region-configuration
    region-name 1
    instance 1 vlan 10 20
    instance 2 vlan 30 40
    active region-configuration

    DHCP
    u t m
    sys
    sys DHCP
    dhcp enable
    interface g0/0/0
    ip add 192.168.6.2 24
    dhcp select global
    quit
    ip pool p10
    network 192.168.10.0 mask 24
    gateway-list 192.168.10.254
    ip pool p20
    network 192.168.20.0 mask 24
    gateway-list 192.168.20.254
    ip pool p30
    network 192.168.30.0 mask 24
    gateway-list 192.168.30.254
    ip pool p40
    network 192.168.40.0 mask 24
    gateway-list 192.168.40.254
    quit
    ip route-static 192.168.0.0 16 192.168.6.1
    return

    展开全文
  • 网络拓扑图

    2011-12-25 16:25:03
    是一款很实用的网络拓扑图,希望大家下载,适用于中小型企业已经学校等,希望该资源能对大家有帮助
  • 接下来小编将与大家分享一下有关小型企业网络拓扑结构绘制的具体方法,希望能帮助大家。方法/步骤1如果想通过电脑软件绘制流程,则我们需要通过百度搜索下载相关流程制作工具来实现。如所示:2打开流程...

    如何画计算机网络拓扑结构图呢?接下来小编将与大家分享一下有关小型企业网络拓扑结构图绘制的具体方法,希望能帮助大家。

    方法/步骤

    1. 1
    2. 如果想通过电脑软件绘制流程图,则我们需要通过百度搜索下载相关流程图制作工具来实现。如图所示:
    90e3b23dae1426efba255e0688a0be4e.png
    1. 2
    2. 打开流程图制作程序后,点击“文件”菜单中的“新建”按钮,此时将打开“迅捷云储中心”界面,切换到“精品模板”选项卡,找到“小型局域网拓扑图”并点击进行创建。
    7a3f5c9963813d2ed7d9b5e35c96d534.png
    1. 3
    2. 在流程图制作界面中,点击“视图”菜单中的“页面比较”即可调整页面视图大小,也可以通过点击“视图”下拉列表来调整视图大小。
    15f961a099397d0eec617455d7da36b5.png
    1. 4
    2. 在绘制计算机网络拓扑结构图的过程中,可能需要添加新的元素,对此我们可以在“更多图库”界面中,勾选相应的子图库,点击“应用”按钮以添加新的元素到工具列表中
    3b37929fa2126778ccb824fbf7732f29.png
    1. 5
    2. 待完成图形子库的添加操作后,就可以在左侧的“图库”列表中找到相应的子图库,如图所示,展开子图库列表,从中选择并拖动相应的图形到页面中即可完成添加操作,同时可以调整其大小和位置。
    28dd63a88ed01ac946f3928d6e831403.png
    1. 6
    2. 对于新添加的元素,我们可以设置其样式,在选中元素的情况下,利用右侧的“样式”面板可以对其中的元素样式进行调整。
    229889d956e988f25069c2a757cc33c6.png
    1. 7
    2. 页面插入文本方法:
    3. 点击“插入”下拉列表,从中选择“文本工具”项,即可在页面中插入一个文本内容,双击对应的文本,就可以对其进行编辑文字操作了。
    478d4866007386f43a1b48393a32aabb.png
    90d802d4a9c9d3e37669d036442e42b2.png
    1. 8
    2. 相应的文字创建完成后,在选中文字内容的情况下,利用右侧的“文本样式”面板,可以针对文字的相关属性进行设置。
    5a10e93c58b71b2a1ec54b1b65e8b00c.png
    展开全文
  • 网络拓扑图集合(23个)

    2009-02-20 19:44:08
    网络拓扑图集合(23个) 安阳师院校园网网络拓扑图 中小型企业网络拓扑.doc 某某网吧网络拓扑图.doc ……
  • 中小型企业网络配置

    2021-03-19 21:30:22
    文章目录中小型企业网络配置一、需求分析二、拓扑图与ip规划三、实现1、 防火墙FW1的配置2、防火墙fw2配置3、 核心交换机LSW1基本配置4 、核心交换机LSW2基本配置5、接入层交换机lsw3基本配置(lsw4~8类似)6 、...

    @

    中小型企业网络配置

    提示:如有错误。欢迎支出


    一、需求分析

    本次论文设计为实现中小型企业的网络规划与实施,可以从系统的完整性、安全性、高效性等几个方面来分析:
    某企业总公司在广州,分公司设在深圳。总部有六个部门如下:管理、财务、后勤、销售、研发、生产。分公司主要负责开拓新市场。
    项目要求:
    (1)为保证内网运行性能,每一个部门单独一个VLAN,进行合理规划IP地址;
    (2)为各设备做基础配置,完成路由配置,实现内外网的基本连通;
    (3)为了保证网络的可用性和可靠性,对核心层设备配置冗余技术,起到热备及负载均衡作用。
    (4)配置出口策略路由,使得不同内网流量分别通过联通、电信两条ISP线路访问Internet,从而起到负载均衡的作用;
    (5)由于公网IP地址有限,尽可能节约IP地址的损耗。
    (6)总公司有多个部门,要求财务部不允许其他部门访问,其他部门都可以互相访问,各部门都允许访问互联网。(具体内容自己规划)。
    (7)总公司拥有自己的WEB,内外网均可访问;
    (8) 实现公司总部与分公司通信。
    (9) 保证内网安全,监视内网资源与访问走向,限制内网用户的网络资源访问权限,并采用防火墙设备来保证外网到内网间的安全。

    二、拓扑图与ip规划

    ## 1.引入库
    在这里插入图片描述

    三、实现

    1、 防火墙FW1的配置

    基本配置
    interface GigabitEthernet1/0/1
    undo shutdown
    ip address 192.168.10.7 255.255.255.0
    gateway 192.168.10.1
    service-manage http permit
    service-manage https permit
    service-manage ping permit
    service-manage ssh permit
    service-manage snmp permit
    service-manage telnet permit
    interface GigabitEthernet1/0/2
    undo shutdown
    ip address 192.168.20.7 255.255.255.0
    gateway 192.168.20.1
    service-manage http permit
    service-manage https permit
    service-manage ping permit
    service-manage ssh permit
    service-manage snmp permit
    service-manage telnet permit
    interface GigabitEthernet1/0/3
    undo shutdown
    ip address 192.168.90.7 255.255.255.0
    service-manage http permit
    service-manage https permit
    service-manage ping permit
    service-manage ssh permit
    service-manage snmp permit
    service-manage telnet permit
    interface GigabitEthernet1/0/4
    undo shutdown
    ip address 10.93.93.7 255.255.255.0
    gateway 10.93.93.2
    service-manage http permit
    service-manage https permit
    service-manage ping permit
    service-manage ssh permit
    service-manage snmp permit
    service-manage telnet permit

    配置VPN接口
    interface Tunnel1
    ip address 192.168.93.1 255.255.255.0
    tunnel-protocol gre
    source 10.93.93.7
    destination 3.3.3.93
    gre key cipher 123

    添加端口
    firewall zone trust
    add interface GigabitEthernet1/0/1
    add interface GigabitEthernet1/0/2
    add interface Tunnel1
    firewall zone untrust
    add interface GigabitEthernet1/0/4
    firewall zone dmz
    add interface GigabitEthernet1/0/3

    配置ospf
    ospf 1
    area 0.0.0.0
    network 192.168.10.0 0.0.0.255
    network 192.168.20.0 0.0.0.255
    network 192.168.90.0 0.0.0.255

    配置静态路由
    ip route-static 0.0.0.0 0.0.0.0 10.93.93.2
    ip route-static 192.168.100.0 255.255.255.0 Tunnel1
    ip route-static 192.168.110.0 255.255.255.0 Tunnel1

    配置静态pat
    nat server web_server protocol tcp global 10.93.93.7 8000 inside 192.168.90.93 www
    nat server ftp_server protocol tcp global 10.93.93.7 2100 inside 192.168.90.93 ftp
    配置自定义防火墙域间策略
    security-policy
    rule name local_to_dmz
    source-zone dmz
    source-zone local
    destination-zone dmz
    destination-zone local
    action permit
    rule name local_to_trust
    source-zone local
    source-zone trust
    destination-zone local
    destination-zone trust
    action permit
    rule name local_to_untrust
    source-zone local
    source-zone untrust
    destination-zone local
    destination-zone untrust
    action permit
    rule name trust_to_dmz
    source-zone dmz
    source-zone trust
    destination-zone dmz
    destination-zone trust
    action permit
    rule name trust_to_untrust
    source-zone trust
    destination-zone untrust
    action permit
    rule name untrust_to_dmz
    source-zone dmz
    source-zone untrust
    destination-zone dmz
    destination-zone untrust
    action permit
    rule name untrust_to_trust
    source-zone untrust
    destination-zone trust
    service gre
    action permit

    配置动态nat
    nat-policy
    rule name trust_to_untrust_nat
    source-zone trust
    egress-interface GigabitEthernet1/0/4
    source-address 192.168.10.0 mask 255.255.255.0
    source-address 192.168.20.0 mask 255.255.255.0
    source-address 192.168.30.0 mask 255.255.255.0
    source-address 192.168.40.0 mask 255.255.255.0
    source-address 192.168.50.0 mask 255.255.255.0
    source-address 192.168.60.0 mask 255.255.255.0
    source-address 192.168.70.0 mask 255.255.255.0
    source-address 192.168.80.0 mask 255.255.255.0
    action source-nat easy-ip

    2、防火墙fw2配置

    基本配置
    interface GigabitEthernet1/0/1
    undo shutdown
    ip address 3.3.3.93 255.255.255.0
    gateway 3.3.3.254
    service-manage http permit
    service-manage https permit
    service-manage ping permit
    service-manage ssh permit
    service-manage snmp permit
    service-manage telnet permit
    interface GigabitEthernet1/0/2
    undo shutdown
    ip address 192.168.100.93 255.255.255.0
    gateway 192.168.100.4
    service-manage http permit
    service-manage https permit
    service-manage ping permit
    service-manage ssh permit
    service-manage snmp permit
    service-manage telnet permit

    配置VPN接口
    interface Tunnel1
    ip address 192.168.93.2 255.255.255.0
    tunnel-protocol gre
    source 3.3.3.93
    destination 10.93.93.7
    gre key cipher 123

    添加端口
    firewall zone trust
    add interface GigabitEthernet1/0/2
    add interface Tunnel1
    firewall zone untrust
    add interface GigabitEthernet1/0/1

    配置ospf
    ospf 1
    area 0.0.0.0
    network 192.168.100.0 0.0.0.255

    配置静态路由
    ip route-static 0.0.0.0 0.0.0.0 3.3.3.254
    ip route-static 192.168.10.0 255.255.255.0 Tunnel1
    ip route-static 192.168.20.0 255.255.255.0 Tunnel1
    ip route-static 192.168.30.0 255.255.255.0 Tunnel1
    ip route-static 192.168.40.0 255.255.255.0 Tunnel1
    ip route-static 192.168.50.0 255.255.255.0 Tunnel1
    ip route-static 192.168.60.0 255.255.255.0 Tunnel1
    ip route-static 192.168.70.0 255.255.255.0 Tunnel1
    ip route-static 192.168.80.0 255.255.255.0 Tunnel1

    配置自定义防火墙域间策略
    security-policy
    rule name trust_to_local
    source-zone trust
    destination-zone local
    action permit
    rule name local_to_trust
    source-zone local
    destination-zone trust
    action permit
    rule name trust_to_dmz
    source-zone dmz
    source-zone trust
    destination-zone dmz
    destination-zone trust
    action permit
    rule name local_to_untrust
    source-zone local
    source-zone untrust
    destination-zone local
    destination-zone untrust
    action permit
    rule name trust_to_untrust
    source-zone trust
    destination-zone untrust
    action permit
    rule name untrust_to_truse
    source-zone untrust
    destination-zone trust
    service gre
    action permit
    配置动态nat
    nat-policy
    rule name trust_to_untrust_nat
    source-zone trust
    egress-interface GigabitEthernet1/0/1
    source-address 192.168.100.0 mask 255.255.255.0
    source-address 192.168.110.0 mask 255.255.255.0
    action source-nat easy-ip

    3、 核心交换机LSW1基本配置

    sysname LSW1
    undo info-center enable
    vlan batch 30 40 50 60 70 80 1000
    配置MSTP
    stp region-configuration
    region-name HUAWEI
    instance 1 vlan 30 to 50
    instance 2 vlan 60 to 80
    active region-configuration

    stp instance 1 root primary
    stp instance 2 root secondary
    stp pathcost-standard legacy

    配置acl
    acl number 2001
    rule 5 deny source 192.168.40.0 0.0.0.255
    rule 10 deny source 192.168.50.0 0.0.0.255
    rule 15 deny source 192.168.60.0 0.0.0.255
    rule 20 deny source 192.168.70.0 0.0.0.255
    rule 25 deny source 192.168.80.0 0.0.0.255

    配置vlan,vrrp,链路聚合,端口
    interface Vlanif30
    ip address 192.168.30.1 255.255.255.0
    vrrp vrid 30 virtual-ip 192.168.30.254
    vrrp vrid 30 priority 150
    vrrp vrid 30 track interface GigabitEthernet0/0/1
    vrrp vrid 30 track interface GigabitEthernet0/0/3
    interface Vlanif40
    ip address 192.168.40.1 255.255.255.0
    vrrp vrid 40 virtual-ip 192.168.40.254
    vrrp vrid 40 priority 150
    vrrp vrid 40 track interface GigabitEthernet0/0/4
    vrrp vrid 40 track interface GigabitEthernet0/0/1
    interface Vlanif50
    ip address 192.168.50.1 255.255.255.0
    vrrp vrid 50 virtual-ip 192.168.50.254
    vrrp vrid 50 priority 150
    vrrp vrid 50 track interface GigabitEthernet0/0/5
    vrrp vrid 50 track interface GigabitEthernet0/0/1
    interface Vlanif60
    ip address 192.168.60.1 255.255.255.0
    vrrp vrid 60 virtual-ip 192.168.60.254
    interface Vlanif70
    ip address 192.168.70.1 255.255.255.0
    vrrp vrid 70 virtual-ip 192.168.70.254
    interface Vlanif80
    ip address 192.168.80.1 255.255.255.0
    vrrp vrid 80 virtual-ip 192.168.80.254
    interface Vlanif1000
    ip address 192.168.10.1 255.255.255.0

    interface Eth-Trunk1
    port link-type trunk
    port trunk allow-pass vlan 2 to 4094
    interface GigabitEthernet0/0/1
    port link-type access
    port default vlan 1000
    interface GigabitEthernet0/0/2
    eth-trunk 1
    interface GigabitEthernet0/0/3
    port link-type trunk
    port trunk allow-pass vlan 2 to 4094
    traffic-filter outbound acl 2001
    interface GigabitEthernet0/0/4
    port link-type trunk
    port trunk allow-pass vlan 2 to 4094
    interface GigabitEthernet0/0/5
    port link-type trunk
    port trunk allow-pass vlan 2 to 4094
    interface GigabitEthernet0/0/6
    port link-type trunk
    port trunk allow-pass vlan 2 to 4094
    interface GigabitEthernet0/0/7
    port link-type trunk
    port trunk allow-pass vlan 2 to 4094
    interface GigabitEthernet0/0/8
    port link-type trunk
    port trunk allow-pass vlan 2 to 4094
    interface GigabitEthernet0/0/24
    eth-trunk 1

    配置ospf
    ospf 1
    area 0.0.0.0
    network 192.168.10.0 0.0.0.255
    network 192.168.30.0 0.0.0.255
    network 192.168.40.0 0.0.0.255
    network 192.168.50.0 0.0.0.255
    network 192.168.60.0 0.0.0.255
    network 192.168.70.0 0.0.0.255
    network 192.168.80.0 0.0.0.255

    ip route-static 0.0.0.0 0.0.0.0 192.168.10.7

    4 、核心交换机LSW2基本配置

    sysname LSW2
    undo info-center enable
    vlan batch 30 40 50 60 70 80 1000
    配置MSTP
    stp region-configuration
    region-name HUAWEI
    instance 1 vlan 30 to 50
    instance 2 vlan 60 to 80
    active region-configuration

    stp instance 1 root secondary
    stp instance 2 root primary
    stp pathcost-standard legacy

    配置acl
    acl number 2001
    rule 5 deny source 192.168.40.0 0.0.0.255
    rule 10 deny source 192.168.50.0 0.0.0.255
    rule 15 deny source 192.168.60.0 0.0.0.255
    rule 20 deny source 192.168.70.0 0.0.0.255
    rule 25 deny source 192.168.80.0 0.0.0.255

    配置vlan,vrrp,链路聚合,端口
    interface Vlanif30
    ip address 192.168.30.2 255.255.255.0
    vrrp vrid 30 virtual-ip 192.168.30.254
    interface Vlanif40
    ip address 192.168.40.2 255.255.255.0
    vrrp vrid 40 virtual-ip 192.168.40.254
    interface Vlanif50
    ip address 192.168.50.2 255.255.255.0
    vrrp vrid 50 virtual-ip 192.168.50.254
    interface Vlanif60
    ip address 192.168.60.2 255.255.255.0
    vrrp vrid 60 virtual-ip 192.168.60.254
    vrrp vrid 60 priority 150
    vrrp vrid 60 track interface GigabitEthernet0/0/1
    vrrp vrid 60 track interface GigabitEthernet0/0/6
    interface Vlanif70
    ip address 192.168.70.2 255.255.255.0
    vrrp vrid 70 virtual-ip 192.168.70.254
    vrrp vrid 70 priority 150
    vrrp vrid 70 track interface GigabitEthernet0/0/1
    vrrp vrid 70 track interface GigabitEthernet0/0/7
    interface Vlanif80
    ip address 192.168.80.2 255.255.255.0
    vrrp vrid 80 virtual-ip 192.168.80.254
    vrrp vrid 80 priority 150
    vrrp vrid 80 track interface GigabitEthernet0/0/1
    vrrp vrid 80 track interface GigabitEthernet0/0/8
    interface Vlanif1000
    ip address 192.168.20.1 255.255.255.0

    interface Eth-Trunk1
    port link-type trunk
    port trunk allow-pass vlan 2 to 4094
    interface GigabitEthernet0/0/1
    port link-type access
    port default vlan 1000
    interface GigabitEthernet0/0/2
    eth-trunk 1
    interface GigabitEthernet0/0/3
    port link-type trunk
    port trunk allow-pass vlan 2 to 4094
    traffic-filter outbound acl 2001
    interface GigabitEthernet0/0/4
    port link-type trunk
    port trunk allow-pass vlan 2 to 4094
    interface GigabitEthernet0/0/5
    port link-type trunk
    port trunk allow-pass vlan 2 to 4094
    interface GigabitEthernet0/0/6
    port link-type trunk
    port trunk allow-pass vlan 2 to 4094
    interface GigabitEthernet0/0/7
    port link-type trunk
    port trunk allow-pass vlan 2 to 4094
    interface GigabitEthernet0/0/8
    port link-type trunk
    port trunk allow-pass vlan 2 to 4094
    interface GigabitEthernet0/0/24
    eth-trunk 1

    配置ospf
    ospf 1
    area 0.0.0.0
    network 192.168.20.0 0.0.0.255
    network 192.168.30.0 0.0.0.255
    network 192.168.40.0 0.0.0.255
    network 192.168.50.0 0.0.0.255
    network 192.168.60.0 0.0.0.255
    network 192.168.70.0 0.0.0.255
    network 192.168.80.0 0.0.0.255

    ip route-static 0.0.0.0 0.0.0.0 192.168.20.7

    5、接入层交换机lsw3基本配置(lsw4~8类似)

    vlan batch 30

    配置mstp
    stp region-configuration
    region-name HUAWEI
    instance 1 vlan 30 to 50
    instance 2 vlan 60 to 80
    active region-configuration

    stp pathcost-standard legacy

    配置接口
    interface Ethernet0/0/1
    port link-type trunk
    port trunk allow-pass vlan 2 to 4094
    interface Ethernet0/0/2
    port link-type trunk
    stp instance 2 cost 20000
    interface Ethernet0/0/3
    port link-type access
    port default vlan 30
    stp edged-port enable
    interface Ethernet0/0/4
    port link-type access
    port default vlan 30
    stp edged-port enable

    6 、路由器AR1基本配置

    配置ip
    interface GigabitEthernet0/0/0
    ip address 10.93.93.2 255.255.255.0
    interface GigabitEthernet0/0/1
    ip address 2.2.2.2 255.255.255.0
    interface GigabitEthernet0/0/2
    ip address 1.1.1.2 255.255.255.0

    配置ospf
    ospf 1
    area 0.0.0.0
    network 1.1.1.0 0.0.0.255
    network 2.2.2.0 0.0.0.255
    network 10.93.93.0 0.0.0.255

    静态路由配置
    ip route-static 0.0.0.0 0.0.0.0 2.2.2.254

    7、 路由器AR2基本配置

    配置ip
    interface GigabitEthernet0/0/0
    ip address 3.3.3.254 255.255.255.0
    interface GigabitEthernet0/0/1
    ip address 2.2.2.254 255.255.255.0

    配置ospf
    ospf 1
    area 0.0.0.0
    network 3.3.3.0 0.0.0.255

    静态路由配置
    ip route-static 0.0.0.0 0.0.0.0 2.2.2.2

    8 、路由器AR3基本配置

    配置ip
    interface GigabitEthernet0/0/0
    ip address 192.168.100.4 255.255.255.0
    interface GigabitEthernet0/0/1
    ip address 192.168.110.4 255.255.255.0

    配置ospf
    ospf 1
    area 0.0.0.0
    network 192.168.100.0 0.0.0.255
    network 192.168.110.0 0.0.0.255

    静态路由配置
    ip route-static 0.0.0.0 0.0.0.0 192.168.100.93

    四、测试

    1 、内网访问内网测试

    其他部门不能访问财务部,其他部门可以相互访问。以财务部(VLAN30)和销售部(VLAN40)、生产部(VLAN60)为例,如图
    在这里插入图片描述

    图5-1 销售部ping生产部
    在这里插入图片描述

    图5-2 销售部无法ping通财务部

    2 、冗余技术测试

    实现总公司内网访问外网时,正常情况下WLAN30-50走交换机LSW1,WLAN60-80走交换机LSW2,当设备出现故障时,切换到备用设备正常访问,以财务部(WLAN30)和生产部(WLAN60)测试
    设备正常情况下财务部到外网的走向如图
    在这里插入图片描述

    图5-3 财务部到外网的走向图
    关闭核心交换机LSW1 g0/0/1口,追踪财务部走向,如图5-5
    在这里插入图片描述

    图5-4 设备故障时追踪财务部走向
    设备正常情况下生产部到外网的走向如图
    在这里插入图片描述

    图5-5 追踪生产部到外网的走向
    关闭核心交换机LS4g0/0/5口,追踪财务部走向,如图5-8
    在这里插入图片描述

    图5-6 设备故障时追踪生产部走向

    3 、内外网访问服务器

    实现校园内网均能访问防火墙DMZ区域中的服务器,这里以生产部为例
    在这里插入图片描述

    图5-7 财务部访问WEB服务器
    实现公司外网能够通过公网IP地址访问到服务器。
    在这里插入图片描述

    图5-8 外网访问WEB
    5.3 内网访问外网,nat
    以销售部(WLAN40)去访问外网时如图5-12,在防火墙上查看状态会话表,可发现地址转换为了端口g1/0/4的IP地址如图5-13:
    在这里插入图片描述

    图5-9 销售部访问外网
    在这里插入图片描述

    图5-10在防火墙中查看状态会话表

    4、 总部与分公司相互访问

    以管理部(WLAN10)和销售部(WLAN40)测试如图5-16和5-17
    在这里插入图片描述

    图5-11 总公司ping分部
    在这里插入图片描述

    图5-12 在防火墙中查看状态会话表
    在这里插入图片描述

    图5-13分部ping总部
    在这里插入图片描述

    图5-14 在防火墙中查看状态会话表

    展开全文
  • 注:详细文档在我的下载资源中,拓扑图如不清晰则可查看pkt文件 已将本文中的拓扑图进行了替换,改善了清晰度。...Cisco Packet Tracer v7.2.2-中小型企业网络建设最终部署文件与文章中小型企业网...

    注:详细文档在我的下载资源中,拓扑图如不清晰则可查看pkt文件

    已将本文中的拓扑图进行了替换,改善了清晰度。若还有疑问,可下载pkt文件进行查看。

    用高版本打开,本实验PKT格式文件用7.2.2版本可以打开

    环境要求:

    Cisco Packet Tracer v7.2.2软件

    说明:

    Cisco Packet Tracer v7.2.2-中小型企业网络建设最终部署文件与文章中小型企业网络建设-Cisco Packet Tracer v7.2.2思科网络模拟器实验练习(https://blog.csdn.net/weixin_39329758/article/details/90709777) 相对应;

    1.下载对应Cisco Packet Tracer v7.2.2软件,在软件中打开“中小型企业网络建设.pkt”即可。

    2.等待各个设备加载完毕即可。

    文档链接:https://download.csdn.net/download/weixin_39329758/11234846

    配置结果pkt文件链接:https://download.csdn.net/download/weixin_39329758/11234813

    Cisco Packet Tracer v7.2.2软件(64位)下载:https://download.csdn.net/download/weixin_39329758/11996158

    一、系统需求及功能

    1.系统需求:

    某集团公司拟为某地的H分公司部署局域网络,并连接到公司总部的网络。总部网络如下图所示:

    H分公司获得了总部统一分配的24位子网掩码的B类私网地址。现还需采购1台路由器、2台三层交换机、4台24口的二层交换机和1台FTP服务器,设备及相关材料由施工方采购。请设计并实施H分公司的网络建设。

    2.网络要求:

    2.1、 H网络接入到R2路由器上,使用OSPF动态路由协议,并配置为完全末梢区域;

    2.2、 H有三个部门,分别是行政部20台左右的主机(实际验收用2台主机作验证,下同),技术部20台左右的主机,工程部40台左右主机,它们必须分属3个不同的VLAN;

    2.3 、H所有主机均能通过NAT访问总部网络(以能ping通总部PC为准);

    2.4、 H的技术部允许访问H的FTP服务器(FTP服务器需部署FTP服务,其他PC部署FTP客户端,以能实现FTP上传下载为准),其他部门不能访问;

    2.5 、H网络在核心交换机处部署冗余保护,FTP服务器部署冗余保护;

    2.6、 所有主机自动获取IPv4地址。

    3.基本功能:

    3.1 、H所有主机均能通过NAT访问总部网络(以能ping通总部PC为准);

    3.2、 H的技术部允许访问H的FTP服务器(FTP服务器需部署FTP服务,其他PC部署FTP客户端,以能实现FTP上传下载为准),其他部门不能访问;

    3.3 、所有主机自动获取IPv4地址;

    3.4 、使用STP协议处理了网络之间形成的环路,不会产生广播风暴;

    二、设计方案

     

    三、系统规划设计

    1.设计流程:

    2.Vlan划分:

     

    部门

     

    Vlan

    主机数

    网络地址

    广播地址

    可用范围/子网掩码

    可用主机数

    工程部

    10

    40

    10.31.1.0

    10.31.1.63

    10.31.1.1-10.31.1.62/26

    62

    技术部

    20

    22

    10.31.1.64

    10.31.1.95

    10.31.1.65-10.1.1.94/27

    30

    行政部

    30

    22

    10.31.1.96

    10.31.1.127

    10.12.1.97-10.31.1.126/27

    30

    3.端口划分:

     

    部门

     

    主机数

    接口

    Vlan

    备注

    工程部

    40

    10.31.1.0

    SW2-1(1-22)+SW2-2(1-18)

    10

     

    技术部

    20

    10.31.1.64

    SW2-3(1-20)

    20

     

    行政部

    20

    22

    10.21.1.96

    SW-(1-20)

    30

     

    4.网络拓扑:

    以下为各部分较为清晰详细的地址等分配信息:

    四、项目脚本:

    1、二层交换机VLAN划分

    SW2-1:(工程部)

    Switch>enable
    Switch#configure terminal
    Switch(config)#hostname SW2-1
    SW2-1(config)#vlan 10
    SW2-1(config-vlan)#exit
    SW2-1(config)#interface range f0/1-22
    SW2-1(config-if-range)#switchport mode access
    SW2-1(config-if-range)#switchport access vlan 10
    SW2-1(config-if-range)#exit
    SW2-1(config)#interface range f0/23-24
    SW2-1(config)#switchport mode trunk
    SW2-1(config)#exit
    

    SW2-2:(工程部)

    Switch>enable
    Switch#configure terminal
    Switch(config)#hostname SW2-2
    SW2-2(config)#vlan 10
    SW2-2(config-vlan)#exit
    SW2-2(config)#interface range f0/1-18
    SW2-2(config-if-range)#switchport mode access
    SW2-2(config-if-range)#switchport access vlan 10
    SW2-2(config-if-range)#exit
    SW2-2(config)#interface range f0/23-24
    SW2-2(config)#switchport mode trunk
    SW2-2(config)#exit
    

    SW2-3:(技术部)

    Switch>enable
    Switch#configure terminal
    Switch(config)#hostname SW2-3
    SW2-3(config)#vlan 20
    SW2-3(config-vlan)#exit
    SW2-3(config)#interface range f0/1-20
    SW2-3(config-if-range)#switchport mode access
    SW2-3(config-if-range)#switchport access vlan 20
    SW2-3(config-if-range)#exit
    SW2-3(config)#interface range f0/23-24
    SW2-3(config)#switchport mode trunk
    SW2-3(config)#exit
    

    SW2-4:(行政部)

    Switch>enable
    Switch#configure terminal
    Switch(config)#hostname SW2-4
    SW2-4(config)#vlan 30
    SW2-4(config-vlan)#exit
    SW2-4(config)#interface range f0/1-20
    SW2-4(config-if-range)#switchport mode access
    SW2-4(config-if-range)#switchport access vlan 30
    SW2-4(config-if-range)#exit
    SW2-4(config)#interface range f0/23-24
    SW2-4(config)#switchport mode trunk
    SW2-4(config)#exit
    

    2、三层交换机端口链路聚合及与二层交换机的连通配置

            主要实现的三层交换机之间的冗余备份,将其中二层交换机与三层交换机之间用trunk线连起来。

    SW3-1:

    Switch>enable
    Switch#configure terminal
    Switch(config)#hostname SW3-1
    SW3-1(config)#vlan 10
    SW3-1(config-vlan)#exit
    SW3-1(config)#vlan 20
    SW3-1(config-vlan)#exit
    SW3-1(config)#vlan 30
    SW3-1(config-vlan)#exit
    SW3-1(config)#interface range f0/5-6
    SW3-1(config-if-range)#switchport trunk encapsulation dot1q
    SW3-1(config-if-range)#switchport mode trunk
    SW3-1(config-if-range)#channel-group 1 mode on
    SW3-1(config-if-range)#switchport mode access
    SW3-1(config-if-range)#switchport access vlan 10
    SW3-1(config-if-range)#switchport access vlan 20
    SW3-1(config-if-range)#switchport access vlan 30
    SW3-1(config-if-range)#exit
    SW3-1(config)#interface range f0/1-4
    SW3-1(config-if-range)#switchport trunk encapsulation dot1q
    SW3-1(config-if-range)#switchport mode trunk
    SW3-1(config-if-range)#exit
    SW3-1(config)#
    

    SW3-2:

    Switch>enable
    Switch#configure terminal
    Switch(config)#hostname SW3-2
    SW3-2(config)#vlan 10
    SW3-2(config-vlan)#exit
    SW3-2(config)#vlan 20
    SW3-2(config-vlan)#exit
    SW3-2(config)#vlan 30
    SW3-2(config-vlan)#exit
    SW3-2(config)#interface range f0/5-6
    SW3-2(config-if-range)#switchport trunk encapsulation dot1q
    SW3-2(config-if-range)#switchport mode trunk
    SW3-2(config-if-range)#channel-group 1 mode on
    SW3-2(config-if-range)#switchport mode access
    SW3-2(config-if-range)#switchport access vlan 10
    SW3-2(config-if-range)#switchport access vlan 20
    SW3-2(config-if-range)#switchport access vlan 30
    SW3-2(config-if-range)#exit
    SW3-2(config)#interface range f0/1-4
    SW3-2(config-if-range)#switchport trunk encapsulation dot1q
    SW3-2(config-if-range)#switchport mode trunk
    SW3-2(config-if-range)#exit
    SW3-2(config)#
    

    3、三层交换机Vlan间通信配置

            三层交换机可以实现不同vlan之间的互通,只需要打开三层交换机的路由功能(ip routing),然后二层交换机与三层交换机之间用trunk链路连接,将每个vlan封装进去即可实现不同vlan之间的通信。

    SW3-1:

    SW3-1(config)#interface vlan 10
    SW3-1(config-if)#no shutdown
    SW3-1(config-if)#ip address 10.31.1.62 255.255.255.192
    SW3-1(config-if)#exit
    SW3-1(config)#
    SW3-1(config)#interface vlan 20
    SW3-1(config-if)#no shutdown
    SW3-1(config-if)#ip address 10.31.1.94 255.255.255.224
    SW3-1(config-if)#exit
    SW3-1(config)#
    SW3-1(config)#interface vlan 30
    SW3-1(config-if)#no shutdown
    SW3-1(config-if)#ip address 10.31.1.126 255.255.255.224
    SW3-1(config-if)#exit
    SW3-1(config)#
    

    SW3-2:

    SW3-2(config)#interface vlan 10
    SW3-2(config-if)#no shutdown
    SW3-2(config-if)#ip address 10.31.1.62 255.255.255.192
    SW3-2(config-if)#exit
    SW3-2(config)#
    SW3-2(config)#interface vlan 20
    SW3-2(config-if)#no shutdown
    SW3-2(config-if)#ip address 10.31.1.94 255.255.255.224
    SW3-2(config-if)#exit
    SW3-2(config)#
    SW3-2(config)#interface vlan 30
    SW3-2(config-if)#no shutdown
    SW3-2(config-if)#ip address 10.31.1.126 255.255.255.224
    SW3-2(config-if)#exit
    SW3-2(config)#
    

    4、路由器配置

    用ospf动态路由实现网络层的通信,给三层交换机与路由器相通的端口也配置IP地址,实现传输层到网络层的通信。

    R3:

    Router>enable
    Router#configure terminal
    Router(config)#hostname R3
    R3(config)#interface loopback 1
    R3(config-if)#no shutdown
    R3(config-if)#ip address 10.31.1.254 255.255.255.255
    R3(config-if)#exit
    R3(config)#interface g0/0
    R3(config-if)#no shutdown
    R3(config-if)#ip address 10.31.1.130 255.255.255.252
    R3(config-if)#exit
    R3(config)#interface g0/1
    R3(config-if)#no shutdown
    R3(config-if)#ip address 10.31.1.133 255.255.255.255
    R3(config-if)#exit
    R3(config)#interface g0/2
    R3(config-if)#no shutdown
    R3(config-if)#ip address 10.31.1.137 255.255.255.252
    R3(config-if)#exit
    R3(config)#router ospf 10	
    R3(config-router)#router-id 10.31.1.254 
    R3(config-router)#network 10.31.1.254 0.0.0.0 area 1
    R3(config-router)#network 10.31.1.128 0.0.0.3 area 1
    R3(config-router)#network 10.31.1.132 0.0.0.3 area 1
    R3(config-router)#network 10.31.1.136 0.0.0.3 area 1
    R3(config-router)#exit
    

    R2

    Router>enable
    Router#configure terminal
    Router(config)#hostname R2
    R2(config)#interface loopback 1
    R2(config-if)#no shutdown
    R2(config-if)#ip address 10.31.1.253 255.255.255.255
    R2(config-if)#exit
    R2(config)#interface g0/0
    R2(config-if)#no shutdown
    R2(config-if)#ip address 10.31.1.129 255.255.255.252
    R2(config-if)#exit
    R2(config)#interface g0/1
    R2(config-if)#no shutdown
    R2(config-if)#ip address 10.31.2.1 255.255.255.0
    R2(config-if)#exit
    R2(config)#router ospf 10	
    R2(config-router)#router-id 10.31.1.253 
    R2(config-router)#network 10.31.1.253 0.0.0.0 area 0
    R2(config-router)#network 10.31.2.0 0.0.0.255 area 0
    R2(config-router)#network 10.31.1.128 0.0.0.3 area 1
    R2(config-router)#exit
    

    R1:

    Router>enable
    Router#configure terminal
    Router(config)#hostname R1
    R1(config)#interface loopback 1
    R1(config-if)#no shutdown
    R1(config-if)#ip address 10.31.1.252 255.255.255.255
    R1(config-if)#exit
    R1(config)#interface g0/1
    R1(config-if)#no shutdown
    R1(config-if)#ip address 10.31.2.2 255.255.255.0
    R1(config-if)#exit
    R1(config)#interface g0/0
    R1(config-if)#no shutdown
    R1(config-if)#ip address 10.31.3.1 255.255.255.0
    R1(config-if)#exit
    R1(config)#router ospf 10	
    R1(config-router)#router-id 10.31.1.252 
    R1(config-router)#network 10.31.1.252 0.0.0.0 area 0
    R1(config-router)#network 10.31.2.0 0.0.0.255 area 0
    R1(config-router)#network 10.31.3.0 0.0.0.255 area 0
    R3(config-router)#exit
    

    SW3-1:

    SW3-1(config)#ip routing
    SW3-1(config)#interface f0/24
    SW3-1(config-if)#no switchport
    SW3-1(config-if)#ip address 10.31.1.134 255.255.255.252
    SW3-1(config-if)#exit
    SW3-1(config)#router ospf 10
    SW3-1(config-router)#network 10.31.1.132 0.0.0.3 area 1
    SW3-1(config-router)#network 10.31.1.0 0.0.0.63 area 1
    SW3-1(config-router)#network 10.31.1.64 0.0.0.31 area 1
    SW3-1(config-router)#network 10.31.1.96 0.0.0.31 area 1
    SW3-1(config-router)#exit
    SW3-1(config-router)#
    

    SW3-2:

    SW3-2(config)#ip routing
    SW3-2(config)#interface f0/24
    SW3-2(config-if)#no switchport
    SW3-2(config-if)#ip address 10.31.1.134 255.255.255.252
    SW3-2(config-if)#exit
    SW3-2(config)#router ospf 10
    SW3-2(config-router)#network 10.31.1.132 0.0.0.3 area 1
    SW3-2(config-router)#network 10.31.1.0 0.0.0.63 area 1
    SW3-2(config-router)#network 10.31.1.64 0.0.0.31 area 1
    SW3-2(config-router)#network 10.31.1.96 0.0.0.31 area 1
    SW3-2(config-router)#exit
    SW3-2(config-router)#
    

    5、特殊区域配置

            题目要求,H网络接入到R2路由器上,使用OSPF动态路由协议,并配置为完全末梢区域,所以将area 1 区域设置为total stub(完全末梢区域)。

    R2

    R2(config)#router ospf 10	
    R2(config-router)#area 1 stub no-summary
    R2(config-router)#exit
    

    R3:

    R3(config)#router ospf 10	
    R3(config-router)#area 1 stub no-summary
    R3(config-router)#exit
    

    SW3-1:

    SW3-1(config)#router ospf 10	
    SW3-1(config-router)#area 1 stub no-summary
    SW3-1(config-router)#exit
    

    SW3-2:

    SW3-2(config)#router ospf 10	
    SW3-2(config-router)#area 1 stub no-summary
    SW3-2(config-router)#exit
    

    6、防环处理

            开启三层交换机和二层交换机的生成树协议,实现防环处理,防止网络风暴的发生。并通过设置根交换机的优先级,使SW3-1作为主根,SW3-2作为次根。

    SW3-1

    SW3-1(config)#spanning-tree vlan 10
    SW3-1(config)#spanning-tree vlan 20
    SW3-1(config)#spanning-tree vlan 30
    SW3-1(config)#spanning-tree vlan 10 priority 4096
    SW3-1(config)#spanning-tree vlan 20 priority 4096
    SW3-1(config)#spanning-tree vlan 30 priority 4096
    

    SW3-2

    SW3-2(config)#spanning-tree vlan 10
    SW3-2(config)#spanning-tree vlan 20
    SW3-2(config)#spanning-tree vlan 30
    SW3-2(config)#spanning-tree vlan 10 priority 8192
    SW3-2(config)#spanning-tree vlan 20 priority 8192
    SW3-2(config)#spanning-tree vlan 30 priority 8192
    

    7、DHCP地址池配置

            DHCP服务可以实现动态获取IP地址的功能,可以在三层交换机上搭建一个无中继DHCP服务,从而使三个部门动态获取IP地址。在R1上搭建一个无中继DHCP服务,从而使H主网的PC机实现动态获取IP地址。

    SW3-1

    SW3-1(config)#service dhcp
    SW3-1(config)#ip dhcp pool vlan10
    SW3-1(config-pool)#network 10.31.1.0 255.255.255.192
    SW3-1(config-pool)#dns-server 4.4.4.4
    SW3-1(config-pool)#default-router 10.31.1.62
    SW3-1config-)#ip dhcp excluded-address 10.31.1.62
    SW3-1(config)#ip dhcp pool vlan20
    SW3-1(config-pool)#network 10.31.1.64 255.255.255.224
    SW3-1(config-pool)#dns-server 4.4.4.4
    SW3-1(config-pool)#default-router 10.31.1.94
    SW3-1(config)#ip dhcp excluded-address 10.31.1.94
    SW3-1(config)#ip dhcp pool vlan30
    SW3-1(config-pool)#network 10.31.1.96 255.255.255.224
    SW3-1(config-pool)#dns-server 4.4.4.4
    SW3-1(config-pool)#default-router 10.31.1.126
    SW3-1(config)#ip dhcp excluded-address 10.31.1.126
    

    SW3-2

    SW3-2(config)#service dhcp
    SW3-2(config)#ip dhcp pool vlan10
    SW3-2(config-pool)#network 10.31.1.0 255.255.255.192
    SW3-2(config-pool)#dns-server 4.4.4.4
    SW3-2(config-pool)#default-router 10.31.1.62
    SW3-1(config-)#ip dhcp excluded-address 10.31.1.62
    SW3-2(config)#ip dhcp pool vlan20
    SW3-2(config-pool)#network 10.31.1.64 255.255.255.224
    SW3-2(config-pool)#dns-server 4.4.4.4
    SW3-2(config-pool)#default-router 10.31.1.94
    SW3-2(config)#ip dhcp excluded-address 10.31.1.94
    SW3-2(config)#ip dhcp pool vlan30
    SW3-2(config-pool)#network 10.31.1.96 255.255.255.224
    SW3-2(config-pool)#dns-server 4.4.4.4
    SW3-2(config-pool)#default-router 10.31.1.126
    SW3-2(config)#ip dhcp excluded-address 10.31.1.126
    

    R1

    R1(config)#service dhcp	
    R1(config)#ip dhcp pool hostdhcp
    R1(config-pool)#network 10.31.3.0 255.255.255.0
    R1(config-pool)#dns-server 4.4.4.4
    R1(config-pool)#default-router 10.31.3.1
    R1(config-pool)#ip dhcp excluded-address 10.31.3.1
    R1(config)#
    

    8、NET配置

            将公司主网与Area1区域连接的端口配置NAT设置,将与主网连接的端口设置为内网,与分公司相连的网络配置为外网。

    R3:

    R2(config)#interface range g0/1-2
    R2(config-if)#ip nat inside 
    R2(config-if)#exit
    R2(config)#interface range g0/0
    R2(config-if)#ip nat outside 
    R2(config-if)#exit
    

    9、FTP配置
            对ftp服务器做冗余保护,所以将FTP分别连接到SW3-1和SW3-2 的fastEthernet0/23端口,给SW3-1和SW3-2 的fastEthernet0/23端口配置IP地址,给FTP服务器的fastEthernet 0和fastEthernet 1接口配置IP地址。

    SW3-1

    SW3-1(config)#interface f0/23
    SW3-1(config-if)#no switchport
    SW3-1(config-if)#ip address 10.31.1.141 255.255.255.252
    SW3-1(config-if)#no shutdown
    SW3-1(config-if)#exit
    SW3-1(config-if)#router ospf 10
    SW3-1(config-router)#network 10.31.1.140 0.0.0.3 area 1
    SW3-1(config-router)#exit
    

    SW3-2:

    SW3-2(config)#interface f0/23
    SW3-2(config-if)#no switchport
    SW3-2(config-if)#ip address 10.31.1.145 255.255.255.252
    SW3-2(config-if)#no shutdown
    SW3-2(config-if)#exit
    SW3-2(config-if)#router ospf 10
    SW3-2(config-router)#network 10.31.1.144 0.0.0.3 area 1
    SW3-2(config-router)#exit
    

    10、ACL控制列表配置配置

            访问控制列表是路由器和交换机接口的指令列表,用来控制端口进出的数据包,ACL适用于所有的路由协议。配置ACL后,可以限制网络流量,允许特定设备访问,指定转发特定端口数据包等。通过配置访问控制列表可以实现只有技术部可以访问FTP服务的要求。且cisco模拟器中的控制列表默认拒绝访问,只需配置一条允许技术部访问的列表即可。

    SW3-1

    SW3-1(config)#access-list 1 permit 10.31.1.64 0.0.0.31
    SW3-1(config)#interface f0/23
    SW3-1(config-if)#ip access-group 1 out
    SW3-1(config-if)#exit
    

    SW3-2:

    SW3-2(config)#access-list 1 permit 10.31.1.64 0.0.0.31
    SW3-2(config)#interface f0/23
    SW3-2(config-if)#ip access-group 1 out
    SW3-2(config-if)#exit
    

    五、测试与验证:

    1、连通性验证(ping)

    (1)vlan间通信(不同部门间的通信)

     

    (2)访问总公司

    (3)链路聚合验证(show etherchannel summary)

    SW3-1:

    SW3-2:

    生成树验证(show spanning-tree)

    SW3-1: 

    vlan10:

    vlan20:

    vlan30:

    SW3-2:

    vlan10:

    vlan20:

    vlan30:

    访问控制列表验证(show ip access-list)

    SW3-1:

    FTP服务验证(ftp 10.31.1.142)

    技术部:

    其他部门:

    完全末梢区域(total stub)验证(show ip route)

    R3:

    SW3-1:

    SW3-2:

    DHCP动态获取IP地址验证

    工程部:

    技术部:

    行政部:

    六、任务分工:

            本实验所有过程为我个人独立完成。

    七、总结收获:

            通过综合实验,把数据通信中的知识点立即的更清楚了。明白了vlan划分、聚合链路、生成树、ACL、NAT等的作用,知道了vlan见通信的配置方式由单臂路由、三次交换机上的vlan通信等。

     

    展开全文
  • 中小型企业网络设计

    2013-05-21 22:19:08
    一、设计需求:1)经理室、设备科、人事处,可以访问外部网络,外部网络不能访问经理室、设备科、人事处...二、网络拓扑3.根据拓扑图和实验需求,我们分析一下整体的网络,首先要在二层交换机上配置vlan,并且把相应...
  • 中小型企业网络构建(思科)

    千次阅读 2020-06-11 13:25:10
    网络培训中心网络系统设计1、引言2、网络设计过程综述2.1 设计目标2.2 ...网络拓扑图4.2 设备选型4.3 IP地址及VLAN划分5、网络设备配置5.1 交换机配置5.1.1 核心层交换机配置5.1.2 接入层交换机配置5.2 路由器配置5.3...
  • 前言*随着互联网的发展,越来越多的中小型公司需要组建简单局域网使公司内部员工上网,并能实现简单上网行为管理,Linux作为网关服务器是再适合不过了,又开源又免费,而且还能免费发布Web。 一、搭建所需环境 ...
  • 3.2.2 企业网络拓扑图 3 4 企业网络详细设计 3 4.1 设计思路 3 4.2 设计步骤 4 4.2.1 按照拓扑图要求连接好设备 4 4.2.2 IP地址与VLAN规划 4 4.2.3 配置内网DHCP服务器 5 4.2.4 核心层交换机配置 5 4.2.5 汇聚层...
  • 本文是基于一个课程的网络...从实际情况出发把这个小型企业的实际需要应用到网络中去,使这个企业的内部网络能够快速便捷。因为条件有限,本次设计的拓扑结构是在模拟器上进行的。主要运用了所学的路由和交换技术。
  • 现有50台计算机,设计一个小型企业网络方案,要求: 1.资源共享,网络内的各个桌面用户可共享数据库、实现办公自动化系统的各项功能; 2.通信服务,最终用户通过广域网连接可以收发电子邮件、实现Web应用、接...
  • 通过分析,我们可以得出该企业拓扑图需要一个核心路由器来完成内外网地址转换,并且指定地址使内外网可以访问到企业内网web服务器。我们可以以一台三层交换机为中心与一台路由器和六台二层交换机相连接作为内网,...
  • 一、小型网络接入的用户在100左右的为小型企业网。对于这种小型网络,我们的组网方案为:在此方案,把各个办公室划分为独立的vlan并设置一个单独的子网,使用2层交换机来进行接入层,使用中型3层交换机作为核心...
  • 1拓扑 1 统一管理设备,认证【本地用户名... 2 10.1、内网设备管理【核心层为例】 说明:之前定义了管理VLAN为VLAN1,定义没有规划,这个可以根据自己情况来分配即可。所以这里以核心层 Core-B为例(1)定义不同用...
  • 通过 eNSP 模拟中小型企业网并在网络设备上采用 VLAN 虚拟局域网、DHCP协议自动分配地址,以及高级ACL和PPP协议,使构建的企业网能满足业务需求,部门之间的传递的安全性。 注:以下案例仅供参考。 一、需求分析 ...
  • 从实际情况出发把这个小型企业的实际需要应用到网络中去,使这个企业的内部网络能够快速便捷。因为条件有限,本次设计的拓扑结构是在模拟器上进行的。主要运用了所学的路由和交换技术。 各个部门内的用户都可以...
  • 0003企业网络模拟-1.pkt

    2019-07-08 22:49:50
    中小型企业网络模拟拓扑图(使用思科PT制作),思科网络模拟
  • 0007企业网络模拟-5.pkt

    2019-07-08 22:51:33
    中小型企业网络模拟拓扑图(使用思科PT制作),思科网络模拟
  • 0005企业网络模拟-3.pkt

    2019-07-08 22:50:50
    中小型企业网络模拟拓扑图(使用思科PT制作),思科网络模拟
  • 0008企业网络模拟-6.pkt

    2019-07-08 22:52:00
    中小型企业网络模拟拓扑图(使用思科PT制作),思科网络模拟
  • 0006企业网络模拟-4.pkt

    2019-07-08 22:51:11
    中小型企业网络模拟拓扑图(使用思科PT制作),思科网络模拟
  • 企业组网案例模拟1、实验要求2、实验拓扑3、实验需求4、配置思路4.1 总部配置4.2 分部配置4.3 配置总部和分部互联4.4 网络优化 1、实验要求 假如你是某公司网管员,要为总部和分部规划网络。左边蓝色区域为总公司...
  • 前言zabbix 作为企业级的系统和网络监控方案,对于中小型公司来说基本可以很好的满足对机器的监控需求,因为其部署方便,操作简单深受现在各个互联网公司喜爱,所以现在基本的互联网公司监控用zabbix的非常多,当你...
  • 一、单活部署(热备HA)对于中小型企业客户,内部资产数量相对较少,单台堡垒机的性能就可以满足时(图形200,字符1000),就可以在客户网络中接入一台堡垒机进行审计。但是对于运维的连续性又有要求,不期望由于堡垒机...
  • 2.4.1网络拓扑结构示意 2.4.2网络中心组建 2.4.3生产车间网络组建 2.4.4企业各部门IP分配表 第三章 网络设备的配置和管理 3.1 划分子网 3.2 划分VLAN的方法 3.2.1什么是VLAN 3.2.2 VLAN划分的几点好处 ...
  • 这是第一篇关于中小型企业组建网络的文章,之前都是写的系统相关的,科技时代的今天,互联网显得尤为重要了,那么应该如何高效、快捷的组网?今天跟大家分享一下组网实例吧。首先,看一张我自己绘制的网络拓扑的实例...
  • 然后对OSPF协议、DHCP协议、VLAN的划分、静态路由以及数据流控制等相关技术理论作了简单的论述,其次结合工程项目,论述了企业网络的需求分析、整体设计,其中包括对IP地质的划分,网络拓扑图等做了分析和描述。...

空空如也

空空如也

1 2 3 4
收藏数 61
精华内容 24
关键字:

中小型企业网络拓扑图