精华内容
下载资源
问答
  • 思科路由器NAT配置详解(转)

    千次阅读 2019-08-07 20:23:10
    思科路由器NAT配置详解(转) 网络技术 2010-07-11 17:48:14 阅读104 评论0 字号:大中小订阅 思科路由器NAT配置详解 一、NAT简介: NAT(Network Address Translation)网络地址转换。 最早出现在思科...

    思科路由器NAT配置详解(转)

    网络技术 2010-07-11 17:48:14 阅读104 评论0   字号: 订阅

    思科路由器NAT配置详解 - ILCHN - ILCHN

    思科路由器NAT配置详解

    一、NAT简介: 

    NAT(Network Address Translation)网络地址转换。 

    最早出现在思科11.2 IOS中,定义在RFC1631和RFC3022中。

    NAT最主要的作用是为了缓解IPv4地址空间的不足。

    同时也带来了一些问题,如每个数据包到达路由器后都要进行包头的转换操作,所以增加了延迟;DNS区域传送,BOOTP/DHCP等协议不可穿越NAT路由器;

    改动了源IP,失去了跟踪到端IP流量的能力,所以使责任不明确了。   

    但是利还是要大于弊的,不然也不会学习它了!最新的CCNA640-802学习指南中依然有专门的一章来讲解NAT,它的重要性可见一斑。   

    二、NAT术语:比较难理解,所以这里用最明了的语言总结如下 -  

    内部本地地址( inside local address ):局域网内部主机的地址,通常是RFC1918地址空间中的地址,称为私有地址。(待转换的地址)  

    内部全局地址(inside global address):内部本地地址被NAT路由器转换后的地址,通常是一个可路由的公网地址。

    外部全局地址(outside global address):是与内部主机通信的目标主机的地址,通常是一个可路由的公网地址。

    外部本地地址(outside local address):是目标主机可路由的公网地址被转换之后的地址,通常是RFC1918地址空间中的地址。

    三、NAT配置详解:  

    静态NAT:将一个私有地址和一个公网地址一对一映射的配置方法,这种方式不能节省IP,通常只为需要向外网提供服务的内网服务器配置。

     

    如图所示:

              PC1地址:192.168.0.2/24  

              PC2地址:192.168.0.3/24

              R1 E0/0地址:192.168.0.1/24     

              R1 S0/0地址:202.106.0.1/24

              R2 S0/0地址:202.106.0.2/24 

              R2 E0/0地址:202.106.1.1/24

              PC3地址:202.106.1.2/24

    各接口地址按上面配置好之后,在R1和R2上配置路由(注意不要为192.168.0.0网络增加路由项,因为私有网络不可以出现在公网路由表中,不然也不叫私有地址了)  

    路由配置好之后在R1上可以ping通PC3,但是PC1只能ping到R1的S0/0,再向前就ping不通了。因为没有192.168.0.0网络的路由表项,所以被丢弃了!下面在R1上配置静态NAT让PC1可以和PC3通信。 

    Router(config)#int fa0/0

    Router(config-if)#ip nat inside  //将该接口标记为内部接口   

    Router(config-if)#int s0 /0/0

    Router(config-if)#ip nat outside //将该接口标记为外部接口

    Router(config-if)#exit

    Router(config)#ip nat inside source static 192.168.0.2 202.106.0.3 //将来自标记为内部接口的地址做为转换源,将 192.168.0.2一对一的转换成 202.106.0.3   

            2、动态NAT:现在PC1就可以和PC3通信了。但是PC2不能,因为R1并没有为PC2提供地址转换。当然我们可以在R1上像给PC1做静态转换一样也给PC2做一个,可如果我们有100台机器工作量就太大了。下面在R1上再继续配置:   

    Router(config)#access-list 10 permit 192.168.0.0 0.0.0.255  //定义标准访问控制列表10只允许定义的地址能够被转换

    Router(config)#ip nat pool out 202.106.0.4 202.106.0.24 netmask 255.255.255.0  //定义名称为out的地址池。

    Router(config)#ip nat inside source list 10 pool out //将访问控制列表定义的地址和地址池关联这样就有前21个内部主机能够得到公网地址。  

    现在PC2也可以和PC3通信了。这就是动态NAT,这种方式也不能节约IP地址。有一百台主机就要100个公网IP,不常用。 

           3、PAT(Port Address Translation)端口地址转换:用一个或多个公网IP为多个私有地址提供转换,能够节省大量IP地址,这种方式在现实网络环境中最常用。

    Router(config)#ip nat inside source list 10 pool out  overload //只需要在动态NAT的基础上多出一个“overload”就可以让上面的21个公网地址反复使用。  

    如果我们只有一个公网地址且已经分配给了R1的S0/0口,可以使用下面的命令来对这仅有的一个公网地址反复利用或叫超载。   

    Router(config)#ip nat inside source list 10 interface serial 0 overload //就是在R1上不设置地址池,因为只有一个公网地址,而只对S0/0接口的地址超载。 

    注意:一条NAT转换条目要占用160字节内存,因此NAT的转换数目受路由器的内存限制。 

       4、配置端口映射:看配置就明白了

    还是上面的图和IP,看下面的配置   

    Router(config)#int fa0/0

    Router(config-if)#ip nat inside  //将该接口标记为内部接口  

    Router(config-if)#int s0  

    Router(config-if)#ip nat outside //将该接口标记为外部接口  

    Router(config-if)#exit  

    Router(config)#ip nat inside source static tcp 192.168.0.2 80 202.106.0.3 80 //将 192.168.0.2的80端口一对一的转换成 202.106.0.3的80端口,也就外网用户在浏览器里输入202.106.0.3时,会打开192.168.0.2上的WWW服务。这里公网地址也可以改成interface Serial1/0 80,如下: 

    Router(config)#ip nat inside source static tcp 192.168.0.3 21  interface Serial1/0 21 //如果只有一个公网地址还可以这样来转换。这样外网访问的不同服务就会定向到不同的内网服务器。   

        5、配置TCP负载平衡:还是上图IP也不变,假如PC1和PC2提供的是相同的WWW服务,为了实现负载平衡可以做如下配置:  

    Router(config)#ip nat pool www 192.168.0.2 192.168.0.3 netmask 255.255.255.0 type rotary //配置地址池www并设成旋转。

    Router(config)#access-list 10 permit 202.106.0.3

    Router(config)#ip nat inside destination list 10 pool www //这样当外网主机访问202.106.0.3的时候路由器会自动定向到192.168.0.2再有请求就定向到192.168.0.3如果地址池里还有别的地址会依次循环,实现负载平衡的目的。注意,地址有了,网络中还要有对应的主机存在,否则会使对方第一次连接失败。

    转载于:https://www.cnblogs.com/mac_arthur/archive/2011/05/26/2057835.html

    展开全文
  • Hello大家好,本篇博文讲述的是大学网络工程思科路由器NAT实验,供各大专院校学生与老师参考,如需转载,需注原创 有关NAT实验的代码 ip nat inside source static 192.168.1.2 222.0.1.3 int f0/0 ip nat inside ...

    Hello大家好,本篇博文讲述的是大学网络工程思科路由器之NAT实验,供各大专院校学生与老师参考,如需转载,需注原创

    有关NAT实验的代码

    ip nat inside source static 192.168.1.2 222.0.1.3
    int f0/0
    ip nat inside
    int Se0/2/0
    ip nat outside
    end
    

    第一步,我们需要选择和连接好实验所需的器材:
    在这里插入图片描述
    不同的用直通线
    相同的用交叉线

    第二步,在服务器和PC上按照实验要求的网段设置IP地址、子网掩码和默认网关:
    在这里插入图片描述
    在这里插入图片描述
    第三步,在路由器上设置静态路由,接口IP,时间钟等:
    路由器0
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    路由器1
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    第四步,在路由器0上配置NAT:
    在这里插入图片描述
    第五步,在模拟状态下验证实验是否成功:
    在这里插入图片描述
    抓包进行检验
    在这里插入图片描述
    至此,网络工程思科路由器NAT实验就结束了
    在这里,博主需要提出的一个题外话是:
    博主很容易犯的一个错误是,在设置路由器的F0/0接口IP的时候,没有设置成PC(服务器)的默认网关,所以在设置了静态路由之后一直都ping不通,所以我要在这里强调一下,加深自己的印象,如果在浏览的同学也有这个错误的话也可以增加印象。
    为什么要把接口IP设置成默认网关?
    通俗的说相同的时候才可以把数据包传出去。

    OK,本次的分享到这里就结束了
    觉得还不错的同学可以点个赞!感谢大家的浏览!

    展开全文
  • NAT是将IP数据报报头中的IP...本文为大家介绍一个思科路由器NAT配置实例,把内网地址转换成公网地址,并通过ACL控制,有选择地对内网地址段进行NAT转换,从而灵活控制可以上网的用户。 一、组网结构和需求 ...

           NAT是将IP数据报报头中的IP地址转换为另一个IP地址的过程,主要用于实现内部网络(私有IP地址)访问外部网络(公有IP地址)的功能。在实际应用中,内部网络一般使用私有地址。本文为大家介绍一个思科路由器的NAT配置实例,把内网地址转换成公网地址,并通过ACL控制,有选择地对内网地址段进行NAT转换,从而灵活控制可以上网的用户。

    一、组网结构和需求

           某工厂的网络拓扑图如下,内网主要分为三个网段:工厂车间(10.10.10.0/24)、工厂办公室(20.20.20.0/24)、研发中心(30.30.30.0/24)。三个网段接到同一台路由器上,此路由器通过专线连接到互联网,专线公网IP地址是:211.111.112.2。现要求在此路由器上配置NAT数据,允许工厂办公室和研发中心的内网地址转换成公网地址访问互联网;但工厂车间的地址段不允许上网,需禁止NAT转换。

     

     

     

     

     

     

     

    二、配置方法

    请查看原文链接:http://www.net1980.com/2010/11/29/cisco-nat/

    转载于:https://blog.51cto.com/daotianquan/646622

    展开全文
  • 192.168.55.2这一个ip给上网,cisco7206路由器,(E0/0外网,F1/1.1vlan34 F1/1.2vlan35 F1/1.3vlan36,F1/1与C2950F0/1相连)下面挂一个CISCO2950 想通过这一个ip把多网段主机都上网,vlan34 10.10.3.Xvlan35 ...

      192.168.55.2这一个ip给上网,cisco7206路由器,(E0/0外网,F1/1.1vlan34 F1/1.2vlan35 F1/1.3vlan36F1/1C2950F0/1相连)下面挂一个CISCO2950 想通过这一个ip把多网段主机都上网,vlan34 10.10.3.Xvlan35 10.10.4.Xvlan36 10.10.5.X(VLANC2950上做好了已经)


    (config)#int F1/1.1 /
    配置F1/1.1 子接口

    (config-if)# encapsulation dot1Q 34/封装属于VLAN34

    (config-if)#ip address 10.10.3.1 255.255.255.0
    (config-if)#ip nat inside /
    设置为内网
    (config-if)#no sh
    (config-if)#exit

    (config)#int F1/1.2 / 配置F1/1.2 子接口

    (config-if)# encapsulation dot1Q 35/封装属于VLAN35

    (config-if)#ip address 10.10.4.1 255.255.255.0
    (config-if)#ip nat inside /
    设置为内网
    (config-if)#no sh
    (config-if)#exit

    (config)#int F1/1.3 / 配置F1/1.3 子接口

    (config-if)# encapsulation dot1Q 36/封装属于VLAN36

    (config-if)#ip address 10.10.5.1 255.255.255.0
    (config-if)#ip nat inside /
    设置为内网
    (config-if)#no sh
    (config-if)#exit


    (config)#int E0/0

    (config-if)# ip address 192.168.55.2 255.255.255.128*外网端口,假设192.168.55.2为外部上网IP

    (config-if)#ip nat outside /设置为外网
    (config-if)#no sh
    (config-if)#exit



    (config)#ip nat pool zytvoa 192.168.55.2 192.168.55.2 netmask 255.255.255.128 /
    设置外部地址池始地址掩码
    (config)#access-list 1 permit 10.10.0.0 0.0.255.255 /
    配置内网口段范围
    (config)#ip nat inside source list 1 pool zytvoa overload/
    配置PAT
    (config)#ip route 0.0.0.0 0.0.0.0
    Ethernet0/0 192.168.55.1/配置默认路由下一跳(网关)

    C7206完成后配置

    interface Ethernet0/0*外网端口,假设192.168.55.2为外部上网IP

    ip address 192.168.55.2 255.255.255.128

    ip nat outside*

    ip virtual-reassembly

    duplex auto

    !

    interface GigabitEthernet0/0

    no ip address

    duplex full

    speed 1000

    media-type gbic

    negotiation auto

    !

    interface FastEthernet1/0

    ip address 10.10.1.1 255.255.255.0

    ip nat inside

    ip virtual-reassembly

    duplex half

    !

    interface FastEthernet1/1

    no ip address

    duplex half

    !

    interface FastEthernet1/1.1

    encapsulation dot1Q 34

    ip address 10.10.2.1 255.255.255.0

    ip nat inside

    ip virtual-reassembly

    !

    interface FastEthernet1/1.2

    encapsulation dot1Q 35

    ip address 10.10.3.1 255.255.255.0

    ip nat inside

    ip virtual-reassembly

    !

    interface FastEthernet1/1.3

    encapsulation dot1Q 36

    ip address 10.10.4.1 255.255.255.0

    ip nat inside

    ip virtual-reassembly

    !

    interface ATM2/0

    no ip address

    shutdown

    no atm ilmi-keepalive

    !

    ip route 0.0.0.0 0.0.0.0 Ethernet0/0 192.168.55.1

    !

    no ip http server

    no ip http secure-server

    !

    ip nat pool zytvoa 192.168.55.2 192.168.55.2 netmask 255.255.255.128

    ip nat inside source list 1 pool zytvoa overload

    !

    access-list 1 permit 10.10.0.0 0.0.255.255



    转载于:https://blog.51cto.com/1841cisco/1243543

    展开全文
  • NAT是一种把内部私有网络地址翻译成合法公网IP地址的技术。简单地说,假如局域网内部地址要与外部网络进行通讯时,NAT技术可以将内部地址替换成公网地址,从而在外部公网上正常使用。反过来,当外网需要访问局域网...
  • 我们都知道思科路由器NAT是用来转换ip地址的,但是很少有人知道Cisco路由器是采用哪种转换方式,只认为它可以采用非注册ip地址转换成注册的公网地址。这其实是很片面的,NAT不仅可以把一个或者多个内部网络IP地址...
  • NAT也就是我们常说的地址转换,这是每台路由器必备的功能,今天我们就以思科路由器,为大家介绍NAT的基础知识,方便大家在设置路由器时心中有数,NAT属接入广域网技术,是一种将私有地址转化为合法IP地址的转换技术...
  • 思科路由器--nat

    千次阅读 2017-12-04 14:09:49
    思科路由器上做nat技术
  • 思科路由器静态NAT配置

    千次阅读 2019-04-24 16:40:28
    R5(config)#ip nat inside source static 11.11.11.1 13.13.13.1 #进入接口E1/1 R5(config)#interface ethernet 1/1 #配置接口属性为NAT出接口 R5(config-if)#ip nat outside R5(config-if)#exit #进入接口E1/2 ...
  • 以上图中的三台路由器,在做NAT之前,只需要都能访问到100段的网段就可以了 R1上路由只配置:bash ip route 0.0.0.0 0.0.0.0 100.1.1.2 R2上路由只配置:bash ip route 200.1.1.0 255.255.255.0 150.1.1.2 R3上路由...
  • 思科路由器的双向NAT

    2016-03-12 12:16:54
    目的:通过双向NAT来更深的理解NAT思科IOS中的数据包处理顺序前提:在真实环境中不会出现环境:将R1和R3模拟成PC,在不加网关的情况下,使两者能够正常通信。定义R2的f0/0为ip nat inside;f1/0为ip nat outside。...
  • 如今通过参加各种培训学习网络技术的大有人在...场景需求:公司现有一条拨号光纤,一台思科路由器,下面的员工需要通过这台思科路由器来上网,并有一台电脑需要对外开放远程桌面功能。需求配置分析:用的拨号光纤,...
  • 配置文件:interface fastethernet0/1ip address192.168.0.1 255.255.0.0 //定义局域网端口IP地址duplex autospeed autoip nat inside //定义为局域端口!interface serial 1/0ip address 222.92.36.1 255.255.255.0 /...
  • ID · 无法用超过特定 MTU 长度进行 PING · 断掉的单播连通性,它可能是因为错误的 DLCI ,访问列表或转单播的 NAT ( 5)OSPF 陷入 LOADING —— 邻居没有应答或邻居的应答从未到达本地路由器路由器也会陷入 ...
  • 在CiscoIOS12.3(4)T后的IOS软件上支持NAT的单用户限制,即可以对做地址转换的单个IP限制其NAT的表项数,因为P2P类软件如BT的一大特点就是同时会有很多的连接数,从而占用了大量的NAT表项,因此应用该方法可有效...
  • 思科cisco路由器实现nat转换 要求: 使用三台路由器,在R2上配置1.0和2.0网段的静态路由,在R1和R3上不配置到R2的路由,通过NAT转换实现R2对R1和R3的访问。 在R1上的配置 R1#conf t R1(config)#...
  • 一.测试拓扑:二....---不幸的是思科不同的IOS,有的虽然有ip nat enable,但是实现不了同样的功能 ---在有的版本中接口下干脆就不能输入ip nat enable B.通过设置DNS域名为内网实际地址解决 ---这种...
  • 输入ip nat inside source static 192.168.0.8 202.94.64.68然后分别进入内外两个端口的端口配置模式输入ip nat {inside | outside}二, 修改telnet登录端口号以及无密码登录修改cisco路由器上的telnet默认端口号 ...
  • NAT和GRE tunnel在思科路由器上的实现

    千次阅读 2014-08-05 13:57:18
    Client --- Router(NAT) ===GRE tunnel=== Router --- Server Client: 90.1.0.8 NAT Router outside: 90.1.0.1 Server 1: 100.100.100.142 Server 2: 100.100.100.162 Server GW: 100.100....

空空如也

空空如也

1 2 3 4 5 ... 8
收藏数 149
精华内容 59
关键字:

思科路由器nat