精华内容
下载资源
问答
  • 网络Cisco实验-跨交换机相同VLAN通信

    千次阅读 2017-12-10 17:34:47
    2.在二层交换机switch0中创建vlan 10,并且将pc1添加进去,在三层交换机Multilayer switch0中也创建vlan 10,将pc0添加进去,两个vlan 10是同一个 3.三层交换机Multilayer switch0默认为auto,不用手动设置trunk ...

    1.设置如图所示网络拓扑


    2.在二层交换机switch0中创建vlan 10,并且将pc1添加进去

    Switch(config)#vlan 10
    Switch(config-vlan)#name vlan10
    Switch(config-vlan)#exit
    Switch(config)#int f0/1
    Switch(config-if)#switchport access vlan 10
    Switch(config-if)#exit
    


    3.在三层交换机Multilayer switch0中也创建vlan 10,将pc0添加进去,两个vlan 10是同一个

    Switch(config)#vlan 10
    Switch(config-vlan)#name vlan10
    Switch(config-vlan)#exit
    Switch(config)#int f0/1
    Switch(config-if)#switchport access vlan 10
    Switch(config-if)#exit
    


    3.三层交换机Multilayer switch0默认为auto,不用手动设置trunk


    4.将二层交换机的f0/3端口设置为trunk

    Switch(config)#int f0/3
    Switch(config-if)#switchport mode trunk
    Switch(config-if)#no shutdown
    Switch(config-if)#exit
    


    5.使用pc0主机ping pc1主机可以连通了

    展开全文
  • 二层交换实现相同vlan通信 LSW1配置命令: undo terminal monitor ----关闭终端显示提示信息 system-view ----进入系统视图模式 [Huawei]sysname SW1 ----更改设备名字为 SW1 [SW1]vlan batch 5 10 15 ----...

    二层交换实现相同vlan通信
    1.实验拓扑图:
    在这里插入图片描述
    2.实验步骤:
    1).LSW1配置步骤:
    undo terminal monitor ----关闭终端显示提示信息
    system-view ----进入系统视图模式
    [Huawei]sysname SW1 ----更改设备名字为 SW1
    [SW1]vlan batch 5 10 15 ----创建vlan 5 10 15
    [SW1]interface GigabitEthernet 0/0/1 ----进入0/0/1端口
    [SW1-GigabitEthernet0/0/1]port link-type access ----端口更改为access
    [SW1-GigabitEthernet0/0/1]port default vlan 5 ----端口加入vlan 5
    ……GE 0/0/2 GE 0/0/3进行相同配置
    [SW1]interface GigabitEthernet 0/0/4 ----进入0/0/4端口
    [SW1-GigabitEthernet0/0/4]port link-type trunk ----端口更改为trunk模式
    [SW1-GigabitEthernet0/0/4]port trunk allow-pass vlan all ----允许所有vlan通过
    配置完成查看验证:display vlan ----查看vlan信息
    display port vlan ----查看端口vlan信息

    2).LSW2配置步骤:
    undo terminal monitor ----关闭终端显示提示信息
    system-view ----进入系统视图模式
    [Huawei]sysname SW2 ----更改设备名字为 SW2
    [SW2]vlan batch 5 10 15 ----创建vlan 5 10 15
    [SW2]interface GigabitEthernet 0/0/1 ----进入0/0/1端口
    [SW2-GigabitEthernet0/0/1]port link-type access ----端口更改为access
    [SW2-GigabitEthernet0/0/1]port default vlan 5 ----端口加入vlan 5
    ……GE 0/0/2 GE 0/0/3进行相同配置
    [SW2]interface GigabitEthernet 0/0/4 ----进入0/0/4端口
    [SW2-GigabitEthernet0/0/4]port link-type trunk ----端口更改为trunk模式
    [SW2-GigabitEthernet0/0/4]port trunk allow-pass vlan all ----允许所有vlan通过
    配置完成查看验证:display vlan ----查看vlan信息
    display port vlan ----查看端口vlan信息

    pc机: 192.168.1.1 ping 192.168.1.2
    192.168.1.1 ping 192.168.1.2
    查看通信

    展开全文
  • 跨交换机相同VLAN通信
  • 华为实验跨交换机不同vlan通信 1.实验拓扑图: ...验证是否跨交换机相同vlan可以互访。 配置单臂路由。实现不同vlan可以互访。 配置子接口,充当vlan100、vlan200的网关。 交换机连接路由器的链路改为tru...
                             华为实验跨交换机不同vlan通信
    

    1.实验拓扑图:
    在这里插入图片描述
    实验操作:
    1.二层交换创vlan实现跨二层交换通信
    创建vlan

    接口加入相应valn
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    验证通信:
    在这里插入图片描述
    sw1、sw2开启trunk,并允许vlan通过。

    在这里插入图片描述
    创建vlan100、vlan200,并将接口加入对应的vlan。
    验证是否跨交换机相同vlan可以互访。
    在这里插入图片描述

    配置单臂路由。实现不同vlan可以互访。
    配置子接口,充当vlan100、vlan200的网关。
    在这里插入图片描述
    交换机连接路由器的链路改为trunk。


    验证:
    在这里插入图片描述
    配置三层交换实现网络互通。
    R1接口配置IP并激活。
    在这里插入图片描述
    配置默认路由,下一跳指向192.168.30.254/24
    在这里插入图片描述
    sw3创建vlan10、20、30,并将接口加入对应的vlan。
    给vlan配置IP,并激活,充当vlan10_pc1、vlan20_pc1的网关
    在这里插入图片描述
    为三层交换配置静态路由,目标指向192.168.30.1。
    在这里插入图片描述
    最后全网互通。

    展开全文
  • 跨交换机相同VLAN间通讯

    千次阅读 2018-04-10 21:43:32
    跨交换机相同VLAN间通讯一、 实验目的1、 了解IEEE802.1q的实现方法,掌握跨二层交换机相同VLAN间通信的调试方法;2、 了解交换机接口的trunk模式和access模式;3、 了解交换机的tagged端口和untagged端口的区别...

    跨交换机相同VLAN间通讯

    一、       实验目的

    1、  了解IEEE802.1q的实现方法,掌握跨二层交换机相同VLAN间通信的调试方法;

    2、  了解交换机接口的trunk模式和access模式;

    3、  了解交换机的tagged端口和untagged端口的区别。

    二、       应用环境

    教学楼有两层,分别是一年级、二年级,每个楼层都有一台交换机满足老师上网需求;每个年级都有语文教研组和数学教研组;两个年级的语文教研组的计算机可以互相访问;两个年级的数学教研组的计算机可以互相访问;语文教研组和数学教研组之间不可以自由访问;

    通过划分VLAN使得语文教研组和数学教研组之间不可以自由访问;使用802.1Q进行跨交换机的VLAN

    三、       实验设备

    1  DCS-3926S交换机2台

    2  PC机2台

    3  Console线1根

    4  直通网线2根

    四、       实验拓扑

     

    五、       实验要求

    在交换机A和交换机B上分别划分两个基于端口的VLAN:VLAN100,VLAN200。

    VLAN 

    端口成员 

    100

    1~8

    200

    9~16

    Trunk口

    24

    使得交换机之间VLAN100的成员能够互相访问,VLAN200的成员能够互相访问;VLAN100和VLAN200成员之间不能互相访问。

    PC1和PC2的网络设置为:

    设备

    IP地址

    Mask

    交换机A 

    192.168.1.11 

    255.255.255.0 

    交换机B

    192.168.1.12

    255.255.255.0

    PC1 

    192.168.1.101 

    255.255.255.0 

    PC2 

    192.168.1.102 

    255.255.255.0 

    PC1、PC2分别接在不同交换机VLAN100的成员端口1~8上,两台PC互相可以ping通;PC1、PC2分别接在不同交换机VLAN的成员端口9~16上,两台PC互相可以ping通;PC1和PC2接在不同VLAN的成员端口上则互相ping不通。

    若实验结果和理论相符,则本实验完成。

     

    六、       实验步骤

    第一步:交换机恢复出厂设置

    switch#set default

    switch#write 

    switch#reload 

    第二步:给交换机设置标示符和管理IP。

    交换机A:

    switch(Config)#hostname switchA

    switchA(Config)#interface vlan 1

    switchA(Config-If-Vlan1)#ip address 192.168.1.11 255.255.255.0

    switchA(Config-If-Vlan1)#no shutdown

    switchA(Config-If-Vlan1)#exit

    switchA(Config)#

     

    交换机B:

    switch(Config)#hostname switchB

    switchB(Config)#interface vlan 1

    switchB(Config-If-Vlan1)#ip address 192.168.1.12 255.255.255.0

    switchB(Config-If-Vlan1)#no shutdown

    switchB(Config-If-Vlan1)#exit

    switchB(Config)#

     

    第三步:在交换机中创建vlan100和vlan200,并添加端口。

    交换机A:

    switchA(Config)#vlan 100

    switchA(Config-Vlan100)#

    switchA(Config-Vlan100)#switchport interface ethernet 0/0/1-8

    switchA(Config-Vlan100)#exit

    switchA(Config)#vlan 200

    switchA(Config-Vlan200)#switchport interface ethernet 0/0/9-16

    switchA(Config-Vlan200)#exit

    switchA(Config)#

    验证配置:

    switchA#show vlan

    VLAN Name         Type       Media     Ports

    ---- ------------ ---------- --------- ----------------------------------------

    1    default      Static     ENET      Ethernet0/0/17      Ethernet0/0/18

                                           Ethernet0/0/19      Ethernet0/0/20

                                           Ethernet0/0/21      Ethernet0/0/22

                                           Ethernet0/0/23      Ethernet0/0/24

    100  VLAN0100     Static     ENET      Ethernet0/0/1       Ethernet0/0/2

                                           Ethernet0/0/3       Ethernet0/0/4

                                           Ethernet0/0/5       Ethernet0/0/6

                                           Ethernet0/0/7       Ethernet0/0/8

    200  VLAN0200     Static     ENET      Ethernet0/0/9       Ethernet0/0/10

                                           Ethernet0/0/11      Ethernet0/0/12

                                           Ethernet0/0/13      Ethernet0/0/14

                                           Ethernet0/0/15      Ethernet0/0/16

    switchA#

     

    交换机B:

    配置与交换机A一样。

     

    第四步:设置交换机trunk端口

    交换机A:

    switchA(Config)#interface ethernet 0/0/24

    switchA(Config-Ethernet0/0/24)#switchport mode trunk

    Set the port Ethernet0/0/24 mode TRUNK successfully

    switchA(Config-Ethernet0/0/24)#switchport trunk allowed vlan all

    set the port Ethernet0/0/24 allowed vlan successfully

    switchA(Config-Ethernet0/0/24)#exit

    switchA(Config)#

    验证配置:

    switchA#show vlan

    VLAN Name         Type       Media     Ports

    ---- ------------ ---------- --------- ----------------------------------------

    1    default      Static     ENET      Ethernet0/0/17      Ethernet0/0/18

                                           Ethernet0/0/19      Ethernet0/0/20

                                           Ethernet0/0/21      Ethernet0/0/22

                                           Ethernet0/0/23    

    Ethernet0/0/24(T)

    100  VLAN0100     Static     ENET      Ethernet0/0/1       Ethernet0/0/2

                                           Ethernet0/0/3       Ethernet0/0/4

                                           Ethernet0/0/5       Ethernet0/0/6

                                           Ethernet0/0/7       Ethernet0/0/8

                                           Ethernet0/0/24(T)

    200  VLAN0200     Static     ENET      Ethernet0/0/9       Ethernet0/0/10

                                           Ethernet0/0/11      Ethernet0/0/12

                                           Ethernet0/0/13      Ethernet0/0/14

                                           Ethernet0/0/15      Ethernet0/0/16

                                           Ethernet0/0/24(T)

    switchA#

    24口已经出现在vlan1、vlan100和vlan200中,并且24口不是一个普通端口,是tagged端口。

     

    交换机B:

    配置同交换机A

     

    第五步:验证实验。

    交换机Aping交换机B:

    switchA#ping 192.168.1.12

    Type ^c to abort.

    Sending 5 56-byte ICMP Echos to 192.168.1.12, timeout is 2 seconds.

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

    switchA#

     

    表明交换机之前的trunk链路已经成功建立。

        按下表验证,PC1插在交换机A上,PC2插在交换机B上:

    PC1位置

    PC2位置

    动作

    结果

    1-8端口

     

    PC1 ping 交换机B

    不通

    9-16端口

     

    PC1 ping交换机B

    不通

    17-24端口

     

    PC1 ping交换机B

    1-8端口

    1-8端口

    PC1 ping PC2

    1-8端口

    9-16端口

    PC1 ping PC2

    不通

     

    七、       注意事项和排错

    1、  取消一个vlan可以使用“no vlan”。

    2、  取消vlan的某个端口可以在vlan模式下使用“no switchport interface ethernet 0/0/x”。

    3、  当使用“switchport trunk allowed vlan all”命令后,所有以后创建的vlan,中都会自动添加trunk口为成员端口;

    八、       配置序列

    switchA#show run               

    Current configuration:                     

    !

       hostname switchA                  

    !

    Vlan 1     

       vlan 1        

    !

    Vlan 100       

       vlan 100          

    !

    Vlan 200       

       vlan 200          

    !

    !

    Interface Ethernet0/0/1                      

       switchport access vlan 100                            

    !

    Interface Ethernet0/0/2                      

       switchport access vlan 100                            

    !

    Interface Ethernet0/0/3                      

       switchport access vlan 100                            

    !

    Interface Ethernet0/0/4                       

       switchport access vlan 100                            

    !

    Interface Ethernet0/0/5                      

       switchport access vlan 100                            

    !

    Interface Ethernet0/0/6                      

       switchport access vlan 100                            

    !

    Interface Ethernet0/0/7                      

       switchport access vlan 100                            

    !

    Interface Ethernet0/0/8                      

       switchport access vlan 100                            

    !

    Interface Ethernet0/0/9                      

       switchport access vlan 200                            

    !

    Interface Ethernet0/0/10                       

       switchport access vlan 200                            

    !

    Interface Ethernet0/0/11                        

       switchport access vlan 200                            

    !

    Interface Ethernet0/0/12                       

       switchport access vlan 200                            

    !

    Interface Ethernet0/0/13                       

       switchport access vlan 200                            

    !

    Interface Ethernet0/0/14                       

       switchport access vlan 200                            

    !

    Interface Ethernet0/0/15                       

       switchport access vlan 200                             

    !

    Interface Ethernet0/0/16                       

       switchport access vlan 200                            

    !

    Interface Ethernet0/0/17            

    !

    Interface Ethernet0/0/18

    !

    Interface Ethernet0/0/19

    !

    Interface Ethernet0/0/20

    !

    Interface Ethernet0/0/21

    !

    Interface Ethernet0/0/22

    !

    Interface Ethernet0/0/23

    !

    Interface Ethernet0/0/24

       switchport mode trunk

    !

    interface Vlan1

       interface vlan 1

       ip address 192.168.1.11 255.255.255.0

    !

    switchA#

    九、       共同思考

    Trunk、access、tagged、untagged这几个专业术语的关联与区别是什么?

    十、       课后练习

    请给交换机A和B分别划分三个vlan,验证vlan实验

    VLAN 

    端口成员 

    10

    5~8

    20

    9~12

    30

    13~16

    Trunk

    1~4

     

    十一、   相关配置命令详解

    switchport access vlan

    命令:switchport access vlan <vlan-id>

    no switchport access vlan

    功能:将当前Access端口加入到指定VLAN;本命令no操作为将当前端口从VLAN里删除。

    参数:<vlan-id>为当前端口要加入的vlan VID,取值范围为1~4094。

    命令模式:端口配置模式

    缺省情况:所有端口默认属于VLAN1。

    使用指南:只有属于Access mode的端口才能加入到指定的VLAN中,并且Access端口同时只能加入到一个VLAN里去。

    举例:设置某Access端口加入VLAN100。

    Switch(Config)#interface ethernet 0/0/8

    Switch(Config-ethernet0/0/8)#switchport mode access

    Switch(Config-ethernet0/0/8)#switchport access vlan 100

    Switch(Config-ethernet0/0/8)#exit

    switchport mode

    命令:switchport mode {trunk|access}

    功能:设置交换机的端口为access模式或者trunk模式。

    参数:trunk表示端口允许通过多个VLAN的流量;access为端口只能属于一个VLAN。

    命令模式:端口配置模式

    缺省情况:端口缺省为Access模式。

    使用指南:工作在trunk mode下的端口称为Trunk端口,Trunk端口可以通过多个VLAN的流量,通过Trunk端口之间的互联,可以实现不同交换机上的相同VLAN的互通;工作在access mode下的端口称为Access端口,Access端口可以分配给一个VLAN,并且同时只能分配给一个VLAN。

    注意在Trunk端口不允许802.1X认证。

    举例:将端口5设置为trunk模式,端口8设置为access模式。

    Switch(Config)#interface ethernet 0/0/5

    Switch(Config-ethernet0/0/5)#switchport mode trunk

    Switch(Config-ethernet0/0/5)#exit

    Switch(Config)#interface ethernet 0/0/8

    Switch(Config-ethernet0/0/8)#switchport mode access

    Switch(Config-ethernet0/0/8)#exit

    switchport trunk allowed vlan

    命令:switchport trunk allowed vlan {<vlan-list>|all}

    no switchport trunk allowed vlan

    功能:设置Trunk端口允许通过VLAN;本命令的no操作为恢复缺省情况。

    参数:<vlan-list>为允许在该Trunk端口上通过的VLAN列表;all 关键字表示允许该Trunk端口通过所有VLAN的流量。

    命令模式:端口配置模式

    缺省情况:Trunk端口缺省允许通过所有VLAN。

    使用指南:用户可以通过本命令设置哪些VLAN的流量通过Trunk端口,没有包含的VLAN流量则被禁止。

    举例:设置Trunk端口允许通过VLAN1,3,5-20的流量。

    Switch(Config)#interface ethernet 0/0/5

    Switch(Config-ethernet0/0/5)#switchport mode trunk

    Switch(Config-ethernet0/0/5)#switchport trunk allowed vlan 1;3;5-20

    Switch(Config-ethernet0/0/5)#exit

    switchport trunk native vlan

    命令:switchport trunk native vlan <vlan-id>

    no switchport trunk native vlan

    功能:设置Trunk端口的PVID;本命令的no操作为恢复缺省值。

    参数:<vlan-id>为Trunk端口的PVID。

    命令模式:端口配置模式

    缺省情况:Trunk端口默认的PVID为1。

    使用指南:在802.1Q中定义了PVID这个概念。Trunk端口的PVID的作用是当一个untagged的帧进入Trunk端口,端口会对这个untagged帧打上带有本命令设置的native PVID的tag标记,用于VLAN的转发。

    举例:设置某Trunk端口的native vlan为100。

    Switch(Config)#interface ethernet 0/0/5

    Switch(Config-ethernet0/0/5)#switchport mode trunk

    Switch(Config-ethernet0/0/5)#switchport trunk native vlan 100

    Switch(Config-ethernet0/0/5)#exit

     

    展开全文
  • 跨交换机实现VLAN通信

    2016-09-19 19:54:52
    实验目的: 掌握如何在交换机上划分基于端口的VLAN、给VLAN内添加端口,理解跨交换机之间VLAN的特点。实验内容: 1、画出实验拓扑图; 2、配置主机IP,测试各主机之间是否ping通; 3、配置交换机,划分VLAN,测试各...
  • 跨交换机实现vlan通信

    2016-12-28 16:57:58
    在这个实验中,创建VLAN 10和VLAN 20,将Host A、...在没有创建VLAN之前,PC之间可以相互ping通,创建VLAN后,相同VLAN可以相互ping通。两台交换机使用F0/5口连接。各主机PC的配置如下:Host A:192.168.0.1 子网掩...
  • 实验十五、跨交换机相同VLAN 间通讯 一、 实验目的 1、了解 IEEE802.1q 的实现方法,掌握跨二层交换机相同 VLAN 间通信的调试方法; 2、 了解交换机接口的 trunk 模式和access 模式; 3、 了解交换机的 tagged 端口...
  • 跨交换机相同VLAN间通讯 一、 实验目的 1、 了解IEEE802.1q的实现方法,掌握跨二层交换机相同VLAN间通信的调试方法; 2、 了解交换机接口的trunk模式和access模式; 3、 了解交换机的tagged端口和untagged端口的...
  • 神州数码设备调试之跨交换机相同VLAN互访 实验目的 掌握神州数码二层交换机相同vlan间通信及配置方法 掌握交换机接口的trunk模式和access模式 实验拓扑 实验设备 DCS二层交换机两台 实验...
  • 一 组网需求: 1.SwitchA与SwitchB用trunk互连,相同VLAN的PC之间可以互访,不同VLAN的PC之间禁止互访; 2.PC1与PC2之间在不同VLAN,通过设置上层三层交换机SwitchB的VLAN接口1...
  •  switchport access vlan 2  switchport mode access ! interface FastEthernet0/2 ! interface FastEthernet0/3 ! interface FastEthernet0/4 ! interface FastEthernet0/5 ! interface ...
  • 一、静态vlan
  • 跨交换机实现相同VLAN间的通信

    千次阅读 2012-08-21 09:37:23
    实验名称:跨交换机实现相同VLAN间的通信(Tag VLAN)。 实验目的:掌握交换机Tag VLAN的配置,理解相同VLAN主机通信,不同VLAN主机隔离的特点。 技术原理: 1.Tag VLAN特点 ? 传输多个VLAN的信息 ? 实现...
  • 我们使用Trunk实现跨交换机VLAN通信。还有以太网通道的操作哦。 实验拓扑 两台交换机直连,每台下面再连接两台VPC,划分VLAN,地址规划如下: 名称 接口 VLAN 地址 PC1 SW1-f1/0 vlan 10 192.168.10.10/24 ...
  • 跨交换机划分vlan

    2018-06-13 11:48:00
    如图所示,四台交换机的IP地址网段相同,划分vlan后,只有相同vlan的主机才能通信 因为是跨交换机的vlan划分,所以两台交换机都要配置相同的vlan switch 1 配置内容 Switch>en Switch# Switch#conf t ...
  • 跨交换机VLAN通信示例

    2020-07-16 20:43:22
    现在我们要完成交换机SW1及SW2的配置,使得相同VLAN内的PC能够实现通信。 由于交换机SW1的GEO/0/1, GEO/0/2以及交换机SW2的GEO/O/1, GEO/0/2都连接着 PC,因此需将这些接口配置为Access类型,并加入相应的VLANo SW1...
  • 相同VLAN跨交换机通信

    2020-12-15 22:10:16
    一.实验目的 1.理解虚拟LAN(VLAN)基本原理。 2.掌握一般交换机按端口划分VLAN的配置...相同VLAN的主机可以进行通信,不同VLAN的主机之间互相访问必须经过路由设备进行转发。 四、实验步骤 新建packet tracer拓扑图
  • 新建一个括扑环境如下: 交换机1配置如下; <Huawei>...[1]vlan batch 5 10//建立vlan5,vlan10 [1]interface GigabitEthernet 0/0/1//进入接口视图 [1-GigabitEthernet0/0/1]port link-type ...
  • 我们以上面的拓扑图来进行实验 四台pc机都在同一网段 pc1和pc2在同一台交换机上 ...并让他们相同vlan能够跨交换机进行通信 在switch1上配置vlan enable 进入特权模式 configure terminal 进入全局配置模...
  • 拓扑图如下 如上图所述 主机0和主机1在同一个路由器上 主机2和主机3在同一个路由器上 ...而且他们在同一网段上他们是...并且让相同vlan可以通信 不同vlan不能通信交换机0上配置vlan enable 进入特权模式...

空空如也

空空如也

1 2 3 4 5
收藏数 81
精华内容 32
关键字:

跨交换机相同vlan通信