精华内容
下载资源
问答
  • eNSP:hybrid接口配置实例

    千次阅读 2020-12-02 18:56:00
    整个结构的所有接口,我们都使用hybrid接口类型 配置 交换机sw1 [Huawei]vlan batch 10 20 30 // 因为PC1可以访问vlan10和vlan30当中的主机,所以E0/0/3接口在接收到带有vlan10和vlan30标签的数据时,剥掉标签发送...

    总体结构图:

    在这里插入图片描述
    目标:vlan10和vlan20中的主机不能通信,vlan10和vlan30中的主机能够通信,vlan20和vlan30中的主机能够通信。

    整个结构的所有接口,我们都使用hybrid接口类型

    配置

    交换机sw1

    [Huawei]vlan batch 10 20 30
    
    // 因为PC1可以访问vlan10和vlan30当中的主机,所以E0/0/3接口在接收到带有vlan10和vlan30标签的数据时,剥掉标签发送给PC1
    [Huawei]interface Eth0/0/3
    [Huawei-Ethernet0/0/3]port hybrid pvid vlan 10
    [Huawei-Ethernet0/0/3]port hybrid untagged vlan 10 30
    [Huawei-Ethernet0/0/3]quit 
    
    // 因为带有vlan10,vlan20和vlan30标签的数据都要经过此接口,所以设置带有vlan10,vlan20和vlan30标签的数据通过G0/0/1接口发送时带原标签发送
    [Huawei]interface GigabitEthernet 0/0/1
    [Huawei-GigabitEthernet0/0/1]port hybrid tagged vlan 10 20 30
    [Huawei-GigabitEthernet0/0/1]quit 
    
    // PC6可以访问各个vlan中的主机,所以E0/0/2接口在接收到带有vlan10,vlan20标签的数据时,会剥掉标签发送给PC6(既然只有一个vlan30的主机,那为什么还要设置接收到vlan30的数据时要剥掉标签发送给PC6呢,这个问题我会在最后提出来)
    [Huawei]interface Eth0/0/2
    [Huawei-Ethernet0/0/2]port hybrid pvid vlan 30
    [Huawei-Ethernet0/0/2]port hybrid untagged vlan 10 20 30
    [Huawei-Ethernet0/0/2]quit 
    
    [Huawei]interface Eth0/0/4
    [Huawei-Ethernet0/0/4]port hybrid pvid vlan 10
    [Huawei-Ethernet0/0/4]port hybrid untagged vlan 10 30
    [Huawei-Ethernet0/0/4]quit
    
    [Huawei]interface Eth0/0/5
    [Huawei-Ethernet0/0/5]port hybrid pvid vlan 20
    [Huawei-Ethernet0/0/5]port hybrid untagged vlan 20 30
    

    交换机sw2

    [Huawei]vlan batch 10 20 30
    
    [Huawei]interface GigabitEthernet 0/0/2
    [Huawei-GigabitEthernet0/0/2]port hybrid tagged vlan 10 20 30
    [Huawei-GigabitEthernet0/0/2]quit 
    
    [Huawei]interface Eth0/0/2
    [Huawei-Ethernet0/0/2]port hybrid pvid vlan 10
    [Huawei-Ethernet0/0/2]port hybrid untagged vlan 10 30
    [Huawei-Ethernet0/0/2]quit
    
    [Huawei]interface Eth0/0/3
    [Huawei-Ethernet0/0/3]port hybrid pvid vlan 20
    [Huawei-Ethernet0/0/3]port hybrid untagged vlan 20 30
    

    测试结果

    PC1访问PC3
    在这里插入图片描述
    PC1访问PC4
    在这里插入图片描述
    PC1访问PC6
    在这里插入图片描述
    PC3访问PC4
    在这里插入图片描述
    PC3访问PC5
    在这里插入图片描述
    PC3访问PC6
    在这里插入图片描述

    在这里插入图片描述
    还有一个小问题,那就是为什么要在交换机SW1连接PC6的E0/0/2接口上设置port hybrid untagged vlan 30呢?既然只有一个在vlan30中的主机,那为什么还要设置E0/0/2接口在接收到vlan30的数据时,要剥掉标签发送给PC6呢?

    我把交换机SW1连接PC6的E0/0/2接口设置为port hybrid tagged vlan 30,这时我再去使用PC6访问不同vlan中的主机一样可以成功访问。

    我在交换机SW1连接PC6的E0/0/2接口上不执行port hybrid tagged vlan 30port hybrid untagged vlan 30这两条命令,此时我再用PC6访问不同vlan中的主机却无法访问。

    交换机SW1的E0/0/2接口作为发送数据的接口时没有发送带vlan30标签的数据给PC6,但是交换机SW1的E0/0/2接口作为接收数据的接口时会接收带vlan30标签的数据,使用port hybrid tagged vlan 30port hybrid untagged vlan 30这两条命令中任意一条就可以完成通信,两者都不使用就无法完成通信,那这样看来,port hybrid tagged vlanport hybrid untagged vlan这两条命令,影响的可能不只是接口发送数据,对接口接收数据也会有影响。

    个人理解,若有不足或错误之处还请指出,如果您有什么想法或见解也可以写在评论区,我们一起学习。

    展开全文
  • 要求:PC1/PC2/PC3 分别连接交换机的 GE0/0/1、GE0/0/2、GE0/0/3 接口,三个接口均为hybrid 链路类型。设置 GE0/0/1 接口 pvid vlan 10、untagged vlan 10 30 等,参考网络拓扑 图 思路: access 接口收报文:判断...

    在这里插入图片描述
    要求:PC1/PC2/PC3 分别连接交换机的 GE0/0/1、GE0/0/2、GE0/0/3 接口,三个接口均为hybrid 链路类型。设置 GE0/0/1 接口 pvid vlan 10、untagged vlan 10 30 等,参考网络拓扑

    思路
    access 接口收报文:判断报文是否有 VLAN 信息,若没有则打上端口 PVID,并进行交换转发;若有则直接丢弃。
    access 接口发报文:将报文的 VLAN 信息剥离后,直接发送出去。
    trunk 接口收报文:判断报文是否有 VLAN 信息,若有则判断该 trunk 口是否允许该 vlan 的数据进入,允许则转发,否则丢弃;若没有 VLAN 信息,则打上端口的 PVID,并进行交换转发。
    trunk 接口发报文:比较将要发送报文的 VLAN 信息和端口的 PVID,若不相等,则直接发送;若相等,则剥离 VLAN 信息后发出。
    hybrid 接口收报文:判断报文是否有 VLAN 信息,若有则判断该 hybrid 口是否允许该 vlan的数据进入(在tagged和untagged列表中的都算允许通过,类似trunk口的allow-pass vlan),允许则转发,否则丢弃(此时不用考虑untagged 配置)。若没有 VLAN 信息,则打上端口的 PVID,并进行交换转发。
    hybrid 接口发报文:1)、判断该 VLAN 在本端口的属性(display interface 即可看到该端口对哪些 vlan 是 untagged 或者 tagged),2)、若是 untagged 则剥离 VLAN 信息后发送;若是tagged 则直接发送。

    配置命令

    vlan batch 10 20 30 //创建 vlan 10、vlan20、vlan30
    port link-type hybrid //配置接口类型为 hybrid
    port hybrid pvid vlan 10 //配置接口的 pvid
    port hybrid untagged vlan 10 30 //配置接口的 untagged vlan
    port hybrid tagged vlan 10 30 //配置接口的 tagged vlan
    
    <LSW1>sys
    [LSW1]vlan batch 10 20 30
    [LSW1]interface GigabitEthernet 0/0/1
    [LSW1-GigabitEthernet0/0/1] port link-type hybrid
    [LSW1-GigabitEthernet0/0/1]port link-type hybrid
    [LSW1-GigabitEthernet0/0/1]port hybrid pvid vlan 10
    [LSW1-GigabitEthernet0/0/1]port hybrid untagged vlan 10 30
    [LSW1-GigabitEthernet0/0/1]int g0/0/2
    [LSW1-GigabitEthernet0/0/2]port hybrid pvid vlan 20
    [LSW1-GigabitEthernet0/0/2]port hybrid untagged vlan 20 30
    [LSW1-GigabitEthernet0/0/2]int g0/0/3
    [LSW1-GigabitEthernet0/0/3]port hybrid pvid vlan 30
    [LSW1-GigabitEthernet0/0/3]port hybrid untagged vlan 10 20 30
    [LSW1-GigabitEthernet0/0/3]return
    <LSW1>save
    
    展开全文
  • 华为2层交换Hybrid接口配置-附件资源
  • 华为网络实验–access、trunk、hybrid接口配置实验 前言 Hybrid接口是华为设备特殊的二层接口模式, 可以类似于vlan和trunk接口, 可以对数据帧不打vlan标签和不打标签。 ●实验目的 通过配置交换机SW1和SW2不同接口...

    华为网络实验–access、trunk、hybrid接口配置实验

    前言

    Hybrid接口是华为设备特殊的二层接口模式,
    可以类似于vlan和trunk接口,
    可以对数据帧不打vlan标签和不打标签。

    ●实验目的

    通过配置交换机SW1和SW2不同接口的access、trunk、hybrid属性,实现PC1能和PC2互通,PC2能和PC4互通,PC3能和PC4互通。

    ●需求分析

    1.新建如下图所示拓扑图;
    在这里插入图片描述
    2.SW1中创建vlan、配置access、trunk和hybrid接口;
    3.SW2中创建vlan、配置trunk和hybrid接口;
    4.路由器R1和R2配置接口网关和直连路由的IP地址,静态路由。

    ●实验步骤

    1.交换机SW1命令

    vlan batch 10 20                     ##创建vlan10 20
    
    interface Ethernet0/0/1
     port link-type access
     port default vlan 10                ##将e0/0/1接口划分到vlan10
    
    interface Ethernet0/0/2
     port link-type access
     port default vlan 20                ##将e0/0/2接口划分到vlan20
    
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 20
                                         ##将g0/0/1接口设为trunk口
    
    interface GigabitEthernet0/0/2
     port hybrid pvid vlan 10            ##进g0/0/2接口贴上vlan10
     port hybrid untagged vlan 10 20     ##出g0/0/2接口脱去vlan10或vlan20
    

    2.交换机SW2命令

    vlan batch 10 20                       ##创建vlan10 20
    
    interface Ethernet0/0/1
     port hybrid pvid vlan 10              ##进e0/0/1接口贴上vlan10标签
     port hybrid untagged vlan 10 20
                                           ##出e0/0/1接口脱去vlan10或vlan20标签
    
    interface Ethernet0/0/2
     port hybrid pvid vlan 20              ##进e0/0/2接口贴上vlan20标签
     port hybrid untagged vlan 10 20
                                           ##出e0/0/2接口脱去vlan10或vlan20标签
    
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 20
                                            ##将g0/0/1接口设为trunk口
    
    interface GigabitEthernet0/0/2
     port hybrid pvid vlan 20               ##进g0/0/2接口贴上vlan20标签
     port hybrid untagged vlan 10 20        ##出g0/0/2接口脱去vlan10或vlan20标签
    

    3.路由器R1命令

    interface GigabitEthernet0/0/0
     ip address 192.168.10.1 255.255.255.0 
                                             ##配置网关IP地址
    
    interface GigabitEthernet0/0/1
     ip address 11.0.0.1 255.255.255.252
                                             ##配置直连路由IP地址
    
    ip route-static 192.168.20.0 255.255.255.0 11.0.0.2
                                             ##配置数据转发192.168.20.0/24网段的静态路由
    

    4.路由器R2命令

    interface GigabitEthernet0/0/0
     ip address 192.168.20.1 255.255.255.0 
                                              ##配置网关IP地址
    
    interface GigabitEthernet0/0/1
     ip address 11.0.0.2 255.255.255.252
                                              ##配置直连路由IP地址
    
    ip route-static 192.168.10.0 255.255.255.0 11.0.0.1
                                              ##配置数据转发192.168.10.0/24网段的静态路由
    

    5.实验结果验证

    PC1能够ping通PC2,PC3能够ping通PC4,PC2能够ping通PC4,实验成功。
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    ●实验总结

    配置hybrid口时,牢记心法口诀。
    出口检查:查untag表 有标 脱 无标 查tag 有 放通 无丢掉
    进口检查:查有无标签 有标 查tag表 有放通 无标 丢弃
    无标 打PVID后 放通
    PC1pingPC2数据传输过程:

    1. 数据从PC1到SW1的e0/0/1口进入交换机,贴上vlan10标签,源IP192.168.10.10,目标IP192.168.20.10 源MAC是PC1的,不知道目标MAC地址,进行ARP广播。
    2. 数据从SW1的g0/0/2接口出去,查untag表,有vlan10标签,脱去vlan10标签。
    3. 到达R1后,查看路由表,重新封装数据帧从g0/0/1接口转发出去。
    4. 到达R2后,查看路由表,重新封装数据帧从g0/0/0接口转发到SW2的g0/0/2接口,查看没有标签,打上pvid 20标签。
    5. 数据从交换机SW2的g0/0/1接口转发到SW1的g0/0/1接口,此过程一直贴有vlan20标签,
    6. 数据从SW1的e0/0/2接口出去时,脱去vlan20的标签,最终到达PC2。PC2单播回应PC1自己的MAC地址,两台主机就能通信了。

    PC3pingPC4数据传输过程:
    源IP192.168.10.11,目标IP192.168.10.12;源MAC
    为PC3的,因为没有PC4的MAC地址,所以要进行ARP广播获取到PC4的MAC地址,
    此过程中数据从PC3进入SW2的e0/0/1接口时,没有标签,打上pvid vlan10的标签,从e0/0/2接口出去的时候查看untag表,有vlan10标签,脱去vlan10标签后数据到达PC4。
    PC2pingPC4数据传输过程:

    1. 数据从PC2到SW1的e0/0/2口进入交换机,贴上vlan20标签,源IP192.168.20.10,目标IP192.168.10.12, 源MAC是PC2的,不知道目标MAC地址,进行ARP广播。
    2. 数据从交换机SW1的g0/0/1接口转发到SW2的g0/0/1接口,此过程一直贴有vlan20标签。
    3. 从SW2的g0/0/2出接口时查untag表,有vlan20标签,脱去vlan20后到达R2的g0/0/0接口。
    4. R2查看路由表,重新封装数据帧从g0/0/1接口转发到R1的g0/0/1接口。
    5. R1查看路由表,重新封装数据帧从g0/0/0接口转发出去。
    6. 数据进入SW1的g0/0/2接口时没有标签,打上pvid vlan10的标签。
    7. 数据从交换机SW1的g0/0/1接口转发到SW2的g0/0/1接口,此过程一直贴有vlan10标签。
    8. 数据从SW2的g0/0/2接口转发出去时,查看untag表,有vlan10标签,脱去vlan10标签后到达PC4。PC4收到PC2的数据包后,单播回应自己的MAC地址,PC2和PC4就能互通了。
    展开全文
  • 交换机Hybrid端口配置

    2019-04-24 10:22:00
    交换机Hybrid端口配置,通过Hybrid配置实现不同PC机之间访问及隔离。
  • Hybrid接口简单配置 拓扑图如下 要图的链接:https://pan.baidu.com/s/1iPaep2BSjxZn_D-eUxANew 提取码:7b88 首先把服务器及主机的ip配置上,这里就不写了 进入s1 s2创建相应vlan 命令如下 vlan batch 2 3 10 ...

    Hybrid接口简单配置

    拓扑图如下
    在这里插入图片描述
    要图的链接:https://pan.baidu.com/s/1iPaep2BSjxZn_D-eUxANew
    提取码:7b88

    1. 首先把服务器及主机的ip配置上,这里就不写了

    2. 进入s1 s2创建相应vlan
      命令如下
      vlan batch 2 3 10
      3.进入s1
      配置接口pid及untaggend列表
      基本命令如下所示
      进如接口
      port link-type hybrid 接口变hybrid口
      port hybrid pvid vlan 1 配置pid就是这个接口属于哪个vlan(图上有标这,照着打)
      port hybrid untagged vlan 1 2 配置un列表
      图如下
      在这里插入图片描述
      先把我s1图中接口 g 0/0/1 g0/0/2 g0/0/3按我最上面的拓扑图接口对应的打上
      原理后面会详细说
      在这里插入图片描述
      在这里插入图片描述
      g0/0/4
      就加了一条
      port hybrid tagged vlan 3 10
      在这里插入图片描述
      S1已完成
      S2配置命令都一样,跟着我图上接口标的打即可,这里就不给图片了
      3.验证
      生产部可以和销售部互访,而且只能访问服务器1
      在这里插入图片描述
      在这里插入图片描述
      财务部不能和任何部门通信,只能访问服务器2
      在这里插入图片描述
      在这里插入图片描述
      4.原理讲解(重要)
      (1)就生产部主机和服务器1通信来说
      在这里插入图片描述
      发出原始数据帧,g 0/0/1接过,打上vlan1的标签,g 0/0/1接口就un列表就要写入
      un列表的意思是数据过来后,在这个表中就把数据去掉vlan标识,并通过,如果un列表没有,就检查tag列表,如果在tag列表中的数据就不去点vlan标识通过。如果un列表和tag列表都没有就不让通过
      这里因为生产部和销售部通信所以,经过都口都要允许相应的vlan,而还要和服务器1通信,数据回来的时候,所以要un列表要写上vlan10
      而其他接口没有相应的un列表所以不能通信
      (2)如果这样的话,要tag列表有什么用,直接用un列表就够,其实不是
      就 财务部只能和服务器2通信来说
      如果 全都设置成un列表的话,就要把两个交换机之间去掉tag列表
      在un列表中加入vlan3 和vlan10
      但是这样的话,当其他部门的数据过来找服务器2是,因为在所以vlan都在un列表中,所以,任何数据进来都会变成原始数据帧。
      而每个接口必须把自己接口的vlan加入自己的un列表中
      那当一个原始数据帧过来后就会打上进的接口的vlan,那就不能实现限制了
      所以在两个交互机接口直接设置tag列表保留vlan标签

    展开全文
  • Hybrid接口配置-1

    2021-09-02 11:18:32
  • 华为Hybrid接口详解(原理+配置

    千次阅读 多人点赞 2020-06-01 16:41:39
    文章目录前言一、Hybrid接口1.1特点1.2工作原理1.3Hybrid接口收发过程1.4Hybrid收发过程流程图二、Hybrid接口配置实验1.1实验拓扑图1.2实验要求1.3实验配置1.4实验测试 前言 Hybrid接口是华为设备的特殊的二层接口...
  • 3.3 Hybrid接口配置

    2021-11-03 16:08:53
  • 华为交换机Hybrid接口及基础配置

    万次阅读 2019-08-08 21:32:55
    三种类型的接口可以共同存在一台交换机上,但Trunk接口不能直接切换为Hybrid接口,只能先设为Access接口,再设置为Hybrid接口。例如,trunk接口不能直接被设置为hybrid接口,只能先设为access接口,再设置为hybrid...
  • Hybrid接口的应用及配置

    千次阅读 2019-03-27 20:23:22
    Hybrid接口既可以连接普通终端的接入链路也可以了解交换机之间的干道链路,它允许对个VLAN的帧通过,同时可以在出接口方向将某些VLAN帧的标签剥掉。 Hybrid接口处理VLAN帧的过程: (1)收到一个二层帧,判断是否...
  •   Hello,今天学习一下交换机配置hybrid接口,分享给大家,如有不正确的还请指教!   Hybrid接口:它可以连接普通终端的接入链路和连接交换机间的干道链路,允许多个VLAN的帧通过,并可以在出接口方向将需要...
  • Hybrid是华为、H3C交换机的一种端口模式,这个接口也能够允许多个VLAN帧通过并且还可以指定哪些VLAN数据帧被剥离标签,主要实现高隔离度的波分和复用。 Hybrid端口和Trunk端口在接收数据时,处理思路方法是一样的,...
  • Hybrid端口配置实例

    千次阅读 2020-06-25 18:38:21
    Hybrid端口配置实例 3.1 问题 参照如下网络拓扑实现跨交换机的相同vlan的通信。 3.2 方案 使用eNSP搭建实验环境,如图-3所示。 图-3 3.3 步骤 实现此案例需要按照如下步骤进行。 1)配置第1台交换机 [SW1]vlanbatch...
  • 交换机hybrid接口详解

    2019-03-05 19:59:39
    802.1Q报文结构; 接口的三种模式:access,hybrid,trunk详解 ; 交换机对于PVID VLAN(华为系)或native VLAN(思科)报文的处理方式
  • VLAN与Trunk配置 Hybrid端口配置 [SW1]vlan 5 [SW1]vlan 10 [SW1]interface Ethernet0/0/1 [SW1-Ethernet0/0/1]port link-type acces [SW1-Ethernet0/0/1]port default vlan 5 [SW1]interface Ethernet0/0/2 [SW1-...
  • 配置sw1 <Huawei>sys Enter system view, return user view with Ctrl+Z. [Huawei]sys SW1 [SW1]vlan batch 1 2 3 10 Info: This operation may take a few seconds. Please wait for a moment...done. [SW...
  • 2、交换机配置过程 [Huawei]vlan 10 //创建vlan10 [Huawei]interface Vlanif 10 //进入vlanif [Huawei-Vlanif10]ip address 192.168.10.1 24 //为vlanif10设置ip地址 [Huawei-Vlanif10]q //退...
  • 一、华为交换机基本配置1.1 交换机设备创建、删除VLAN1.2 设置接口类型1.2.1 设置access类型1.2.2 设置Trunk类型1.3 华为交换机日常维护查看命令二、Hybrid 接口特性2.1 Hyrid接口特点2.2 Hybrid接口作用三、Hybrid...
  • Hybrid接口配置

    2021-04-19 10:35:12
    Hybrid接口配置 一、Hybrid接口原理 (1)、收到数据帧:判断是否有标签,无标签则打上Hybrid接口 的PVID;有标签,判断是否允许帧进入,否则丢弃。 (2)、发出帧:1.判断VLAN在本接口的属性【Untagged\Tagged】...
  • Vlan的access、trunk以及hybird接口配置实验 文章目录Vlan的access、trunk以及hybird接口配置实验实验拓扑实验思路实验步骤1.配置PC2.再对每个与主机相连的接口配置access接口SW1sw23.交换机之间配置trunk接口sw1sw...
  • eNSP实现配置Hybrid端口

    千次阅读 2020-03-27 18:05:47
    实现不同vlan间PC不可互访,而不同vlan的PC均可访问服务器的特殊效果,具体要求如下。 在交换机中创建相关vlan 修改端口模式与pvid 修改端口允许通过的数据帧 ...1)配置第1台交换机 [SW1]vlan batch 5 10 50 [S...
  • Hybrid接口配置 华为设备接口类型: Access 只能属于一个VLAN,一般用于连接交换机与用户电脑,该端口不打tag(VALN ID)。 Trunk 可以属于多个VLAN,一般用于连接交换机与交换机之间或交换机与上层设备之间的通信...
  • 交换机Hybrid端口典型配置

    千次阅读 2020-03-22 21:46:58
    三台PC机使用同一个地址段,但在交换机上需要使用Hybrid端口实现以下功能: 1、PC 1可以访问到PC 2和PC 3 2、PC 2和PC 3之间无法互访 二、组网图 三、配置步骤 #创建Vlan 10,20,30 switch(config)#vlan 10 ...
  • hybrid端口的配置及原理

    千次阅读 2020-07-18 21:30:38
    交换机端口模式主要有三种:access、trunk、hybrid。其中access和trunk两种模式使用频率较hybrid模式来说要高出不少,hybrid模式相对其他两种模式来说更加复杂。 三种模式下端口的工作方式各不相同: access模式...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 10,164
精华内容 4,065
关键字:

hybrid接口配置