精华内容
下载资源
问答
  • 【Android开发】基本组件-列表选择框

    千次阅读 2015-04-01 12:45:29
    Android中,可以使用两种方法向屏幕中添加列表选择框,一种是通过在XML布局文件中使用标记添加;另一种是在Java文件中,通过new关键字创建。 推荐使用XML配置,基本语法如下: android:prompt="@string
    Android中提供的列表选择框(Spinner)相当于在网页中常见的下拉列表框,通常用于提供一系列可选择的列表项共用户选择。
    

    Android中,可以使用两种方法向屏幕中添加列表选择框,一种是通过在XML布局文件中使用<Spinner>标记添加;另一种是在Java文件中,通过new关键字创建。

    推荐使用XML配置,基本语法如下:
    <Spinner
        android:prompt="@string/info"
        android:entries="@array/数组名称"
        android:layout_width="warp_content"
        android:layout_height="warp_content"
        android:id="@+id/ID号">
    </Spinner>

    其中,android:entries为可选属性,用于指定列表项,如果在布局文件中不指定该属性,可以在JAVA代码中通过为其指定适配器的方式指定;android:prompt属性也是可选属性,用于指定列表选择框的标题。

    实例:
    res/layout/main.xml:
    <LinearLayout xmlns:android="http://schemas.android.com/apk/res/android"
        xmlns:tools="http://schemas.android.com/tools"
    	android:layout_width="wrap_content"
    	android:layout_height="wrap_content"
    	android:orientation="horizontal"
    	android:screenOrientation="landscape"
    	android:background="#FFFFFF">
    	<Spinner android:entries="@array/ctype"
    	    android:layout_height="wrap_content"
    	    android:layout_width="wrap_content"
    	    android:id="@+id/spinner1"/>
    </LinearLayout>

    编写用于指定列表项的数组资源文件,并将其保存在res/values目录中,这里将其命名为arrays.xml,在该文件中添加一个字符串数组,命名为ctype,具体代码如下:
    <?xml version="1.0" encoding="utf-8"?>
    <resources>
        <string-array name="ctype">
            <item>身份证</item>
            <item>学生证</item>
            <item>军人证</item>
            <item>工作证</item>
            <item>其他</item>
        </string-array>
    </resources>
    

    MainActivity:
    package com.example.test;
    
    import android.app.Activity;
    import android.os.Bundle;
    import android.util.Log;
    import android.view.View;
    import android.view.View.OnClickListener;
    import android.widget.Button;
    import android.widget.CheckBox;
    import android.widget.CompoundButton;
    import android.widget.CompoundButton.OnCheckedChangeListener;
    import android.widget.Toast;
    
    public class MainActivity extends Activity {
    	private OnCheckedChangeListener checkBox_listener;
    	@Override
    	protected void onCreate(Bundle savedInstanceState) {
    		super.onCreate(savedInstanceState);
    		setContentView(R.layout.main);
    	    
    	}
    }

    效果如图:


    可以用下列方法获取列表选择框中的选中值:
    Spinner spinner=(Spinner)findViewById(R.id.spinner1);
    spinner.getSelectedItem();

    如果需要在用户选择不同的列表项后,执行相应的处理,则可为该列表选项添加OnItemSelecedListener事件监听器。这里我们获取选择项的值输出到日志中。

    //为选择列表框添加OnItemSelecedListener事件监听器
    		spinner.setOnItemSelectedListener(new OnItemSelectedListener() {
    
    
    			@Override
    			public void onItemSelected(AdapterView<?> parent, View v, int pos,
    					long id) {
    				String result=parent.getItemAtPosition(pos).toString();
    				Log.i("Spinner实例", result);
    			}
    
    
    			@Override
    			public void onNothingSelected(AdapterView<?> arg0) {
    				// TODO Auto-generated method stub
    				
    			}
    		});

    点击后的结果如图:



    在使用列表选择框时,如果不在布局文件中直接为其指定要显示的列表项,也可以通过为其指定适配器的方式指定。下面的例子介绍通过指定适配器的方式指定列表项的方法。


    为列表选择框指定适配器,通常分为一下3个步骤实现:
    1.创建一个适配器对象,通常使用ArrayAdapter类。在Android中,创建适配器通常可以使用以下两种方法:一种是通过数组资源文件创建;另一种是通过在Java文件中使用字符串数组创建。
    a.通过数组资源文件创建适配器,需要使用ArrayAdapter类的实例,具体代码如下:
    ArrayAdapter<CharSequence> adapter=ArrayAdapter.createFromResource(this,R.array.ctype, 
    android.R.layout.simple_spinner_item); //创建一个适配器

    b.通过在Java文件中使用字符串数组创建
    String [] ctype=new String[]{"身份证","学生证","工作证","其他"};
    ArrayAdapter<String> adapter=new ArrayAdapter<String>(this,android.R.layout.simple_spinner_item,ctype);

    2.为适配器设置列表框下拉时的选项样式
    adapter.setDropDownViewResource(android.R.layout.simple_spinner_dropdown_item);

    3.将适配器与选择列表框关联

    spinner.setAdapter(adapter);

    转载请注明出处:http://blog.csdn.net/acmman/article/details/44805211

    展开全文
  • (最好也将类型设置成报表列表框,不然无法显示报表列,同时选择框也不能按列放置) 代码 .版本 2 .支持库 iext .程序集 窗口程序集_启动窗口 .子程序 __启动窗口_创建完毕 .局部变量 i, 整数型 超级列表框1....

    属性

    首先将属性-是否有检查框设置成真。(最好也将类型设置成报表列表框,不然无法显示报表列,同时选择框也不能按列放置)

    代码

    .版本 2
    .支持库 iext
    
    .程序集 窗口程序集_启动窗口
    
    .子程序 __启动窗口_创建完毕
    .局部变量 i, 整数型
    
    超级列表框1.插入列 (, , , , , )
    .计次循环首 (10, i)
        超级列表框1.插入表项 (, 到文本 (i), , , , )
        超级列表框1.置状态图片 (i - 1, 选择 (超级列表框1.取当前状态图片 (i - 1) = 0, 1, 0))
    .计次循环尾 ()
    

    如下图:

    易语言 超级列表框 设置选中状态-选择框的 方法

    运行效果:

    易语言 超级列表框 设置选中状态-选择框的 方法

    解释

    置状态图片:

    设置指定表项的状态图片。如果“是否有检查框”属性为真,调用“置状态图片 (表项索引, 0)”或“置状态图片 (表项索引, 1)”可以设置表项检查框的选中状态(前者为不选中,后者为选中)。

    取当前状态图片:

    取回指定表项的当前状态图片索引,图片索引指向状态图片组属性中的某一图片,从 0 开始,-1 表示无图片。如果“是否有检查框”属性为真,返回值是当前检查框的选中状态,1表示被选中,0表示未选中。

    更多

    判断是否表项选中:

    .版本 2
    .支持库 iext
    
    .子程序 _按钮1_被单击
    .局部变量 文本, 文本型
    .局部变量 i, 整数型
    
    .计次循环首 (超级列表框1.取表项数 (), i)
        .如果真 (超级列表框1.取当前状态图片 (i - 1) = 1)
            编辑框1.内容 = 编辑框1.内容 + “表项” + 到文本 (i) + “被选中” + “    ”
        .如果真结束
    
    .计次循环尾 ()
    

    易语言 超级列表框 设置选中状态-选择框的 方法

    实际运行效果:
    易语言 超级列表框 设置选中状态-选择框的 方法

    添加全选取消全选功能:

    在启动窗口添加一个“选择框”,并将属性-选中设置为“真”

    .版本 2
    .支持库 iext
    
    .子程序 _选择框1_被单击
    .局部变量 i, 整数型
    
    .如果 (选择框1.选中 = 真)
        .计次循环首 (超级列表框1.取表项数 (), i)
            超级列表框1.置状态图片 (i - 1, 1)
        .计次循环尾 ()
    
    .否则
        .计次循环首 (超级列表框1.取表项数 (), i)
            超级列表框1.置状态图片 (i - 1, 0)
        .计次循环尾 ()
    
    .如果结束
    

    易语言 超级列表框 设置选中状态-选择框的 方法

    取消全选后的效果:

    易语言 超级列表框 设置选中状态-选择框的 方法

    其他

    视频教程: https://www.eyuyan.tv/p1289

    展开全文
  • 高级控件之列表选择框(Spinner)

    千次阅读 2016-12-11 15:51:39
    Spinner是一个下拉列表,通常用于选择一系列可选择列表项,它可以使用适配器,也可以直接设置数组源。

    一.列表选择框的基本知识

          Spinner是一个下拉列表,通常用于选择一系列可选择的列表项,它可以使用适配器,也可以直接设置数组源。

    (一)XML配置:

     <Spinner android:id="@+id/ctype" 
    android:layout_width="match_parent" 
    android:layout_height="wrap_content" 
    android:entries="@array/ctype"/>//设置数组源 

    (二)选中默认值:

    spinner.setSelection(2,true);选中默认值

    (三)监听事件:

    spinner.setOnItemSelectedListener(new OnItemSelectedListener() {
         @Override 
         public void onItemSelected(AdapterView<?> parent, View view ,  int position, long id) { 
                        //当用户选择其中一项时 
        } 
         @Override 
         public void onNothingSelected(AdapterView<?> parent) {
         //当没有任何选择时
         } 
    });

          它也可以设置适配器作为数据源,如果下拉列表中并不止一个TextView显示文本,那么就需要设置适配器,但是一般下拉列表都只需要一个文本。

    (四)适配器

          spinner.setAdapter(adapter); 如果需要多个组件值都需要改变,那么一般使用SimpleAdapter类。

    (五)自动完成文本框(AutoCompleteTextView)和列表选择框(Spinner)的区别

          都是有点类似下拉效果而已,但是实际用途是非常不一样的;
          1.自动完成文本框继承于EditText,是输入内容时的提示作用。
          2.列表选择框一般用于点击一个文本框,然后显示可以选择的列表内容,点击列表某个内容后把数据显示在文本框内。

    二.使用资源文件的数据来加载显示Spinner

    (一)创建资源文件arrays.xml(在values文件夹中)

    <?xml version="1.0" encoding="utf-8"?>
    <resources>
        <string-array name="myarray">
            <item>李嘉诚</item>
            <item>李文志</item>
            <item>李世民</item>
            <item>李鸿章</item>
            <item>李丹丹</item>
            <item>李泉</item>
        </string-array>
    </resources>

    (二)设计布局文件

    <RelativeLayout xmlns:android="http://schemas.android.com/apk/res/android"
        android:layout_width="match_parent"
        android:layout_height="match_parent" >
    
        <Spinner
            android:id="@+id/spinner"
            android:layout_width="wrap_content"
            android:layout_height="wrap_content"
            android:entries="@array/myarray" />
    
    </RelativeLayout>

    (三)java代码设计

    public class MainActivity extends Activity {
    
        // Spinner对象
        Spinner spinner;
        // 数据源
        String arr[];
        @Override
        protected void onCreate(Bundle savedInstanceState) {
            super.onCreate(savedInstanceState);
            setContentView(R.layout.activity_main);
            // 实例化对象
            spinner = (Spinner) findViewById(R.id.spinner);
    
            //获取资源文件里面的数组数据
             arr=getResources().getStringArray(R.array.myarray);
            // 添加选中条目的点击事件
            spinner.setOnItemSelectedListener(new OnItemSelectedListener() {
    
                // 选中任意的条目后会触发
                @Override
                public void onItemSelected(AdapterView<?> parent, View view,
                        int position, long id) {
    
                    Toast.makeText(MainActivity.this, "你选中了" + arr[position], 0)
                            .show();
    
                }
    
                // 这个方法基本没有用
                @Override
                public void onNothingSelected(AdapterView<?> parent) {
                }
            });
    
        }
    
    }

    程序运行后显示的界面:
    z1
    默认选中的是第一个资源数据;

    点击下拉框后显示的界面:
    z2

    点击下拉显示的某一个数据后显示的界面:
    z3

    三.使用数组或集合的数据来加载显示Spinner

    (一)布局文件

    <RelativeLayout xmlns:android="http://schemas.android.com/apk/res/android"
        android:layout_width="match_parent"
        android:layout_height="match_parent" >
    
        <Spinner
            android:id="@+id/spinner"
            android:layout_width="wrap_content"
            android:layout_height="wrap_content"
              />
    
    </RelativeLayout>

    (二)java代码文件

    package com.example.lesson7_spinner;
    
    import android.R.integer;
    import android.app.Activity;
    import android.os.Bundle;
    import android.view.View;
    import android.widget.AdapterView;
    import android.widget.AdapterView.OnItemSelectedListener;
    import android.widget.ArrayAdapter;
    import android.widget.Spinner;
    import android.widget.SpinnerAdapter;
    import android.widget.Toast;
    
    public class MainActivity extends Activity {
    
        // Spinner对象
        Spinner spinner;
    
        // 数据源
    
        String[] array = { "张三", "张4", "张5", "张6", "张7", "张8", "张9", "张10", "张11" };
    
        String arr[];
        @Override
        protected void onCreate(Bundle savedInstanceState) {
            super.onCreate(savedInstanceState);
            setContentView(R.layout.activity_main);
            // 实例化对象
            spinner = (Spinner) findViewById(R.id.spinner);     
    
            // 添加选中条目的点击事件
            spinner.setOnItemSelectedListener(new OnItemSelectedListener() {
    
                // 选中任意的条目后会触发
                @Override
                public void onItemSelected(AdapterView<?> parent, View view,
                        int position, long id) {
    
                    Toast.makeText(MainActivity.this, "你选中了" + arr[position], 0)
                            .show();
    
                }
    
                // 这个方法基本没有用
                @Override
                public void onNothingSelected(AdapterView<?> parent) {
                }
            });
    //创建适配器对象
            SpinnerAdapter adapter = new ArrayAdapter<String>(this,
                    android.R.layout.simple_dropdown_item_1line, array);
    //给Spinner设置适配器 
    spinner.setAdapter(adapter);
    
        }
    
    }

    程序运行后点击下拉后显示的界面:

    z4

    在一般的程序中第二种方法的使用是常见的,因为页面数据的传递一般都是集合或数组。

    展开全文
  • 易语言超级列表框表项全部选择或者全部取消 源码
  • 移动端弹出列表选择框

    万次阅读 2016-11-04 14:54:21
    pushbutton 移动端弹出列表选择框 移动端从下往上推动画效果端弹出列表选择框,适应所有主流移动端机型,支持Node引入,require引入;如有用得不爽可以随时提意见,谢谢。

    pushbutton 移动端弹出列表选择框

    移动端从下往上推动画效果端弹出列表选择框,适应所有主流移动端机型,支持Node引入,require引入;如有用得不爽可以随时提意见,谢谢。

    demo地址: https://gtdalp.github.io/widget/pushbutton/demos/pushbutton.html

    npm安装

    npm install pushbuttonjs

    使用方法如下:

    1、html结构

    <section id="pushbutton"></section>

    2、需要引入的js

    <script src="../src/jslib/zepto.min.js"></script>
    <script src="../build/pushbutton.min.js"></script>

    3、调用

    new Pushbutton('#pushbutton', {
        data: [
            {text:'拍照', cls: 'photo', attr: {'data-key': 'photo'} },
            {text:'录像', attr: [
                {key1: 'video2'},
                {key2: 'video2'}
            ]},
            {text:'语音录入'}
        ],
        // 点击回调 返回true 则不隐藏弹出框
        onClick: function( e ) {
            console.log(e);
            // 返回主要有用数据
            // e.target  当前dom节点
            // e.data  当前点击的data
            // e.index  当前点击的选择是第几个
            return true;
        },
        // maxHeight: 100,  // 默认显示的高度
        isShow: true   // 默认是否显示
    });
    var dom = document.getElementById("pushbuttonClick");
    var refresh = document.getElementById("refresh");
    
    dom.onclick = function () {
        pub.show();
    }
    refresh.onclick = function () {
        pub.refresh({
            data: [{text: '1321321321'}]
        });
    }

    效果图 demo1.png

    4、API

    4.1 options.data 数据

    options.data = [
        {text:'拍照', cls: 'photo', attr: {'data-key': 'photo'} },
        {text:'录像', attr: [
            {key1: 'video2'},
            {key2: 'video2'}
        ]},
        {text:'语音录入'}
    ]

    4.2 options.onClick 点击回调 返回true 则不隐藏弹出框

    options.onClick = function( e ) {
        console.log(e);
        // 返回主要有用数据
        // e.target  当前dom节点
        // e.data  当前点击的data
        // e.index  当前点击的选择是第几个
        return true;
    }

    4.3 maxHeight 默认显示的高度

    options.maxHeight = 100  // 默认显示的高度

    4.4 isShow 默认是否显示

    options.isShow = false   // 默认是否显示  默认不显示

    4.5 show 显示

    Pushbutton.show()   // 显示

    4.6 hide 隐藏

    Pushbutton.hide()   // 隐藏

    4.7 refresh 刷新

    Pushbutton.refresh({
        .. // options 可以传options
    })   // 刷新
    展开全文
  • 选择列表框实现一键选中取消,可以推广到超级列表框等组件。 选中取消选择列表框源码 .版本 2 .局部变量 m, , , , 511遇见论坛(bbs.511yj.com) .局部变量 n, , , , 511遇见论坛(bbs.511yj.com) .判断开始...
  • 选择和输入的下拉列表框示例

    千次阅读 2018-10-05 12:11:33
    &lt;html&gt;&lt;head&gt;&lt;meta http-equiv="Content-Type"...可选择和输入的下拉列表框&lt;/title&gt;&lt;style type="text/css"&gt;div,sp
  • 本课录制了易语言选择框选中状态属性判断,一键全部选中、一键全部取消。 视频链接: 511遇见易语言教程选择框一键选中与取消 易语言选择框属性源码: .版本 2 .子程序 _选择框1_被单击 .如果真 (选择框...
  •  加入成员 (选择数组, 选择列表框1.取项目文本 (i - 1))  信息 (选择列表框1.取项目文本 (i - 1), 0, ) 计次循环尾 () 3.连接数据库 a.在启动窗口上添加个odbC源(拖入就可以了) b.外部...
  • <script type="text/html" id="href"> <div class="layui-input-inline"> <select name="quiz2"> <option value="">请选择性别</option> <option value="男"...
  • jQuery实现列表框双向选择操作

    千次阅读 2018-01-29 17:55:25
    列表框的操作经常碰到过这样的应用:从左侧的列表框中选中要选的项添加到右侧列表框中,然后提交最终选择的项,对误操作而选中的项还可以执行移除操作。在很多系统中应用比如说求职网站的选择意向工作地区,QQ好友...
  • 用户选择框设计思路

    千次阅读 2018-08-21 14:08:07
    最近新项目要用到选择人员,于是重新在新项目中设计了一版选人。 效果图如下: 功能部分 一个选人主要有以下几个展示部分: 人员组织树 已选节点信息 操作工具栏   这三大部分再细分下各自应有的...
  • 简单通用弹出选择框,keys没有可以不传 [java]   view plain   copy public   void  Choise( final  List values, final  List keys, final  ...
  • 安卓组件------列表选择框

    千次阅读 2017-03-01 18:27:28
    如下图便是一个列表选择框 下拉列表的列表选择项能够通过xml文件的android:entries属性指定,或是在java代码中导入,属性android:prompt是列表项的标题。 一 列表项数据:  实际运用当中,很多下拉列表项的...
  • C# ListBox:列表框控件

    千次阅读 2019-06-11 22:26:10
    并可以选择其中的一项或多项内容,从形式上比使用复选更好一些。 列表框中常用属性: 列表框还提供了一些方法来操作列表框中的选项,由于列表框中的选项是一个集合形式的, 列表项的操作都是用 Items 属性...
  • 微信小程序下拉选择框

    千次阅读 2019-07-30 16:59:55
    一般来说的话,总有点需要下拉并且能够搜索选择的需求。 首先wxml <!-- 下拉菜单 --> <view class='menu-po'> <!-- 请选择 --> <view class='menu'> <view class='menu-list'> ...
  • [微信小程序]搜索功能实现,搜索样式

    万次阅读 多人点赞 2017-11-28 11:21:11
    微信小程序开发交流qq群 173683895 承接微信小程序开发。...1.在首页做一个搜索的样式并实现跳转到搜索页面 <view class='page_row' bindtap="suo"> <view class="search"> <view cla...
  • 复选框列表对于允许用户在选择框中选择多个选项很有用。但在这种情况下,可以通过按住控制(ctrl)按钮选择多个选项,用户讨厌这个。您可以使用jQuery进行多选复选框下拉列表,而不是使用HTML中的多个属性。 这是一...
  • Jquery 各类弹出 确认选择框

    千次阅读 2020-07-04 14:05:44
    http://www.jq22.com/demo/jqueryConfirm20160413/
  • jq实现动态下拉选择框

    千次阅读 2019-05-27 20:32:57
    但是下拉列表框中的内容,有时候需要根据某些页面的参数发生改变,这时就需要使用jq动态生成下拉选择框。 页面中policyid的下拉选择框需要根据参数flightnum来改变。policyid在显示的时候,显示的是名称,但是值是...
  • 本节视频通过三种方法实现了防止项目重复加入列表框。 易语言列表框防止项目重复加入列表框视频教程源码: .版本 2 .程序集 窗口程序集_启动窗口 .子程序 __启动窗口_创建完毕 列表框1.现行选中项 = 0 ...
  • 易语言组合去重复到列表框

    千次阅读 2019-12-08 19:15:51
    在辅助开发时,我们需要通过组合控制一些功能,或者获取一些数据,比如把组合里 的值添加到列表框,这里就需要去除重复的,以下代码实现了这个功能。 .版本 2 .支持库 spec .支持库 EDataStructure .程序集 ...
  • //获取当前选择项的值. var options=$("#fukusyaNendo option:selected");//获取当前选择项. options.val();//获取当前选择项的值. 2.获取内容 var options=$("#fukusyaNendo option:selected"); va...
  • MFC实现的多选的列表框ListBox

    热门讨论 2011-10-20 23:05:00
    本文以包含两个列表框的对话框为例,实现了对话框常用的功能。左边的“待选的历史人物”列表框包含历史人物...当单击“清除”按钮,则已选择的名字移到左侧的列表框。且列表框中的选项可以实现多选和多个选项同时操作。
  • 带搜索功能的下拉选择框select2

    千次阅读 2018-11-14 15:29:51
    连续选择多个,而不关闭,通过设置closeOnSelect=false设定,详情见 https://select2.org/configuration/options-api 设置select 选中某个值:$("#user").val('1').trigger("change"); 设置select 选中多个值...
  • Spinner实现下拉列表框
  • 一、允许多项选择 代码如下 Private Sub UserForm_Initialize() arr = Sheets("产品表").Range("a1").CurrentRegion ... '设置列表框属性 .List = arr .MultiSelect = fmMultiSelectExtended ...
  • Axure表单元件:下拉列表框列表框

    千次阅读 2019-12-23 14:43:20
    单击选择框,可以设为默认选中,没有勾选默认为第一个。 注:点击“添加多个”,可以一次性填多条值。 列表框 操作与下拉列表框类似。区别只是在“编辑列表选项”对话框中,可以选择多个;最最根本区别是展示效果,...
  • 选择列表 如上图,是antd的可选择列表,我们如何将普通列表变成可选择列表呢,这就用到了一个很重要的属性rowSelection。 rowSelection 如下图,rowSelection属性是一个对象,他有很多的参数。 下面是antd官网...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 542,872
精华内容 217,148
关键字:

列表选择框是通过