精华内容
下载资源
问答
  • 本节视频通过三种方法实现了防止项目重复加入列表框。 易语言列表框防止项目重复加入列表框视频教程源码: .版本 2 .程序集 窗口程序集_启动窗口 .子程序 __启动窗口_创建完毕 列表框1.现行选中项 = 0 ...

    本节视频通过三种方法实现了防止项目重复加入列表框。

    易语言列表框防止项目重复加入列表框视频教程源码:

    .版本 2
    
    .程序集 窗口程序集_启动窗口
    
    .子程序 __启动窗口_创建完毕
    
    列表框1.现行选中项 = 0
    皮肤_加载 (1)
    
    .子程序 _按钮1_被单击
    
    列表框1.加入项目 (编辑框1.内容, )
    编辑框1.内容 = “”
    
    .子程序 _按钮2_被单击, , , 不重复加入-1
    
    .如果 (列表框1.选择 (编辑框1.内容) = -1)
    列表框1.加入项目 (编辑框1.内容, )
    信息框 (“添加成功!”, 0, , )
    .否则
    信息框 (“已经存在【” + 编辑框1.内容 + “】请不要重复添加该内容!”, 0, , )
    
    .如果结束
    
    .子程序 _按钮3_被单击, , , 不重复加入-2
    
    .如果 (SendMessageA (列表框1.取窗口句柄 (), 399, 0, 编辑框1.内容) = -1)
    列表框1.加入项目 (编辑框1.内容, )
    信息框 (“添加成功!”, 0, , )
    .否则
    信息框 (“已经存在【” + 编辑框1.内容 + “】请不要重复添加该内容!”, 0, , )
    
    .如果结束
    
    .子程序 _按钮4_被单击, , , 不重复加入-3
    .局部变量 i, 整数型
    .局部变量 重复, 逻辑型
    
    .计次循环首 (列表框1.取项目数 (), i)
    .如果真 (列表框1.取项目文本 (i - 1) = 编辑框1.内容)
    重复 = 真
    跳出循环 ()
    .如果真结束
    重复 = 假
    .计次循环尾 ()
    
    .如果 (重复 = 假)
    列表框1.加入项目 (编辑框1.内容, )
    编辑框1.内容 = “”
    信息框 (“添加成功!”, 0, , )
    .否则
    信息框 (“已经存在【” + 编辑框1.内容 + “】请不要重复添加该内容!”, 16, , )
    .如果结束

    源码:511遇见易语言教程

               511遇见易语言教程视频链接

               易语言列表框防止项目重复加入列表框

    展开全文
  • 本课视频通过四种方法实现了易语言列表框去重复项目到列表框。 易语言列表框去重复项目到列表框视频教程源码: .版本 2 .程序集 窗口程序集_启动窗口 .子程序 __启动窗口_创建完毕 皮肤_加载 (1) .子程序 _...

    本课视频通过四种方法实现了易语言列表框去重复项目到列表框。

    易语言列表框去重复项目到列表框视频教程源码:

    .版本 2
    
    .程序集 窗口程序集_启动窗口
    
    .子程序 __启动窗口_创建完毕
    
    皮肤_加载 (1)
    
    .子程序 _按钮1_被单击
    .局部变量 项目文本, 文本型
    
    项目文本 = 列表框1.取项目文本 (列表框1.现行选中项)
    .如果 (列表框查找文本 (列表框2, 项目文本) = 真)
    列表框2.加入项目 (项目文本, )
    .否则
    
    .如果结束
    
    .子程序 列表框查找文本, 逻辑型
    .参数 列表框, 列表框
    .参数 要加入的文本, 文本型
    .局部变量 I, 整数型
    
    .计次循环首 (列表框.取项目数 (), I)
    .如果真 (要加入的文本 = 列表框.取项目文本 (I - 1))
    返回 (假)
    .如果真结束
    
    .计次循环尾 ()
    返回 (真)
    
    .子程序 _按钮2_被单击
    .局部变量 列表框1内容, 文本型
    
    列表框1内容 = 列表框1.取项目文本 (列表框1.现行选中项)
    .如果 (列表框2.选择 (列表框1内容) = -1)
    列表框2.加入项目 (列表框1内容, )
    .否则
    
    .如果结束
    
    .子程序 _按钮3_被单击
    .局部变量 项目, 文本型
    
    项目 = 列表框1.取项目文本 (列表框1.现行选中项)
    
    .如果 (列表框加入项目 (列表框2, 项目) = 真)
    信息框 (“项目添加成功”, 0, , )
    .否则
    
    .如果结束
    
    .子程序 列表框加入项目, 逻辑型
    .参数 列表框, 列表框
    .参数 要加入的文本, 文本型
    .局部变量 n, 整数型
    
    .计次循环首 (列表框.取项目数 (), n)
    .如果真 (要加入的文本 = 列表框.取项目文本 (n - 1))
    返回 (假)
    .如果真结束
    
    .计次循环尾 ()
    列表框.加入项目 (要加入的文本, )
    返回 (真)
    
    .子程序 _按钮4_被单击
    .局部变量 项目, 文本型
    
    项目 = 列表框1.取项目文本 (列表框1.现行选中项)
    .如果 (SendMessageA (列表框2.取窗口句柄 (), 399, 0, 项目) = -1)
    列表框2.加入项目 (项目, )
    信息框 (“项目添加成功!”, 0, , )
    
    .否则
    信息框 (“已经存主【” + 项目 + “】请不要重复添加!”, 16, , )
    
    .如果结束

    源码:511遇见易语言教程

               511遇见易语言教程视频链接

               易语言列表框去重复项目到列表框

     

    展开全文
  • Axure表单元件:下拉列表框列表框

    千次阅读 2019-12-23 14:43:20
    下拉列表框 1,拖动“下拉列表框”元件至页面中; 2,双击下拉列表框,打开“编辑列表选项” 3,点击“+”增加列,输入内容;单击选择框,可以设为默认选中,没有勾选默认为第一个。 注:点击“添加多个”,可以...

    下拉列表框

    1,拖动“下拉列表框”元件至页面中;
    在这里插入图片描述
    2,双击下拉列表框,打开“编辑列表选项”
    在这里插入图片描述
    3,点击“+”增加列,输入内容;单击选择框,可以设为默认选中,没有勾选默认为第一个。
    在这里插入图片描述
    注:点击“添加多个”,可以一次性填多条值。

    列表框

    操作与下拉列表框类似。区别只是在“编辑列表选项”对话框中,可以选择多个;最最根本区别是展示效果,列表框是平铺展示所有内容;下拉列表框只显示一列当前列内容
    在这里插入图片描述

    展开全文
  • 列表框属性

    2019-11-22 14:01:41
    列表框 列表框允许用户从多个对象中选择一项或多项,这些对象可以是文本、文件和位图等。当列表框的项不能全部显示出来时,可以用滚动条来滚动显示。 1. 基础知识 默认的列表框只允许用户单选,需要多选时,须把...

    列表框

    列表框允许用户从多个对象中选择一项或多项,这些对象可以是文本、文件和位图等。当列表框的项不能全部显示出来时,可以用滚动条来滚动显示。

    1. 基础知识
    默认的列表框只允许用户单选,需要多选时,须把列表框的风格定义为 LBS_ MULTIPLESEL 和 LBS_EXTENDEDSEL 。列表框提供的其他风格取值可以控制列表框的外观和操作。例如是否按照列表框各项的名称排序,是否多行排列,是否有滚动条等。

    风格取值                   描述
    LBS_EXTENDEDSEL           //能通过Shift键或者鼠标进行多选
    LBS_HASSTRINGS            //可以用GetText函数得到列表框里选项的字符串
    LBS_MULTICOLUMN           //指定列表框以多列形式显示内容
    LBS_MULTIPLESEL           //用户可以选择多个项
    LBS_NOINTEGRALHEIGHT      //当应用程序创建列表框时,列表框的大小由系统指定
    LBS_NOREDRAW              //列表框不响应用户的修改,可以通过发送WM_REDRAW 来取消该设置
    LBS_NOTIFY                //让主窗口接收列表框的任何改变的消息
    LBS_OWNERDRAWFIXED        //主窗口负责列表框的重画,列表框里每项的高度相同
    LBS_0WNERDRAWVARIABLE     //主窗口负责列表框的重画,列表框里每项的高度可以变化
    LBS_SORT                  //按各项名称的字母排序
    LBS_STANDARD              //等同于LBS_SORT和LBS_NOTIFY
    LBS_USETABSTOPS           //允许用户使用Tab键在各项中切换
    LBS_WANTKEYBOARDINPUT     //输入焦点在列表框时,任何键盘输入都会向父窗口发送WM_VKEYTOITEM或者WM_CHARTOITEM消息
    LBS_DISABLENOSCROLI       //当列表框的项不够时,垂直滚动条禁活:没有该属性时,滚动条隐藏

    当用户对列表框进行了操作时,就会向主窗口发送一条消息。列表框的消息类型比较简单,主要是单击、双击和选择等。同编辑框一样,列表框也会遇到内存不够的问题,所以消息类型中含有这一项。消息总是通过WM_COMMAND的形式发送给主窗口的。其中,wParam的低位字节表示列表框的标识符,高位字节表示消息的类型,lParam表示主窗口句柄。列表框的消息类型如表所示。

    消息类型                   描述
    LB_DELETESTRING           //删除指定的选项
    LB_ADDFILE                //向列表框里增加一个文件(包括目录)
    LB_FINDSTRING             //在列表框里查找指定的项
    LB_FINDSTRlNGEXACT        //精确查找指定的项
    LB_GETCOUNT               //得到列表框里项的数目
    LB_GETCURSEL              //返回当前被选中选项的序号
    LB_GETSEL                 //得到被选项的状态,如果出错,则返回零值
    LB_GETSELCOUNT            //得到被选中的个数
    LB_GETTEXT                //返回选中的文本,返回值为字符串长度
    LB_GETTEXTLEN             //返回字符串长度
    LB_INITSTORAGE            //向列表框增加项之前存储原来的内容
    LB_INSERTSTRING           //向列表框增加一项,但不重新排序
    LB_ITEMFROMPOINT          //返回离指定点最近项的序号
    LB_RESETCONTENT           //清除列表框里所有的项
    LB_SELECTSTRING           //寻找指定的项
    LB_SELITEMRANGE           //指定选择的范围
    LB_SELITEMRANGEEX         //选定或者删除指定的项
    LB_SETCOLUMNWIDTH         //设置列的宽度
    LB_SETCOUNT               //设置列表框里项的最大数目
    LB_SETCURSEL              //选中指定的项
    LBN_DBLCLK                //发送用户双击的消息
    LBN_ERRSPACE              //发送内存空间不够的消息
    LBN_KILLFOCUS             //当列表框失去焦点时发送该消息
    LBN_SELCANCEL             //当用户取消选择时发送该消息
    LBN_SELCHANGE             //当用户选择改变时发送该消息
    LBN_SETFOCUS              //当输入焦点转移到列表框时发送该消息
    WM_CTLCOLORLISTBOX        //在列表框重画时向父窗口发送该消息
    WM_DELETEITEM             //删除选项
    WM_VKEYTOITEM             //输入焦点在列表框里,用户按键时发送该消息

    鼠标右键WM_CONTEXTMENU 消息就行了。wParam 是点击右键的窗口的句柄,lParam 是鼠标坐标。如果用户使用 SHIFT+F10 来响应菜单,那么 lParam 收到的坐标都是 -1。
    LOWORD(wParam) 子窗口ID
    HIWORD(wParam) 通知码
    Lparam 子窗口句柄

     

    2. 定义列
    增加列需要用列的结构LVCOLUMN,定义如下:

    typedef struct _LVCOLUMN {
    UINT mask;                //定义该列可使用的类型
    int fmt;                  //定义列格式
    int cx;                   //定义列宽度(以像素为单位)
    LPTSTR pszText;           //列内容
    int cchTextMax;           //列内容最大长度
    int iSubItem;             //定义此列序号
    #if (_WIN32_IE >= 0x0300)
    int iImage;               //指向图像
    int iOrder;               //零基列偏移量。列偏移量是从左到右的顺序。例如0列在最左边。
    #endif #if (_WIN32_WINNT >= 0x0600)
    int cxMin;                //指定列宽最小值
    int cxDefault;            //默认列宽
    int cxIdeal;              //只读,作为列宽的理想宽度自动调整宽度大小
    #endif
    } LVCOLUMN, *LPLVCOLUMN;  //结构名称

    使用方法:
    SendMessage(hwnd, LVM_INSERTCOLUMN, 0, (LPARAM)&colmn)
    还有LVM_GETCOLUMN LVM_SETCOLUMN LVM_DELETECOLUMN

     

    3. 改变项
    改变项需要结构体LVITEM,定义如下:

    typedef struct {
    UINT mask;              //设置成员标志,如格式等
    int iItem;              //项目索引
    int iSubItem;           //添加到的列序
    UINT state;             //指明项目状态,如图片,叠加图片
    UINT stateMask;         //指state成员的有效位
    LPTSTR pszText;         //项目内容
    int cchTextMax;         //项目最大长度
    int iImage;             //指向图片索引
    LPARAM lParam;          //特殊值,如果你用SORTITEM它就需要这个,或者别的特别的
    #if (_WIN32_IE >= 0x0300)
    int iIndent;            //图片宽度
    #endif
    #if (_WIN32_WINNT >= 0x0501)
    int iGroupId;           //指向所在的组id
    UINT cColumns;          //需要展示的列数,最大为20
    UINT puColumns;         //返回这个项目所指向的列
    #endif
    #if (_WIN32_WINNT >= 0x0600)
    int piColFmt;           //返回列属性
    int iGroup;             //项目列
    #endif
    } LVITEM, *LPLVITEM;

    使用方法:
    SendMessage(hres, LVM_INSERTITEM, 0, (LPARAM)&item);

    展开全文
  • QComboBox下拉列表框QComboBox以占用最少...QComboBox类属性editable 设置是否可编辑currentText设置当前列表框显示内容(前提是先在列表框添加内容)currentIndex设置当前列表框显示内容的索引(前提是先在列表框添加...
  • 组合框,列表框

    2016-05-19 10:34:51
    组合框封装类:CComboBox列表框封装类CListBox首先将列表框和组合框都绑定控件变量,我们希望当按下添加按钮时,将数据从编辑框分别添加到列表框和组合框中去添加按钮代码:void Cdemo7Dlg::OnBnClickedButAdd() ...
  • JAVA列表框组件

    2019-09-26 19:20:24
    列表框(JList)与下拉列表框的区别不仅表现在外观上,当激活下拉列表框时,还会出现下拉列表框中的内容;但列表框只是在窗体上占据固定的大小,如果需要列表框具有滚动效果,可以将列表框放入滚动面板中。 使用...
  • HTML 下拉列表框

    千次阅读 2019-04-28 16:30:23
    HTML 下拉列表框
  • C# 列表框

    千次阅读 2017-02-20 15:53:22
    做了一个列表框的小程序 用鼠标指向列表里的项目 比如 橘子,栗子时 文本框会显示 相应的名字 当你在文本框中输入你想添加的东西 再按一下添加按钮 想添加的东西就会进入列表 当你选中列表框中的莫个item 再...
  • JSP 下拉列表框、多行下拉列表框

    千次阅读 2014-07-25 17:24:15
    1、下拉列表框:  语法:
  • 易语言组合框去重复到列表框

    千次阅读 2019-12-08 19:15:51
    在辅助开发时,我们需要通过组合框控制一些功能,或者获取一些数据,比如把组合框里 的值添加到列表框,这里就需要去除重复的,以下代码实现了这个功能。 .版本 2 .支持库 spec .支持库 EDataStructure .程序集 ...
  • C# 下拉列表框

    万次阅读 2017-02-09 21:47:54
    下拉列表框 ComboBox既是下拉列表 属性: Items属性:为下拉列表添加相应的项目,与列表框类似 DropDownStyle属性:控制组合框的外观和功能(此属性如果选择DropDownList则只可选择而不能再框中输入,若选择...
  • win32 使用列表框

    2019-05-24 17:27:53
    列表框介绍: 列表框提供一个可供用户选择的列表,用户可以一次选择一个项目,也可以同时选中多个项目。 资源的定义介绍: 资源代码: 可选择的列表框风格: 用户消息的处理: WM_COMMAND 通知码:当列表框...
  • 下拉列表框: 下拉列表框是指允许网页浏览者从下拉式菜单中选择某一项,我们通常会在网页中看到各种下拉列表框,这是一种最节省空间的方式。正常情况下,浏览者只能看见一个选项,单击选项按钮打开菜单后才能看到...
  • 本课视频通过5种方法实现了易语言组合框添加不重复文本到列表框。 易语言组合框添加不重复文本到列表框视频交教程源码: .版本 2 .子程序 _按钮1_被单击 .局部变量 文本, 文本型 文本 = 组合框1.内容 .如果...
  • 列表框控件ListBox

    2016-08-16 13:51:31
    前面两节讲了比较常用的按钮控件,并通过按钮控件实例说明了具体用法。本文要讲的是列表框控件(ListBox)及其使用实例。  列表框控件简介 ...列表框可分为单选列表框和多选列表框,顾名思义,单选列
  • 一:文本框和多行文本框 ...input type="text"/>...列表框是将所有选项展示出来,而下拉列表框会将所有选项折叠起来,两者的区别就是选项是否会折叠起来。 三:复选框和单选按钮 单选按钮必须为每一个
  • 列表框控件简介

    千次阅读 2015-09-29 11:26:36
    列表框可分为单选列表框和多选列表框,顾名思义,单选列表框中一次只能选择一个列表项,而多选列表框可以同时选择多个列表项。  列表框也会向父窗口发送通知消息。这些通知消息及含义如下:  LBN_DBLCLK :...
  • 下拉框与列表框

    千次阅读 2014-10-24 17:30:50
    下拉列表框和下拉列表 下拉列表框和下拉列表 下拉列表框:请选择电话区号: 北京 西安 成都 单选列表框:请选择电话区号 北京 西安 成都
  • 自定义wxpython下拉列表框,支持修改边框颜色,按钮图标的动态变换 原理同前两片文章一样,使用了两个wx.staticText做边框,一个文本框来显示下拉列表的数据,和一个图片按钮,实现下拉的标志,和一个自带的列表框...
  • C# ListBox:列表框控件

    千次阅读 2019-06-11 22:26:10
    列表框 (ListBox) 将所提供的内容以列表的形式显示出来, 并可以选择其中的一项或多项内容,从形式上比使用复选框更好一些。 列表框中常用属性: 列表框还提供了一些方法来操作列表框中的选项,由于列表框中的...
  • 对于列表框控件中数据项的添加、修改、获取或删除等操作都是通过列表框控件函数实现的。首先认识一下列表框控件的函数:listLoadList("ControlName","Filename")此函数用于将CSV格式文件“Filename”中的列表项调入...
  • (最好也将类型设置成报表列表框,不然无法显示报表列,同时选择框也不能按列放置) 代码 .版本 2 .支持库 iext .程序集 窗口程序集_启动窗口 .子程序 __启动窗口_创建完毕 .局部变量 i, 整数型 超级列表框1....
  • Android自定义的下拉列表框控件

    万次阅读 2017-10-20 13:49:40
    Android中的有个原生的下拉列表控件Spinner,但是这个控件有时候不符合我们自己的要求, 比如有时候我们需要类似windows 或者web网页中常见的那种下拉列表控件,类似下图这样的: 这个时候只有自己动手...
  • 列表框、组合框

    千次阅读 2010-04-08 15:54:00
    如果项目总数超过了列表框可显示的项目数,列表框会自动添加滚动条,可以方便用户以滚动的方式来选择列表框列表框的常用属性·listcount属性:用于返回列表框中的所有选项的个数,该属性只能在程序代码中调用和设置...
  • win32之列表框

    千次阅读 2016-10-19 18:08:33
    列表框:  1.风格  单列列表框  单例列表框 - 默认 多列列表框 - LBS_MULTICOLUMN 多列列表框  2. 使用  创建列表框 "LISTBOX"; LB_ADDSTRING - 追加选项 LB_INSERTSTRING - 按照指定位置的添加  2.3...
  • Java Swing JList:列表框组件

    千次阅读 2019-03-05 23:30:17
    1 JList:列表框组件 列表框与下拉列表的区别不仅仅表现在外观上,当激活下拉列表时,会出现下拉列表框中的内容。但列表框只是在窗体系上占据固定的大小,如果需要列表框具有滚动效果,可以将列表框放到滚动面板中...
  • Java 列表框

    千次阅读 2012-05-19 10:18:25
    摘 要 本文针对Java语言的特点,提出了在程序中动态添加和删除列表框中的列表元素并在结束操作时获取列表元素的实现方法,并给出了具体开发的实例。  关键词 Java 列表框  引言  Java是一种纯粹的面向对象的...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 48,070
精华内容 19,228
关键字:

列表框