精华内容
下载资源
问答
  • 列表框属性 千次阅读
    2019-11-22 14:01:41

    列表框

    列表框允许用户从多个对象中选择一项或多项,这些对象可以是文本、文件和位图等。当列表框的项不能全部显示出来时,可以用滚动条来滚动显示。

    1. 基础知识
    默认的列表框只允许用户单选,需要多选时,须把列表框的风格定义为 LBS_ MULTIPLESEL 和 LBS_EXTENDEDSEL 。列表框提供的其他风格取值可以控制列表框的外观和操作。例如是否按照列表框各项的名称排序,是否多行排列,是否有滚动条等。

    风格取值                   描述
    LBS_EXTENDEDSEL           //能通过Shift键或者鼠标进行多选
    LBS_HASSTRINGS            //可以用GetText函数得到列表框里选项的字符串
    LBS_MULTICOLUMN           //指定列表框以多列形式显示内容
    LBS_MULTIPLESEL           //用户可以选择多个项
    LBS_NOINTEGRALHEIGHT      //当应用程序创建列表框时,列表框的大小由系统指定
    LBS_NOREDRAW              //列表框不响应用户的修改,可以通过发送WM_REDRAW 来取消该设置
    LBS_NOTIFY                //让主窗口接收列表框的任何改变的消息
    LBS_OWNERDRAWFIXED        //主窗口负责列表框的重画,列表框里每项的高度相同
    LBS_0WNERDRAWVARIABLE     //主窗口负责列表框的重画,列表框里每项的高度可以变化
    LBS_SORT                  //按各项名称的字母排序
    LBS_STANDARD              //等同于LBS_SORT和LBS_NOTIFY
    LBS_USETABSTOPS           //允许用户使用Tab键在各项中切换
    LBS_WANTKEYBOARDINPUT     //输入焦点在列表框时,任何键盘输入都会向父窗口发送WM_VKEYTOITEM或者WM_CHARTOITEM消息
    LBS_DISABLENOSCROLI       //当列表框的项不够时,垂直滚动条禁活:没有该属性时,滚动条隐藏

    当用户对列表框进行了操作时,就会向主窗口发送一条消息。列表框的消息类型比较简单,主要是单击、双击和选择等。同编辑框一样,列表框也会遇到内存不够的问题,所以消息类型中含有这一项。消息总是通过WM_COMMAND的形式发送给主窗口的。其中,wParam的低位字节表示列表框的标识符,高位字节表示消息的类型,lParam表示主窗口句柄。列表框的消息类型如表所示。

    消息类型                   描述
    LB_DELETESTRING           //删除指定的选项
    LB_ADDFILE                //向列表框里增加一个文件(包括目录)
    LB_FINDSTRING             //在列表框里查找指定的项
    LB_FINDSTRlNGEXACT        //精确查找指定的项
    LB_GETCOUNT               //得到列表框里项的数目
    LB_GETCURSEL              //返回当前被选中选项的序号
    LB_GETSEL                 //得到被选项的状态,如果出错,则返回零值
    LB_GETSELCOUNT            //得到被选中的个数
    LB_GETTEXT                //返回选中的文本,返回值为字符串长度
    LB_GETTEXTLEN             //返回字符串长度
    LB_INITSTORAGE            //向列表框增加项之前存储原来的内容
    LB_INSERTSTRING           //向列表框增加一项,但不重新排序
    LB_ITEMFROMPOINT          //返回离指定点最近项的序号
    LB_RESETCONTENT           //清除列表框里所有的项
    LB_SELECTSTRING           //寻找指定的项
    LB_SELITEMRANGE           //指定选择的范围
    LB_SELITEMRANGEEX         //选定或者删除指定的项
    LB_SETCOLUMNWIDTH         //设置列的宽度
    LB_SETCOUNT               //设置列表框里项的最大数目
    LB_SETCURSEL              //选中指定的项
    LBN_DBLCLK                //发送用户双击的消息
    LBN_ERRSPACE              //发送内存空间不够的消息
    LBN_KILLFOCUS             //当列表框失去焦点时发送该消息
    LBN_SELCANCEL             //当用户取消选择时发送该消息
    LBN_SELCHANGE             //当用户选择改变时发送该消息
    LBN_SETFOCUS              //当输入焦点转移到列表框时发送该消息
    WM_CTLCOLORLISTBOX        //在列表框重画时向父窗口发送该消息
    WM_DELETEITEM             //删除选项
    WM_VKEYTOITEM             //输入焦点在列表框里,用户按键时发送该消息

    鼠标右键WM_CONTEXTMENU 消息就行了。wParam 是点击右键的窗口的句柄,lParam 是鼠标坐标。如果用户使用 SHIFT+F10 来响应菜单,那么 lParam 收到的坐标都是 -1。
    LOWORD(wParam) 子窗口ID
    HIWORD(wParam) 通知码
    Lparam 子窗口句柄

     

    2. 定义列
    增加列需要用列的结构LVCOLUMN,定义如下:

    typedef struct _LVCOLUMN {
    UINT mask;                //定义该列可使用的类型
    int fmt;                  //定义列格式
    int cx;                   //定义列宽度(以像素为单位)
    LPTSTR pszText;           //列内容
    int cchTextMax;           //列内容最大长度
    int iSubItem;             //定义此列序号
    #if (_WIN32_IE >= 0x0300)
    int iImage;               //指向图像
    int iOrder;               //零基列偏移量。列偏移量是从左到右的顺序。例如0列在最左边。
    #endif #if (_WIN32_WINNT >= 0x0600)
    int cxMin;                //指定列宽最小值
    int cxDefault;            //默认列宽
    int cxIdeal;              //只读,作为列宽的理想宽度自动调整宽度大小
    #endif
    } LVCOLUMN, *LPLVCOLUMN;  //结构名称

    使用方法:
    SendMessage(hwnd, LVM_INSERTCOLUMN, 0, (LPARAM)&colmn)
    还有LVM_GETCOLUMN LVM_SETCOLUMN LVM_DELETECOLUMN

     

    3. 改变项
    改变项需要结构体LVITEM,定义如下:

    typedef struct {
    UINT mask;              //设置成员标志,如格式等
    int iItem;              //项目索引
    int iSubItem;           //添加到的列序
    UINT state;             //指明项目状态,如图片,叠加图片
    UINT stateMask;         //指state成员的有效位
    LPTSTR pszText;         //项目内容
    int cchTextMax;         //项目最大长度
    int iImage;             //指向图片索引
    LPARAM lParam;          //特殊值,如果你用SORTITEM它就需要这个,或者别的特别的
    #if (_WIN32_IE >= 0x0300)
    int iIndent;            //图片宽度
    #endif
    #if (_WIN32_WINNT >= 0x0501)
    int iGroupId;           //指向所在的组id
    UINT cColumns;          //需要展示的列数,最大为20
    UINT puColumns;         //返回这个项目所指向的列
    #endif
    #if (_WIN32_WINNT >= 0x0600)
    int piColFmt;           //返回列属性
    int iGroup;             //项目列
    #endif
    } LVITEM, *LPLVITEM;

    使用方法:
    SendMessage(hres, LVM_INSERTITEM, 0, (LPARAM)&item);

    更多相关内容
  • MFC 下拉列表框设置

    千次阅读 2019-11-06 10:33:27
    设置下拉列表框: 步骤1:打开VS2015,新建项目工程,选择模块下的Visual C++-->MFC-->MFC应用程序,设定好项目文件名和路径,点击确定。 步骤2:进入应用程序类 型界面。勾选“基于对话框”,在“MFC的...

    MFC:

    MFC(Microsoft Foundation Classes),是一个微软公司提供的类库(class libraries)以C++类的形式封装了Windows的API,并且包含一个应用程序框架,以减少应用程序开发人员的工作量。包含的类包含大量Windows句柄封装类和很多Windows的内建控件和组件的封装类。MFC是WinAPI与C++的结合。API,即微软提供的Windows下应用程序的编程语言接口,是一种软件编程的规范,但不是一种程序开发语言。

    设置下拉列表框:

    步骤1:打开VS2015,新建项目工程,选择模块下的Visual C++-->MFC-->MFC应用程序,设定好项目文件名和路径,点击确定。

    步骤2:进入应用程序类 型界面。勾选“基于对话框”,在“MFC的使用” 中,勾选“在共享DLL中 使用MFC(U)”,再点击下 一步。注:MFC可以在静态库下 使用,或者在共享DLL中 使用,但前者会把所有用到的dll文件集成到exe 文件,因此占用内存较大,所以建议选择后者。

     

    步骤3: 进入用户界面功能。选择主框架样式,可以自由选择是否添加最小化框、最大化框;“关于”框也可以去掉;对话框标题一般不需要更改,默认与项目名称一致。

    步骤4:进入高级功能界 面。高级功能一般默认即可,无须勾选其它选项。如果用不上"Active 控件",可以去掉其勾选。

    步骤5: 进入生成的类界面。显示自动生成的两个类的头文件和源文件名称

    步骤6: 建立完的工程自动生成了对应的界面
     

     

    步骤7:在资源视图中点击工具箱,选择Combo Box 拖至对话框窗口。

    步骤8:右键Combo Box控件添加变量,类别选择Value,设置变量名,点击完成。

     

    步骤9:右键点击Combo Box打开属性,在属性中添加Data中的数据(即你要选择的下拉列表中的数据),以 ;隔开。

    步骤10:添加一个button控件测试一下,同样在工具箱中选中Button。

    步骤11:双击Button1即可进入控件的函数,在函数中输入如下代码。

    步骤12:完成之后,编译调试。

    步骤13:选好控件数据之后,点击Button1按钮,测试是否能获取到控件数据。

     

     

     

     

     

    展开全文
  • 511遇见易语言教程列表框属性方法

    千次阅读 2020-07-09 09:06:20
    本节视频录制了易语言列表框的取项目文本、置项目文本、加入项目、插入项目、是否被选择、取所有选择项目等属性方法。 易语言教程列表框视频教程源码: .版本 2 .程序集 窗口程序集_启动窗口 .子程序 _按钮1_...

    本节视频录制了易语言列表框的取项目文本、置项目文本、加入项目、插入项目、是否被选择、取所有选择项目等属性方法。

    易语言教程列表框视频教程源码:

    .版本 2
    
    .程序集 窗口程序集_启动窗口
    
    .子程序 _按钮1_被单击
    
    信息框 (列表框1.取项目文本 (列表框1.现行选中项), #信息图标, , )
    
    .子程序 _按钮2_被单击
    
    信息框 (列表框1.取项目文本 (到整数 (编辑框1.内容)), #信息图标, , )
    
    .子程序 _按钮3_被单击
    
    列表框1.置项目文本 (列表框1.现行选中项, 编辑框1.内容)
    
    .子程序 _按钮4_被单击
    .局部变量 项目索引
    
    项目索引 = 列表框1.加入项目 (编辑框1.内容, )
    列表框1.现行选中项 = 项目索引
    
    .子程序 _按钮5_被单击
    .局部变量 项目索引, 整数型
    
    项目索引 = 列表框1.插入项目 (到整数 (编辑框1.内容), 编辑框2.内容, )
    列表框1.现行选中项 = 项目索引
    
    .子程序 _按钮6_被单击
    .局部变量 bool, 逻辑型
    
    bool = 列表框1.是否被选择 (到整数 (编辑框1.内容))
    .如果 (bool)
    信息框 (“被选择”, 0, , )
    .否则
    信息框 (“没有选择”, 0, , )
    .如果结束
    
    .子程序 _按钮7_被单击
    .局部变量 项目数组, 整数型, , "0"
    .局部变量 选择数量
    .局部变量 索引文本, 文本型
    .局部变量 项目文本, 文本型
    .局部变量 n, 整数型
    
    项目数组 = 列表框1.取所有被选择项目 ()
    选择数量 = 取数组成员数 (项目数组)
    .如果真 (选择数量 = 0)
    信息框 (“请选择项目”, 0, , )
    返回 ()
    .如果真结束
    
    .计次循环首 (选择数量, n)
    
    索引文本 = 索引文本 + #换行符 + 到文本 (项目数组 [n])
    
    项目文本 = 项目文本 + #换行符 + 列表框1.取项目文本 (项目数组 [n])
    
    .计次循环尾 ()
    
    信息框 (“被选中的项目文本:” + 索引文本 + 项目文本, 0, , )

    源码:511遇见易语言教程

               511遇见易语言教程视频链接

               易语言教程列表框属性方法

    展开全文
  • java:下拉列表框组件

    千次阅读 2022-04-19 22:25:32
    下拉列表框组件一、关键代码一)、创建单个下拉列表框内容(项)二)、字符串数组添加多个下拉列表框内容(项)三)、模型方法给下拉列表框添加内容(项)二、简单说明三、流程图四、源码一)、源码A二)、源码A...

    一、关键代码

    一)、创建单个下拉列表框的内容(项)

    1. 可以先创建下拉列表框,然后不断的一个个添加内容元素,注意泛型的使用,泛型这里选择字符串(String)。
    2. 单个创建下拉下拉列表框的内容元素,可以创建多个,下方源码只创建一个(“PC120挖机”)。
    3. 需要注意在源码前面添加下拉列表框的包类。import javax.swing.JComboBox;// 下拉框列表
    		// combo(连击),String<字符串>
    		JComboBox<String> comboBox_1=new JComboBox<>();
    		comboBox_1.addItem("PC120挖机");// 下拉框列表添加内容。Item(条款,项)
    

    二)、字符串数组添加多个下拉列表框的内容(项)

    • 也可以先创建字符串数组,数组里添加多个内容(项),然后将这个字符串数组的数据添加到下拉列表框中。
    		String items_1[]={"54m天泵","56m天泵","62m天泵"};// 建立数组
    		JComboBox<String> comboBox_1=new JComboBox<>(items_1);// 使用数组String添加下拉元素
    

    三)、模型方法给下拉列表框添加内容(项)

    1. 需要注意泛型的添加,不加有些JDK版本报错。源码本身无问题,但会因版本的兼容性问题报错。
    2. 模型方法注意添加模型相关的包类。
      import javax.swing.ComboBoxModel;// 下拉框列表模型
      import javax.swing.DefaultComboBoxModel;// 默认下拉框列表模型
    3. 模型方法的好处之一是当要在原来内容的基础上,继续加某一项内容(项)时,编写相关插入的相关代码便可。如:
      model_1.addElement(tmp);// 向数组模型添加元素 Element(元素)
      注意: 上行一行代码,这里只做说明使用,本文源码未使用。
    		JComboBox<String> comboBox_1=new JComboBox<>();// 新建下拉框列表
    		String items_1[]={"小户型","大户型","工区"};
    		// 下行不加<String>会因版本问题报错
    		ComboBoxModel<String> cm_1=new DefaultComboBoxModel<>(items_1);// 创建下拉框列表模型
    		comboBox_1.setModel(cm_1);// 向列表中添加模型
    

    二、简单说明

    • 大致流程说明。大致的流程也可观看流程图得知。先创建窗体f和容器c,将容器嵌入窗体中。设置窗体点击×即关闭程序,窗体可见,初始不设置布局。以上主要为way1的相关源码。然后创建一个下拉列表框,并给下拉列表框添加内容(元素)。添加内容有三种方法,源码看way2、way3、way4部分,分别为三种添加内容(项、元素)的方法。
    • way2的源码流程,先创建下拉列表框,然后逐个添加内容元素,最后再以动作监听,输出信息框的方式展示运行效果。
    • way3的源码流程,先创建字符串数组,数组中编辑好内容元素,然后将字符串数组添加到下拉列表框中,最后和way2一样以信息框展示运行效果。
    • way4的源码流程,创建下拉列表框,创建数组,将数组引入模型中,将模型添加到下拉列表框中。然后添加事件监听,通过输入信息框的方式展示运行效果。模型个泛型需要设置好,因为有的JDK版本会提示因编译的安全问题报错而无法编译。
    • Main一类。创建Demo类,功能的组合,如way1接way2,或者way1接way3。本文直接创建3个way1的窗体。

    三、流程图

    窗体
    容器
    初始不设置布局
    下拉列表框
    添加元素方法way2
    添加元素方法way3
    添加元素方法way4
    分别创建多个元素
    设置可编辑
    动作监听弹出信息框
    字符串数组创建元素
    设置不可编辑
    动作监听弹出信息框
    模型方法创建元素
    动作监听弹出信息框

    四、源码

    一)、源码A

    • 窗体里添加一个下拉列表框,和一个按钮。点击按钮弹出信息框,信息框的内容:索引和选择的内容。给下拉列表框里添加元素,代码有三种方法来实现。这里分别用方法way2、way3、way4(way1为窗体的属性)。本文源码是选择直接编译成三个窗体,各显示三个方法的效果。毕竟注释后一个个分别编译后的效果对比性较差,直接在桌面共同生成三个方法各自的效果对比性更好。
    • 注意:编译后三个窗体,是重合的,分别拉开分析便可。
    /*	【程序思想】
    *	下拉列表框组件
    */
    
    import java.awt.Container;// 容器
    
    import java.awt.event.ActionListener;// 动作监听
    import java.awt.event.ActionEvent;// 动作事件
    
    import javax.swing.JFrame;// 窗体
    import javax.swing.JComboBox;// 下拉框列表
    import javax.swing.ComboBoxModel;// 下拉框列表模型
    import javax.swing.DefaultComboBoxModel;// 默认下拉框列表模型
    import javax.swing.JButton;// 按钮
    import javax.swing.JOptionPane;// 选择 窗格
    
    class Demo{
    	JFrame f=new JFrame();// 窗体
    	Container c;// 容器
    
    	/*
    		way1
    		窗体的基本属性
    	*/
    	void way1(){
    		f.setBounds(400,200,500,400);// 位置、尺寸
    		f.setDefaultCloseOperation(JFrame.EXIT_ON_CLOSE);// 点×即关闭
    		c=f.getContentPane();// 容器c嵌入窗体
    		c.setLayout(null);// 初始容器c不设置布局
    	}
    
    	/*
    		way2
    		下拉框列表属性的设置,方法一
    	*/
    	void way2(){
    		
    		// combo(连击),String<字符串>
    		JComboBox<String> comboBox_1=new JComboBox<>();
    		comboBox_1.addItem("PC120挖机");// 下拉框列表添加内容。Item(条款)
    		comboBox_1.addItem("YC60挖机");// 下拉框列表添加内容。Item(条款)
    		comboBox_1.addItem("PC220炮机");// 下拉框列表添加内容。Item(项,项目)
    		
    		comboBox_1.setBounds(15,10,100,20);// 下拉框的坐标、尺寸。绝对布局
    		c.add(comboBox_1);
    
    		comboBox_1.setEditable(true);// 列表框可编辑
    
    		JButton btn_1=new JButton("按钮way2");
    		// Action(动作),performed(执行),Message(信息),dialog(对话框),selected(挑选),index(指数)
    		btn_1.addActionListener(new ActionListener(){
    			public void actionPerformed(ActionEvent e){
    				JOptionPane.showMessageDialog(f,
    					"选择的索引:"+comboBox_1.getSelectedIndex()+"\n"+
    					"选择的内容为:"+comboBox_1.getSelectedItem()
    				);
    				
    			}
    
    		});
    		btn_1.setBounds(120,20,110,40);// 按钮的坐标、尺寸
    		c.add(btn_1);
    	}
    
    	/*
    		way3
    		下拉框列表的属性设置,方法二
    	*/
    	void way3(){
    		String items_1[]={"54m天泵","56m天泵","62m天泵"};// 建立数组
    		JComboBox<String> comboBox_1=new JComboBox<>(items_1);// 使用数组String添加下拉元素
    
    		comboBox_1.setBounds(20,15,90,30);// 下拉框列表的位置、尺寸
    		c.add(comboBox_1);
    
    		comboBox_1.setEditable(false);// 列表框不可编辑
    
    		JButton btn_1=new JButton("按钮way3");
    		// Action(动作),performed(执行),Message(信息),dialog(对话框),selected(挑选),index(指数)
    		btn_1.addActionListener(new ActionListener(){
    			public void actionPerformed(ActionEvent e){
    				JOptionPane.showMessageDialog(f,
    					"选择的索引:"+comboBox_1.getSelectedIndex()+"\n"+
    					"选择的内容为:"+comboBox_1.getSelectedItem()
    				
    				);
    				
    			}
    
    		});
    		btn_1.setBounds(120,20,110,40);// 按钮的坐标、尺寸
    		c.add(btn_1);
    	}
    
    	/*
    		way4
    		下拉框的属性,方法三
    		模型方法
    	*/
    	void way4(){
    		// <泛型:字符串>
    		JComboBox<String> comboBox_1=new JComboBox<>();// 新建下拉框列表
    		String items_1[]={"小户型","大户型","工区"};
    		// 下行不加<String>会因版本问题报错
    		ComboBoxModel<String> cm_1=new DefaultComboBoxModel<>(items_1);// 创建下拉框列表模型
    		comboBox_1.setModel(cm_1);// 向下拉列表中添加模型
    
    		comboBox_1.setBounds(20,18,90,25);// 下拉框列表坐标、大小
    		c.add(comboBox_1);
    
    		JButton btn_1=new JButton("按钮way4");
    		// Action(动作),performed(执行),Message(信息),dialog(对话框),selected(挑选),index(索引)
    		btn_1.addActionListener(new ActionListener(){
    			public void actionPerformed(ActionEvent e){
    				JOptionPane.showMessageDialog(f,
    					"选择的索引:"+comboBox_1.getSelectedIndex()+"\n"+
    					"选择的内容为:"+comboBox_1.getSelectedItem()
    				);
    				
    			}
    
    		});
    		btn_1.setBounds(120,20,110,40);// 按钮的坐标、尺寸
    		c.add(btn_1);
    	}
    
    	public static void main(String[] args) {
    		Demo d=new Demo();
    		d.way1();// 窗体a属性
    		d.way2();// 下拉框列表的属性,编写方式1
    
    		Demo d_2=new Demo();
    		d_2.way1();// 再新建一个窗体b
    		d_2.way3();// 下拉框列表的属性,编写方式2
    
    		Demo d_3=new Demo();
    		d_3.way1();// 新建窗体c
    		d_3.way4();// 下拉框列表的属性,编写方式3,模型
    		
    		d.f.setVisible(true);// 窗体可见
    		d_2.f.setVisible(true);
    		d_3.f.setVisible(true);
    	}
    }
    
    

    二)、源码A的运行效果

    1.默认编译效果

    (1)、默认的编译效果,三个窗体因方法way1设置的坐标大小相同,所以在同一位置。如下图。我们分别拉开展示就好。
    在这里插入图片描述
    (2)、拉开最前面的两个窗体,让三个窗体在同一桌面平面展示。如下:
    在这里插入图片描述

    2.方法way2的窗体

    (1)、点击“按钮way2”,效果如下:
    在这里插入图片描述
    (2)、 “按钮way2”窗体的下拉列表框是可以编辑的,源码A中有相关的代码。这里我们编辑“推土机”后点击“按钮way2”,效果如下:
    在这里插入图片描述

    3.方法way3的窗体

    (1)、选择下拉列表框中的“62m天泵”,如下:
    在这里插入图片描述
    (2)、点击“按钮way3”,效果如下:
    在这里插入图片描述

    4.方法way4的窗体

    (1)、选择下拉列表框中的“大户型”,如下:

    • 注意:way4使用模型方法添加元素。
      在这里插入图片描述
      (2)、点击“按钮way04”的效果如下:
      在这里插入图片描述

    五、结语

    模型方法不设置好或不设泛型的话,有时候编译报错,作者的JDK版本便无法编译,不是常见的缺什么内容或类相关的报错,而是大致意思是说这个方法不安全不给你编译的报错。但有的版本不设置泛型便可编译运行。对于窗体的运行效果,想着一个个编译截图上传太麻烦,便选择生成三个方法下不同编译效果的窗体,这样对比也比较直观。其实这里“比较”的方向意思是三个方法都可以达成相同的效果,而不是各窗体的这个和哪个看起来怎么怎么样的不同。编译直观不同的地方是各方法里又另外添加了些功能代码,如:way2窗体的下拉列表框可编辑,way3窗体的下拉列表框不可编辑。但根本上元素类下拉选择的效果各方法却是一样的。

    六、定位日期

    2022.4.19;23:25 流程图、源码、源码运行效果的内容
    2022.4.20;23:30

    展开全文
  • (最好也将类型设置成报表列表框,不然无法显示报表列,同时选择框也不能按列放置) 代码 .版本 2 .支持库 iext .程序集 窗口程序集_启动窗口 .子程序 __启动窗口_创建完毕 .局部变量 i, 整数型 超级列表框1....
  • 列表框的重要属性有: Selection 该属性决定用户的选择方式,缺省值为 Single 。属性值有: ①:Single ── 单项选择 ②:Multiple ── 多项选择,但是忽略 Ctrl 和 Alt 键。 ③:Extended ── 允许使用 ...
  • C# ListBox:列表框控件

    千次阅读 2019-06-11 22:26:10
    列表框中常用属性列表框还提供了一些方法来操作列表框中的选项,由于列表框中的选项是一个集合形式的, 列表项的操作都是用 Items 属性进行的。 例如Items.Add方法用于向列表框中添加项,...
  • PyQT5控件:下拉列表框(QComboBox)

    千次阅读 2020-12-16 06:03:36
    QComboBox下拉列表框QComboBox以占用最少...QComboBox类属性editable 设置是否可编辑currentText设置当前列表框显示内容(前提是先在列表框添加内容)currentIndex设置当前列表框显示内容的索引(前提是先在列表框添加...
  • html下拉列表框默认值

    千次阅读 2020-12-29 04:53:59
    HTML 和 JavaScript 综合练习题一、单项选择 ... HTTP 2. HTTP 服务默认......name 的属性值必须要相同,必须有一个 value 值 实现默认选中的属性 :checked="checked" - 文件输入项(在后期上传时候用到): -下拉.........
  • WPS表格怎么使用列表框控件?

    千次阅读 2021-01-13 16:52:38
    wps表格想要制作一个列表框,该怎么制作呢?需要使用列表框空间,该怎么制作呢?下面我们就来看看详细的教程。1、打开WPS软件,在表格创建一个简单的表格,在单元格的输入数据,比如分类表,如下图所示。2、...
  • 易语言组合框去重复到列表框

    千次阅读 2019-12-08 19:15:51
    在辅助开发时,我们需要通过组合框控制一些功能,或者获取一些数据,比如把组合框里 的值添加到列表框,这里就需要去除重复的,以下代码实现了这个功能。 .版本 2 .支持库 spec .支持库 EDataStructure .程序集 ...
  • 在matlab
  • vb学习总结, 列表框  1、属性  1、columns  该属性用来确定列表的列数。当该属性设置为0(默认)是,所用的项目呈单列显示。...list属性保存了列表框中所有值得数组,可以通过下标访问数组的值(下标值从
  • VB关于LIST列表框的使用

    千次阅读 2019-01-29 14:35:42
    ... 注意:在使用list列表的过程,添加的列表数量...例如name名称list1列表框添加了了A,B,C三项,那么A项地址为list1.list(0),B项地址为list1.list(1),C项的地址为list1.list(2).列表的数量计数list1.listcount=3
  • 常用控件:列表框控件ListBox

    千次阅读 2017-09-29 10:10:18
    列表框可分为单选列表框和多选列表框,顾名思义,单选列表框中一次只能选择一个列表项,而多选列表框可以同时选择多个列表项。  列表框也会向父窗口发送通知消息。这些通知消息含义如下:  LBN_DBLCLK:用户...
  • LabVIEW(十六):多列列表框控件

    千次阅读 2018-09-25 08:51:00
    程序框图选中多列列表框右键>创建>属性节点>项名:多列列表框所有的表格都称作项名。 (2)、选中项名属性右键>转换为写入 (3)、选中项名属性右键>创建>常量 (4)、调整输入常量的表格大小:可以调整单个表格和...
  • wpsexcel复选怎么设置

    千次阅读 2020-12-23 04:51:28
    选中A12,取消复选,数据——有效性...追答设置复选的LinkedCell属性A10A16IF(A10,SUM(A14:A15),0)追问呵呵 看不太懂,能不 能说说具体的步骤,先谢谢你啦,大哥,还有,多个复选能不能选定到同个单元格...
  • LabVIEW多列列表框背景颜色操作

    万次阅读 2017-08-07 17:27:09
    多列列表框概述在很多情况下我们需要在表格某一列查找一些指定的元素,并且想让其显示为指定的颜色,此时就可以利用多列列表框的一些属性来解决这一问题。
  • 本篇博文分享程序设计时一个细节小技巧,在LabVIEW显示控件中内容过长设置自动滚动条。
  • MFC实例:[5] ListBox 列表框控件实例

    千次阅读 2019-04-01 17:39:52
    MFC实例:[4] ListBox 列表框控件实例
  • labview技巧——多列列表框

    万次阅读 2019-02-26 22:03:56
    【多行列表框】可用于显示包含多个横向信息的数据,列表本身支持鼠标选中行(默认为单行,可以右击更改其他),所以可以利用属性节点将当前选中行的数据提取出来方便处理,例如删除数据,导出当前行的信息等,可以...
  • Qt QListWidget列表框用法详解

    千次阅读 2022-01-25 13:30:02
    Qt QListWidget列表框用法详解 很多应用程序需要以列表的形式向用户展示数据(资源),比如 Windows 操作系统会以列表的方式展示很多张桌面背景图(如图 1a) 所示),再比如很多音乐播放器以列表的形式展示音乐...
  • 组合框和列表框都可以在界面上同时显示多项内容,并且允许用户选中其中的某项内容列表框还允许同时选择多项。这两种控件的使用,有很多相似之处;2.3.1 技术要点: Windows 预先定义了一系列“CB_ ”开头的消息...
  • form表单的下拉菜单和列表框

    千次阅读 2019-09-25 01:04:46
     控制生成列表框属性就是multiple,size的值代表的是列表框的行数,而第二个select标签里用了一个optgroup的子标签,它的作用就是将列表的各个选项进行分类,使用户可以更加清晰的看出来选择哪一个。  
  • 【原创】带你玩转超级列表框(全套教程目录)讲师:雪山凌狐... 带你玩转超级列表框 2 常用属性设置  主要说了超级列表框属性 或者说 和 我门自己总结的 使用
  • VS2010 下 MFC下拉列表框的用法

    千次阅读 2018-06-26 16:30:36
    最近在写一个串口程序,需要将下拉列表框的数据全部显示,怎么设置都不对,最后终于找到了设置方法:二、如何控制Combo Box的下拉长度1,首先要知道两点:一、那就是在设计界面里,点击一下Combo Box的下拉箭头,...
  • 安卓实现下拉列表框 【Spinner】

    千次阅读 2019-10-06 15:20:09
    下拉列表框 引言: 别人写的东西往往不能全信,照着写出bug很正常,有些东西看来还是要自己摸索啊。下拉列表,要用到Spinner控件。 步骤一: 你需要在布局声明这个控件。 <Spinner android:entries="@array/...
  • 一、允许多项选择 代码如下 Private Sub UserForm_Initialize() arr = Sheets("产品表").Range("a1").CurrentRegion ... '设置列表框属性 .List = arr .MultiSelect = fmMultiSelectExtended ...
  • 在提供用户调查几面的时候,如果选项比较多,那么就会用到:下拉框组件(JComboBox)列表框组件(JList)滚动窗格组件(JScrollPane)介绍三个组件:下拉框组件(JComboBox):点击箭头可以显示其他信息列表框组件...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 502,484
精华内容 200,993
关键字:

列表框中的列表内容通过()属性设置