精华内容
下载资源
问答
  • 511遇见易语言教程列表框属性方法

    千次阅读 2020-07-09 09:06:20
    本节视频录制了易语言列表框的取项目文本、置项目文本、加入项目、插入项目、是否被选择、取所有选择项目等属性方法。 易语言教程列表框视频教程源码: .版本 2 .程序集 窗口程序集_启动窗口 .子程序 _按钮1_...

    本节视频录制了易语言列表框的取项目文本、置项目文本、加入项目、插入项目、是否被选择、取所有选择项目等属性方法。

    易语言教程列表框视频教程源码:

    .版本 2
    
    .程序集 窗口程序集_启动窗口
    
    .子程序 _按钮1_被单击
    
    信息框 (列表框1.取项目文本 (列表框1.现行选中项), #信息图标, , )
    
    .子程序 _按钮2_被单击
    
    信息框 (列表框1.取项目文本 (到整数 (编辑框1.内容)), #信息图标, , )
    
    .子程序 _按钮3_被单击
    
    列表框1.置项目文本 (列表框1.现行选中项, 编辑框1.内容)
    
    .子程序 _按钮4_被单击
    .局部变量 项目索引
    
    项目索引 = 列表框1.加入项目 (编辑框1.内容, )
    列表框1.现行选中项 = 项目索引
    
    .子程序 _按钮5_被单击
    .局部变量 项目索引, 整数型
    
    项目索引 = 列表框1.插入项目 (到整数 (编辑框1.内容), 编辑框2.内容, )
    列表框1.现行选中项 = 项目索引
    
    .子程序 _按钮6_被单击
    .局部变量 bool, 逻辑型
    
    bool = 列表框1.是否被选择 (到整数 (编辑框1.内容))
    .如果 (bool)
    信息框 (“被选择”, 0, , )
    .否则
    信息框 (“没有选择”, 0, , )
    .如果结束
    
    .子程序 _按钮7_被单击
    .局部变量 项目数组, 整数型, , "0"
    .局部变量 选择数量
    .局部变量 索引文本, 文本型
    .局部变量 项目文本, 文本型
    .局部变量 n, 整数型
    
    项目数组 = 列表框1.取所有被选择项目 ()
    选择数量 = 取数组成员数 (项目数组)
    .如果真 (选择数量 = 0)
    信息框 (“请选择项目”, 0, , )
    返回 ()
    .如果真结束
    
    .计次循环首 (选择数量, n)
    
    索引文本 = 索引文本 + #换行符 + 到文本 (项目数组 [n])
    
    项目文本 = 项目文本 + #换行符 + 列表框1.取项目文本 (项目数组 [n])
    
    .计次循环尾 ()
    
    信息框 (“被选中的项目文本:” + 索引文本 + 项目文本, 0, , )

    源码:511遇见易语言教程

               511遇见易语言教程视频链接

               易语言教程列表框属性方法

    展开全文
  • 像下面这样,用easyui的...data-options在支持HTML5的浏览器有效,如果浏览器版本较低,那么最好直接把配置写成属性,例如: input id="demoCombo" type="text" class="easyui-combobox" editable="false"/>

    像下面这样,用easyui的combobox做的下拉列表,要使它只可以选择列表里面的值,不可以直接输入或删除值

    http://c.hiphotos.baidu.com/zhidao/pic/item/77094b36acaf2edd19e1c6528e1001e93901937d.jpg


    data-options在支持HTML5的浏览器中有效,如果浏览器版本较低,那么最好直接把配置写成属性,例如:


    <input id="demoCombo" type="text" class="easyui-combobox" editable="false"/>


    或者不行的话就用js来控制:


    $("#demoCombo").combobox({editable:false});



    展开全文
  • MFC 下拉列表框设置

    千次阅读 2019-11-06 10:33:27
    设置下拉列表框: 步骤1:打开VS2015,新建项目工程,选择模块下的Visual C++-->MFC-->MFC应用程序,设定好项目文件名和路径,点击确定。 步骤2:进入应用程序类 型界面。勾选“基于对话框”,在“MFC的...

    MFC:

    MFC(Microsoft Foundation Classes),是一个微软公司提供的类库(class libraries)以C++类的形式封装了Windows的API,并且包含一个应用程序框架,以减少应用程序开发人员的工作量。包含的类包含大量Windows句柄封装类和很多Windows的内建控件和组件的封装类。MFC是WinAPI与C++的结合。API,即微软提供的Windows下应用程序的编程语言接口,是一种软件编程的规范,但不是一种程序开发语言。

    设置下拉列表框:

    步骤1:打开VS2015,新建项目工程,选择模块下的Visual C++-->MFC-->MFC应用程序,设定好项目文件名和路径,点击确定。

    步骤2:进入应用程序类 型界面。勾选“基于对话框”,在“MFC的使用” 中,勾选“在共享DLL中 使用MFC(U)”,再点击下 一步。注:MFC可以在静态库下 使用,或者在共享DLL中 使用,但前者会把所有用到的dll文件集成到exe 文件,因此占用内存较大,所以建议选择后者。

     

    步骤3: 进入用户界面功能。选择主框架样式,可以自由选择是否添加最小化框、最大化框;“关于”框也可以去掉;对话框标题一般不需要更改,默认与项目名称一致。

    步骤4:进入高级功能界 面。高级功能一般默认即可,无须勾选其它选项。如果用不上"Active 控件",可以去掉其勾选。

    步骤5: 进入生成的类界面。显示自动生成的两个类的头文件和源文件名称

    步骤6: 建立完的工程自动生成了对应的界面
     

     

    步骤7:在资源视图中点击工具箱,选择Combo Box 拖至对话框窗口。

    步骤8:右键Combo Box控件添加变量,类别选择Value,设置变量名,点击完成。

     

    步骤9:右键点击Combo Box打开属性,在属性中添加Data中的数据(即你要选择的下拉列表中的数据),以 ;隔开。

    步骤10:添加一个button控件测试一下,同样在工具箱中选中Button。

    步骤11:双击Button1即可进入控件的函数,在函数中输入如下代码。

    步骤12:完成之后,编译调试。

    步骤13:选好控件数据之后,点击Button1按钮,测试是否能获取到控件数据。

     

     

     

     

     

    展开全文
  • (最好也将类型设置成报表列表框,不然无法显示报表列,同时选择框也不能按列放置) 代码 .版本 2 .支持库 iext .程序集 窗口程序集_启动窗口 .子程序 __启动窗口_创建完毕 .局部变量 i, 整数型 超级列表框1....

    属性

    首先将属性-是否有检查框设置成真。(最好也将类型设置成报表列表框,不然无法显示报表列,同时选择框也不能按列放置)

    代码

    .版本 2
    .支持库 iext
    
    .程序集 窗口程序集_启动窗口
    
    .子程序 __启动窗口_创建完毕
    .局部变量 i, 整数型
    
    超级列表框1.插入列 (, , , , , )
    .计次循环首 (10, i)
        超级列表框1.插入表项 (, 到文本 (i), , , , )
        超级列表框1.置状态图片 (i - 1, 选择 (超级列表框1.取当前状态图片 (i - 1) = 0, 1, 0))
    .计次循环尾 ()
    

    如下图:

    易语言 超级列表框 设置选中状态-选择框的 方法

    运行效果:

    易语言 超级列表框 设置选中状态-选择框的 方法

    解释

    置状态图片:

    设置指定表项的状态图片。如果“是否有检查框”属性为真,调用“置状态图片 (表项索引, 0)”或“置状态图片 (表项索引, 1)”可以设置表项检查框的选中状态(前者为不选中,后者为选中)。

    取当前状态图片:

    取回指定表项的当前状态图片索引,图片索引指向状态图片组属性中的某一图片,从 0 开始,-1 表示无图片。如果“是否有检查框”属性为真,返回值是当前检查框的选中状态,1表示被选中,0表示未选中。

    更多

    判断是否表项选中:

    .版本 2
    .支持库 iext
    
    .子程序 _按钮1_被单击
    .局部变量 文本, 文本型
    .局部变量 i, 整数型
    
    .计次循环首 (超级列表框1.取表项数 (), i)
        .如果真 (超级列表框1.取当前状态图片 (i - 1) = 1)
            编辑框1.内容 = 编辑框1.内容 + “表项” + 到文本 (i) + “被选中” + “    ”
        .如果真结束
    
    .计次循环尾 ()
    

    易语言 超级列表框 设置选中状态-选择框的 方法

    实际运行效果:
    易语言 超级列表框 设置选中状态-选择框的 方法

    添加全选取消全选功能:

    在启动窗口添加一个“选择框”,并将属性-选中设置为“真”

    .版本 2
    .支持库 iext
    
    .子程序 _选择框1_被单击
    .局部变量 i, 整数型
    
    .如果 (选择框1.选中 = 真)
        .计次循环首 (超级列表框1.取表项数 (), i)
            超级列表框1.置状态图片 (i - 1, 1)
        .计次循环尾 ()
    
    .否则
        .计次循环首 (超级列表框1.取表项数 (), i)
            超级列表框1.置状态图片 (i - 1, 0)
        .计次循环尾 ()
    
    .如果结束
    

    易语言 超级列表框 设置选中状态-选择框的 方法

    取消全选后的效果:

    易语言 超级列表框 设置选中状态-选择框的 方法

    其他

    视频教程: https://www.eyuyan.tv/p1289

    展开全文
  • C# ListBox:列表框控件

    千次阅读 2019-06-11 22:26:10
    列表框中常用属性列表框还提供了一些方法来操作列表框中的选项,由于列表框中的选项是一个集合形式的, 列表项的操作都是用 Items 属性进行的。 例如Items.Add方法用于向列表框中添加项,...
  • 列表框设置每行行高

    千次阅读 2013-11-04 14:22:24
    MFC的标准列表框控件并没有给出设置每一行高度的接口。 有两种方法可以设置: 1.取巧的方法:为列表框插入图标,每一行的高度自动变为图标的高度。这个方法很快,但总觉得有点别扭,且不好移植。所以我没用这种...
  • 列表框控件List Control设置行高

    千次阅读 2017-04-11 17:02:50
    MFC的标准列表框控件并没有给出设置每一行高度的接口。 有两种方法可以设置: 1.取巧的方法:为列表框插入图标,每一行的高度自动变为图标的高度。这个方法很快,但总觉得有点别扭,且不好移植。所以我没用这种...
  • C# 列表框

    千次阅读 2017-02-09 16:46:50
    Items属性列表框中的项 SelectionMode属性:只是列表框将是单项选择,多项选择还是不可选择; one表示只能选一个; MultiSimple表示可以选择多个; MultiExtended鼠标单击只能选择一个,但是可以利用组合键选择多...
  • 在matlab
  • 易语言组合框去重复到列表框

    千次阅读 2019-12-08 19:15:51
    在辅助开发时,我们需要通过组合框控制一些功能,或者获取一些数据,比如把组合框里 的值添加到列表框,这里就需要去除重复的,以下代码实现了这个功能。 .版本 2 .支持库 spec .支持库 EDataStructure .程序集 ...
  • 列表框的重要属性有: Selection 该属性决定用户的选择方式,缺省值为 Single 。属性值有: ①:Single ── 单项选择 ②:Multiple ── 多项选择,但是忽略 Ctrl 和 Alt 键。 ③:Extended ── 允许使用 ...
  • C# 下拉列表框

    万次阅读 2017-02-09 21:47:54
    Items属性:为下拉列表添加相应的项目,与列表框类似 DropDownStyle属性:控制组合框的外观和功能(此属性如果选择DropDownList则只可选择而不能再框输入,若选择DropDown则即可在框输入又可以进行选择) ...
  • 列表框、组合框

    千次阅读 2010-04-08 15:54:00
    如果项目总数超过了列表框可显示的项目数,列表框会自动添加滚动条,可以方便用户以滚动的方式来选择列表框列表框的常用属性·listcount属性:用于返回列表框中的所有选项的个数,该属性只能在程序代码调用和设置·...
  • 在下拉列表框中显示树状结构

    千次阅读 2005-08-08 18:15:00
    作者:星轨(oRbIt) E_Mail :inte2000@163.com 转载请注明原作者,否则请勿转载 在下拉列表框中...一个典型的用户界面就是使用下拉列表框(或称组合列表框)显示数据库相关表名或某个表的某个字段的全部数据
  • 下拉列表框设置和取值

    千次阅读 2009-03-24 10:47:00
    1,从下拉列表中简单取值sex"> boy gril 则你在servlet里取值 request.getParameter("sex") ;... Struts中将数据库内容动态生成下拉列表内容 文章有错误,我要报错 到论坛交流、讨论 对该文章进行评论
  • VC中列表框控件的使用

    千次阅读 2011-08-09 21:38:59
    1 将列表框的View属性改为Report 2 设置列表框的风格 m_listRest.SetExtendedStyle(LVS_EX_FULLROWSELECT | LVS_EX_GRIDLINES | LVS_EX_CHECKBOXES);    3 为列表框
  • ComboBox(下拉列表框)ComboBox(下拉列表框)常用属性: valueField: 基础数据值名称绑定到该下拉列表框。— 提交值 textField:基础数据字段名称绑定到该下拉列表框。—显示值 url:通过URL加载远程列表数据。...
  • LabVIEW多列列表框背景颜色操作

    千次阅读 2017-08-07 17:27:09
    多列列表框概述在很多情况下我们需要在表格某一列查找一些指定的元素,并且想让其显示为指定的颜色,此时就可以利用多列列表框的一些属性来解决这一问题。
  • wx.ListBox创建列表框

    千次阅读 2013-04-23 10:26:27
    7.4.3 如何创建一个列表框列表框是提供给用户选择的另一机制。选项被放置在一个矩形的窗口,用户可以选择一个或多个。列表框比单选按钮占据较少的空间,当选项...在wxPython列表框是类wx.ListBox的元素。该
  • HTML列表框

    千次阅读 2015-01-09 10:11:39
    New Document               红色 蓝色 绿色 黄色 白色    ...实现:在select标签添加size属性。 这全是费代码其实就一个关键的属性:select标签里面的 size属性
  • Items属性:复选列表框中所有项目的集合。 SelectedIndex属性:选中的集合项目的索引(Items集合的项目索引从0开始)。 SelectedItem属性:选中的项,跟listBox控件一样,该属性是object类型。、
  • Java 列表框

    千次阅读 2012-05-19 10:18:25
    摘 要 本文针对Java语言的特点,提出了在程序动态添加和删除列表框中的列表元素并在结束操作时获取列表元素的实现方法,并给出了具体开发的实例。  关键词 Java 列表框  引言  Java是一种纯粹的面向对象的...
  • 在DataGridView控件加入ComboBox下拉列表框的实现  虽然在Visual Studio DataGridView控件的DataGridViewComboBoxColumn可以实现下拉列表框,但这样的列会在整列中都显示下拉列表框,不太美观,而且还要用代码...
  • 第二步:设置列表框属性,在样式,选择“报告“----默认情况下是图标,这样是不会显示表格的,所以这里需要选择报告形式 第三步:创建列表框的成员变量, 这里需要注意的是:列表框的成员变
  • JS设置下拉列表框当前所选值

    千次阅读 2013-12-15 17:06:43
    function setSelectOption(objId, targetValue){ //objid:下拉列表框的ID;targetValue:当前所选值  var obj = document.getElementById(objId);  if(obj){  var options = obj.options;  if(options){
  • 【原创】带你玩转超级列表框(全套教程目录)讲师:雪山凌狐... 带你玩转超级列表框 2 常用属性设置  主要说了超级列表框属性 或者说 和 我门自己总结的 使用
  • MFC创建列表框&&及添加表格的方法

    千次阅读 2016-01-02 10:33:29
    第二步:设置列表框属性,在样式,选择“报告“----默认情况下是图标,这样是不会显示表格的,所以这里需要选择报告形式 第三步:创建列表框的成员变量, 这里需要注意的是:列表框的成员变量名一般是...
  • 列表框控件

    千次阅读 2005-04-27 16:28:00
    列表框控件(listbox) [下载例程] 列表框主要用于输入,它允许用户从所列出的表项中进行单项或多项选择,被选择...对于列表项的选择, 应用程序用CreateWindowEx创建列表框控件时,可根据控件的用途在下表选择部份
  • 组合框和列表框都可以在界面上同时显示多项内容,并且允许用户选中其中的某项内容列表框还允许同时选择多项。这两种控件的使用,有很多相似之处;2.3.1 技术要点: Windows 预先定义了一系列“CB_ ”开头的消息...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 450,142
精华内容 180,056
关键字:

列表框中的列表内容通过()属性设置