精华内容
下载资源
问答
  • 编辑框内容到超级列表框表项写法 编辑框内容到超级列表框表项写法 编辑框内容到超级列表框表项写法编辑框内容到超级列表框表项写法
  • 本课视频通过5种方法实现了易语言组合框添加不重复文本到列表框。 易语言组合框添加不重复文本到列表框视频交教程源码: .版本 2 .子程序 _按钮1_被单击 .局部变量 文本, 文本型 文本 = 组合框1.内容 .如果...

    本课视频通过5种方法实现了易语言组合框添加不重复文本到列表框。

    易语言组合框添加不重复文本到列表框视频交教程源码:

    .版本 2
    
    .子程序 _按钮1_被单击
    .局部变量 文本, 文本型
    
    文本 = 组合框1.内容
    
    .如果 (列表框查找文本 (列表框1, 文本) = 真)
    列表框1.加入项目 (组合框1.取项目文本 (组合框1.现行选中项), )
    .否则
    
    .如果结束
    
    .子程序 列表框查找文本, 逻辑型
    .参数 列表框, 列表框
    .参数 要加入的文本, 文本型
    .局部变量 i, 整数型
    
    .计次循环首 (列表框.取项目数 (), i)
    .如果真 (要加入的文本 = 列表框.取项目文本 (i - 1))
    返回 (假)
    .如果真结束
    .计次循环尾 ()
    返回 (真)
    
    .子程序 _按钮2_被单击
    .局部变量 文本, 文本型
    
    文本 = 组合框1.内容
    
    .如果 (列表框加入项目 (列表框1, 文本) = 真)
    信息框 (“加入成功”, 0, , )
    .否则
    信息框 (“该文本【” + 文本 + “】已经存在,不要重复加入”, 16, , )
    .如果结束
    
    .子程序 列表框加入项目, 逻辑型
    .参数 列表框, 列表框
    .参数 要加入的文本, 文本型
    .局部变量 i, 整数型
    
    .计次循环首 (列表框.取项目数 (), i)
    .如果真 (要加入的文本 = 列表框.取项目文本 (i - 1))
    返回 (假)
    .如果真结束
    
    .计次循环尾 ()
    列表框.加入项目 (要加入的文本, )
    返回 (真)
    
    .子程序 _按钮3_被单击
    
    .如果 (列表框1.选择 (组合框1.取项目文本 (组合框1.现行选中项)) = -1)
    列表框1.加入项目 (组合框1.取项目文本 (组合框1.现行选中项), )
    
    .否则
    
    .如果结束
    
    .子程序 _按钮4_被单击
    .局部变量 文本, 文本型
    
    文本 = 组合框1.内容
    
    .如果 (SendMessageA (列表框1.取窗口句柄 (), 399, 0, 文本) = -1)
    列表框1.加入项目 (组合框1.取项目文本 (组合框1.现行选中项), )
    
    .否则
    信息框 (“该文本【” + 文本 + “】已经存在,不要重复加入”, 16, , )
    .如果结束
    
    .子程序 _按钮5_被单击
    .局部变量 项目数量
    .局部变量 i
    
    项目数量 = 列表框1.取项目数 ()
    .判断开始 (项目数量 = 0)
    列表框1.加入项目 (组合框1.取项目文本 (组合框1.现行选中项), )
    .判断 (项目数量 > 0)
    .计次循环首 (项目数量, i)
    .如果 (寻找文本 (列表框1.取项目文本 (i - 1), 组合框1.取项目文本 (组合框1.现行选中项), , 假) ≠ -1)
    返回 ()
    
    .否则
    
    .如果结束
    
    .计次循环尾 ()
    列表框1.加入项目 (组合框1.取项目文本 (组合框1.现行选中项), )
    
    .默认
    
    .判断结束

    源码:511遇见易语言教程

               511遇见易语言教程视频链接

               易语言组合框添加不重复文本到列表框

     

     

    展开全文
  • 在文本框中输入内容,点击“添加”按钮后添加到列表框中;点击“删除”按钮则从列表框中删除选中的元素。 protected void Button1_Click(object sender, EventArgs e) { // ListBox1.Text= TextBox1.Text+ ...

    在文本框中输入内容,点击“添加”按钮后添加到列表框中;点击“删除”按钮则从列表框中删除选中的元素。

    protected void Button1_Click(object sender, EventArgs e)
            {
                // ListBox1.Text= TextBox1.Text+ ListBox1.Text;
                this.ListBox1.Items.Add(TextBox1.Text);
            }
    
    protected void Button2_Click(object sender, EventArgs e)
            {
                string checkobject = this.ListBox1.SelectedItem.ToString();
                this.ListBox1.Items.Remove(checkobject);
            }

     

    展开全文
  • CListCtrl 添加编辑框,下拉列表框,时间控件 CListCtrl 添加编辑框,下拉列表框,时间控件
  • 本课视频通过四种方法实现了易语言列表框去重复项目到列表框。 易语言列表框去重复项目到列表框视频教程源码: .版本 2 .程序集 窗口程序集_启动窗口 .子程序 __启动窗口_创建完毕 皮肤_加载 (1) .子程序 _...

    本课视频通过四种方法实现了易语言列表框去重复项目到列表框。

    易语言列表框去重复项目到列表框视频教程源码:

    .版本 2
    
    .程序集 窗口程序集_启动窗口
    
    .子程序 __启动窗口_创建完毕
    
    皮肤_加载 (1)
    
    .子程序 _按钮1_被单击
    .局部变量 项目文本, 文本型
    
    项目文本 = 列表框1.取项目文本 (列表框1.现行选中项)
    .如果 (列表框查找文本 (列表框2, 项目文本) = 真)
    列表框2.加入项目 (项目文本, )
    .否则
    
    .如果结束
    
    .子程序 列表框查找文本, 逻辑型
    .参数 列表框, 列表框
    .参数 要加入的文本, 文本型
    .局部变量 I, 整数型
    
    .计次循环首 (列表框.取项目数 (), I)
    .如果真 (要加入的文本 = 列表框.取项目文本 (I - 1))
    返回 (假)
    .如果真结束
    
    .计次循环尾 ()
    返回 (真)
    
    .子程序 _按钮2_被单击
    .局部变量 列表框1内容, 文本型
    
    列表框1内容 = 列表框1.取项目文本 (列表框1.现行选中项)
    .如果 (列表框2.选择 (列表框1内容) = -1)
    列表框2.加入项目 (列表框1内容, )
    .否则
    
    .如果结束
    
    .子程序 _按钮3_被单击
    .局部变量 项目, 文本型
    
    项目 = 列表框1.取项目文本 (列表框1.现行选中项)
    
    .如果 (列表框加入项目 (列表框2, 项目) = 真)
    信息框 (“项目添加成功”, 0, , )
    .否则
    
    .如果结束
    
    .子程序 列表框加入项目, 逻辑型
    .参数 列表框, 列表框
    .参数 要加入的文本, 文本型
    .局部变量 n, 整数型
    
    .计次循环首 (列表框.取项目数 (), n)
    .如果真 (要加入的文本 = 列表框.取项目文本 (n - 1))
    返回 (假)
    .如果真结束
    
    .计次循环尾 ()
    列表框.加入项目 (要加入的文本, )
    返回 (真)
    
    .子程序 _按钮4_被单击
    .局部变量 项目, 文本型
    
    项目 = 列表框1.取项目文本 (列表框1.现行选中项)
    .如果 (SendMessageA (列表框2.取窗口句柄 (), 399, 0, 项目) = -1)
    列表框2.加入项目 (项目, )
    信息框 (“项目添加成功!”, 0, , )
    
    .否则
    信息框 (“已经存主【” + 项目 + “】请不要重复添加!”, 16, , )
    
    .如果结束

    源码:511遇见易语言教程

               511遇见易语言教程视频链接

               易语言列表框去重复项目到列表框

     

    展开全文
  • C# 获得串口名添加到列表框

    千次阅读 2015-01-04 12:34:03
    public Form1() { InitializeComponent(); //portsArray数组获得所有串口列表 string[] portsArray = SerialPort.GetPortNames(); //把获得的串口名添加到列表框






            public Form1()
            {
                InitializeComponent(); 
      
                //portsArray数组获得所有串口列表
                string[] portsArray = SerialPort.GetPortNames(); 
    
                //把获得的串口名添加到列表框
                foreach (string portnumber in portsArray)
                {
                    comboBox_Com.Items.Add(portnumber);
                }          
            }
    
            private void button_Open_Click(object sender, EventArgs e)//打开串口按钮
            {
                if (!mySP.IsOpen)
                {
                    mySP.PortName = comboBox_Com.SelectedItem.ToString();//串口名
                    mySP.BaudRate = (int)19200;
                    mySP.DataBits = (int)8;
                    mySP.Parity = Parity.None;
                    mySP.StopBits = StopBits.One;
                    mySP.Open();
                    button_Open.Text = "close";//按钮显示关闭
    
                }
                else
                {
                    mySP.Close();
                    //MessageBox.Show("Err:Open Comm Port");
                    button_Open.Text = "open";
                }  
            }


    展开全文
  • 向工作添加列表框或组合框

    千次阅读 2012-05-04 10:29:40
    添加列表框(表单控件) 如果“开发工具”选项卡未显示,请显示它。 显示“开发工具”选项卡 单击“Office 按钮” ,然后单击“Excel 选项”。 在“常用”类别中的“使用 Excel 时采用的首选项”下,...
  • 易语言组合框去重复到列表框

    千次阅读 2019-12-08 19:15:51
    在辅助开发时,我们需要通过组合框控制一些功能,或者获取一些数据,比如把组合框里 的值添加到列表框,这里就需要去除重复的,以下代码实现了这个功能。 .版本 2 .支持库 spec .支持库 EDataStructure .程序集 ...
  • 本节视频通过三种方法实现了防止项目重复加入列表框。 易语言列表框防止项目重复加入列表框视频教程源码: .版本 2 .程序集 窗口程序集_启动窗口 .子程序 __启动窗口_创建完毕 列表框1.现行选中项 = 0 ...
  • 给组合框或列表框添加元素一、RowSource属性添加元素二、为工作中的ActiveX控件中的列表框添加元素三、使用list属性添加元素四、使用additem方法添加列表项五、列表框的其他属性 一、RowSource属性添加元素 ...
  • 第一步:向界面中添加列表框控件”,用鼠标拖进来   第二步:设置列表框的属性,在样式中,选择“报告“----默认情况下是图标,这样是不会显示表格的,所以这里需要选择报告形式 第三步:创建列表框...
  • 我要做一个测试软件,要做一个列表框其中要添加复选按钮来选择测试项目要不要执行,这个要怎么做?
  • CListCtrl列表框添加与更改图标

    千次阅读 2012-08-06 10:13:07
    本文转载:... 一、添加图标 首先把列表框的属性中样式设为report样式。然后在给列表框插入列之前执行下面的操作: CBitmap bitmap;  m_Imagelist.Create (16,16,ILC_COLOR24 ,5,1);
  • html页面中要有: 然后在javascript中: var initData = function() { var cbbYear = document.getElementById("playground"); for (var i = 1990; i ; i++) {
  • JavaScript实现下拉列表框添加选项

    千次阅读 2019-10-18 12:40:27
    * @ listItems 要添加到列表框中的列表项数组 */ function addListOption(selectId, listItems) { // 循环遍历数组 for (var item in listItems) { // 获取下拉列表框对象 var select...
  • asp.net动态添加下拉列表框

    千次阅读 2014-12-02 21:26:46
    <p class="pLine"> 添加新链接" /> <asp:TextBox ID="txt_links" runat="server" Height="25px" Width="329px" Visible="false" ></asp:TextBox> .aspx.cs代码如下: using System; using...
  • Axure表单元件:下拉列表框列表框

    千次阅读 2019-12-23 14:43:20
    下拉列表框 1,拖动“下拉列表框”元件至页面中; 2,双击下拉列表框,打开“编辑列表选项” 3,点击“+”增加列,输入...最最根本区别是展示效果,列表框是平铺展示所有内容;下拉列表框只显示一列当前列内容 ...
  • VB中列表框添加与删除项目

    千次阅读 2019-02-11 16:50:17
  • JSP 下拉列表框、多行下拉列表框

    千次阅读 2014-07-25 17:24:15
    1、下拉列表框:  语法:
  • C# ListBox:列表框控件

    千次阅读 2019-06-11 22:26:10
    列表框 (ListBox) 将所提供的内容以列表的形式显示出来, 并可以选择其中的一项或多项内容,从形式上比使用复选框更好一些。 列表框中常用属性: ... 例如Items.Add方法用于向列表框添加项,...
  • 在Jcombox里需要用到一个带选择的Jtree组件,该怎么来实现?求大神解救。
  • MFC中创建列表框&&及添加表格的方法

    千次阅读 2016-01-02 10:33:29
    第一步:向界面中添加列表框控件”,用鼠标拖进来   第二步:设置列表框的属性,在样式中,选择“报告“----默认情况下是图标,这样是不会显示表格的,所以这里需要选择报告形式 第三步:创建列表框的...
  • 在jQuery中将左右两个列表框内容相互移动,移动的同时进行删除,这里只是给大家写一个入门的小案例,今后写相同的功能思路也是一样的。仅供新手们的一个参考。希望能给那些跟我一样在菜鸟路上不断奋斗的人一些灵感...
  • C#——列表框(listbox)的体验添加

    千次阅读 2014-11-06 15:02:06
    *文件名称:C#——列表框(listbox)的体验添加 *作者:杨飞 *完成日期:2014年9月2日 *版本号:v1.0 *对任务及求解方法的描述部分:C#——列表框(listbox)的体验添加 *我的程序:*/ using System;
  • C# 列表框

    千次阅读 2017-02-20 15:53:22
    做了一个列表框的小程序 用鼠标指向列表里的项目 比如 橘子,栗子时 文本框会显示 相应的名字 当你在文本框中输入你想添加的东西 再按一下添加按钮 想添加的东西就会进入列表 当你选中列表框中的莫个item 再...
  • Excel VBA ListBox列表框添加和删除问题

    万次阅读 2008-04-04 23:30:00
    Excel VBA 窗体中有两个ListBox,需要做的操作:从一个列表框中选择列表值向另一个列表添加值,以及从已选择的值中删除选择的列表值。 例:ListBox列表 被选框lbData, 选择框lbSelectedData,列表框中显示三列。-...
  • js,根据input框内容实时搜索列表,并添加底色以突出显示js,根据input框内容实时搜索列表,纯前端,下面分三个部分进行展示: 首先,让我们看一下做出来的效果:1.html代码 2.js代码 3.css样式 1.html代码 名称: ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 517,458
精华内容 206,983
关键字:

列表框内容添加到表