精华内容
下载资源
问答
  • 2019-12-08 19:15:51

    在辅助开发时,我们需要通过组合框控制一些功能,或者获取一些数据,比如把组合框里 的值添加到列表框,这里就需要去除重复的,以下代码实现了这个功能。

    .版本 2
    .支持库 spec
    .支持库 EDataStructure
    
    .程序集 窗口程序集_启动窗口
    
    .子程序 _按钮1_被单击
    .局部变量 项目, 文本型
    
    项目 = 组合框1.内容
    .判断开始断 (列表框加入项目 (列表框1, 项目) = 1)
        ' 信息框 (“项目存在了”, 0, , )
    .默认
        ' 列表框1.加入项目 (组合框1.取项目文本 (组合框1.现行选中项), )
        ' 组合框1.现行选中项 = 0
    .判断结束
    调试输出 (组合框1.取项目文本 (组合框1.现行选中项))
    .如果 (查找列表框文本 (列表框1, 项目) = 真)
        列表框1.加入项目 (组合框1.取项目文本 (组合框1.现行选中项), )
    .否则
    
    .如果结束
    
    
    .子程序 列表框加入项目, 逻辑型, , 不重复加入
    .参数 列表框, 列表框
    .参数 欲加入的项目文本, 文本型
    .局部变量 i, 整数型
    
    .计次循环首 (列表框.取项目数 (), i)
        .如果真 (欲加入的项目文本 = 列表框.取项目文本 (i - 1))
            返回 (假)
        .如果真结束
    
    .计次循环尾 ()
    列表框.加入项目 (欲加入的项目文本, )
    返回 (真)
    
    .子程序 去重复, 文本型
    .参数 文本数组, 文本型, 数组
    .局部变量 i, 整数型
    .局部变量 分割数组, 文本型, , "0"
    .局部变量 内容数组, 文本型, , "0"
    .局部变量 n, 整数型
    .局部变量 去重复, 节点
    .局部变量 内容, 文本型
    
    .计次循环首 (取数组成员数 (文本数组), i)
        分割数组 = 分割文本 (文本数组 , “*”, )
        .如果真 (取数组成员数 (分割数组) > 2)
            加入成员 (内容数组, 分割数组 [2])
    
        .如果真结束
    
    .计次循环尾 ()
    .计次循环首 (取数组成员数 (内容数组), n)
        .如果真 (去重复.加入属性 (内容数组 [n], 真))
            内容 = 内容 + 文本数组 [n] + #换行符
        .如果真结束
    
    .计次循环尾 ()
    返回 (内容)
    
    .子程序 _按钮2_被单击, , , 输出列表框旋转项目
    .局部变量 a, 整数型
    
    .计次循环首 (列表框1.取项目数 (), a)
        .如果真 (列表框1.是否被选择 (a - 1))
            调试输出 (列表框1.取项目文本 (a - 1))
        .如果真结束
    
    .计次循环尾 ()
    
    .子程序 子程序_组合框加入项目, 逻辑型, , 重复返回假
    .参数 组合框, 组合框
    .参数 欲加入的项目文本, 文本型
    .局部变量 i, 整数型
    
    .计次循环首 (组合框.取项目数 (), i)
        .如果真 (欲加入的项目文本 = 组合框.取项目文本 (i - 1))
            返回 (假)
        .如果真结束
    
    .计次循环尾 ()
    组合框.加入项目 (欲加入的项目文本, )
    返回 (真)
    
    .子程序 查找列表框文本, 逻辑型, , 查找列表框里的文本是否存在
    .参数 列表框, 列表框
    .参数 欲加入的项目文本, 文本型
    .局部变量 i, 整数型
    
    .计次循环首 (列表框.取项目数 (), i)
        .如果真 (欲加入的项目文本 = 列表框.取项目文本 (i - 1))
            返回 (假)
        .如果真结束
    
    .计次循环尾 ()
    ' 列表框.加入项目 (欲加入的项目文本, )
    返回 (真)
    
    .子程序 _按钮3_被单击, , , 方法2
    .局部变量 项目, 文本型
    
    项目 = 组合框1.内容
    列表框加入项目 (列表框1, 项目)
    
    .子程序 _按钮4_被单击

     

    更多相关内容
  • 易语言超级列表框可编辑模块源码 系统结构:初始化,获取表头高度,被双击,显示编辑框,隐藏编辑框,GetItemTop,消息钩子回调,GetWindowRect,SendMessage,ReleaseCapture,SetCapture,GetScrollPos,SetWindowLong,C
  • 列表框和组合框的区别是什么?

    千次阅读 2021-06-10 17:17:14
    列表框和组合框的区别1、自动排序方式不同:当列表框不能同时显示所有项目的时候,将自动添加滚动条,使用户可以滚动查阅所有选项。组合框的风格取值定义了组合框的具体属性,包括是否自动排序,是否有滚动条。2、...

    e7a18a1cad1a47a1114805dbd31007eb.png

    列表框和组合框的区别

    1、自动排序方式不同:

    当列表框不能同时显示所有项目的时候,将自动添加滚动条,使用户可以滚动查阅所有选项。组合框的风格取值定义了组合框的具体属性,包括是否自动排序,是否有滚动条。

    2、项目输入方式不同:

    列表框是显示一系列项供用户选择的控件,对选中的项可以进行后续的处理。用户选择可以是多项的。组合框是一个编辑框带一个可以下拉的列表框,用户在下拉框中选择的项会进入编辑框中,再进行后续处理,在编辑框中也可以直接输入。

    3、数据类型不同:

    在组合框中有Simple、Dropdown、Drop List三种类型。Simple类型的组合框和列表框部分是固定显示的,不能下拉;而其余两种带一个下拉手柄。设计中别忘记添加滚动条。Dropdown与Drop List的区别是后者的编辑框不能输入。

    在列表框中有Simple、 Multiple、Extended三种类型,它们决定了用户选取项的方法。Simple模式只能够选取单项,Multiple模式可以按Ctrl键+鼠标左键选取多个项,而Extended则可以通过鼠标拖处矩形一次选取连续的项,也可以加按Ctrl键作多次选择。

    想要了解更多相关知识,请关注 html中文网!!

    展开全文
  • 易语言报表式超级列表框源码,报表式超级列表框,初始化,属性_置列类型,属性_取列类型,方法_复制组件,方法_自动调节列宽,内部_取数组非空成员数,属性_置组合框高度,事件_主超级列表框_被双击,事件_主超级列表框_鼠标...
  • LabVIEW的组合框

    2021-01-19 23:07:04
    组合框控件类似于文本型或菜单型下拉列表框,不同的是组合框控件是字符串类型的数据,而菜单型下拉列表框是数值类型的数据。  右键单击组合框控件,在弹出的快捷菜单中选择“编辑项...”进入字符串编辑对话框,或...
  • 组合框控件类似于文本型或菜单型下拉列表框,不同的是组合框控件是字符串类型的数据,而菜单型下拉列表框是数值类型的数据。  右键单击组合框控件,在弹出的快捷菜单中选择“编辑项...”进入字符串编辑对话框,或...
  • 列表框和组合框 列表框是CListBox类的对象,组合框是CComboBox的对象。 列表框 属性设置 列表框的重要属性有: Selection 该属性决定用户的选择方式,缺省值为 Single 。属性值有: ①:Single ── 单项...
    上一篇:MFC界面编程基础(12):组框、单选按钮和复选框下一篇:MFC界面编程基础(14):滚动条

    列表框和组合框

    列表框是CListBox类的对象,组合框是CComboBox的对象。

    列表框

    • 属性设置
      列表框的重要属性有:
    • Selection
      该属性决定用户的选择方式,缺省值为 Single 。属性值有:
      ①:Single ── 单项选择
      ②:Multiple ── 多项选择,但是忽略 Ctrl 和 Alt 键。
      ③:Extended ── 允许使用 Ctrl 和 Alt 进行多项选择
      ④:None ── 禁止选择
      在这里插入图片描述
    • Sort
      当该属性被设置为True后,列表框中的选项按字母顺序排列。
      在这里插入图片描述
    • 常用成员函数
    • 添加项目
      格式: int AddString( LPCTSTR lpszItem );
      例如:语句 m_l. AddString(" 陈蓉 ") ; 把“陈蓉”添加到了列表框 m_l 中。
    • 删除项目
      格式: int DeleteString( UINT nIndex );
      说明: nIndex 表示被删除项目在列表框中的位置,对于第一个选项nIndex应为 0 。
      例如:语句 m_l. DeleteString (4) ;删除列表框中的第 5 个项目。
    • 获取当前被选定的项目的序号
      格式: int GetCurSel( ) const;
      例如:语句int I=m_l.GetCurSel(); 将使I 获得 m_l 列表框中当前选定的项目的序号。
    • 获取列表框中指定的项目
      格式 1 : int GetText( int nIndex, LPTSTR lpszBuffer ) const;
      格式 2 : void GetText( int nIndex, CString& rString ) const;
      说明 :将列表框中第 nIndex 个选项的文本送到 lpszBuffer 或 rString 中。
      例如:假定有说明语句 char s1[20]; CString s2;则语句 m_l.GetText(4, s1); 和 m_l. GetText(4, s2); 把第 5 项内容分别送到 s1 和 s2 中。

    【例】

    编写一个能对列表框进行项目添加、修改和删除操作的应用程序,如图所示。“添加”按钮的功能是将文本框中的内容添加到列表框,“删除”按钮的功能是删除列表框中选定的选项。如果要修改列表框,则首先选定选项,然后单击“修改”按钮,所选的选项显示在文本框中,当在文本框中修改完之后再单击“修改确定”按钮更新列表框。
    在这里插入图片描述

    • 界面设计
      首先创建一个对话框应用程序框架,然后放置按钮。列表框和命令按钮按表连接变量,其余控件不需要连接变量。
      在这里插入图片描述
    • 初始化
      列表框的选项在对话框的初始化函数中用 AddString 函数添加。
    BOOL CTESTDlg::OnInitDialog() 
    { 
    	┆ 
    	// TODO: Add extra initialization here 
    	m_l.AddString(" 大学计算机基础 "); 
    	m_l.AddString("C/C++ 程序设计 "); 
    	m_l.AddString("VB 程序设计 "); 
    	m_l.AddString(" 软件技术基础 "); 
    	┆ 
    } 
    
    • 消息处理函数
    …………………………………………………………
    void CTESTDlg::OnButton1() // 选择“添加”后执行的函数 
    { 
     // TODO: Add your control notification handler code here 
     UpdateData(TRUE); 
     m_l.AddString(m_e); 
     m_e=""; 
     UpdateData(FALSE); 
    } 
    …………………………………………………………
    void CTESTDlg::OnButton2() // 选择“删除”后执行的函数 
    { 
     // TODO: Add your control notification handler code here 
     int n=m_l.GetCurSel(); 
     m_l.DeleteString(n); 
    } 
    …………………………………………………………
    void CTESTDlg::OnButton3() // 选择“修改”后执行的函数 
    { 
     // 将选定的项目送编辑框供修改 
     // TODO: Add your control notification handler code here 
     CString s; 
     int n=m_l.GetCurSel(); 
     m_l.GetText(n,s); 
     m_e=s; 
     UpdateData(FALSE); 
    } 
    …………………………………………………………
    void CTESTDlg::OnButton4() // 选择“确定修改”后执行的函数 
    { 
     // 将修改后的项目送回列表框中,替换原项目,实现修改。 
     // TODO: Add your control notification handler code here 
     UpdateData(TRUE); 
     int n=m_l.GetCurSel(); 
     m_l.DeleteString(n); 
     m_l.InsertString(n,m_e); 
     m_e=""; 
     UpdateData(FALSE); 
    } 
    …………………………………………………………
    

    组合框

    • 属性设置

    • 种类( Type )
      该属性用于指定组合框的类型,共有三个选择: Simple 、 Dropdown 和 Droplist ,默认值为 Dropdown 。
      在这里插入图片描述

    • 键入列表框项( Enter listbox items )
      在列表框的属性窗口有一个“ Data ”属性,这是在设计阶段输入选项的地方,如图所示。输入每一项都需要用分号分隔
      在这里插入图片描述

    • 常用成员函数
      编辑框和列表框的成员函数几乎都可以用于组合框,但是列表框的成员函数 GetText() 在组合框中的是 GetLBText()

    • int GetLBText( int nIndex, LPTSTR lpszText ) const;

    • void GetLBText( int nIndex, CString& rString ) const;
      说明 :使用 GetLBText 函数可以将组合框中的第 nIndex 个项目的文本送入 lpszText 或 rString 中。

    • 组合框发出的消息

    • CBN_SELECTCHANGE :组合框的列表框中的选项改变时发送

    • CBN_EDITCHANGE :组合框的编辑框中文本改变时发出

    【例】

    设计一个如图所示的对话框。如果单击“确定”按钮,则用 MessageBox 显示如图所示的信息框。
    在这里插入图片描述

    • 首先创建一个对话框程序框架,然后放置各控件,进行属性设置,组合框的选项在设计阶段直接输入,按表连接变量,其余控件不需要连接变量。

    在这里插入图片描述

    • 消息处理函数
    void CTESTDlg::OnButton1() 
    { 
     // TODO: Add your control notification handler code here 
     UpdateData(TRUE); 
     CString s; 
     s=" 品牌 :"; 
     s=s+m_c; 
     s=s+"\n"; 
     s=s+" 数量 :"; 
     s=s+m_e; 
     MessageBox(s); 
    }
    
    上一篇:MFC界面编程基础(12):组框、单选按钮和复选框下一篇:MFC界面编程基础(14):滚动条
    展开全文
  • 16.3 组合框列表框;组合框也称为选择列表(choice list)或是下拉列表(drop-down list),它包含一个条目列表,用户能从中进行选择。 属性是从JComponent等父辈继承来的。 构造方法与一般方法: JComboBox() ...
  • 列表框的selected属性

    千次阅读 2021-06-10 17:17:36
    Φ是什么意思?读"fai".是直径的意思不?...而用作列表框和组合框有没有select属性列表框有selected,表示是否选中:If List1.Selected(i) Then 组合框只允许选一个,没有select,Combo1.ListIndex即为当前选中...

    Φ是什么意思?读"fai".是直径的意思不?

    “Φ”是数学中表示圆的直径的希腊字母。 “Φ”是希腊字母中的一个,读作fai,其写法分为两种,大写:Φ,小写:φ,小写时左上角的弯是开口的;而用作

    列表框和组合框有没有select属性

    4c9bc99dde5846b4eccc572c8d01b153.png

    列表框有selected,表示是否选中:If List1.Selected(i) Then 组合框只允许选一个,没有select,Combo1.ListIndex即为当前选中的项

    html 里select 下拉列表中设置默认值怎么写

    &nbsp设置下拉列表框的默认值:使用关键字selected < select name = "pronvince"> < option value ="SH">上海 < option value ="BJ">北京 < option value ="JS">江苏 < option value ="HB" selected="selected">湖北 < option value ="ZJ">浙江 如果希

    怎样用js取得select下拉列表框内选中的option的val1

    急vb里,列表框有list ,selected,text,listcou...想请教VB里的高手,至少比我强的 我一直不怎么会LISTBOX的代码编写 谢啦。list 返回某一项的内容,如 print list1.list(0) selected 判断某项是否被选定 text 返回某一项的内容 一般用于list1_click中 listcount 返回list中一共有多少项 参考。。

    html中下拉列表框中的全部属性

    1.下拉框当前选中项目 obj.selectedIndex 2.下拉框项目数 obj.length 3.下拉框第N项的值 obj.options[N-1].value 4.下拉框第N项的“描述值” obj.options[N-1].text 5.选中第N项 obj.options[N-1].selected = true; =false;即为不选中 6.在末尾增

    ligerui list getselecteditems列表框怎么获取到选问1:在action里写Xname的getset方法只3,要action被触发,jsp页面上的select就把选中的值传到Xname里了。注意里存的是一个Map类型的一个key对应一个value。key和value在后台都是能够拿到的具体用哪个标签看一下struts2的文档,很详细。

    如何判断asp中下拉列表框是选的那个选项

    大米是5.6黄豆是6.3 如何在第一个选择之后 ,线面的菜单直接显示??

    asp下拉列表框怎么实现在asp当中如果选择了一个列表框中的值后,当比如在同一页中按了我可以给你思路,具体代码你自己写:

    添加一个INPUT,类型为HIDDEN,目标action为当前页。

    添加JAVASCRIPT代码,事件为列表框onchange,将选定value赋值给HIDDEN.

    同一页面最上面添加表单的提取代码

    紧急CSS布局HTML小编今天和大家分享助:jsp提交表单查询后,下拉列表框(SELECT我想在提交包含班级和学生和学期查询条件的表单(form)后,由struts处建议你试一试strust 标签

    展开全文
  • vb学习总结, 列表框  1、属性  1、columns  该属性用来确定列表的列数。当该属性设置为0(默认)是,所用的项目呈单列显示。...list属性保存了列表框中所有值得数组,可以通过下标访问数组中的值(下标值从
  • 组合框和列表框都可以在界面上同时显示多项内容,并且允许用户选中其中的某项内容,列表框还允许同时选择多项。这两种控件的使用,有很多相似之处;2.3.1 技术要点: Windows 中预先定义了一系列“CB_ ”开头的消息...
  • 易语言组合框基本属性方法事件

    千次阅读 2020-07-08 09:09:11
    本节视频教程录制了易语言组合框的取项目数、取项目数值、取项目文本、置项目文本、加入项目、插入项目、删除项目等属性组合框基本属性方法事件截图 视频链接: 76 属性: 左边 顶边 ...
  • html 下的列表框和组合框

    千次阅读 2019-12-06 11:17:40
    <html> <head> <title> New Document </title> <meta http-equiv="Content-Type" content="text/html; charset=utf-8" /> </head>...//加上 size 属性,combox...
  • 组合框和复选框

    2021-06-10 17:55:37
    组合框和列表框的区别如下:自动排序方式不同: 当列表框不能同时显示所有项目时候,将自动添加滚动条,使用户可以滚动查阅所有选项。组合框的风格取值定义了组合框的具体属性,包括是否自动排序,是否有滚动条。...
  • VC++60 第十二章 列表框和组合框

    千次阅读 2016-10-13 17:49:48
    第十二章 列表框和组合框   列表框是显示一系列项供用户选择的控件,对选中的项可以进行后续的处理。用户选择可以是多项的,但本章的例程设计为单选的。组合框是一个编辑框带一个可以下拉的列表框,用户在...
  • 1.可分别设置组合框中编辑框下拉列表框的字体、字体颜色、字体大小 2.可设置只读属性 3.可根据下拉列表项的文本长度扩宽下拉列表宽度 4.重绘下拉列表,包括边框和具有焦点的项 5.下拉列表项中提供了删除功能,非...
  • axure下拉列表框单选框First, let’s clarify what exactly is a dropdown menu, and what is a combo box, aren’t they the same? Well … no, not really, let me explain. 首先,让我们弄清楚什么是下拉菜单,...
  • 列表框是CListBox类的对象,组合框是CComboBox的对象,滚动条是 CScrollBar 类...在组合框(Combo Box)的属性窗口有一个“ Data ”属性,这是在设计阶段输入选项的地方,输入每一项需要用分号分隔。 CBN_EDITCHA...
  • java:下拉列表框组件

    千次阅读 2022-04-19 22:25:32
    下拉列表框组件一、关键代码一)、创建单个下拉列表框的内容(项)二)、字符串数组添加多个下拉列表框的内容(项)三)、模型方法给下拉列表框添加内容(项)二、简单说明三、流程图四、源码一)、源码A二)、源码A...
  • 组合框列表框添加元素一、RowSource属性添加元素二、为工作表中的ActiveX控件中的列表框添加元素三、使用list属性添加元素四、使用additem方法添加列表项五、列表框的其他属性 一、RowSource属性添加元素 ...
  • 列表框和组合框的使用

    万次阅读 2010-06-24 15:21:00
    列表框是显示一系列项供用户选择的...   本章要点 1 列表框的设计、项的添加删除 2 组合框的设计使用   12.1 ListCombo程序运行时的界面功能     chap
  • 组合框绑定数据源.rar

    2010-07-01 12:58:50
    组合框绑定数据源.rar组合框绑定数据源.rar组合框绑定数据源.rar
  • Access-控件解析-组合框-01-下拉列表

    千次阅读 2019-04-03 20:35:44
    微信公众号原文 系统:Windows 7 软件:Excel 2010 / Access 2010 这个系列介绍常用的控件 ...手动设置组合框下拉列表:长江;黄河;珠江;淮河 通过代码修改组合框下拉列表:1;2;3;4 应用场景,组合框的下拉...
  • 列表框组合框

    千次阅读 2010-04-08 15:54:00
    如果项目总数超过了列表框可显示的项目数,列表框会自动添加滚动条,可以方便用户以滚动的方式来选择列表框列表框的常用属性·listcount属性:用于返回列表框中的所有选项的个数,该属性只能在程序代码中调用设置...
  • 向工作表中添加列表框组合框

    千次阅读 2012-05-04 10:29:40
    添加列表框(表单控件) 如果“开发工具”选项卡未显示,请显示它。 显示“开发工具”选项卡 单击“Office 按钮” ,然后单击“Excel 选项”。 在“常用”类别中的“使用 Excel 时采用的首选项”下,...
  • 组合框控件ComboBox

    千次阅读 2021-06-08 22:52:59
    1、组合框属性 组合框属性 说明 DropDownStyle 获取或设置指定组合框样式的值,可取以下值之一。①DropDown (默认值):文本部分可编辑,用户必须单击箭头按钮来显示列表部分。②DropDownList:用户不能...
  • C# ComboBox:组合框控件

    千次阅读 2019-06-11 23:19:40
    在C#WinForm开发中组合框(ComboBox)控件也称下拉列表框, 用于选择所需的选项,例如在注册学生信息时选择学历、专业等。 使用组合框可以有效地避免非法值的输入。 在组合框中也有一些经常使用的属性,如下表所...
  • 窗体上建立一个简单组合框,在组合框的文本框输入数字字符,按回车键后加入到组合框列表框内,如图E.8所示;单击“交换”按钮,将列表框中最小值项目第0个项目交换;最大值与最后项目交换,如图所示: 提示...
  • MFC 组合框(下拉框) CComboBox

    千次阅读 2018-11-03 20:28:07
    常用属性设置: 属性 含义 data 设置内容,不同内容间用英文的分号“;”分隔 type 显示风格 Sort True 内容自动排序 常用...
  • 一、允许多项选择 代码如下 Private Sub UserForm_Initialize() arr = Sheets("产品表").Range("a1").CurrentRegion ... '设置列表框属性 .List = arr .MultiSelect = fmMultiSelectExtended ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 130,493
精华内容 52,197
关键字:

列表框和组合框都具有的属性