精华内容
下载资源
问答
  • 超级列表框设置表头背景颜色源码子类化超级列表框ListView(注意不是表头),在WM_DRAWITEM 消息下进行重绘;但刚开始我们发现根本接收不到WM_DRAWITEM 消息。原来我们还缺少这一步,我们要将ListView的Header 的...
  • 易语言超级列表框高亮显示部分内容源码,超级列表框高亮显示部分内容,消息处理,创建字体_,GetDC,ReleaseDC,SetBkMode,TextOutA,SelectObject,SetWindowLongA,SetTextColor,CreateFontA,CallWindowProc
  • 源码可以让超级列表框文本颜色和背景颜色自行搭配。
  • 设置超级列表框颜色.EC 易语言 设置超级列表框颜色.EC
  • mfc 列表框行颜色设置方法

    千次阅读 2019-09-11 14:04:15
    指定改变CListCtrl中某一行的颜色,比如说刚添加进去的一行,让它改变颜色,这样记录多了,容易看到自己刚刚加入的行,方便操作可查看,也可以让添加和...新建一个mfc 对话框工程,并添加列表框控件,添加一些数据...

    指定改变CListCtrl中某一行的颜色,比如说刚添加进去的一行,让它改变颜色,这样记录多了,容易看到自己刚刚加入的行,方便操作可查看,也可以让添加和修改的记录显示不一样的颜色,方便的多了,VC自带的没有这种功能。

    虽然说自带没有这个功能,但可以用NU_CUSTOMDRAW

    我的环境是vc2010, 听说vc6 没有,需要手动添加。

    新建一个mfc 对话框工程,并添加列表框控件,添加一些数据,让他能正常显示一个列表框的表格。这个时候还不能设置行颜色。

    添加改变颜色的事件

    打开MFC Class Wizard ,用如下方式添加列表框(我的是IDC_LIST2)的NU_CUSTOMDRAW事件,

    然后把代码加入如下: 

    void CListCtrlTestDlg::OnCustomdrawList2(NMHDR *pNMHDR, LRESULT *pResult)
    {
    	//LPNMCUSTOMDRAW pNMCD = reinterpret_cast<LPNMCUSTOMDRAW>(pNMHDR);
    	// TODO: Add your control notification handler code here
    	//pNMCD->clrTextBk = RGB(51, 153, 255);
    	//pNMCD->clrText = RGB(255, 255, 255);
    	//*pResult = 0;
    
    	LPNMLVCUSTOMDRAW  lplvcd = (LPNMLVCUSTOMDRAW)pNMHDR;
        *pResult = 0;
    	//return ;
    
    switch(lplvcd->nmcd.dwDrawStage)
    {
    	case CDDS_PREPAINT :
    		*pResult = CDRF_NOTIFYITEMDRAW;
    		break;
    	case CDDS_ITEMPREPAINT:
    		*pResult =CDRF_NOTIFYSUBITEMDRAW;
    	break;
    	case CDDS_SUBITEM | CDDS_ITEMPREPAINT:
    		if(lplvcd->nmcd.dwItemSpec==0)
    		{
    		lplvcd->clrTextBk = RGB(255,0,0); //红色
    		}
    		if(lplvcd->nmcd.dwItemSpec==1)
    		{
    		lplvcd->clrTextBk = RGB(0,255,0); //绿色
    		}
    		if(lplvcd->nmcd.dwItemSpec==2)
    		{
    		lplvcd->clrTextBk = RGB(0,0,255); //蓝色
    		}
    		if(lplvcd->nmcd.dwItemSpec==3)
    		{
    		lplvcd->clrTextBk = RGB(255,255,0); //黄色
    		}
    		if(lplvcd->nmcd.dwItemSpec==4)
    		{
    		lplvcd->clrTextBk = RGB(160,32,240); //紫色
    		}
    		if(lplvcd->nmcd.dwItemSpec==5)
    		{
    		lplvcd->clrTextBk = RGB(0,255,255); //青色
    		}
    		if(lplvcd->nmcd.dwItemSpec==6)
    		{
    		lplvcd->clrTextBk = RGB(255,97,0); //橙色
    		}
    		if(lplvcd->nmcd.dwItemSpec==7)
    		{
    		lplvcd->clrTextBk = RGB(0,255,127); //嫩绿色
    		}
    		if((lplvcd->nmcd.dwItemSpec)>7)
    		{
    		lplvcd->clrTextBk = RGB(0,0,0); //黑色
    		}
    		*pResult = CDRF_NEWFONT;
    		break;
    	}
    
    }
    

    编译运行结果如下:

    代码解说:

    开始我看到一文,事件产生的代码如下:

        LPNMCUSTOMDRAW pNMCD = reinterpret_cast<LPNMCUSTOMDRAW>(pNMHDR);
        // TODO: Add your control notification handler code here

    后面好像会报错,改为文章代码才好,这个代码是别人用vc6 做的。

    更多属性可以看微软的内容介绍:

    https://docs.microsoft.com/zh-cn/windows/win32/api/commctrl/ns-commctrl-nmlvcustomdraw?redirectedfrom=MSDN

    这个代码只是设置0,1,2,3,4,5,6,7行的颜色,其他行都为黑色。当然只是演示功能的需要。

    这里customdraw有几个阶段。

    switch(lplvcd->nmcd.dwDrawStage) 就是判断阶段,只是在

    case CDDS_SUBITEM | CDDS_ITEMPREPAINT:  才设置背景颜色。

    其他阶段不要做。

    展开全文
  • 首先将属性-是否有检查框设置成真。(最好也将类型设置成报表列表框,不然无法显示报表列,同时选择框也不能按列放置) 代码 .版本 2 .支持库 iext .程序集 窗口程序集_启动窗口 .子程序 __启动窗口_创建完毕 ....

    属性

    首先将属性-是否有检查框设置成真。(最好也将类型设置成报表列表框,不然无法显示报表列,同时选择框也不能按列放置)

    代码

    .版本 2
    .支持库 iext
    
    .程序集 窗口程序集_启动窗口
    
    .子程序 __启动窗口_创建完毕
    .局部变量 i, 整数型
    
    超级列表框1.插入列 (, , , , , )
    .计次循环首 (10, i)
        超级列表框1.插入表项 (, 到文本 (i), , , , )
        超级列表框1.置状态图片 (i - 1, 选择 (超级列表框1.取当前状态图片 (i - 1) = 0, 1, 0))
    .计次循环尾 ()
    

    如下图:

    易语言 超级列表框 设置选中状态-选择框的 方法

    运行效果:

    易语言 超级列表框 设置选中状态-选择框的 方法

    解释

    置状态图片:

    设置指定表项的状态图片。如果“是否有检查框”属性为真,调用“置状态图片 (表项索引, 0)”或“置状态图片 (表项索引, 1)”可以设置表项检查框的选中状态(前者为不选中,后者为选中)。

    取当前状态图片:

    取回指定表项的当前状态图片索引,图片索引指向状态图片组属性中的某一图片,从 0 开始,-1 表示无图片。如果“是否有检查框”属性为真,返回值是当前检查框的选中状态,1表示被选中,0表示未选中。

    更多

    判断是否表项选中:

    .版本 2
    .支持库 iext
    
    .子程序 _按钮1_被单击
    .局部变量 文本, 文本型
    .局部变量 i, 整数型
    
    .计次循环首 (超级列表框1.取表项数 (), i)
        .如果真 (超级列表框1.取当前状态图片 (i - 1) = 1)
            编辑框1.内容 = 编辑框1.内容 + “表项” + 到文本 (i) + “被选中” + “    ”
        .如果真结束
    
    .计次循环尾 ()
    

    易语言 超级列表框 设置选中状态-选择框的 方法

    实际运行效果:
    易语言 超级列表框 设置选中状态-选择框的 方法

    添加全选取消全选功能:

    在启动窗口添加一个“选择框”,并将属性-选中设置为“真”

    .版本 2
    .支持库 iext
    
    .子程序 _选择框1_被单击
    .局部变量 i, 整数型
    
    .如果 (选择框1.选中 = 真)
        .计次循环首 (超级列表框1.取表项数 (), i)
            超级列表框1.置状态图片 (i - 1, 1)
        .计次循环尾 ()
    
    .否则
        .计次循环首 (超级列表框1.取表项数 (), i)
            超级列表框1.置状态图片 (i - 1, 0)
        .计次循环尾 ()
    
    .如果结束
    

    易语言 超级列表框 设置选中状态-选择框的 方法

    取消全选后的效果:

    易语言 超级列表框 设置选中状态-选择框的 方法

    其他

    视频教程: https://www.eyuyan.tv/p1289

    展开全文
  • MFC 下拉列表框设置

    千次阅读 2019-11-06 10:33:27
    设置下拉列表框: 步骤1:打开VS2015,新建项目工程,选择模块下的Visual C++-->MFC-->MFC应用程序,设定好项目文件名和路径,点击确定。 步骤2:进入应用程序类 型界面。勾选“基于对话框”,在“MFC的...

    MFC:

    MFC(Microsoft Foundation Classes),是一个微软公司提供的类库(class libraries)以C++类的形式封装了Windows的API,并且包含一个应用程序框架,以减少应用程序开发人员的工作量。包含的类包含大量Windows句柄封装类和很多Windows的内建控件和组件的封装类。MFC是WinAPI与C++的结合。API,即微软提供的Windows下应用程序的编程语言接口,是一种软件编程的规范,但不是一种程序开发语言。

    设置下拉列表框:

    步骤1:打开VS2015,新建项目工程,选择模块下的Visual C++-->MFC-->MFC应用程序,设定好项目文件名和路径,点击确定。

    步骤2:进入应用程序类 型界面。勾选“基于对话框”,在“MFC的使用” 中,勾选“在共享DLL中 使用MFC(U)”,再点击下 一步。注:MFC可以在静态库下 使用,或者在共享DLL中 使用,但前者会把所有用到的dll文件集成到exe 文件,因此占用内存较大,所以建议选择后者。

     

    步骤3: 进入用户界面功能。选择主框架样式,可以自由选择是否添加最小化框、最大化框;“关于”框也可以去掉;对话框标题一般不需要更改,默认与项目名称一致。

    步骤4:进入高级功能界 面。高级功能一般默认即可,无须勾选其它选项。如果用不上"Active 控件",可以去掉其勾选。

    步骤5: 进入生成的类界面。显示自动生成的两个类的头文件和源文件名称

    步骤6: 建立完的工程自动生成了对应的界面
     

     

    步骤7:在资源视图中点击工具箱,选择Combo Box 拖至对话框窗口。

    步骤8:右键Combo Box控件添加变量,类别选择Value,设置变量名,点击完成。

     

    步骤9:右键点击Combo Box打开属性,在属性中添加Data中的数据(即你要选择的下拉列表中的数据),以 ;隔开。

    步骤10:添加一个button控件测试一下,同样在工具箱中选中Button。

    步骤11:双击Button1即可进入控件的函数,在函数中输入如下代码。

    步骤12:完成之后,编译调试。

    步骤13:选好控件数据之后,点击Button1按钮,测试是否能获取到控件数据。

     

     

     

     

     

    展开全文
  • 实现一个在编辑input下根据输入内容显示匹配内容的下拉列表。 实现思路很简单: 将匹配的内容放在一个div中,input输入时把匹配内容的div显示在input下面。 在做的过程中遇到一个棘手的问题: input的onblur中隐藏...
  • 我一直认为Axure的使用是做产品经理必备的基础技能之一,所以从一开始转行做产品经理就在熟悉和试图挖掘更多的Axure使用技巧。 本篇以及后面几篇文章...1.设置下拉框、列表框和元件文本内容 第一步,拖拽一个下拉...

    我一直认为Axure的使用是做产品经理必备的基础技能之一,所以从一开始转行做产品经理就在熟悉和试图挖掘更多的Axure使用技巧。

    本篇以及后面几篇文章都希望较简单的方式完成简单的交互设计。事先说明一下,我不是专门做交互设计的,只是因为平时工作中个人觉得可以少量使用交互让原型图设计更为流畅。最近打算将学习资料整理一下给到需要的人查看。

    1.设置下拉框、列表框和元件文本内容

    第一步,拖拽一个下拉框、列表框、矩形和三个文本标签;

    如下图:

    第二步,分别给下拉框、列表框和矩形命名为xialai、liebiao、juxing1;

    第三步,给下拉框和列表框设置内容:分别选中下拉框和列表框,然后点击鼠标右键--选择‘编辑列表项’--点击‘编辑多项’分别输入‘内容一、内容二、内容三’或输入在实际工作中要用到的下拉选项内容;

     

    第四步,最关键的步骤:分别选中下拉框和列表框-》点击右边交互页面的‘添加用例’进入用例编辑页面-》点击‘添加条件’进入条件设立页面,最后如下图进行设置:

    注:描述那里是根据上面的设置自动出来的。不需要改动。

     

    第五步:设置矩形的交互。

     

     

     

     

     

     

     

     

    展开全文
  • C# ListBox:列表框控件

    千次阅读 2019-06-11 22:26:10
    列表框 (ListBox) 将所提供的内容以列表的形式显示出来, 并可以选择其中的一项或多项内容,从形式上比使用复选框更好一些。 列表框中常用属性: 列表框还提供了一些方法来操作列表框中的选项,由于列表框中的...
  • 列表框属性

    千次阅读 2019-11-22 14:01:41
    列表框 列表框允许用户从多个对象中选择一项或多项,这些对象可以是文本、文件和位图等。当列表框的项不能全部显示出来时,可以用滚动条来滚动显示。 1. 基础知识 默认的列表框只允许用户单选,需要多选时,须把...
  • 易语言超级列表框使用

    千次阅读 2016-08-12 15:26:30
    易语言超级列表框和循环的连用
  • 列表框和组合框 列表框是CListBox类的对象,组合框是CComboBox的对象。 列表框 属性设置 列表框的重要属性有: Selection 该属性决定用户的选择方式,缺省值为 Single 。属性值有: ①:Single ── 单项...
  • Axure表单元件:下拉列表框列表框

    千次阅读 2019-12-23 14:43:20
    下拉列表框 1,拖动“下拉列表框”元件至页面中; 2,双击下拉列表框,打开“编辑列表选项” 3,点击“+”增加列,输入...最最根本区别是展示效果,列表框是平铺展示所有内容;下拉列表框只显示一列当前列内容 ...
  • 易语言超级列表框与组合框应用 11111111111111111111111111111111111111111111
  • Access-控件解析-列表框-02-获取选项

    千次阅读 2018-08-25 19:50:05
    微信公众号原文 系统:Windows 7 ...本篇介绍的控件为:列表框。涉及功能为:后台获取用户的选择项 UI界面存在大量与用户互动的部分,根据客户不同的选择展现不同的信息 功能动图 静图 Part 2:...
  • 【原创】带你玩转超级列表框(全套教程目录)讲师:雪山凌狐... 带你玩转超级列表框 2 常用属性来设置  主要说了超级列表框的属性 或者说 和 我门自己总结的 使用
  • JSP 下拉列表框、多行下拉列表框

    千次阅读 2014-07-25 17:24:15
    1、下拉列表框:  语法:
  • 常用控件:列表框控件ListBox

    千次阅读 2017-09-29 10:10:18
    列表框可分为单选列表框和多选列表框,顾名思义,单选列表框中一次只能选择一个列表项,而多选列表框可以同时选择多个列表项。  列表框也会向父窗口发送通知消息。这些通知消息含义如下:  LBN_DBLCLK:用户...
  • JAVA下拉列表框组件

    千次阅读 2019-09-23 20:09:50
    Swing中的下拉列表框使用JComboBox类对象来表示,它是javax.swing.JComponent类的子类。 它的常用构造方法如下: public JComboBox(). public JComboBox(ComboBoxModel dataModel). public JComboBox(Object[]...
  • 前端 自定义下拉列表框

    万次阅读 2017-08-27 21:31:20
    今天在公司里,遇到了一个很简单的问题,有一个UI样式固定的下拉列表框。当我拿到这个ui的时候,第一感觉就是简单的select标签就可以解决问题,但是后面在改样式的过程中,遇到了许许多多的问题,包括无法修改选中后...
  • //创建下拉列表框离开焦点事件 添加该事件是为了删除动态事件 以免多次调用 (e.Control as ComboBox).Leave += new EventHandler(ComboBox_Leave); } } //离开焦点事件 private void ComboBox_Leave(object ...
  • 在提供用户调查几面的时候,如果选项比较多,那么就会用到:下拉框组件(JComboBox)列表框组件(JList)滚动窗格组件(JScrollPane)介绍三个组件:下拉框组件(JComboBox):点击箭头可以显示其他信息列表框组件...
  • HTML---下拉框、列表框使用详解(select 与 option)

    万次阅读 多人点赞 2019-09-27 13:24:57
    select创建列表框和下拉菜单, 必须与option 结合使用 select 属性: disable 禁用 multipe 列表框和下拉框是否允许多选 ,支持boolean值属性,为true时则为列表框 size 列表框可同时显示多少个列表项 select 能...
  • 使用Vue实现下拉列表框批量添加选项,设置被选中的值。 代码如下: <!DOCTYPE html> <html> <head> <meta charset="utf-8"> <title>学习Vue</title> <!-- 使用CDN...
  • Android中的Spinner列表选择框,就是平时常见的下拉列表框,通常用于提供一系列的可选择的列表项,供用户进行选择,方便用户输入。具体效果如图1所示。 图1 Spinner下拉列表中的列表项数据,可以来自于资源数组,...
  • JavaSwing_2.10: JList(列表框

    万次阅读 多人点赞 2017-07-09 00:12:31
    JList,列表框。JList 以列表的形式展示多个选项,允许用户选择一个或多个选项。其中的选项内容由一个 ListModel 实例来维护。JList 不实现直接滚动,需要滚动显示,可以结合 JScrollPane 实现滚动效果。
  • 表单域包括文本框、复选框、列表框、组合框、按钮和签名域等,主要用于收集用户填写或选择的数据。这篇文章将介绍如何在Java应用程序中给PDF文档添加表单域。 导入jar文件 本文所使用的PDF类库是Free Spire.PDF ...
  • 超级列表框1.插入表项 (, , , , , ) .子程序 超级列表框1检查框状态被改变 .参数 表项索引, 整数型 .参数 检查框状态, 整数型 .判断开始 (检查框状态 = 1) 超级列表框1.置标题 (0, 0, “开启”) .默认 ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 406,275
精华内容 162,510
关键字:

列表框如何设置列表内容