精华内容
下载资源
问答
  • 511遇见易语言教程列表框属性方法

    千次阅读 2020-07-09 09:06:20
    本节视频录制了易语言列表框的取项目文本、置项目文本、加入项目、插入项目、是否被选择、取所有选择项目等属性方法。 易语言教程列表框视频教程源码: .版本 2 .程序集 窗口程序集_启动窗口 .子程序 _按钮1_...

    本节视频录制了易语言列表框的取项目文本、置项目文本、加入项目、插入项目、是否被选择、取所有选择项目等属性方法。

    易语言教程列表框视频教程源码:

    .版本 2
    
    .程序集 窗口程序集_启动窗口
    
    .子程序 _按钮1_被单击
    
    信息框 (列表框1.取项目文本 (列表框1.现行选中项), #信息图标, , )
    
    .子程序 _按钮2_被单击
    
    信息框 (列表框1.取项目文本 (到整数 (编辑框1.内容)), #信息图标, , )
    
    .子程序 _按钮3_被单击
    
    列表框1.置项目文本 (列表框1.现行选中项, 编辑框1.内容)
    
    .子程序 _按钮4_被单击
    .局部变量 项目索引
    
    项目索引 = 列表框1.加入项目 (编辑框1.内容, )
    列表框1.现行选中项 = 项目索引
    
    .子程序 _按钮5_被单击
    .局部变量 项目索引, 整数型
    
    项目索引 = 列表框1.插入项目 (到整数 (编辑框1.内容), 编辑框2.内容, )
    列表框1.现行选中项 = 项目索引
    
    .子程序 _按钮6_被单击
    .局部变量 bool, 逻辑型
    
    bool = 列表框1.是否被选择 (到整数 (编辑框1.内容))
    .如果 (bool)
    信息框 (“被选择”, 0, , )
    .否则
    信息框 (“没有选择”, 0, , )
    .如果结束
    
    .子程序 _按钮7_被单击
    .局部变量 项目数组, 整数型, , "0"
    .局部变量 选择数量
    .局部变量 索引文本, 文本型
    .局部变量 项目文本, 文本型
    .局部变量 n, 整数型
    
    项目数组 = 列表框1.取所有被选择项目 ()
    选择数量 = 取数组成员数 (项目数组)
    .如果真 (选择数量 = 0)
    信息框 (“请选择项目”, 0, , )
    返回 ()
    .如果真结束
    
    .计次循环首 (选择数量, n)
    
    索引文本 = 索引文本 + #换行符 + 到文本 (项目数组 [n])
    
    项目文本 = 项目文本 + #换行符 + 列表框1.取项目文本 (项目数组 [n])
    
    .计次循环尾 ()
    
    信息框 (“被选中的项目文本:” + 索引文本 + 项目文本, 0, , )

    源码:511遇见易语言教程

               511遇见易语言教程视频链接

               易语言教程列表框属性方法

    展开全文
  • Dim属性数组中很重要的属性,也叫维数向量,当维数向量有两个值时代表为矩阵,有一个值时代表为一维数组。#使用向量生成数组或者矩阵 c<-1:12 c # [1] 1 2 3 4 5 6 7 8 9 10 11 12 dim(c)&...

    在R中,数组(Arrary)可以看做是带多个下标的相同类型的元素集合,常用的是数值型的数组如矩阵,也可以是别的类型的数组,比如字符型,逻辑型等。

    Dim属性是数组中很重要的属性,也叫维数向量,当维数向量有两个值时代表为矩阵,有一个值时代表为一维数组。

    #使用向量生成数组或者矩阵
    c<-1:12
    c
    # [1]  1  2  3  4  5  6  7  8  9 10 11 12
    dim(c)<-c(3,4)
    c
    #       [,1] [,2] [,3] [,4]
    # [1,]    1    4    7   10
    # [2,]    2    5    8   11
    # [3,]    3    6    9   12
    
    dim(c)<-12
    c
    # [1]  1  2  3  4  5  6  7  8  9 10 11 12
    class(c)
    # [1] "array"
    
    #使用Arrary来生成数组a   arrary (data,dim=length(data))
    a<-array(1:12,dim=c(3,4))
    a
    
    #       [,1] [,2] [,3] [,4]
    # [1,]    1    4    7   10
    # [2,]    2    5    8   11
    # [3,]    3    6    9   12
    
    #使用matrix来构造矩阵(二维数组)matrix(data,nrow=,ncol=,byrow=True)
    a<-matrix(1:12,3,4) #构建一个3行4列的矩阵
    a
    
    #数组下标的使用
    #数组可以通过1、精确指定下标2、以空值代表所有下标, 3、以向量形式指出下标 4、通过数组形式指出下标
    
    a<-1:24
    dim(a)<-c(2,3,4)  #定义一个三维数组
    
    a[1,2,3]
    # [1] 15
    a[,,3]
    #       [,1] [,2] [,3]
    # [1,]   13   15   17
    # [2,]   14   16   18
    
    a[,2:3,1:2]
    # , , 1
    # 
    #       [,1] [,2]
    # [1,]    3    5
    # [2,]    4    6
    # 
    # , , 2
    # 
    #       [,1] [,2]
    # [1,]    9   11
    # [2,]   10   12
    
    #在不改变数组维度的情况下,将其赋值为0
    a[]<-0
    a
    
    #也可以用其它数组的值来表示该数组的下标
    b<-matrix(c(1,1,1,2,2,3,1,3,4,2,1,4),nrow = 3,ncol = 3)
    b
    #       [,1] [,2] [,3]
    # [1,]    1    2    1
    # [2,]    1    2    3
    # [3,]    1    3    4
    
    a[b]
    # [1]  3 15 23
    
    #同样的我们还可以对其进行赋值运算
    a[b]<-0
    # a
    # , , 1
    # 
    # [,1] [,2] [,3]
    # [1,]    1    0    5
    # [2,]    2    4    6
    # 
    # , , 2
    # 
    # [,1] [,2] [,3]
    # [1,]    7    9   11
    # [2,]    8   10   12
    # 
    # , , 3
    # 
    # [,1] [,2] [,3]
    # [1,]   13    0   17
    # [2,]   14   16   18
    # 
    # , , 4
    # 
    # [,1] [,2] [,3]
    # [1,]   19   21    0
    # [2,]   20   22   24
    
    #数组和矩阵的四则运算是对应元素之间的运算,一般是结构相同才能运算
    #数组和矩阵运算时,是对矩阵的列运算,不匹配时,一般会有警告
    
    #apply函数 apply(A,margin,fun)
    #a代表矩阵,margin=1 代表按行进行fun函数,=2代表按列进行fun函数
    a<-1:6
    dim(a)<-c(2,3)
    a
    #       [,1] [,2] [,3]
    # [1,]    1    3    5
    # [2,]    2    4    6
    apply(a,1,sum)
    # [1]  9 12
    
    
    #矩阵的运算包含转置、求特征向量、特征根等,笔者用到的不多,以后再总结
    

    展开全文
  • 工作用到的 Winform 属性编辑器 propertyGrid示例 下拉列表框
  • 后台数据的结构如下: "productfactors": [ {//产品投保要素 "factortype": "Period",//要素类型 "datatype": "08",//数据类型 ... { //投保要素值列表 "factorvalue": "1Y",//投保要素值计算值 ...

    后台数据的结构如下:

    "productfactors": [
      {//产品投保要素
        "factortype": "Period",//要素类型
        "datatype": "08",//数据类型
        "productfactorvalues": [
          { //投保要素值列表
            "factorvalue": "1Y",//投保要素值计算值
            "factordisplayvalue": "1年",//投保要素值显示值
            "isdisplay": "Y",//是否显示
            "isdefaultvalue": "Y",//是否为默认值
            "showorder": 1//排序序号
          },
          { //投保要素值列表
            "factorvalue": "2Y",//投保要素值计算值
            "factordisplayvalue": "1年",//投保要素值显示值
            "isdisplay": "Y",//是否显示
            "isdefaultvalue": "N",//是否为默认值
            "showorder": 2//排序序号
          },
        ]
      },
      {//产品投保要素
        "factortype": "Period",//要素类型
        "datatype": "08",//数据类型
        "productfactorvalues": [
          { //投保要素值列表
            "factorvalue": "1Y",//投保要素值计算值
            "factordisplayvalue": "1岁",//投保要素值显示值
            "isdisplay": "Y",//是否显示
            "isdefaultvalue": "Y",//是否为默认值
            "showorder": 1//排序序号
          },
          { //投保要素值列表
            "factorvalue": "2Y",//投保要素值计算值
            "factordisplayvalue": "2岁",//投保要素值显示值
            "isdisplay": "Y",//是否显示
            "isdefaultvalue": "N",//是否为默认值
            "showorder": 2//排序序号
          }
        ]
      }
    ],
    

    html代码如下:

    <!-- 下拉框 -->
    <view class="PolicyholderContentText" v-for="(items,Index) in productfactorslist" v-show="items.isdisplay=='Y' && items.datatype=='08' " :name="items.factortype" :value="items.productfactorvalues[ValData[items.factortype]].factordisplayvalue">
      <text>{{items.factortypename}}</text>
      <picker  class="type" mode = "selector" :data-type="items.productfactorvalues[ValData[items.factortype]].factorvalue" :id="items.factortype" @change="bindPickerChange(items,$event)" :value="ValData[items.factortype]" :range="items.productfactorvalues" :range-key="'factordisplayvalue'" :data-current="Index"  :name="items.factortype" >
        <view>{{items.productfactorvalues[ValData[items.factortype]].factordisplayvalue}}</view>
      </picker>
    </view>

    首先要根据接口把数据获取回来,获取回来的数据进行处理,得到外层的数组就是上面的productfactors数组,只是我们在data中声明一个变量数组来接收获取回来的数据,例如:productfactorslist:[]。

    正如官方文档所说的uni-app中picker,picker中range的值是一个数组,因为是双层数组,我们所需要的下拉框的值是一个数组,不需要便利,这时候我们如果通过items.productfactorvalues取值,再通过@change事件把我们下拉选择的索引传给e.target.value,这样我们是可以修改下拉框的值,但是会造成遍历出来的下拉框会联动,因为他们的索引没有区分,所以想要区分每一个下拉框的值,我们就需要在本质上区分他们的索引,每一个下拉框有自己的索引,这样选择一个下拉框的索引才不会干扰其他的下拉框。

    我的做法是根据数据所获取回来的投保要素的要素类型factortype进行区分,首先要创建一个空对象,代码如下:

    ValData:{},

    然后再向空对象中传参数和值,参数就是我们遍历出来的每一个要素类型factortype,这是我们就要在初始加载页面的时候Onload中获取数据时候操作,代码如下:

    success:(res) => {
      var Data = res.data;
      this.product = Data.data.product;
      this.Initprem = this.product.initprem;
      // this.productfactorslist = Data.data.product.productfactors;
      var Datalist = [];
      Datalist =  Data.data.product.productfactors;
      console.log(Datalist);
      var len = Datalist.length;
      this.productfactorslist = Datalist;
      // 下拉框初始赋值
      Datalist.forEach((Val,Valindex)=>{
        if(Datalist[Valindex].datatype == '08'){							 
          Val.productfactorvalues.forEach(({factorvalue,isdefaultvalue},index)=>{
            if(isdefaultvalue == 'Y'){
              this.ValData[Val.factortype]=index;
              this.ValList[Val.factortype]=factorvalue;
            }
          })
        }
      })
      console.log(this)
      console.log(this.productfactorslist);
    },
    fail:(res)=> {
      console.log(res);
    }
    

    这时候还会有一个下拉框初始显示默认值,是根据isdefaultvalue 属性来确定的,上面的数据中有,这样通过forEach遍历数组就会给每一个下拉框附一个初始值,初始值是根据索引来获取的在picker中,这样在页面加载的时候我们直接把获取到默认的索引值直接赋给所选取的索引值e.target.value即可,代码如下:

    bindPickerChange: function(items,e) {
      console.log(e)
      console.log(items)
      var id = items.factortype;
      this.ValData[id] = e.target.value;
      this.ValList[id] = items.productfactorvalues[this.ValData[items.factortype]].factorvalue;
      console.log(this)
      this.$forceUpdate();
    },

    这样就可以选择单独的下拉框,索引值不会共用了,就可以数据单独选择了,在这里他也出现了一个问题,因为vue框架在加载多层数据时候有时候不会自动自动渲染数据,需要我们强制让页面选自然数据,只需要在change事件末尾加一个this.$forceUpdate();就可以强制渲染,完成数据加载。

    在完成下拉框的数据加载之后,选择完数据之后我们就要把选择的数据传到后台进行提交,这时候就需要进行表单提交了,但是这个uni-app中picker的表单提交只能默认在e.target.detail中,并且我不太懂他传过去数据的属性是怎末来的,所以我还是自己写了个对象,用来接受表单提交的数据,和刚才获取索引的时候的方法一样。过程如下:

    首先建立一个空对象ValList:{},

    然后在页面初始加载数据的时候就给ValList赋予一个初始的属性和值,属性还是刚才数据中的投保要素类型factorvalue,值就是根据isdefaultvalue来判断获取的一个值,代码如下:this.ValList那行

    Datalist.forEach((Val,Valindex)=>{
      if(Datalist[Valindex].datatype == '08'){							    
        Val.productfactorvalues.forEach(({factorvalue,isdefaultvalue},index)=>{
          if(isdefaultvalue == 'Y'){
            this.ValData[Val.factortype]=index;
            this.ValList[Val.factortype]=factorvalue;
          }
        })
      }
    })

    然后再@change事件中也要根据刚才获取的索引来取值并添加到我们创建的空对象ValList中,代码如下:this.ValList那行

    bindPickerChange: function(items,e) {
      console.log(e)
      console.log(items)
      var id = items.factortype;
      this.ValData[id] = e.target.value;
      this.ValList[id] = items.productfactorvalues[this.ValData[items.factortype]].factorvalue;
      console.log(this)
      this.$forceUpdate();
    },

    这时候我们选择一个值之后就会创建一个空对象ValData存储我们获取值的属性和索引,同时创建一个空对象ValList来存储我们要提交的表单的值,也就是获取的下拉框的属性和值。控制台打印出的this的值如下:

    实现的下拉框效果如下:

    选择一个下拉框修改值之后

    展开全文
  • 在matlab

    edit_string = get(handles.string_edit,'string');
    if (isempty(edit_string))
        disp('Please give an string to add')
    end
    
    list_string = get(handles.listbox1,'string');   % list_string是一个元胞?是
     if (~isempty(list_string))
         set(handles.listbox1,'string',vertcat(edit_string,list_string));
    else
        set(handles.listbox1,'string',edit_string);
    end

    该段代码是把编辑框中的字符加入到裂框中。 我们几种方法可验证该问题。

    比如  在 

    list_string = get(handles.listbox1,'string');   % list_string是一个元胞?是
    后面加上  class(list_string) 然后我们就可以在命令行看到结果为 cell


    然而,本文重点不在于次!我想说的是 函数 vertcat 和 函数 cat(1,...)

    这俩个函数在垂直方向拼接输入参数但是他们俩个函数都需要输入参数列相同

    例如

     a = ['123 ';'1234';'4  6']
    
    a =
    
    123 
    1234
    4  6
    
    >> b = '44'
    
    b =
    
    44
    
    >> cat(1,b,a)
    Error using cat
    Dimensions of matrices being concatenated are not consistent.
     
    >> vertcat(b,a)
    Error using vertcat
    Dimensions of matrices being concatenated are not consistent.

    当列相同的时候拼接是成功的

    c = '1470'
    
    
    c =
    
    
    1470
    
    
    >> cat(1,c,a)
    
    
    ans =
    
    
    1470
    123 
    1234
    4  6
    vertcat 结果也一样

    然而,开始的程序在执行的时候却没有错误,这就说明 列表框'string'返回的存储类型绝对不是普通高维数组。cat函数与vertcat函数对与元胞数组也是使用的。例如:

     a = {'1231';'sdfa'}
    
    a = 
    
        '1231'
        'sdfa'
    
    >> b = '1'
    
    b =
    
    1
    
    >> cat(1,b,a)
    
    ans = 
    
        '1'
        '1231'
        'sdfa'
    本人初学matlab,以上均是学习过程中遇到的问题,总结的心得!如果您发现有什么错误,还望指出来!谢谢!


    展开全文
  • R数组列表、数据、因子

    千次阅读 2017-08-09 23:25:17
    数组 列表 数据 因子
  • 1、修复由于关闭 创建_列表载体 第二参数 是否跟随母组件可视属性 导致的显示部分表项异常错误 3、修复由于对组件可视属性的判断,如果在 创建完毕 下执行 创建_表项_首次 和 删除方法 导致的无法正常删除错误 4、...
  • js在dom元素中根据某些‘属性’排序添加元素过滤已有元素(值相等)单词首字母大写排序 添加元素 var myArr=new Array(),arr=[];//两种数组定义形式 ...//向数组中添加每一个p元素中属性为div...
  • 易语言报表式超级列表框源码,报表式超级列表框,初始化,属性_置列类型,属性_取列类型,方法_复制组件,方法_自动调节列宽,内部_取数组非空成员数,属性_置组合框高度,事件_主超级列表框_被双击,事件_主超级列表框_鼠标...
  • 背景: 前端框架为AdminLTE,后台为SSM,项目需要实现表格添加一行的功能,并且这一行有select2的多选数组遇到的问题: (1)select2多选返回的数据是数组,但添加多行,由于其name相同,springMVC通过String[]...
  • List<SpecialguardInfo> list=specialguardOrderService.findfreeSg(date1,date2);//得到list对象集合 String[] arr=new String[list.size()];... //把list对象的id属性装进arr数组 int count...
  • Jquery类似框架的封装之伪数组转化为真数组

    千次阅读 热门讨论 2016-11-24 14:30:58
    数组转化为真数组
  • MFC在编辑框中显示一个二维数组

    千次阅读 2014-03-05 00:14:30
    想到总结这个问题是因为在先前的那个扫雷程序,想实现在一个界面上显示当前的地雷的布局,实际上是显示一个二维数组,当时想了一些办法,觉得类似的可能用得上故作一个简单的总结。雷区的方格存储的是数字,-1的...
  • 数组、矩阵、列表和数据的应用 #R语言备忘录三# #数组array和矩阵matrix、列表list、数据dataframe #数组 #数组的重要属性就是dim,维数 #得到4*5的矩阵 z dim(z) (3,4) z #构建数组 x (1:20, dim = c(4,5)...
  • vb学习总结, 列表框  1、属性  1、columns  该属性用来确定列表的列数。当该属性设置为0(默认)是,所用的项目呈单列显示。...list属性保存了列表框中所有值得数组,可以通过下标访问数组中的值(下标值从
  • android 从资源获取数组

    万次阅读 2013-10-06 12:02:06
    8.1. 从资源获取数组 8.1.1.概述 除了在Java代码定义数组,Android还提供了在资源定义数组,然后在Java代码解析资源,从而获取数组的方法。 实际开发,推荐将数据存放在资源文件,以实现程序的逻辑...
  • 易语言组合框去重复到列表框

    千次阅读 2019-12-08 19:15:51
    在辅助开发时,我们需要通过组合框控制一些功能,或者获取一些数据,比如把组合框里 的值添加到列表框,这里就需要去除重复的,以下代码实现了这个功能。 .版本 2 .支持库 spec .支持库 EDataStructure .程序集 ...
  • 绑定列表框组件的item到ArrayList或Option[]ArrayList要求包含的数组是Option[]3.绑定列表框组伯的selected到String[]4.可以从selected绑定的String[]属性去获得所selected的东东即值列表5.可以修改ArrayList
  • Labview学习笔记2之 多列列表框 目标: 找出鼠标在列表框中选择的位置的值 指令: 多列表框-属性节点-列首(获得...多列表框-属性节点-项名(获得除行首列首外所有列表框的2维字符串数组) 代码: ...
  • 在R软件,矩阵是有维数的向量,这里的矩阵元素可以是数值型、字符型或者逻辑型,但是每个元素必须拥有相同的模式,这个和向量一致。 (1)创建矩阵: m <- matrix(1:20,4,5) 行数和列数的分配必须满足分配条件...
  • LabVIEW多列列表框背景颜色操作

    千次阅读 2017-08-07 17:27:09
    多列列表框概述在很多情况下我们需要在表格某一列查找一些指定的元素,并且想让其显示为指定的颜色,此时就可以利用多列列表框的一些属性来解决这一问题。
  • 列表框、组合框

    千次阅读 2010-04-08 15:54:00
    如果项目总数超过了列表框可显示的项目数,列表框会自动添加滚动条,可以方便用户以滚动的方式来选择列表框列表框的常用属性·listcount属性:用于返回列表框中的所有选项的个数,该属性只能在程序代码调用和设置...
  • 支持高级大量的维度数组与矩阵运算,此外也针对数组运算提供大量的数学函数库。Numpy运算效率极好,是大量机器学习框架的基础库。 使用numpy库的函数前,需使用import关键字引入numpy库,本博客采用以下方式引入...
  • javaScript数组属性和方法(示例和解析)

    千次阅读 多人点赞 2018-12-12 21:42:20
    数组属性和方法属性 属性 constructor 描述:返回对创建此对象的数组函数的引用。 语法:object.constructor function employee(name,job,born) { this.name=name; this.job=job; this.born=born; } var bill=...
  • Vue,JS判断数组中包含的每一层对象的某一个属性值不能为空或者其他 终极大法:就是用every,some遍历数组,区别:every只要有一项不满足条件都返回false some有一项满足都会返回true 这种操作一般用来操作列表,提交...
  • 函数vector有两个参数:类型(mode)和长度(length),创建的向量元素值取决于参数所指定的数据类型:数值型向量则元素值都为0,逻辑型都为FALSE,字符型都为""。以下三个函数有几乎相同的效果(创建一个向量)并且只有一个...
  • C# 复选列表框 和 imageList组件

    千次阅读 2017-02-09 21:01:17
    复选列表框 CheckedListBox是一个 复选列表框 属性: CheckOnClick属性:指示...SelectedIndexChanged()事件:这个事件是只要选中列表框中的某项就会触发该事件,而不必要打上勾 ItemCheck事件:指示某项的选中状态将要
  • <body> //html部分先写一个列表select <select name="" id="sel"><...//数组内容 var data = ["北京","上海","广州"]; //获取select var sel = document.getElementById('s...
  • 列表框控件(listbox)消息

    千次阅读 2017-03-15 10:21:37
    列表框主要用于输入,它允许用户从所列出的表项中进行单项或多项选择,被选择的项呈高亮度显示... 应用程序用CreateWindowEx创建列表框控件时,可根据控件的用途在下表选择部份常数来设定其风格属性(style)。  常

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 136,356
精华内容 54,542
关键字:

列表框属性中是数组的是