精华内容
下载资源
问答
  • 本节视频通过三种方法实现了防止项目重复加入列表框。 易语言列表框防止项目重复加入列表框视频教程源码: .版本 2 .程序集 窗口程序集_启动窗口 .子程序 __启动窗口_创建完毕 列表框1.现行选中项 = 0 ...

    本节视频通过三种方法实现了防止项目重复加入列表框。

    易语言列表框防止项目重复加入列表框视频教程源码:

    .版本 2
    
    .程序集 窗口程序集_启动窗口
    
    .子程序 __启动窗口_创建完毕
    
    列表框1.现行选中项 = 0
    皮肤_加载 (1)
    
    .子程序 _按钮1_被单击
    
    列表框1.加入项目 (编辑框1.内容, )
    编辑框1.内容 = “”
    
    .子程序 _按钮2_被单击, , , 不重复加入-1
    
    .如果 (列表框1.选择 (编辑框1.内容) = -1)
    列表框1.加入项目 (编辑框1.内容, )
    信息框 (“添加成功!”, 0, , )
    .否则
    信息框 (“已经存在【” + 编辑框1.内容 + “】请不要重复添加该内容!”, 0, , )
    
    .如果结束
    
    .子程序 _按钮3_被单击, , , 不重复加入-2
    
    .如果 (SendMessageA (列表框1.取窗口句柄 (), 399, 0, 编辑框1.内容) = -1)
    列表框1.加入项目 (编辑框1.内容, )
    信息框 (“添加成功!”, 0, , )
    .否则
    信息框 (“已经存在【” + 编辑框1.内容 + “】请不要重复添加该内容!”, 0, , )
    
    .如果结束
    
    .子程序 _按钮4_被单击, , , 不重复加入-3
    .局部变量 i, 整数型
    .局部变量 重复, 逻辑型
    
    .计次循环首 (列表框1.取项目数 (), i)
    .如果真 (列表框1.取项目文本 (i - 1) = 编辑框1.内容)
    重复 = 真
    跳出循环 ()
    .如果真结束
    重复 = 假
    .计次循环尾 ()
    
    .如果 (重复 = 假)
    列表框1.加入项目 (编辑框1.内容, )
    编辑框1.内容 = “”
    信息框 (“添加成功!”, 0, , )
    .否则
    信息框 (“已经存在【” + 编辑框1.内容 + “】请不要重复添加该内容!”, 16, , )
    .如果结束

    源码:511遇见易语言教程

               511遇见易语言教程视频链接

               易语言列表框防止项目重复加入列表框

    展开全文
  • 本课视频通过四种方法实现了易语言列表框去重复项目到列表框。 易语言列表框去重复项目到列表框视频教程源码: .版本 2 .程序集 窗口程序集_启动窗口 .子程序 __启动窗口_创建完毕 皮肤_加载 (1) .子程序 _...

    本课视频通过四种方法实现了易语言列表框去重复项目到列表框。

    易语言列表框去重复项目到列表框视频教程源码:

    .版本 2
    
    .程序集 窗口程序集_启动窗口
    
    .子程序 __启动窗口_创建完毕
    
    皮肤_加载 (1)
    
    .子程序 _按钮1_被单击
    .局部变量 项目文本, 文本型
    
    项目文本 = 列表框1.取项目文本 (列表框1.现行选中项)
    .如果 (列表框查找文本 (列表框2, 项目文本) = 真)
    列表框2.加入项目 (项目文本, )
    .否则
    
    .如果结束
    
    .子程序 列表框查找文本, 逻辑型
    .参数 列表框, 列表框
    .参数 要加入的文本, 文本型
    .局部变量 I, 整数型
    
    .计次循环首 (列表框.取项目数 (), I)
    .如果真 (要加入的文本 = 列表框.取项目文本 (I - 1))
    返回 (假)
    .如果真结束
    
    .计次循环尾 ()
    返回 (真)
    
    .子程序 _按钮2_被单击
    .局部变量 列表框1内容, 文本型
    
    列表框1内容 = 列表框1.取项目文本 (列表框1.现行选中项)
    .如果 (列表框2.选择 (列表框1内容) = -1)
    列表框2.加入项目 (列表框1内容, )
    .否则
    
    .如果结束
    
    .子程序 _按钮3_被单击
    .局部变量 项目, 文本型
    
    项目 = 列表框1.取项目文本 (列表框1.现行选中项)
    
    .如果 (列表框加入项目 (列表框2, 项目) = 真)
    信息框 (“项目添加成功”, 0, , )
    .否则
    
    .如果结束
    
    .子程序 列表框加入项目, 逻辑型
    .参数 列表框, 列表框
    .参数 要加入的文本, 文本型
    .局部变量 n, 整数型
    
    .计次循环首 (列表框.取项目数 (), n)
    .如果真 (要加入的文本 = 列表框.取项目文本 (n - 1))
    返回 (假)
    .如果真结束
    
    .计次循环尾 ()
    列表框.加入项目 (要加入的文本, )
    返回 (真)
    
    .子程序 _按钮4_被单击
    .局部变量 项目, 文本型
    
    项目 = 列表框1.取项目文本 (列表框1.现行选中项)
    .如果 (SendMessageA (列表框2.取窗口句柄 (), 399, 0, 项目) = -1)
    列表框2.加入项目 (项目, )
    信息框 (“项目添加成功!”, 0, , )
    
    .否则
    信息框 (“已经存主【” + 项目 + “】请不要重复添加!”, 16, , )
    
    .如果结束

    源码:511遇见易语言教程

               511遇见易语言教程视频链接

               易语言列表框去重复项目到列表框

     

    展开全文
  • Axure表单元件:下拉列表框列表框

    千次阅读 2019-12-23 14:43:20
    下拉列表框 1,拖动“下拉列表框”元件至页面中; 2,双击下拉列表框,打开“编辑列表选项” 3,点击“+”增加列,输入内容;单击选择框,可以设为默认选中,没有勾选默认为第一个。 注:点击“添加多个”,可以...

    下拉列表框

    1,拖动“下拉列表框”元件至页面中;
    在这里插入图片描述
    2,双击下拉列表框,打开“编辑列表选项”
    在这里插入图片描述
    3,点击“+”增加列,输入内容;单击选择框,可以设为默认选中,没有勾选默认为第一个。
    在这里插入图片描述
    注:点击“添加多个”,可以一次性填多条值。

    列表框

    操作与下拉列表框类似。区别只是在“编辑列表选项”对话框中,可以选择多个;最最根本区别是展示效果,列表框是平铺展示所有内容;下拉列表框只显示一列当前列内容
    在这里插入图片描述

    展开全文
  • JSP 下拉列表框、多行下拉列表框

    千次阅读 2014-07-25 17:24:15
    1、下拉列表框:  语法:

    1、下拉列表框:

          语法:

         <select name="名称">

              <option value="值" selected>显示值</option>

              ............

        </select>

    2、多行下拉列表框

          语法;

          <select name="名称" size="行数" multiple>

         ......

         </select>

    展开全文
  • C# 列表框

    千次阅读 2017-02-09 16:46:50
    列表框 ListBox 属性: Items属性:列表框中的项 SelectionMode属性:只是列表框将是单项选择,多项选择还是不可选择; one表示只能选一个; MultiSimple表示可以选择多个; MultiExtended鼠标单击只能选择一个,...
  • 超级列表框扩展_置列高 超级列表框扩展_自动调整列宽 超级列表框扩展_取单元格列号 超级列表框扩展_取单元格行号 超级列表框扩展_快速排序 超级列表框扩展_置入组合框 超级列表框扩展_置入文本框 超级列表框扩展_...
  • HTML 下拉列表框

    千次阅读 2019-04-28 16:30:23
    HTML 下拉列表框
  • C# ListBox:列表框控件

    千次阅读 2019-06-11 22:26:10
    列表框 (ListBox) 将所提供的内容以列表的形式显示出来, 并可以选择其中的一项或多项内容,从形式上比使用复选框更好一些。 列表框中常用属性: 列表框还提供了一些方法来操作列表框中的选项,由于列表框中的...
  • Java 列表框

    千次阅读 2012-05-19 10:18:25
    摘 要 本文针对Java语言的特点,提出了在程序中动态添加和删除列表框中的列表元素并在结束操作时获取列表元素的实现方法,并给出了具体开发的实例。  关键词 Java 列表框  引言  Java是一种纯粹的面向对象的...
  • 下拉框与列表框

    千次阅读 2014-10-24 17:30:50
    下拉列表框和下拉列表 下拉列表框和下拉列表 下拉列表框:请选择电话区号: 北京 西安 成都 单选列表框:请选择电话区号 北京 西安 成都
  • 易语言组合框去重复到列表框

    千次阅读 2019-12-08 19:15:51
    在辅助开发时,我们需要通过组合框控制一些功能,或者获取一些数据,比如把组合框里 的值添加到列表框,这里就需要去除重复的,以下代码实现了这个功能。 .版本 2 .支持库 spec .支持库 EDataStructure .程序集 ...
  • labview状态显示窗口专用,采用列表框,可以动态的滚动显示信息,内含注解!
  • QQ列表框控件SideBar

    2008-09-20 01:38:51
    sidebar,制作QQ列表框,以及类似的动态列表框的最佳选择,附有使用flash
  • 易语言超级列表框使用

    千次阅读 2016-08-12 15:26:30
    易语言超级列表框和循环的连用
  • 编辑框内容到超级列表框表项写法 编辑框内容到超级列表框表项写法 编辑框内容到超级列表框表项写法编辑框内容到超级列表框表项写法
  • android 列表框

    千次阅读 2014-07-10 09:49:02
    android:text="列表选择" /> 2、ActivityMain.class类 包 import android.app.Activity; import android.app.AlertDialog; import android.content.DialogInterface; import android.os.Bundle; ...
  • 列表框控件

    千次阅读 2005-04-27 16:28:00
    列表框控件(listbox) [下载例程] 列表框主要用于输入,它允许用户从所列出的表项中进行单项或多项选择,被选择的项呈高亮度显示.列表框具有边框,并且一般带有一个垂直滚动条.列表框分单选列表框和多重选择列表...
  • C# 下拉列表框

    万次阅读 2017-02-09 21:47:54
    下拉列表框 ComboBox既是下拉列表 属性: Items属性:为下拉列表添加相应的项目,与列表框类似 DropDownStyle属性:控制组合框的外观和功能(此属性如果选择DropDownList则只可选择而不能再框中输入,若选择...
  • 列表框、组合框

    千次阅读 2010-04-08 15:54:00
    如果项目总数超过了列表框可显示的项目数,列表框会自动添加滚动条,可以方便用户以滚动的方式来选择列表框列表框的常用属性·listcount属性:用于返回列表框中的所有选项的个数,该属性只能在程序代码中调用和设置...
  • PB多选下拉列表框PB多选下拉列表框PB多选下拉列表框PB多选下拉列表框PB多选下拉列表框PB多选下拉列表框PB多选下拉列表框PB多选下拉列表框PB多选下拉列表框PB多选下拉列表框PB多选下拉列表框PB多选下拉列表框PB多选...
  • 本课视频通过5种方法实现了易语言组合框添加不重复文本到列表框。 易语言组合框添加不重复文本到列表框视频交教程源码: .版本 2 .子程序 _按钮1_被单击 .局部变量 文本, 文本型 文本 = 组合框1.内容 .如果...
  • MFC可编辑列表框控件

    2016-08-27 19:12:01
    扩展了MFC列表框控件功能,使得列表框控件中的值可以编辑
  • 超级列表框排序功能 .版本 2 .支持库 iext 重定义数组 (文本数组, 假, 超级列表框1.取表项数 ()) .计次循环首 (超级列表框1.取表项数 (), n) 文本数组 [n] = 超级列表框1.取标题 (n - 1, 参考列) 超级列表框1....
  • wx.ListBox创建列表框

    千次阅读 2013-04-23 10:26:27
    7.4.3 如何创建一个列表框列表框是提供给用户选择的另一机制。选项被放置在一个矩形的窗口中,用户可以选择一个或多个。列表框比单选按钮占据较少的空间,当选项的数目相对少的时候,列表框是一个好的选择。...
  • CListCtrl 添加编辑框,下拉列表框,时间控件 CListCtrl 添加编辑框,下拉列表框,时间控件
  • 511遇见易语言教程列表框属性方法

    千次阅读 2020-07-09 09:06:20
    本节视频录制了易语言列表框的取项目文本、置项目文本、加入项目、插入项目、是否被选择、取所有选择项目等属性方法。 易语言教程列表框视频教程源码: .版本 2 .程序集 窗口程序集_启动窗口 .子程序 _按钮1_...
  • MFC实现的多选的列表框ListBox

    热门讨论 2011-10-20 23:05:00
    左边的“待选的历史人物”列表框包含历史人物的名字,当选中人名并单击“添加”按钮,则名字会被添加到右边的“你喜欢的历史人物”列表框,同时从左侧的列表框中删除;当选中“你喜欢的历史人物”列表框中的人名并...
  • 易语言超级列表框排序模块.ec易语言超级列表框排序模块.ec
  • 易语言超级列表框批量导入导出

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 908,951
精华内容 363,580
关键字:

列表框是什么