精华内容
下载资源
问答
  • 511遇见易语言教程列表框属性方法

    千次阅读 2020-07-09 09:06:20
    本节视频录制了易语言列表框的取项目文本、置项目文本、加入项目、插入项目、是否被选择、取所有选择项目等属性方法。 易语言教程列表框视频教程源码: .版本 2 .程序集 窗口程序集_启动窗口 .子程序 _按钮1_...

    本节视频录制了易语言列表框的取项目文本、置项目文本、加入项目、插入项目、是否被选择、取所有选择项目等属性方法。

    易语言教程列表框视频教程源码:

    .版本 2
    
    .程序集 窗口程序集_启动窗口
    
    .子程序 _按钮1_被单击
    
    信息框 (列表框1.取项目文本 (列表框1.现行选中项), #信息图标, , )
    
    .子程序 _按钮2_被单击
    
    信息框 (列表框1.取项目文本 (到整数 (编辑框1.内容)), #信息图标, , )
    
    .子程序 _按钮3_被单击
    
    列表框1.置项目文本 (列表框1.现行选中项, 编辑框1.内容)
    
    .子程序 _按钮4_被单击
    .局部变量 项目索引
    
    项目索引 = 列表框1.加入项目 (编辑框1.内容, )
    列表框1.现行选中项 = 项目索引
    
    .子程序 _按钮5_被单击
    .局部变量 项目索引, 整数型
    
    项目索引 = 列表框1.插入项目 (到整数 (编辑框1.内容), 编辑框2.内容, )
    列表框1.现行选中项 = 项目索引
    
    .子程序 _按钮6_被单击
    .局部变量 bool, 逻辑型
    
    bool = 列表框1.是否被选择 (到整数 (编辑框1.内容))
    .如果 (bool)
    信息框 (“被选择”, 0, , )
    .否则
    信息框 (“没有选择”, 0, , )
    .如果结束
    
    .子程序 _按钮7_被单击
    .局部变量 项目数组, 整数型, , "0"
    .局部变量 选择数量
    .局部变量 索引文本, 文本型
    .局部变量 项目文本, 文本型
    .局部变量 n, 整数型
    
    项目数组 = 列表框1.取所有被选择项目 ()
    选择数量 = 取数组成员数 (项目数组)
    .如果真 (选择数量 = 0)
    信息框 (“请选择项目”, 0, , )
    返回 ()
    .如果真结束
    
    .计次循环首 (选择数量, n)
    
    索引文本 = 索引文本 + #换行符 + 到文本 (项目数组 [n])
    
    项目文本 = 项目文本 + #换行符 + 列表框1.取项目文本 (项目数组 [n])
    
    .计次循环尾 ()
    
    信息框 (“被选中的项目文本:” + 索引文本 + 项目文本, 0, , )

    源码:511遇见易语言教程

               511遇见易语言教程视频链接

               易语言教程列表框属性方法

    展开全文
  • R数组列表、数据、因子

    千次阅读 2017-08-09 23:25:17
    数组 列表 数据 因子

    基础知识

    1.数组

    > A <- array(1:24,c(3,4,2)) #生成一个3 x 4 x 2的数组
    > A
    , , 1
    
         [,1] [,2] [,3] [,4]
    [1,]    1    4    7   10
    [2,]    2    5    8   11
    [3,]    3    6    9   12
    
    , , 2
    
         [,1] [,2] [,3] [,4]
    [1,]   13   16   19   22
    [2,]   14   17   20   23
    [3,]   15   18   21   24
    
    > A[2,2,2] #数组索引和矩阵、向量类似
    [1] 17
    > 
    > dim(A) #获取维数
    [1] 3 4 2
    > dim(A) = 24 #改变数组的维度  变为向量
    > A
     [1]  1  2  3  4  5  6  7  8  9 10 11 12 13 14 15 16 17 18 19
    [20] 20 21 22 23 24
    >
    > dim(A) = c(4,6) #改变数组维度 变为 4 x 6 矩阵
    > A
         [,1] [,2] [,3] [,4] [,5] [,6]
    [1,]    1    5    9   13   17   21
    [2,]    2    6   10   14   18   22
    [3,]    3    7   11   15   19   23
    [4,]    4    8   12   16   20   24
    > 

    2.列表

    > list1 = list(name='R Programming',action='learn',content='list')
    > list1
    $name
    [1] "R Programming"
    
    $action
    [1] "learn"
    
    $content
    [1] "list"
    
    > list1[1] #获取列表第一项内容
    $name
    [1] "R Programming"
    
    > list1['action'] #获取列表里'action'项对应的内容 注意加引号
    $action
    [1] "learn"
    
    > list1$content #获取列表里content属性的内容
    [1] "list"
    > 
    > length(list1) #获取列表属性个数
    [1] 3
    > mode(list1) #获取数据类型
    [1] "list"
    > names(list1) #获取列表的属性
    [1] "name"    "action"  "content"
    > 

    3.数据框

    > #学号
    > number <- paste(2017,3098:3118,sep="")
    > #数学分析成绩
    > x1 <- round(runif(21,min=45,max=97))
    > #高等代数成绩
    > x2 <- round(rnorm(21,mean=75,sd=10))
    > x2[which(x2>100)] <- 100
    > #解析几何成绩
    > x3 <- round(rnorm(21,mean=84,sd=10))
    > x3[which(x3>100)] <- 100
    > #考试成绩数据框
    > data <- data.frame(number,x1,x2,x3) #组合数据框
    > data
         number x1 x2  x3
    1  20173098 85 76  76
    2  20173099 71 70  86
    3  20173100 62 89 100
    4  20173101 84 73  76
    5  20173102 75 97 100
    6  20173103 92 86  83
    7  20173104 91 70  80
    8  20173105 76 79  89
    9  20173106 54 62  93
    10 20173107 60 72  81
    11 20173108 48 79  79
    12 20173109 75 91  66
    13 20173110 66 83  93
    14 20173111 60 74 100
    15 20173112 64 73 100
    16 20173113 83 64  90
    17 20173114 64 70  85
    18 20173115 62 75  85
    19 20173116 68 86  81
    20 20173117 84 84  81
    21 20173118 90 76 100

    4.因子

    > x <- c('Female','Male','Male','Female','Female')
    > 
    > x
    [1] "Female" "Male"   "Male"   "Female" "Female"
    >
    > f =factor(x) #将x按因子水平分类
    > f
    [1] Female Male   Male   Female Female
    Levels: Female Male
    > 
    > levels(f)  #获取f的因子水平
    [1] "Female" "Male"  
    > 
    展开全文
  • 然而,开始的程序在执行的时候却没有错误,这就说明 列表框'string'返回的存储类型绝对不是普通高维数组。cat函数与vertcat函数对与元胞数组也是使用的。例如: a = {'1231';'sdfa'} a = '1231' 'sdfa' >>...

    edit_string = get(handles.string_edit,'string');
    if (isempty(edit_string))
        disp('Please give an string to add')
    end
    
    list_string = get(handles.listbox1,'string');   % list_string是一个元胞?是
     if (~isempty(list_string))
         set(handles.listbox1,'string',vertcat(edit_string,list_string));
    else
        set(handles.listbox1,'string',edit_string);
    end

    该段代码是把编辑框中的字符加入到裂框中。 我们几种方法可验证该问题。

    比如  在 

    list_string = get(handles.listbox1,'string');   % list_string是一个元胞?是
    后面加上  class(list_string) 然后我们就可以在命令行看到结果为 cell


    然而,本文重点不在于次!我想说的是 函数 vertcat 和 函数 cat(1,...)

    这俩个函数在垂直方向拼接输入参数但是他们俩个函数都需要输入参数列相同

    例如

     a = ['123 ';'1234';'4  6']
    
    a =
    
    123 
    1234
    4  6
    
    >> b = '44'
    
    b =
    
    44
    
    >> cat(1,b,a)
    Error using cat
    Dimensions of matrices being concatenated are not consistent.
     
    >> vertcat(b,a)
    Error using vertcat
    Dimensions of matrices being concatenated are not consistent.

    当列相同的时候拼接是成功的

    c = '1470'
    
    
    c =
    
    
    1470
    
    
    >> cat(1,c,a)
    
    
    ans =
    
    
    1470
    123 
    1234
    4  6
    vertcat 结果也一样

    然而,开始的程序在执行的时候却没有错误,这就说明 列表框'string'返回的存储类型绝对不是普通高维数组。cat函数与vertcat函数对与元胞数组也是使用的。例如:

     a = {'1231';'sdfa'}
    
    a = 
    
        '1231'
        'sdfa'
    
    >> b = '1'
    
    b =
    
    1
    
    >> cat(1,b,a)
    
    ans = 
    
        '1'
        '1231'
        'sdfa'
    本人初学matlab,以上均是学习过程中遇到的问题,总结的心得!如果您发现有什么错误,还望指出来!谢谢!


    展开全文
  • Dim属性数组中很重要的属性,也叫维数向量,当维数向量有两个值时代表为矩阵,有一个值时代表为一维数组。#使用向量生成数组或者矩阵 c&lt;-1:12 c # [1] 1 2 3 4 5 6 7 8 9 10 11 12 dim(c)&...

    在R中,数组(Arrary)可以看做是带多个下标的相同类型的元素集合,常用的是数值型的数组如矩阵,也可以是别的类型的数组,比如字符型,逻辑型等。

    Dim属性是数组中很重要的属性,也叫维数向量,当维数向量有两个值时代表为矩阵,有一个值时代表为一维数组。

    #使用向量生成数组或者矩阵
    c<-1:12
    c
    # [1]  1  2  3  4  5  6  7  8  9 10 11 12
    dim(c)<-c(3,4)
    c
    #       [,1] [,2] [,3] [,4]
    # [1,]    1    4    7   10
    # [2,]    2    5    8   11
    # [3,]    3    6    9   12
    
    dim(c)<-12
    c
    # [1]  1  2  3  4  5  6  7  8  9 10 11 12
    class(c)
    # [1] "array"
    
    #使用Arrary来生成数组a   arrary (data,dim=length(data))
    a<-array(1:12,dim=c(3,4))
    a
    
    #       [,1] [,2] [,3] [,4]
    # [1,]    1    4    7   10
    # [2,]    2    5    8   11
    # [3,]    3    6    9   12
    
    #使用matrix来构造矩阵(二维数组)matrix(data,nrow=,ncol=,byrow=True)
    a<-matrix(1:12,3,4) #构建一个3行4列的矩阵
    a
    
    #数组下标的使用
    #数组可以通过1、精确指定下标2、以空值代表所有下标, 3、以向量形式指出下标 4、通过数组形式指出下标
    
    a<-1:24
    dim(a)<-c(2,3,4)  #定义一个三维数组
    
    a[1,2,3]
    # [1] 15
    a[,,3]
    #       [,1] [,2] [,3]
    # [1,]   13   15   17
    # [2,]   14   16   18
    
    a[,2:3,1:2]
    # , , 1
    # 
    #       [,1] [,2]
    # [1,]    3    5
    # [2,]    4    6
    # 
    # , , 2
    # 
    #       [,1] [,2]
    # [1,]    9   11
    # [2,]   10   12
    
    #在不改变数组维度的情况下,将其赋值为0
    a[]<-0
    a
    
    #也可以用其它数组的值来表示该数组的下标
    b<-matrix(c(1,1,1,2,2,3,1,3,4,2,1,4),nrow = 3,ncol = 3)
    b
    #       [,1] [,2] [,3]
    # [1,]    1    2    1
    # [2,]    1    2    3
    # [3,]    1    3    4
    
    a[b]
    # [1]  3 15 23
    
    #同样的我们还可以对其进行赋值运算
    a[b]<-0
    # a
    # , , 1
    # 
    # [,1] [,2] [,3]
    # [1,]    1    0    5
    # [2,]    2    4    6
    # 
    # , , 2
    # 
    # [,1] [,2] [,3]
    # [1,]    7    9   11
    # [2,]    8   10   12
    # 
    # , , 3
    # 
    # [,1] [,2] [,3]
    # [1,]   13    0   17
    # [2,]   14   16   18
    # 
    # , , 4
    # 
    # [,1] [,2] [,3]
    # [1,]   19   21    0
    # [2,]   20   22   24
    
    #数组和矩阵的四则运算是对应元素之间的运算,一般是结构相同才能运算
    #数组和矩阵运算时,是对矩阵的列运算,不匹配时,一般会有警告
    
    #apply函数 apply(A,margin,fun)
    #a代表矩阵,margin=1 代表按行进行fun函数,=2代表按列进行fun函数
    a<-1:6
    dim(a)<-c(2,3)
    a
    #       [,1] [,2] [,3]
    # [1,]    1    3    5
    # [2,]    2    4    6
    apply(a,1,sum)
    # [1]  9 12
    
    
    #矩阵的运算包含转置、求特征向量、特征根等,笔者用到的不多,以后再总结
    

    展开全文
  • Jquery类似框架的封装之伪数组转化为真数组

    千次阅读 热门讨论 2016-11-24 14:30:58
    数组转化为真数组
  • 数组、矩阵、列表和数据的应用 #R语言备忘录三# #数组array和矩阵matrix、列表list、数据dataframe #数组 #数组的重要属性就是dim,维数 #得到4*5的矩阵 z dim(z) (3,4) z #构建数组 x (1:20, dim = c(4,5)...
  • vb学习总结, 列表框  1、属性  1、columns  该属性用来确定列表的列数。当该属性设置为0(默认)是,所用的项目呈单列显示。...list属性保存了列表框中所有值得数组,可以通过下标访问数组中的值(下标值从
  • js在dom元素中根据某些‘属性’排序添加元素过滤已有元素(值相等)单词首字母大写排序 添加元素 var myArr=new Array(),arr=[];//两种数组定义形式 ...//向数组中添加每一个p元素中属性为div...
  • 易语言组合框去重复到列表框

    千次阅读 2019-12-08 19:15:51
    在辅助开发时,我们需要通过组合框控制一些功能,或者获取一些数据,比如把组合框里 的值添加到列表框,这里就需要去除重复的,以下代码实现了这个功能。 .版本 2 .支持库 spec .支持库 EDataStructure .程序集 ...
  • LabVIEW多列列表框背景颜色操作

    千次阅读 2017-08-07 17:27:09
    多列列表框概述在很多情况下我们需要在表格中某一列查找一些指定的元素,并且想让其显示为指定的颜色,此时就可以利用多列列表框的一些属性来解决这一问题。
  • Labview学习笔记2之 多列列表框 目标: 找出鼠标在列表框中选择的位置中的值 指令: 多列表框-属性节点-列首(获得...多列表框-属性节点-项名(获得除行首列首外所有列表框的2维字符串数组) 代码: ...
  • 列表中的元素是向量,这些向量构成数据的列,每一列必须具有相同的长度,所以数据是矩形结构,而且数据的列必须命名。 与矩阵的区别: - 数据形状上很像矩阵; - 数据是比较规则的列表; - 矩阵必须为同一...
  • 支持高级大量的维度数组与矩阵运算,此外也针对数组运算提供大量的数学函数库。Numpy运算效率极好,是大量机器学习框架的基础库。 使用numpy库中的函数前,需使用import关键字引入numpy库,本博客采用以下方式引入...
  • 列表框、组合框

    千次阅读 2010-04-08 15:54:00
    如果项目总数超过了列表框可显示的项目数,列表框会自动添加滚动条,可以方便用户以滚动的方式来选择列表框列表框的常用属性·listcount属性:用于返回列表框中的所有选项的个数,该属性只能在程序代码中调用和设置...
  • javaScript数组属性和方法(示例和解析)

    千次阅读 多人点赞 2018-12-12 21:42:20
    数组属性和方法属性 属性 constructor 描述:返回对创建此对象的数组函数的引用。 语法:object.constructor function employee(name,job,born) { this.name=name; this.job=job; this.born=born; } var bill=...
  • 后台数据的结构如下: "productfactors": [ {//产品投保要素 "factortype": "Period",//要素类型 "datatype": "08",//数据类型 ... { //投保要素值列表 "factorvalue": "1Y",//投保要素值计算值 ...
  • 最后,注意数据和矩阵一样有维数这个属性。  5、列表( List ) : 列表可以用 list 函数创建,方法与创建数据类似。 它对其中包含的对象没有什么限制。和 data.frame() 比较,...
  • JQuery EasyUI combobox(下拉列表框)

    万次阅读 2015-04-01 09:06:58
    下拉列表框 继承 $.fn.combo.defaults. 重写 $.fn.combobox.defaults. 组合框显示一个可编辑的文本框和下拉列表,用户选择一个或多个值。用户可以直接输入文本到顶部的列表,或选择一个或多个当前值列表。 依赖 ...
  • 列表框控件(listbox)消息

    千次阅读 2017-03-15 10:21:37
    列表框主要用于输入,它允许用户从所列出的表项中进行单项或多项选择,被选择的项呈高亮度显示... 应用程序用CreateWindowEx创建列表框控件时,可根据控件的用途在下表中选择部份常数来设定其风格属性(style)。  常
  • 列表框控件

    千次阅读 2005-04-27 16:28:00
    列表框控件(listbox) [下载例程] 列表框主要用于输入,它允许用户从所列出的表项中进行单项或多项选择,被选择的项呈高亮度显示.列表框具有边框,并且一般带有一个垂直滚动条.列表框分单选列表框和多重选择列表...
  •  R中最为基本的类包括了数值、逻辑、字符,在此基础上构成了一些复合型的类,包括矩阵、数组、数据列表。  对于任何一个对象,我们可以用class()函数来观察它的类,同时可以使用attribute()函数来观察其属性...
  • C# 复选列表框 和 imageList组件

    千次阅读 2017-02-09 21:01:17
    复选列表框 CheckedListBox是一个 复选列表框 属性: CheckOnClick属性:指示复选框是否应该在首次点击某项时切换(此属性为false则必须点击两下才能选中选项,为true只需要点击一次) 事件: ...
  • 本文列举了各种JavaScript对象与数组,同时包括对上述每一对象或数组所完成工作的简短描述,以及与其相关的属性方法,以及事件处理程序,还注明了该对象或数组的父对象用户同样可能需要参考Online Companion中的超级文本...
  • R语言的对象(Objects)主要包括向量、矩阵、数组、数据列表。 R语言的对象有五种最基本的类型,即,字符型(character)、数值型(numeric,包括小数)、整型(integer)、复数型(complex)以及逻辑型...
  • var chk_value =[];//定义一个数组   $('input[name="communicateTeacher.claIds"]:checked').each(function(){//遍历每一个名字为interest的复选,其中选中的执行函数   chk_value
  • MFC在编辑中显示一个二维数组

    千次阅读 2014-03-05 00:14:30
    想到总结这个问题是因为在先前的那个扫雷程序中,想实现在一个界面上显示当前的地雷的布局,实际上是显示一个二维数组,当时想了一些办法,觉得类似的可能用得上故作一个简单的总结。雷区的方格存储的是数字,-1的...
  • 绑定列表框组件的item到ArrayList或Option[]ArrayList要求包含的数组是Option[]3.绑定列表框组伯的selected到String[]4.可以从selected绑定的String[]属性去获得所selected的东东即值列表5.可以修改ArrayList
  • 下拉列表框的右下角有一个小三角,点击这个小三角就可以展开列表框,选择某一项后列表框自动收起,列表框会显示选择的一项的内容。 在activity_main.xml文件中,用Spinner标签来定义下拉列表框属性: android...
  • javascript 数组

    2009-10-30 10:49:00
    options数组数组是select对象的一个属性,即选择中的所有选项()的一个列表属性 defaultSelected 选项列表中的缺省选项 index 选项列表中某选项的索引位置 length 选项列表中的选项数() name 选项列表的名字...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 132,892
精华内容 53,156
关键字:

列表框的什么属性是数组