精华内容
下载资源
问答
  • 列表框的什么属性返回
    千次阅读
    2019-11-22 14:01:41

    列表框

    列表框允许用户从多个对象中选择一项或多项,这些对象可以是文本、文件和位图等。当列表框的项不能全部显示出来时,可以用滚动条来滚动显示。

    1. 基础知识
    默认的列表框只允许用户单选,需要多选时,须把列表框的风格定义为 LBS_ MULTIPLESEL 和 LBS_EXTENDEDSEL 。列表框提供的其他风格取值可以控制列表框的外观和操作。例如是否按照列表框各项的名称排序,是否多行排列,是否有滚动条等。

    风格取值                   描述
    LBS_EXTENDEDSEL           //能通过Shift键或者鼠标进行多选
    LBS_HASSTRINGS            //可以用GetText函数得到列表框里选项的字符串
    LBS_MULTICOLUMN           //指定列表框以多列形式显示内容
    LBS_MULTIPLESEL           //用户可以选择多个项
    LBS_NOINTEGRALHEIGHT      //当应用程序创建列表框时,列表框的大小由系统指定
    LBS_NOREDRAW              //列表框不响应用户的修改,可以通过发送WM_REDRAW 来取消该设置
    LBS_NOTIFY                //让主窗口接收列表框的任何改变的消息
    LBS_OWNERDRAWFIXED        //主窗口负责列表框的重画,列表框里每项的高度相同
    LBS_0WNERDRAWVARIABLE     //主窗口负责列表框的重画,列表框里每项的高度可以变化
    LBS_SORT                  //按各项名称的字母排序
    LBS_STANDARD              //等同于LBS_SORT和LBS_NOTIFY
    LBS_USETABSTOPS           //允许用户使用Tab键在各项中切换
    LBS_WANTKEYBOARDINPUT     //输入焦点在列表框时,任何键盘输入都会向父窗口发送WM_VKEYTOITEM或者WM_CHARTOITEM消息
    LBS_DISABLENOSCROLI       //当列表框的项不够时,垂直滚动条禁活:没有该属性时,滚动条隐藏

    当用户对列表框进行了操作时,就会向主窗口发送一条消息。列表框的消息类型比较简单,主要是单击、双击和选择等。同编辑框一样,列表框也会遇到内存不够的问题,所以消息类型中含有这一项。消息总是通过WM_COMMAND的形式发送给主窗口的。其中,wParam的低位字节表示列表框的标识符,高位字节表示消息的类型,lParam表示主窗口句柄。列表框的消息类型如表所示。

    消息类型                   描述
    LB_DELETESTRING           //删除指定的选项
    LB_ADDFILE                //向列表框里增加一个文件(包括目录)
    LB_FINDSTRING             //在列表框里查找指定的项
    LB_FINDSTRlNGEXACT        //精确查找指定的项
    LB_GETCOUNT               //得到列表框里项的数目
    LB_GETCURSEL              //返回当前被选中选项的序号
    LB_GETSEL                 //得到被选项的状态,如果出错,则返回零值
    LB_GETSELCOUNT            //得到被选中的个数
    LB_GETTEXT                //返回选中的文本,返回值为字符串长度
    LB_GETTEXTLEN             //返回字符串长度
    LB_INITSTORAGE            //向列表框增加项之前存储原来的内容
    LB_INSERTSTRING           //向列表框增加一项,但不重新排序
    LB_ITEMFROMPOINT          //返回离指定点最近项的序号
    LB_RESETCONTENT           //清除列表框里所有的项
    LB_SELECTSTRING           //寻找指定的项
    LB_SELITEMRANGE           //指定选择的范围
    LB_SELITEMRANGEEX         //选定或者删除指定的项
    LB_SETCOLUMNWIDTH         //设置列的宽度
    LB_SETCOUNT               //设置列表框里项的最大数目
    LB_SETCURSEL              //选中指定的项
    LBN_DBLCLK                //发送用户双击的消息
    LBN_ERRSPACE              //发送内存空间不够的消息
    LBN_KILLFOCUS             //当列表框失去焦点时发送该消息
    LBN_SELCANCEL             //当用户取消选择时发送该消息
    LBN_SELCHANGE             //当用户选择改变时发送该消息
    LBN_SETFOCUS              //当输入焦点转移到列表框时发送该消息
    WM_CTLCOLORLISTBOX        //在列表框重画时向父窗口发送该消息
    WM_DELETEITEM             //删除选项
    WM_VKEYTOITEM             //输入焦点在列表框里,用户按键时发送该消息

    鼠标右键WM_CONTEXTMENU 消息就行了。wParam 是点击右键的窗口的句柄,lParam 是鼠标坐标。如果用户使用 SHIFT+F10 来响应菜单,那么 lParam 收到的坐标都是 -1。
    LOWORD(wParam) 子窗口ID
    HIWORD(wParam) 通知码
    Lparam 子窗口句柄

     

    2. 定义列
    增加列需要用列的结构LVCOLUMN,定义如下:

    typedef struct _LVCOLUMN {
    UINT mask;                //定义该列可使用的类型
    int fmt;                  //定义列格式
    int cx;                   //定义列宽度(以像素为单位)
    LPTSTR pszText;           //列内容
    int cchTextMax;           //列内容最大长度
    int iSubItem;             //定义此列序号
    #if (_WIN32_IE >= 0x0300)
    int iImage;               //指向图像
    int iOrder;               //零基列偏移量。列偏移量是从左到右的顺序。例如0列在最左边。
    #endif #if (_WIN32_WINNT >= 0x0600)
    int cxMin;                //指定列宽最小值
    int cxDefault;            //默认列宽
    int cxIdeal;              //只读,作为列宽的理想宽度自动调整宽度大小
    #endif
    } LVCOLUMN, *LPLVCOLUMN;  //结构名称

    使用方法:
    SendMessage(hwnd, LVM_INSERTCOLUMN, 0, (LPARAM)&colmn)
    还有LVM_GETCOLUMN LVM_SETCOLUMN LVM_DELETECOLUMN

     

    3. 改变项
    改变项需要结构体LVITEM,定义如下:

    typedef struct {
    UINT mask;              //设置成员标志,如格式等
    int iItem;              //项目索引
    int iSubItem;           //添加到的列序
    UINT state;             //指明项目状态,如图片,叠加图片
    UINT stateMask;         //指state成员的有效位
    LPTSTR pszText;         //项目内容
    int cchTextMax;         //项目最大长度
    int iImage;             //指向图片索引
    LPARAM lParam;          //特殊值,如果你用SORTITEM它就需要这个,或者别的特别的
    #if (_WIN32_IE >= 0x0300)
    int iIndent;            //图片宽度
    #endif
    #if (_WIN32_WINNT >= 0x0501)
    int iGroupId;           //指向所在的组id
    UINT cColumns;          //需要展示的列数,最大为20
    UINT puColumns;         //返回这个项目所指向的列
    #endif
    #if (_WIN32_WINNT >= 0x0600)
    int piColFmt;           //返回列属性
    int iGroup;             //项目列
    #endif
    } LVITEM, *LPLVITEM;

    使用方法:
    SendMessage(hres, LVM_INSERTITEM, 0, (LPARAM)&item);

    更多相关内容
  • 列表框的selected属性

    千次阅读 2021-06-10 17:17:36
    Φ是什么意思?读"fai".是直径的意思不?...而用作列表框和组合框有没有select属性列表框有selected,表示是否选中:If List1.Selected(i) Then 组合框只允许选一个,没有select,Combo1.ListIndex即为当前选中...

    Φ是什么意思?读"fai".是直径的意思不?

    “Φ”是数学中表示圆的直径的希腊字母。 “Φ”是希腊字母中的一个,读作fai,其写法分为两种,大写:Φ,小写:φ,小写时左上角的弯是开口的;而用作

    列表框和组合框有没有select属性

    4c9bc99dde5846b4eccc572c8d01b153.png

    列表框有selected,表示是否选中:If List1.Selected(i) Then 组合框只允许选一个,没有select,Combo1.ListIndex即为当前选中的项

    html 里select 下拉列表中设置默认值怎么写

    &nbsp设置下拉列表框的默认值:使用关键字selected < select name = "pronvince"> < option value ="SH">上海 < option value ="BJ">北京 < option value ="JS">江苏 < option value ="HB" selected="selected">湖北 < option value ="ZJ">浙江 如果希

    怎样用js取得select下拉列表框内选中的option的val1

    急vb里,列表框有list ,selected,text,listcou...想请教VB里的高手,至少比我强的 我一直不怎么会LISTBOX的代码编写 谢啦。list 返回某一项的内容,如 print list1.list(0) selected 判断某项是否被选定 text 返回某一项的内容 一般用于list1_click中 listcount 返回list中一共有多少项 参考。。

    html中下拉列表框中的全部属性

    1.下拉框当前选中项目 obj.selectedIndex 2.下拉框项目数 obj.length 3.下拉框第N项的值 obj.options[N-1].value 4.下拉框第N项的“描述值” obj.options[N-1].text 5.选中第N项 obj.options[N-1].selected = true; =false;即为不选中 6.在末尾增

    ligerui list getselecteditems列表框怎么获取到选问1:在action里写Xname的getset方法只3,要action被触发,jsp页面上的select就把选中的值传到Xname里了。注意里存的是一个Map类型的一个key对应一个value。key和value在后台都是能够拿到的具体用哪个标签看一下struts2的文档,很详细。

    如何判断asp中下拉列表框是选的那个选项

    大米是5.6黄豆是6.3 如何在第一个选择之后 ,线面的菜单直接显示??

    asp下拉列表框怎么实现在asp当中如果选择了一个列表框中的值后,当比如在同一页中按了我可以给你思路,具体代码你自己写:

    添加一个INPUT,类型为HIDDEN,目标action为当前页。

    添加JAVASCRIPT代码,事件为列表框onchange,将选定value赋值给HIDDEN.

    同一页面最上面添加表单的提取代码

    紧急CSS布局HTML小编今天和大家分享助:jsp提交表单查询后,下拉列表框(SELECT我想在提交包含班级和学生和学期查询条件的表单(form)后,由struts处建议你试一试strust 标签

    展开全文
  • 列表框控件(ListBox)的常用属性 属性 说明 (Name) 列表框控件的名称 Appearance 是否用立体效果绘制,取值为:0 平面 1 3D(立体) BackColor 设置背景颜色,可从弹出的调色板选择。 该控件获得焦点时,失去焦点的控件...

    💗 大家好🤗🤗🤗,我是左手の明天!💗

    📆  最近更新:2022 年 5 月 24 日,左手の明天的第 244 篇原创博客

    📚 更新于专栏:Matlab GUI编程技巧


    目录

    🚩listbox控件用法和属性

    🚩 回调函数

    🚩添加/删除列表框中的项目

    ⭐️删除ListBox的某一项

    ⭐️添加ListBox的某一项

    ⭐️删除“空”项中的simpliest办法

    🚩listbox读取/添加不重复数据

    ⭐️读取数据

    ⭐️写入数据

    🚩创建列表框组件:uilistbox

    ⭐️语法

    ⭐️输入参数

    parent - 父容器

    Value - 值

    Items - 列表框项目

    ItemsData - 与 Items 属性值的每个元素关联的数据

    Multiselect - 多项目选择

    ValueChangedFcn - 值更改函数

    Position - 列表框的位置和大小

    ⭐️创建列表框

    ⭐️设置和访问列表框属性值 

    ⭐️显示列表框选项

    ⭐️显示列表框数据

    ⭐️允许选择多个项目的列表框


    🚩listbox控件用法和属性

    列表框是一种 UI 组件,用于显示列表中的项目。可通过属性控制列表框的外观和行为。使用圆点表示法引用特定的对象和属性:

    fig = uifigure;
    list = uilistbox(fig);
    list.Items = {'Red','Green','Blue'};

    属性列表:

    • Value - 值
    • Items - 列表框项目
    • ItemsData - 与 Items 属性值的每个元素关联的数据
    • FontName - 字体名称
    • FontSize - 字体大小
    • FontWeight - 字体粗细

    字体粗细,指定为下列值之一:

    1.  'normal' - 特定字体定义的默认粗细
    2. 'bold' - 字符轮廓比 'normal' 粗 并非所有字体都有加粗字体。对于非加粗字体,指定 'bold' 会得到普通字体。

    • FontAngle - 字体角度

    字体角度,指定为 'normal' 或 'italic'。并非所有字体都有倾斜字体角度。对于无斜体字体,指定 'italic' 后会使用常规字体角度。

    • FontColor - 字体颜色

    字体颜色,指定为 RGB 三元组、十六进制颜色代码或下表中列出的选项之一。

    RGB 三元组和十六进制颜色代码对于指定自定义颜色非常有用。

    1.  RGB 三元组是包含三个元素的行向量,其元素分别指定颜色中红、绿、蓝分量的强度。强度值必须位于 [0,1] 范围内,例如 [0.4 0.6 0.7]
    2. 十六进制颜色代码是字符向量或字符串标量,以井号 (#) 开头,后跟三个或六个十六进制数字,范围可以是 0 到 F。这些值不区分大小写。因此,颜色代码   '#FF8800'   与   '#ff8800''#F80' 与 '#f80' 是等效的。

     下表列出了命名颜色选项、等效 RGB 三元组和十六进制颜色代码。

    颜色名称短名称RGB 三元组十六进制颜色代码
    'red''r'[1 0 0]'#FF0000'
    'green''g'[0 1 0]'#00FF00'
    'blue''b'[0 0 1]'#0000FF'
    'cyan''c'[0 1 1]'#00FFFF'
    'magenta''m'[1 0 1]'#FF00FF'
    'yellow''y'[1 1 0]'#FFFF00'
    'black''k'[0 0 0]'#000000'
    'white''w'[1 1 1]'#FFFFFF'
    • BackgroundColor - 背景色
    • Visible - 可见性状态

    可见性状态,指定为 'on' 或 'off',或者指定为数值或逻辑值 1 (true) 或 0 (false)。值 'on' 等效于 true'off' 等效于 false

    1.  'on' - 显示对象。
    2.  'off' - 隐藏对象而不删除它。您仍然可以访问不可见 UI 组件的属性。
    •  Multiselect - 多项目选择
    • Enable - 工作状态
    • ContextMenu - 上下文菜单
    • Position - 列表框的位置和大小
    • InnerPosition - 列表框的内部位置和大小
    • OuterPosition - 列表框的外部位置和大小
    • Layout - 布局选项

    布局选项,指定为 GridLayoutOptions 对象。此属性为网格布局容器的子级组件指定选项。如果组件不是网格布局容器的子级(例如,它是图窗或面板的子级),则此属性为空且不起作用。但是,如果组件是网格布局容器的子级,则可以通过在 GridLayoutOptions 对象上设置 Row 和 Column 属性,将组件放置在网格的所需行和列中。

    例如,以下代码将一个列表框放置在其父网格的第三行第二列中。

    g = uigridlayout([4 3]);
    list = uilistbox(g);
    list.Layout.Row = 3;
    list.Layout.Column = 2;

    要使该列表框跨多个行或列,请将 Row 或 Column 属性指定为二元素向量。例如,此列表框跨列 2 到 3

    list.Layout.Column = [2 3];
    • Type - 图形对象的类型
    • Tag - 对象标识符
    • UserData - 用户数据

    🚩 回调函数

    (1)Callback - 用户与控件交互时执行的回调函数

    Note:''(默认) | 函数句柄 | 元胞数组 | 字符串

    此函数使控件响应用户输入,例如按钮点击、滑动条移动或复选框选中。

    (2)CreateFcn - 控件创建函数

    Note:函数句柄 | 元胞数组 | 字符串

    该属性指定要在 MATLAB 创建 uicontrol 时执行的回调函数。MATLAB 在执行 CreateFcn 回调之前初始化所有的控件属性值。如果不指定 CreateFcn 属性,则 MATLAB 执行默认的创建函数。

    CreateFcn 代码中使用 [gcbo] 函数可以获得创建的控件的句柄。

    对现有控件设置 CreateFcn 属性没有任何作用。

    (3)DeleteFcn - 控件删除函数

    Note:函数句柄 | 元胞数组 | 字符串

    DeleteFcn 属性指定要在 MATLAB 删除控件时(例如,最终用户删除图形时)执行的回调函数。MATLAB 在销毁控件的属性之前执行 DeleteFcn 回调。如果不指定 DeleteFcn 属性,则 MATLAB 执行默认的删除函数。

    在 DeleteFcn 代码中使用 gcbo 函数以获得删除的控件的句柄。

    (4)ValueChangedFcn - 值更改函数

    当用户从列表框中选择不同的项目时,将会执行此回调函数。如果以编程方式更改 Value 属性设置,将不会执行此回调函数。

    此回调函数可以访问有关用户与列表框的交互的特定信息。MATLAB 将 ValueChangedData 对象中的此信息作为第二个参数传递给回调函数。在 App 设计工具中,该参数名为 event。您可以使用圆点表示法查询对象属性。例如,event.PreviousValue 返回列表框的上一个值。ValueChangedData 对象不可用于指定为字符向量的回调函数。

    下表列出了 ValueChangedData 对象的属性。

    属性
    Value列表框在 App 用户最近一次与它交互之后的值
    PreviousValue列表框在 App 用户最近一次与它交互之前的值
    Source执行回调的组件
    EventName'ValueChanged'

    🚩添加/删除列表框中的项目

    实现的功能

    matlab中尝试创建一个列表框,可以动态添加或删除项目

    需要用到listboxhandle,可以用findobj来获得

    hMyListBox = findobj('type', 'listbos'); %如果你的GUI上只有一个listbox的话

    ⭐️删除ListBox的某一项

    oldString = get(hMyListBox, 'String'); 
    curPos = get(hMyListBox, 'Value'); 
    oldString(curPos) = []; 
    set(hMyListBox, 'String', oldString);

    当然也可以通过以下方式实现:

    n=get(handles.listbox,'value'); %获取选中的行号
    str=get(handles.listbox,'string'); %获取列表中的所有数据
    m=size(str1,1);
    k=0;
    for i=1:m
        for j=1:size(n,2)
            if(i~=n(j))
                k=k+1;
                str1(k,:)=str(i,:);
            end
        end
    end
    set(handles.listbox,'string',str1);

    ⭐️添加ListBox的某一项

    newItem={'This is a new string'}; 
    oldString = get(hMyListBox, 'String'); 
    curPos = get(hMyListBox, 'Value'); 
    numStrings = length(oldString); 
    newString = {oldString(1:curPos) newItem oldString(curPos:numStrings)}; 
    set(hMyListBox, 'String', newString);

    ⭐️删除“空”项中的simpliest办法

    删除“空”项中的simpliest办法就是更新listbox字符串与remainig项目。

    有三种可能性:

    • 第一个元素已被删除:新列表将为upd_list={existingItems{2:end}}
    • 最后一个元素已被删除:新列表将为upd_list={existingItems{1:end-1}}
    • ans中间元素已被删除:新列表将为upd_list={existingItems{1:selectedId-1} existingItems{selectedId+1:end}}

    还可以检查列表的所有元素都被删除,在这种情况下,禁用“删除”pushbutton;在这种情况下,您必须在“添加”callback中启用它。

    btnDeleteLabel_Callback相关代码可以为如下:

    % --- Executes on button press in btnDeleteLabel. 
    function btnDeleteLabel_Callback(hObject, eventdata, handles) 
    % hObject handle to btnDeleteLabel (see GCBO) 
    % eventdata reserved - to be defined in a future version of MATLAB 
    % handles structure with handles and user data (see GUIDATA) 
    
    selectedId = get(handles.listbox_labels, 'Value')  % get id of selectedLabelName 
    existingItems = get(handles.listbox_labels, 'String') % get current listbox list 
    % 
    % It is not necessary 
    % 
    % existingItems{selectedId} = []     % delete the id 
    
    % Identify the items: if in the list only one ites has been added the 
    % returned list is a char array 
    if(class(existingItems) == 'char') 
        upd_list='' 
        set(handles.listbox_labels, 'String', upd_list) 
    else 
        % If the returned list is a cell array there are three cases 
        n_items=length(existingItems) 
        if(selectedId == 1) 
         % The first element has been selected 
         upd_list={existingItems{2:end}} 
        elseif(selectedId == n_items) 
         % The last element has been selected 
         upd_list={existingItems{1:end-1}} 
         % Set the "Value" property to the previous element 
         set(handles.listbox_labels, 'Value', selectedId-1) 
        else 
         % And element in the list has been selected 
         upd_list={existingItems{1:selectedId-1} existingItems{selectedId+1:end}} 
        end 
    end 
    % Update the list 
    set(handles.listbox_labels, 'String', upd_list)  % restore cropped version of label list 
    
    % Disable the delete pushbutton if there are no more items 
    existingItems = get(handles.listbox_labels, 'String') 
    if(isempty(existingItems)) 
        handles.btnDeleteLabel.Enable='off' 
    end 

    🚩listbox读取/添加不重复数据

    ⭐️读取数据

    • 如果列表只有1个数据,则读取格式为char;
    • 如果列表有多于1个数据,则读取格式为cell;

    因此,为了统一,使用了str to cell转换函数cellstr()

    print_list = cellstr(get(handles.listbox2,'string'));

    ⭐️写入数据

    将new_print_list写入listbox中

    set(handles.listbox,'string',new_print_list);

    缺陷:以上方式会清空原来listbox中的数据,直接用new_print_list覆盖。

    如果想要保留原来listbox中的数据,而且满足 “如果新数据已经在列表中,则忽略;否则就加到列表中”,那么可以改为以下代码:

    % 先读取原list中的数据
    print_list = cellstr(get(handles.listbox,'string'));
    
    % 如果new_print_list是新数据,则加入列表;否则不加入
    if ~strcmp(cur_str, print_list)
    	new_print_list = [print_list; cellstr(cur_str)];
    	set(handles.listbox,'string',new_print_list);
    end

    🚩创建列表框组件:uilistbox

    ⭐️语法

    • lb = uilistbox :在新图窗窗口中创建一个列表框,并返回 ListBox 对象。
    • lb = uilistbox(parent) :在指定的父容器中创建列表框。父容器可以是使用uifigure函数创建的 Figure 或其子容器之一。
    • lb = uilistbox(___,Name,Value) :使用一个或多个 Name,Value 对组参数指定 ListBox 属性。

    ⭐️输入参数

    parent - 父容器

    指定为使用 uifigure 函数创建的 Figure 对象或其子容器之一:TabPanelButtonGroup 或 GridLayout。如果不指定父容器,MATLAB 会调用 uifigure 函数创建新 Figure 对象充当父容器。

    Value - 值

    指定为 Items 数组或 ItemsData 数组的元素,或指定为空元胞数组。默认情况下,Value 是 Items 中的第一个元素。

    要不指定任何选择,请将 Value 设置为空元胞数组。

    将 Value 指定为 Items 的元素,即可选择与该元素匹配的列表项。如果 ItemsData 非空,则 Value 必须设置为 ItemsData 的元素,而列表框将选中列表中的关联项目。

    Items - 列表框项目

    指定为字符向量元胞数组、字符串数组或一维分类数组。允许重复的元素。列表框显示的选项与 Items 数组中的元素数量一样多。如果将此属性指定为分类数组,MATLAB 将使用数组中的值,而不是完整的类别集。

    ItemsData - 与 Items 属性值的每个元素关联的数据

    与 Items 属性值的每个元素关联的数据,指定为 1×n 数值数组或 1×n 元胞数组。允许重复的元素。

    例如,如果您将 Items 值设置为员工姓名,则可以将 ItemsData 值设置为对应的员工 ID 号。ItemsData 值对 App 用户不可见。

    如果 ItemsData 值和 Items 值中的数组元素数量不匹配,将发生以下情况之一:

    • 如果 ItemsData 值为空,则 Items 值的所有元素都呈现给 App 用户。

    • 如果 ItemsData 值中的元素数大于 Items 值,则 Items 值的所有元素都呈现给 App 用户。MATLAB 将忽略多余的 ItemsData 元素。

    • 如果 ItemsData 值非空,但元素数少于 Items 值,只将在 ItemsData 值中具有对应元素的 Items 值的元素呈现给 App 用户。

    示例: {'One','Two','Three'}

    示例: [10 20 30 40]

    Multiselect - 多项目选择

    多项目选择,指定为 'off' 或 'on',或者指定为数值或逻辑值 1 (true) 或 0 (false)。值 'on' 等效于 true'off' 等效于 false。因此,您可以使用此属性的值作为逻辑值。

    ValueChangedFcn - 值更改函数

    当用户从列表框中选择不同的项目时,将会执行此回调函数。如果以编程方式更改 Value 属性设置,将不会执行此回调函数。

    此回调函数可以访问有关用户与列表框的交互的特定信息。MATLAB 将 ValueChangedData 对象中的此信息作为第二个参数传递给回调函数。在 App 设计工具中,该参数名为 event。您可以使用圆点表示法查询对象属性。例如,event.PreviousValue 返回列表框的上一个值。ValueChangedData 对象不可用于指定为字符向量的回调函数。

    下表列出了 ValueChangedData 对象的属性。

    属性
    Value列表框在 App 用户最近一次与它交互之后的值
    PreviousValue列表框在 App 用户最近一次与它交互之前的值
    Source执行回调的组件
    EventName'ValueChanged'

    Position - 列表框的位置和大小

    列表框相对于父容器的位置和大小,指定为向量 [left bottom width height]。下表介绍该向量中的每个元素。

    元素说明
    left父容器的内部左边缘与列表框的外部左边缘之间的距离
    bottom父容器的内部下边缘与列表框的外部下边缘之间的距离
    width列表框的左右外部边缘之间的距离
    height列表框的上下外部边缘之间的距离

    所有测量值都以像素为单位。

    Position 值相对于父容器的可绘制区域。可绘制区域是指容器边框内的区域,不包括装饰元素(如菜单栏或标题)所占的区域。

    示例: [100 100 100 200]

    ⭐️创建列表框

    在图窗窗口中创建一个列表框。

    fig = uifigure('Position', [100 100 300 250]);
    lbx = uilistbox(fig);

    ⭐️设置和访问列表框属性值 

    创建一个列表框。

    fig = uifigure;
    lbx = uilistbox(fig);

    确定列表框是否允许多选。

    multi = lbx.Multiselect
    
    multi =
    
         off

    允许多选。

    lbx.Multiselect = 'on';

    ⭐️显示列表框选项

    创建一个列表框,以便在用户选择列表中的某个项目时执行相应操作。

    将以下代码以 selectlistbox.m 文件保存到 MATLAB 路径上。

    此代码将创建一个 App,其中包含一个列表框和一个文本区域。ValueChangedFcn 回调将更新文本区域以显示列表框选项。

    function selectlistbox
    
    fig = uifigure('Position',[100 100 350 275]);
    
    % Create text area
    txt = uitextarea(fig,...
        'Position',[125 90 100 22],...
        'Value','First');
    
    % Create list box
    lbox = uilistbox(fig,...
        'Position',[125 120 100 78],...
        'Items',{'First','Second','Third'},... 
        'ValueChangedFcn', @updateEditField); 
    
    % ValueChangedFcn callback
    function updateEditField(src,event) 
        txt.Value = src.Value;
    end
    
    end

    运行 selectlistbox 并从列表中选择一个选项。

    ⭐️显示列表框数据

    创建一个列表框,其中的每个项目都有关联的数值。当用户选择列表框中的项目时,编辑字段将显示关联的数值。

    将以下代码以 dataselection.m 文件保存到 MATLAB 路径上。此代码将创建一个 App,其中包含一个列表框和一个数值编辑字段。列表中的每一项都有与其关联的温度。当用户选择列表中的项目时,ValueChangedFcn 回调将在编辑字段中显示相应的温度。

    function dataselection
    fig = uifigure('Position',[100 100 350 275]);
    
    % Create Numeric Edit Field
    ef = uieditfield(fig,'numeric',...
        'Position',[125 90 100 22]);
    
    % Create List Box
    lbox = uilistbox(fig,...
        'Items', {'Freezing', 'Warm', 'Hot', 'Boiling'},...
        'ItemsData', [0, 25, 40, 100],...
        'Position',[125 120 100 78],...
        'ValueChangedFcn', @selectionChanged);
    
    % ValueChangedFcn callback
    function selectionChanged(src,event)
        % Display list box data in edit field
        ef.Value = src.Value;
    end
    
    end

    运行 dataselection 并选择列表中的项目。数值编辑字段将更新以反映与所选项相关联的温度。

    ⭐️允许选择多个项目的列表框 

    创建一个 App,其中包含一个列表框,允许选择多个项目。编写 ValueChangedFcn 回调以便在列表框下方的文本区域中显示所选项。

    将以下代码以 multiselect.m 文件保存到 MATLAB 路径上。

    function multiselect
    fig = uifigure('Position',[100 100 350 275]);
    
    % Create Text Area
    txt = uitextarea(fig,...
        'Position',[125 80 100 50]);
    
    % Create List Box
    lbox = uilistbox(fig,...
        'Position',[125 150 100 78],...
        'Multiselect','on',...
        'ValueChangedFcn',@selectionChanged);
    
    % ValueChangedFcn callback
    function selectionChanged(src,event)
        txt.Value = src.Value;
    end
    
    end

    运行 multiselect,然后从列表中选择项目。文本区域显示您选择的内容。


    🌟全文共9567个字,码字总结不易,老铁们来个三连:点赞、关注、评论🌟

    🌟作者:左手の明天🌟

    🌟原创不易,转载请联系作者并注明出处🌟

    展开全文
  • 511遇见易语言教程列表框属性方法

    千次阅读 2020-07-09 09:06:20
    本节视频录制了易语言列表框的取项目文本、置项目文本、加入项目、插入项目、是否被选择、取所有选择项目等属性方法。 易语言教程列表框视频教程源码: .版本 2 .程序集 窗口程序集_启动窗口 .子程序 _按钮1_...

    本节视频录制了易语言列表框的取项目文本、置项目文本、加入项目、插入项目、是否被选择、取所有选择项目等属性方法。

    易语言教程列表框视频教程源码:

    .版本 2
    
    .程序集 窗口程序集_启动窗口
    
    .子程序 _按钮1_被单击
    
    信息框 (列表框1.取项目文本 (列表框1.现行选中项), #信息图标, , )
    
    .子程序 _按钮2_被单击
    
    信息框 (列表框1.取项目文本 (到整数 (编辑框1.内容)), #信息图标, , )
    
    .子程序 _按钮3_被单击
    
    列表框1.置项目文本 (列表框1.现行选中项, 编辑框1.内容)
    
    .子程序 _按钮4_被单击
    .局部变量 项目索引
    
    项目索引 = 列表框1.加入项目 (编辑框1.内容, )
    列表框1.现行选中项 = 项目索引
    
    .子程序 _按钮5_被单击
    .局部变量 项目索引, 整数型
    
    项目索引 = 列表框1.插入项目 (到整数 (编辑框1.内容), 编辑框2.内容, )
    列表框1.现行选中项 = 项目索引
    
    .子程序 _按钮6_被单击
    .局部变量 bool, 逻辑型
    
    bool = 列表框1.是否被选择 (到整数 (编辑框1.内容))
    .如果 (bool)
    信息框 (“被选择”, 0, , )
    .否则
    信息框 (“没有选择”, 0, , )
    .如果结束
    
    .子程序 _按钮7_被单击
    .局部变量 项目数组, 整数型, , "0"
    .局部变量 选择数量
    .局部变量 索引文本, 文本型
    .局部变量 项目文本, 文本型
    .局部变量 n, 整数型
    
    项目数组 = 列表框1.取所有被选择项目 ()
    选择数量 = 取数组成员数 (项目数组)
    .如果真 (选择数量 = 0)
    信息框 (“请选择项目”, 0, , )
    返回 ()
    .如果真结束
    
    .计次循环首 (选择数量, n)
    
    索引文本 = 索引文本 + #换行符 + 到文本 (项目数组 [n])
    
    项目文本 = 项目文本 + #换行符 + 列表框1.取项目文本 (项目数组 [n])
    
    .计次循环尾 ()
    
    信息框 (“被选中的项目文本:” + 索引文本 + 项目文本, 0, , )

    源码:511遇见易语言教程

               511遇见易语言教程视频链接

               易语言教程列表框属性方法

    展开全文
  • 本文要讲的是列表框控件(ListBox)及其使用实例。 Xtreme Toolkit Pro是屡获殊荣的VC界面库,是MFC开发中最全面界面控件套包,它提供了Windows开发所需要的11种主流的Visual C++ MFC控件,包括Command Bars、...
  • Qt QListWidget列表框用法详解

    千次阅读 2022-01-25 13:30:02
    Qt QListWidget列表框用法详解 很多应用程序中需要以列表的形式向用户展示数据(资源),比如 Windows 操作系统会以列表的方式展示很多张桌面背景图(如图 1a) 所示),再比如很多音乐播放器中以列表的形式展示音乐...
  • 微信公众号原文 系统:Windows 7 软件:Excel 2010 / Access 2010 这个系列介绍常用的控件 包括在界面端的设置及在代码端的实现 ...列表框支持多选(属性表-其他-多重选择-展开的),本文目标在于...
  • 然而,开始的程序在执行的时候却没有错误,这就说明 列表框'string'返回的存储类型绝对不是普通高维数组。cat函数与vertcat函数对与元胞数组也是使用的。例如: a = {'1231';'sdfa'} a = '1231' 'sdfa' >>...
  • 超级列表框* 英文名称:Insert 在指定的位置插入新表项,成功返回新表项的位置索引,失败返回 -1 。本命令为初级对象成员命令。 参数<1>的名称为“插入位置”,类型为“整数型(int)”,可以被省略。指定新...
  • 常用控件:列表框控件ListBox

    千次阅读 2017-09-29 10:10:18
    列表框可分为单选列表框和多选列表框,顾名思义,单选列表框中一次只能选择一个列表项,而多选列表框可以同时选择多个列表项。  列表框也会向父窗口发送通知消息。这些通知消息含义如下:  LBN_DBLCLK:用户...
  • vb列表框ListBox的详细使用方法

    万次阅读 2018-06-12 15:19:45
    列表框(ListBox)控件表示一个选项清单,用户可能用鼠标选择其中一个或者几个选项。 列表框的特点是:列表框中的项目是通过程序插入到其中的,用户无法向清单中输入数据,当选择其中的项
  • 易语言组合框去重复到列表框

    千次阅读 2019-12-08 19:15:51
    在辅助开发时,我们需要通过组合框控制一些功能,或者获取一些数据,比如把组合框里 的值添加到列表框,这里就需要去除重复的,以下代码实现了这个功能。 .版本 2 .支持库 spec .支持库 EDataStructure .程序集 ...
  • VC++60 第十二章 列表框和组合框

    千次阅读 2016-10-13 17:49:48
    第十二章 列表框和组合框   列表框是显示一系列项供用户选择的控件,对选中的项可以进行后续的处理。用户选择可以是多项的,但本章的例程设计为单选的。组合框是一个编辑框带一个可以下拉的列表框,用户在...
  • 列表框可分为单选列表框和多选列表框,顾名思义,单选列表框中一次只能选择一个列表项,而多选列表框可以同时选择多个列表项。   列表框也会向父窗口发送通知消息。这些通知消息及含义如下: LBN_DBLCLK :用户用...
  • ListBox控件—列表控件 --常用的属性和方法 Items: public ObjectCollection Items {get; } 摘要: 该属性使用户可以获取当前存储在ListBox中的项列表的引用,可以在集合中添加项、移除项、获取项计数 返回结果...
  • 列表框控件简介

    千次阅读 2015-09-29 11:26:36
    列表框可分为单选列表框和多选列表框,顾名思义,单选列表框中一次只能选择一个列表项,而多选列表框可以同时选择多个列表项。  列表框也会向父窗口发送通知消息。这些通知消息及含义如下:  LBN_DBLCLK :...
  • 列表框控件(listbox)消息

    千次阅读 2017-03-15 10:21:37
    列表框主要用于输入,它允许用户从所列出的表项中进行单项或多项选择,被选择的项呈高亮度显示... 应用程序用CreateWindowEx创建列表框控件时,可根据控件的用途在下表中选择部份常数来设定其风格属性(style)。  常
  • CListBox类控件的使用 (一) CListBox类控件...列表框通常出现在对话框里,如用列表框选择文 件名、目录等。列表框有一个预定义的键盘接口,用户可以用键盘上的箭头或PageUp及PageDown键在列 表框中进行数据
  • itemcget(index, option) 获取列表框中,index指定项的配置属性。 itemconfig(index, **options) 修改列表框中,index指定项的配置属性。 nearest(y) 返回最靠近y坐标的索引值。 see(index) 保证index指定的项值在...
  • Delphi列表框组件(TListBox)详解

    千次阅读 2016-09-02 14:36:06
    此组件为一个标准的Windows 列表框组件,它用于显示一系列的列表,用户可以选择、加入、删除或修改其中的项目。 1.TLlistBox 组件的典型用法 在Windows 应用程序中,经常要用到列表框列表框能够在一个可翻滚...
  • JQuery EasyUI combobox(下拉列表框)

    万次阅读 2015-04-01 09:06:58
    下拉列表框 继承 $.fn.combo.defaults. 重写 $.fn.combobox.defaults. 组合框显示一个可编辑的文本框和下拉列表,用户选择一个或多个值。用户可以直接输入文本到顶部的列表,或选择一个或多个当前值列表。 依赖 ...
  • Qt入门-列表框QListWidget类

    万次阅读 2012-07-20 17:17:00
    QListWidget类也是GUI中常用的类,它从QListView下派生: class Q_GUI_EXPORT QListWidget : public ...常用方法和属性: (1)addItem void addItem ( const QString & label ) void addItem ( QListWidgetItem
  • 用vb列表框做一个图书管理系统

    千次阅读 2020-09-16 10:27:59
    哈喽大家好,欢迎来到一起学VB课堂,今天我们将要学习列表框ListBox控件和组合框ComboBox控件,这两个控件在VB中是非常重要的控件,当然其难度也比前面学习的控件难度有所增加,这两个控件我会单独分在两个课程,小...
  • 下拉列表框数据量过大解决方案

    千次阅读 2020-07-26 16:13:47
    我的解决方案是,每次从后端读取100条数据(当然你可以自己限定每次查询的条数),当用户在列表框输入数据进行筛选时,再通过模糊查询从后端查询100条数据,用户输的数据越精确,匹配度越高。下面是具体代码: 1、...
  • 向工作表中添加列表框或组合框

    千次阅读 2012-05-04 10:29:40
    添加列表框(表单控件) 如果“开发工具”选项卡未显示,请显示它。 显示“开发工具”选项卡 单击“Office 按钮” ,然后单击“Excel 选项”。 在“常用”类别中的“使用 Excel 时采用的首选项”下,...
  • 前面两节讲了比较常用的按钮控件,并通过按钮控件实例说明了具体用法。...列表框可分为单选列表框和多选列表框,顾名思义,单选列表框中一次只能选择一个列表项,而多选列表框可以同时选择多个列表项。  列
  • easyui下拉列表属性

    千次阅读 2014-07-09 09:53:08
    2、 Combo的属性参数配置 Width:设置select的宽度,默认为auto panelWidth:下拉列表的宽度,默认为null panelHeight:下拉列表的高度,默认为200 multilple:定义是否支持多重选择,默认为false ...
  • VS2010 下 MFC下拉列表框的用法

    千次阅读 2018-06-26 16:30:36
    最近在写一个串口程序,需要将下拉列表框的数据全部显示,怎么设置都不对,最后终于找到了设置方法:二、如何控制Combo Box的下拉长度1,首先要知道两点:一、那就是在设计界面里,点击一下Combo Box的下拉箭头,...
  • Checkbox 对象属性和事件

    千次阅读 2021-06-11 09:39:58
    Checkbox 对象属性和事件HTML DOM Checkbox 对象Checkbox 对象Checkbox 对象代表一个 HTML 表单中的 一个选择。在 HTML 文档中 每出现一次,Checkbox 对象就会被创建。您可以通过遍历表单的 elements[] 数组来访问...
  • 列表框可分为单选列表框和多选列表框,顾名思义,单选列表框中一次只能选择一个列表项,而多选列表框可以同时选择多个列表项。  列表框也会向父窗口发送通知消息。这些通知消息及含义如下:  LBN_DBLCLK :...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 290,620
精华内容 116,248
热门标签
关键字:

列表框的什么属性返回