精华内容
下载资源
问答
  • 列表框属性

    千次阅读 2019-11-22 14:01:41
    列表框 列表框允许用户从多个对象中选择一项或多项,这些对象可以是文本、文件和位图等。当列表框的项不能全部显示出来时,可以用滚动条来滚动显示。 1. 基础知识 默认的列表框只允许用户单选,需要多选时,须把...

    列表框

    列表框允许用户从多个对象中选择一项或多项,这些对象可以是文本、文件和位图等。当列表框的项不能全部显示出来时,可以用滚动条来滚动显示。

    1. 基础知识
    默认的列表框只允许用户单选,需要多选时,须把列表框的风格定义为 LBS_ MULTIPLESEL 和 LBS_EXTENDEDSEL 。列表框提供的其他风格取值可以控制列表框的外观和操作。例如是否按照列表框各项的名称排序,是否多行排列,是否有滚动条等。

    风格取值                   描述
    LBS_EXTENDEDSEL           //能通过Shift键或者鼠标进行多选
    LBS_HASSTRINGS            //可以用GetText函数得到列表框里选项的字符串
    LBS_MULTICOLUMN           //指定列表框以多列形式显示内容
    LBS_MULTIPLESEL           //用户可以选择多个项
    LBS_NOINTEGRALHEIGHT      //当应用程序创建列表框时,列表框的大小由系统指定
    LBS_NOREDRAW              //列表框不响应用户的修改,可以通过发送WM_REDRAW 来取消该设置
    LBS_NOTIFY                //让主窗口接收列表框的任何改变的消息
    LBS_OWNERDRAWFIXED        //主窗口负责列表框的重画,列表框里每项的高度相同
    LBS_0WNERDRAWVARIABLE     //主窗口负责列表框的重画,列表框里每项的高度可以变化
    LBS_SORT                  //按各项名称的字母排序
    LBS_STANDARD              //等同于LBS_SORT和LBS_NOTIFY
    LBS_USETABSTOPS           //允许用户使用Tab键在各项中切换
    LBS_WANTKEYBOARDINPUT     //输入焦点在列表框时,任何键盘输入都会向父窗口发送WM_VKEYTOITEM或者WM_CHARTOITEM消息
    LBS_DISABLENOSCROLI       //当列表框的项不够时,垂直滚动条禁活:没有该属性时,滚动条隐藏

    当用户对列表框进行了操作时,就会向主窗口发送一条消息。列表框的消息类型比较简单,主要是单击、双击和选择等。同编辑框一样,列表框也会遇到内存不够的问题,所以消息类型中含有这一项。消息总是通过WM_COMMAND的形式发送给主窗口的。其中,wParam的低位字节表示列表框的标识符,高位字节表示消息的类型,lParam表示主窗口句柄。列表框的消息类型如表所示。

    消息类型                   描述
    LB_DELETESTRING           //删除指定的选项
    LB_ADDFILE                //向列表框里增加一个文件(包括目录)
    LB_FINDSTRING             //在列表框里查找指定的项
    LB_FINDSTRlNGEXACT        //精确查找指定的项
    LB_GETCOUNT               //得到列表框里项的数目
    LB_GETCURSEL              //返回当前被选中选项的序号
    LB_GETSEL                 //得到被选项的状态,如果出错,则返回零值
    LB_GETSELCOUNT            //得到被选中的个数
    LB_GETTEXT                //返回选中的文本,返回值为字符串长度
    LB_GETTEXTLEN             //返回字符串长度
    LB_INITSTORAGE            //向列表框增加项之前存储原来的内容
    LB_INSERTSTRING           //向列表框增加一项,但不重新排序
    LB_ITEMFROMPOINT          //返回离指定点最近项的序号
    LB_RESETCONTENT           //清除列表框里所有的项
    LB_SELECTSTRING           //寻找指定的项
    LB_SELITEMRANGE           //指定选择的范围
    LB_SELITEMRANGEEX         //选定或者删除指定的项
    LB_SETCOLUMNWIDTH         //设置列的宽度
    LB_SETCOUNT               //设置列表框里项的最大数目
    LB_SETCURSEL              //选中指定的项
    LBN_DBLCLK                //发送用户双击的消息
    LBN_ERRSPACE              //发送内存空间不够的消息
    LBN_KILLFOCUS             //当列表框失去焦点时发送该消息
    LBN_SELCANCEL             //当用户取消选择时发送该消息
    LBN_SELCHANGE             //当用户选择改变时发送该消息
    LBN_SETFOCUS              //当输入焦点转移到列表框时发送该消息
    WM_CTLCOLORLISTBOX        //在列表框重画时向父窗口发送该消息
    WM_DELETEITEM             //删除选项
    WM_VKEYTOITEM             //输入焦点在列表框里,用户按键时发送该消息

    鼠标右键WM_CONTEXTMENU 消息就行了。wParam 是点击右键的窗口的句柄,lParam 是鼠标坐标。如果用户使用 SHIFT+F10 来响应菜单,那么 lParam 收到的坐标都是 -1。
    LOWORD(wParam) 子窗口ID
    HIWORD(wParam) 通知码
    Lparam 子窗口句柄

     

    2. 定义列
    增加列需要用列的结构LVCOLUMN,定义如下:

    typedef struct _LVCOLUMN {
    UINT mask;                //定义该列可使用的类型
    int fmt;                  //定义列格式
    int cx;                   //定义列宽度(以像素为单位)
    LPTSTR pszText;           //列内容
    int cchTextMax;           //列内容最大长度
    int iSubItem;             //定义此列序号
    #if (_WIN32_IE >= 0x0300)
    int iImage;               //指向图像
    int iOrder;               //零基列偏移量。列偏移量是从左到右的顺序。例如0列在最左边。
    #endif #if (_WIN32_WINNT >= 0x0600)
    int cxMin;                //指定列宽最小值
    int cxDefault;            //默认列宽
    int cxIdeal;              //只读,作为列宽的理想宽度自动调整宽度大小
    #endif
    } LVCOLUMN, *LPLVCOLUMN;  //结构名称

    使用方法:
    SendMessage(hwnd, LVM_INSERTCOLUMN, 0, (LPARAM)&colmn)
    还有LVM_GETCOLUMN LVM_SETCOLUMN LVM_DELETECOLUMN

     

    3. 改变项
    改变项需要结构体LVITEM,定义如下:

    typedef struct {
    UINT mask;              //设置成员标志,如格式等
    int iItem;              //项目索引
    int iSubItem;           //添加到的列序
    UINT state;             //指明项目状态,如图片,叠加图片
    UINT stateMask;         //指state成员的有效位
    LPTSTR pszText;         //项目内容
    int cchTextMax;         //项目最大长度
    int iImage;             //指向图片索引
    LPARAM lParam;          //特殊值,如果你用SORTITEM它就需要这个,或者别的特别的
    #if (_WIN32_IE >= 0x0300)
    int iIndent;            //图片宽度
    #endif
    #if (_WIN32_WINNT >= 0x0501)
    int iGroupId;           //指向所在的组id
    UINT cColumns;          //需要展示的列数,最大为20
    UINT puColumns;         //返回这个项目所指向的列
    #endif
    #if (_WIN32_WINNT >= 0x0600)
    int piColFmt;           //返回列属性
    int iGroup;             //项目列
    #endif
    } LVITEM, *LPLVITEM;

    使用方法:
    SendMessage(hres, LVM_INSERTITEM, 0, (LPARAM)&item);

    展开全文
  • 511遇见易语言教程列表框属性方法

    千次阅读 2020-07-09 09:06:20
    本节视频录制了易语言列表框的取项目文本、置项目文本、加入项目、插入项目、是否被选择、取所有选择项目等属性方法。 易语言教程列表框视频教程源码: .版本 2 .程序集 窗口程序集_启动窗口 .子程序 _按钮1_...

    本节视频录制了易语言列表框的取项目文本、置项目文本、加入项目、插入项目、是否被选择、取所有选择项目等属性方法。

    易语言教程列表框视频教程源码:

    .版本 2
    
    .程序集 窗口程序集_启动窗口
    
    .子程序 _按钮1_被单击
    
    信息框 (列表框1.取项目文本 (列表框1.现行选中项), #信息图标, , )
    
    .子程序 _按钮2_被单击
    
    信息框 (列表框1.取项目文本 (到整数 (编辑框1.内容)), #信息图标, , )
    
    .子程序 _按钮3_被单击
    
    列表框1.置项目文本 (列表框1.现行选中项, 编辑框1.内容)
    
    .子程序 _按钮4_被单击
    .局部变量 项目索引
    
    项目索引 = 列表框1.加入项目 (编辑框1.内容, )
    列表框1.现行选中项 = 项目索引
    
    .子程序 _按钮5_被单击
    .局部变量 项目索引, 整数型
    
    项目索引 = 列表框1.插入项目 (到整数 (编辑框1.内容), 编辑框2.内容, )
    列表框1.现行选中项 = 项目索引
    
    .子程序 _按钮6_被单击
    .局部变量 bool, 逻辑型
    
    bool = 列表框1.是否被选择 (到整数 (编辑框1.内容))
    .如果 (bool)
    信息框 (“被选择”, 0, , )
    .否则
    信息框 (“没有选择”, 0, , )
    .如果结束
    
    .子程序 _按钮7_被单击
    .局部变量 项目数组, 整数型, , "0"
    .局部变量 选择数量
    .局部变量 索引文本, 文本型
    .局部变量 项目文本, 文本型
    .局部变量 n, 整数型
    
    项目数组 = 列表框1.取所有被选择项目 ()
    选择数量 = 取数组成员数 (项目数组)
    .如果真 (选择数量 = 0)
    信息框 (“请选择项目”, 0, , )
    返回 ()
    .如果真结束
    
    .计次循环首 (选择数量, n)
    
    索引文本 = 索引文本 + #换行符 + 到文本 (项目数组 [n])
    
    项目文本 = 项目文本 + #换行符 + 列表框1.取项目文本 (项目数组 [n])
    
    .计次循环尾 ()
    
    信息框 (“被选中的项目文本:” + 索引文本 + 项目文本, 0, , )

    源码:511遇见易语言教程

               511遇见易语言教程视频链接

               易语言教程列表框属性方法

    展开全文
  • 然而,开始的程序在执行的时候却没有错误,这就说明 列表框'string'返回的存储类型绝对不是普通高维数组。cat函数与vertcat函数对与元胞数组也是使用的。例如: a = {'1231';'sdfa'} a = '1231' 'sdfa' >>...

    edit_string = get(handles.string_edit,'string');
    if (isempty(edit_string))
        disp('Please give an string to add')
    end
    
    list_string = get(handles.listbox1,'string');   % list_string是一个元胞?是
     if (~isempty(list_string))
         set(handles.listbox1,'string',vertcat(edit_string,list_string));
    else
        set(handles.listbox1,'string',edit_string);
    end

    该段代码是把编辑框中的字符加入到裂框中。 我们几种方法可验证该问题。

    比如  在 

    list_string = get(handles.listbox1,'string');   % list_string是一个元胞?是
    后面加上  class(list_string) 然后我们就可以在命令行看到结果为 cell


    然而,本文重点不在于次!我想说的是 函数 vertcat 和 函数 cat(1,...)

    这俩个函数在垂直方向拼接输入参数但是他们俩个函数都需要输入参数列相同

    例如

     a = ['123 ';'1234';'4  6']
    
    a =
    
    123 
    1234
    4  6
    
    >> b = '44'
    
    b =
    
    44
    
    >> cat(1,b,a)
    Error using cat
    Dimensions of matrices being concatenated are not consistent.
     
    >> vertcat(b,a)
    Error using vertcat
    Dimensions of matrices being concatenated are not consistent.

    当列相同的时候拼接是成功的

    c = '1470'
    
    
    c =
    
    
    1470
    
    
    >> cat(1,c,a)
    
    
    ans =
    
    
    1470
    123 
    1234
    4  6
    vertcat 结果也一样

    然而,开始的程序在执行的时候却没有错误,这就说明 列表框'string'返回的存储类型绝对不是普通高维数组。cat函数与vertcat函数对与元胞数组也是使用的。例如:

     a = {'1231';'sdfa'}
    
    a = 
    
        '1231'
        'sdfa'
    
    >> b = '1'
    
    b =
    
    1
    
    >> cat(1,b,a)
    
    ans = 
    
        '1'
        '1231'
        'sdfa'
    本人初学matlab,以上均是学习过程中遇到的问题,总结的心得!如果您发现有什么错误,还望指出来!谢谢!


    展开全文
  • 列表框、组合框

    千次阅读 2010-04-08 15:54:00
    如果项目总数超过了列表框可显示的项目数,列表框会自动添加滚动条,可以方便用户以滚动的方式来选择列表框列表框的常用属性·listcount属性:用于返回列表框中的所有选项的个数,该属性只能在程序代码中调用和设置...

     

          列表框常用来显示一个项目的列表,用户可以从中选择一项或多项。如果项目总数超过了列表框可显示的项目数,列表框会自动添加滚动条,可以方便用户以滚动的方式来选择列表框
    列表框的常用属性
    ·listcount属性:用于返回列表框中的所有选项的个数,该属性只能在程序代码中调用和设置

    ·listindex属性:返回当前选项的索引号,索引号从0开始,如果没有选中,该属性为-1,该属性也只能在程序中代码中调用和设置

    ·list属性:得到列表中任何选项的值,它以数组的方式存在。list属性可以在属性窗口中设置也可以在代码中通过additem方法添加

    ·selected属性:记录了列表框中的选项时候被选中。也用数组表示,其值为false和true。

    ·text属性:用来直接返回当前选中的项目文本。list.text和list1.list(list.listindex)表达式的结果完全相同。当我们知道选中项目的文本内容时,用text属性就行;当我们对选定项目进行详细描述时,使用list和listindex属性能够表达的更加详细

    ·multiselect属性:通过设置multiselect属性可以实现在列表中同时选择多个项目,其可能的取值如下:
       none-标准列表,每次只能选择一项
       simple-简单多项选择,即可以逐条选择多项
       extended(英语翻译:伸出的,伸展的;延长的,持续的;扩大的,扩展的)-扩充多项选择,即可以让用户一次可以选择相邻的多项选项或逐条选择不相邻的多项选项(shift键和ctrl键)

    ·style属性:该属性只能在设计时在属性窗口中设置,用于控制列表框的外观。其值可以设置为0(标准样式)和1(复选框样式)

    ·sorted属性(英语翻译:分类的,分选的):设置列表框中的项目是否按字母顺序排序,设计时属性
       true-字母按升序排列显示
       false-不进行排序

    ·columns属性(英语翻译:列):当列表框内容较多时,设置列表框中出现水平滚动条、垂直滚动条以及显示的列数。其值可取0-n
       0--列表框显示垂直滚动条,并且所有选项都排列在一列中
       1--列表框显示水瓶滚动条,同时在列表的宽度范围内自动显示1-n列

     

    列表框的常用事件和方法

    ·additem方法:用于向列表框中添加数据
       <listname.> additem  <item> [,index]
        注:item是添加到列表框中的字符串表达式
        index用于指定新插入的项在列表框中的位置,第一项位置为0,以此类推;若省略,则新增加的列表项将自动放在列表框的末尾
        利用该方法一次只能增加一个列表框,若要添加多项,则要使用多个这样的句子

    ·removeitem方法:用于删除列表框中指定的列表项。
       <listname.> removeitem <index>
       该方法一次只能删除一个列表框

    ·clear方法:用于清除列表框中的所有列表项
       <listname>.clear

     

     

     

          组合框:组合框兼有文本框和列表框的功能,既可以在控件的文本框部分输入信息,也可以在控件的列表框部分选择一项,组合框也具有自动添加滚动条的能力

     

    常用属性
    ·style属性
       0-下拉组合框,包括一个下拉式列表和一个文本框。用户可以单击右端的向下箭头来显示可滚动的选项列表框,还可以在文本框中输入列表中没有的新选项
       1-简单组合框,它由一个文本框和一个标准列表框组成,列表框不是下拉式的,列表项目始终显示在列表框中,所以在设计时应适应调整组合框的大小
       2-下拉列表组合框,它在外观上和下拉列式组合框一样,右端也有一个箭头,可供拉下和收起,可以从下拉列表框选择选项,但不能接收文本输入

    ·text属性:用户所选择项目的文本或直接从文本编辑区输入的文本

    展开全文
  • 易语言组合框去重复到列表框

    千次阅读 2019-12-08 19:15:51
    在辅助开发时,我们需要通过组合框控制一些功能,或者获取一些数据,比如把组合框里 的值添加到列表框,这里就需要去除重复的,以下代码实现了这个功能。 .版本 2 .支持库 spec .支持库 EDataStructure .程序集 ...
  • 列表框控件简介

    千次阅读 2015-09-29 11:26:36
    列表框可分为单选列表框和多选列表框,顾名思义,单选列表框中一次只能选择一个列表项,而多选列表框可以同时选择多个列表项。  列表框也会向父窗口发送通知消息。这些通知消息及含义如下:  LBN_DBLCLK :...
  • wx.ListBox创建列表框

    千次阅读 2013-04-23 10:26:27
    7.4.3 如何创建一个列表框列表框是提供给用户选择的另一机制。选项被放置在一个矩形的窗口中,用户可以选择一个或多个。列表框比单选按钮占据较少的空间,当选项的数目相对少的时候,列表框是一个好的选择。...
  • 列表框控件

    千次阅读 2005-04-27 16:28:00
    列表框控件(listbox) [下载例程] 列表框主要用于输入,它允许用户从所列出的表项中进行单项或多项选择,被选择的项呈高亮度显示.列表框具有边框,并且一般带有一个垂直滚动条.列表框分单选列表框和多重选择列表...
  • 列表框控件(listbox)消息

    千次阅读 2017-03-15 10:21:37
    列表框主要用于输入,它允许用户从所列出的表项中进行单项或多项选择,被选择的项呈高亮度显示... 应用程序用CreateWindowEx创建列表框控件时,可根据控件的用途在下表中选择部份常数来设定其风格属性(style)。  常
  • 常用控件:列表框控件ListBox

    千次阅读 2017-09-29 10:10:18
    列表框可分为单选列表框和多选列表框,顾名思义,单选列表框中一次只能选择一个列表项,而多选列表框可以同时选择多个列表项。  列表框也会向父窗口发送通知消息。这些通知消息含义如下:  LBN_DBLCLK:用户...
  • JQuery EasyUI combobox(下拉列表框)

    万次阅读 2015-04-01 09:06:58
    下拉列表框 继承 $.fn.combo.defaults. 重写 $.fn.combobox.defaults. 组合框显示一个可编辑的文本框和下拉列表,用户选择一个或多个值。用户可以直接输入文本到顶部的列表,或选择一个或多个当前值列表。 依赖 ...
  • 列表框控件(listbox)

    2010-05-06 18:22:00
    列表框(listbox)主要用于输入,它允许用户从所列出的表项中进行单项或多项选择,被选择的...对于列表项的选择, 应用程序用CreateWindowEx创建列表框控件时,可根据控件的用途在下表中选择部份常数来设定其风格属性(st
  • 第12章、列表框

    千次阅读 2013-05-23 17:44:00
    第12章、列表框 【知识要点】  (1)列表框ListBox 【问题提出】  第8章我们学习了下拉列表框,特点是多选一,而我们实际项目中还经常会有多先多的情况,这就需要列表框,我们尝试完成以下从多个电脑品牌...
  • MFC控件listbox(列表框

    千次阅读 2014-11-14 10:06:54
    MFC控件listbox(列表框) 定义控件对应变量: 假定已经创建了一个Dialog,并且给该Dialog建立了类,并且从控件工具箱将 Combo Box 控件拖放到上面。打开 Class Wizard,添加控件对应变量,如:CComboBox m_...
  • 列表框和组合框的使用

    千次阅读 2010-06-24 15:21:00
    列表框是显示一系列项供用户选择的控件,对选中的项可以进行后续的处理。用户选择可以是多项的,但本章的例程设计为单选的。组合框是一个编辑框带一个可以下拉的列表框,用户在下拉框中选择的项会进入编辑框中...
  • vb列表框ListBox的详细使用方法

    万次阅读 2018-06-12 15:19:45
    列表框(ListBox)控件表示一个选项清单,用户可能用鼠标选择其中一个或者几个选项。 列表框的特点是:列表框中的项目是通过程序插入到其中的,用户无法向清单中输入数据,当选择其中的项
  • EasyUI ComboBox(下拉列表框

    万次阅读 2016-07-22 21:13:35
    ComboBox(下拉列表框) 扩展自$.fn.combo.defaults。使用$.fn.combobox.defaults重写默认值对象。 下拉列表框显示一个可编辑文本框和下拉式列表,用户可以选择一个值或多个值。用户可以直接输入文本到列表顶部或...
  • Win32字控件-列表框

    千次阅读 2013-09-28 12:25:47
    LBS_DISABLENOSCROLL 当列表框不包含足够的项目移动时,列表框中显示禁用垂直滚动条。如果没有此样式当列表框不包含足够的项目时,滚动条隐藏。 LBS_EXTENDEDSEL 使用shift键和鼠标或特定组合键,用户可以选择多个项...
  • 在下拉列表框中显示树状结构

    千次阅读 2005-08-08 18:15:00
    作者:星轨(oRbIt) E_Mail :inte2000@163.com 转载请注明原作者,否则请勿转载 在下拉列表框中...一个典型的用户界面就是使用下拉列表框(或称组合列表框)显示数据库中相关表名或某个表中的某个字段的全部数据
  • vb列表框ListBox的使用

    千次阅读 2007-10-11 11:09:00
    列表框(ListBox)控件表示一个选项清单,用户可能用鼠标选择其中一个或者几个...下面这个例子充分说明了列表框的这个特点,并介绍了列表框(ListBox)的常用属性。 为了学习方便,提供的源码已经作了详细的中文注释,
  • Delphi列表框组件(TListBox)详解

    千次阅读 2016-09-02 14:36:06
    此组件为一个标准的Windows 列表框组件,它用于显示一系列的列表,用户可以选择、加入、删除或修改其中的项目。 1.TLlistBox 组件的典型用法 在Windows 应用程序中,经常要用到列表框列表框能够在一个可翻滚...
  • 列表框控件ListBox(选择类控件)

    千次阅读 2014-04-28 12:41:15
    列表框控件ListBox用于显示一个列表,用户可以从中选择一项或多项。如果选项总数超出可以显示的项数,则控件会自动添加滚动条。 列表控件的部分属性及说明 属性名 说明 Items 获取列表...
  • 前面两节讲了比较常用的按钮控件,并通过按钮控件实例说明了具体用法。...列表框可分为单选列表框和多选列表框,顾名思义,单选列表框中一次只能选择一个列表项,而多选列表框可以同时选择多个列表项。  列
  • Qt入门-列表框QListWidget类

    万次阅读 2012-07-20 17:17:00
    QListWidget类也是GUI中常用的类,它从QListView下派生: class Q_GUI_EXPORT QListWidget : public ...常用方法和属性: (1)addItem void addItem ( const QString & label ) void addItem ( QListWidgetItem
  • qt5之下拉列表框QComboBox

    千次阅读 2019-03-07 14:45:40
    QComboBox提供了下拉列表框的控件。下面简单介绍几个的方法和属性。  (1)addItems  void addItem(const QString &amp;amp;amp;amp;amp;amp;amp;text, const QVariant &amp;amp;amp;amp;amp;amp;amp;...
  • 列表框表示标准Windows列表框,它提供用户选的一列选择表。如果列表框包含更多的项,不能一次显示,滚动栏提供存取列表框中其余项。 New Term 一些列表框(list boxes)是自绘(Owner-Draw)表框,在自绘列表框...
  • 组合列表框在应用程序开发中,使用相当频繁,一个好的组合列表框,既能让用户有很好的使用体验,也能提高程序的开发效率。一般使用组合列表框,我们都希望能够实现在提供的选项中进行搜索、通过键盘或鼠标进行选择、...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 260,763
精华内容 104,305
关键字:

列表框的什么属性返回