精华内容
下载资源
问答
  • 树莓派安装OpenWrt

    千次阅读 2020-03-06 10:07:16
    树莓派安装OpenWrt Raspberry Pi 4 B 安装 OpenWrt,那啥上网操作等 1. 下载OpenWrt 访问页面https://openwrt.org/toh/hwdata/raspberry_pi_foundation/start,选择Raspberry对应版本 如果是Raspberry Pi 4 B直接...

    树莓派安装OpenWrt

    Raspberry Pi 4 B 安装 OpenWrt,那啥上网操作等
    还有后续可以过不了审核

    1. 下载OpenWrt

    http://cn.openwrt.cc:60080/firmware/2021-02-23

    访问页面https://openwrt.org/toh/hwdata/raspberry_pi_foundation/start,选择Raspberry对应版本

    如果是Raspberry Pi 4 B直接下载http://downloads.openwrt.org/snapshots/targets/brcm2708/bcm2711/openwrt-brcm2708-bcm2711-rpi-4-squashfs-factory.img.gz

    2. 将OpenWrt写入SD卡中

    • windows可以使用Win32Diskimager.exe``````balenaEtcher或者其他PE工具也可

    • mac使用dd命令,具体操作如下

      1. 在命令行输入diskutil list,出现如下图所示/dev/disk4就是需要写入的sd卡

      2. 然后取消挂载sd卡,diskutil umountDisk disk4

      3. 然后输入 sudo dd if=/Users/carter/Downloads/openwrt-koolshare-mod-v2.31-r10822-50aa0525d1-x86-64-combined-squashfs.img of=/dev/disk4 bs=1m,出现如下信息表示成功。

        dd命令详解

        命令选项
        if=文件名          输入文件名,缺省为标准输入。即指定源文件。
        of=文件名          输出文件名,缺省为标准输出。即指定目的文件。
        ibs=bytes         一次读入bytes个字节,即指定一个块大小为bytes个字节。
        obs=bytes         一次输出bytes个字节,即指定一个块大小为bytes个字节。
        bs=bytes          同时设置读入/输出的块大小为bytes个字节。
        cbs=bytes         一次转换bytes个字节,即指定转换缓冲区大小。
        skip=blocks       从输入文件开头跳过blocks个块后再开始复制。
        seek=blocks       从输出文件开头跳过blocks个块后再开始复制。
        count=blocks      仅拷贝blocks个块,块大小等于ibs指定的字节数。
        
        关键字用法
        conv=<关键字>,关键字可以有以下11种:
        conversion      用指定的参数转换文件。
        ascii           转换ebcdic为ascii
        ebcdic          转换ascii为ebcdic
        ibm             转换ascii为alternate ebcdic
        block           把每一行转换为长度为cbs,不足部分用空格填充
        unblock         使每一行的长度都为cbs,不足部分用空格填充
        lcase           把大写字符转换为小写字符
        ucase           把小写字符转换为大写字符
        swab            交换输入的每对字节
        noerror         出错时不停止
        notrunc         不截短输出文件
        sync            将每个输入块填充到ibs个字节,不足部分用空(NUL)字符补齐。
        --help          显示帮助信息
        --version       显示版本信息
        

    3. 将SD卡插入树莓派,并启动

    不用在意是否有显示器,可以直接通过ssh连接,默认IP地址192.168.1.1

    4. 通过SSH连接树莓派,后续将称为R路由器。

    ssh root@192.168.1.1
    # 如果IP有冲突自行处理
    

    5. 修改IP地址,更改192.168.1.1为相应地址即可

    root@OpenWrt:~# vi /etc/config/network
    config interface 'loopback'
            option ifname 'lo'
            option proto 'static'
            option ipaddr '127.0.0.1'
            option netmask '255.0.0.0'
    
    config globals 'globals'
            option ula_prefix 'fd76:85c4:64f4::/48'
    
    config interface 'lan'
            option type 'bridge'
            option ifname 'eth0'
            option proto 'static'
            option ipaddr '192.168.1.1'
            option netmask '255.255.255.0'
            option ip6assign '60'
    

    6. 即使连接有线,现在R路由器也不能访问网络,需要进行如下配置

    root@OpenWrt:~# route
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    192.168.199.0   *               255.255.255.0   U     0      0        0 br-lan
    # 可以看到 Gateway为空,所以我们需要执行如下命令
    root@OpenWrt:~# route add default gw 192.168.199.1
    # 然后重启
    root@OpenWrt:~# reboot
    # 注意:再次连接时,需使用第5步更改的IP地址,如果没有更改直接使用
    ssh root@192.168.1.1
    
    # 如果还是无法访问可以执行
    root@OpenWrt:~# vi /tmp/resolv.conf
    # 然后加入如下信息
    nameserver 192.168.1.1
    nameserver 114.114.114.114
    

    7. 再次连接R路由器,见图执行相应命令,现在已经可以访问网络

    8. 安装luci

    # 更新依赖
    root@OpenWrt:~# opkg update
    # 安装luci
    root@OpenWrt:~# opkg install luci
    # 如果出现安装失败情况,请确认opkg update 是否成功
    
    # 安装汉语包
    root@OpenWrt:~# opkg install luci-i18n-base-zh-cn
    root@OpenWrt:~# opkg install luci-i18n-firewall-zh-cn
    
    

    9. 设置开启启动并启动服务

    root@OpenWrt:~# /etc/init.d/uhttpd enable
    root@OpenWrt:~# /etc/init.d/uhttpd start
    

    10. 访问192.168.1.1,用户名 root密码 admin

    展开全文
  • VMware安装OpenWrt

    2012-06-02 12:36:41
    VMware安装OpenWrtVMware安装OpenWrt
  • 本教程为大家分享了Vmware安装OpenWrt15.05的具体过程,供大家参考,具体内容如下 1.虚拟机文件制作 下载对应版本的img文件,本文选择15.05: http://xiazai.jb51.net/201612/yuanma/VmwareOpenWrt(jb51.net).rar 在...
  • VMware安装OpenWrt19.07.0

    千次阅读 2020-07-27 11:23:13
    VMware安装OpenWrt19.07.0一:安装准备二:安装openwrt三:启动openwrt四:替换源五:安装包 一:安装准备 准备一个Linux发行版的虚拟机系统,Ubuntu、Centos都可以,这里使用的是Centos7.5 因为笔者这里要求安装...

    一:安装准备

    准备一个Linux发行版的虚拟机系统,Ubuntu、Centos都可以,这里使用的是Centos7.5

    因为笔者这里要求安装python3.7以上版本,而openwrt19以下的版本默认安装的是3.7以下的版本,所以这里选择安装OpenWrt19.07.0版本

    进入Linux系统,使用终端操作以下步骤:

    yum install qemu-img.x86_64
    wget https://downloads.openwrt.org/releases/19.07.0/targets/x86/64/openwrt-19.07.0-x86-64-combined-ext4.img.gz
    # 解压
    # gzip -d openwrt-19.07.0-x86-64-combined-ext4.img.gz
    gunzip openwrt-19.07.0-x86-64-combined-ext4.img.gz
    # 转换镜像
    qemu-img convert -f raw openwrt-19.07.0-x86-64-combined-ext4.img -O vmdk openwrt-19.07.0-x86-64-combined-ext4.vmdk
    

    将上面生成好的.vmdk下载到宿主机,该文件在虚拟机运行及做虚拟机文件迁移时都需要用到该文件。

    二:安装openwrt

    打开vm虚拟机,创建新的虚拟机
    VMware安装OpenWrt19.07.0
    VMware安装OpenWrt19.07.0
    VMware安装OpenWrt19.07.0
    VMware安装OpenWrt19.07.0
    VMware安装OpenWrt19.07.0
    VMware安装OpenWrt19.07.0
    VMware安装OpenWrt19.07.0
    VMware安装OpenWrt19.07.0
    VMware安装OpenWrt19.07.0
    VMware安装OpenWrt19.07.0
    VMware安装OpenWrt19.07.0
    VMware安装OpenWrt19.07.0
    VMware安装OpenWrt19.07.0

    三:启动openwrt

    VMware安装OpenWrt19.07.0
    设置openwrt系统的ip
    VMware安装OpenWrt19.07.0
    VMware安装OpenWrt19.07.0
    VMware安装OpenWrt19.07.0
    在浏览器上访问设置的ip地址,正常打开登录界面,默认密码是root,没有设置密码时有提示需要设置密码,只有设置密码后才能ssh登录。使用其他的SSH客户端即可登录到openwrt。

    四:替换源

    root@OpenWrt:~# cat /etc/opkg/distfeeds.conf
    src/gz openwrt_core http://mirrors.ustc.edu.cn/lede/releases/19.07.0/targets/x86/64/packages
    src/gz openwrt_base http://mirrors.ustc.edu.cn/lede/releases/19.07.0/packages/x86_64/base
    src/gz openwrt_luci http://mirrors.ustc.edu.cn/lede/releases/19.07.0/packages/x86_64/luci
    src/gz openwrt_packages http://mirrors.ustc.edu.cn/lede/releases/19.07.0/packages/x86_64/packages
    src/gz openwrt_routing http://mirrors.ustc.edu.cn/lede/releases/19.07.0/packages/x86_64/routing
    src/gz openwrt_telephony http://mirrors.ustc.edu.cn/lede/releases/19.07.0/packages/x86_64/telephony
    

    五:安装包

    root@OpenWrt:~# opkg update
    root@OpenWrt:~# opkg install python3
    
    展开全文
  • parallels desktop安装OpenWrt

    千次阅读 2020-04-07 15:22:09
    mac电脑上,使用parallels desktop虚拟机安装OpenWrt,参照这篇文章无法成功。从官网下载下来的镜像是img格式,parallels无法加载img和vmdk。网上没有找到直接的方法说明parallels如何安装OpenWrt,下面介绍一下流程...

    背景

    mac电脑上,使用parallels desktop虚拟机安装OpenWrt,参照这篇文章无法成功。从官网下载下来的镜像是img格式,parallels无法加载img和vmdk。网上没有找到直接的方法说明parallels如何安装OpenWrt,下面介绍一下流程。

    流程

    1、官方下载img文件后,使用StarWindConverter将其转换成vhd格式;
    2、创建一个UTF-8文本文件,后缀名为.vmc,复制如下内容,注意absolute和relative要按照自己的实际路径和名称修改。参考

    <preferences>
    <version type="string">2.0</version>
    <hardware>
    <pci_bus>
    <ide_adapter>
    <ide_controller id="0">
    <location id="0">
    <drive_type type="integer">1</drive_type>
    <pathname>
    <absolute type="string">/Users/OpenWrt.vhd</absolute>
    <relative type="string">OpenWrt.vhd</relative>
    </pathname>
    </location>
    </ide_controller>
    </ide_adapter>
    </pci_bus>
    </hardware>
    </preferences>
    

    3、在parallels中,打开该vmc文件即可安装OpenWrt成功。

    4、修改parallels设置,为OpenWrt增加网络(默认没有网络),否则OpenWrt无法上网,注意OpenWrt在关闭的情况下,才能点击下面的+号添加网络,网络设置为“共享网络”。同时OpenWrt的network文件设置参考第一篇文章:
    在这里插入图片描述

    展开全文
  • vm安装openwrt虚拟机

    千次阅读 2018-04-16 11:07:10
    这篇文章主要为大家详细介绍了Vmware安装OpenWrt15.05虚拟机教程,具有一定的参考价值,感兴趣的小伙伴们可以参考一下本教程为大家分享了Vmware安装OpenWrt15.05的具体过程,供大家参考,具体内容如下1.虚拟机文件...
    这篇文章主要为大家详细介绍了Vmware安装OpenWrt15.05虚拟机教程,具有一定的参考价值,感兴趣的小伙伴们可以参考一下
    
    本教程为大家分享了Vmware安装OpenWrt15.05的具体过程,供大家参考,具体内容如下

    1.虚拟机文件制作
    下载对应版本的img文件,本文选择15.05:
    http://xiazai.jb51.net/201612/yuanma/VmwareOpenWrt(jb51.net).rar
    在Ubuntu中安装qemu-img工具:sudo apt-get install qemu-img
    输入命令:
    将输出文件命名为openwrt-15.05-x86-generic-combined.vmdk
    2.openwrt虚拟机设置
    首先新建虚拟机,配置过程如下图所示:
    15.05内核版本为3.18,所以选择其他Linux 3.x 内核
    删除设备:声卡、打印机、USB控制器、CD驱动器等
    3.OpenWrt虚拟机开启
    将第一步中产生的openwrt-15.05-x86-generic-combined.vmdk文件拷入创建的OpenWrt文件夹下
    修改文件OpenWrt-15.05.vmx
    开启虚拟机:
    完成。
    以上就是本文的全部内容,希望对大家的学习有所帮助,也希望大家多多支持脚本之家。
    展开全文
  • 虚拟机安装openwrt以及配置

    千次阅读 2020-09-28 00:19:22
    虚拟机安装openwrt以及配置下载及格式转换下载格式转换安装配置 下载及格式转换 下载 https://www.right.com.cn/forum/thread-4013563-1-1.html 大佬的文章,本文只是用来演示使用,并未有其他用途 格式转换 qemu-...
  • 本来想只刷个openwrt路由固件来测试哈的,但又觉得浪费了它的强大配置,何不先刷入armbian固件,再在docker中安装openwrt,今后想要添加别的功能还可以无限的发挥想象。由于对linux和docker一知半解,过程中走了不少...
  • 虚拟机安装openwrt只需10分钟

    千次阅读 2020-09-13 18:07:28
    虚拟机安装openwrt只需要10分钟 下载镜像10秒:wget https://downloads.openwrt.org/releases/19.07.4/targets/x86/generic/openwrt-19.07.4-x86-generic-combined-ext4.img.gz [root@HK-myzdl ~]# wget ...
  • Vmware安装OpenWrt

    万次阅读 2019-06-07 13:18:04
    (1) 首先要安装Vmware, 这个请自行百度安装。 (2) 安装个Ubuntu系统,这个是为了转换镜像。当然也可以直接下载别人已经转换完成的镜像。 (3) 下载openwrt镜像 ...
  • opkg-upgrade:列出并安装OpenWRT LEDE opkg可升级软件包
  • VM15.5虚拟机安装openwrt作为旁路由 安装OpenWrt 选择配置类型 - 自定义 安装来源 - 稍后安装系统 操作系统 - Linux系统,3.x内核 处理器配置 - 根据自己机器的情况 内存 - 大于1...
  • OpenWrt 是嵌入式的 Linux 路由器固件,OpenWrt在稳定运行的同时提供了强大的扩展能力,用户可以完全的定制属于自己的路由系统,满足不一样的个性化需求,本文讲解如何使用ESXI安装OpenWRT,打造属于自己的软路由。...
  • 树莓派3B安装openwrt19.07.041.目的2.下载3.驱动安装 1.目的 为了实现家用wifi的扩展,打算利用闲置的树莓派3b进行配置。板载wifi用于扩展ap,外接usb无线网卡用于wan接收家用wifi信号(这两个可以互相调整,主要看...
  • pve安装openwrt

    千次阅读 2019-11-21 20:29:16
    openwrt镜像 教程开始: 一:制作windows镜像 打开老毛桃,选择ISO模式,选择镜像位置,点击生成ISO。 等待生成即可 二:使用软碟通写入DiskImage跟openwrt镜像 选择刚刚生成的ISO文件,选择打开方式为...
  • 树莓派3安装openwrt打造无线路由器

    万次阅读 2017-09-05 20:50:39
    1. 树莓派型号 树莓派3代B型,1.2GHz,四核64位ARMv8 CortexA53 CPU(bcm...2. 安装openwrt 2.1下载系统镜像 一开始按照网上的各种教程,安装了openwrt官网的openwrt-brcm2708-bcm2708-rpi-ext4-sdcard.img镜像,...
  • Virtualbox中安装Openwrt

    2015-03-31 14:41:00
    Virtualbox中安装Openwrt Virtualbox:https://www.virtualbox.org/wiki/DownloadsOpenwrt:http://downloads.openwrt.org/backfire/10.03.1/x86_generic/openwrt-x86-generic-combined-ext2.vdi (不需要转换可...
  • 树莓派安装openwrt 写入镜像 openwrt下载 选择openwrt-19.07.6-brcm2708-bcm2709-rpi-2-ext4-factory.img.gz。 SDFormatter格式化SD卡,Win32DiskManager将镜像写入SD卡。 硬件连接 硬件:树莓派3B+,SD卡,网线,...
  • PVE安装openwrt

    千次阅读 2020-05-18 16:40:11
    1、创建虚拟机; 2、分离硬盘,删除硬盘; 3、导入硬盘,qm importdisk 100 openwrt.img pool; 4、编辑新硬盘,设置引导顺序;
  • 树莓派变身软路由——安装openwrt

    万次阅读 多人点赞 2020-03-31 18:11:58
    由于安装kali,性能不足。安装原版树莓派镜像又不是刚需。所以奢侈了一会,刷了个openwrt镜像当软路由使用。 前期准备:(需要的工具在文末) 树莓派3B+ 适用于树莓派的openwrt镜像 读卡器 一张32G以上的内存...
  • 本篇文章教大家如何安装Openwrt软路由系统并配置正常使用。首先我们需要能用来当作软路由的主板,主板要至少需要2个千兆网口,一个用作Wan,其他用作Lan.我这边用到的是ASUS-N3050I-CM-A,这块主板拥有两个千兆网口,...
  • 1. 刷入OpenWrt系统 我使用的OpenWrt版本为:Attitude Adjustment 12.09。下载链接: tl-wr703n-v1-squashfs-factory.bin 如果要使用其他版本,进入下面的链接(注意最好使用factory结尾的固件,这种是最完整的,不...
  • 360c301路由器安装openwrt18.06usb打印服务器替换 本人一直使用360c301路由器,无意间看到可以刷openwrt,加之本人之前有一老式针式打印机(打快递单子用),win10不能很好兼容,(也可能是主板芯片对老打印机不...
  • 在CentOS上安装openwrt环境(一)

    千次阅读 2017-03-22 23:06:06
    为了做一个基于openwrt的净网路由器的开发,所以在VMware Workstation上安装了miniCentOS7,现在在CentOS7上试着安装一下openwrt的环境安装openwrt需要下载许多东西,所以先要配置一个yum源: 步骤如下: 1、下载...
  • VMware安装OpenWrt让宿主机上网&旁路由(两种方案)一、下载固件二、安装LEDE三、虚拟机网卡配置四、两种上网环境方案一:宿主机通过虚拟机中的Openwrt上网1.配置VMware Network Adapter VMnet82.配置有线网卡...
  • 树莓派安装OpenWrt-旁路由(阉割版)

    千次阅读 2020-03-31 14:56:41
    树莓派安装OpenWrt-旁路由 参考资料 自编译 OpenWrt 固件,支持 Raspberry Pi 2B/3B/3B+/4B 1. 工具准备 windows``````osx格式化SD卡工具SD Card Formatter, 或者其他工具,建议格式化为ext4或 squashfs ...
  • 软路由安装openwrt系统

    2021-08-15 12:37:59
    文章目录背景使用目的下载地址OpenWRT系统安装安装前准备开始安装进入WePE界面写入openwrt系统路由器配置用户密码设置网卡配置DNS服务器配置主从路由连接进入软路由UI界面结语 背景 陆陆续续折腾了很久软路由,由于...
  • 树莓派4B安装Openwrt软路由并用作家庭网络网关设备 缘由 家里需要联网设备太多,光猫性能不够,家里小米AX3600不想来刷机,然后就想到了被尘封的树莓派4B,经过一段时间的研究与折腾,最终完成了家庭网络的完善以及...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 9,275
精华内容 3,710
关键字:

怎么安装openwrt