精华内容
下载资源
问答
  • 要想安装低版本软件,最佳的办法是添加ubuntu官方的trusty源。 比如,使用清华的源,则在source.list里添加上trusty源,然后就可以apt-get安装了。具体例子如下 1. vim /etc/apt/source.list 2. 在文件最下

    Ubuntu 16.04 x64  apt-get 最低版本的的jdk是openjdk-8,最低版本的libgif是libgif7。要想安装低版本的软件,最佳的办法是添加ubuntu官方的trusty源,也就是14.04的源即可。

    比如,使用清华的源,则在source.list里添加上trusty源,然后就可以apt-get安装了。具体例子如下

    1. vim /etc/apt/source.list

    2. 在文件最下方添加 deb http://mirrors.tuna.tsinghua.edu.cn/ubuntu/ trusty main

    3. apt-get update

    4. apt-get install openjdk-7

    展开全文
  • 专注于iPhone相关研究,24小时滚动报道关于iPhone新闻  因为固件版本不同而导致一些新的软件无法在老的iPhone/iPod Touch固件系统上安装问题一直困扰很多人,而下面我们有一种折中的解决办法,虽然这样...

    专注于iPhone相关研究,24小时滚动报道关于iPhone新闻

      因为固件版本不同而导致一些新的软件无法在老的iPhone/iPod Touch固件系统上安装问题一直困扰很多人,而下面我们有一种折中的解决办法,虽然这样的方法不会100%有用,但是对绝大部分软件是可以试一试的。

    我们举例说明:2.2.1版改成2.2版的方法

     

     myapple.cc

    1. 先将ipa格式软件后缀.ipa改成.rar,改好后会变成一个压缩包。
    2. 解开压缩包,可以看到一个名字是Payload的文件夹,点击进入看到一个.app文件夹,点进进入。

     

    3. 找到一个名字为Info.plist的文件,左键双击会打开一个记事本文件。将里面的东西都复制出来,帖到另个文本,再把里面所有的2.2.1改成成2.2,然后把这个修改记事本文件另存为Info.plist。

    4. 再按照之前的方法进入到.app,按添加把之前另存为的Info.plist,记事本文件覆盖原来的Info.plist。然后查看一下覆盖后的Info.plist,里面2.2.1的地方是否都变成2.2。

    5.确认都变成2.2之后将压缩包的后缀名由.rar改回.ipa,然后用iTunes同步即可。

    展开全文
  • yum安装低版本软件包We may need to install some old packages such as the kernel in our Linux box. Let’s use installing a older version of Linux kernel in Fedora as the example to introduce how to ...

    yum安装低版本软件包

    We may need to install some old packages such as the kernel in our Linux box. Let’s use installing a older version of Linux kernel in Fedora as the example to introduce how to install old packages from the repository using yum.

    我们可能需要在Linux框中安装一些旧软件包,例如内核。 让我们以在Fedora中安装旧版本的Linux内核为例,介绍如何使用yum从存储库安装旧软件包。

    By now, suppose we have install kernel-2.6.32.16-143 in the Linux box and we want to install some older kernel in the repository.

    到目前为止,假设我们已经在Linux框中安装了kernel-2.6.32.16-143,并且我们想在存储库中安装一些较旧的内核。

    First find out all the kernels in the repository by:

    首先通过以下方法找出存储库中的所有内核:

    # yum list --showduplicates kernel

    All the kernel packages will be listed like this:

    将列出所有内核软件包,如下所示:

    Installed Packages
    kernel.i686                        2.6.32.16-141.fc12               @updates
    Available Packages
    kernel.i686                        2.6.31.5-127.fc12                fedora
    kernel.i686                        2.6.32.16-150.fc12               updates

    We find out that 2.6.31.5-127.fc12 kernel package is available. We can install it now:

    我们发现2.6.31.5-127.fc12内核软件包可用。 我们现在可以安装它:

    # yum install kernel-2.6.31.5-127.fc12

    Then yum will install the kernel of older version. For other packages, the method is similar with kernel. We just need to replace kernel with the package name above.

    然后,yum将安装旧版本的内核。 对于其他软件包,该方法与内核相似。 我们只需要用上面的软件包名称替换内核。

    翻译自: https://www.systutorials.com/installing-specific-old-versions-of-packages-in-yum/

    yum安装低版本软件包

    展开全文
  • iphone安装低版本App的方法

    千次阅读 2020-04-10 11:38:38
    低版本iTunes(须12.6.5.3及以下版本,在爱思助手的“刷机越狱 - 其他工具”内安装) Fillder抓包工具(百度网盘:https://dwz.cn/rQcFsExq) App历史版本查询(推荐网站:https://tools.la...

    背景

    苹果App只能通过 App Store 或其他同类资源平台上登陆 Apple ID 进行安装。

    PP助手已停服(历史版本功能已无法使用,当然其他各资源平台都不行了)

    因为苹果安装包内置了Apple ID信息,故在不知 ID 信息的情况下,无法导入他人下载的安装包

    简单说就是目前没有能够直接下载历史版本的方法(可能笔者暂时还没找到)

    该方法不需要越狱

    原理

    通过抓包工具捕获 iTunes 发送至服务器的App信息,并对其版本ID进行更换,进而伪装维低版本的App下载命令。

    所需工具

    1. 爱思助手
    2. 低版本iTunes(须12.6.5.3及以下版本(该版本及以下内置App Store功能),在爱思助手的“刷机越狱 - 其他工具”内安装)
    3. Fillder抓包工具(百度网盘:https://dwz.cn/rQcFsExq
    4. App历史版本查询(推荐网站:https://tools.lancely.tech/apple/app-search

    准备工作

    1 、打开iTunes(不要检测更新),账户 ——> 登陆 apple id账户 ——>授权 ——> 对这台电脑授权,然后关闭。

    2、打开Fillder(所有的对话框全部选 'No'),Tools ——> Options,在打开的界面中如下图操作。HTTPS ——> (打勾)Capture HTTPS CONNECTS;(打勾)Decypt HTTPS traffic;(打勾)Ingnore server certificate errors (unsafe)

    3、同上述界面,进行下图操作,Actions ——> Trust Root CerificateExport Root Certificate to Desktop.

    操作完成后电脑桌面上会生成如下图所示的证书文件,双击安装即可。

    【注】:不安装证书会导致浏览器或其他软件不能上网的情况

    至此,准备工作已完成,关闭Fillder。(即使安装证书后,只要iTunes)

    【注】:安装证书后,浏览器和其他软件可正常联网,但 iTunes 进行验证 Apple ID 操作仍会失败(其他功能可以正常使用),所以必须先暂时关闭 Fillder。

    开始

    1、先打开 iTunes,搜索想要下载的App,进入下载界面后先不要点击 “获取”。

    2、打开App历史版本查询工具(以上述网站为例)如下图所示,找到需要安装的 App 版本,记下所对应的 ID 号

    3、打开 Fillder,复制指令 bpu MZBuy.woa 粘贴至图中位置,回车,即为设置断点。

    出现下图的所示文字,即为设置成功,开始进行抓包。

    4、这时在 iTunes 中点击 “获取”,Fillder会自动捕获这一事件,同时Fillder界面中会出现App的信息。找到图中所示图标位置即为抓到的包,点击横线处,进入包信息修改界面。

    5、首先点击 TextView,再将图中的 ID号改为刚才记下的旧版本的ID号,最后点击右下角 Run to Completion,发起下载。发起成功后(iTunes图标闪烁或是软件内显示正在准备下载),立即关闭Fillfer

    【注】:上面说过,Fillder存在会导致 iTunes 无法验证 Apple ID,而 App下载时是需要验证 Apple ID的,所以必须马上关闭,不过即便如此,也可能会导致下载失败,不过没关系,下载任务已成功发起,这时在 iTunes 右上角点击重试即可。

    6、等待 iTunes 下载完成即可,在资料库中找到App,右键选择 “在Windows资源管理器中显示”(即为打开文件所在文件夹),可以找到一个下载好的安装包(ipa文件)。

    7、关闭 iTunes,在爱思助手中导入安装刚才下载好的安装包即可。

    参考

    安装低版本软件的 2 个方法:https://www.i4.cn/news_detail_28793.html

    iPhone 如何安装旧版本的 App?:https://www.zhihu.com/question/23817667/answer/519668127

     

    展开全文
  • 1. 下载并安装最新的R版本软件,以国内的清华的镜像为例(国内镜像速度快) https://mirrors.tuna.tsinghua.edu.cn/CRAN/ 2. 官网上如何下载老版本或低版本(旧版本)的R语言(同时下载多个版本的R,功能运行更加...
  • 手里有个备用机4年前的华为手机,安装软件的时候发现安装...尝试使用华为自带的应用市场安装,最终失败告终,还是提示版本。 使用安卓开发者的调试工具安装adb,测试成功了。 adb install /Users/itkey/demo/Ti.
  • Centos下Yum安装版本软件

    千次阅读 2017-02-28 16:52:25
    软件版本了,手动安装有一些麻烦,想采用Yum安装的可以使用下面的方案: 【1、检查当前安装的PHP包】 yum list installed | grep php 如果有安装的PHP包,先删除他们 yum remove ...
  • Ubuntu10.04 下安装低版本GCC方法

    千次阅读 2012-10-22 14:12:17
    Ubuntu10.04 下安装低版本GCC方法 ...因为编译软件的需要,Ubuntu 10.04 LTS自带的gcc4.4.3版本太高,需要gcc3.x,因此 需要安装低版本的gcc,我选择的是gcc3.3.6。 第一、下载deb安装包,
  • 手机刷机后不能安装低版本APP。以微信为例子,刷机成功后,第一次安装低版本的微信,登陆时系统提示,需要安装最新的APP。然后就是灰色。不可用。这种情况下,更新微信APP,安装成功后,卸载,再安装低版本的微信APP...
  • 前沿 逆向开发中,可能会分析一些高版本的应用,但是设备的版本号低于应用最低版本号,这个时候就可以看这篇文章了。 方法1: 1.越狱设备安装蚂蚁源(https://apt.cydia.love/) ...即可下载到低版本手机上。 ...
  • 魅族手机,每次安装了一个高版本的APK之后,卸载后再安装低版本的APK时,就提示安装失败。用ADB调试时发现提示: Failure [INSTALL_FAILED_VERSION_DOWNGRADE] 先是在手机上清理,仍然不行。然后又在网上查了半天,...
  • 由于360加固软件是每一次更新都是会强制更新的,而我是半年前用的360加固版本打包的应用对于当前的360加固软件来说是过了,导致现在的用户安装apk后会闪退。解决方法是,用现在最新的360加固软件重新打包apk就...
  • 有时候出现不同版本软件,需要安装不同版本的JDK,但是卸载后发现虽然卸载完成后,重新安装和配置环境变量后,通过(doc环境下输入命令:java -version)查看安装成功与否,发现还是之前的版本,重复多次仍然没...
  • HomeBrew安装指定版本软件   快速多版本切换 通过 brew install [formula]@[tag] 安装多个版本,然后把其他版本移动到[formula]默认目录中,然后通过brew switch <formula> <version&...
  • 如何在iphone/ipad上安装低版本App

    千次阅读 2014-08-31 22:07:00
    其实苹果是提供低版本下载的,只是系统不会提示下载低版本的app,而是提示你升级系统版本! 解决办法: 1.下载最新版本的itunes 2.将你的iphone/ipad上的应用同步至itunes资料库,注意,必须使用和iphon...
  • 最近有人提出问题,说IOS7怎么在APP store中下载软件,好多软件都提示需要ios8及以上才可以下载,而App Store里下载又不会提供给你旧版本,难倒ios7就必须升级才能下载吗?对此本人在网上查了好多资料也做了好多测试...
  • Ubuntu20.04终端安装、切换低版本gcc/g++

    千次阅读 多人点赞 2020-09-29 11:55:02
    Ubuntu20.04安装低版本gcc/g++查看当前版本需要有软件源安装gcc-5,g++-5查看设置优先级选择gcc/g++版本查看gcc/g++版本 查看当前版本 gcc -v g++ -v 需要有软件源 打开sources.list sudo gedit /etc/apt/sources....
  • Ubuntu安装低版本gcc和g++

    千次阅读 2012-05-09 21:54:48
    转载地址:...     ============================================================================================== ...因为编译软件的需要,Ubuntu自带
  • 如何用Homebrew安装指定版本软件? Homebrew是一个macOS软件包管理器 它的介绍和安装方法其实在首页上都有: https://brew.sh/index_zh-cn.html 我这里列举出简明步骤,照做即可。 1. 安装 终端输入...
  • 有朋友提问:低版本cad如何打开高版本图纸?遇上这种情况的朋友,一般都会陷入两难境地。想要安装一个最新版的cad软件吧,既费时又麻烦,不这么解决又打不开图纸,真的很烦恼。 其实你只要转换一下思维方式,这个...
  • Ubuntu 12.10安装低版本gcc和g++编译器

    千次阅读 2013-11-17 16:10:58
    Ubuntu12.10默认安装gcc编译器为最新的编译器,实际中常常需降低编译器版本,现列举较为简单实用的方法如下: sudo apt-get install gcc-4.6 sudo apt-get install g++-4.6 查看g++和gcc两个软件包安装的文件的...
  • Ubuntu下载Deb安装包安装低版本gcc

    千次阅读 2011-08-22 16:29:12
    转自:http://hi.baidu.com/419836321/blog/item/690ba4a5bbc597ef9152ee26.html http://gcc.gnu.org/ 因为编译软件的需要,Ubuntu自带的gcc4.4.1版本太高,需要gcc3.x,因此需要
  • Mac OS 10.14 低版本如何安装Xcode 11.6 高版本教程

    万次阅读 热门讨论 2020-08-01 10:42:00
    电脑系统版本2. 首先去苹果官方下载中心下载需要版本的Xcode3. 下载完毕后解压4. 解压出来的包点击会提示系统版本低不能使用5. 对不能使用的Xcode进行处理 1. 电脑系统版本 2. 首先去苹果官方下载中心下载需要版本...
  • ubuntu12.04中有时候因为gcc版本,会出现一系列的错误,解决这些错误的方法,就是安装版本的gcc。1.更新Ubuntu的gcc版本,依次进行如下操作:sudo add-apt-repository ppa:ubuntu-toolchain-r/testsudo apt-...
  • Ubuntu安装切换多个软件版本

    千次阅读 2015-06-05 01:23:40
    在编译某些软件的时候,可能依赖的gcc或者g++的版本和系统不符合,大多情况下都是要比系统版本,但是又不想删除系统的gcc和g++,因为可能其他软件可能需要保持当前的版本,那就可以在ubuntu内安装保留多个gcc和...
  • 请问大神android开发如何让app从高版本到低版本进行安装
  • 由于一些特殊情况,要修改版本号,很多用户疑惑说Win10系统版本号是可以任意修改的?答案是可以的。一般系统版本号自带的,大家没事千万不要修改。如果你有需要,可参考下文教程修改。 具体方法如下: 1、首先,按...
  • windows中如何将已安装的nodejs高版本降级为低版本

    万次阅读 多人点赞 2020-11-27 18:15:44
    第一步:先清空本地安装的node.js版本 1.按健win+R弹出窗口,键盘输入cmd,然后敲回车(或者鼠标直接点击电脑左面最左下角的win窗口图标弹出,输入cmd再点击回车键) 然后进入命令控制行窗口,并输入where node查看...
  • eNSP模拟器——安装出现:已安装的VirtualBox版本,请先卸载再安装HCL 解决:卸载VirtualBox软件安装VirtualBox5.2版本,覆盖安装也可以,安装路径中不要含有中文 软件下载地址:VirtualBox5.2

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 179,048
精华内容 71,619
关键字:

怎么安装低版本软件