精华内容
下载资源
问答
  • 这样就可以防止以前同时打开多个文件夹窗口时,因为这些文件夹窗口使用的是同一个explorer.exe(Windows资源管理器)进程,那么一旦某个文件夹窗口失去响应或崩溃,就会株连所有的文件夹窗口,导致整个Windows资源管理...

    测试平台:Windows 10 1903 专业版

    微软在Win10中为Windows资源管理器做出了一大改进,可在单独的Windows资源管理器进程中打开文件夹窗口。这样就可以防止以前同时打开多个文件夹窗口时,因为这些文件夹窗口使用的是同一个explorer.exe(Windows资源管理器)进程,那么一旦某个文件夹窗口失去响应或崩溃,就会株连所有的文件夹窗口,导致整个Windows资源管理器进程重启或关闭。

    首先我们打开文件资源管理器,点击查看界面,然后点击"选项",在下拉菜单中选择"更改文件夹和搜索选项",如图。

    babdc2313df2ed072723662419ece935.png

    进入文件夹选项配置界面后,切换到查看选项卡,在高级设置里面勾选"在单独的进程中打开文件夹窗口",如图。

    1898ee677183fe737d5e35852860fac1.png

    下来我们看看开启前后的资源管理器进程的对比情况。

    开启前(只有一个Windows资源管理器主进程):

    5c6fe4ac04f0863e1d608efa15470555.png

    后,分为了两个进程,一个是Windows资源管理器主进程,如图。

    990456394cf5c27fdf09436ab00754b7.png

    个是单独的Windows资源管理器应用进程,如图。

    71566da5bbe97cd25210b8b169b0a4c7.png
    990456394cf5c27fdf09436ab00754b7.png
    71566da5bbe97cd25210b8b169b0a4c7.png
    展开全文
  • 加载新的窗口时,控制台打印window.location.href 会显示 xxx/dist/index.html#/intro 当angular路由变成 hash模式的时候,控制台打印会变成 这样在新的页面可以从编译好的dist文件中,取出路由了 ...

    由于angular2+的路由默认为history模式,但是history模式时候

    加载新的窗口时,控制台打印window.location.href 会显示

         xxx/dist/index.html#/intro

    当angular路由变成

    hash模式的时候,控制台打印会变成

    这样在新的页面可以从编译好的dist文件中,取出路由了

    展开全文
  • rt, public Test() { InitializeComponent(); ProClientName = "..\\..\\..\\..\\Client\\bin\\Debug\\testclient...由于我要始终监视win32控制台程序GYJWServer.exe显示的数据,所以想将他始终置顶,怎么实现?
  • 比如说网易云音乐一样。我第一次开了。然后最小化。我第二次打开的时候就直接还原窗口。而不是再开一个进程。代码应该怎么写。
  • >...还有怎么打开一个新页面前三篇文章传送门electron-vue跨平台桌面应用开发实战教程(一)——Hello Worldelectron-vue跨平台桌面应用开发实战教程(二)——主进程常用配置electron-vue跨...

    29ba10cf70e664f85bbb9326c93f5dc2.png

    > 本文我们讲解下怎么修改窗口样式,系统默认的窗口非常普通,通常与设计不符,所以我们要自定义,接下来我们讲解下怎么去掉原有样式,怎么实现实现窗口的最小化,最大化和关闭按钮。还有怎么打开一个新页面

    前三篇文章传送门

    electron-vue跨平台桌面应用开发实战教程(一)——Hello World

    electron-vue跨平台桌面应用开发实战教程(二)——主进程常用配置

    electron-vue跨平台桌面应用开发实战教程(三)——动态修改窗口大小

    我们基于上一篇文章的代码(上一篇文章的git地址:https://gitee.com/hedavid/electron-vue-demos)接着写。先看下上一篇文章实现的样式:

    6254eb2d76cb9a8b58d40344f157b548.png

    765e95763af40906ca0f20745cab2d29.png

    接下来我们就要开始今天的讲解了

    1.去掉外边框

    我们修改background.js,修改createWindow方法,创建BrowserWindow时增加
    frame: false

    win = new BrowserWindow({
        width: 400,
        height: 550,
        frame: false,
        webPreferences: {
          nodeIntegration: true
        }
      })
    

    这样窗口就会变成这样:

    cbf84739eb8e7ebeed252b97cd6aa1a0.png

    但是现在又有一个新问题,应用没有关闭按钮,没有最小化按钮,也不能拖拽移动位置了,接下来我们为他创建一个工具条。

    2.增加操作栏

    (注意:在此处还涉及到其他页面的样式调整,在这里就不列举了,查看git上的代码即可) 我们修改Login.vue,增加以下代码(只展示关键代码,部分样式和html请查看git上的代码):

    const { ipcRenderer } = require('electron')
    // 点击最小化按钮调用的方法
    minimize () {
        ipcRenderer.send('minimize')
    },
    // 点击关闭按钮调用的方法
    close () {
        ipcRenderer.send('close')
    },
    

    窗口的拖动需要增加以下样式:

    -webkit-app-region: drag; // 可拖动
    -webkit-app-region: no-drag; // 不可拖动

    3.主线程中增加对应的最小化和关闭窗口的方法

    ipcMain.on('close', e =>
      win.close()
    )
    
    ipcMain.on('minimize', e =>
      win.minimize()
    )
    

    接下来我们改造一下主页面,来实现打开新窗口的功能

    4. 打开新窗口

    4.1 新建Calendar.vue

    <template>
      <div>
        <el-calendar v-model="value"></el-calendar>
      </div>
    </template>
    
    <script>
    export default {
      name: 'Calendar',
      data () {
        return {
          value: new Date()
        }
      }
    }
    </script>
    

    4.2 修改router

    {
        path: '/Calendar',
        name: 'Calendar',
        component: Calendar
    },
    

    4.3 修改background.js

    const winURL = process.env.NODE_ENV === 'development'
      ? 'http://localhost:8080'
      : `file://${__dirname}/index.html`
    

    上边这段代码主要是用来解决vue路由访问页面的问题,端口号是vue启动的默认端口号,如果有需要可以自行修改

    win.loadURL(winURL)
    

    上边这段代码主要是修改主窗口加载的url,修改我我们上边声明的那个

    // 定义calendar窗体
    let calendarWin
    // 创建calendar窗口方法
    function openCalendarWindow () {
      calendarWin = new BrowserWindow({
        width: 400,
        height: 550,
        parent: win, // win是主窗口
        webPreferences: {
          nodeIntegration: true
        }
      })
      calendarWin.loadURL(winURL + '#/Calendar')
      calendarWin.on('closed', () => { calendarWin = null })
    }
    ipcMain.on('openCalendarWindow', e =>
      openCalendarWindow()
    )
    

    上边这段代码是打开新窗口的代码,calendarWin.loadURL(winURL + '#/Calendar') 是指向我们上边创建的页面。

    4.4 在Home.vue页面中调用创建新窗口的方法

    openCalendarWindow () {
      ipcRenderer.send('openCalendarWindow')
    }
    

    接下来我们看下效果

    f89bffbcaafd6cd4e80466e54949b759.png

    以上就是今天的全部内容,下一篇我们讲一下怎么发系统通知,最小化到托盘,剪贴板

    展开全文
  • ---判断窗口标题.版本 2.支持库 eAPI.子程序 __启动窗口_创建完毕.局部变量 i, 整数型.局部变量 wins, 文本型, , "0"wins = 取所有窗口列表 ().计次循环首 (取数组成员数 (wins), )i = i + 1.如果 (取窗口标题 ...

    ---判断窗口标题

    .版本 2.支持库 eAPI

    .子程序 __启动窗口_创建完毕

    .局部变量 i, 整数型

    .局部变量 wins, 文本型, , "0"

    wins = 取所有窗口列表 ()

    .计次循环首 (取数组成员数 (wins), )

    i = i + 1

    .如果 (取窗口标题 (到数值 (wins [i])) = 取窗口标题 (取窗口句柄 ()))

    结束 ()

    .否则

    .如果结束

    .计次循环尾 ()

    ' 记住窗口一定要有标题!

    ---判断进程

    .版本 2.支持库 eAPI

    .子程序 __启动窗口_创建完毕

    .局部变量 进程列表, 进程信息, , "0"

    .局部变量 临时名称, 文本型

    .局部变量 第一位置, 整数型

    .局部变量 第二位置, 整数型

    .局部变量 临时文本, 文本型

    .局部变量 成员, 整数型

    进程列表 = 取系统进程列表 ()

    临时名称 = 取执行文件名 ()

    .计次循环首 (取数组成员数 (进程列表), 成员)

    临时文本 = 临时文本 + 进程列表 [成员].进程名称

    .计次循环尾 ()

    第一位置 = 寻找文本 (临时文本, 临时名称, , 真)

    第二位置 = 寻找文本 (临时文本, 临时名称, 第一位置 + 2, 真)

    .如果真 (第二位置 > 第一位置)

    信息框 (“该程序正在运行中...” + #换行符 + “请不要重复运行...”, #警告图标, “提示信息”)

    结束 ()

    取消

    评论

    展开全文
  • 还有怎么打开一个新页面 前三篇文章传送门 electron-vue跨平台桌面应用开发实战教程(一)——Hello World electron-vue跨平台桌面应用开发实战教程(二)——主进程常用配置 electron-vue跨...
  • windows怎么查看进程的启动时间

    千次阅读 2018-01-15 10:34:59
    点击“开始→运行”,在运行框里输入“msinfo32”打开“系统信息”窗口,依次点击“软件环境→正在运行任务”就可以查看到进程的详细信息,比如进程路径、文件创建日期、启动时间等等一目了然,对不熟悉的进程可以...
  • >...还有怎么打开一个新页面前三篇文章传送门electron-vue跨平台桌面应用开发实战教程(一)——Hello Worldelectron-vue跨平台桌面应用开发实战教程(二)——主进程常用配置electron-vue跨...
  • 这个问题是CSDN网友MattHgh (黎明破晓前)提出来的,这个问题其实有很多种解决的办法,这里我用WH_SHELL钩子解决,WH_SHELL...那么怎么根据窗口的句柄的句柄获得对应的程序路径呢,这个当然可以通过枚举所有的进程...
  • 这篇文章主要介绍一下Wireshark抓包工具获取到的HTTP协议相关的数据,...1.HTTP 协议抓包实战1.1 打开Wireshark工具,选中正在使用的网卡以太网4(以自己电脑实际使用为准),点击捕获,然后选择选项:1.2 在新窗口中...
  • 1、打开命令窗口(以管理员身份运行) 开始—->运行—->cmd,或者是 window+R 组合键,调出命令窗口。 2、查看被占用端口对应的 PID 比如查找8081端口的PID 输入命令: netstat -aon|findstr "8081" 回车执行...
  • 1.首先,按住win+r调出命令窗口,并输入cmd进入指令面板 2.输入netstat -ano查看所有网络端口 也可以指定查询某个端口 netstat -ano | findstr "88" 3.找到端口所对应的进程号,输入taskkill -PID 进程号 -F 例如...
  • IE7,IE8设置新窗口在选项卡打开

    千次阅读 2010-12-23 22:42:00
     但是我们新开的IE浏览器里打开一个网页在点击其子网页的时候会发现,IE并没有新建选项卡中打开,而是又打开了一个新的IE进程,只有在网址右键中选择"在新选项卡中打开"时才会在同一个IE中打开子网页,怎么才能把这个...
  • 2. 打开 DOS 窗口,转到mysqlbin目录。3. 输入mysqld --skip-grant-tables回车。如果没有出现提示信息,那就对了。如果指令没有阻塞输入或者 tasklist 无 mysqld 进程,这说明不成功,用 3.1 的指令。3.1mysqld --...
  • electron 多窗口通信

    2020-03-11 22:23:15
    一个窗口中的js中执行一个命令通过ipcRenderer发送给主进程,主进程用ipMan进行处...但是只有一个窗口能得到消息其他窗口却无法得到,目的是为了通过系统注销关闭除了主窗口外的所有打开窗口,请教这该怎么解决。</p>
  • Linux如何利用终端关闭进程

    千次阅读 2018-03-07 16:03:24
    打开终端窗口2.输入ps命令用于查看当前正在运行的进程。目前,该终端下有三个进程: bash、a.out、ps我们将关闭a.out进程。3.使用kill命令根据进程的ID号(PID)关闭进程通过ps查到a.out进程进程号PID是3960kill -s...
  • linux编程-进程简介

    2014-05-12 17:59:41
    例如,当我们在打开一个程序两次是,会看到两个窗口,每个窗口就是一个运行实例,即进程。 用进程可以实现高级编程,使一个应用程序一次调用多个进程协同工作,实现软件性能的稳定和快速。 1.进程ID 当linux 系统...
  • DOS窗口查看端口占用

    2018-08-21 23:47:00
    背景:最近用tomcat,一直访问不了,要...打开DOS窗口,输入netstat -ano,找到8080端口号,查看PID后面的进程号 然后输入netstat -aon|findstr "PID",找到这个进程详情,发现1521这个端口怎么这么熟悉呢,原...
  • 怎么关闭qq防护更新进程窗口呢?此文就为大家分享解决qq安全防护更新进程关闭的方法。   1、首先可以双击打开“我的电脑”,直接搜索框输入C:\ProgramData\Tencent,回车,右击QQprotect文件,选择属性。    ...
  • 我的程序中用CreateProcess打开了一个第三方应用,我想给这个应用程序发消息(postmessage或sendmessage),但是取不到有效的窗口句柄,用findwindow有时能取到,有时又取不到,很着急啊,不知道怎么弄才好,关键这...
  • 1.在开始--运行 里面输入cmd点回车...3.ctrl+alt+del打开任务管理器,选进程,这里有很多正在运行的程序怎么找?别急点上面的  查看--选择列--在PID(进程标示符)前面打钩。好了,下面的进程前面都有了PID号码。
  • 小白重装系统,专注于简单。...虽然电脑管家、360之类的管家软件通常都有屏蔽的功能,但毕竟需要运行着这些软件,占用系统资源,今天小编教大家...当电脑弹出了广告时,我们右键打开任务管理器,找到广告弹窗对应的进程...
  • C语言实现命令行窗口

    千次阅读 2013-10-10 15:45:51
    一种方式是main函数带参数argc argv,但是这样每次运行都需要先打开cmd然后输入可执行文件名加参数,怎么样能直接运行可执行文件就出现一个类似cmd的窗口,我可以在上面输入自定义的命令呢? 是不是需要创建进程来...
  • 前边两篇文字简单介绍了一下怎么搭建electron-vue项目,主进程的基本配置,主进程和渲染进程之间的通讯。本文我们主要来讲解下如何动态的修改窗口大小。 通常很多桌面应用,初次打开都需要登录,登录窗口比较小,...
  • 前边两篇文字简单介绍了一下怎么搭建electron-vue项目,主进程的基本配置,主进程和渲染进程之间的通讯。本文我们主要来讲解下如何动态的修改窗口大小。 通常很多桌面应用,初次打开都需要登录,登录窗口比较小,...
  • 用RSelenium爬取数据时,打开chrome浏览器突然不显示浏览器窗口了(进程显示浏览器已在运行中),这个怎么处理呢?  </p>

空空如也

空空如也

1 2 3 4 5 ... 9
收藏数 175
精华内容 70
关键字:

怎么打开进程窗口