精华内容
下载资源
问答
  • 路由协议

    2019-01-20 14:53:32
    路由协议分类 工作方式 分为静态路由与动态路由协议 对网络的认识 DV(distance vector距离矢量) 只知道目的网络的大概方向和距离,道听途说型,自身无选录算法,容易形成环路 ,rip eigrp 皆为此类型 LS(link...

    路由协议分类

    工作方式
     分为静态路由与动态路由协议
    
    对网络的认识

    DV(distance vector距离矢量) 只知道目的网络的大概方向和距离,道听途说型,自身无选录算法,容易形成环路 ,rip eigrp 皆为此类型

    LS(linkstate链路状态)知道全网的拓扑结构,map,不会形成环路 ,ospf协议为此类型

    混合型(兼有DV和LS两种有点)eigrp


    路由协议使用的范围

    AS(自治系统):一个逻辑管理域,由统一的机构负责管理1-65535 ,如电信移动网通皆为AS
    IGP(内部网关协议):运行在同一个AS内部的路由协议 rip、eigrp、ospf
    EGP(外部网关协议):运行在不同AS之间的路由协议BGP(边界网关协议)

    ⦁ 传递路由信息的精确性和准确性
    有类别(classfull)传递路由更新的时候不带子网掩码,传递路由不准确 ripv1 igrp
    无类别(classless) 带子网掩码,传递路由精确

    RIP 协议

    为防止回环发生,RIP采用以下几种机制

    水平分割机制-DV型协议防环
    从一个借口上收到的路由更新,不会再从这个接口上发回,即A给B的路由表更新,B不会再发回给A


    静态路由

    配置静态路由表命令:

    Ip router 目的网络号 目的网络号的子网掩码 下一跳目的IP 下一跳路由端口的子网掩码

    例:ip router 192.168.2.0 255.255.255.0 192.168.3.1 255.255.255.0
    其中 192.168.2.0 255.255.255.0 为R3路由的网络号,即为目的网络号
    192.168.1.3 255.255.255.0 为R2路由的F0/1端口,即为下一跳的路由端口IP及子网掩码

    查看路由信息
    R1#show ip route
    
    删除路由信息
    R1(config)#NO ip route 172.16.10.229 255.255.255.255 192.168.178.254
    
    静态路由添加后都是单向通讯,想要互通的话要反向路由也做静态路由表

    默认路由

    如若内网的地址想要到外网,需要添加一条默认路由,即下一跳到任何地址

     Router(config)#ip route 0.0.0.0 0.0.0.0 172.16.10.226  //0.0.0.0代表任何地址,172.16.10.226表下一出口
    

    动态路由

    RIP

    RIP的路径选择

    1.Hop(跳数)是RIP选路依据的唯一度量值
    2.度量值metric一样,负载转发数据
    3.RIP默认支持4条同时负载
    4.RIP跳数最大为15(可等于15)
    #- 为防止回环发生,RIP采用以下几种机制

    水平分割机制-DV型协议防环

    从一个借口上收到的路由更新,不会再从这个接口上发回,即A给B的路由表更新,B不会再发回给A

    RIP宣告的IP需是主类地址,例如10.0.0.0(A类) 172.16.0.0 (B类) 192.168.1.0.(C类)
    RIP使用的协议为UDP 520 为4层的协议

    RIP路由协议配置

    要使用RIP协议,需要宣告此路由的直连接口信息,命令如下:

    Router(config)#router rip     //设置
    Router(config-router)#version 2
    Router(config-router)#network 192.168.178.0
    Router(config-router)#network 172.16.0.0     //注意要宣告所有与路由直连的接口,并且根据IP分类
                                             //进行宣告,因为宣告的地址没有子网掩码
    

    在network配置之后,路由便会向外发送rip报文

    rip路由汇总

    作用是优化路由表,减小路由表的范围,优化转发
    默认情况下,RIP开启后会自动开启自动汇总,开启自动汇总的命令为

      Router(config)#auto-summary
    

    手动汇总的命令为:

    Router(config)#ip summary-address rip 192.168.135.0 255.255.248.0    //一条即可汇总135-140段
    

    RIP下的默认路由

    下发默认路由的命令是:

    Router(config)#router rip
    Router(config)#default-information originate
    

    默认路由一般为边界路由器,即与ISP连接的那台路由器。


    OSPF

    (Open Shortest Path First) 开放式最短路径优先

    使用IP协议,所以是3层的路由协议

    OSPF有分区概念,分为骨干区域(ID为0)和非骨干区域(ID非0)
    所有非0区域必须直连骨干区域,不可串接
    OSPF的选路标准是根据带宽来选取,即COST值越小 越优先
    如果OSPF运行在IPV4环境中,就使用的是OSPF V2  
    如果OSPF运行在IPV6环境中,就使用的是OSPF V3
    

    OSPFV2

    1.无需管理员手动制定每条路由
    2.动态发送OSPF报文,自动形成路由表
    3.OSPF报文以组播和单播形式发送,组播地址是224.0.0.5 244.0.0.6
    4.路由表支持更新机制:触发更新、周期更新
    5.OSPF路由协议是直接封装在IP报头的协议,IP协议号是89
    6.OSPF路由协议是典型的链路状态路由协议
    7.无类路由协议,适用于大中型网络
    8.工业标准的协议,只能运行在IPV4的网络上
    
    OSPF三张表:

    邻居表、拓扑表(链路状态数据库)、路由表

    OSPF引入区域的概念

    ⦁ 骨干区域(area 0)
    ⦁ 常规区域(1-65535)
    所有常规区域必须和骨干区域相连
    常规区域内的路由信息交互先经骨干,再传递至其他常规区域,骨干区起到中转作用

    OSPF的配置

    Router(config)#router ospf 100   //100为进程号,每台路由器可以相同也可以不同
    Router(config)#network 10.1.1.2 0.0.0.0 area 0   //网段和反掩码,255.255.255.0 的反掩码是0.0.0.255
    Router(config)#network 10.2.2.2 0.0.0.0 area 0   //are 0 即为区域0
    
    OSPF中有路由器ID的概念
    

    路由器ID是路由器在OSPF网络中的唯一标示

    两种配置router-id 的方式
    1.手动制定() 命令为:Router(config)#router-id 1.1.1.1 Router ID 制定后跟实际通讯的IP没有关系,也不通
    2.自动选择,选择规则为 (1)优先环回口最大的IP (2)没有环回口,选择物理口最大的IP

    OSPF选路是OSPF的选路标准是根据带宽来选取 即COST值越小 越优先

    如果要更改OSPF的选路,做到等价负载,即路由有两条相同的路线情况下,均可以连通的情况下
    可以修改接口的BW值,show int e0/0接口信息中可以看到BW 10000Kbit/s
    将此数值修改成2个接口相同即可做到等价负载,BW值只是一个数值,不影响实际传输的速率

    修改的命令为

    Router(config)#int e0/0
    Router(config)#bandwidth 10000  //后面不需要单位
    
    查看邻居表的命令为
    show ip ospf neighbor
    
    查看LSDB(链路状态数据库)
       Show ip ospf database
    

    EIGRP

    特点
    1.无需管理员手动指定每条路由
    2.动态发送EIGRP报文,自动形成路由表
    3.EIGRP报文以组播和单播形式发送,组播地址是24.0.0.10
    4.路由表支持更新机制:触发更新
    5.EIGRP路由协议是直接封装在IP报头的协议,IP协议号是88
    6.EIGRP路由协议是典型的高级距离矢量型路由协议
    7.收敛速度快,100%无环路
    8.支持非等价负载均衡
    9.无类路由协议,思科私有的路由协议,适用于中型网络
    10.支持多种网络层协议,也就是说可以在非IP网络上运行

    EIGRP的三张表

    邻居表 直接相连并运行EIGRP的路由器列表,就是收集直连的设备信息
    拓扑表 收集信息并计算 ,
    路由表 根据拓扑表计算最优路径 并算出路由表

    EIGRP选路度量值

    默认计算度量值标准是由两个条件: 带宽 延迟 在计算的时候,带宽取最小值(瓶颈)延迟取总和(延迟叠加)
    可以配置的度量值标准 : 可靠性 ——》(取最小值) 负载——》(取最大值) M、
    还有 一个 MTU值 ——》(最小值)
    虽然在路局路由器间通过EIGRP数据包交换MTU信息,但计算度量值时并不考虑MTU信息因素

    EIGRP配置命令

    Router(config)#router eigrp 100      (100为AS号,即自制系统号,所有跑EIGRP网络内的路由需要相同)
    Router(config)#network 172.16.0.0    可以使用反掩码,也可以宣告主类地址
    Router(config)#network 10.0.0.0
    

    EIGRP的度量值叫 metric

    计算公式为 [10的7次方/最小带宽(K)+延迟总和]*256 = metric
    用命令show int e0/0查看接口里
    BW 1544 Kbit/S 为接口带宽 DLY 20000 used 为延迟

    修改方式为

    进入接口配置

    Router(config-if)#bandwidt 1000000  //修改带宽
    Router(config-if)#delay 10      //修改延迟
    

    如果要修改EIGRP的选路,将希望走的那条线路的接口的带宽改大 延迟改小即可

    AD 即管理距离

    各个协议的AD值不同,如下表

    协议 AD值
    OSPF 110
    EIGRP 90
    RIP 120

    在查看路由表信息的内容中有此类信息

    在单臂路由的环境中,使用动态路由协议的时候要把每个环回口也要宣告
    展开全文
  • 静态路由&rip协议&ospf路由协议

    千次阅读 2020-06-13 14:51:13
    rip和ospf路由协议rip路由协议简介信息协议历史信息原理版本RIPv1RIPv2rip和rip2区别rip-1rip-2RIPng协议分层常考题ospf路由协议概述实现过程opsf分组优点缺点实验:rip路由协议实验ospf路由协议 rip路由协议 简介 ...

    rip路由协议

    简介

    路由信息协议(RIP) 是内部网关协议IGP中最先得到广泛使用的协议【1058 [1] 】。RIP是一种分布式的基于距离矢量的路由选择协议,是因特网的标准协议,其最大优点就是实现简单,开销较小。
    但RIP的缺点也较多。首先,其限制了网络的规模,能使用的最大距离为15(16表示不可达)。其次路由器交换的信息是路由器的完整路由表,因而随着网络规模的扩大,开销也就增加。最后,“坏消息传播得慢”,使更新过程的收敛时间过长。因此对于规模较大的网络就应当使用OSPF协议。然而在规模较小的网络中,使用RIP协议的仍占多数。


    信息协议

    路由信息协议(Routing Information Protocol,缩写:RIP)是一种使用最广泛的内部网关协议(IGP)。(IGP)是在内部网络上使用的路由协议(在少数情形下,也可以用于连接到因特网的网络),它可以通过不断的交换信息让路由器动态的适应网络连接的变化,这些信息包括每个路由器可以到达哪些网络,这些网络有多远等。 IGP是应用层协议,并使用UDP作为传输协议。
    虽然RIP仍然经常被使用,但大多数人认为它将会而且正在被诸如OSPF和IS-IS这样的路由协议所取代。当然,我们也看到EIGRP,一种和RIP属于同一基本协议类(距离矢量路由协议,Distance Vector Routing Protocol)但更具适应性的路由协议,也得到了一些使用。


    历史信息

    Xerox公司在20世纪70年代开发的,是IP所使用的第一个路由协议,RIP已经成为从UNIX系统到各种路由器的必备路由协议。RIP协议有以下特点:
      (1)RIP是自治系统内部使用的协议即内部网关协议,使用的是距离矢量算法。
      (2)RIP使用UDP的520端口进行RIP进程之间的通信。
      (3)RIP主要有两个版本:RIPv1和RIPv2。RIPv1协议的具体描述在RFC1058中,RIPv2是对RIPv1协议的 改进,其协议的具体描述在RFC2453中。
      (4)RIP协议以跳数作为网络度量值。
    (5)RIP协议采用广播或组播进行路由更新,其中RIPv1使用广播,而RIPv2使用组播(224.0.0.9)。
      (6)RIP协议支持主机被动模式,即RIP协议允许主机只接收和更新路由信息而不发送信息。 
      (7)RIP协议支持默认路由传播。
      (8)RIP协议的网络直径不超过15跳,适合于中小型网络。16跳时认为网络不可达。
      (9)RIPv1是有类路由协议,RIPv2是无类路由协议,即RIPv2的报文中含有掩码信息。
    RIP所使用的路由算法是Bellman-Ford算法.这种算法最早被用于一个计算机网络是在1969年,当时是作为ARPANET的初始路由算法。
    RIP是由“网关信息协议”(Xerox Parc的用于互联网工作的PARC通用数据包协议簇的一部分)发展过来的,可以说网关信息协议是RIP的最早的版本。后来的一个版本才被命名为“路由信息协议”,是Xerox网络服务协议簇的一部分。


    原理

    同一自治系统(A.S.)中的路由器每 30秒会与相邻的路由器 交换子讯息,以动态的建立路由表。
    RIP 允许最大的hop数(跳数)为15 多于15跳不可达。


    版本

    RIP共有三个版本,RIPv1, RIPv2, RIPng
    其中RIPV1和RIPV2是用在IPV4的网络环境里,RIPng是用在IPV6的网络环境里。

    RIPv1

    RIPv1使用分类路由,定义在[RFC 1058 [1] ]中。在它的路由更新(Routing Updates)中并不带有子网的资讯,因此它无法支持可变长度子网掩码。这个限制造成在RIPv1的网络中,同级网络无法使用不同的子网掩码。换句话说,在同一个网络中所有的子网络数目都是相同的。另外,它也不支持对路由过程的认证,使得RIPv1有一些轻微的弱点,有被攻击的可能。

    RIPv2

    因为RIPv1的缺陷,RIPv2在1994年被提出,将子网络的资讯包含在内,透过这样的方式提供无类别域间路由,不过对于最大节点数15的这个限制仍然被保留着。另外针对安全性的问题,RIPv2也提供一套方法,透过加密来达到认证的效果。而之后[RFC 2082 [2] ]也定义了利用MD5来达到认证的方法。 RIPv2的相关规定在[RFC 2453 [3] ] orSTD56。
    现今的IPv4网络中使用的大多是RIPv2,RIPv2是在RIPv1基础上的改进, RIPv2和RIPv1相比主要有以下区别。

    rip和rip2区别

    rip-1

    • RIP属于典型的距离矢量路由选择协议。
    • RIP消息通过广播地址255.255.255.255进行发送,RIPv2使用组播地址224.0.0.9发送消息,两者都使用UDP 协议的520端口。
    • RIP以到目的网络的最小跳数作为路由选择度量标准,而不是在链路的带宽和延迟的基础上进行选择。
    • RIP是为小型网络设计的。它的跳数计数限制为15跳,16跳为不可到达。
    • RIP是一种有类路由协议,不支持不连续子网设计。RIP-2支持CIDR及VLSM可变长子网掩码,使其支持不连续子网设计。
    • RIP周期性进行完全路由更新,将路由表广播给邻居路由器,广播周期缺省为30秒。
    • RIP的协议管理距离为120。

    rip-2

    • RIP-2 是一种无类别路由协议(Classless Routing Protocol)。
    • RIP-2协议报文中携带掩码信息,支持VLSM(可变长子网掩码)和CIDR。
    • RIP-2支持以组播方式发送路由更新报文,组播地址为224.0.0.9,减少网络与系统资源消耗。
    • RIP-2支持对协议报文进行验证,并提供明文验证和MD5验证两种方式,增强安全性。
    • RIP-2能够支持VLSM
      在这里插入图片描述

    RIPng

    RIPng(Routing Information Protocol next generation)则被定义在[RFC 2080 [4] ],主要是针对IPv6做一些延伸的规范。与RIPv2相比下其最主要的差异是:
    RIPv2 支持RIP更新认证, RIPng 则没有 (IPv6 routers were, at the time, supposed to use IPsec for authentication);
    RIPv2 容许附上arbitrary 的标签, RIPng 则不容许;
    RIPv2 encodes the next-hop into each route entries, RIPng requires specific encoding of the nexthop for a set of route entries.
    RIPv2 UDP的Port number 为 520,RIPng UDP的Port number 为 521


    协议分层

    TCP/IP参考模型分为四层:应用层(Application Layer)、主机到主机层、网络层(Internet Layer)、网络接入层。
    在这里插入图片描述

    常考题

    • 什么是RIP
      RIP是一种距离矢量路由协议(Distance Vector Routing Protocol)。基本上,距离矢量路由协议基于距离矢量算法根据目的地的远近(远近=经过路由器的数量)来决定最好的路径。
    • RIP的作用是什么
      RIP让路由器之间互相传递路由信息。路由器通过RIP,能自动知道远程目的地,而不需要网络管理员给每台路由器添加静态路由信息。
    • 传递路由信息
      RIP把自己所有的路由信息,通过Response包泛洪给邻居。
    • 计算Metric
      RIP用“跳数”来计算cost(metric),每经过一台路由器,“跳数”就增加1。RIP会通过“跳数”最小的路径传输数据包。

    ospf路由协议

    概述

    开放式最短路径优先(Open Shortest Path First,OSPF)是广泛使用的一种动态路由协议,它属于链路状态路由协议,具有路由变化收敛速度快、无路由环路、支持变长子网掩码(VLSM)和汇总、层次区域划分等优点。在网络中使用OSPF协议后,大部分路由将由OSPF协议自行计算和生成,无须网络管理员人工配置,当网络拓扑发生变化时,协议可以自动计算、更正路由,极大地方便了网络管理。但如果使用时不结合具体网络应用环境,不做好细致的规划,OSPF协议的使用效果会大打折扣,甚至引发故障。
    OSPF协议是一种链路状态协议。每个路由器负责发现、维护与邻居的关系,并将已知的邻居列表和链路费用LSU(Link State Update)报文描述,通过可靠的泛洪与自治系统AS(Autonomous System)内的其他路由器周期性交互,学习到整个自治系统的网络拓扑结构;并通过自治系统边界的路由器注入其他AS的路由信息,从而得到整个Internet的路由信息。每隔一个特定时间或当链路状态发生变化时,重新生成LSA,路由器通过泛洪机制将新LSA通告出去,以便实现路由的实时更新。

    实现过程

    1. 初始化形成端口初始信息:在路由器初始化或网络结构发生变化(如链路发生变化,路由器新增或损坏)时,相关路由器会产生链路状态广播数据包LSA,该数据包里包含路由器上所有相连链路,也即为所有端口的状态信息。
    2. 路由器间通过泛洪(Floodingl机制交换链路状态信息:各路由器一方面将其LSA数据包传送给所有与其相邻的OSPF路由器,另一方面接收其相邻的OSPF路由器传来的LSA数据包,根据其更新自己的数据库。
    3. 形成稳定的区域拓扑结构数据库:OSPF路由协议通过泛洪法逐渐收敛,形成该区域拓扑结构的数据库,这时所有的路由器均保留了该数据库的一个副本。
    4. 形成路由表:所有的路由器根据其区域拓扑结构数据库副本采用最短路径法计算形成各自的路由表。

    opsf分组

    OSPF协议依靠五种不同类型的分组来建立邻接关系和交换路由信息,即问候分组、数据库描述分组、链路状态请求分组、链路状态更新分组和链路状态确认分组。

    1. 问候(Hello)分组
      OSPF使用Hello分组建立和维护邻接关系。在一个路由器能够给其他路由器分发它的邻居信息前,必须先问候它的邻居们。
    2. 数据库描述(Data base Description,DBD)分组
      DBD分组不包含完整的“链路状态数据库”信息,只包含数据库中每个条目的概要。当一个路由器首次连入网络,或者刚刚从故障中恢复时,它需要完整的“链路状态数据库”信息。此时,该路由器首先通过hello分组与邻居们建立双向通信关系,然后将会收到每个邻居反馈的DBD分组。新连入的这个路由器会检查所有概要,然后发送一个或多个链路状态请求分组,取回完整的条目信息。
    3. 链路状态请求(Link State Request,LSR)分组
      LSR分组用来请求邻居发送其链路状态数据库中某些条目的详细信息。当一个路由器与邻居交换了数据库描述分组后,如果发现它的链路状态数据库缺少某些条目或某些条目已过期,就使用LSR分组来取得邻居链路状态数据库中较新的部分。
    4. 链路状态更新(Link State Update,LSU)分组
      LSU分组被用来应答链路状态请求分组,也可以在链路状态发生变化时实现洪泛(flooding)。在网络运行过程中,只要一个路由器的链路状态发生变化,该路由器就要使用LSU,用洪泛法向全网更新链路状态。
    5. 链路状态确认(Link State Acknowledgment,LSAck)分组
      LSAck分组被用来应答链路状态更新分组,对其进行确认,从而使得链路状态更新分组采用的洪泛法变得可靠。

    优点

    • OSPF适合在大范围的网络:OSPF协议当中对于路由的跳数,它是没有限制的,所以OSPF协议能用在许多场合,同时也支持更加广泛的网络规模。只要是在组播的网络中,OSPF协议能够支持数十台路由器一起运作。
    • 组播触发式更新:OSPF协议在收敛完成后,会以触发方式发送拓扑变化的信息给其他路由器,这样就可以减少网络宽带的利用率;同时,可以减小干扰,特别是在使用组播网络结构,对外发出信息时,它对其他设备不构成其他影响
    • 收敛速度快:如果网络结构出现改变,OSPF协议的系统会以最快的速度发出新的报文,从而使新的拓扑情况很快扩散到整个网络;而且,OSPF采用周期较短的HELLO报文来维护邻居状态。
    • 以开销作为度量值:OSPF协议在设计时,就考虑到了链路带宽对路由度量值的影响。OSPF协议是以开销值作为标准,而链路开销和链路带宽,正好形成了反比的关系,带宽越是高,开销就会越小,这样一来,OSPF选路主要基于带宽因素。
    • OSPF协议的设计是为了避免路由环路:在使用最短路径的算法下,收到路由中的链路状态,然后生成路径,这样不会产生环路。
    • 应用广泛:广泛的应用在互联网上,其他会有大量的应用实例。证明这是使用最广泛的IPG之一。

    缺点

    • OSPF协议的配置对于技术水平要求很高,配置比较复杂的。因为网络会根据具体的参数,给整个网络划分区域或者标注某个属性,所以各种情况都会非常复杂,这就要求网络分析员对OSPF协议的配置要相当了解,不但要求具有普通的网络知识技术,还要有更深层的技术理解,只有具备这样的人员,才能完成OSPF协议的配置和日常维护。
    • 路由其自身的负载分担能力是很低的。OSPF路由协议会根据几个主要的因素,生成优先级不同的接口。然而在同一个区域内,路由协议只会通过优先级最高的那个接口。只要是接口优先级低于最高优先级,那么路由就不会通过。在这个基础上,不同等级的路由,无法相互承担负载,只能独自运行。
    版权声明:以上源于百度百科

    实验:rip路由协议

    1. 实验拓扑
      在这里插入图片描述
    2. ip地址分配
    设备 接口 地址
    RA GE0/0 192.168.1.2/24
    RA GE0/1 192.168.2.1/24
    RB GE0/0 192.168.2.2/24
    RB GE0/1 192.168.3.1/24
    PA 192.168.1.1/24
    PB 192.168.3.2/24
    1. 给RA/RB配置接口地址
    <H3C>system-view
    System View: return to User View with Ctrl+Z.
    [H3C]int ge0/0
    [H3C-GigabitEthernet0/0]ip add 192.168.1.2 24
    

    其余同上。

    1. 配置好之后,我们再测试下连通性

    PA客户端

    # ping 的是PA--PA  环回地址loopback		状态:成功
    <H3C>ping 192.168.1.1
    Ping 192.168.1.1 (192.168.1.1): 56 data bytes, press CTRL_C to break
    56 bytes from 192.168.1.1: icmp_seq=0 ttl=255 time=0.000 ms
    56 bytes from 192.168.1.1: icmp_seq=1 ttl=255 time=0.000 ms
    56 bytes from 192.168.1.1: icmp_seq=2 ttl=255 time=0.000 ms
    56 bytes from 192.168.1.1: icmp_seq=3 ttl=255 time=0.000 ms
    56 bytes from 192.168.1.1: icmp_seq=4 ttl=255 time=0.000 ms
    --- Ping statistics for 192.168.1.1 ---
    5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss
    round-trip min/avg/max/std-dev = 0.000/0.000/0.000/0.000 ms
    
    # ping 的是RA的接口ge0/0 	状态:成功
    <H3C>ping 192.168.1.2
    Ping 192.168.1.2 (192.168.1.2): 56 data bytes, press CTRL_C to break
    56 bytes from 192.168.1.2: icmp_seq=0 ttl=255 time=1.000 ms
    56 bytes from 192.168.1.2: icmp_seq=1 ttl=255 time=0.000 ms
    56 bytes from 192.168.1.2: icmp_seq=2 ttl=255 time=1.000 ms
    56 bytes from 192.168.1.2: icmp_seq=3 ttl=255 time=1.000 ms
    56 bytes from 192.168.1.2: icmp_seq=4 ttl=255 time=0.000 ms
    --- Ping statistics for 192.168.1.2 ---
    5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss
    round-trip min/avg/max/std-dev = 0.000/0.600/1.000/0.490 ms
    
    # ping的是RA的接口ge0/1   状态:成功
    <H3C>ping 192.168.2.1
    Ping 192.168.2.1 (192.168.2.1): 56 data bytes, press CTRL_C to break
    56 bytes from 192.168.2.1: icmp_seq=0 ttl=255 time=1.000 ms
    56 bytes from 192.168.2.1: icmp_seq=1 ttl=255 time=1.000 ms
    56 bytes from 192.168.2.1: icmp_seq=2 ttl=255 time=0.000 ms
    56 bytes from 192.168.2.1: icmp_seq=3 ttl=255 time=0.000 ms
    56 bytes from 192.168.2.1: icmp_seq=4 ttl=255 time=0.000 ms
    --- Ping statistics for 192.168.2.1 ---
    5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss
    round-trip min/avg/max/std-dev = 0.000/0.400/1.000/0.490 ms
    
    # ping 的是RB的接口ge0/0   状态:失败
    <H3C>ping 192.168.2.2
    Ping 192.168.2.2 (192.168.2.2): 56 data bytes, press CTRL_C to break
    Request time out
    Request time out
    Request time out
    Request time out
    Request time out
    --- Ping statistics for 192.168.2.2 ---
    5 packet(s) transmitted, 0 packet(s) received, 100.0% packet loss
    

    为什么会失败?
    因为PA是192.168.1.0/24网络段,但是RB的接口ge0/0是192.168.2.0/24网络段,不在同一个网络段,所以无法通信。

    # RA路由表信息
    <H3C>display ip routing-table
    Destinations : 16       Routes : 16
    Destination/Mask   Proto   Pre Cost        NextHop         Interface
    0.0.0.0/32         Direct  0   0           127.0.0.1       InLoop0
    127.0.0.0/8        Direct  0   0           127.0.0.1       InLoop0
    127.0.0.0/32       Direct  0   0           127.0.0.1       InLoop0
    127.0.0.1/32       Direct  0   0           127.0.0.1       InLoop0
    127.255.255.255/32 Direct  0   0           127.0.0.1       InLoop0
    192.168.1.0/24     Direct  0   0           192.168.1.2     GE0/0
    192.168.1.0/32     Direct  0   0           192.168.1.2     GE0/0
    192.168.1.2/32     Direct  0   0           127.0.0.1       InLoop0
    192.168.1.255/32   Direct  0   0           192.168.1.2     GE0/0
    192.168.2.0/24     Direct  0   0           192.168.2.1     GE0/1
    192.168.2.0/32     Direct  0   0           192.168.2.1     GE0/1
    192.168.2.1/32     Direct  0   0           127.0.0.1       InLoop0
    192.168.2.255/32   Direct  0   0           192.168.2.1     GE0/1
    224.0.0.0/4        Direct  0   0           0.0.0.0         NULL0
    224.0.0.0/24       Direct  0   0           0.0.0.0         NULL0
    255.255.255.255/32 Direct  0   0           127.0.0.1       InLoop0
    

    在路由表中我们也看不见指向192.168.2.2/24的路由信息。
    5. 配置静态路由协议

    命令行:ip route-static	 目的网络  	网络号长度 		下一跳
    
    # 路由器RA配置
    [RA]IP route-static 192.168.3.0 24 192.168.2.2
    
    # 路由器RB配置
    [RB]IP route-static 192.168.1.0 24 192.168.2.1
    

    完成之后:

    # 用PA去ping一下PB  		状态:成功
    ping 192.168.3.2
    Ping 192.168.3.2 (192.168.3.2): 56 data bytes, press CTRL_C to break
    56 bytes from 192.168.3.2: icmp_seq=0 ttl=253 time=2.000 ms
    56 bytes from 192.168.3.2: icmp_seq=1 ttl=253 time=1.000 ms
    56 bytes from 192.168.3.2: icmp_seq=2 ttl=253 time=1.000 ms
    56 bytes from 192.168.3.2: icmp_seq=3 ttl=253 time=1.000 ms
    56 bytes from 192.168.3.2: icmp_seq=4 ttl=253 time=1.000 ms
    --- Ping statistics for 192.168.3.2 ---
    5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss
    round-trip min/avg/max/std-dev = 1.000/1.200/2.000/0.400 ms
    
    # RA路由表信息
    [RA]display ip routing-table
    Destinations : 17       Routes : 17
    Destination/Mask   Proto   Pre Cost        NextHop         Interface
    0.0.0.0/32         Direct  0   0           127.0.0.1       InLoop0
    127.0.0.0/8        Direct  0   0           127.0.0.1       InLoop0
    127.0.0.0/32       Direct  0   0           127.0.0.1       InLoop0
    127.0.0.1/32       Direct  0   0           127.0.0.1       InLoop0
    127.255.255.255/32 Direct  0   0           127.0.0.1       InLoop0
    192.168.1.0/24     Direct  0   0           192.168.1.2     GE0/0
    192.168.1.0/32     Direct  0   0           192.168.1.2     GE0/0
    192.168.1.2/32     Direct  0   0           127.0.0.1       InLoop0
    192.168.1.255/32   Direct  0   0           192.168.1.2     GE0/0
    192.168.2.0/24     Direct  0   0           192.168.2.1     GE0/1
    192.168.2.0/32     Direct  0   0           192.168.2.1     GE0/1
    192.168.2.1/32     Direct  0   0           127.0.0.1       InLoop0
    192.168.2.255/32   Direct  0   0           192.168.2.1     GE0/1
    192.168.3.0/24     Static  60  0           192.168.2.2     GE0/1
    224.0.0.0/4        Direct  0   0           0.0.0.0         NULL0
    224.0.0.0/24       Direct  0   0           0.0.0.0         NULL0
    255.255.255.255/32 Direct  0   0           127.0.0.1       InLoop0
    

    多了一条路由信息,指向192.168.3.0/24,下一跳是192.168.2.2

    1. 删除静态路由协议,配置rip协议
    # 查看静态路由表
    [RA]display route-static routing-table
    Total number of routes: 1
    Status: * - valid
    *Destination: 192.168.3.0/24
           NibID: 0x11000000        NextHop: 192.168.2.2
       MainNibID: N/A             BkNextHop: N/A
         BkNibID: N/A             Interface: N/A
         TableID: 0x2           BkInterface: N/A
            Flag: 0x82d01          BfdSrcIp: N/A
         DbIndex: 0x1            BfdIfIndex: 0x0
            Type: Normal        BfdVrfIndex: 0
      TrackIndex: 0xffffffff          Label: NULL
      Preference: 60            vrfIndexDst: 0
         BfdMode: N/A            vrfIndexNH: 0
       Permanent: 0                     Tag: 0
    
    # 删除静态路由
    [RA]delete static-routes all
    
    # RB配置rip协议(就是相邻网络段就好)
    [RB]rip
    [RB-rip-1]network 192.168.2.0
    [RB-rip-1]network 192.168.3.0
    
    # RA配置rip协议
    [RA]rip
    [RA-rip-1]net 192.168.2.0
    [RA-rip-1]net 192.168.1.0
    
    1. 测试
    # PA---PB		状态:成功
    ping 192.168.3.2
    Ping 192.168.3.2 (192.168.3.2): 56 data bytes, press CTRL_C to break
    56 bytes from 192.168.3.2: icmp_seq=0 ttl=253 time=1.000 ms
    56 bytes from 192.168.3.2: icmp_seq=1 ttl=253 time=1.000 ms
    56 bytes from 192.168.3.2: icmp_seq=2 ttl=253 time=3.000 ms
    56 bytes from 192.168.3.2: icmp_seq=3 ttl=253 time=2.000 ms
    56 bytes from 192.168.3.2: icmp_seq=4 ttl=253 time=1.000 ms
    --- Ping statistics for 192.168.3.2 ---
    5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss
    round-trip min/avg/max/std-dev = 1.000/1.600/3.000/0.800 ms
    
    # 查看rip协议配置
    [RA]display rip 1
      Public VPN-instance name:
        RIP process: 1
           RIP version: 1
           Preference: 100
           Checkzero: Enabled
           Default cost: 0
           Summary: Enabled
           Host routes: Enabled
           Maximum number of load balanced routes: 32
           Update time   :   30 secs  Timeout time         :  180 secs
           Suppress time :  120 secs  Garbage-collect time :  120 secs
           Update output delay:   20(ms)  Output count:    3
           TRIP retransmit time:    5(s)  Retransmit count: 36
           Graceful-restart interval:   60 secs
           Triggered Interval : 5 50 200
           BFD: Disabled
           Silent interfaces: None
           Default routes: Disabled
           Verify-source: Enabled
           Networks:
               192.168.1.0            192.168.2.0
           Configured peers: None
           Triggered updates sent: 2
    
    1. 删除rip1协议,配置rip2协议
    # 取消rip协议
    [RA]undo rip
    Undo RIP process? [Y/N]:y
    
    # 取消rip协议
    [RB]undo rip
    Undo RIP process? [Y/N]:y
    
    # RB配置rip2协议
    [RB]rip
    [RB-rip-1]version 2
    [RB-rip-1]net 192.168.2.0
    [RB-rip-1]net 192.168.3.0
    
    # RA配置rip协议
    [RA]rip
    [RA-rip-1]version 2
    [RA-rip-1]net 192.168.1.0
    [RA-rip-1]net 192.168.2.0
    
    # 查看rip2协议
    [RA]display rip
      Public VPN-instance name:
        RIP process: 1
           RIP version: 2
           Preference: 100
           Checkzero: Enabled
           Default cost: 0
           Summary: Enabled
           Host routes: Enabled
           Maximum number of load balanced routes: 32
           Update time   :   30 secs  Timeout time         :  180 secs
           Suppress time :  120 secs  Garbage-collect time :  120 secs
           Update output delay:   20(ms)  Output count:    3
           TRIP retransmit time:    5(s)  Retransmit count: 36
           Graceful-restart interval:   60 secs
           Triggered Interval : 5 50 200
           BFD: Disabled
           Silent interfaces: None
           Default routes: Disabled
           Verify-source: Enabled
           Networks:
               192.168.1.0            192.168.2.0
           Configured peers: None
           Triggered updates sent: 2
    
    1. 测试
    <H3C>ping 192.168.3.2
    Ping 192.168.3.2 (192.168.3.2): 56 data bytes, press CTRL_C to break
    56 bytes from 192.168.3.2: icmp_seq=0 ttl=253 time=2.000 ms
    56 bytes from 192.168.3.2: icmp_seq=1 ttl=253 time=1.000 ms
    56 bytes from 192.168.3.2: icmp_seq=2 ttl=253 time=2.000 ms
    56 bytes from 192.168.3.2: icmp_seq=3 ttl=253 time=2.000 ms
    56 bytes from 192.168.3.2: icmp_seq=4 ttl=253 time=2.000 ms
    --- Ping statistics for 192.168.3.2 ---
    5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss
    round-trip min/avg/max/std-dev = 1.000/1.800/2.000/0.400 ms
    

    实验:ospf路由协议

    1. 实验拓扑
      在这里插入图片描述

    2. ip地址分配

    设备 接口 地址
    RA GE0/0 192.168.1.2/24
    RA Se1/0 192.168.2.1/24
    RB Se1/0 192.168.2.2/24
    RB GE0/1 192.168.3.1/24
    PA 192.168.1.1/24
    PB 192.168.3.2/24
    1. 配置IP命令
      略(学过rip路由配置就不应该对此有疑问!!!)

    2. 状态检测

    # PB-----ping-----PB
    ping 192.168.3.2
    Ping 192.168.3.2 (192.168.3.2): 56 data bytes, press CTRL_C to break
    56 bytes from 192.168.3.2: icmp_seq=0 ttl=255 time=0.000 ms
    56 bytes from 192.168.3.2: icmp_seq=1 ttl=255 time=0.000 ms
    56 bytes from 192.168.3.2: icmp_seq=2 ttl=255 time=0.000 ms
    56 bytes from 192.168.3.2: icmp_seq=3 ttl=255 time=0.000 ms
    56 bytes from 192.168.3.2: icmp_seq=4 ttl=255 time=0.000 ms
    --- Ping statistics for 192.168.3.2 ---
    5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss
    round-trip min/avg/max/std-dev = 0.000/0.000/0.000/0.000 ms
    
    # PB-----ping-----RB(GE0/1)
    ping 192.168.3.1
    Ping 192.168.3.1 (192.168.3.1): 56 data bytes, press CTRL_C to break
    56 bytes from 192.168.3.1: icmp_seq=0 ttl=255 time=0.000 ms
    56 bytes from 192.168.3.1: icmp_seq=1 ttl=255 time=0.000 ms
    56 bytes from 192.168.3.1: icmp_seq=2 ttl=255 time=0.000 ms
    56 bytes from 192.168.3.1: icmp_seq=3 ttl=255 time=1.000 ms
    56 bytes from 192.168.3.1: icmp_seq=4 ttl=255 time=1.000 ms
    --- Ping statistics for 192.168.3.1 ---
    5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss
    round-trip min/avg/max/std-dev = 0.000/0.400/1.000/0.490 ms
    
    # PB-----ping-----RB(se1/0)
    ping 192.168.2.2
    Ping 192.168.2.2 (192.168.2.2): 56 data bytes, press CTRL_C to break
    56 bytes from 192.168.2.2: icmp_seq=0 ttl=255 time=1.000 ms
    56 bytes from 192.168.2.2: icmp_seq=1 ttl=255 time=0.000 ms
    56 bytes from 192.168.2.2: icmp_seq=2 ttl=255 time=1.000 ms
    56 bytes from 192.168.2.2: icmp_seq=3 ttl=255 time=1.000 ms
    56 bytes from 192.168.2.2: icmp_seq=4 ttl=255 time=0.000 ms
    --- Ping statistics for 192.168.2.2 ---
    5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss
    round-trip min/avg/max/std-dev = 0.000/0.600/1.000/0.490 ms
    
    # PB-----ping-----RA(Se1/0)
    ping 192.168.2.1
    Ping 192.168.2.1 (192.168.2.1): 56 data bytes, press CTRL_C to break
    Request time out
    Request time out
    Request time out
    Request time out
    Request time out
    --- Ping statistics for 192.168.2.1 ---
    5 packet(s) transmitted, 0 packet(s) received, 100.0% packet loss
    

    配置没有问题,继续…



    1. 配置ospf路由协议
    # 配置单个区域的opsf,就是上面两台路由设备在同一个ospf域内
    
    # RA
    [RA]ospf 100
    [RA-ospf-100]area 12
    [RA-ospf-100-area-0.0.0.12]network 192.168.1.0 0.0.0.255
    [RA-ospf-100-area-0.0.0.12]network 192.168.2.0 0.0.0.255
    [RA-ospf-100-area-0.0.0.12]quit
    [RA-ospf-100]
    
    # RB
    [RB]ospf 100
    [RB-ospf-100]area 12
    [RB-ospf-100-area-0.0.0.12]net 192.168.2.0 0.0.0.255
    [RB-ospf-100-area-0.0.0.12]net 192.168.3.0 0.0.0.255
    [RB-ospf-100-area-0.0.0.12]quit
    [RB-ospf-100]
    
    1. 查看OSPF配置信息
    [RA]dis ospf routing
             OSPF Process 100 with Router ID 192.168.2.1
                      Routing Table
                    Topology base (MTID 0)
     Routing for network
     Destination        Cost     Type    NextHop         AdvRouter       Area
     192.168.3.0/24     1563     Stub    192.168.2.2     192.168.3.1     0.0.0.12
     192.168.1.0/24     1        Stub    0.0.0.0         192.168.2.1     0.0.0.12
     192.168.2.0/24     1562     Stub    0.0.0.0         192.168.2.1     0.0.0.12
    
    1. 检验
    # PA-----ping-----PB
    <H3C>ping 192.168.3.2
    Ping 192.168.3.2 (192.168.3.2): 56 data bytes, press CTRL_C to break
    56 bytes from 192.168.3.2: icmp_seq=0 ttl=253 time=2.000 ms
    56 bytes from 192.168.3.2: icmp_seq=1 ttl=253 time=2.000 ms
    56 bytes from 192.168.3.2: icmp_seq=2 ttl=253 time=2.000 ms
    56 bytes from 192.168.3.2: icmp_seq=3 ttl=253 time=2.000 ms
    56 bytes from 192.168.3.2: icmp_seq=4 ttl=253 time=1.000 ms
    --- Ping statistics for 192.168.3.2 ---
    5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss
    round-trip min/avg/max/std-dev = 1.000/1.800/2.000/0.400 ms
    
    1. 多区域OSPF配置
    # 具体代码和单个区域是一样的,网络段分配给不同域内即可
    
    1. 至此,实验全部完结,感谢各位博主、大佬的观看
      在这里插入图片描述
    展开全文
  • AODV路由协议详解

    千次阅读 2020-04-04 20:03:46
    移动Ad Hoc网络(Mobile Adhoc Network,MANET)是一种无线自组织的...AODV(Ad Hoc On-Demand Distance Vector)路由协议是专门为移动Ad Hoc网络设计的路由协议,它是一个按需路由协议,只要当需要建立到目的节点的路

    AODV路由协议详解

    本文目录:
    在这里插入图片描述
    本文是对AODV路由协议的原理描述,作者同时在android平台对AODV路由协议做了代码实现,有需要的可以自行下载https://download.csdn.net/download/qq_36267931/12589470

    移动Ad Hoc网络概述

    “Ad Hoc”一词起源于拉丁语,可以翻译为“for this purpose only”,意译为“特别的,临时的网络”。
    移动Ad Hoc网络(Mobile Adhoc Network,MANET)专指用于移动无线设备的Ad Hoc网络,用于其它用途的Ad Hoc网络有无线网状网络(wireless mesh network,WMN)和无线传感器网络(wirelss sensors networks,WSN)等。
    移动Ad Hoc网络中的节点一般是可以通过无线方式与其它设备进行数据接收和转发的移动设备,比如手机和手提笔记本。每一个节点既是接收数据的主机,也是负责转发数据的路由器。因为节点的路由器身份,移动Ad Hoc允许在没有无线访问接入点(wireless access point)的情况下节点之间的数据双向传输,网络中的数据可能需要经过节点的多跳传输才能到达目的节点。
    移动Ad Hoc网络允许节点动态地进入和离开网络,网络拓扑动态的变化所可能造成的路由失效,可以通过修复路由或重新发现新路由等办法解决。
    总结一下,移动Ad Hoc网络具有以下特点:
    (1)自组织,无需无线访问接入点即可通信,每个节点都充当路由器。
    (2)自适应,允许网络拓扑的动态变化,可以进行路由的重新发现与修正。
    (3)易部署,无需部署无线访问接入点即可实现节点之间的通信。
    (4)网络控制频繁,由于网络拓扑可能经常变化,移动Ad Hoc网络需要大量的网络控制信息来维护路由。
    (5)安全性与可靠性待加强,由于网络通过无线的方式传输,对比有线方式可靠性较差,且容易受到攻击与窃听。移动Ad Hoc网络中节点需要相互信任,因为数据可能会经过中间节点转发到目的节点,这也需要一定的机制检验节点的安全性。

    由于移动Ad Hoc网络的以上特点,传统的路由协议如RIP(Routing Information Protocol,路由信息协议)和OSPF(Open Shortest Path First,开放式最短路径优先协议)无法很好的在移动Ad Hoc网络上运行。目前常见的应用于移动Ad Hoc网络的路由 Routing)、DSR(Dynamic Source Routing)、AODV(Ad Hoc On-Demand Distance Vector)和ZRP(Zone Routing Protocol)等。本文将会使用AODV路由协议作为移动Ad Hoc网络的路由协议。

    AODV协议概述

    AODV路由协议是为Ad Hoc网络中的节点(移动设备)进行相互数据传输而设计的,它是一个按需路由协议,按需指节点不会存储网络中所有节点的路由信息,只有在需要向目的节点传输数据时,才会检查路由表,如果没有路由,则会向网络广播发送路由请求,这是路由发现过程,是为了来获取到目的节点的路由。
    路由请求(RREQ)、路由回复(RREP)、路由错误(RERR)和活跃路由检测(HELLO)是AODV路由协议定义的四种信息类型。这些信息用UDP进行传输,所以可以使用IP协议的地址,比如可以使用节点自身的IP地址作为RREQ信息中的源地址,可以使用255.255.255.255进行全域的广播。当源节点要与目的节点通信但双方还没有建立连接时,或者连接已经建立但路由过期或者失效,源节点向地址255.255.255.255发送RREQ消息寻求到目的节点的路由,收到RREQ消息的节点如果自身是目的节点,或者路由表中存在到目的节点的合法路由,则产生RREP消息单播到源节点,停止广播RREQ消息;如果收到RREQ消息的节点不是目的节点和有到目的节点路由的中间节点,则把RREQ消息继续广播到除了接收端外的所有接口。当网络检测到链路故障,会发送RERR给特定节点,通知其他节点更新路由。HELLO信息是RREP信息的一个特例,通过广播HELLO信息可以检测节点与其直连节点之间的连接情况。
    一旦源节点与目的节点成功建立连接,并且网络拓扑结构无变化和无链路故障发生,AODV路由协议就停止发挥作用。当源节点需要跟新目的节点进行通信时,重复发送RREQ的过程来发现到新目的节点的路由。
    路由循环(routing loops)和计数到无穷(count to infinity)是基于距离向量算法的路由协议都需要解决的问题,AODV路由协议采用递增的序列号来解决上述问题。RREQ、RREP、RERR信息报文中都含有序列号字段。使用序列号可以让节点分辨信息报文的新旧情况,方便节点用新的信息报文来更新路由表中由旧信息报文产生的路由信息。
    AODV路由协议支持在小规模的网络中运行,节点数目范围在数十到数千,而且要求相互通信的节点之间需要完全信任,因为数据在传输到目的节点的过程中可能会需要其他中间节点分析数据和转发。
    总的来说,AODV路由协议具有以下的优点:
    (1)不需要实时维护路由表,只有需要时才寻求路由和更新路由表。
    (2)支持组播,扩展性里良好
    (3)中间节点可以代替目的节点回复,减少了路由发现过程的延时,提高了收敛速度
    (4)所有节点和信息报文中都有序列号,避免了路由循环和计数到无穷的问题
    (5)被国内外广泛研究,有许多基于AODV路由协议的改进协议
    (6)但与此同时也存在一些缺点:
    (7)路由发现过程需要广播报文,对网络资源消耗较大
    (8)安全性问题,网络中每个节点必须互相信任,到目的节点的消息能被转发的中间节点明文接收,有一定的安全隐患

    AODV协议消息格式

    这一节将会介绍AODV路由协议所定义的三种消息–RREQ、RREP、REER的数据格式。HELLO消息为设定了特殊值的RREP消息,会在RREP的介绍中进行描述。最后还会对另外一种特殊的消息RREP-ACK做一个简要描述。

    RREQ消息格式

    当节点需要与某个目的节点传输数据,但没有目的节点的合法路由,可以向全网广播RREQ消息,向网络寻求到目的节点的路由,并且在约定的时间内等待携带有到目的节点路由信息的RREP消息回来,若规定时间内无收到RREP回复,则重发RREQ消息,直到达到最大发送次数。其他节点根据收到RREQ消息的接口建立从当前节点到源节点的反向路由。表1是RREQ的消息格式介绍,介绍了每个字段的名称与比特数。表2是对RREQ各个字段的解释。

    在这里插入图片描述

    在这里插入图片描述
    在这里插入图片描述

    RREP消息格式

    RREP消息用于单播回复RREQ消息,目的是为了告知发送RREQ消息的源节点到目的节点的路由。通过RREP消息可以建立从收到RREP消息的节点到RREP消息中的目的节点的正向路由,用于以后发送数据到目的节点。表3介绍了RREP的消息格式,给出了每个字段的位置与比特数。表4是对RREP部分字段的解释。

    在这里插入图片描述

    在这里插入图片描述
    Hello消息用于活跃节点向所有邻近节点广播自身的存在,当一个节点处于正在使用的路由中时,需要定时向邻近节点广播Hello消息,若邻近节点收到Hello消息,则更新路由表中对应节点的生存时间。
    Hello消息是一种特殊的RREP消息,其特殊之处在于为某些字段设置了特殊值,描述如表5
    在这里插入图片描述

    RERR消息格式

    当链路发生故障导致一个或者多个目的节点不可达时,RERR消息就会被发送,设计RERR消息是为了能通知网络中其他节点哪些目的节点因为故障导致不可访问,表6是RERR消息的格式,表7是对RERR消息中部分字段的解释。

    在这里插入图片描述
    在这里插入图片描述

    RREP-ACK消息格式

    RREP-ACK消息格式用于回复标志位A设为1的RREP消息。这经常发生于节点怀疑链路不可靠或者只能单向传播,RREP-ACK意义在于告知发送RREP的节点目的节点已经收到RREP消息,并且暗示了链路是双向传播和可靠的。
    表8是RREP-ACK消息格式的介绍,可以看到RREP-ACK消息中只有两个字段,较为简单。表9是对RREP-ACK消息中两个字段的解释。

    在这里插入图片描述

    AODV协议过程

    路由表和序列号

    每一个节点都需要维护自己的路由表,每一个路由表条目字段见表10。
    在这里插入图片描述

    每一个路由表条目负责到一个目的IP地址的路由,为了保证路由的及时更新,路由表需要对目的序列号进行维护,以便过期或受损的路由能及时被发现。
    每一个节点的路由表条目中都必须维护到目的节点的序列号,在三种情况下节点会更新路由表中的序列号:
    (1)目的IP地址为自己的路由表条目。节点发送RREQ消息(见2.3.2)前,自身序列号加一,以便通知其他节点路由需要重新搜索。另外在发送回复RREQ消息的RREP消息前,把自身序列号更新为旧的序列号和RREQ中目的序列号中两者的最大值。
    (2)节点收到AODV控制消息,即RREQ、RREP和RERR。若控制消息中的序列号比路由表中的大,即控制消息中的路由更新,此时用大的序列号更新路由表序列号;若两个序列号相等,但路由表中的跳数字段比控制消息中的跳数字段+1要大,即控制消息中的路由更短,此时用控制消息更新路由表中的相关字段,如下一跳,网络接口。
    (3)到目的节点的路径过期或者损坏。在没有收到下一节点回复的RREP-ACK或者链路层通知发生链路损坏时,需要把所有受链路影响不可达的路由表条目中的目的序列号都加一,并设置标志位不合法,这样可以避免后续该节点重新使用损坏的链路。

    发送RREQ消息

    源节点发送RREQ消息是为了向网络寻求到目的节点的路由。发送RREQ消息的过程见图 1。
    图1中可以看到,发送RREQ消息的起因是源节点无法找到到目的节点的合法路由,若存在到目的节点的合法路由,则整个过程结束。无合法路由时,源节点开启定时器,构建好RREQ消息后,向IP地址255.255.255.255发送RREQ消息,在发送RREQ消息后,在规定等待时间NET_TRAVERSAL_TIME毫秒内等待相关节点回复RREP消息,如果及时收到回复,则过程结束,如果超时仍未收到回复,则采用二进制指数退避的方法更新等待时间,重新开启定时器计时和发送RREQ消息,直到发送次数超过RREQ_RETRIES或者收到RREP回复,则结束,数据会被丢弃,并通知上层协议无法建立到目的节点的路由。

    RREQ消息的构建过程具体如下:RREQ消息中的目的IP地址字段为目的节点IP地址,如果源节点路由表中有目的节点的序列号(但已过期),则填进序列号字段,如果没有,则消息中的U标志位设为1。每个节点维护自己的唯一的RREQ ID,每次发送RREQ消息,则给RREQ ID加一,然后再填入RREQ中的字段。跳数字段设为0。

    在这里插入图片描述

    二进制指数退避方法设置等待时间的过程如下,第一次等待时间为NET_TRAVERSAL_TIME毫秒,第二次为NET_TRAVERSAL_TIME2毫秒,第三次为NET_TRAVERSAL_TIME2*2毫秒,每一次的等待时间都是上一次的两倍,这是为了避免网络堵塞。
    RREQ消息使用广播发送,所以可能会造成网络中存在大量的RREQ消息。为了控制RREQ消息的传输范围,我们可以修改IP头部中的TTL字段,避免每一次RREQ消息都被网络中所有节点接收。举个例子,一开始TTL设置为1,则RREQ消息只能发送到源节点的邻近节点,如果目的节点不在这些邻近节点中,则再次发送RREQ消息,此时TTL设置为2,则收到RREQ消息的节点就会更多,当最终源节点收到RREP回复时,可能有的节点还没有收到过源节点发送的RREQ消息,这样就有效的避免了大量的RREQ消息在网络中传播。

    处理和转发RREQ消息

    图2 是处理和转发RREQ消息的过程。当节点收到RREQ消息,它会判断在过去的PATH_DISCOVERY_TIME内是否有收到具有相同源IP地址和RREQ ID的RREQ消息,如果有,则丢弃新收到的RREQ消息,过程结束。这个判断的原因是节点可能从不同的邻接节点处收到相同的RREQ消息(因为RREQ消息为广播转发),而收到的第一个RREQ消息暗示着一条从源节点到该节点的最短路径,所以保留第一条RREQ消息,而后面相同的RREQ消息则丢弃,避免重复处理。
    下面讨论RREQ消息是第一次收到的情况。
    首先,搜索是否存在到源IP地址的反向路由,如果没有则建立反向路由。反向路由即当前节点到源IP地址所在的节点的路由,具体来说是当前节点知道通过哪个接口把数据转发到源节点。反向路由的建立过程和更新过程具体如下:
    (1)RREQ中的源节点序列号跟路由表中目的IP是源节点的表项的序列号进行比较,路由表中个更新为两者最大值
    (2)路由表对应表项合法目的序列号标志位设为1
    (3)路由表对应表项中的下一跳字段设为收到RREQ消息的上一个节点的IP地址,这个地址可以在IP头部获取到,一般跟RREQ消息中的源IP地址不同
    (4)路由表对应表项中的跳数字段从RREQ中复制

    更新或创建反向路由后,判断自身是否为目的节点或者有到目的节点的路由,如果是目的节点,则向源节点发送RREP消息,过程结束;如果有到目的节点的路由,则除了向源节点发送RREP消息外,可能还需要向目的节点发送免费RREP消息,具体过程见2.3.4 。
    如果节点不是目的节点和没有到目的节点的路由,而且IP头部中的TTL大于1,节点就把IP头部TTL减一,RREQ中的跳数加一,最后把RREQ消息广播到255.255.255.255地址,过程结束,若TTL等于1,则无需广播转发,直接丢弃RREQ消息。
    在这里插入图片描述

    产生RREP消息过程

    节点在两种情况下会产生RREP。
    第一种情况节点是RREQ指向的目的节点,如果自身维护的序列号加一后跟RREQ中的目的序列号相等,则加一,然后新的值复制进RREP消息中的目的序列号字段,并把跳数字段设为0.,最后把RREP通过反向路由单播发送消息回发送RREQ的源节点。
    第二种情况是RREQ消息中D标志位(Destination Only)为0,节点为中间节点,拥有到目的节点的路由,且路由活跃不过期,具体来说就是路由表中对应目的序列号大于等于RREQ中的序列号。节点把路由表中目的节点相关表项的目的序列号填进RREP的目的序列号字段中,并通过RREQ消息所在的IP头部更新到发送RREQ消息的源节点的路由,进而建立反向路由。RREP中的Hop Count字段设置为中间节点路由表中到目的节点的Hop Count字段,RREP中的lifetime字段设置为路由表中到目的节点的表项中的expire time减去当前时间,即该RREP在路由表表项过期后也同时过期,上述更新完RREP消息后,即可单播到发送RREQ消息的源节点。
    如果RREQ中的G标志位(免费路由标志)设为1,在发送RREP给源节点之后,还需要发送一个免费RREP(gratuitous RREP)到目的节点,免费RREP也是RREP消息,部分字段设置如下:
    (1)跳数字段设置为中间节点到源节点的跳数
    (2)目的IP地址字段设置为发送RREQ的源节点的IP地址
    (3)源IP地址字段设置为RREQ中的目的IP地址字段
    (4)生存时间字段设置为中间节点路由表中维护的到发送RREQ源节点的生存时间

    设置完成后免费RREP会根据路由表选择到目的节点的下一跳发送到目的节点。
    发送免费RREP消息的目的在于假设目的节点发送了一个RREQ到源节点,然后这个免费RREP就是中间节点代替源节点来回复这一不存在的RREQ消息,这样目的节点就可以建立到源节点的反向路由。如果不发送免费RREP消息,目的节点可能不知道RREQ消息的存在,也无法建立到源节点的路由,而只有中间节点具有到源节点的路由,使得后续目的节点与源节点的双向传输无法进行。

    接收和转发RREP消息过程

    图3是接收和转发RREP消息的过程。当一个节点收到RREP消息,它根据RREP中的目的IP地址字段判断自己是否为RREP消息目的节点(即发送RREQ的源节点),如果是RREP目的节点,则根据RREP的进入接口更新路由,建立从RREQ源节点到RREQ目的节点的正向路由,用于以后从源节点到RREQ目的节点的数据传输。如果节点不是RREP消息目的节点,则判断是否存在到RREQ目的节点的正向路由,如果不存在,则创建一个无序列号的到RREQ目的节点的路由,如果有,跟存在的正向路由做比较,及时调整和更新正向路由。以下几种情况所存正向路由会被更新:
    (1)路由表中对应表项的序列号标记为非法
    (2)RREP中的目的序列号比路由表中对应选项的合法的目的序列号要大
    (3)两个序列号相等,但路由表中序列号标记为不活跃
    (4)两个序列号相等,但RREP中的跳数表项加一小于路由表中对应表项的跳数

    到RREQ目的节点的路由表表项被创建或者更新后,该表项会被标记为活跃路由,目的序列号设为合法,下一跳设定为收到RREP消息的IP头部的IP地址,跳数设置为RREP中的跳数加一,过期时间设置为当前时间加上RREP消息中的生存时间字段,最后把序列号改为RREP消息中的目的序列号,随后RREP消息会根据之前已经建立好的反向路由发送到下一个节点,至此整个接收和转发RREP的过程结束。
    正向路由更新后,后续RREQ源节点可以通过每一个中间节点的正向路由与目的节点进行数据传输。

    在这里插入图片描述

    链路中可能存在一些单向链路,RREQ广播时无法发现,但RREP单播回复RREQ时,可能会因为单向链路导致传输失败,此时若不处理单向链路,源节点因为收不到RREP回复会多次发送RREQ,直到超时。所以如果链路中可能存在单向链路,下一跳节点可以采用发送RREP-ACK或者链路层确认机制来通知上一个节点链路失败,然后上一个节点会把下一跳节点拉入黑名单,在BLACKLIST_TIMEOUT时间段内忽视所有从下一跳发送来的RREQ消息,此时源节点因为收不到RREP消息,选择再次发送RREQ,因为是广播发送,所以上一个节点可能会从其他节点收到该RREQ消息,虽然路由距离可能比已经在黑名单的节点要长,但可以作为单向链路的一个替代。
    当需要下一跳节点发送RREP-ACK消息,RREP消息中A标志位必须设为1。

    Hello消息发送与处理过程

    当节点处于一条活跃路由中时,需要通过向邻近的节点广播Hello消息来通知邻近节点自身的存活。Hello消息发送过程见图4。首先节点判断自己是否处于活跃路由中,如果是,则开启定时器,每过HELLO_INTERVAL毫秒,节点检查自己过去HELLO_INTERVAL毫秒内是否送过广播(Hello消息或者RREQ),如果没有,则广播Hello消息。当节点判断自己不再处于活跃路由中,则可以结束Hello消息发送过程。
    节点可以通过监听在一段时间内是否收到邻近节点的消息来判断与邻近节点的连接是否正常。Hello消息处理过程见图5。如果在过去的DELETE_PERIOD时间内,已经从邻近节点收到Hello消息,然后接下来的ALLOWED_HELLO_LOSS * HELLO_INTERVAL内都没有从邻近节点收到任何消息,那么节点就会假设与该邻近节点的链路已断开,此时应该发送RERR消息,当节点收到Hello消息,且存在反向路由,则更新到发送Hello消息节点的路由的生存时间,并且用Hello中的目的序列号更新路由表中对应序列号,若不存在反向路由,则丢弃Hello消息。

    在这里插入图片描述
    在这里插入图片描述

    发送和处理RERR消息

    发送和处理RERR消息统称为路由修复过程,路由修复过程发生于检测到链路故障或者收到无法处理的数据时。
    RERR消息可以广播发送也可以单播发送,一个节点一秒不能发送超过RERR_RATELIMIT 条RERR。
    (1)生成RERR消息
    RERR消息可以广播发送也可以单播发送,一个节点一秒不能发送超过RERR_RATELIMIT 条RERR。
    节点在三种情况下会发送RERR消息,第一种是路由表中存在的活跃路由的下一跳节点发生链路故障;第二种是收到一个数据包指向某个目的节点,但路由表中无在修复的或活跃的指向目的节点的路由;第三种是从邻近节点收到RERR消息。
    下面分情况讨论RERR消息的产生。
    第一种情况中,把路由表中所有以故障节点为下一跳的条目中的目的IP地址放入RERR消息中的不可达目的IP地址字段或者额外的不可达目的IP地址字段,然后把路由表中对应目的序列号+1,并填入RERR消息中。
    第二种情况中,只有一个目的节点不可达,把它的目的IP地址复制入RERR消息中,路由表中序列号+1后也放入RERR消息中。
    第三种情况中,假设节点从邻近节点A收到RERR消息,则路由表中所有下一跳为A的条目中所有的目的IP地址都复制到新的RERR消息中,并且把路由表中对应目的序列号+1,并填入新RERR消息中。
    (2)更新自身路由表
    在发送RERR消息前需要更新路由表,除了对应目的序列号+1,还有以下操作,先把把指向RERR中目的节点的路由入口设为无效,随后路由表生存时间字段设置为当前时间+DELETE_PERIOD,最后在超过生存时间后才执行删除路由入口的操作。
    (3)决定转发节点
    在生成了RERR消息和更新自身路由表后,节点需要决定把RERR消息转发到哪些邻近节点。路由表中因为RERR消息导致无效的路由条目中,有一个上游节点列表(list of precursors),里面存放着使用这条路由的上游节点,其中有的是邻近节点,而这些节点就是RERR消息需要转发到的节点。
    (4)路由修复过程
    当链路发生故障,所有直接使用该链路的邻接点都产生一个RERR消息,然后这些节点会将RERR消息转发到其他节点,其他节点也一样处理,直到所有受影响的节点都收到RERR消息。无论是源节点还是中间节点,当链路故障后需要再次发送数据到受影响的目的节点,则需要再次发送RREQ消息来发现到目的节点的路由,在重新建立路由之前的数据都需要缓存起来。

    小结

    主要对AODV路由协议进行了详细的介绍,在对AODV协议做了一个总体概述后,详细的介绍了AODV的控制消息RREQ、RREP、RERR、RREP-ACK和Hello的消息格式和用途,并对部分消息字段做出了解释,接着分小结介绍了每一种控制消息的发送和处理过程。

    展开全文
  • RIP—路由信息协议 V1/V2/NG(IPV6) 使用范围:IGP 邻居间直接共享路由表;周期更新(30s)和触发更新,使用跳数作为度量; 基于UDP520端口工作;支持等开销负载均衡,默认4条,最大6条;IOS版本12.4以上...

    RIP-路由信息协议 V1/V2/NG(IPV6)

    – 使用范围:IGP
    – 邻居间直接共享路由表;周期更新(30s)和触发更新,使用跳数作为度量;
    – 基于UDP520端口工作;
    – 支持等开销负载均衡,默认4条,最大6条;
    – IOS版本12.4以上支持16条;管理距离120;
    – 周期更新的原因:

    1. 没有确认机制
    2. 没有保活机制

    1、V1和V2的区别:
    V1有类别,V2无类别;
    V1无法支持子网划分和汇总,支持连续子网;
    V2支持子网划分和CIDR,不支持超网;
    V1广播更新–255.255.255.255
    V2组播更新–224.0.0.9
    V2支持认证

    2、计时器:更新计时器,无效计时器,刷新计时器,抑制计时器,触发计时器。

    计时器 解释
    更新计时器 指运行RIP协议的路由器向所有接口广播自己的全部路由表的时间间隔。在CISCO的IOS软体中缺省时间是30s。为了避免在MA网络中由于系统时延引起的更新同步,在CISCO中的实际更新时间间隔为25.5-30s之间,即30s减去一个在4.5s内的随机值。
    无效计时器 针对路由表中的特定路由条目的计时器。路由器每收到一次路由条目就把无效计时器置0,也就是说路由条目每隔无效计时器规定的时间内必须收到该路由条目更新报文。如果没有收到相关条目的跟新报文那么无效计时器超时,路由器就认为该目的不可达,并向所有接口广播不可达的更新报文。无效计时器在IOS中缺省是180s。
    刷新计时器 指路由器条目的刷新时间。刷新存在2种意思:1、如果在刷新时间内没有收到更新报文,那么该目的的路由条目将被直接删除;2、在刷新时间内收到更新报文,那么该条目的路由条目的刷新计时器被刷新置0,CISCO中刷新计时器的缺省时间是240s,也就是比无效计时器多了60s。意味着在一条路由条目在180s内没有收到更新报文时,刷新计时器超时。路由条目中该路由被标志位x.x.x.x is possibly down,知道刷新新计时器也超时了该路由条目才删除。在RIP中真正删除路由条目的是刷新计时器超时。
    抑制计时器 如果一条路由更新的跳数大于路由表已经记录该路由的跳数,那么将会引起该路由进入长达180S的抑制计时器
    触发更新计时器 使用在触发更新中的一种计时器,触发更新计时器使用1-5s的随机值来避免触发更新风暴。

    3、防环机制:

    机制 解释
    水平分割 从此口进不从此口出:仅用于直线拓扑防环,用于减少MA网络的重复更新
    最大跳数 15跳,16跳不可达
    毒性逆转水平分割 发更新:当网络稳定之后存在断开网络 时,将立即产生跳数为16跳的毒性更新包并发送到邻居路由器来告知邻居该路径不可达,收到该毒性更新包的邻居将立即删除与之有关的路由条目,之后邻居打破水平分割机制将信息再次发出,来标记确认;分为主动发送和超时发送
    抑制计时器 路由器如果在相同的接口上收到某个路由条目的距离比原先收到的距离大,那么将启动一个抑制计时器。在抑制计时器的时间内该目的不可到达。抑制计时器主要是在RIP协议中用来防止路由环路,该计时器的原理是引用一个怀疑量,不管是真的还是假的消息,路由器先认为是假消息来避免路由环路。如果在抑制计时器超时时还能接受到该消息,那么这时路由器就认为条消息是真的。

    4、配置:
    RIPV1

    r1(config)#router rip   启动rip
    r1(config-router)#version 1     //选择版本1,若不选版本,默认为升级版本1;
    宣告:激活   路由
    r1(config-router)#network 12.0.0.0
    r1(config-router)#network 1.0.0.0
    

    RIPV2

    r1(config)#router rip
    r1(config-router)#version 2
    r1(config-router)#no auto-summary 
    r1(config-router)#network 12.0.0.0
    r1(config-router)#network 1.0.0.0
    

    5、扩展配置:
    V2的认证–用于邻居间身份的核实,保障更新的安全性

    r1(config)#key chain xx  //先定义秘钥
    r1(config-keychain)#key 1
    r1(config-keychain-key)#key-string cisco123
    r1(config-keychain-key)#exit
    r1(config-keychain)#exit
    r1(config)#interface s1/1  //再在连接邻居的接口上调用
    r1(config-if)#ip rip authentication key-chain xx
    r1(config-if)#ip rip authentication mode md5 
    

    V2的手工汇总:在更新源路由器上所有更新发出的接口上配置

    r2(config)#int s1/0         
    r2(config-if)#ip summary-address rip 2.2.2.0 255.255.254.0
    

    被动接口:只接收不发送路由协议信息,只能用于连接用户pc的接口,不得用于连接邻居的接口,否则邻居间无法收发路由信息
    只适用与组播或者广播,对单播不影响
    单播邻局----周期性的以单播向邻居发送信息,RIP不影响周期性的组播,OSPF EIGRP中会抑制组播更新。

    r1(config)#router rip  
    r1(config-router)#passive-interface fastEthernet 0/0
    r1(config-router)#neighbor 12.1.1.2
    

    加快收敛:修改计时器 30s更新 180s失效 180s抑制 240s刷新 20s睡眠时间
    按比例修改计时器可以加快收敛速度,但不易修改过小

    r1#show ip protocols 
    r1(config)#router rip
    r1(config-router)#timers basic 15 90 90 120 //全网设备修改一致
    

    缺省路由–边界路由器上配置命令后,将向内网所有设备发送缺省路由条目;之后本地需要管理员
    【1】手工配置静态缺省指向ISP

    r3(config)#router rip
    r3(config-router)#default-information originate 
    

    【2】手工汇总产生缺省路由(汇总产生缺省的路由器不会再发送其他明细路由)

    r1(config)#int s1/1
    r1(config-if)#ip summary-address rip 0.0.0.0 0.0.0.0
    

    【3】.重发布缺省

    【4】.network产生缺省路由(本地存在静态出接口写法的缺省路由,network通告换会不能做)

    r1(config)#router rip
    r1(config-router)#network 0.0.0.0
    

    可以把静态路由出接口写法network到路由协议中(只支持DV型协议)
    相当于

    r1(config)#ip route 0.0.0.0 0.0.0.0 null 0 
    

    然后network到协议中

    【5】.通告default-network定义成默认网络
    (存在主类路由,将该主类路由定义为default-network,然后通告进入RIP)

    r1(config)#ip default-network
    

    Network通告进入到路由协议中RIP不需要network就会产生缺省EIGRP需要network

    干涉选路 ---- 偏移列表
    1)修改AD值

    r1(config-router)#distance 121 //表示所有的路由AD值全部改为121
    

    还可以和单个邻居修改,后面跟更新源地址和反掩码
    2)修改metric值
    在控制层面流量进或出的接口上,人为的加大度量值,可以叠加,来干涉选路;

    r2(config)#access-list 1 permit 3.3.3.0   使用ACL抓取路由
    r2(config)#router rip
    r2(config-router)#offset-list  1    out    1         serial 1/0
                              //  ACL   方向  增加的度量  对应的接口
    

    过滤路由
    (使用分发列表distribute-list),分发列表自身没有过滤功能,依靠ACL或者prefix-list进行过滤(在使用扩展ACL时,可以使用源(过滤路由所在的路由器的更新源地址)匹配更新源(要过滤的路由),使目标定义过滤的路由,建议使用prefix-list)
    注意:使用扩展ACL可以使用源控制网络号,使用目标地址控制网络掩码,但在被distribute-list调用时不生效。
    在接口调用时in out方向都可以(但OSPF协议接口调用必须在in方向,重发布必须在out方向)
    可以在同种路由器协议传递过程中使用,重发布中使用,适用于DV型

    V1和V2兼容
    默认V1设备仅收发V1路由,V2设备仅收发V2路由;升级版本1设备,接收1/2,发1;
    无论设备此时使用什么版本,均可修改接口收发的版本标准

    r1(config)#interface s1/1
    r1(config-if)#ip rip receive version 1 2 
    r1(config-if)#ip rip send version  1 2 
    

    V2的设备被修改为发送版本1时,路由将和普通V1路由一致;
    V1的设备倍修改为发送版本2时,可以使用目标ip224.0.0.9来发路由,但依然不能携带掩码;

    V1的连续子网问题
    连续子网—母网相同,掩码一致;可以被汇总
    在V1协议中,若本地将发送给邻居的路由条目,与邻居间直连网段是连续子网,那么将携带主机位发送;邻居接收到后,将使用直连网段的掩码来作为这条路由的掩码;

    若不能修改接口地址,可以使用第二地址来实现连续子网;

    r1(config)#interface s1/1
    r1(config-if)#ip address 1.1.3.1 255.255.255.0 secondary 
    

    更新源检测
    若关闭了更新源检测,直连双方不在同一网段,无法递归路由,导致能学习的路由无法使用,可以在直连之间使用PPP链路(通过学习对方的主机路由来完成递归查找任务)

    r1(config)#router rip
    r1(config-router)#no validate-update-source
    

    开启V1触发更新
    (仅仅在非MA接口上生效,以太网接口(无此命令),FR物理接口,FR多点子接口不生效—有命令但是不生效)— 两端都要开启在低速丙炔点到点网络中有触发更新。

    r1(config)#int serial 1/0
    r1(config-if)#ip rip triggered
    

    创作者:Eric· Charles

    展开全文
  • 距离矢量路由协议主要会产生2个问题,无限计数和路由环路问题。当然也有相应的解决办法。1.无限计数问题及解决方法请看下列拓扑图:假设初始状态R0、R1、R2构成的网络已经收敛,当10.4.0.0这个网络出现问题时,R2...
  • RIP路由协议

    千次阅读 2013-06-20 22:31:36
    路由信息协议RIP RIP通过广播UDP报文来交换路由信息,提供跳跃计数(hop count)作为尺度来衡量路由距离,跳跃计数是一个包到达目标所必须经过的路由器的数目。RIP最多支持的跳数为15,即在源和目的网间所要经过...
  • DSDV路由协议

    万次阅读 2018-01-25 11:41:39
    一、移动自组织网络简单介绍 (1)移动自组织网络特点 ...拓扑结构动态变化没有主管理主机节点主机的电量有限简单拥有很小的存贮空间loop free很短的控制信息低...(2)路由协议 ① 路由表驱动 ② 混合
  • RIP路由协议的理解

    万次阅读 多人点赞 2016-11-26 01:42:29
    RIP路由协议的理解@(计算机网络)距离向量算法,实际中较少使用。 默认,RIP使用简单的度量:通往目的站点所需经过的链路数?。取值为1~15,数值16表示无穷大。 使用UDP的520端口发送和接收RIP分组。 RIP**每隔30秒以...
  • 自治系统内部的路由器通过域内路由协议彼此交换路由信息,一般域内路由协议分为距离向量协议和链路状态协议,前者以RIP代表,后者常用的有OSPF、IS-IS协议;自治系统边界路由器通过域间路由协议交换路由信息,目前...
  • 路由协议之OSPF

    千次阅读 多人点赞 2018-11-22 08:26:13
    目录 OSPF协议 OSPF的七种状态 OSPF的11种LSA Stub和Nssa OSPF中的防环机制 ...OSPF(Open Shortest Path First开放式最短路径优先)是一个内部网关协议IGP,用于在单一自治系统内决策路由。是对...
  • 一、DSDV路由协议 1、概念:一种目的节点序列机理矢量的路由算法。(Destination-Sequenced Distance Vector) 2、组成:该路由为先应式路由,采用分布式Bellan-Ford算法。  ① 先应式路由也称表驱动路由,在实际...
  • 计算机网络之路由协议详解

    万次阅读 2016-06-27 20:35:42
    因为笔者主要研究WMN,所以首先从WMN的路由协议说起,但是WMN路由协议很多都是借鉴有线网络的路由协议,所以目的在于让读者对于网络层的路由协议有个全局的认识。本篇虽然有一些专业术语,但基本都在上下文可以找到...
  • rip路由协议简介

    2019-01-08 00:08:53
    RIP 是最早的距离矢量路由协议。尽管 RIP 缺少许多更为高级的路由协议所具备的复杂功能,但其简单性和使用的广泛性使其具有很强的生命力。RIP 不是“即将被淘汰”的协议。实际上,现在已经出现了一种支持 IPv6 ...
  • 常见的动态路由协议可以分为“距离矢量路由协议”和“链路状态路由协议”。 其中距离矢量路由协议依据的是从源网络到目标网络所经过的路由器的个数来选择路由,典型的协议是“RIP”; 链路状态路由协议会综合考虑从...
  • RIP路由协议的汇总

    千次阅读 2019-06-23 11:25:38
    RIP路由协议的汇总 当网络中路由器的路由条目非常多时,可以通过路由汇总来减少路由条目数,加快收敛时间和增强网络稳定性。 路由汇总的原理是,同一个自然网段内的不通子网的路由在向外(其他网段)发送时聚合成一...
  • 静态路由主要有以下几种用途:在不会显著增长的小型网络中,使用静态路由便于维护路由表。静态路由可以路由到末节网络,或者从末节网络路由到外部(请参阅第 2 章)。使用单一默认路由。如果某个网络在路由表中找不...
  • RIP路由协议配置

    2019-08-20 00:48:55
    超时:180s未收到更新,标记为不可用(跳数 16),240 秒收不到,即刻从路由表中删除 跳数:最大为15 协议:UDP,端口号520 水平分割:即从一个接口收到路由更新,不会再从这个接口将收到的路由发回去; 认证:V1不...
  • 动态路由RIP协议!

    千次阅读 2021-04-14 19:54:21
    动态路由RIP什么是路由路由协议的分类动态路由协议的分类距离矢量路由协议选择的特点RIP的度量值RIP概述RIPV1报文格式RIPV2报文格式RIPV2相较于RIPV1的改进下一跳距离矢量路由协议的防环机制 什么是路由 路由协议的...
  • 动态路由协议BGP介绍

    千次阅读 2019-07-29 17:01:28
    文章目录BGP介绍BGP相关术语BGP报文介绍BGP五种报文BGP报文结构路由属性分类:BGP常见路由属性Origin属性Next_Hop属性AS_Path属性Local_Pre属性Community属性MED属性BGP路由黑洞产生原因BGP路由反射器以及联盟BGP...
  • 路由协议(RIP、OSPF协议)

    千次阅读 2020-03-11 15:22:39
    1、路由协议简介 在互联网中,一个自治系统(AS)是一个有权自主地决定在本系统中应采用何种路由协议的小型单位。这个网络单位可以是一个简单的网络也可以是一个由一或多个普通的网络管理员来控制的网络群体,它是一...
  • 华为rip路由协议

    2016-06-27 11:07:29
    1.RIP(Routing information Protocol)是一种用于自治系统AS(AUtonomous System)内部的一种动态路由协议。它是一种较为简单的内部网关协议(interior Gageway protocol,IGP) 2.RIP是一种基于距离矢量(Distance-...
  • 计算机网络——5.路由协议

    千次阅读 2016-03-03 18:07:28
    本文描述了路由技术的原理,包括路由协议的分类、静态路由、RIP、OSPF、EIGRP的工作原理,路由技术是网络技术的重要组成部分。
  • 3.2 Ad Hoc 网络路由协议

    千次阅读 2020-04-21 23:34:46
    Ad Hoc 网络路由协议 Ad Hoc 网络路由面临的问题 在设计Ad Hoc 网络路由协议时,我们首先要明确可能面临的问题: (1)路由信息不易获得:定期交换路由信息的开销大、网络资源有限,并且必须被所有节点共享、节点...
  • 前一篇简单阐述了静态路由中的相关知识(传送门) 本篇就整理一下动态路由的相关内容 动态路由基本概念 动态路由主要是基于以下两点 能否设计一种机制使各个路由器根据自己静态的不完整的信息“学习”出比较复杂...
  • 路由协议(routing protocol) 用于路由器选择路径和管理路由表 路由器路由的方式 一旦选择了一条路径后,路由器将路由被路由协议,它是数据包的运输工具 路由协议:RIP,IGRP,EIGRP 被路由协议,可路由...
  •   RIP协议是基于Bellham-Ford(距离矢量)算法,即贝尔曼算法,该路由算法可以根据路径参数,也就是度量值的好坏来生成路由条目。 如图1所示,如果收到邻居给的路由,若本地没有,则接收。 图1 2....
  • 实验一:RIP动态路由协议实验

    千次阅读 2019-09-22 16:14:31
    实验报告一:RIP动态路由协议实验 实验拓扑: Requirment: 某网络整体结构如果所示,在Router1上有3个回环口,IP地址如图,Router3连接两台主机,现要求通过使用路由协议实现全网互联。 在各路由器上配置静态路由...
  • isis路由协议

    千次阅读 2016-06-27 10:50:02
    R2(config-router)#log-adjacency-changes all(显示邻居变化信息)需要手工做,其它路由协议默认就有这一命令 R1#debug isis adj-pack R1#clear clns * R1#clear clns neighbors  R1#clear ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 94,341
精华内容 37,736
关键字:

删除路由协议