精华内容
下载资源
问答
  • jquery如何判断数组是否包含指定元素?在jquery中,可以使用$.inArray()函数来判断数组是否包含指定元素。利用$.inArray("元素(字符串)",数组名称) 来进行判断,当存在指定元素(字符串)时,返回该元素在数组的下标,...

    5e20049e57de1141.jpg

    jquery如何判断数组是否包含指定元素?

    在jquery中,可以使用$.inArray()函数来判断数组是否包含指定元素。利用$.inArray("元素(字符串)",数组名称) 来进行判断,当存在指定元素(字符串)时,返回该元素在数组的下标,不存在时返回 -1。

    示例:

    jquery判断元素是否存在于数组中

    //参数第一个为数组,第二个为需要判断是否存在于数组中的值

    function isInArray(arr,val){

    var str = ","+arr.join(",")+",";

    if(str.indexOf(","+val+",") != "-1"){

    //该数存在于数组中

    arr.splice($.inArray(val,arr),1); //把该数从数组中删除

    console.log(arr);

    }else{

    //该数不存在于数组中

    console.log("不存在");

    }

    }

    var arr = [1,28,60,80,6];

    isInArray(arr,28);//存在,删除元素28

    isInArray(arr,18);//不存在,提示“不存在”

    效果图:

    1578131067214989.png

    $.inArray() 函数

    $.inArray() 函数用于在数组中查找指定值,并返回它的索引值(如果没有找到,则返回-1)

    提示:源数组不会受到影响,过滤结果只反映在返回的结果数组中。

    语法:$.inArray( value, array [, fromIndex ] )

    参数:value 任意类型 用于查找的值。

    array Array类型 指定被查找的数组。

    fromIndex 可选。Number类型 指定从数组的指定索引位置开始查找,默认为 0

    更多web前端开发知识,请查阅 HTML中文网 !!

    展开全文
  • 主要介绍了JS判断数组是否包含某元素实现方法汇总,文中通过示例代码介绍的非常详细,对大家的学习或者工作具有一定的参考学习价值,需要的朋友可以参考下
  • 子程序 子程序_判断数组是否包含某元素, 逻辑型 .参数 参_数组, 文本型, 数组 .参数 参_要查找的元素, 文本型 .局部变量 i, 整数型 .计次循环首 (取数组成员数 (参_数组), i) .如果真 (参_要查找的元素 = 参_数组...
    .版本 2
    
    .子程序 子程序_判断数组是否包含某元素, 逻辑型
    .参数 参_数组, 文本型, 数组
    .参数 参_要查找的元素, 文本型
    .局部变量 i, 整数型
    
    .计次循环首 (取数组成员数 (参_数组), i)
        .如果真 (参_要查找的元素 = 参_数组 [i])
            返回 ()
        .如果真结束
    
    .计次循环尾 ()
    返回 ()
    
    展开全文
  • 现在前端开发经常需要从api中获取返回的数组, 也许是array,也许是json, 不管是什么,都需要对返回的数据进行再处理, 其中一个重要且经常用到的操作, 就是“判断重复”及“重复的次数” 例如, 返回一个班级的...

    现在前端开发经常需要从api中获取返回的数组,

    也许是array,也许是json,

    不管是什么,都需要对返回的数据进行再处理,

    其中一个重要且经常用到的操作,

    就是“判断重复”及“重复的次数”

    例如,

    返回一个班级的json,

    要求判断有多少个孩子的年龄是相同的?

    这种对数据的操作很常见的。。

    现在我们先看代码:

    看不清,不要紧,我大概讲一下,很简单的。

    首先它的结构是这样的:

    (1),声明一个新的数组newArr,一个临时变量temp,一个计数器count;

    (2),一个二重嵌套的for循环;

    (3),一个if判断;

    (4),一个return方法;

    那么,在运行的时候呢,

    arrCheck这个函数的参数arr,就是我们要传入的数组[1,2,3,3,4]了;

    首先声明一个新数组newArr=[],一个temp,一个计数器;

    然后进入第一重for循环,

    在这里把数组[1,2,3,3,4]的每项通过

    temp = arr[i];

    赋值给temp,

    然后在第二重for循环里,用if(arr[j] == temp)来进行比较,

    可能有些同学对于for for嵌套循环有点晕,其实这个很简单的,

    就是外层for循环数组一个数,

    内层for循环整个数组一遍,

    看上面的代码示例,可以很清楚的看到,

    i循环一个数字,j把整个数组循环了一遍;

    那就意味着,数组有多长,

    就会用for for嵌套把整个数组循环多少次

    那么回来这个判断重复次数的例子中来,

    我们可以通过for for循环中的if(arr[j] == temp)

    把整个数组中的每一项,都和整个数组进行一次比较,

    如果相等,就把count++,

    然后执行arr[j]=-1,为什么要这么做呢?

    因为这样就可以不再比较,已经确定重复的数组项了。

    例如,arr=[1,2,3,3,4]

    arr[2]是3,

    arr[3]也是3

    那么3已经确定是重复并计数过的了,就不再比较它了。

    然后 if(temp != -1),

    这个就比较好理解了,它只是一个筛选判断而已,

    用来不显示被值为-1的值。

    大家运行下示例程序,就明白了。

    最后就是返回已经筛选完成的新数组 newArr。

    这个小例子的重点有三个:

    1,通过嵌套for循环,把数组的每一项,跟整个数组中的所有项,比较一遍;

    2,通过if判断,如果有相等的项,count++,并把相等的项置为-1,这样可以判断等于-1的就是重复的,就不再加入新数组了;

    3,用if判断!=-1,决定是否加入新数组中,返回。

    完了,

    很简单吧,

    还看不懂的同学,可以用console.log,一步一步的打印结果,帮助理解。

    展开全文
  • 目前国企等一些单位仍然...下面是ie8浏览器,判断数组某元素是否存在,和删除数组中指定元素的一段javascript脚本,正好今天做业务代码用到了,顺便做一个简单的笔记,方便后续查找,也希望能帮助有需要的js新手。

    目前国企等一些单位仍然使用的xp等历史系统,就不得不面对ie8的对各种脚本兼容性问题了。下面是在数组中判断某元素是否存在和删除数组中指定元素做一个简单的笔记,方便后续查找,也希望能帮助有需要的js新手。

    1、判断数组中是否存在某个元素 

    <script>
        // 给数组添加属性regStr; fromCharCode() 函数的功能是将Unicode编码转换为字母
        // 关于此函数的更多介绍: https://www.runoob.com/jsref/jsref-fromcharcode.html
        Array.prototype.regStr = String.fromCharCode(2);
    
        // 给数组添加函数isExist
        Array.prototype.isExist= function (e) {
    	    var r = new RegExp(this.regStr + e + this.regStr);
    	    return (r.test(this.regStr + this.join(this.regStr) + this.regStr));
        };
    
        // 测试方法
        function testMain(){
            // 声明数组并添加元素
            var userIdArr=[];
            userIdArr.push(1);
            userIdArr.push(2);
            userIdArr.push(3);
            
            // 输出结果为 true
            console.info(userIdArr.isExist(2));
        }
    
    </script>

    2、删除数组中指定的元素

    <script>
        // 给数组添加indexOf函数,功能是返回元素所在的下标;正常情况下Array自带此函数,但ie8须显式重写
        Array.prototype.indexOf = function(val) {
            for (var i = 0; i < this.length; i++) {
                if (this[i] == val) return i;
            }
            return -1;
        };
        
        // 给数组添加remove 函数,即删除指定元素。 
        Array.prototype.remove = function(val) {
            var index = this.indexOf(val);
            if (index > -1) {
                this.splice(index, 1);
            }
        };
    
        // 测试
        function testMain(){
            // 声明数组并添加元素
            var userIdArr=[];
            userIdArr.push(1);
            userIdArr.push(2);
            userIdArr.push(3);
            
            // 调用函数删除指定元素
            userIdArr.remove(2);
            
            // 将数组转换为字符串输出
            console.info(userIdArr.toString());
        }
    
    </script>

     

     

    展开全文
  • 有两种方法可以判断数组是否包含某元素: 方法1, 将数组转换为list,然后使用list的contains方法来判断: Arrays.asList(...).contains(...) 方法2,遍历数组判断: public static T> boolean contains( ...
  • js中 判断数组 是否包含某元素

    千次阅读 2019-04-25 10:32:37
    四个API ,判断包含某元素: 1.Array.indexOf() --推荐,Array.indexOf("x")== -1,则不包含,不返回-1 则包含 2.Array.find() 3.Array.findIndex() 4.for 或 foreach 循环,然后 if 判断 1.Array.indexOf() var ...
  • 判断数组中是否包含某元素: $(function () {  var arr = [ 4, "Pete", 8, "John" ]; alert(jQuery.inArray( "xx", arr )); //如果包含则返回该元素在数组中的索引,如果不包含则返回-1 })
  • var testarr=[{"a":"0"},{"b":"1"},{"c":"2"}]; alert($.inArray({"a":"0"},testarr)); //总是返回-1
  • 判断数组中的元素是否连续

    千次阅读 2018-07-20 00:14:32
    如果一个数组包含n个元素,并且该数组中元素是连续的,那么它一定具有“数组中最大值元素与最小值元素之差为n-1”的性质。如果这些元素中包含0这样的通配数字,并且保证数组中的元素是连续的,那么数组中的非零最大...
  • JS数组判断是否包含某元素
  • // 判断数组包含element元素 Array.prototype.contains = function (element) { for (var i = 0; i < this.length; i++) { if (this[i] == element) { return true; } } ...
  • 这个是整理过的:... 方法一:arr.indexOf(某元素):未找到则返回 -1。 实际用法:if(arr.indexOf(某元素) > -1){//则包含元素} 例: var fruits = ["Banana", "Orange", "Apple", "Mango"]; v...
  • 主要介绍了python实现判断数组是否包含指定元素的方法,涉及Python中in的使用技巧,具有一定参考借鉴价值,需要的朋友可以参考下
  • 简述 js判断数组中是否包含某元素的方法 1.array.indexOf(item,start):元素在数组中的位置,如果没与搜索到则返回 -1 参数 描述 item 必须。查找的元素。 start 可选的整数参数。规定在数组中开始检索的...
  • java如何判断数组中是否包含某元素

    千次阅读 2015-06-03 09:28:35
    有两种方法可以判断数组是否包含元素: 方法1, 将数组转换为list,然后使用list的contains方法来判断: Arrays.asList(...).contains(...) 方法2,遍历数组判断: public static T> boolean contains( ...
  • jQuery判断数组是否包含指定元素 /** * 使用jquery的inArray方法判断元素是否存在于数组中 * @param {Object} arr 数组 * @param {Object} value 元素值 */ var index = $.inArray(value,arr);//返回下标值,...
  • JS 判断数组是否包含某个元素方法集合 文章目录JS 判断数组是否包含某个元素方法集合1、JavaScript indexOf() 方法2、jQuery.inArray()方法3、JavaScript find() 方法4、JavaScript findIndex() 方法5、for 循环和 ...
  • iOS判断数组是否包含某个元素

    千次阅读 2019-09-29 20:48:34
    NSString *str = @"数组"; NSArray *array=@[@"who",@"数组",@"array",@"3"]; BOOL isbool = [array containsObject: str]; NSLog(@"i = %i",isbool);...数组包含某个元素 i=0;数组不包含某个元素 ...
  • 判断数组是否包含某个元素

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 373,705
精华内容 149,482
关键字:

判断数组包含某元素