精华内容
下载资源
问答
  • 2019-02-26 10:48:04
    routeOS设置端口映射
    设置端口映射 :

    ip->Firewall-> Destination NAT -> +

    General 页

    Src. address 0.0.0.0/0
    src. port
    interfalce 外网
    Dst.address 0.0.0.0/32(区别于其他曾经发过的设置)
    Dst.port 映射端口
    protocol tcp

    ACTION 页:
    Action nat
    to Dst.address 内网映射IP -内网映射IP
    to Dst.port 映射端口


    来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/10294527/viewspace-124005/,如需转载,请注明出处,否则将追究法律责任。

    转载于:http://blog.itpub.net/10294527/viewspace-124005/

    更多相关内容
  • 今天早上一来,有同事求救,说要发布一台服务器供第三方联调测试,需要在路由器上做端口映射。现在的情况是,本来昨天在路由器上都做好了设置,第三方公司也能访问我们的服务,但今天一来,人家说服务访问不了

      几年前拿的网络工程师证,但后来一直从事软件开发,思科的好多命令都忘了。今天早上一来,有同事求救,说要发布一台服务器供第三方做联调测试,需要在路由器上做端口映射。

      现在的情况是,本来昨天在路由器上都做好了设置,第三方公司也能访问我们的服务,但今天一来,人家说服务访问不了。原来是ADSL动态IP地址惹的祸,因为路由器今天重新从ISP哪里获取了一个新的IP地址。路由器的公网IP地址都变了,对应的nat策略也就失效了。

      我看了同事在路由器上做的nat策略,仔细分析了一下,他使用的命令格式为:

    ip nat inside source static protocol local-address local-port global-address global-port [permit-inside]

    参数说明:

    • local-address:内部本地地址。是主机在网络内部的IP地址,一般是未注册的私有地址。
    • global-address:内部全局地址。是内部主机在外部网络表现出的地址,一般是注册的合法公网IP地址。
    • protocol:协议。可以是 TCP 或 UDP。
    • local-port:本地地址的服务端口号。
    • global-port:全局地址的服务端口号,它可以和local-port不同。
    • permit-inside:允许内部用户使用全局地址访问本地主机。

      按道理,按照上述命令格式来配置端口转换,是没有错误的。但是同事忽略了一点,我们的路由器是使用ADSL拨号的,IP地址随时都会发生改变,配置时,他将global-address写死了一个固定IP地址,这也就导致了路由器重新获取IP地址后端口转换失效,贴出同事的nat配置:

    ip nat inside source static tcp 10.10.49.180 80 14.153.20.47 10000

    要解决这个问题,分两步:

    1、确定路由器上的wan口名称

    R2800-zuoyue-jifang# show running-config
     
    interface Loopback0 
     ip address 10.10.100.2 255.255.255.255 
     ip ospf network point-to-point 
    ! 
    interface GigabitEthernet0/0 
     no ip address 
     ip nat enable 
     ip virtual-reassembly 
     duplex auto 
     speed auto 
     pppoe enable group global 
     pppoe-client dial-pool-number 1 
    ! 
    interface GigabitEthernet0/1 
     ip address 10.10.39.10 255.255.255.248 
     ip access-group qq in 
     ip nat inside 
     ip nat enable 
     ip virtual-reassembly 
     duplex auto 
     speed auto 
    ! 
    interface Dialer100
     mtu 1492 
     ip address negotiated 
     ip nat outside 
     ip virtual-reassembly 
     encapsulation ppp 
     dialer pool 1 
     dialer-group 1 
     ppp authentication pap callin 
     ppp pap sent-username ****** ****** 

    找到了wan口名称是“interface Dialer100”。

    2、global-address不在写成固定ip地址,以wan口名代替

    ip nat inside source static tcp 10.10.49.180 80 interface Dialer100 10000

    这样就不怕路由器的IP地址经常改变了,nat策略也一直生效。

    最后,提供在路由器上不能清除nat测试的方法,例如:

    no ip nat inside source static tcp 10.10.49.180 80 interface Dialer100 10000

    会报“%Static entry in use, cannot remove”错误,解决的方法是:

    R2800-zuoyue-jifang# clear ip nat translation *

    然后再执行删除。不过该操作会造成整个网络短暂掉线。

    展开全文
  • 局域网动态IP端口映射.pdf
  • 路由器怎么映射?路由器一开始分配的是动态公网IP地址,或甚至是内网IP地址时该怎么映射?今天我们就来看看路由器端口映射动态公网和内网IP的教程,需要的朋友可以参考下
  • cpe动态ip做端口映射方案

    千次阅读 2020-09-27 11:20:55
    cpe介绍 无线cpe,实际是一种接收移动信号并以无线WIFI信号转发出来的移动信号接入设备。 应用场景 ...运用openvpn组建局域网,设定固定虚拟ip,然后做端口映射方案,解决cpe动态ip通讯问题。 ...

    cpe介绍

    无线cpe,实际是一种接收移动信号并以无线WIFI信号转发出来的移动信号接入设备。

    应用场景

    机场施工难度大,费用高,走有线通讯方案困难,因此,用5G cpe插流量卡,解决有线通讯短板。

    问题

    管理后台有ros websocket数据通讯以及rtsp流地址播放视频的需求,但是这两个需求都要求使用静态ip,与cpe每次重启随机分配的动态ip冲突

    解决办法

    运用VPN组建局域网,设定固定虚拟ip,然后做端口映射方案,解决cpe动态ip通讯问题。

    在这里插入图片描述
    在这里插入图片描述

    展开全文
  • ROS ADSL动态IP端口映射另类做法已带贴图
  • ROS动态IP端口映射

    千次阅读 2019-05-29 15:09:53
    废话不多说了,下面主要讲讲RouterOS解决ADSL动态IP端口映射和显示IP问题。 环境:ADSL动态IP,ROS网关10.0.0.1,内网IP:10.0.0.9,端口:443,主要用于网站web,https访问(NAS建的Web Station) 需求:1、外网...

    年前升级200M电信光线后,一直对路由器不满意,正好回购公司淘汰的Dell OP7010,再买个I350四网口千兆网卡,ESXi开启搞起。Dell是Q77系列的主板+I5 3470的cpu,装ESXi6.x,支持VT-D,可以使用网卡直通,再装上ROS6.x和Nas黑群晖,开启ros和nas后,空载的时候使用功率计检测在30w左右。很满意了,毕竟是台式的CPU。

    废话不多说了,下面主要讲讲RouterOS解决ADSL动态IP端口映射和显示IP问题。

    环境:ADSL动态IP,ROS网关10.0.0.1,内网IP:10.0.0.9,端口:443,主要用于网站web,https访问(NAS建的Web Station)

    需求:1、外网直接访问域名https://www.myxzy.com(已绑定ADSL获取的IP地址,本站没开HTTPS访问也没做绑定,这边只是做演示),可以直接打开网站

    2、内网直接访问https://www.myxzy.com,可以直接打开网站

    3、可以正常获取外网客户端访问IP

     

    详细图文操作:

    1、端口映射

    使用Winbox打开ROS路由器,打开IP --> Firewall --> NAT,创建一条dstnat策略,其中“Chain”设为dstnat,“Dst.Address”设为ADSL获取到的公网IP地址,“Protocol”设为6(tcp),“Dst.Port”设为443,“Action”设为dst-nat,“To Address”设为10.0.0.9,“To Ports”设为443。

    右击该条策略,选择“comment”,输入“443”,名字可以随便输,但是和脚本中用到的要一样的。

    端口映射已经可以了,外部网路可以通过公网IP/域名访问了内网10.0.0.9这台的网站了,但是内网用户不能通过公网IP/域名访问了。

    1.jpg

    2.jpg

     

    2、内网和外网访问以及IP显示问题

    5.jpg

    由于使用的是ADSL PPPoE拨号动态获取IP地址,所以会有一条srcnat策略,Action设置为“masquerade”,masquerade是srcnat的一个特例,主要用在无固定ip网关的情况下,比如adsl拨号等。由于NAT方设置较masquerade复杂,加上现在大量的ROS教程都是以masquerade方式共享上网,所以目前在用的ROS大多数采用masquerade设置共享。如果不进行设置客户端显示IP都会是网关地址。

    修改这条srcnat策略,“Out.Interface”设为!LAN,这边LAN-bridge1是桥接了所有内网网口。

    6.jpg

    创建一条srcnat策略,其中“Chain”设为srcnat,“Src.Address”设为10.0.0.0/23(根据子网掩码设置),“Action”设为masquerade

    8.jpg

    9.jpg

     

    3、脚本更新公网IP地址

    由于是动态IP地址,每次会有不一样的,所以这边需要添加一个脚本用于更新公网IP地址。

    system --> script,新建一个脚本,ADSL-PPPoE是创建的PPPoE拨号的名称,443是策略的名称

     

    :global ipaddr [/ip address get [/ip address find interface=ADSL-PPPoE] address]
    :set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
    :global oldip [/ip firewall nat get [/ip firewall nat find comment="443"] dst-address]
    :if ($ipaddr != $oldip) do={
    :log info [/ip firewall nat set [/ip firewall nat find comment="443"] dst-address=$ipaddr]
    }

     

    10.jpg

    system --> schedule,新建一个计划,Interval是间隔时间,其中的443-ip是上面创建的脚本名称

    11.jpg

    到此端口映射已经完成,内网外网都可以访问。

     

    4、回流设置(建议不用设置该策略)

    创建一条srcnat策略,其中“Chain”设为srcnat,“Src.Address”设为10.0.0.0/24,“Dst.Address”设为10.0.0.9,“Protocol”设为6(tcp),“Dst.Port”设为443,“Action”设为src-nat,“To Address”设为ADSL获取到的公网IP地址,“To Ports”设为443。

    右击该条策略,选择“comment”,输入“443_2”,名字可以随便输,但是和脚本中用到的要一样的。

    回流设置好了,内网用户可以通过公网IP/域名访问了内网10.0.0.9这台的网站了。

    3.jpg

    4.jpg

    回流,就是将内网源地址为网段的所有机器对所有目标地址的需求全都进行源地址转换为外网IP。所有从外网回来的数据通过外网IP再回传到内网的机器,这样就保证了内网上网正常,但这样的效率下降到原来的50%,对于masquerade来共享上网时,内网访问内网服务器显示的IP是网关地址还是外网IP是一样的,所以明显不合算。

    展开全文
  • ROS的ADSL多线端口映射脚本 ROS 端口映射 多线映射。。。。。。。。。。。。
  • 虚拟机动态获取IP,配置静态IP,进行端口映射往往是很多初学linux同事的困惑,今天我整理了一下。因为时间有限,不能详细描述,贴了一些设置时重要的图,还是比较清楚的,希望对大家有帮助!
  • 可以设置动态ADSL动态IP端口映射 我成功了
  • D-Link防火墙端口映射(动态IP&静态IP).pdf
  • :global newipaddress :global lodipaddress :set newipaddress [/ip address get [/ip address find dynamic=yes interface="pppoe-out1"] address] :set newipaddress [:pick $newipaddress 0 ([:len $newipaddres...
  • 动态和静态端口映射

    千次阅读 2017-10-25 10:57:16
    动态端口映射: 内网中的一台电脑要访问新浪网,会向NAT网关发送数据包,包头中包括对方(就是新浪网)IP、端口和本机IP、端口,NAT网关会把本机IP、端口替换成自己的公网IP、一个未使用的端口,并且会记下这个映射...
  • 虚拟机做端口映射

    千次阅读 2021-05-03 16:46:02
    用虚拟机映射端口充当服务器。
  • 端口映射动态端口静态端口

    千次阅读 2019-09-02 10:00:26
    端口映射动态和静态之分。 映射端口有两个含义 1、同端口映射,指通过端口转换来获取公网ip地址的端口。 2、指端口映射出来的端口,例如把电脑A的80端口映射到路由器公网ip上的80端口,那么路由器上的80端口就...
  • 一种应用于物联网的内网服务器端口映射与网关动态IP地址解析方法,陈枫,尹长川,本文基于动态域名服务技术和端口映射技术,提出了一种应用于物联网数据采集系统中实现内网服务器端口映射和网关动态IP地址解析的�
  • 准备花生壳映射条件 1.引入库 2.读入数据 总结 1.前言 上一章介绍了局域网内https服务端配置与客户端联合使用,传送门链接: (SVN笔记)https内网服务端配置+本机客户端使用 CSDN链接:...
  • 端口映射--自己主机服务器

    万次阅读 2019-06-06 20:51:33
    今天下午,想起之前想要连另一个局域网的Oracle服务器,就试着去,结果找到了端口映射这个概念,并实现了: 百科: 端口映射  首先,简单告诉大家,什么叫端口映射:  端口映射又叫端口转发,又叫虚拟...
  • 华为USG设备做端口映射

    万次阅读 2019-12-10 10:55:18
    端口映射 端口映射是NAT的一种,功能是把在公网的地址转翻译...端口映射动态和静态之分。 通过管理地址(10.0.0.2:8443)登录web管理界面 防火墙->NAT->目的NAT 选择虚拟服务器列表->新建 117....
  • 外网访问内网数据库-P2P穿透 ...如内网无公网IP,实现外网访问内网数据库,使用nat123方案有:改变访问端口的端口映射、不改变访问端口的全端口映射P2P、不变访问端口的全端口映射转发P2P。以ORACLE、MS
  • 什么是端口映射 在网络技术中,端口(Port)有好几种意思。集线器、交换机、路由器的端口指的是连接其他网络设备的接口,如RJ-45端口、Serial端口等。我们这里所说的端口,不是计算机硬件的I/O端口,而是软件形式上的...
  • 目录一、实验需求1.1需求一1.2需求二1.3需求三二、...●要求R3通过DHCP协议向PC1、PC2、PC3、PC4分配ip地址。 1.2需求二 ●要求PC1、PC2、PC3、PC4通过Easyip可以ping通PC5。 1.3需求三 ●要求云服务器通过“NAT server
  • 端口映射工具

    2015-10-30 09:14:40
    端口映射是NAT的一种,功能是把在公网的地址转翻译成私有地址, 采用路由方式的ADSL宽带路由器拥有一个动态或固定的公网IP,ADSL直接接在HUB或交换机上,所有的电脑共享上网。看到还是有好多朋友不能开自己的服务器...
  • nat123是集合80端口映射动态域名解析、域名解析管理的开放自由的平台,可轻松管理域名解析、发布网站、访问内网应用,支持任何网络。 软件功能特色: 支持开机运行,自动登录,精简模式登录,代理上网,后台服务...
  • 【基于公网IP映射端口】:我们SIM868模块调试GPRS数据传输功能的时候,往往会利用公网IP地址进行数据传输,大致步骤是: 1)先查询公网IP(百度查IP或者通过路由器查询WAN口IP); 2)再查询自己电脑内网IP(方法...
  • SSH端口转发笔记(ipv6 与 端口映射)

    千次阅读 2021-05-11 22:05:59
    端口转发概念端口转发或隧道,是一种通过SSH转发本来不安全的TCP通信的安全保护罩。您可以保护例如POP3,SMTP和HTTP连接,否则可能是不安全的。网络上什么人都有!有两种类型的端口转发:本地和远程转发。它们也分别...
  • at123是集合80端口映射动态域名解析、域名解析管理的开放自由的平台,可轻松管理域名解析、发布网站、访问内网应用,支持任何网络。 nat123动态域名解析P2P全端口映射软件功能特色: 支持开机运行,自动登录,...
  • 络地址及端口转换、动态网络地址及端口转换、端口映射等。NAT 常用于私有地址域与公用 地址域的转换以解决IP 地址匮乏问题。在防火墙上实现NAT 后,可以隐藏受保护网络的内 部拓扑结构,在一定程度上提高网络的安全...
  • 内网端口映射

    千次阅读 2021-06-18 14:21:42
    这里写自定义目录标题端口映射 端口映射 我们首先使用路由器通过的内外网映射实现功能。首先通过终端浏览器连接到路由器管理界面,一般路由器的登录地址为:192.168.0.1或者192.168.1.1,具体地址一般路由器机盒上会...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 81,107
精华内容 32,442
关键字:

动态ip做端口映射