精华内容
下载资源
问答
  • 动态路由 OSPF配置

    2020-02-05 11:04:23
    (目的:路由器上分别配置动态路由 OSPF ,对各段路径划分不同的网段并通告全网,使各网段能正常通信) 根据拓扑图中给定的网段配置 2 台路由器的 IP 地址 R1(config)#int f0/0 //进入接口 R1(config if)#ip address ...

    动态路由 OSPF

    在这里插入图片描述

    (目的:路由器上分别配置动态路由 OSPF ,对各段路径划分不同的网段并通告全网,使各网段能正常通信)
    根据拓扑图中给定的网段配置 2 台路由器的 IP 地址
    R1(config)#int f0/0 //进入接口
    R1(config if)#ip address 192.168.1.1 255.255.255.0 // 配置 IP
    R1(configif)#int f0/1 //进入接口
    (config–if)#ip add 192.168.2.1 255.255.255.128 //配置配置IP

    在 R 1 上通告其直连的网段到区域 0
    R1(config)#router ospf 1 //开启 ospf 进程 1
    R1(configrouter)#network 192.168.1.0 0.0.0.255 area 0 //通告网段192.168.1.0 24 到区域 0
    R1(config router)#network 192.168.2.0 0.0.0.127 area 0 //通告网段1 92.168.2.0 25 到区域 0

    同理R2通告其直连的网段到区域 0
    R2(config)#router ospf 1 //开启 ospf 进程 1
    R2(configrouter)#network 192.168.2.0 0.0.0.255 area 0 //通告网段192.168.2.0 24 到区域 0
    R2(config router)#network 192.168.3.0 0.0.0.127 area 0 //通告网段1 92.168.3.0 25 到区域 0

    查看路由表: show ip route

    展开全文
  • eNSP动态路由ospf配置

    万次阅读 2019-08-05 19:24:20
    先设置三台路由器,左右是两个网段 先为四个节点都设置上相应的ip,inter进入相应的端口,ip add 10.1.1.1 30,每设置完一个ip都dis this一下看是否设置上ip。 然后先设置AR2: ...dis this或者dis ospf p...

    先设置三台路由器,左右是两个网段

    先为四个节点都设置上相应的ip,inter进入相应的端口,ip add 10.1.1.1 30,每设置完一个ip都dis this一下看是否设置上ip。

    然后先设置AR2:

    ospf 1

    area 0

    network 10.1.1.0 0.0.0.3  #这个路由器连接的一个网络,发布出去,最后是反子网掩码

    dis this或者dis ospf peer brief 查看动态路由设置是否正确,应该显示的是下一跳的ip,后面的状态是full(比较慢,如果dis this中出现了,但是在dis ospf p b中还没有出现,可以等一会)

     

    然后先设置AR3:

    ospf 1

    area 0

    network 10.1.1.0 0.0.0.3  #这个路由器连接的左边网络,发布出去,最后是反子网掩码

    network 20.1.1.0 0.0.0.3  #这个路由器连接的右边网络,发布出去,最后是反子网掩码

    dis this或者dis ospf peer brief 查看动态路由设置是否正确,应该显示的是下一跳的ip,后面的状态是full(比较慢,如果dis this中出现了,但是在dis ospf p b中还没有出现,可以等一会)

     

     

    然后先设置AR4:

    ospf 1

    area 0

    network 20.1.1.0 0.0.0.3  #这个路由器连接的左边网络,发布出去,最后是反子网掩码

    dis this或者dis ospf peer brief 查看动态路由设置是否正确,应该显示的是下一跳的ip,后面的状态是full(比较慢,如果dis this中出现了,但是在dis ospf p b中还没有出现,可以等一会)

     

     

    三台路由器都设置完了以后,可以用第一台路由器ping最后一台,ping的通则说明三台路由器的动态路由协议配置完成

     

     

     

     

    然后在第一台路由器前面加一台pc

    先到AR2中设置0/0/1接口的ip,在去设置pc机的ip,掩码和网关

     

    然后进入AR2路由器中,添加一个直连路由

    ospf 1

    import-route direct

    然后用pc1去ping最远的那台路由,能ping的通就是配好了

     

    然后再添加一台pc,启动,同样是先进入AR2设置0/0/2接口的ip,再去pc机中设置ip,掩码和网关,但是这边的网段和之前pc机的网段不能是同一个,只第三段不同

     

    然后用pc2来ping最远的路由器

     

     

     

     

     

     

     

     

     

     

     

    展开全文
  • eNSP模拟动态路由ospf配置方法

    千次阅读 2020-06-09 15:36:00
    进行ospf配置 需要注意:一台路由器可以属于多个区域,一条链路只能属于一个区域。 在系统目录下: 配置R1 [r1] ospf 1 router-id 1.1.1.1 //标识ospf路由器且不重复 [r1-ospf-1] area 0 [r1-ospf-1-area-0.0.0

    实验目的:用ospf实现pc与pc之间的通信

    OSPF工作原理(三步骤)

    1、 发送hello报文,建立邻居关系。

    2、 泛洪LSA,形成统一的LSDB。(Lsa有链路状态信息)

    3、 运行SPF算法,得到最优路径。

    实验拓扑图

    在这里插入图片描述
    pc1与pc2的配置详情
    在这里插入图片描述
    在这里插入图片描述
    对router1、2、3分别进行对应的端口ip的配置:路由表信息如下
    配置信息如下
    R1
    在这里插入图片描述
    R2
    在这里插入图片描述

    R3
    在这里插入图片描述
    常规配置完成
    进行ospf配置
    需要注意:一台路由器可以属于多个区域,一条链路只能属于一个区域。
    在系统目录下:
    配置R1

    [r1]    ospf 1 router-id 1.1.1.1    //标识ospf路由器且不重复
    [r1-ospf-1]   area 0
    [r1-ospf-1-area-0.0.0.0]   network 192.168.1.0  0.0.0.255  //此时为反掩码,通配符
    r1-ospf-1-area-0.0.0.0]    network 12.1.1.0 0.0.0.255
    

    这样 就可以把这两条链路放在区域area 0 中
    配置R2
    [r2] ospf 1 router-id 2.2.2.2
    [r2-ospf-1] area 0
    [r2-ospf-1-area-0.0.0.0] network 12.1.1.0 0.0.0.255
    [r2-ospf-1-area-0.0.0.0] network 23.1.1.0 0.0.0.255

    配置R3用同样的方式。
    之后得到新的路由表:
    R1
    在这里插入图片描述
    R2
    在这里插入图片描述
    R3
    在这里插入图片描述

    利用pc1 ping pc2
    在这里插入图片描述

    通过 display ospf lsdb 查看ospf链路状态数据库的信息
    在这里插入图片描述

    ospf的进程号有什么用

    也就是在输入ospf时加的 Process ID

    展开全文
  • 0x0 ospf配置 **AR1:** ospf 100 #创建ospf协议进程号 area 0 #进入区域 network 12.1.1.0 0.0.0.255 #ospf宣告直连网段的掩码是反掩码 **AR2:** ospf 100 #创建ospf协议进程号 area 0 #进入区域 network ...

    0x0 ospf的配置

    在这里插入图片描述

     **AR1:**
     ospf 100   #创建ospf协议进程号
     area 0      #进入区域
     network 12.1.1.0 0.0.0.255  #ospf宣告直连网段的掩码是反掩码
    
    **AR2:**
    ospf 100     #创建ospf协议进程号
    area 0        #进入区域
    network 12.1.1.0 0.0.0.255    #ospf宣告直连网段的掩码是反掩码
    network 23.1.1.0 0.0.0.255    #ospf宣告直连网段的掩码是反掩码
    
    **AR3:**
    ospf 100    #创建ospf协议进程号
    area 0       #进入区域
    network 23.1.1.0 0.0.0.255    #ospf宣告直连网段的掩码是反掩码
    

    查看ospf配置:

    display ospf peer               #查看ospf邻居
    display ip routing-table protocol ospf  #查看ospf协议的路由表
    

    0x1 ospf 修改RID

    1.#查看ospf配置信息
    [Huawei]dis ospf peer

     OSPF Process 100 with Router ID 12.1.1.1
    	 Neighbors 
    

    2.#修改router-id

    [Huawei]ospf 100 router-id 1.1.1.1
    Info: The configuration succeeded. You need to restart the OSPF process 
    to validate the new router ID.
    

    #RID ID 不需要是设备上真实存在的IP

    3.重置ospf进程

     <Huawei>reset ospf process
        Warning: The OSPF process will be reset. Continue? [Y/N]:y
    

    修改后:

    <Huawei>dis ospf peer
    
    	 OSPF Process 100 with Router ID 1.1.1.1
    		 Neighbors 
    

    0x2 修改ospf 基准带宽

    [Huawei-ospf-100]bandwidth-reference 1000
    

    建议在线路大于百M的时候就修改ospf的基准带宽,把基准带宽修改成网络中最大带宽(默认是百兆)

    10000/1000=10
    10+10=20 cost

    0x3 设置静默接口

    在数据转发给下一个设备的接口上配置静默接口,就无法转发OSPF数据包
    ospf 100
    silent-interface g0/0/1

    注:

    RIP协议的静默接口是阻断广播和组播,不能阻断单播 OSPF协议的静默接口是阻断所有传播

    0x4 修改计时器

    进入接口
    [R1-GigabitEthernet 0/0/0] ospf timer hello 20 //默认时间为10s

    [R1-GigabitEthernet 0/0/0] ospf timer dead 60

    注:邻居双方hello时间和死亡时间要一致,所以邻居之间都需要修改

    修改DR 和BDR角色

    [R1-GigabitEthernet 0/0/0] ospf dr-priority 10

    需要把原本的DR 的优先级改成0,其他的DR才能被选举

    OSPF 认证

    接口认证: [R1-GigabitEthernet 0/0/0] ospf authentication-mode md5 1 cipher
    huawei111 //密文认证

    区域认证:
    ospf 100
    area 0
    ospf authentication-mode md5 1 cipher huawei1

    展开全文
  • OSPF动态路由协议的配置命令

    千次阅读 2017-05-21 10:15:14
    OSPF动态路由协议  开放式最短路径优先协议是当今最流行和应用最广泛的路由协议之一。OSPF采用的是一种链路状态算法,并因此克服了RIP协议和其他采用距离适量算法协议的缺点。OSPF具有收敛速度快、路由汇聚使...
  • 华为eNSP配置动态路由OSPF协议

    千次阅读 2021-01-13 17:02:49
    一是动态路由OSPF协议;二是华为OSPF协议命令配置;三是配置OSPF静默接口;四是联通测试和查看OSPF邻居表;五是Wireshark数据抓包R1接口e0/0/0。
  • 动态路由协议OSPF配置

    2021-06-08 16:50:47
    (2)规划PC及路由器相关接口的IP地址,配置动态路由协议OSPF,使PC之间能相互通信; (3)使用命令查看每台路由器上的相关信息。三、实验仪器及环境 (1)路由器2台; (2)交换机2台; (3)PC4台; (4)双绞线、控制线、背靠背...
  • MikroTik ROS软路由OSPF命令配置实例

    千次阅读 2020-08-04 10:58:39
    目录MikroTik ROS软路由OSPF命令配置实例什么是OSPF:简单介绍工作原理:拓扑图配置命令 什么是OSPF: OSPF全程(Open Shortest Path First),是一款基于拓扑的路由选择协议,按类型划分为IGP协议,链路状态协议,用于...
  • OSPF配置命令总结

    2020-10-26 15:29:58
    abr-summary(OSPF区域) //用来在区域边界路由器(ABR)上配置路由聚合。 area(OSPF) //用来创建OSPF区域,并进入OSPF区域视图。 asbr-summary //用来设置自治系统边界路由器(ASBR)对OSPF引入的路由...
  • ospf动态路由配置

    2018-03-10 19:57:24
    利用三层交换机和ospf协议来实现实现动态路由。有完整的拓扑图和命令
  • 思科 动态路由OSPF

    2020-01-23 11:37:22
    1.利用ospf动态路由协议完成各个子网网络之间的互联通信 2.利用ospf动态路由协议完成不同自治区域之间的互联通信 实验步骤 1.利用ospf动态路由协议完成各个子网网络之间的互联通信 拓扑图见上边 路由器和PC的配置 ...
  • 《实验报告OSPF动态路由配置》由会员分享,可在线阅读,更多相关《实验报告OSPF动态路由配置(5页珍藏版)》请在人人文库网上搜索。1、淮海工学院计算机工程学院实验报告书课程名:网络管理技术 题 目: 动态路由...
  • 基于eNSP的华为设备--单臂路由配置,静态路由配置,RIP动态路由配置OSPF动态路由配置华为模拟器配置单臂路由功能快捷键合理的创建标题,有助于目录的生成如何改变文本的样式插入链接与图片如何插入一段漂亮的代码...
  • 华为交换机配置动态路由OSPF

    千次阅读 2019-09-11 21:20:51
    #配置ospf编号及私有路由ip [R1-ospf-1] area 0  #配置所属区域 [R1-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255  #声明直连路由网段 [R1-ospf-1-area-0.0.0.0] network 1.1.1.1 0.0.0.0  #声明回环...
  • 动态路由OSPF多区域

    2020-11-27 00:13:49
    文章目录一、 OSPF多区域的生成二、OSPF的三种通信量三、OSPF的路由器类型四、OSPF的区域类型五、OSPF链路状态数据库六、路由器对路由条目的选择七、末梢区域和完全末梢区域八、配置命令 一、 OSPF多区域的生成 生成...
  • 常见的动态路由OSPF

    2021-01-12 09:01:29
    文章目录OSPF路由协议概述内部网关协议和外部网关协议OSPF是链路状态路由协议OSPF的工作过程OSPF区域Router IDDR.BDR和DRotherOSPF的包类型(五个包)OSPF邻接关系的建立(七个状态)OSPF网络类型(四个类型) OSPF...
  • 前言   RIP是基于距离矢量算法的路由协议,由于应用在...动态路由OSPF,开放式最短路径协议 OSPF v3没有认证 属于IGP(内部网关)协议,链路状态路由协议——不直接传递各路由器的路由表,而传递链路状态信息。 ...
  • 动态路由OSPF路由协议的高级配置一、路由重分发1.1理解路由重分发1.2、路由重分发的考虑二、OSPF的重分发路由2.1 重分发OSPF域中路由的路径类型2.2、 路由器有两条到达外部目的网络的路径E1、E2三、NSSA区域3.1 ...
  • H3C路由器配置——动态路由OSPF协议

    千次阅读 2019-10-08 07:10:51
    (1)、OSPF(Open Shortest Path First,开放最短路径优先)路由协议是用于网际协议(IP)网络的链路状态路由协议。是一个被各厂商设备广泛支持的链路状态路由协议。OSPF执行IETF标准,IETF标准被不同厂商的设备所...
  • 1、单区域配置OSPF路由配置好IP地址信息: #物理接口 interface GigabitEthernet0/0/0 ip address 10.0.123.2 255.255.255.0 # #回环接口 interface LoopBack0 ip address 10.0.1.1 255.255.255.0 # ...
  • 动态路由OSPF(多区)OSPF多区域的生成原因OSPF的通信量OSPF中的路由器的类型OSPF区域的类型OSPF链路状态通告类型链路状态数据库的组成末梢区域和完全末梢区域 OSPF多区域的生成原因 1)改善网络的可扩展性 2)快速...
  • ospf配置命令

    2011-12-16 11:33:29
    ospf(open shortest path first)协议即“开放最短路径优先协议”。它是一种基于链路状态的...ospf协议支持ip子网、支持与其他路由协议的路由的引入、还支持基于接口的报文验证、接口链路开销的用户配置ospf...
  • OSPF动态路由配置(Cisco)

    万次阅读 多人点赞 2019-01-17 00:54:03
    在路由器上配置OSPF路由 配置静态默认路由 在多路访问网络上配置OSPF 掌握OSPF协议的配置方法   二、实验环境  •思科3560三层交换机一台。 •计算机4台(已安装 Windows Server 2003 操作系统)...
  •  前一篇博客使用了 距离矢量路由协议的 RIP协议来动态配置路由。本篇博客学习使用OSPF协议实现动态路由。 一、OSPF的基本概念  OSPF(,开放的最短路径优先协议) 自治系统(AS):一个使用相同路由策略的区域; ...
  • Router0配置: Router1配置: Multilayer Switch0配置: Switch0配置: Switch1配置: 主机PC0配置: 202.199.1.2 255.255.255.0 202.199.1.1 主机PC1配置: 202.199.2.2 255.255.255.0 202.199.2.1 主机PC2...
  • 本文档详细介绍路由器 OSPF 动态路由配置的方法 实验目的 掌握 OSPF 协议的配置方法 掌握查看通过动态路由协议 OSPF 学习产生的路由 熟悉广域网线缆的链接方式 实验背景 假设校园网通过一台三层交换机连到校园...
  • 文章目录一、实验拓扑二、实验需求需求1需求2需求3三、实验步骤R1R2R3R4R5R6四、验证需求需求1需求2需求3 一、实验拓扑 ...配置OSPF,宣告网段 配置RIP 协议注入 R2 R2是边界路由,需要宣告area
  • 文章目录前言一、OSPF的基本概念1.1定义1.2协议概述1.2.1自治系统(AS)1.2.2内部网关协议(IGP)1.2.3外部网关协议(EGP)1.3OSPF区域1.4Router ID1.5DR与BDR1.5.1指定路由器(DR)1.5.2其它路由器(DRother)1.5.3DR与...
  • OSPF协议配置命令解析

    万次阅读 多人点赞 2018-12-05 22:06:30
    一,ospf命令 命令功能 ospf命令用来创建并运行OSPF进程。 undo ospf命令用来关闭OSPF进程。 缺省情况下,系统不运行OSPF协议,即不运行OSPF进程。 2.命令格式 ospf I process-id I router-id router-id] undo ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 15,660
精华内容 6,264
关键字:

动态路由ospf配置命令