精华内容
下载资源
问答
  • 动态路由RIP

    2020-11-08 12:16:52
    动态路由RIP一.动态路由的概述(1).动态路由的特点(2).动态路由协议概述(3).度量值(4).按照路由执行的算法分类(1).距离矢量路由协议(2).链路状态路由协议二.RIP路由协议及工作原理(1)RIP的概述(2)...

    一.动态路由的概述

    动态路由是基于某种路由协议实现的

    (1).动态路由的特点

    (1)减少了管理任务
    (2)占用了少量带宽

    (2).动态路由协议概述

    路由器之间用来交换信息的语言

    (3).度量值

    1、跳数、带宽、负载、时延、可靠性、成本
    2、路由器会通过度量值来确定最优路由路径
    在这里插入图片描述

    (4).按照路由执行的算法分类

    (1).距离矢量路由协议

    (1)、依据从源网络到目标网络所经过的路由器的个数选择路由.
    (2)、RIP, IGRP (思科私有协议)

    (2).链路状态路由协议

    (1)、综合考虑从源网络到目标网络的各条路径的情况选择路由.
    (2)、OSPF, IS-IS

    二.RIP路由协议及工作原理

    (1)RIP的概述

    1、定期更新
    2、邻居
    3、广播更新
    4、全路由表更新

    (2)路由表的形成

    1、路由器学习到直连路由
    2、更新周期30s到时,路由器会向邻居发送路由表
    3、再过30s,第二个更新周期到了再次发送路由表

    (3)RIP度量值与更新时间

    1.RIP度量值为跳数

    最大条数为15跳,16跳为不可达

    2.RIP更新时间

    每个30秒发送路由更新消息,UDP520端口

    3.RIPP路由更新消息

    发送整个路由表信息

    三.路由环路

    (1)、从一个接口学习到路由信息,不再从这个接口发送出去
    (2)、同时也能减少路由更新信息占用的链路带宽资源
    在这里插入图片描述

    四.水平分割

    1. 水平分割

    在路由信息传送过程中,路由器从某个接口接收到的更新信息不允许再从这个接口发回去。同时也能减少路由更新信息占用的链路带宽资源。
    在这里插入图片描述

    2. 毒性逆转

    路由器从某个接口上接收到某个网段的路由信息之后,并不是不往回发送信息了,而是发送,只不过是将这个网段标志为不可达,再发送出去。收到此种的路由信息后,接收方路由器会立刻抛弃该路由,而不是等待其老化时间到。这样可以加速路由的收敛。

    3.配置命令

    [R1]rip 1 ###启动RIP
    [R1-rip-1] version 2 ##启动版本2 (缺省为版本1)
    [R1-rip-1]undo summary ##关闭路由自动聚合(即所有路由信息都会按照IP地址分类归类)
    [R1-rip-1] network 192.168.10.0 ##宣告主网络号, v2会携带掩码组播更新224.0.0.9, v1不携带掩码广播更新255.255.255. 255
    [R1-rip-1]network 200.1.1.0

    兼容模式

    [R1] int go/0/1
    [R1-GigabitEthernet0/0/1]rip version 2 multicast ##把设置成rip1路由器的某一接口单独设置成rip版本2

    展开全文
  • 动态路由rip

    2020-01-02 14:05:32
    #router rip R2 ( config - router ) #net R2 ( config - router ) #network 172.168 .2 .0 R2 ( config - router ) #network 172.168 .3 .0 R2 ( config ) #ip route 0.0 .0 .0 0.0 .0 .0 202.112 .10...

    实验拓扑

    在这里插入图片描述
    在这里插入图片描述

    实验配置

    R1(config)#interface f0/0
    R1(config-if)#ip ad
    R1(config-if)#ip address 172.168.1.1 255.255.255.0
    R1(config-if)#no shu
    R1(config-if)#no shutdown 
    R1(config-if)#interface f0/1
    R1(config-if)#ip address 172.168.2.1 255.255.255.0
    R1(config-if)#no shu
    R1(config-if)#no shutdown 
    
    R2(config)#interface f0/0
    R2(config-if)#ip add
    R2(config-if)#ip address 172.168.3.1 255.255.255.0
    R2(config-if)#no shu
    R2(config-if)#no shutdown 
    R2(config-if)#interface f0/1
    R2(config-if)#ip address 172.168.2.2 255.255.255.0
    R2(config-if)#no shu
    R2(config-if)#no shutdown 
    R2(config-if)#interface s0/0/0
    R2(config-if)#ip address 202.112.10.1 255.255.255.252
    R2(config-if)#clock rate 64000
    R2(config-if)#no shutdown 
    
    
    R3(config)#interface f0/0
    R3(config-if)#ip ad
    R3(config-if)#ip address 59.64.128.1 255.255.255.0
    R3(config-if)#no shu
    R3(config-if)#no shutdown 
    R3(config-if)#interface s0/0/0
    R3(config-if)#ip address 202.112.10.2 255.255.255.252
    R3(config-if)#no shu
    R3(config-if)#no shutdown 
    
    R1(config)#router rip
    R1(config-router)#passive-interface f0/0
    
    
    R2(config-router)#passive-interface f0/0
    
    R1(config-router)#network 172.168.1.0
    R1(config-router)#network 172.168.2.0
    
    R2(config)#router rip
    R2(config-router)#net
    R2(config-router)#network 172.168.2.0
    R2(config-router)#network 172.168.3.0
    R2(config)#ip route 0.0.0.0 0.0.0.0 202.112.10.2
    
    
    R3(config)#ip route 0.0.0.0 0.0.0.0 202.112.10.1
    R3(config)#
    
    展开全文
  • 动态路由RIP实验.rar

    2020-12-30 12:46:34
    动态路由RIP实验.rar
  • 动态路由RIP
  • 动态路由RIP协议配置

    2018-12-07 18:50:20
    动态路由RIP协议配置 网络工程与技术课的实验报告,有需要的小伙伴可以下载
  • 配置动态路由RIP

    2021-04-10 17:29:47
    配置动态路由RIP 什么是动态路由RIP 1.路由协议是路由器之间交互信息的一种语言。 2.路由协议共享网络状态和网络可达性的一些信息。 3.路由协议定义了一套路由器之间通信时使用的规则。 4.路由协议维护路由表、提供...

    配置动态路由RIP

    什么是动态路由RIP

    1.路由协议是路由器之间交互信息的一种语言。
    2.路由协议共享网络状态和网络可达性的一些信息。
    3.路由协议定义了一套路由器之间通信时使用的规则。
    4.路由协议维护路由表、提供最佳转发路径。

    RIP就是距离矢量路由协议,是一种内部网关协议,一种动态路由选择协议,用于自治系统内的路由信息的传递。这个协议的配置简单,具有动态路由的可扩展性和应变能力,能够自动学习路由、选择路由,通过多种特效避免网络中出现环路。在带宽、配置和管理方面要求较低,主要适用于较小规模的网络中。路由器能够自动地建立自己的路由表,并且能够根据实际情况的变化适时地进行调整。

    配置RIP

    拓扑图

    在这里插入图片描述

    三个路由器基本配置

    在这里插入图片描述
    在这里插入图片描述

    路由器协议配置

    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    给每个路由器启用第二版

    在这里插入图片描述

    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    测试

    在这里插入图片描述

    总结

    RIP协议配置需要配置好PC机及路由器各个接口的IP地址等参数,另外,路由协议配置要采用RFC2453的version 2。

    展开全文
  • 华为动态路由RIP

    2020-05-31 18:11:19
    华为动态路由RIP 动态路由:基于某种理由协议实现 动态路由特点:1、减少了管理任务 2、占用网络带宽 动态路由协议概述:路由器之间用来交换信息的语言 度量值:跳数、带宽、负载、时延、可靠性、成本 RIP路由协议...

    华为动态路由RIP
    动态路由:基于某种理由协议实现
    动态路由特点:1、减少了管理任务 2、占用网络带宽

    动态路由协议概述:路由器之间用来交换信息的语言
    度量值:跳数、带宽、负载、时延、可靠性、成本

    RIP路由协议工作原理
    RIP是距离-矢量路由选择协议
    RIP的·基本概念
    定期更新(路由器没经过一段时间周期-30秒后,向相邻路由发送更新信息)
    广播更新(RIP V1 255.255.255.255)
    组播更新(RIP V2 224.0.0.98)
    泛宏路由表(路由器将从相邻路由学到的路由表放心自己的路由表中,然后将路由表所有路由信息通告给其他路由器,知道整个网络学习到)

    实验案列:使用eNSP模拟RIP环境
    实验环境
    B公司成立了一个新部门,同时购置了一批路由器,因网关太懒了,所以不想配置静态路由,所以准备构建动态路由。
    需求描述
    使用eNSP构建拓扑,配置ip以及Loo 0。
    将制作的RIP配置版本信息。
    推荐步骤
    1.为路由器配置ip和Lo 0。
    2.配置R1,R2,R3的RIP。
    3.理解RIP配置不同版本是为了防止路由换路,增加带宽。

    根据在这里插入图片描述要求搭建拓扑

    sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sys R1
    [R1]int g0/0/0
    [R1-GigabitEthernet0/0/0]ip add 12.0.0.1 30
    May 29 2020 14:00:46-08:00 R1 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP
    on the interface GigabitEthernet0/0/0 has entered the UP state.
    [R1-GigabitEthernet0/0/0]int Loo 0
    [R1-LoopBack0]ip add 1.1.1.1 24
    [R1-LoopBack0]q
    在这里插入图片描述
    R2
    sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sys R2
    [R2]int g0/0/0
    [R2-GigabitEthernet0/0/0]ip add 12.0.0.2 30
    May 29 2020 14:01:54-08:00 R2 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP
    on the interface GigabitEthernet0/0/0 has entered the UP state.
    [R2-GigabitEthernet0/0/0]int Loo 0
    [R2-LoopBack0]ip add 2.2.2.2 24
    [R2-LoopBack0]int g0/0/1
    [R2-GigabitEthernet0/0/1]ip add 23.0.0.1 30
    May 29 2020 14:02:21-08:00 R2 %%01IFNET/4/LINK_STATE(l)[1]:The line protocol IP
    on the interface GigabitEthernet0/0/1 has entered the UP state.
    [R2-GigabitEthernet0/0/1]q
    在这里插入图片描述

    R3
    sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sys R3
    [R3]int g0/0/1
    [R3-GigabitEthernet0/0/1]ip add 23.0.0.2 30
    May 29 2020 14:04:00-08:00 R3 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP
    on the interface GigabitEthernet0/0/1 has entered the UP state.
    [R3-GigabitEthernet0/0/1]int Loo 0
    [R3-LoopBack0]ip add 3.3.3.3 24
    [R3-LoopBack0]q
    在这里插入图片描述

    R1 RIP
    [R1]rip 1
    [R1-rip-1]
    [R1-rip-1]version 1
    [R1-rip-1]network 12.0.0.0
    [R1-rip-1]network 1.0.0.0
    在这里插入图片描述

    R2 RIP
    [R2]rip 1
    [R2-rip-1]
    [R2-rip-1]network 12.0.0.0
    [R2-rip-1]network 23.0.0.0
    [R2-rip-1]network 2.0.0.0
    在这里插入图片描述

    R3 RIP
    [R3]rip 1
    [R3-rip-1]version 2
    [R3-rip-1]network 23.0.0.0
    [R3-rip-1]network 3.0.0.0
    [R3-rip-1]q
    [R3]
    在这里插入图片描述

    此时PC1可以连通PC2,PC2可以连通PC3,但是PC1不能连通PC2
    在这里插入图片描述

    在R2路由器中配置PIR V2,增加rip获取
    [R2]int g0/0/1
    [R2-GigabitEthernet0/0/1]r v 2 m
    [R2-GigabitEthernet0/0/1]q
    在这里插入图片描述

    此时R1到R3可以互相连通了
    在这里插入图片描述
    在这里插入图片描述

    展开全文
  • 在思科模拟器上怎么配置动态路由RIP?动态路由会自主选择最佳路径的,不像静态路由某个节点瘫痪了,整个网络就都瘫痪了,下面我们来看看思科模拟器上配置动态路由RIP的图文教程
  • 文章目录静态路由及动态路由 RIP 静态路由及动态路由 RIP 1.静态路由: (静态路由的目的:静态配置IP 实现通信(更高效)) R1(configif)#ip address 192.168.2.0 255.255.255.0 //配置 IP R2(config if)#ip ...
  • 动态路由RIP协议!

    2021-04-14 19:54:21
    动态路由RIP什么是路由路由协议的分类动态路由协议的分类距离矢量路由协议选择的特点RIP的度量值RIP概述RIPV1报文格式RIPV2报文格式RIPV2相较于RIPV1的改进下一跳距离矢量路由协议的防环机制 什么是路由 路由协议的...
  • 华为HCNA实验学习--RIP配置HCNA 动态路由RIP配置实验1.动态路由的概念2.静态路由的配置思路 HCNA 动态路由RIP配置实验 本章内容意在学习静态路由协议相关知识。通过本章的学习,你将掌握以下内容: 1.动态路由的概念...
  • 动态路由RIP配置

    2020-06-02 16:00:56
    什么是动态路由 RIP RIP 是一种较为简单的内部网关协议( IGP ),基于 UDP ,端口号为 520 ,包括 RIPV1 和 RIPv2 两个版本。RIPv2 对 RIPv1 进行了扩充,支持 VLSM 和 CIDR ,支持安全验证。 由于 RIP 的功能较为...
  • 动态路由rip2

    2020-05-20 17:10:26
    配置动态路由rip2 pc0的ip 192.168.10.1, 网关192.168.10.254 server0的ip 192.168.20.1 , 网关192.168.20.254 pc1的ip 192.168.30.1, 网关192.168.30.254 中途有三个路由器连接,此时,再写静态路由会非常繁琐,...
  • 动态路由RIP以及理解

    2020-05-28 14:50:54
    动态路由RIP以及理解 相比较于静态路由,动态路由由协议具有更强的可扩展性,具备更强的应变能力。在特定环境中,动态路由协议的配置和参数调整比配置静态路由复杂。网络规模越大,静态路由越无法满足需求,配置也...
  • 内附:静态路由默认路由动态路由RIP实验配置,有图,注释文档。
  • Windows Server 2003 路由器之动态路由RIP Windows Server 2003路由器 1路由器的原理 2路由器的设置 3筛选进出路由器的数据包 4请求拨号连接 5动态路由RIP 6网桥 5动态路由RIP 动态路由器 当计算机的路由条目发生...
  • cisco 动态路由RIP配置

    2017-11-12 02:39:00
    动态路由RIP运用在一个较大的企业网络,在有多个路由器的时候. 动态路由就是网络中路由器之间互相通信,传递路由信息,利用收到的路由信息更新路由表的过程. 动态路由协议分类: 距离矢量路由协议 根据跳数来...
  • 动态路由rip配置命令

    2020-06-02 18:45:26
    动态路由rip1实验 实验需求 两个路由器配rip 1 实验步骤 【1】绘制拓扑图 【2】R1路由器配置 【3】R2路由器配置 【4】R3路由器配置 【5】测试1 【6】解决R3学习不到路由信息问题 具体步骤 【1】绘制拓扑图 【2】R1...
  • 动态路由rip1实验

    2020-07-06 13:13:26
    动态路由rip1实验 实验需求 两个路由器配rip 1 实验步骤 【1】绘制拓扑图 【2】R1路由器配置 【3】R2路由器配置 【4】R3路由器配置 【5】测试1 【6】解决R3学习不到路由信息问题 具体步骤 【1】绘制拓扑图 [外链图片...
  • 实验三:动态路由RIP

    2020-03-30 08:53:57
    重点掌握动态路由RIP的配置 熟悉动态路由协议中传播默认路由的方法 Ⅱ.项目结构 Ⅲ.地址表 Ⅳ.实验要求 按上面表格中IP地址的规划,配置路由器各接口IP和计算机IP地址(串口线路DCE时钟频率64000)。 以R1为...
  • 动态路由RIP协议一、动态路由协议基础1.1 概述1.2 度量值1.3收敛1.4动态路由分类二、RIP工作原理2.1 基本原理2.2 路由环路2.3水平分割2.4 毒性逆转三、RIP v1和RIP v2的区别 一、动态路由协议基础 1.1 概述 相较于...
  • Cisco Packet Tracer 动态路由RIP配置

    千次阅读 2019-04-03 15:52:06
    Cisco Packet Tracer 动态路由RIP配置 一、拓扑图 二、PC、路由IP配置 PC0: PC1: route0配置: Router>en Router#conf t Enter configuration commands, one per line. End with CNTL/Z. Router(config)#...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 2,332
精华内容 932
关键字:

动态路由rip