精华内容
下载资源
问答
  • 动态路由RIP协议

    2019-11-15 19:21:50
    动态路由协议简介 1·路由协议是路由器之间交互信息的一种语言。 2·路由协议共享网络状态和网络可达性的一些信息。 3·路由协议定义了一套路由器之间通信时使用的规则。 4·路由协议维护路由表、提供最佳转发...

    动态路由的分类:
    1、基于AS的分类
    AS:Autonoumous System,自治系统。AS编号范围0-65535,其中0-64511公有AS,64512-65535私有AS号。
    IGP:内部网关协议(AS之内)–RIP、OSPF、ISIS、EIGRP(Cisco私有)
    EGP:外部网关协议(AS之间)–BGP
    2、IGP协议的分类:
    距离矢量(DV):RIP、EIGRP—路由器之间共享路由表
    链路状态(LS):OSPF、ISIS—路由器之间发送拓扑
    3、基于更新时是否携带子网掩码
    有类路由:不带(带的是主类掩码)
    无类路由:带
    RIP:Routing Information Protocol,路由信息协议
    1、基本概念:
    标准的DV型协议,分为三个版本–RIPv1、RIPv2、RIPng(IPv6)
    基于UDP 端口号520
    周期更新机制 30s–确认、保活
    支持等开销负载均衡
    管理距离120,以跳数(经过路由器的数量)作为度量值,最大15,16跳不可达
    2、RIPv1和RIPv2的区别
    1)更新方式:RIPv1广播更新,RIPv2组播更新(224.0.0.9)
    2)RIPv1更新时不带掩码;RIPv2更新时携带掩码
    3)RIPv2支持手工认证–邻居间的身份核实

    3、RIP数据包:
    update包–更新包,携带路由条目的数据包
    4、RIP的破环机制
    1)水平分割–同一条路由条目,从此口入不从此口出,终极目标为了消除重复更新;只能破除线型拓扑和星型拓扑
    2)毒性 逆转水平分割–触发更新–专用于网络断开的情况
    3)抑制计时器

    网络结构发生变化:
    1)新增
    2)断开
    3)设备无法通信**

    RIP路由协议
    RIP:Routing Information Protocol (路由信息协议)
    一种距离矢量路由协议,属于IGP协议。
    RIP协议适用于中小型网络,有RIPv1和RIPv2两个版本。

    其中:
    RIPv1为有类别路由协议,不支持VLSM和CIDR
    以广播的形式发送报文
    不支持验证

    RIPv2为无类别路由协议,支持VLSM,支持路由聚合与CIDR
    支持以广播或者组播(224.0.0.9)的形式发送报文
    支持明文验证和 MD5 密文验证

    使用UDP进行路由信息的交互,目标端口号520。
    RIP支持:水平分割(避免路由环路的出现和加快路由汇聚的技术)、毒性逆转(一种改进的水平分割)和触发更新。

    用画图表示下实验

    在这里插入图片描述
    *
    配置AR1、2、3各个接口IP和loopback接口
    以下代码为:本人懒的,大概…代码。

    r1:

    int f0/0
    ip addr 10.1.0.1 24

    int l0
    ip addr 172.16.1.1 24

    int l1
    ip addr 172.16.2.1 24

    int l2
    ip addr 172.16.3.1 24

    r2:

    int f0/0
    ip addr 10.1.0.2 24

    int f0/1
    ip addr 10.2.0.1 24

    int l0
    ip addr 192.168.1.1 30

    int l1
    ip addr 192.168.1.5 30

    int l2
    ip addr 192.168.1.9 30

    r3:
    sys
    int f0/0
    ip addr 10.3.0.1 24

    int f0/1
    ip addr 10.2.0.2 24

    r4:
    int f0/0
    ip addr 10.3.0.2 24

    int l0
    ip addr 192.168.2.1 24

    :4、配置R1和R2的手动聚合,查看并分析路由表,测试连通性。

    把R1的172.16.1.0 2.0 3.0聚合为172.16.0.0/22

    int f0/0
    rip summary-address 172.16.0.0 255.255.252.0

    把R2的192.168.1.1 1.5 1.9聚合为192.168.1.0/26

    int f0/0
    rip summary-address 192.168.1.0 255.255.255.192

    然后查看它们的路由表

    展开全文
  • 动态路由RIP协议配置

    2018-12-07 18:50:20
    动态路由RIP协议配置 网络工程与技术课的实验报告,有需要的小伙伴可以下载
  • 动态路由RIP协议一、动态路由协议基础1.1 概述1.2 度量值1.3收敛1.4动态路由分类二、RIP工作原理2.1 基本原理2.2 路由环路2.3水平分割2.4 毒性逆转三、RIP v1和RIP v2的区别 一、动态路由协议基础 1.1 概述 相较于...

    一、动态路由协议基础

    1.1 概述

    相较于静态路由,动态路由的优点在于不需要手工书写路由,在配置好接口IP地址和和直连网段后,路由表之间可以相互学习(路由器能够自动建立路由表,根据网络中路由器之间通信,传递信息,利用收到的路由信息更新路由表)
    但并不代表动态路由可以取代静态路由,在网络中静态路由和动态路由相互补充
    动态路由的特点:
    1.减少了管理任务
    2.占用了网络宽带
    在这里插入图片描述
    如图所示:R2利用从R1和R3传递的路由路由信息更新了自身的路由表
    在这里插入图片描述
    当有其他非直连网段(50.0.0.0)出现时,R2也会根据变化,作出及时反映

    1.2 度量值

    度量值代表距离 (上图中的Metric就是度量值)
    路由器通过度量值来确定最优路由路径
    每一种路由算法在产生路由表时,会为每一条通过网络的路径产生一个数值(度量值),其最小的值表示最优路径
    度量值的计算可以只考虑路径的一个特性,但更复杂的度量值是综合了路径的多个特性产生的
    一些常用的度量值:
    1.跳数
    通过一台路由器算一跳
    2.带宽
    数据传输速度
    3.负载
    网络资源或者链路已被使用的(或正在运行的)部分的大小
    4.时延
    报文从源端传到目的地的时间
    5.可靠性
    链路稳定性
    6.成本
    协议的计算公式,用来计算总成本

    1.3收敛

    使所有路由表都达到一致状态的过程

    1.4动态路由分类

    动态路由协议按照路由执行的算法可以分为:
    1.距离矢量路由协议
    依据从源网络到目标网络所经过的路由器的个数选择路由,包括RIP、IGRP (思科私有协议)
    2.链路状态路由协议
    综合考虑从源网络到目标网络的各条路径的情况选择路由,包括OSPF、 IS-IS

    二、RIP工作原理

    2.1 基本原理

    RIP属于距离矢量路由选择协议,它以跳数作为度量值来衡量到达目的地址的距离,最大跳数为15跳,16跳即为不可达,因此RIP只能应用于小型网络
    RIP在更新周期30s到时会以广播形式发送一次路由信息(使用UDP的520端口)在邻居之间互传
    更新消息是发送整个路由信息

    2.2 路由环路

    动态路由的工作原理就是通过每隔30s一次的广播进行的自主学习,同样每30s更新一次路由表,但在实际工作环境中不可能有同时开启的情况,这样的话,路由器就可能收到它自己发送的路由信息

    在这里插入图片描述如图所示:
    如果R3在更新周期内先发生状态变化,比如毒化40.0.0.0网段(40.0.0.0出现故障),那么跳数Hop会变成16,此时正好R2更新周期到了,向R3发送本身的路由表,就把原先学习记录到的40网段的发送了过去,这样R3就把出问题的40网段给覆盖,并且把下一跳地址变为30.0.0.1
    在这里插入图片描述
    此时如果有个数据包是发向40.0.0.0网段的,经过R2,查看路由表,找到下一跳30.0.0.2发向R3,R3得到后查看路由表得到,40.0.0.0网段的下一跳又向着30.0.0.1发,即形成路由环路
    在这里插入图片描述

    2.3水平分割

    水平分割为防环机制:
    路由器从某个接口接收到的更新信息不允许再从这个接口发回去
    在这里插入图片描述
    如图所示,R2在收到R1和R3的路由信息后,在下一次更新时就不会将他们各自的直连网段信息发回去
    水平分割可以有效防止路由环路的产生,同时也能减少路由更新信息所占用的链路带宽资源

    2.4 毒性逆转

    毒性逆转可以理解为升级版的水平分割,将从邻居那里所获得的路由信息不是不发送回去,而是直接将这个网段标志为不可达(16跳)再发送回去,接收方路由器收到路由信息后会立刻抛弃该路由,而不是等待其老化时间到,不过毒性逆转会增加路由信息,占据链路带宽,通常不建议使用

    三、RIP v1和RIP v2的区别

    在这里插入图片描述

    展开全文
  • 动态路由RIP协议的原理及配置 一:RIP路由协议原理 ​ RIP 路由协议是基于距离矢量算法,使用跳数(metric)来衡量到达目标地址的距离。它是一个用于路由器和主机间交换路由信息的距离向量协议。这种协议的路由器只与...

    动态路由RIP协议的原理及配置

    一:RIP路由协议原理

    ​ RIP 路由协议是基于距离矢量算法,使用跳数(metric)来衡量到达目标地址的距离。它是一个用于路由器和主机间交换路由信息的距离向量协议。这种协议的路由器只与自己相邻的路由器交换信息,范围限制在15跳之内。

    二:实验目的

    使得一台主机能通过RIPv2协议动态获取到另一台主机分配的ip地址

    三:实验操作

    1、使用装有GNS3的电脑,打开GNS3,拖出三台路由器和两台PC机,用双绞线链接好、该标记的标记以便自己查看,并开启。
    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-4h1QuGDm-1571646076080)(C:\Users\xumin\AppData\Roaming\Typora\typora-user-images\1571643555944.png)]
    2、现在开始配置,先对R1、R2、R3各个接口配置地址,然后进行rip协议的配置

    R1
    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-zpUKgvQg-1571646076083)(C:\Users\xumin\AppData\Roaming\Typora\typora-user-images\1571644597690.png)]
    R2、R3的步骤也是如此
    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-LB7QJ4xO-1571646076088)(C:\Users\xumin\AppData\Roaming\Typora\typora-user-images\1571644557465.png)]
    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-1yQi9PaZ-1571646076089)(C:\Users\xumin\AppData\Roaming\Typora\typora-user-images\1571644666929.png)]
    3、都配置好之后查看路由表(show ip route),看自己有没有配置错误
    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-T6MGTF50-1571646076091)(C:\Users\xumin\AppData\Roaming\Typora\typora-user-images\1571645123590.png)]
    4、最后配置两台主机的ip地址,在相互ping,看是否能进行通讯,能相互通讯则这个实验完成了。
    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-NmcnuzBt-1571646076093)(C:\Users\xumin\AppData\Roaming\Typora\typora-user-images\1571644823951.png)]
    看的出来是ping通了,则现在两台主机是可以相互通讯的了。本次实验完成了。

    展开全文
  • 计算机综合实验–动态路由RIP协议实验 模拟软件:Cisco Packet Tracer 7.0 图Router3 -r1 Router>en Router#conf t Enter configuration commands, one per line. End with CNTL/Z. Router(config)#ho r1 r1...

    计算机综合实验–动态路由RIP协议实验

    简单的动态路由RIP实验 模拟软件:Cisco Packet Tracer 7.0

    图Router3 -r1

    Router>en
    Router#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    Router(config)#ho r1
    r1(config)#int f0/0
    r1(config-if)#ip add 10.1.1.254  255.0.0.0
    r1(config-if)#no sh
    
    r1(config-if)#exit
    %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
    
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
    %IP-4-DUPADDR: Duplicate address 10.1.1.1 on FastEthernet0/0, sourced by 00D0.FF09.4461
    
    r1(config-if)#int f0/1
    r1(config-if)#ip add 20.1.1.1 255.0.0.0
    r1(config-if)#no sh
    
    r1(config)#router rip
    r1(config-router)#ver 2
    r1(config-router)#network 10.0.0.0
    r1(config-router)#network 20.0.0.0
    r1(config-router)#end
    
    r1#ping 10.1.1.2
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
    

    图Router1 -r2

    Router>en
    Router#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    Router(config)#ho r2
    r2(config)#int f0/0
    r2(config-if)#ip add 20.1.1.2 255.0.0.0
    r2(config-if)#no sh
    
    r2(config-if)#
    %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
    
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
    
    r2(config-if)#int f0/1
    r2(config-if)#ip add 30.1.1.1 255.0.0.0
    r2(config-if)#no sh
    
    r2(config)#router rip
    r2(config-router)#ver 2
    r2(config-router)#network 20.0.0.0
    r2(config-router)#network 30.0.0.0
    r2(config-router)#end
    
    r2#ping 20.1.1.1
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 20.1.1.1, timeout is 2 seconds:
    .!!!!
    Success rate is 80 percent (4/5), round-trip min/avg/max = 0/0/0 ms
    

    图Router5-r3

    Router>en
    Router#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    Router(config)#ho r3
    r3(config)#int f0/0
    r3(config-if)#ip add 30.1.1.2 255.0.0.0
    r3(config-if)#no sh
    
    r3(config-if)#int f0/1
    r3(config-if)#ip add 40.1.1.254  255.0.0.0
    r3(config-if)#no sh
    
    r3(config)#router rip
    r3(config-router)#ver 2
    r3(config-router)#network 30.0.0.0
    r3(config-router)#network 40.0.0.0
    r3(config-router)#end
    

    在这里插入图片描述

    展开全文
  • 配置动态路由RIP协议

    2020-03-22 12:16:14
    4、配置动态路由 (1)Router0配置动态路由rip A、en B、config t C、router rip D、network 172.16.0.0 【注意:这里没有指定子网掩码,因为172.16.0.0是一个B类地址,子网掩码是255.255.255.0,直接写成172.16.0.0...
  • (这里使用动态路由协议RIP动态路由基本原理: 动态路由是与静态路由是相对的一个概念,动态路由可以通过与相邻的路由建立连通,从而相邻双方将自身已知路由表信息进行交换、更新,动态调整自身的路由表...
  • 动态路由协议分类: v距离矢量路由协议:从源网络到目标所经过的路由个数来选择路由,典型的协议RIP和IGRP。 v链路状态路由协议:综合考虑从源网络到目标的各条路径的情况来选择路由,典型的协议有OSPF和IS-IS。 ...
  • 二、RIP协议工作过程 2.1、工作特点  n路由信息协议RIP(Routing Information Protocol)是一个真正的距离矢量路由选择协议。  n它每隔30秒就送出自己完整的路由表到所有激活的接口。  nRIP协议选择最佳路径...
  • 分别配置三台路由器:R1ripv1版本,R3ripv2版本,R2兼容模式,调整R2端口rip协议版本让三台路由器能互相学习路由表 二、实验环境 在华为ENSP中建立如图所示拓扑图 在R1中设置 [R1]interface g0/0/0 ##配置接口ip [R1...
  • 动态路由协议之RIP协议一、动态路由1.1动态路由概述1.1.1动态路由1.1.2动态路由特点1.1.3动态路由的工作流程1.2动态路由协议1.2.1动态路由协议概述1.2.2度量值1.2.3收敛1.2.4动态路由协议分类二、RIP(距离——矢量...
  • 掌握动态路由协议RIPRIP路由协议的配置方法以及掌握路由器路由表内容的查看方法
  • 了解动态路由RIP协议动态路由概述动态路由的特点动态路由协议概述度量值收敛静态路由与动态路由的比较路由协议距离矢量路由协议链路状态路由协议RIP 距离矢量---路由协议RIP的基本概念路由信息的传输过程RIP的度量...
  • 动态路由协议及rip协议一、动态路由(一)概述(二)metric度量值和收敛(三)传说的路由和传信的路由二、RIP路由协议(一)概念及路由表的形成(二)rip防止环路的方法(三)RIPV1/2的区别(四)配置命令 一、动态...
  • 动态路由/RIP协议

    2021-01-07 17:05:53
    动态路由动态路由RIP水平分割RIPV1和V2的区别毒性大挪移 动态路由 *基于某种路由协议实现的,相比于静态路由,特点是减少了管理任务,会占用网络带宽。动态路由之间不需要手动写路由,路由之间能够自己互相学习。 *...
  • 动态路由——RIP协议

    2020-12-28 18:48:48
    动态路由协议概述3. 按照路由执行的算法分类二. RIP(距离矢量路由协议)1. 水平分割2. RIP v1和RIP v2的区别 一. 动态路由的概念 动态路由是指路由器能够自动地建立自己的路由表,并且能够根据实际情况的变化适时...
  • 动态路由RIP协议

    2019-09-18 07:20:34
    动态路由RIP协议概述 RIP协议最初是为Xerox网络系统的Xerox parc通用协议而设计的,是Internet中常用的路由协议。RIP采用距离向量算法,即路由器根据距离选择路由,所以也称为距离向量协议。路由器收集所有可到达...
  • 动态路由一、动态路由概述1.1 动态路由特点1.2 动态路由协议概述1.3 度量值1.4 收敛1.5 静态路由与动态路由的比较1.6 路由协议1.6.1 距离矢量路由协议1.6.2 链路状态路由协议二、RIP(距离-矢量路由选择协议)2.1 ...
  • 动态路由动态路由中的RIP协议一.动态路由1.动态路由的特点2.选择依据:度量值3.收敛4.静态路由与动态路由的比较二.动态路由协议分类三.RIP是距离矢量路由选择协议1.RIP的基本概念2.RIP的度量值与更新时间四.RIP...
  • 动态路由RIP协议

    2020-11-09 19:48:27
    动态路由RIP协议) 目录 一 概念 1.动态路由的特点 2.动态路由协议的概述 3.动态路由协议的分类 二 RIP路由协议 1.RIP基本的概念 2.路由表的形成 3.水平分割 4.RIP的两个版本 5.配置 一 动态路由的概念 动态路由是...
  • 动态路由协议动态路由rip动态路由协议通过路由信息的交换生成并维护转发引擎所需的路由表。...文章目录动态路由协议动态路由rip动态路由动态路由概述动态路由协议基础动态路由协议分类rip路由协议rip路由
  • 动态路由协议RIP

    2020-11-03 15:21:16
    RIP协议 RIP:距离-矢量路由选择协议; RIP的基本概念:定期更新,邻居,广播通信,全路由表更新; RIP的度量值:跳数,最大跳数位15跳,16跳之后不可达; 水平分割 水平分割的意义:防止路由环路的
  • 0x0 RIP协议如何工作? 在路由器上开启RIP协议,并将路由器的直连网段宣告进RIP后,RIP会将这些直连网段信息封装成RIP协议报文,发送给...注:在动态路由中我们添加的网段都是直连网段 0x2 配置RIP 宣告 rip 100 ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 1,590
精华内容 636
关键字:

动态路由rip协议